6.1. Lesson: Crearea unui Nou Set de Date Vectoriale

Datele pe care le utlizați trebuie să vină de undeva. Pentru aplicațiile uzuale, datele există deja; dar cu cât proiectul este mai aparte și mai specializat, cu atât scad șansele ca datele să fie disponibile. În asemenea cazuri va fi nevoie să va creați propriile date.

Scopul acestei lecții: De a crea un nou set de date vectoriale.

6.1.1. basic Follow Along: Dialogul de Creare a unui Strat

Înainte de a adăuga date vectoriale noi veți avea nevoie de un set de date la care să le adăugați. În cazul nostru veți începe prin a creea date complet noi, mai degrabă decât să editați un set de date existent. În concluzie, va trebui să începeți prin a crea propriul set de date.

You’ll need to open a Create Layer dialog that will allow you to define a new layer.

  • Navigate to and click on the menu entry Layer ‣ Create Layer ‣ New Shapefile Layer.

Vi se va prezenta urmatorul dialog:

../../../_images/create_vector_layer.png

Este important să decideți ce fel de set de date doriți. Fiecare tip de strat vectorial este „construit diferit” în fundal, deci odată ce ați creat un strat, nu îi puteți schimba tipul.

Pentru următorul exercițiu, vom crea noi entități care descriu zonele. Pentru astfel de entități, va trebui să creați un set de date poligonale.

  • Clic pe butonul radio Polygon:

../../../_images/polygon_selected.png

Aceasta nu are nici un impact asupra restului dialogului, dar va determina folosirea tipului corect de geometrie care să fie utilizat la crearea setului de date vectorial.

Câmpul următor vă permite să specificați Sistemul de Coordonate de Referință, sau CRS. Un CRS specifiă cum se descrie un punct de pe Pământ ca și cooronate, și pentru că există mai multe moduri de a face asta, există diferite CRS-uri. CRS-ul pentru acest proiect este WGS84, deci este deja corect de la început:

../../../_images/default_crs.png

În continuare exista o colecție de câmpuri grupate sub New attribute. În mod implicit, un strat nou are doar un atribut, câmpul id (pe care ar trebui să îl vedeți în Attributes list). Dar, pentru ca datele creeate să fie utile, veți avea nevoie să spuneți ceva despre caracteristicile pe care le veți crea în acest nou strat. Pentru scopul actual va fi suficient să adăugați un câmp numit name.

  • Reproduceți setarea de mai jos, apoi faceți clic pe butonul Add to attributes list:

../../../_images/new_attribute.png
  • Verificați dacă dialogul dvs. arată acum astfel:

../../../_images/new_attribute_added.png
  • Clic pe OK. Va apărea un dialog de salvare.

  • Navigați la directorul exercise_data.

  • Salvați noul strat ca și school_property.shp.

The new layer should appear in your Layers panel.

6.1.2. basic Follow Along: Sursele de Date

Când creați date noi, este evident necesar să se refere la obiecte care există întradevăr pe teren. De aceea, va fi nevoie să obțineți informația de undeva.

Există multe moduri de a obține date despre obiecte. De exemplu, ați putea folosi un GPS pentru a caputra puncte din lumea reală, după care să importați datele in QGIS. Sau ați putea să identificați punctele folosind un teodolit, după care să introduceți manual coordonatele pentru a crea noi entități.

Pentru exemplul nostru, veți folosi digitizarea. Eșantioanele seturilor de date raster vă sunt puse la dispoziție, așa că va trebui să le importați după nevoie.

  • Clic pe butonul Add Raster Layer: addRasterLayer

  • Navigați la directorul exercise_data/raster/.

  • Selectați fișierul 3420C_2010_327_RGB_LATLNG.tif.

  • Faceți clic pe Open. O imagine va fi încărcată în harta dvs.

  • Find the new image in the Layers panel.

  • Faceți clic și glisați-o în partea de jos a listei, astfel încât să puteți vedea în continuare celelalte straturi.

  • Găsiți și transfocați în această arie:

../../../_images/map_area_zoom.png

Notă

Dacă simbologia stratului buildings acoperă o parte sau toate straturile raster, puteți dezactiva temporar stratul prin deselectarea lui în Layers panel. Ați putea dori de asemenea să ascundeți simbologia roads dacă considerați că vă distrage.

Veți digitiza aceste trei câmpuri:

../../../_images/field_outlines.png

Pentru a începe digitizarea trebuie să intrați în modul editare. Aplicațiile GIS cer asta în mod curent pentru a preveni modificarea sau ștergerea accidentală a datelor importante. Modul editare este activat sau dezactivat independent pentru fiecare strat.

Pentru a intra în modul de editare, în cazul stratului school_property:

  • Faceți clic pe stratul din Lista straturilor pentru a-l selecta. (Asigurați-vă că este selectat stratul corect, în caz contrar veți edita un alt strat!)

  • Clic pe butonul Toggle Editing button: edit

Dacă nu puteți găsi acest buton, verificați dacă bara de instrumente Digitizing este activată. Ar trebui să existe un semn de selectare lângă elementul de meniu View ‣ Toolbars ‣ Digitizing.

De îndată ce vă aflați în modul de editare, veți vedea că instrumentele de digitizare sunt acum active:

capturePolygon moveFeature vertexToolActiveLayer

Alte patru butoane relevante sunt încă inactive, dar se vor activa atunci când vom începe interacțiunea cu noile noastre date:

saveEdits deleteSelected editCut editCopy editPaste

De la stânga la dreapta, în bara de instrumente, acestea sunt:

  • Salvare Editare: salvează modificările aduse stratului.

  • Adăugare Entități: începe digitizarea unei noi entități.

  • Deplasează Entitățil(e): deplasează o entitate.

  • Instrumentul Nod: deplasează doar o parte a unei entități.

  • Ștergere Selecție: șterge entitatea selectată.

  • Ștergere Entitate: șterge entitatea selectată.

  • Copie Entitățile: copie entitatea selectată.

  • Lipire Entități: lipește în hartă o entitate decupată sau copiată.

Doriți să adăugați o nouă entitate.

  • Clic pe butonul Adăugare Entitate, pentru a începe digitizarea câmpurilor școlii noastre.

Veți observa transformarea într-un reticul a cursorului mouse-ului. Acest lucru va permite plasarea cu o mai mare acuratețe a punctelor pe care le veți digitaliza. Nu uitați că deși folosiți instrumentul de digitalizare, transfocarea hărții se poate efectua cu ajutorul rotiței mouse-ului, iar deplasarea ei este posibilă prin ținerea apăsată a rotiței și mișcarea mouse-ului.

Prima entitate pe care o veți digitaliza este athletics field:

../../../_images/school_area_one.png
  • Începeți digitizarea făcând clic pe un punct, de-a lungul marginii câmpului.

  • Plasați mai multe puncte, făcând clic în continuare de-a lungul marginii, până când forma desenată acoperă complet câmpul.

  • După introducerea ultimului punct, faceți clic-dreapta, pentru a încheia desenarea poligonului. Acest lucru va finaliza entitatea și vă va prezenta dialogul Atributelor.

  • Completați valorile, așa cum se arată mai jos:

../../../_images/school_area_one_attributes.png
  • Faceți clic pe OK, creând astfel o nouă entitate!

Amintiți-vă că dacă ați făcut o greșeală în timp ce digitizați o entitate, o puteți edita oricând după ce ați definitivat crearea ei. Dacă ați făcut o greșeală, continuați digitizarea până ați terminat crearea entității de mai sus. Apoi:

  • Selectați entitatea cu ajutorul instrumentului Select Single Feature:

../../../_images/single_feature_select.png

Puteți utiliza:

  • instrumentul Move Feature(s) pentru a deplasa întreaga entitate,

  • Instrumentul Nod pentru a deplasa doar un punct, în cazul în care ați efectuat un clic eronat,

  • Ștergere Selecție pentru a scăpa de entitate în întregime, astfel încât să puteți încerca din nou, și

  • the Edit ‣ Undo menu item or the Ctrl+Z keyboard shortcut to undo mistakes.

6.1.3. basic Try Yourself

  • Digitizarea școlii propriu-zise și a câmpului de sus. Utilizați această imagine pentru a vă ajuta:

../../../_images/field_outlines.png

Amintiți-vă că fiecare entitate nouă trebuie să aibă o valoare id unică!

Notă

După ce ați terminat de adăugat entitățile într-un strat, nu uitați să salvați modificările și să ieșiți din modul de editare.

Notă

Puteți personaliza umplerea, conturul, poziționarea și formatarea etichetelor pentru school_property folosind tehnicile învățate în lecțiile anterioare. În exemplul nostru vom folosi un contur de linie întreruptă violet deschis fără umplere.

6.1.5. In Conclusion

Acum știți cum să creați entități! Acest curs nu acoperă adăugarea entităților de tip punct, deoarece nu este neapărat necesară după ce ați lucrat cu entități mai complexe (lini și poligoane). Funționează exact la fel, cu excepția faptului că dați clic doar o singură dată unde doriți să plasați punctul, îi completați atributele ca de obicei, după care entitatea este creată.

Cunoașterea digitizării este importantă deoarece reprezintă o activitate frecventă în aplicațiile GIS.

6.1.6. What’s Next?

Caracteristicile dintr-un strat GIS nu sunt doar imagini, ci obiecte în spațiu. De exemplu, poligoanele adiacente știu unde se află unul față de celălalt. Aceasta se numește topologie. În lecția următoare veți vedea un exemplu de utilizare.