14.2. Lesson: Kartan georeferointi

Yleinen metsänhoidon tehtävä on päivittää metsäalueen tietoja. On mahdollista että edelliset tiedot alueesta ovat jo vuosien takaa ja ne oli kerätty analogisesti (siis paperille) tai ehkäpä ne oli digitoitu mutta jäljellä on ainoastaan paperinen versio tuosta inventointidatasta.

Todennäköisesti haluat käyttää myös tätä tietoa paikkatietojärjestelmässäsi, esimerkiksi vertailuun tuoreempien inventointien kanssa. Tämä tarkoittaa että Sinun on digitoitava käsillä oleva informaatio piakkatieto-ohjelmaasi, Mutta ennekuin aloitamme digitoinnin, on tehtävä tärkeä ensimmäinen askel, skannattava ja georeferoitava paperikarttasi.

Tämän oppitunnin tavoite: Oppia käyttämään Georeferointityökalua QGIS ohjelmassa.

14.2.1. basic Skannaa kartta

Ensimmäinen toimenpide joka Sinun tulee suorittaa on skannata kartta. Jos kartta on liian suuri, voit skannata sen useampaan osaan mutta pidä mielessäsi että Sinun on toistettava alkutoimenpiteet ja georeferointi jokaiselle osalle erikseen. Joten jos mahdollista, skannaa karttaan niin vähiin osiin kuin mahdollista.

Jos aiot käyttää muuta kartaan kuin tämän oppaan ohessa saamaasi, käytä omaa skanneriasi skannataksesi kartan kuvatiedostoksi, resoluutiota 300 DPI on hyvä. Jos kartassasi on värejä, skannaa kuva värillisenä niin että voit myöhemmin käyttää noita värejä tietojen erottelemiseksi kartasta eri tasoille (esim. metsäkuviot, korkeuskäyrät, tiet …).

Tässä esimerkissä käytät aiemmin skannattua karttaa, löydät sen nimellä rautjarvi_map.tif datahakemistosta

14.2.2. basic Follow Along: Skannatun kartan georeferointi

Open QGIS and set the project’s CRS to ETRS89 / ETRS-TM35FIN in Project ‣ Properties ‣ CRS, which is the currently used CRS in Finland.

../../../_images/f_1.png

Tallenna QGIS projekti nimellä map_digitizing.qgs.

Tulet käyttämään georeferointi liitännäistä QGIS:ssä, liitännäinen on jo ladattu QGISiin. Aktivoi liitännäinen liitännäisten hallinnassa samoin kuin olet tehnyt aiemmissa moduleissa. Liitännäinen on nimeltään Georeferointi GDAL.

Kartan georeferointi:

  • Avaa georeferointityökalu, Rasteri ‣ Georeferoija ‣ Georeferoija.

  • Add the map image file, rautjarvi_map.tif, as the image to georeference, File ‣ Open raster.

  • Kun kysytään etsi ja valitse KKJ / Finland zone 2 CRS. Tämä koordinaattijärjestelmä (CRS) oli käytössä Suomessa aiemmin vuonna 1994 kun tämä kartta luotiin.

  • Klikkaa OK.

Seuraavaksi Sinun tulee määritellä muunnosasetukset kartan georeferoinnille:

  • Avaa Asetukset ‣ Muunnos asetukset.

  • Klikkaa ikonin Tulosrasteri laatikkoa, mene hakemistoon tai luo hakemisto exercise_data\forestry\digitizing ja nimeä tiedostoksi rautjarvi_georef.tif.

  • Aseta loput parametrit kuten on näytetty alla.

../../../_images/Clipboard10.png
  • Klikkaa OK.

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeference this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer’s window.

  • Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  • Valitse Lisää piste työkalu ja klikkaa hiusristikon leikkauspisteessä (liikuta ja zoomaa tarvittaessa).

  • Syötä karttakoordinaatit valintaikkunassa kirjoita koordinaatit kuten ne ovat kartalla

  • Klikkaa OK.

Ensimmäinen koordinaatti georeferointia varten on nyt valmis.

Etsi muita mustia hiusviivaristikoita kuvassa, ne ovat erillään 1000 metrin päässä toisistaan sekä pohjois- että itäsuunnissa. Sinun tulisi kyetä laskemaan noiden pisteiden koordinaatit suhteessa ensimmäiseen.

Zoom out in the image and move to the right until you find other cross-hair, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible. Digitize at least three more ground control points in the same way you did the first one. You should end up with something similar to this:

../../../_images/Clipboard09.png

Jo kolmen digitoidun maaston tarkistuspisteen jälkeen voit nähdä georeferointivirheiden tulevan punaisina viivoina pisteistä. Virheet pisteissä voidaan nähdä myös GCP taulussa dX[pikseleihin] ja dY[pikseleihin] sarakkeissa. Virhe pikseleissä ei tulisi olla suurempi kuin 10 pikseliä, jos on tulisi Sinun tarkistaa pisteet jotka olet digitoinut ja koordinaatit jotka olet anatanut löytääksesi mikä on ongelma. Voit käyttää alla olevaa kuvaa apuna.

Once you are happy with your control points, you can save them for later use:

  • Tiedosto ‣ Tallenna GCP pisteet nimellä….

  • In the folder exercise_data\forestry\digitizing, name the file rautjarvi_map.tif.points.

Lopuksi georeferoi karttasi:

  • Tiedosto ‣ Aloita georeferointi.

  • Huomaa että nimesit tiedoston jo rautjarvi_georef.tif nimellä kun muokkasit Georeferoinin asetuksia.

Nyt voit nähdä kartan QGIS projektissa georeferoituna rasterina. Huomaa että rasteri näyttää hieman kiertyneeltä mutta tämä johtuu ainoastaan siitä että tieto on KKJ / Finland zone 2 koordinaatistossa ja projektisi on

To check that your data is properly georeferenced you can open the aerial image in the exercise_data\forestry folder, named rautjarvi_aerial.tif. Your map and this image should match quite well. Set the map transparency to 50% and compare it to the aerial image.

../../../_images/Clipboard14.png

Tallenna muutokset QGIS projektiin koska jatkat tästä pisteestä seuraavalla oppitunnilla.

14.2.3. In Conclusion

You have now georeferenced a paper map, making it possible to use it as a map layer in QGIS.

14.2.4. What’s Next?

In the next lesson, you will digitize the forest stands in your map as polygons and add the inventory data to them.