Outdated version of the documentation. Find the latest one here.

.

Настройка QGIS

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Примечание

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the :menuselection`view` menu (Panels and Toolbars) or in Project for Options.

Панели инструментов

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Меню «Панели инструментов» nix

Совет

Обзорная карта

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Совет

Отладочные сообщения

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Свойства проекта

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • Вкладка Система координат позволяет выбрать систему координат для данного проекта и включить преобразование координат векторных и растровых слоёв «на лету», если используются слои с разными системами координат.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Параметры section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • The Macros menu is used to edit Python macros for projects. Currently, only three macros are available: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Настройка макросов в QGIS

  • The Relations menu is used to define 1:n relations. The relations are defined in the project properties dialog. Once relations exist for a layer, a new user interface element in the form view (e.g. when identifying a feature and opening its form) will list the related entities. This provides a powerful way to express e.g. the inspection history on a length of pipeline or road segment. You can find out more about 1:n relations support in Section Creating one to many relations.

Параметры

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Владка «Общие»

Приложение

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Задать Тема значков selectstring. Доступна только тема «default».

  • Настроить Размер значков selectstring.

  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Изменить Время показа диалогов и сообщений состояния selectstring.

  • checkbox Не показывать заставку при запуске

  • checkbox Показывать совет дня при запуске

  • checkbox Выделять заголовки групп виджетов

  • checkbox Оформлять группы виджетов в стиле QGIS

  • checkbox Use live-updating color chooser dialog

Файлы проектов

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Create new project from default project. You have the possibility to press on Set current project as default or on Reset default. You can browse through your files and define a directory where you find your user-defined project templates. This will be added to Project ‣ New From Template. If you first activate checkbox Create new project from default project and then save a project in the project templates folder.
  • checkbox Запрашивать сохранение изменений в проекте и источниках данных, когда это необходимо

  • checkbox Warn when opening a project file saved with an older version of QGIS
  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Вкладка «Система»

Переменные среды

System environment variables can now be viewed, and many configured, in the Environment group (see figure_environment_variables). This is useful for platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. It’s also useful for setting and viewing environment variables for the external tool sets controlled by the Processing toolbox (e.g., SAGA, GRASS), and for turning on debugging output for specific sections of the source code.

  • checkbox Use custom variables (restart required - include separators). You can [Add] and [Remove] variables. Already-defined environment variables are displayed in Current environment variables, and it’s possible to filter them by activating checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

Просмотр переменных окружения в QGIS

Модули

[Add] or [Remove] Path(s) to search for additional C++ plugin libraries

Вкладка «Источники данных»

Таблица атрибутов

  • checkbox Открывать таблицу аттрибутов во встраиваемом окне (требуется перезапуск)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representation for NULL values. Here, you can define a value for data fields containing a NULL value.

Источники данных

  • Искать источники данных в панели обозревателя selectstring. Предлагается два метода: «По расширению» и «По содержимому».

  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Prompt for raster sublayers when opening. Some rasters support sublayers — they are called subdatasets in GDAL. An example is netCDF files — if there are many netCDF variables, GDAL sees every variable as a subdataset. The option allows you to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘Always’: Always ask (if there are existing sublayers)
    • ‘If needed’: Ask if layer has no bands, but has sublayers
    • ‘Never’: Never prompt, will not load anything
    • ‘Load all’: Never prompt, but load all sublayers
  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layer with double click and select in extended mode
  • checkbox Добавлять слои Oracle двойным щелчком и включить расширенную выборку

Вкладка «Отрисовка»

Rendering behaviour

  • checkbox By default new layers added to the map should be displayed
  • checkbox Use render caching where possible to speed up redraws
  • checkbox Render layers in parallel using many CPU cores
  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplication by default for newly added layers
  • Simplification threshold
  • checkbox Simplify on provider side if possible
  • Maximum scale at which the layer should be simplified

Параметры отрисовки

  • checkbox Рисовать сглаженные линии (снижает скорость отрисовки)

Растры

  • With RGB band selection, you can define the number for the Red, Green and Blue band.

Contrast enhancement

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Границы среза с накоплением

  • Множитель стандартного отклонения

Отладка

  • checkbox Map canvas refresh

Colors Menu

This menu allows you to add some custom color that you can find in each color dialog window of the renderes. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operation. Finally you can export the color set as a gpl file or import them.

Вкладка «Карта и легенда»

Внешний вид по умолчанию

  • Установить Цвет выделения selectcolor и Цвет фона selectcolor.

Легенда

  • По двойному щелчку на слое в легенде selectstring можно открывать свойства слоя или открывать таблицу атрибутов.

  • The following Legend item styles are possible:
    • checkbox Выводить имена слоёв с прописной буквы

    • checkbox Выделять слои полужирным шрифтом

    • checkbox Выделять группы полужирным шрифтом

    • checkbox Показывать в легенде атрибуты классификации

    • checkbox Создавать значки для растровых слоёв

    • checkbox Add new layers to selected or current group

Вкладка «Инструменты»

This menu offers some options regarding the behaviour of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance factor expressed as a percentage of the map width. This means the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified are to be highlighted.
  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Инструмент измерений

  • Установить Цвет линии для инструментов измерений

  • Установить число Десятичных знаков

  • checkbox Сохранять базовые единицы

  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Прокрутка и масштабирование

  • Задать Действие при прокрутке колеса мыши selectstring («Увеличить», «Увеличить и центрировать», «Увеличить в положении курсора», «Ничего»)

  • Установить Фактор увеличения для колеса мыши

Масштабный ряд

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Composer Menu

Composition defaults

You can define the Default font here.

Grid appearance

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Color...

Grid defaults

  • Define the Spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Guide defaults

  • Define the Snap tolerance selectnumber

Вкладка «Оцифровка»

Создание объектов

  • checkbox Отключить всплывающее окно ввода атрибутов для каждого создаваемого объекта

  • checkbox Использовать последние введённые значения

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Резиновая нить

  • Установить Толщину линии selectnumber и Цвет линии selectcolor для «резиновой нити»

Прилипание

  • checkbox Открывать параметры прилипания во встраиваемом окне (требуется перезапуск)

  • Установить Режим прилипания по умолчанию selectstring («К вершинам», «К сегментам», «К вершинам и сегментам», «Выключена»)

  • Установить Порог прилипания по умолчанию в единицах карты или пикселях

  • Установить Радиус поиска для редактирования вершин selectnumber (в единицах карты или пикселях)

Маркеры вершин

  • checkbox Показывать маркеры только для выбранных объектов

  • Установить Стиль маркера selectstring («Перекрестие» (по умолчанию), «Полупрозрачный круг» или «Без маркера»)

  • Задать Размер маркера selectnumber.

Параллельные кривые

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Дополнительные функции оцифровки. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Join style
  • Quadrant segments
  • Miter limit

Вкладка «GDAL»

GDAL is a data exchange library for raster files. In this tab, you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver is to be used for a raster format, as in some cases more than one GDAL driver is available.

Вкладка «Система координат»

Система координат для новых проектов

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Создавать новые проекты в указанной системе координат

Система координат для новых слоёв

This area allows you to define the action to take when a new layer is created, or when a layer without a CRS is loaded.

  • radiobuttonon Запрашивать систему координат

  • radiobuttonoff Использовать систему координат проекта

  • radiobuttonoff Use default CRS displayed below

Default datum transformations

  • checkbox Ask for datum transformation when no default is defined
  • If you have worked with the ‘on-the-fly’ CRS transformation you can see the result of the transformation in the window below. You can find information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’.

Locale Menu

  • checkbox Переопределить системный язык и Язык, используемый вместо системного

  • Дополнительная информация о системном языке

Network Menu

Общие

  • Задать Адрес поиска WMS-серверов,по умолчанию используется http://geopole.org/wms/search?search=\%1\&type=rss

  • Установить Таймаут для сетевых запросов (мс). Значение по умолчанию — 60000

  • Настроить Время актуальности данных WMS-C/WMTS по умолчанию (часы). Значение по умолчанию —- 24 часа.

  • Define Max retry in case of tile request errors
  • Define User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Настройка прокси-сервера в QGIS

Параметры кэширования

Задать Каталог и Размер кэша.

  • checkbox Использовать прокси-сервер для внешних соединений и настроить поля «Узел», «Порт», «Пользователь», и «Пароль».

  • Установить Тип прокси selectstring в соответствии с конфигурацией сети.

    • Default Proxy: прокси определяется настройками приложения

    • Socks5Proxy: Общий прокси для любого вида связи. Поддерживаются TCP, UDP, привязка к порту (входящие соединения) и авторизация

    • HttpProxy: реализован с использованием команды «СONNECT», поддерживает только исходящие TCP соединения; поддерживает авторизацию

    • HttpCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP requests.
    • FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests.

Excluding some URLs can be added to the text box below the proxy settings (see Figure_Network_Tab).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Совет

Использование прокси-серверов

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check to see if they succeed in your case.

Можно настроить параметры в соответствии со своими потребностями. Внесение некоторых изменений может потребовать перезапуска QGIS для их применения.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx You can find your settings in: $HOME/Library/Preferences/org.qgis.qgis.plist
  • win Settings are stored in the registry under: HKEY\CURRENT_USER\Software\QGIS\qgis

Настройка интерфейса

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

Диалог «Настройка интерфейса» nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panel, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Панели инструментов). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.