Outdated version of the documentation. Find the latest one here.

9.4. Lesson: Exercițiu Suplimentar

În această lecție, veți efectua o analiză GIS completă în QGIS.

Note

Lecția a fost dezvoltată de Linfiniti și S Motala (Cape Peninsula University of Technology)

9.4.1. Definirea Problemei

Vi se cere să găsiți zone în interiorul și în jurul Peninsulei Cape, care este un habitat potrivit pentru o specie de plante rare, Fynbos. Extinderea ariei dumneavoastră de investigare din Peninsula Cape este: la sud de Melkbosstrand, la vest de Strand. Botaniștii vă informează despre următoarele cerințe pentru specia în cauză:

  • Crește pe pante orientate spre est.

  • Crește pe pante cu o înclinație între 15% și 60%.

  • Crește în zone cu precipitații anuale totale de >1200 mm.

  • Se găsește numai la cel puțin 250 de m distanță față de orice așezare umană.

  • Zona de vegetație în care apare ar trebui să aibă o suprafață de cel puțin 6000m2.

Ca voluntar pentru Cape Nature, ați fost de acord să căutați planta pe cea mai apropiată suprafață de teren față de casa dvs. Folosiți-vă abilitățile GIS pentru a determina unde ar trebui să efectuați căutarea.

9.4.2. Conturarea unei Soluții

Pentru a rezolva această problemă, va trebui să utilizați datele disponibile (în exercise_data/more_analysis) pentru a găsi zona candidat, cea mai apropiată de casa dvs. Dacă nu locuiți în Cape Town (cazul pe care se bazează această problemă), puteți alege orice casă din regiunea Cape Town. Soluția va implica:

  • analiza DEM-ului, pentru a găsi pantele orientate spre est și având înclinațiile specificate;

  • analiza rasterului de precipitații, pentru a găsi zonele cu cantitatea corectă de precipitații;

  • analiza stratul vectorial de Zonare, pentru a găsi zonele care sunt situate la distanța specificată față de așezările umane și au dimensiunea corectă.

9.4.3. Setarea Hărții

  • Clic pe butonul “CRS status” din colțul din extrema dreaptă-jos a ecranului. Sub fila CRS a ecranului care apare, veți vedea caseta de Coordinate reference systems of the world.

  • În această casetă, navigați la Projected Coordinate Systems ‣ Universal Transverse Mercator (UTM).

  • Selectați WGS 84 / UTM zone 33S (având codul EPSG 32733).

  • Clic pe OK. Harta este acum în sistemul de coordonate de referință UTM33S.

  • Salvați harta făcând clic pe butonul Save Project As din bara de instrumente, sau utilizând elementul de meniu File ‣ Save Project As....

  • Salvați harta în directorul numit Rasterprac, pe care îl puteți crea oriunde, pe calculatorul dvs. Veți salva în acest director orice alte straturi create ulterior.

9.4.4. Încărcarea Datelor în Hartă

Pentru a procesa datele, va trebui să încărcați straturile necesare (numele străzilor, zonele, precipitațiile, DEM-ul) în canevasul hărții.

9.4.4.1. Pentru vectori ...

  • Faceți clic pe butonul Add Vector Layer, sau folosiți elementul de meniu Layer ‣ Add Vector Layer....

  • În caseta de dialog care apare, asigurați-vă că butonul radio File este selectat.

  • Clic pe butonul Browse.

  • În caseta de dialog care apare, deschideți directorul exercise_data/more_analysis/streets.

  • Selectați fișierul Street_Names_UTM33S.shp.

  • Clic pe Deschidere.

Dialogul se închide și arată dialogul inițial, cu calea de fișier specificată în câmpul de text de lângă butonul Browse. Acest lucru vă permite să vă asigurați că este selectat fișierul corect. Este, de asemenea, posibilă introducerea manuală a căii fișierului în acest câmp, dacă doriți acest lucru.

  • Clic Open. Stratul vectorial se va încărca din harta dvs. Culoarea sa este atribuită în mod automat. Aceasta va fi schimbată ulterior.

  • Redenumiți stratul în Streets.

  • Faceți clic dreapta în Lista straturilor (în mod implicit, panoul din partea stângă a ecranului).

  • Faceți clic pe Rename în caseta de dialog care apare și redenumiți stratul, apăsând tasta Enter în momentul când suntți gata.

  • Repetați procesul de adăugare a straturilor vectoriale, dar de data aceasta selectați fișierul Generalised_Zoning_Dissolve_UTM33S.shp din directorul Zoning.

  • Redenumiți-l Zoning.

9.4.4.2. Pentru rastere ...

  • Faceți clic pe butonul Add Raster Layer, sau folosiți elementul de meniu Layer ‣ Add Raster Layer....

  • Navigați la fișierul corespunzător, selectați-l și faceți clic pe Open.

  • Faceți acest lucru pentru fiecare dintre cele două fișiere raster. Fișierele dorite sunt: DEM/reproject/DEM and Rainfall/reprojected/rainfall.tif.

  • Redenumiți rasterul de precipitații în Rainfall (prima literă fiind majusculă). Inițial, atunci când le încărcați, imaginile vor fi afișate ca dreptunghiuri gri. Nu vă faceți griji, acest lucru se va schimba ulterior.

  • Salvați harta.

Pentru a vedea în mod corespunzător ce se întâmplă, simbolistica pentru straturi trebuie să fie schimbată.

9.4.5. Schimbarea simbologiei straturilor vectoriale

  • În Lista straturilor faceți clic-dreapta pe stratul Streets.

  • Selectați Properties din meniul care apare.

  • Mergeți la fila Style , în dialogul care va apărea.

  • Clic pe butonul Modificare, care are un pătrat prezentat în culoarea actuală a stratului Streets.

  • Selectați o culoare nouă din dialogul care va apărea.

  • Clic pe OK

  • Clic pe butonul Change, care are un pătrat prezentat în culoarea actuală a stratului Streets.

  • Urmați un proces similar pentru stratul Zoning, apoi alegeți o culoare potrivită pentru el.

9.4.6. Schimbarea simbologiei straturilor raster

Simbologia straturilor raster este oarecum diferită.

  • Deschideți dialogul Properties pentru rasterul Rainfall.

  • Mergeți în stratul Style. Veți observa că stilul acestui dialog este foarte diferit de versiunea folosită pentru straturile vectoriale.

  • Asigurați-vă că butonul Use standard deviation

  • Modificați valoarea din caseta asociată la 2.00 (ar trebui să fie setată la 0.00 în mod implicit).

  • În secțiunea Contrast enhancement, schimbați valoarea listei derulante Current la Stretch to MinMax.

  • Clic OK. Rasterul “Precipitațiilor”, în cazul în care este vizibil, trebuie să-și schimbe culorile, permițându-vă să vedeți valori diferite de luminozitate pentru fiecare pixel.

  • Repetați acest proces pentru DEM, dar stabiliți abaterile standard utilizate pentru întindere la 4.00.

9.4.7. Modificarea ordinii straturilor

  • În Lista straturilor, faceți clic și deplasați straturile în sus și în jos, pentru a modifica ordinea în care vor apărea în hartă.

  • Versiunile mai noi de QGIS pot avea o casetă Control rendering order dedesubtul Listei straturilor. Asigurați-vă că este bifată.

Acum, că toate datele sunt încărcate și vizibile în mod corespunzător, analiza poate începe. Cel mai bine este dacă are loc, mai întâi, operațiunea de decupare. Astfel, puterea de procesare nu va fi irosită pe calcularea valorilor pentru zonele care nu vor fi deloc utilizate.

9.4.8. Găsires Districtelor Corecte

  • Încărcați stratul vectorial admin_boundaries/Western_Cape_UTM33S.shp în harta dvs.

  • Redenumiți-l Districts.

  • Faceți clic-dreapta pe stratul Districts din Layers list.

  • În meniul care apare, selectați elementul de meniu Query.... Va apărea dialogul Query Builder.

Veți construi acum o interogare pentru a selecta doar următoarea listă de districte:

  • Bellville,
  • Cape,
  • Goodwood,
  • Kuils River,
  • Mitchells Plain,
  • Simons Town, și

  • Wynberg.
  • În lista Fields, faceți dublu-clic pe câmpul NAME_2. Acesta va apărea în câmpul de text SQL where clause de mai jos.

  • Făcând clic pe butonul = button; un semn = va fi atașat interogării SQL.

  • Clic pe butonul All de sub lista (acum vidă) a. După o scurtă întârziere, lista Valorilor se va popula cu valoarea câmpului selectat (NAME_2).

  • Faceți dublu-clic pe valoarea Bellville din lista Valorilor. Ca și mai înainte, aceasta se va adăuga în interogarea SQL.

Pentru a selecta mai mult de un district, va trebui să utilizați operatorul boolean OR.

  • Faceți clic pe butonul OR pentru a adăuga textul în interogarea SQL.

  • Folosind un proces similar cu cel de mai sus, adăugați următoarele la interogarea SQL existentă:

    "NAME_2" = 'Cape'
    
  • Adăugați un alt operator OR, apoi procedați într-un mod similar cu lista de districte de mai sus .

  • Interogarea finală ar trebui să fie

    "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
    "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
    'Simons Town' OR "NAME_2" = 'Wynberg'
  • Clic OK. Districtele prezentate în harta dvs. sunt acum limitate la cele din lista de mai sus.

9.4.9. Decuparea Rasterelor

Acum, că aveți o zonă de interes, puteți decupa rasterele după ea.

  • Asigurați-vă că sunt vizibile numai straturile DEM, Rainfall și Districts.

  • Districtele trebuie să fie în partea de sus, astfel încât acestea sunt vizibile.

  • Deschideți caseta dialogului de decupare prin selectarea elementului de meniu Raster ‣ Extraction ‣ Clipper.

  • În caseta cu lista derulantă Input file (raster), selectați stratul DEM.

  • Specificați o locație de ieșire în câmpul de text Output file, făcând clic pe butonul Select....

  • Navigați în directorul Rasterprac.

  • Introduceți un nume de fișier.

  • Salvați fișierul. Lăsați caseta No data value nebifată.

  • Folosiți modul de decupare Extent, prin selectarea butonului radio corect.

  • Faceți clic și deplasați o zonă pe canevas, astfel încât aria care include districtele să fie selectată.

  • Bifaţi caseta Load into canvas when finished.

  • Clic pe OK

  • După finalizarea operațiunii de tăiere, NU ÎNCHIDEȚI dialogul Clipper. (Acest lucru ar putea provoca pierderea zonelor de decupare pe care le-ați definit deja.)

  • Selectați rasterul Rainfall din lista derulantă Input file (raster), apoi alegeți un nume de fișier de ieșire diferit.

  • Nu modificați alte opțiuni. Nu modificați zona de decxupare existentă, pe care ați definit-o anterior. Lăsați totul la fel și faceți clic pe OK.

  • După finalizares celei de-a doua operațiuni de tăiere, puteți închide dialogul Clipper.

  • Salvați harta.

9.4.10. Curățarea hărții

  • Eliminați straturile originale Rainfall și DEM din Lista straturillor:

  • Clic-dreapta pe aceste straturi apoi selectați Remove.

    • Acest lucru nu va elimina datele de pe dispozitivul de stocare, doar le va scoate din harta dvs.

  • Dezactivați etichetele din stratul Streets:

    • Clic pe butonul Etichetare.

    • Debifați caseta Label this layer with.

    • Clic pe OK

  • Afișați iarăși toate Streets:

    • Clic-dreapta pe stratul din Lista straturilor.

    • Selectați Query.

  • În fereastra de dialog care apare, Query, faceți clic pe butonul Clear, apoi pe OK.

  • Așteptați în timp ce datele sunt încărcate. Toate străzile vor fi de acum vizibile.

  • Schimbați simbologia straturilor raster ca mai înainte (parcurgeți Schimbarea simbolisticii straturilor raster).

  • Salvați harta.

  • Puteți ascunde acum straturile vectoriale debifând caseta de lângă ele, în Lista straturilor. Acest lucru va face randarea hărții mai rapidă și, astfel, veți salva ceva timp.

Pentru a crea relieful, va trebui să utilizați un plugin care a fost scris special în acest scop.

9.4.11. Activarea plugin-ul de Analiză a Terenurilor Raster

Acest plugin este inclus în mod implicit în QGIS 1.8. Cu toate acestea, el nu poate fi imediat vizibil. Pentru a verifica dacă acesta este accesibil pe sistemul dumneavoastră:

  • Faceți clic pe elementul de meniu Plugins –> Manage Plugins....

  • Asigurați-vă că este selectată caseta de lângă Raster Terrain Analysis plugin.

  • Clic pe OK

Veți avea acum acces la acest plugin prin intermediul elementului de meniu Raster ‣ Terrain analysis.

Rețineți că plugin-uri pot depinde, uneori, de anumite module Python, instalate pe sistemul dumneavoastră. În cazul în care un plugin refuză să lucreze, specificând lipsa dependențelor, vă rugăm să cereți asistență lectorului dvs.

9.4.12. Crearea reliefului

  • În Lista straturilor, asigurați-vă că DEM este stratul activ (adică, acesta este evidențiat, după ce ați făcut clic pe el).

  • Clic pe elementul de meniu Raster ‣ Terrain analysis ‣ Hillshade pentr a deschide dialogul Hillshade.

  • Specificați o locație adecvată pentru stratul de ieșire și denumiți-o hillshade.

  • Bifați caseta Add result to project.

  • Clic pe OK

  • Așteptați să se termine prelucrarea.

Noul strat hillshade a apărut în Lista straturilor dvs.

  • Făcând clic dreapta pe stratul hillshade din Lista straturilor dvs., se va desxchide dialogul Properties.

  • Clic pe fila Transparency, apoi setați transparența la 80%.

  • Clic pe OK, în fereastra de dialog.

  • Observați efectul, atunci când relieful transparent este suprapus peste DEM-urile decupate.

9.4.13. Panta

  • Faceți clic pe elementul de meniu Raster ‣ Terrain analysis.

  • Selectați tipul de analiză Slope, având ca intrare DEM-ul decupat.

  • Specificați un nume corespunzător și o locație pentru fișierul de ieșire.

  • Bifați caseta Add result to project.

  • Clic pe OK

Imaginea pantei a fost calculată și adăugată la hartă. Cu toate acestea, ca de obicei, se vede doar un dreptunghi gri. Pentru a observa corect ce se întâmplă, schimbați simbolistica, după cum urmează.

  • Deschideți dialogul Properties (ca de obicei, prin intermediul meniului clic-dreapta al stratului).

  • Clic pe fila Stilului.

  • Acolo unde scrie Grayscale (în caseta cu derulare verticală Harta culorilor), alegeți Pseudocolor.

  • Asigurați-vă că butonul radio Use standard deviation este selectat.

9.4.14. Aspectul

  • Utilizați aceeași abordare ca și pentru calculul pantei, dar selectați Aspectul, în fereastra de dialog inițială.

Amintiți-vă să salvați periodic modificările.

9.4.15. Reclasificarea rasterelor

  • Faceți clic pe elementul de meniu Raster ‣ Raster calculator.

  • Specificați directorul dvs. Rasterprac,

  • Asigurați-vă că este selectată caseta Add result to project.

În lista din stânga, a Benzilor raster, veți vedea toate straturile raster din Lista straturilor. În cazul în care stratul pantei este denumit slope, acesta va fi listat ca slope@1.

Panta trebuie să aibă între 15 și 60 grade. Orice pantă mai mică de 15 sau mai mare de 60 va fi astfel exclusă.

  • Folosind elementele din listă și butoanele din interfață, construiți următoarea expresie:

    (([email protected] < 15) OR ([email protected] > 60)) = 0
  • Alegeți o locație pentru câmpul Output layer și numele de fișier corespunzător.

  • Clic pe OK

Acum găsi aspectul corect (orientat spre est: între 45 și 135 grade) folosind aceeași abordare.

După ce ați reclasificat toate rasterele, le veți vedea afișate sub formă de dreptunghiuri gri pe hartă (presupunând că acestea au fost adăugate corect pe hartă). Pentru a afișa corect datele raster cu numai două clase (1 și 0, ceea ce înseamnă adevărat sau fals), va trebui să le schimbați simbologia.

9.4.16. Setarea stilului pentru straturile reclasificate

  • Deschideți fila Style în fereastra de dialog a Proprietăților stratului, ca de obicei.

  • Sub titlul Încărcare valori min / max din bandă, selectați butonul radio Actual (lent).

  • Clic pe butonul Load.

Câmpurile Valori min / max personalizate ar trebui să fie populate acum cu 0 și, respectiv, 1. (Dacă acest lucru nu s-a întâmplat, atunci a existat o greșeală cu reclasificarea datelor, și va trebui să repetați aceași acțiune.)

  • Sub antetul Îmbunătățire contrast, alegeți din lista Curent Întindere la MinMax.

  • Clic pe OK

  • Faceți acest lucru pentru toate cele trei rastere reclasificate, și amintiți-vă să vă salvați munca!

Singurul criteriu care rămâne este cel referitor la faptul că zona trebuie să fie la 250m față de zonele urbane. Vom îndeplini această cerință prin asigurarea faptului că suprafețele pe care le calculăm se află la :​kbd:250m sau la mai mult față de marginea unei zone rurale. Prin urmare, trebuie să găsim, mai întâi, toate zonele rurale.

9.4.17. Găsirea zonele rurale

  • Ascunderea tuturor straturilor din Lista straturilor.

  • Afișarea straturilor vectoriale Zoning.

  • Clic-dreapta pentru a se deschide dialogul Query.

  • Construiți următoarea interogare:

    "Gen_Zoning" = 'Rural'
    

    Consultați instrucțiunile anterioare pentru construirea interogării Streets, dacă v-ați blocat.

  • Când ați terminat, închideți dialogul :guilabel:`Query.

Ar trebui să vedeți o colecție de poligoane din partea stratului Zonare. Va trebui să le salvați în fișierul unui nou strat.

  • În meniul descis printr-un clic-dreapta pe stratul Zoning, selectați Save as....

  • Salvați stratul în directorul Zoning.

  • Denumiți fișierul rezultat rural.shp.

  • Clic pe OK

  • Adăugați straturile în harta dvs.

  • Faceți clic pe elementul de meniu Vector > Geoprocessing Tools > Dissolve.

  • Selectați stratul vectorial rural ca intrare, lăsând nebifată opțiunea Se utilizează doar entitățile selectate.

  • Sub Câmpul de dizolvare, selectați — Dizolvă tot —.

  • Salvați stratul în directorul Zoning.

  • Faceți clic pe OK. Va apărea un dialog care vă întreabă dacă doriți să adăugați noul strat la TOC (“Cuprins”, făcând referire la Lista straturilor).

  • Clic Yes.

  • Închideți dialogul Dissolve.

  • Eliminați straturile rural și Zoning.

  • Salvați harta.

Acum trebuie să excludem zonele care se află la 250m de marginea zonelor rurale. Faceți acest lucru prin crearea unui tampon negativ, așa cum se explică mai jos.

9.4.18. Crearea unui tampon negativ

  • Faceți clic pe elementul de meniu Vector ‣ Geoprocessing Tools ‣ Buffer(s).

  • În caseta de dialog care apare, selectați stratul vectorial rural_dissolve ca intrare (nu trebuie bifată opțiunea Se utilizează numai entitățile selectate).

  • Selectați butonul Distanța tamponului și introduceți valoarea -250 în câmpul asociat; valoarea negativă arată că tamponul trebuie să fie de tip intern.

  • Bifați caseta Dissolve buffer results.

  • Setați fișierul de ieșire la același director ca și celelalte fișiere vectoriale rurale.

  • Denumiți fișierul rezultat rural_buffer.shp.

  • Clic pe Salvare.

  • Faceți clic pe Ok și așteptați procesarea, pentru a îmcheia.

  • Selectați Yes din fereastra de dialog care apare.

  • Închideți dialogul Buffer.

  • Eliminați stratul rural_dissolve.

  • Salvați harta.

Pentru a încorpora zonele rurale în aceeași analiză cu cele trei rastere existente, acesta va trebui să fie, de asemenea, rasterizat. Dar, pentru ca rasterele să fie compatibile cu analiza, acestea vor trebui să fie de aceeași dimensiune. De aceea, înainte de a putea rasteriza, va trebui să decupați vectorul după aceeași suprafață ca și cele trei rastere. Un vector poate fi decupat după un alt vector, așa că va trebui mai întâi să creați un poligon de încadrare cu aceeași dimensiune ca a rasterelor.

9.4.19. Crearea unei casete de încadrare vectoriale

  • Faceți clic pe elementul de meniu Layer –> New –> New Shapefile Layer....

  • În rubrica Type, selectați butonul Polygon.

  • Clic pe Specify CRS, apoi stabiliți sistemul de coordonate de referință WGS 84 / UTM zone 33S : EPSG:32733.

  • Clic pe OK.

  • Clic OK în dialogul New Vector Layer.

  • Salvați stratul vectorial în directorul Zoning.

  • Denumiți fișierul rezultat atlas_coverage.shp.

  • Ascundeți toate straturile, cu excepția noului strat bbox și unul dintre rasterele reclasificate.

  • Asigurați-vă că stratul bbox este evidențiat în Layers list.

  • Apelați la elementul de meniu View > Toolbars pentru a vă asigura că Digitizarea este selectată. Ar trebui să vedeți pe bara de instrumente o pictogramă cu un creion sau o cariocă. Acesta este butonul Toggle editing.

  • Clic pe butonul de Activare editare pentru a intra în modul de editare. Acest lucru vă permite să editați un strat vectorial.

  • Faceți clic pe butonul Adăugare entitate, care ar trebui să se afle lângă butonul Trecere în modul de editare. Acesta se poate ascunde în spatele unui buton cu o săgeată dublă; în cazul în care acest lucru, faceți clic pe săgețile duble pentru a afișa butoanele ascunse ale bării instrumentelor de Digitizare.

  • Având activat instrumentul de Adăugare entitate, faceți clic-stânga pe colțurile rasterului. Este posibil să trebuiască să măriți harta folosind rotița mouse-ului pentru a vă asigura că este corectă. Puteți deplasa harta, în acest mod, ținând apăsat butonul din mijloc sau rotița mouse-ului.

  • Pentru al patrulea și ultimul punct, faceți clic-dreapta pentru a finaliza forma.

  • Introduceți orice număr arbitrar pentru ID-ul formei.

  • Clic pe OK

  • Clic pe butonul Save edits.

  • Clic pe butonul Toggle editing

  • Salvați harta.

Acum, că aveți o casetă de încadrare, o puteți folosi pentru a decupa stratul tampon rural.

9.4.20. Decuparea unui strat vectorial

  • Asigurați-vă că numai straturile bbox și rural_buffer sunt vizibile, ultimul aflându-se în partea superioară.

  • Faceți clic pe elementul de meniu Vector > Geoprocessing Tools > Clip.

  • În caseta de dialog care apare, setați rural_buffer pentru stratul de intrare vectorial și bbox pentru stratul de decupare, având nebifate ambele casete de Utilizare doar a entităților selectate.

  • Puneți fișierul de ieșire sub directorul Zoning.

  • Denumiți fișierul rezultat rural_clipped.

  • Clic pe OK

  • Când vi se solicită să adăugați stratul în Cuprins, faceți clic pe Yes.

  • Închideți dialogul.

  • Comparați cei trei vectori și vizualizați rezultatele.

  • Eliminați straturile bbox și rural_buffer, apoi salvați harta.

Acum estte gata fr a fi rasterizat.

9.4.21. Rasterizarea unui strat vectorial

Va trebui să specificați o dimensiune a pixelului pentru un nou raster pe care îl creați, așa că mai întâi va trebui să cunoașteți dimensiunea unuia dintre rasterele existente.

  • Deschideți dialogul Properties al oricăruia dintre cele trei rastere existente.

  • Mergeți la fila Metadata.

  • Notați valorile X și Y de sub antetul Dimensiuni din tabela Metadatelor.

  • Închideți dialogul Properties.

  • Clic pe elementul de meniu Raster ‣ Conversion ‣ Rasterize. Este posibil să primiți un avertisment despre un set de date care este neacceptat. Faceți clic pentru a-l ignora.

  • Selectați rural_clipped pentru stratul de intrare.

  • Cresți o locație pentru fișierul de ieșire, în directorul Zoning.

  • Denumiți fișierul rezultat rural_raster.tif.

  • Bifați caseta Dimensiune nouă, apoi introduceți valorile X și Y notate anterior.

  • Bifaţi caseta Load into canvas.

  • Dați clic pe pictograma creionului de lângă câmpul de text, care arată comanda ce va fi rulată. La finalul textului existent, adăugați un spațiu și apoi textul -burn 1. Acest lucru indică funcției de Rasterizare să “calcineze” vectorul existent în noul raster și să dea zonelor acoperite de vector noua valoare de 1 (spre deosebire de restul imaginii, care va fi în mod automat 0).

  • Clic pe OK

  • Noul raster ar trebui să apară în harta dvs. o dată ce a fost calculată.

  • Noul raster va arăta ca un dreptunghi gri - puteți schimba stilul de afișare așa cum ați procedat și pentru rasterele reclasificate.

  • Salvați harta dvs.

Acum, că aveți toate cele patru criterii, fiecare într-un raster separat, trebuie să le combinați pentru a vedea care zone îndeplinesc toate criteriile. Pentru a face acest lucru, rasterele vor fi multiplicate unele cu altele. Atunci când se întâmplă acest lucru, toți pixelii care se suprapun și au o valoare de 1 vor păstra valoarea 1, dar în cazul în care vreun pixel are valoarea de 0 în oricare dintre cele patru rastere, atunci rezultatul va avea valoarea 0. În acest fel, se vor păstra doar zonele care se suprapun.

9.4.22. Combinarea rasterelor

  • Faceți clic pe elementul de meniu Raster ‣ Raster calculator.

  • Construiți următoarea expresie (folosind denumirile corespunzătoare pentru straturile dvs, în funcție de modul în care le-ați denumit):

    [Rural raster] * [Reclassified aspect] * [Reclassified slope] *
    [Reclassified rainfall]
  • Setați locația de ieșire în directorul Rasterprac.

  • Denumiți fișierul rezultat cross_product.tif.

  • Asigurați-vă că este selectată caseta Add result to project.

  • Clic pe OK.

  • Schimbați simbolistica noului raster în același mod în care setați stilul pentru celelalte rastere reclasificate. Noul raster va afișa acum în mod corespunzător zonele în care toate criteriile sunt îndeplinite.

Pentru a obține rezultatul final, trebuie să selectați zonele care sunt mai mari de 6000m^2. Cu toate acestea, calcularea cu precizie a acestor suprafețe este posibilă numai pentru un strat vectorial, astfel încât va trebui să vectorizați rasterul.

9.4.23. Vectorizarea rasterului

  • Faceți clic pe elementul de meniu Raster ‣ Conversion ‣ Polygonize.

  • Selectați rasterul cross_product.

  • Stabiliți locația de ieșire pe Rasterprac.

  • Denumiți fișierul candidate_areas.shp.

  • Asigurați-vă că este selectată caseta Load into canvas when finished.

  • Clic pe OK.

  • Închideți caseta de dialog atunci când prelucrarea este completă.

Toate zonele rasterului au fost vectorizate, deci va trebui să selectați numai zonele care au valoarea 1.

  • Deschideți dialogul Interogărilor pentru noul vector.

  • Construiți această interogare:

    "DN" = 1
    
  • Clic pe OK

  • Creați un nou fișier vectorial din rezultate, salvând vectorul candidate_areas după ce interogarea este completă (și numai zonele cu valoarea 1 sunt vizibile). Pentru aceasta utilizați funcția de Salvare ca... din meniul care apare la efectuarea unui clic dreapta pe strat.

  • Salvați fișierul în directorul Rasterprac.

  • Denumiți fișierul candidate_areas_only.shp.

  • Salvați harta dvs.

9.4.24. Calculați aria pentru fiecare poligon

  • Deschideți prin clic-dreapta, meniul noului strat vectorial.

  • Selectați Deschidere tabelă de atribute.

  • Clic pe butonul de Activare editare din partea de jos a tabelei, sau apăsați Ctrl+E.

  • Clic pe butonul de Deschidere calculator de câmpuri din partea de jos a tabelei, sau apăsați Ctrl+I.

  • Sub antetul Câmpului nou din dialogul care apare, introduceți numele câmpului area. Tipul câmpului de ieșire ar trebui să fie un număr întreg, iar lățimea câmpului ar trebui să fie de 10.

  • În Expresia calculatorului raster, introduceți:

    $area

    Astfel, acest calculator câmp va calcula suprafața fiecărui poligon din stratul vectorial, iar apoi va popula apoi o nouă coloană (denumită area) , de tip întreg, cu valoarea determinată.

  • Clic pe OK

  • Faceți același lucru pentru un alt câmp nou denumit id. În Expresia calculatorului de câmpuri, introduceți:

    $id

    Acest lucru ne asigură că fiecare poligon are un ID unic, în scop de identificare.

  • Faceți clic iarăși pe butonul Toggle editing, apoi salvați modificările dacă vi se solicită acest lucru.

9.4.25. Selectarea zonelor cu o dimensiune dată

Acum, că ariile sunt cunoscute:

  • Construiți o interogare (ca de obicei) pentru a selecta numai poligoanele mai mari de 6000m^2. Interogarea este:

    "area" > 6000
    
  • Salvați selecția într-un nou strat vectorial denumit solution.shp.

Acum aveți zonele dumneavoastră calculate, din care o veți alege pe cea mai apropiată de casa dvs.

9.4.26. Digitizați casa dvs.

  • Creați un nou strat vectorial, ca și mai înainte, dar de această dată, selectând ca Tip Punctul.

  • Asigurați-vă că acesta se află în CRS-ul corect!

  • Denumiți noul strat house.shp.

  • Finalizați crearea noului strat.

  • Intrați în modul de editare (în timp ce noul strat este selectat).

  • Efectuați clic pe punctul care reprezintă reședința dvs. sau un alt loc de rezidență, folosind străzile pentru a vă ghida. S-ar putea să trebuiască să deschideți și alte straturi pentru a vă ajuta să identificați casa respectivă. În cazul în care nu locuiți prin apropiere, e suficient să faceți clic pe undeva, printre străzile unde ar putea fi situată o casă.

  • Introduceți orice număr arbitrar pentru ID-ul formei.

  • Clic pe OK

  • Salvați modificările și ieșiți din modul de editare.

  • Salvați harta.

Va trebui să găsiți centroidele (“centrele de masă”) pentru poligoane, pentru a decide care este cel mai apropiat de casa dvs.

9.4.27. Calculați centroizii poligoanelor

  • Faceți clic pe elementul de meniu Vector ‣ Geometry Tools ‣ Polygon centroids menu item.

  • Specificați stratul de intrare solution.shp.

  • Stabiliți locația de ieșire Rasterprac.

  • Apelați fișierul destinație solution_centroids.shp.

  • Clic OK pentru a-l adăuga la Cuprins (Lista straturilor), apoi închideți dialogul.

  • Setați noul strat în partea superioară a ordinii stratului, astfel încât să îl puteți vedea.

9.4.28. Aflați care este cel mai apropiat centroid de casa dvs.

  • Faceți clic pe elementul de meniu Vector –> Analysis Tools –> Distance matrix.

  • Stratul de intrare ar trebui să fie cel al reședinței dvs., iar stratul țintă solution_centroids. Ambele ar trebui să utilizeze câmpul id ca și ID unic.

  • Tip matricii de ieșire ar trebui să fie linear.

  • Stabiliţi o locație şi un nume corespunzătoare pentru rezultat.

  • Clic pe OK

  • Deschideți fișierul într-un editor de texte (sau importați-l într-o foaie de calcul). Atenție la ID-ul destinației care se va asocia cu cea mai scurtă Distanță. Pot exista mai multe de una la aceeași distanță.

  • Construiți o interogare în QGIS pentru a selecta numai zonele cele mai apropiate de casa dvs. (selecționându-le folosind câmpul id).

Acesta este răspunsul final la întrebarea.

Includeți și stratul reliefului semi-transparent peste un raster plăcut, la alegerea dvs. (de exemplu: guilabel: DEM-ul sau rasterul pantei). De asemenea, includeți poligonul din cea mai apropiată zon(ă) soluție, precum și casa dvs. Urmați cele mai bune practici cartografice, pentru a crea harta de ieșire.