Outdated version of the documentation. Find the latest one here.

9.4. Lesson: Exercițiu Suplimentar

În această lecție, veți efectua o analiză GIS completă în QGIS.

Note

Lecția a fost dezvoltată de Linfiniti și S Motala (Cape Peninsula University of Technology)

9.4.1. Definirea Problemei

Vi se cere să găsiți zone în interiorul și în jurul Peninsulei Cape, care este un habitat potrivit pentru o specie de plante rare, Fynbos. Extinderea ariei dumneavoastră de investigare din Peninsula Cape este: la sud de Melkbosstrand, la vest de Strand. Botaniștii vă informează despre următoarele cerințe pentru specia în cauză:

  • Crește pe pante orientate spre est.

  • Crește pe pante cu o înclinație între 15% și 60%.

  • Crește în zone cu precipitații anuale totale de >1200 mm.

  • Se găsește numai la cel puțin 250 de m distanță față de orice așezare umană.

  • Zona de vegetație în care apare ar trebui să aibă o suprafață de cel puțin 6000m2.

Ca voluntar pentru Cape Nature, ați fost de acord să căutați planta pe cea mai apropiată suprafață de teren față de casa dvs. Folosiți-vă abilitățile GIS pentru a determina unde ar trebui să efectuați căutarea.

9.4.2. Conturarea unei Soluții

In order to solve this problem, you will have to download data from https://www.dropbox.com/s/q5evvkizuunrcs0/more_analysis.zip?dl=0 and place it under exercise_data/more_analysis folder. You will use it to find the candidate area that is closest to your house. If you don’t live in Cape Town (where this problem is based) you can choose any house in the Cape Town region. The solution will involve:

  • analiza DEM-ului, pentru a găsi pantele orientate spre est și având înclinațiile specificate;

  • analiza rasterului de precipitații, pentru a găsi zonele cu cantitatea corectă de precipitații;

  • analiza stratul vectorial de Zonare, pentru a găsi zonele care sunt situate la distanța specificată față de așezările umane și au dimensiunea corectă.

9.4.3. Setarea Hărții

  • Clic pe butonul “CRS status” din colțul din extrema dreaptă-jos a ecranului. Sub fila CRS a ecranului care apare, veți vedea caseta de Coordinate reference systems of the world.

  • În această casetă, navigați la Projected Coordinate Systems ‣ Universal Transverse Mercator (UTM).

  • Select the entry WGS 84 / UTM zone 33S (with the EPSG code 32733).
  • Click OK. The map is now in the UTM33S coordinate reference system.
  • Salvați harta făcând clic pe butonul Save Project As din bara de instrumente, sau utilizând elementul de meniu File ‣ Save Project As....

  • Save the map in a directory called Rasterprac that you should create somewhere on your computer. You will save whatever layers you create in this directory as well.

9.4.4. Încărcarea Datelor în Hartă

Pentru a procesa datele, va trebui să încărcați straturile necesare (numele străzilor, zonele, precipitațiile, DEM-ul) în canevasul hărții.

9.4.4.1. For vectors ...

  • Click on the Add Vector Layer button, or use the Layer ‣ Add Vector Layer... menu item.
  • In the dialog that appears, ensure that the File radio button is selected.
  • Click on the Browse button.
  • In the dialog that appears, open the exercise_data/more_analysis/streets directory.
  • Select the file Street_Names_UTM33S.shp.
  • Clic pe Deschidere.

The dialog closes and shows the original dialog, with the file path specified in the text field next to the Browse button. This allows you to ensure that the correct file is selected. It is also possible to enter the file path in this field manually, should you wish to do so.

  • Click Open. The vector layer will load in your map. Its color is automatically assigned. It will be changed later.
  • Rename the layer to Streets.
  • Right-click on it in the Layers list (by default, the pane along the left-hand side of the screen).
  • Click Rename in the dialog that appears and rename it, pressing the Enter key when done.
  • Repeat the vector adding process, but this time select the Generalised_Zoning_Dissolve_UTM33S.shp file in the Zoning directory.
  • Rename it to Zoning.

9.4.4.2. For rasters ...

  • Click on the Add Raster Layer button, or use the Layer ‣ Add Raster Layer... menu item.
  • Navigați la fișierul corespunzător, selectați-l și faceți clic pe Open.

  • Do this for each of the two raster files. The files you want are DEM/reproject/DEM and Rainfall/reprojected/rainfall.tif.
  • Rename the rainfall raster to Rainfall (with an initial capital). Initially when you load them, the images will be gray rectangles. Don’t worry, this will be changed later.
  • Salvați harta.

Pentru a vedea în mod corespunzător ce se întâmplă, simbolistica pentru straturi trebuie să fie schimbată.

9.4.5. Schimbarea simbologiei straturilor vectoriale

  • In the Layers list, right-click on the Streets layer.
  • Selectați Properties din meniul care apare.

  • Switch to the Style tab in the dialog that appears.
  • Clic pe butonul Modificare, care are un pătrat prezentat în culoarea actuală a stratului Streets.

  • Selectați o culoare nouă din dialogul care va apărea.

  • Clic pe OK

  • Clic pe butonul Change, care are un pătrat prezentat în culoarea actuală a stratului Streets.

  • Urmați un proces similar pentru stratul Zoning, apoi alegeți o culoare potrivită pentru el.

9.4.6. Schimbarea simbologiei straturilor raster

Simbologia straturilor raster este oarecum diferită.

  • Deschideți dialogul Properties pentru rasterul Rainfall.

  • Switch to the Style tab. You’ll notice that this style dialog is very different from the version used for vector layers.
  • Asigurați-vă că butonul Use standard deviation

  • Change the value in the associated box to 2.00 (it should be set to 0.00 by default).
  • În secțiunea Contrast enhancement, schimbați valoarea listei derulante Current la Stretch to MinMax.

  • Clic OK. Rasterul “Precipitațiilor”, în cazul în care este vizibil, trebuie să-și schimbe culorile, permițându-vă să vedeți valori diferite de luminozitate pentru fiecare pixel.

  • Repeat this process for the DEM, but set the standard deviations used for stretching to 4.00.

9.4.7. Modificarea ordinii straturilor

  • In the Layers list, click and drag layers up and down to change the order they appear in on the map.
  • Newer versions of QGIS may have a Control rendering order checkbox beneath the Layers list. Ensure that it is checked.

Acum, că toate datele sunt încărcate și vizibile în mod corespunzător, analiza poate începe. Cel mai bine este dacă are loc, mai întâi, operațiunea de decupare. Astfel, puterea de procesare nu va fi irosită pe calcularea valorilor pentru zonele care nu vor fi deloc utilizate.

9.4.8. Găsires Districtelor Corecte

  • Load the vector layer admin_boundaries/Western_Cape_UTM33S.shp into your map.
  • Rename it to Districts.
  • Right-click on the Districts layer in the Layers list.
  • În meniul care apare, selectați elementul de meniu Query.... Va apărea dialogul Query Builder.

Veți construi acum o interogare pentru a selecta doar următoarea listă de districte:

  • Bellville,
  • Cape,
  • Goodwood,
  • Kuils River,
  • Mitchells Plain,
  • Simons Town, and
  • Wynberg.
  • În lista Fields, faceți dublu-clic pe câmpul NAME_2. Acesta va apărea în câmpul de text SQL where clause de mai jos.

  • Click the = button; an = sign is added to the SQL query.
  • Clic pe butonul All de sub lista (acum vidă) a. După o scurtă întârziere, lista Valorilor se va popula cu valoarea câmpului selectat (NAME_2).

  • Faceți dublu-clic pe valoarea Bellville din lista Valorilor. Ca și mai înainte, aceasta se va adăuga în interogarea SQL.

In order to select more than one district, you’ll need to use the OR boolean operator.

  • Faceți clic pe butonul OR pentru a adăuga textul în interogarea SQL.

  • Folosind un proces similar cu cel de mai sus, adăugați următoarele la interogarea SQL existentă:

    "NAME_2" = 'Cape'
    
  • Add another OR operator, then work your way through the list of districts above in a similar fashion.

  • Interogarea finală ar trebui să fie

    "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
    "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
    'Simons Town' OR "NAME_2" = 'Wynberg'
  • Clic OK. Districtele prezentate în harta dvs. sunt acum limitate la cele din lista de mai sus.

9.4.9. Decuparea Rasterelor

Acum, că aveți o zonă de interes, puteți decupa rasterele după ea.

  • Asigurați-vă că sunt vizibile numai straturile DEM, Rainfall și Districts.

  • Districtele trebuie să fie în partea de sus, astfel încât acestea sunt vizibile.

  • Deschideți caseta dialogului de decupare prin selectarea elementului de meniu Raster ‣ Extraction ‣ Clipper.

  • În caseta cu lista derulantă Input file (raster), selectați stratul DEM.

  • Specificați o locație de ieșire în câmpul de text Output file, făcând clic pe butonul Select....

  • Navigate to your Rasterprac directory.
  • Introduceți un nume de fișier.

  • Salvați fișierul. Lăsați caseta No data value nebifată.

  • Folosiți modul de decupare Extent, prin selectarea butonului radio corect.

  • Faceți clic și deplasați o zonă pe canevas, astfel încât aria care include districtele să fie selectată.

  • Check the Load into canvas when finished box.
  • Clic pe OK

  • După finalizarea operațiunii de tăiere, NU ÎNCHIDEȚI dialogul Clipper. (Acest lucru ar putea provoca pierderea zonelor de decupare pe care le-ați definit deja.)

  • Selectați rasterul Rainfall din lista derulantă Input file (raster), apoi alegeți un nume de fișier de ieșire diferit.

  • Do not change any other options. Do not alter the existing clipping area which you drew previously. Leave everything the same and click OK.
  • După finalizares celei de-a doua operațiuni de tăiere, puteți închide dialogul Clipper.

  • Salvați harta.

9.4.10. Curățarea hărții

  • Remove the original Rainfall and DEM layers from the Layers list:
  • Clic-dreapta pe aceste straturi apoi selectați Remove.

    • Acest lucru nu va elimina datele de pe dispozitivul de stocare, doar le va scoate din harta dvs.

  • Dezactivați etichetele din stratul Streets:

    • Clic pe butonul Etichetare.

    • Debifați caseta Label this layer with.

    • Clic pe OK

  • Afișați iarăși toate Streets:

    • Right-click on the layer in the Layers list.
    • Selectați Query.

  • În fereastra de dialog care apare, Query, faceți clic pe butonul Clear, apoi pe OK.

  • Așteptați în timp ce datele sunt încărcate. Toate străzile vor fi de acum vizibile.

  • Change the raster symbology as before (see Changing the symbology of raster layers).
  • Salvați harta.

  • You can now hide the vector layers by unchecking the box next to them in the Layers list. This will make the map render faster and will save you some time.

In order to create the hillshade, you will need to use a plugin that was written for this purpose.

9.4.11. Activating the Raster Terrain Analysis plugin

This plugin is included by default in QGIS 1.8. However, it may not be immediately visible. To check if it is accessible on your system:

  • Click on the menu item Plugins ‣ Manage Plugins....
  • Ensure that the box next to Raster Terrain Analysis plugin is selected.
  • Clic pe OK

You will now have access to this plugin via the Raster ‣ Terrain analysis menu item.

Remember that plugins may sometimes depend on certain Python modules being installed on your system. Should a plugin refuse to work while complaining of missing dependencies, please ask your tutor or lecturer for assistance.

9.4.12. Crearea reliefului

  • In the Layers list, ensure that the DEM is the active layer (i.e., it is highlighted by having been clicked on).
  • Click on the Raster ‣ Terrain analysis ‣ Hillshade menu item to open the Hillshade dialog.
  • Specificați o locație adecvată pentru stratul de ieșire și denumiți-o hillshade.

  • Check the Add result to project box.
  • Clic pe OK

  • Așteptați să se termine prelucrarea.

Noul strat hillshade a apărut în Lista straturilor dvs.

  • Făcând clic dreapta pe stratul hillshade din Lista straturilor dvs., se va desxchide dialogul Properties.

  • Click on the Transparency tab and set the transparency slider to 80%.
  • Click OK on the dialog.
  • Observați efectul, atunci când relieful transparent este suprapus peste DEM-urile decupate.

9.4.13. Panta

  • Faceți clic pe elementul de meniu Raster ‣ Terrain analysis.

  • Selectați tipul de analiză Slope, având ca intrare DEM-ul decupat.

  • Specificați un nume corespunzător și o locație pentru fișierul de ieșire.

  • Check the Add result to project box.
  • Clic pe OK

Imaginea pantei a fost calculată și adăugată la hartă. Cu toate acestea, ca de obicei, se vede doar un dreptunghi gri. Pentru a observa corect ce se întâmplă, schimbați simbolistica, după cum urmează.

  • Deschideți dialogul Properties (ca de obicei, prin intermediul meniului clic-dreapta al stratului).

  • Click on the Style tab.
  • Acolo unde scrie Grayscale (în caseta cu derulare verticală Harta culorilor), alegeți Pseudocolor.

  • Asigurați-vă că butonul radio Use standard deviation este selectat.

9.4.14. Aspectul

  • Utilizați aceeași abordare ca și pentru calculul pantei, dar selectați Aspectul, în fereastra de dialog inițială.

Amintiți-vă să salvați periodic modificările.

9.4.15. Reclasificarea rasterelor

  • Faceți clic pe elementul de meniu Raster ‣ Raster calculator.

  • Specify your Rasterprac directory as the location for the output layer.
  • Ensure that the Add result to project box is selected.

In the Raster bands list on the left, you will see all the raster layers in your Layers list. If your Slope layer is called slope, it will be listed as slope@1.

The slope needs to be between 15 and 60 degrees. Everything less than 15 or greater than 60 must therefore be excluded.

  • Folosind elementele din listă și butoanele din interfață, construiți următoarea expresie:

    (([email protected] < 15) OR ([email protected] > 60)) = 0
  • Alegeți o locație pentru câmpul Output layer și numele de fișier corespunzător.

  • Clic pe OK

Now find the correct aspect (east-facing: between 45 and 135 degrees) using the same approach.

Having reclassified all the rasters, you will now see them displayed as gray rectangles in your map (assuming that they have been added to the map correctly). To properly display raster data with only two classes (1 and 0, meaning true or false), you will need to change their symbology.

9.4.16. Setarea stilului pentru straturile reclasificate

  • Open the Style tab in the layer’s Properties dialog as usual.
  • Sub titlul Încărcare valori min / max din bandă, selectați butonul radio Actual (lent).

  • Clic pe butonul Load.

The Custom min / max values fields should now populate with 0 and 1, respectively. (If they do not, then there was a mistake with your reclassification of the data, and you will need to go over that part again.)

  • Sub antetul Îmbunătățire contrast, alegeți din lista Curent Întindere la MinMax.

  • Clic pe OK

  • Faceți acest lucru pentru toate cele trei rastere reclasificate, și amintiți-vă să vă salvați munca!

The only criterion that remains is that the area must be 250m away from urban areas. We will satisfy this requirement by ensuring that the areas we compute are 250m or more from the edge of a rural area. Hence, we need to find all rural areas first.

9.4.17. Găsirea zonele rurale

  • Hide all layers in the Layers list.

  • Afișarea straturilor vectoriale Zoning.

  • Clic-dreapta pentru a se deschide dialogul Query.

  • Construiți următoarea interogare:

    "Gen_Zoning" = 'Rural'
    

    Consultați instrucțiunile anterioare pentru construirea interogării Streets, dacă v-ați blocat.

  • Când ați terminat, închideți dialogul :guilabel:`Query.

Ar trebui să vedeți o colecție de poligoane din partea stratului Zonare. Va trebui să le salvați în fișierul unui nou strat.

  • În meniul descis printr-un clic-dreapta pe stratul Zoning, selectați Save as....

  • Salvați stratul în directorul Zoning.

  • Name the output file rural.shp.
  • Clic pe OK

  • Adăugați straturile în harta dvs.

  • Faceți clic pe elementul de meniu Vector > Geoprocessing Tools > Dissolve.

  • Selectați stratul vectorial rural ca intrare, lăsând nebifată opțiunea Se utilizează doar entitățile selectate.

  • Under Dissolve field, select — Dissolve all —.
  • Salvați stratul în directorul Zoning.

  • Click OK. A dialog will appear asking whether you want to add the new layer to the TOC (“Table of Contents”, referring to the Layers list).
  • Click Yes.
  • Închideți dialogul Dissolve.

  • Eliminați straturile rural și Zoning.

  • Salvați harta.

Now you need to exclude the areas that are within 250m from the edge of the rural areas. Do this by creating a negative buffer, as explained below.

9.4.18. Crearea unui tampon negativ

  • Faceți clic pe elementul de meniu Vector ‣ Geoprocessing Tools ‣ Buffer(s).

  • În caseta de dialog care apare, selectați stratul vectorial rural_dissolve ca intrare (nu trebuie bifată opțiunea Se utilizează numai entitățile selectate).

  • Select the Buffer distance button and enter the value -250 into the associated field; the negative value means that the buffer must be an internal buffer.
  • Bifați caseta Dissolve buffer results.

  • Setați fișierul de ieșire la același director ca și celelalte fișiere vectoriale rurale.

  • Name the output file rural_buffer.shp.
  • Clic pe Salvare.

  • Faceți clic pe Ok și așteptați procesarea, pentru a îmcheia.

  • Selectați Yes din fereastra de dialog care apare.

  • Închideți dialogul Buffer.

  • Eliminați stratul rural_dissolve.

  • Salvați harta.

Pentru a încorpora zonele rurale în aceeași analiză cu cele trei rastere existente, acesta va trebui să fie, de asemenea, rasterizat. Dar, pentru ca rasterele să fie compatibile cu analiza, acestea vor trebui să fie de aceeași dimensiune. De aceea, înainte de a putea rasteriza, va trebui să decupați vectorul după aceeași suprafață ca și cele trei rastere. Un vector poate fi decupat după un alt vector, așa că va trebui mai întâi să creați un poligon de încadrare cu aceeași dimensiune ca a rasterelor.

9.4.19. Crearea unei casete de încadrare vectoriale

  • Click on the menu item Layer ‣ New ‣ New Shapefile Layer....
  • În rubrica Type, selectați butonul Polygon.

  • Click Specify CRS and set the coordinate reference system WGS 84 / UTM zone 33S : EPSG:32733.
  • Clic pe OK.

  • Clic OK în dialogul New Vector Layer.

  • Salvați stratul vectorial în directorul Zoning.

  • Name the output file bbox.shp.
  • Ascundeți toate straturile, cu excepția noului strat bbox și unul dintre rasterele reclasificate.

  • Ensure that the bbox layer is highlighted in the Layers list.
  • Apelați la elementul de meniu View > Toolbars pentru a vă asigura că Digitizarea este selectată. Ar trebui să vedeți pe bara de instrumente o pictogramă cu un creion sau o cariocă. Acesta este butonul Toggle editing.

  • Clic pe butonul de Activare editare pentru a intra în modul de editare. Acest lucru vă permite să editați un strat vectorial.

  • Faceți clic pe butonul Adăugare entitate, care ar trebui să se afle lângă butonul Trecere în modul de editare. Acesta se poate ascunde în spatele unui buton cu o săgeată dublă; în cazul în care acest lucru, faceți clic pe săgețile duble pentru a afișa butoanele ascunse ale bării instrumentelor de Digitizare.

  • Având activat instrumentul de Adăugare entitate, faceți clic-stânga pe colțurile rasterului. Este posibil să trebuiască să măriți harta folosind rotița mouse-ului pentru a vă asigura că este corectă. Puteți deplasa harta, în acest mod, ținând apăsat butonul din mijloc sau rotița mouse-ului.

  • Pentru al patrulea și ultimul punct, faceți clic-dreapta pentru a finaliza forma.

  • Introduceți orice număr arbitrar pentru ID-ul formei.

  • Clic pe OK

  • Clic pe butonul Save edits.

  • Clic pe butonul Toggle editing

  • Salvați harta.

Acum, că aveți o casetă de încadrare, o puteți folosi pentru a decupa stratul tampon rural.

9.4.20. Decuparea unui strat vectorial

  • Asigurați-vă că numai straturile bbox și rural_buffer sunt vizibile, ultimul aflându-se în partea superioară.

  • Faceți clic pe elementul de meniu Vector > Geoprocessing Tools > Clip.

  • În caseta de dialog care apare, setați rural_buffer pentru stratul de intrare vectorial și bbox pentru stratul de decupare, având nebifate ambele casete de Utilizare doar a entităților selectate.

  • Puneți fișierul de ieșire sub directorul Zoning.

  • Name the output file rural_clipped.
  • Clic pe OK

  • Când vi se solicită să adăugați stratul în Cuprins, faceți clic pe Yes.

  • Închideți dialogul.

  • Comparați cei trei vectori și vizualizați rezultatele.

  • Eliminați straturile bbox și rural_buffer, apoi salvați harta.

Acum estte gata fr a fi rasterizat.

9.4.21. Rasterizarea unui strat vectorial

Va trebui să specificați o dimensiune a pixelului pentru un nou raster pe care îl creați, așa că mai întâi va trebui să cunoașteți dimensiunea unuia dintre rasterele existente.

  • Deschideți dialogul Properties al oricăruia dintre cele trei rastere existente.

  • Mergeți la fila Metadata.

  • Make a note of the X and Y values under the heading Dimensions in the Metadata table.
  • Închideți dialogul Properties.

  • Clic pe elementul de meniu Raster ‣ Conversion ‣ Rasterize. Este posibil să primiți un avertisment despre un set de date care este neacceptat. Faceți clic pentru a-l ignora.

  • Selectați rural_clipped pentru stratul de intrare.

  • Cresți o locație pentru fișierul de ieșire, în directorul Zoning.

  • Name the output file rural_raster.tif.
  • Check the New size box and enter the X and Y values you made a note of earlier.
  • Bifaţi caseta Load into canvas.

  • Click the pencil icon next to the text field which shows the command that will be run. At the end of the existing text, add a space and then the text -burn 1. This tells the Rasterize function to “burn” the existing vector into the new raster and give the areas covered by the vector the new value of 1 (as opposed to the rest of the image, which will automatically be 0).
  • Clic pe OK

  • Noul raster ar trebui să apară în harta dvs. o dată ce a fost calculată.

  • Noul raster va arăta ca un dreptunghi gri - puteți schimba stilul de afișare așa cum ați procedat și pentru rasterele reclasificate.

  • Salvați harta dvs.

Now that you have all four criteria each in a separate raster, you need to combine them to see which areas satisfy all the criteria. To do so, the rasters will be multiplied with each other. When this happens, all overlapping pixels with a value of 1 will retain the value of 1, but if a pixel has the value of 0 in any of the four rasters, then it will be 0 in the result. In this way, the result will contain only the overlapping areas.

9.4.22. Combinarea rasterelor

  • Faceți clic pe elementul de meniu Raster ‣ Raster calculator.

  • Construiți următoarea expresie (folosind denumirile corespunzătoare pentru straturile dvs, în funcție de modul în care le-ați denumit):

    [Rural raster] * [Reclassified aspect] * [Reclassified slope] *
    [Reclassified rainfall]
  • Set the output location to the Rasterprac directory.

  • Name the output raster cross_product.tif.

  • Ensure that the Add result to project box is checked.

  • Clic pe OK.

  • Schimbați simbolistica noului raster în același mod în care setați stilul pentru celelalte rastere reclasificate. Noul raster va afișa acum în mod corespunzător zonele în care toate criteriile sunt îndeplinite.

To get the final result, you need to select the areas that are greater than 6000m^2. However, computing these areas accurately is only possible for a vector layer, so you will need to vectorize the raster.

9.4.23. Vectorizarea rasterului

  • Faceți clic pe elementul de meniu Raster ‣ Conversion ‣ Polygonize.

  • Select the cross_product raster.
  • Set the output location to Rasterprac.
  • Name the file candidate_areas.shp.
  • Ensure that Load into canvas when finished is checked.
  • Clic pe OK.

  • Închideți caseta de dialog atunci când prelucrarea este completă.

All areas of the raster have been vectorized, so you need to select only the areas that have a value of 1.

  • Deschideți dialogul Interogărilor pentru noul vector.

  • Construiți această interogare:

    "DN" = 1
    
  • Clic pe OK

  • Create a new vector file from the results by saving the candidate_areas vector after the query is complete (and only the areas with a value of 1 are visible). Use the Save as... function in the layer’s right-click menu for this.

  • Save the file in the Rasterprac directory.

  • Denumiți fișierul candidate_areas_only.shp.

  • Salvați harta dvs.

9.4.24. Calculați aria pentru fiecare poligon

  • Deschideți prin clic-dreapta, meniul noului strat vectorial.

  • Selectați Deschidere tabelă de atribute.

  • Clic pe butonul de Activare editare din partea de jos a tabelei, sau apăsați Ctrl+E.

  • Clic pe butonul de Deschidere calculator de câmpuri din partea de jos a tabelei, sau apăsați Ctrl+I.

  • Under the New field heading in the dialog that appears, enter the field name area. The output field type should be an integer, and the field width should be 10.

  • În Expresia calculatorului raster, introduceți:

    $area

    Astfel, acest calculator câmp va calcula suprafața fiecărui poligon din stratul vectorial, iar apoi va popula apoi o nouă coloană (denumită area) , de tip întreg, cu valoarea determinată.

  • Clic pe OK

  • Faceți același lucru pentru un alt câmp nou denumit id. În Expresia calculatorului de câmpuri, introduceți:

    $id

    Acest lucru ne asigură că fiecare poligon are un ID unic, în scop de identificare.

  • Faceți clic iarăși pe butonul Toggle editing, apoi salvați modificările dacă vi se solicită acest lucru.

9.4.25. Selectarea zonelor cu o dimensiune dată

Acum, că ariile sunt cunoscute:

  • Build a query (as usual) to select only the polygons larger than 6000m^2. The query is:

    "area" > 6000
    
  • Save the selection as a new vector layer called solution.shp.

Acum aveți zonele dumneavoastră calculate, din care o veți alege pe cea mai apropiată de casa dvs.

9.4.26. Digitizați casa dvs.

  • Creați un nou strat vectorial, ca și mai înainte, dar de această dată, selectând ca Tip Punctul.

  • Asigurați-vă că acesta se află în CRS-ul corect!

  • Name the new layer house.shp.
  • Finalizați crearea noului strat.

  • Intrați în modul de editare (în timp ce noul strat este selectat).

  • Efectuați clic pe punctul care reprezintă reședința dvs. sau un alt loc de rezidență, folosind străzile pentru a vă ghida. S-ar putea să trebuiască să deschideți și alte straturi pentru a vă ajuta să identificați casa respectivă. În cazul în care nu locuiți prin apropiere, e suficient să faceți clic pe undeva, printre străzile unde ar putea fi situată o casă.

  • Introduceți orice număr arbitrar pentru ID-ul formei.

  • Clic pe OK

  • Salvați modificările și ieșiți din modul de editare.

  • Salvați harta.

Va trebui să găsiți centroidele (“centrele de masă”) pentru poligoane, pentru a decide care este cel mai apropiat de casa dvs.

9.4.27. Calculați centroizii poligoanelor

  • Click on the Vector ‣ Geometry Tools ‣ Polygon centroids menu item.
  • Specificați stratul de intrare solution.shp.

  • Provide the output location as Rasterprac.
  • Call the destination file solution_centroids.shp.
  • Click OK and add the result to the TOC (Layers list), then close the dialog.
  • Setați noul strat în partea superioară a ordinii stratului, astfel încât să îl puteți vedea.

9.4.28. Aflați care este cel mai apropiat centroid de casa dvs.

  • Click on the menu item Vector ‣ Analysis Tools ‣ Distance matrix.
  • The input layer should be your house, and the target layer solution_centroids. Both of these should use the id field as their unique ID field.
  • Tip matricii de ieșire ar trebui să fie linear.

  • Stabiliţi o locație şi un nume corespunzătoare pentru rezultat.

  • Clic pe OK

  • Deschideți fișierul într-un editor de texte (sau importați-l într-o foaie de calcul). Atenție la ID-ul destinației care se va asocia cu cea mai scurtă Distanță. Pot exista mai multe de una la aceeași distanță.

  • Build a query in QGIS to select only the solution areas closest to your house (selecting it using the id field).

Acesta este răspunsul final la întrebarea.

Includeți și stratul reliefului semi-transparent peste un raster plăcut, la alegerea dvs. (de exemplu: guilabel: DEM-ul sau rasterul pantei). De asemenea, includeți poligonul din cea mai apropiată zon(ă) soluție, precum și casa dvs. Urmați cele mai bune practici cartografice, pentru a crea harta de ieșire.