Outdated version of the documentation. Find the latest one here.

QGIS GUI

When QGIS starts, you are presented with the GUI as shown in the figure (the numbers 1 through 5 in yellow circles are discussed below).

Figure QGIS GUI 1:

../../../_images/startup.png

QGIS GUI with Alaska sample data

Note

As decorações na sua janela (Barra de Títulos, etc.) podem aparecer diferente maneira dependendo do seu sistema operativo e gestor de janelas.

The QGIS GUI is divided into five areas:

  1. Barra de Menus

  2. Toolbars
  3. Panels
  4. Vista do Mapa

  5. Barra de Estado

These five components of the QGIS interface are described in more detail in the following sections. Two more sections present keyboard shortcuts and context help.

Panels and Toolbars

From the View menu (Settings under KDE), you can switch on and off QGIS widgets (Panels ‣) or toolbars (Toolbars ‣). You can (de)activate any of them by right-clicking the menu bar or a toolbar and choose the item you want. Each panel or toolbar can be moved and placed wherever you feel comfortable with in QGIS interface. The list can also be extended with the activation of Core or external plugins.

Toolbars

A barra de ferramentas fornece o acesso à maioria das mesmas funções que dos menus, mais as ferramentas adicionais para interagir com o mapa. Cada item da barra de ferramentas tem uma janela de ajuda disponível. Mantenha o seu rato em cima do item e uma descrição curta da finalidade da ferramenta irá ser exibida.

Every toolbar can be moved around according to your needs. Additionally, they can be switched off using the right mouse button context menu, or by holding the mouse over the toolbars.

Figure Toolbars:

../../../_images/toolbars1.png

The Toolbars menu

Tip

Restaurar as Barras de Ferramentas

If you have accidentally hidden a toolbar, you can get it back by choosing menu option View ‣ Toolbars ‣ (or Settings ‣ Toolbars ‣ under Linux KDE). If for some reason a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

Panels

QGIS provides by default many panels to work with.

Figure Panels:

../../../_images/panels.png

The Panels menu

Some of these panels are described below while others may be found in different parts of the document, namely:

Layers Panel

The layers panel lists all the layers in the project. The checkbox in each legend entry can be used to show or hide the layer. The toolbar in the layers panel allows you to:

  • addGroup Add new group
  • showPresets Manage Visibility: control visibility of layers and preset layers combination
  • filterMap Filter Legend by Map Content: only the layers that are set visible and whose features intersect the current map canvas have their style rendered in the layers panel. Otherwise, a generic NULL symbol is applied to the layer. Based on the layer symbology, this is a convenient way to identify which kind of features from which layers cover your area of interest.
  • expressionFilter Filter Legend by Expression: helps you apply an expression to remove from the selected layer tree styles that have no feature satisfying the condition. This can be used for example to highlight features that are within a given area/feature of another layer. From the drop-down list, you can edit and clear the expression set.
  • expandTree Expand All or collapseTree Collapse All layers and groups in the layers panel.
  • and removeLayer Remove Layer/Group currently selected.

Figure Layer tools Bar:

../../../_images/layer_toolbar.png

Layer Toolbar in Layers Panel

The button showPresets allows you to add Presets views in the legend. Presets are a way to save and easily restore a combination of layers with their current style. To add a preset view, just set visible the layers you want, with their desired symbology, and click on showPresets button. Choose Add Preset... from the drop-down menu and give a name to the preset. The added preset is listed at the bottom of the drop-down menu and is recalled by clicking on it.

The Replace Preset ‣ option helps you overwrite a preset content with the current map view while the Remove Current Preset button deletes the active preset.

All the added presets are also present in the map composer in order to allow you to create a map layout based on your specific views (see Main properties).

Note

Tools to manage the layers panel are also available to layout the map and legend items of the print composer

A camada pode ser seleccionada e arrastada para cima e para abaixo na legenda para alterar a ordenação-z. A Ordenação-Z significa que as camadas listadas perto do topo da legenda são desenhadas sobre as camadas listadas mais abaixo na legenda.

Note

This behavior can be overridden by the Layer Order panel.

Layers in the legend window can be organized into groups. There are two ways to do this:

  1. Press the folder icon to add a new group. Type in a name for the group and press Enter. Now click on an existing layer and drag it onto the group.
  2. Seleccione algumas camadas, e clique com o botão direito do rato na legenda da janela e escolha Agrupar Seleccionados. As camadas seleccionadas irão automaticamente incorporar o novo grupo.

Para trazer a camada para fora do grupo pode arrastar para fora, ou clicar no botão direito do rato em cima e escolha Faça item de topo. Os grupos podem ser também agrupados dentro de outros grupos.

A caixa de verificação para o grupo irá mostrar ou esconder todas as camadas do grupo com um clique.

The content of the right mouse button context menu depends on whether the selected legend item is a raster or a vector layer. For GRASS vector layers, toggleEditing Toggle editing is not available. See section Digitalizando e editando as camadas vectoriais GRASS for information on editing GRASS vector layers.

Below are listed available options in context menu depending on the selected item.

Option Vector Layer Raster Layer Group
zoomToLayer Zoom to Layer/Group checkbox checkbox checkbox
unchecked Show in Overview checkbox checkbox
zoomActual Zoom to Native Resolution (100%) checkbox
Stretch Using Current Extent checkbox
removeLayer Remove checkbox checkbox checkbox
duplicateLayer Duplicate checkbox checkbox
Set Layer Scale Visibility checkbox checkbox
Set Layer/Group CRS checkbox checkbox checkbox

Definir SRC do projecto a partir da Camada

checkbox checkbox
Styles ‣ checkbox checkbox
Copy Style checkbox checkbox
Paste Style checkbox checkbox checkbox
openTable Open Attribute Table checkbox
toggleEditing Toggle Editing checkbox
allEdits Current Edits ‣ checkbox (in Edit mode)
Save As... checkbox checkbox
Save As Layer Definition File... checkbox checkbox checkbox

Filtrar

checkbox
unchecked Show Feature Count checkbox

Propriedades

checkbox checkbox
Move to Top-level checkbox checkbox

Renomear

checkbox checkbox checkbox

Agrupar Seleccionados

checkbox checkbox

Propriedades

checkbox checkbox
Set Group WMS Data checkbox
unchecked Mutually Exclusive Group checkbox
addGroup Add Group checkbox

Enabling the Mutually Exclusive Group option you can make a group have only one layer visible at the same time. Whenever a layer within the group is set visible the others will be toggled not visible.

É possível seleccionar mais de uma camada ou grupo ao mesmo tempo segurando a tecla Ctrl enquanto selecciona as camadas com o botão esquerdo do rato. Pode mover todas as camadas seleccionadas para um novo grupo ao mesmo tempo.

You may also delete more than one layer or group at once by selecting several items with the Ctrl key and pressing Ctrl+D afterwards. This way, all selected layers or groups will be removed from the layers list.

Editing vector layer style

From the Layers panel, you have shortcuts to easily and quickly edit the layer rendering. Right-click on a vector layer and select Styles –> in the list in order to:

  • see the currently applied styles to the layer. In case you defined many styles for the layer, you can switch from one to another and have your layer rendering automatically updated in the map canvas.
  • copy the current style, and when applicable, paste a copied style from another layer
  • rename the current style, add a new one (which is actually a copy of the current one) or delete the current style (when multiple styles available).

Note

The previous options are also available for raster layer.

Whether the features in the vector layer have all the same unique symbol or they are classified (in that case, the layer is displayed in a tree structure with each class as sub-item), the following options are available at layer level or class level:

  • a Edit Symbol... button to open the The symbol Selector dialog and update any property (symbol, size, color...) of the layer or feature symbol. Double-clicking on a feature does also open the Symbol Selector dialog.
  • a Color Selector widget with a Color Wheel from which you can click a color and have it automatically update the symbol fill color. For convenience, Recent colors are available at the bottom of the color wheel.
  • a showAllLayers Show All Items and hideAllLayers Hide All Items to toggle on or off the visibility of all the classes of features. This avoids (un)checking items one by one.

Tip

Quickly share a layer style

From the context menu, copy the style of a layer and paste it to a group or a selection of layers: the style is applied to all the layers that are of the same type (vector vs raster) as the original layer and, in case of vector, have the same geometry type (point, line or polygon).

Trabalhando com a Ordem da legenda de camada indepenente

There is a panel that allows you to define an independent drawing order for the layers panel. You can activate it in the menu Settings ‣ Panels ‣ Layer Order Panel. This feature allows you to, for instance, order your layers in order of importance, but still display them in the correct order (see figure_layer_order). Checking the checkbox Control rendering order box underneath the list of layers will cause a revert to default behavior.

Figure Layer Order:

../../../_images/layer_order.png

Define a legend independent layer order

Statistical Summary Panel

This panel can show some statistics on a specific vector layers. The panel allows users to choose:

  • the vector layer;
  • the column or the expression;
  • filter statistics to selected features;
  • refresh the informations;
  • the statistics information to display with the bottom right button;

QGIS Overview Panel

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labelling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Log Messages Panel

When loading or processing some operations, you can track and follow messages that appear in different tabs using the messageLog Log Messages Panel. It can be activated using the most right icon in the bottom status bar.

Undo/Redo Panel

For each layer being edited, this panel shows the list of actions done, allowing to quickly undo a set of actions by simply selecting the action listed above.

Vista do Mapa

Also called Map canvas, this is the “business end” of QGIS — maps are displayed in this area. The map displayed in this window will depend on the vector and raster layers you have chosen to load (see sections that follow for more information on how to load layers). The map view can be panned, shifting the focus of the map display to another region, and it can be zoomed in and out. Various other operations can be performed on the map as described in the label_toolbars description above. The map view and the legend are tightly bound to each other — the maps in view reflect changes you make in the legend area.

Tip

Aumentado o Mapa com a roda do Rato

Pode usar a roda do rato para ampliar ou afastar o mapa. Posicione o cursos do rato dentro da área do mapa e rode a roda para a frente (longe de si) para ampliar e para trás (perto de si) para afastar. A posição do cursor do mapa é centrada onde a ampliação ocorre. Pode personalizar o comportamento de ampliação da roda do rato usando o separador Ferramentas de mapa no menu Configurações ‣ Opções .

Tip

Movendo o Mapa com as Setas de Direcção e Barra de Espaço

Pode usar as teclas de direcção para mover o mapa. Coloque o cursor do mapa dentro da área do mapa e clique na tecla direita de direcção para mover para este, tecla esquerda de direcção para mover para oeste, tecla para cima para mover para norte e a tecla de direcção para baixo para mover para sul. Pode também mover o mapa usando a barra de espaço ou clicando na roda do rato: apenas mova o rato enquanto segura a barra de espaço ou clica a roda do rato.

Barra de Estado

The status bar provides you with general information about the map view, and actions processed or available and offers you tools to manage the map view.

On the left side of the status bar, you can get a summary of actions you’ve done (such as selecting features in a layer, removing layer) or a long description of the tool you are hovering over (not available for all tools). On startup, the bar status also informs you about availability of new or upgradeable plugins (if checked in Plugin Manager settings).

In case of lengthy operations, such as gathering of statistics in raster layers or rendering several layers in map view, a progress bar is displayed in the status bar to show the current progress of the action.

The tracking Coordinate option shows the current position of the mouse, following it while moving across the map view. You can set the unit (and precision) to use in the project properties, General tab. Click on the small button at the left of the textbox to toggle between the Coordinate option and the extents Extents option that displays in map units, the coordinates of the current lower leftmost and upper rightmost points of the map view, as you pan and zoom in and out.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. If you zoom in or out, QGIS shows you the current scale. There is a scale selector, which allows you to choose among predefined and custom scales to assign to the map view.

To the right of the scale display you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, there is a small checkbox which can be used to temporarily prevent layers being rendered to the map view (see section Renderização).

To the right of the render functions, you find the projectionDisabled Current CRS: icon with the EPSG code of the current project CRS. Clicking on this lets you Enable ‘on the fly’ CRS transformation properties for the current project and apply another CRS to the map view.

Finally, the messageLog Messages button opens the Log Messages Panel which informs you on underlying process (QGIS startup, plugins loading, processing tools...)

Tip

Calculando a Escala Correcta para o Seu Enquadramento do Mapa

When you start QGIS, the default CRS is WGS 84 (epsg 4326) and units are degrees. This means that QGIS will interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually change this setting, e.g. to meters, in the General tab under Project ‣ Project Properties, or you can use the projectionDisabled Current CRS: icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., +units=us-ft).

Note that CRS choice on startup can be set in Settings ‣ Options ‣ CRS.