Outdated version of the documentation. Find the latest one here.

9.4. Lesson: 補足の実習

このレッスンでは、QGISでの完全なGIS解析を通して案内します。

ノート

Lesson developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

9.4.1. 問題の状態

あなたはケープ半島とその周辺で、珍しいフィンボスの植物種に適した生息地である領域を見つける任務を課されています。ケープ半島内での調査地域の範囲は次のとおりです。Melkbosstrandの南、ストランドの西。問題の種は次の嗜好を示すことを植物学者が示してくれています

  • 東向き斜面に生息します。

  • 15%と60%の間の勾配の斜面に生息します。

  • 年間総降水量1200ミリメートル超の領域に生息します。

  • どの集落からも少なくとも250メートル離れたところで発見されます。

  • それが発生した植生の面積は、面積が少なくとも6000平方メートルである必要があります。

ケープ自然保護ボランティアとして、あなたは自宅に最も近い適当な土地の一画でその植物を探すことに合意しました。GISのスキルを使用してどこを見に行くべきか決定しましょう。

9.4.2. ソリューションの概要

自宅に最も近い候補領域を見つけるために、この問題を解決するために、利用可能なデータを使用する必要があります(exercise_data/more_analysis で利用可能)。ケープタウン(この問題の基になる)に住んでいない場合は、ケープタウンの領域の任意の家を選択できます。解決策に含まれるのは:

  • DEMを分析し、東向き斜面および該当する勾配を有する斜面を見つける。

  • 降雨ラスタを分析し、該当する降雨量の領域を見つける。

  • ゾーニングベクトルレイヤーを分析し、集落から離れていて該当するサイズである領域を見つける。

9.4.3. マップの設定

  • 画面の一番右下にある「CRSステータス」ボタンをクリックします。表示される画面の CRS タブの下に world座標参照系 ボックスが表示されるでしょう。

  • このボックスで、 システム座標投影->ユニバーサル横メルカトル(UTM) に移動します。

  • Select the entry WGS 84 / UTM zone 33S (with the EPSG code 32733).
  • OK をクリックします。マップは UTM33S のCRSです。

  • プロジェクトに名前を付けて保存 ツールバーボタンをクリックして地図を保存するか、 ファイル‣プロジェクトに名前を付けて保存... メニュー項目を使用します。

  • お手元のコンピュータ上のどこかに Rasterprac というディレクトリを作成し、地図を保存してください。作成したレイヤーもこのディレクトリに保存します。

9.4.4. 地図へデータを読み込む

データを処理するために、マップキャンバスに必要なレイヤー(通りの名前、ゾーン、降雨、DEM)をロードする必要があります。

9.4.4.1. ベクタにとって・・・

  • ベクトルレイヤーを追加 ボタンをクリックするか、レイヤー->ベクタレイヤーを追加... メニュー項目を使用します。

  • 表示されるダイアログで、ファイル のラジオボタンが選択されているかを確認します。

  • ブラウズ ボタンをクリックします。

  • 表示されるダイアログで、 exercise_data/more_analysis/streets ディレクトリを開きます。

  • Street_Names_UTM33S.shp を選択します。

  • 開く をクリックします。

ダイアログが閉じて、ファイルのパスが Browse ボタン隣のテキストフィールドに指定された元のダイアログが表示されています。これにより、正しいファイルが選択されていることを確認できます。そうしたければ手動でもこのフィールドにファイルのパスを入力できます。

  • 開く をクリックします。ベクトルレイヤーが地図にロードされます。その色は自動的に割り当てられます。それは後に変更されます。

  • レイヤを Streets にリネームします。

  • レイヤーlist (デフォルトでは、画面の左側に沿った窓)でそれを右クリックします。

  • 現れるダイアログで 名前変更 をクリックして名前を変更し、終わったら Enter キーを押します。

  • ベクトル追加処理を繰り返しますが、今回は Zoning ディレクトリで Generalised_Zoning_Dissolve_UTM33S.shp ファイルを選択します。

  • 名前を Zoning に変更します。

9.4.4.2. ラスタでは・・・

  • ラスターレイヤーを追加 ボタンをクリックするか、 レイヤー->ラスターレイヤーを追加... メニュー項目を使用してください。

  • 該当するファイルに移動し、それを選択し、 開く をクリックしてください。

  • 2つのラスターファイル各々にこれを行います。したいファイルは、次のとおりです。 DEM/再投影/DEM降雨/再投影/rainfall.tif

  • 降雨ラスタの名前を Rainfall (先頭大文字)に変更します。最初にそれらをロードする際は、画像がグレーの長方形になります。これは後に変更されますので心配無用です。

  • マップを保存します。

適切に何が起こっているのかを確認するためには、レイヤーのためのシンボルを変更する必要があります。

9.4.5. ベクタレイヤのシンボロジの変更

  • レイヤーリスト 内で 街路 レイヤを右クリックします。

  • 表示されているメニューで プロパティ を選択します。

  • 表示されているダイアログで スタイル タブに切り替えます。

  • 街路 レイヤーの現在の色を示す四角が付いた 変更 とラベルのついたボタンをクリックしてください。

  • 表示されるダイアログで新しい色を選択します。

  • OK をクリックします。

  • レイヤプロパティ ダイアログの OK をもう一度クリックします。これは 街路 レイヤーの色を変更します。

  • Zoning レイヤーについて同様のプロセスに従って、そのための適切な色を選択してください。

9.4.6. ラスタレイヤのシンボロジの変更

ラスタレイヤシンボロジはどこか違います。

  • Rainfall ラスタの プロパティ ダイアログを開きます。

  • Style タブに切り替えます。このスタイルダイアログがベクトルレイヤーに使用されるバージョンとは非常に異なっていることに気づくでしょう。

  • 標準偏差を使用する が選択されていることを確認します。

  • 関連付けられたボックスで値を 2.00 に変更します(デフォルトでは 0.00 に設定されているはずです)。

  • コントラスト強調 見出しの下に、 Current ドロップダウンリストの値を MinMaxにストレッチ に変更します。

  • OK をクリックします。「降水量」ラスターは、見える場合は、画素毎に異なる輝度値が見えるように、色を変更しなければなりません。

  • DEMのためにこのプロセスを繰り返し、ストレッチするために使用される標準偏差を 4.00 に設定します。

9.4.7. レイヤ順の変更

  • レイヤーの一覧 中で、レイヤーをクリックおよび上下にドラッグして地図上に表示される順序を変更します。

  • QGIS の新しいバージョンでは、レイヤリスト 下に レンダリング順序を制御 チェックボックスがあるかもしれません。それがチェックされていることを確認してください。

これですべてのデータがロードされ正常に表示されますので、分析を開始できます。クリッピング操作が最初に行われるならば、最高です。使用するつもりのない領域の値を計算することに処理能力を無駄使いしないようにするためです。

9.4.8. 正しい地区の検索

  • ベクタレイヤ admin_boundaries/Western_Cape_UTM33S.shp を地図にロードします。

  • Districts にリネームします。

  • レイヤリスト 内で Districts レイヤを右クリックします。

  • 表示されるメニューで、 クエリ... メニュー項目を選択します。 クエリBuilder ダイアログが表示されます。

今、地区の次のリストだけを選択するためのクエリを作成します:

  • Bellville,
  • Cape,
  • Goodwood,
  • Kuils River,
  • Mitchells Plain,
  • Simons Town, そして

  • Wynberg.
  • フィールド リスト中で NAME_2 フィールドをダブルクリックします。以下の SQLのwhere句 のテキストフィールドに表示されます。

  • = ボタンをクリックし、 = 記号がSQLクエリに追加されます。

  • (現在空) リストの下の ALL ボタンをクリックします。短い遅延の後、これは選択したフィールドの値(NAME_2 )を持つ リストを移入します。

  • リストの中で Bellville をダブルクリックします。前述のように、これはSQLクエリに追加されます。

複数の地区を選択するためには、OR ブール演算子を使用する必要があります。

  • OR ボタンをクリックすると、それがSQLクエリに追加されます。

  • 上記と同様のプロセスを使用して、既存のSQLクエリに次の行を追加します。

    "NAME_2" = 'Cape'
    
  • 別の:kbd:OR 演算子を追加し、その後、同様の方法で、上記の地区のリストを通して作業を続けます。

  • 最終的なクエリはこうであるべきです

    "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
    "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
    'Simons Town' OR "NAME_2" = 'Wynberg'
  • OK をクリックします。地図に表示される地区は現在、上記のリストのものに限定されています。

9.4.9. ラスタのクリップ

今、興味の領域を持っている、このエリアへのラスタをクリップできます。

  • 見えるレイヤーは DEMRainfallDistricts レイヤーだけであることを確認してください。

  • Districts は見えるように最上になければなりません。

  • ラスター->抽出->Clipper メニュー項目を選択することにより、クリッピングダイアログを開きます。

  •  入力ファイル(ラスタ)レイヤー ドロップダウンリストで DEM レイヤーを選択します。

  • 選択... ボタンをクリックして、 出力ファイル テキストフィールドに出力先を指定します。

  • Rasterprac ディレクトリに移動します。

  • ファイル名を入力します。

  • ファイルを保存します。データ値なし チェックボックスはチェックなしのままにしておきます。

  • 正しいラジオボタンが選択されていることを確保することによって 範囲 クリッピングモードを使用してください。

  • 地区を含む領域が選択されるように、キャンバス内のエリアをクリックしてドラッグ。

  • 終了時にキャンバスにロード ボックスをチェックします。

  • OK をクリックします。

  • クリッピング操作が完了した後、Clipper ダイアログを閉じないでください。(そうすると、すでに定義されているクリッピング領域を失う原因となります。)

  • 入力ファイル(ラスタ) ドロップダウンリストで Rainfall ラスタを選択し、別の出力ファイル名を選択します。

  • 他のオプションを変更しないでください。以前に描いた既存のクリッピング領域を変更しないでください。すべてのものを同じままに残し、OK をクリックしてください。

  • 第二のクリッピング操作が完了したら、Clipper ダイアログを閉じることができます。

  • マップを保存します。

9.4.10. マップをクリーンアップします。

  • レイヤーリスト から元の 降雨DEM レイヤーを削除します:

  • これらのレイヤ上で右クリックし、 削除 を選択します。

    • これは、記憶装置からデータを削除しません。地図から外すだけです。

  • 街路 レイヤのラベルを無効にします。

    • ラベリング ボタンをクリックします。

    • このレイヤーにラベル付け ボックスのチェックをオフにします。

    • OK をクリックします。

  • 再度 Streets をすべて表示します。

    • レイヤリスト でレイヤを右クリックします。

    • クエリ を選択します。

  • 表示された クエリ ダイアログで、 Clear ボタンをクリックし、 OK をクリックします。

  • データがロードされるまで待ちます。すべての街は今、表示されます。

  • *ラスタレイヤのシンボルを変更する*参照)以前のようにラスタシンボルを変更します。

  • マップを保存します。

  • レイヤーリスト 中のベクトルレイヤーを、横にあるボックスをオフにして非表示できます 。これにより、地図のレンダリングが速くなりますし、時間の節約になります。

陰影起伏を作成するには、この目的のために書かれたプラグインを使用する必要があります。

9.4.11. ラスタ地形解析 プラグインの有効化

このプラグインはQGIS 1.8にデフォルトで含まれています。しかし、それはすぐに表示されない場合があります。それがシステム上でアクセス可能かどうかを確認するには:

  • プラグイン–>プラグインを管理... メニュー項目をクリックしてください。

  • ラスター地形分析プラグイン の隣のボックスが選択されていることを確認します。

  • OK をクリックします。

ラスター->地形分析 メニュー項目を経由して、このプラグインにアクセスできるようになります。

プラグインは、時には特定のPythonモジュールがシステムにインストールされているに依存してもよいことに注意してください。プラグインが欠落している依存関係を訴えながら働くことを拒否すべきである、援助のためのあなたの家庭教師や講師を依頼してください。

9.4.12. 陰影図の作成

  • レイヤーリスト 中で DEM がアクティブレイヤーであることを確認してください(すなわち、それはクリックされたことにより強調表示されている)。

  • ラスター->地形分析->Hillshade メニュー項目をクリックして Hillshade ダイアログを開きます。

  • 出力レイヤーのための適切な場所を指定し、それを hillshade と呼びます。

  • 結果をプロジェクトに追加する をチェックします。

  • OK をクリックします。

  • 処理が完了するのを待ちます。

新しい hillshade レイヤーが レイヤーlist に現れています。

  • レイヤーlist 中で hillshade レイヤーを右クリックし、Properties ダイアログを呼び出します。

  • 透明度 タブをクリックして透明度スライダーを 80% に設定します。

  • ダイアログで OK をクリックします。

  • 透明な陰影起伏がクリップされたDEM上に重ね合わされたときに効果に注意されたいです。

9.4.13. 傾斜

  • ラスター‣地形分析 メニュー項目をクリックします。

  • クリップされたDEMを入力レイヤーとして 傾斜 分析タイプを選択します。

  • 出力の目的のために適切なファイル名と場所を指定します。

  • 結果をプロジェクトに追加する をチェックします。

  • OK をクリックします。

勾配画像が計算され、地図に追加されました。しかし、いつものように単なる灰色の四角形です。何が起こっているかを適切に確認するには、次のようにシンボルを変更します。

  • (いつものようにレイヤーの右クリックメニューを経由して) レイヤー Properties ダイアログを開きます。

  • スタイル タブをクリックします。

  • ( カラーマップ ドロップダウンメニューで) グレースケール となっているところを 疑似カラー に変更します。

  • 標準偏差を使用 ラジオボタンが選択されていることを確認します。

9.4.14. 傾斜方位

  • 傾斜を計算するのと同じアプローチを使用しますが、最初のダイアログボックスで 傾斜方向 を選択します。

定期的にマップを保存することを忘れないで下さい。

9.4.15. ラスタの再階級

  • ラスター‣ラスター計算機 メニュー項目をクリックしてください。

  • 出力レイヤーのための場所として Rasterprac ディレクトリを指定します。

  • プロジェクトに結果を追加 ボックスが選択されていることを確認します。

左の ラスターbands リストに、レイヤーlist 中のすべてのラスタレイヤが表示されます。傾斜レイヤーが 傾斜 という名であれば、それは 傾斜@1 、と表示されます。

傾きが 1560 度の間にあることが必要です。したがって 15 未満 60 超はすべて排除しなければなりません。

  • インタフェースのリスト項目とボタンを使用して以下の式を作成します:

    (([email protected] < 15) OR ([email protected] > 60)) = 0
  • 適切な場所とファイル名で 出力layer フィールドを設定してください。

  • OK をクリックします。

同じアプローチを使用して正しい向き(東向き 45135 度の間)を見つけます。

すべてのラスタを再分類した今、それらは(それらは正しく地図に追加されていると仮定して)自分の地図に灰色の長方形として表示が表示されます。( 10 はtrueまたはfalseを意味する)2つのクラスだけでラスタデータを正しく表示するには、それらのシンボルを変更する必要があります。

9.4.16. 再階級されたレイヤのスタイルの設定

  • いつものように、レイヤーの プロパティ ダイアログ中で スタイル タブを開きます。

  • bandから最小/最大値ロード 見出しの下の 実際(遅い) ラジオボタンを選択します。

  • 読み込み ボタンをクリックします:

今 :guilabel: カスタム最小/最大値`フィールドにそれぞれ :kbd:`01 を取り込む必要があります。(そうでない場合、そこのデータの再分類と間違いだった、と再びその部分の上に移動する必要があります。)

  • コントラスト強調 見出しの下で Current`ドロップダウンリストを :guilabel:`MinMaxへストレッチする に設定します。

  • OK をクリックします。

  • 3つのすべてのためにこれを行うには、ラスタを再分類し、作業を保存することを忘れないでください!

残る唯一の基準は、その領域が都市地域から 250m 離れてなければならないことです。計算領域が農村地域の端から 250m 以上であることを確実にすることによって、この要件を満たします。したがってまず、すべての農村地域を見つける必要があります。

9.4.17. 農村地域の検索

  • レイヤリスト ですべてのレイヤを非表示にします。

  • Zoning を再表示します。

  • その上で右クリックして Query ダイアログを起動します。

  • 次のクエリをビルドします:

    "Gen_Zoning" = 'Rural'
    

    行き詰まったら Streets クエリを構築するための以前の説明書を参照してください。

  • それを実行したら クエリ ダイアログを閉じます。

Zoning レイヤーからポリゴンのコレクションが表示されるはずです。新しいレイヤファイルにこれらを保存する必要があります。

  • Zoning の右クリックメニューで 名前を付けて保存... を選択します。

  • Zoning ディレクトリの下にレイヤーを保存します。

  • 出力ファイル名を rural.shp とします。

  • OK をクリックします。

  • レイヤをマップに追加します。

  • ベクター‣ジオプロセシングツール ‣ディゾルブ をクリックします。

  • 選択地物のみ使用 ボックスのチェックはないままで、入力ベクトルレイヤーとして rural レイヤーを選択します。

  • ディゾルブfield の下で、 —すべてをディゾルブ— を選択します。

  • Zoning ディレクトリの下にレイヤーを保存します。

  • OK をクリックします。TOC(「目次」 レイヤーlist に言及)に新しいレイヤーを追加するかどうかを確認するダイアログが表示されます。

  • はい をクリックします。

  • ディゾルブ ダイアログを閉じます。

  • ruralZoning レイヤーを外します。

  • マップを保存します。

今、農村地域の端から 250m 内にある領域を除外する必要があります。以下に説明するように、負のバッファを作成することによってこれを行います。

9.4.18. 負のバッファを作成します

  • メニュー項目 ベクトル‣バッファ‣ジオプロセシングツール をクリックしてください。

  • 表示されるダイアログで、入力ベクトルレイヤーとして rural_dissolve レイヤーを選択します( 選択された地物のみ使用 はチェックすべきではありません)。

  • バッファ距離 ボタンを選択し、関連するフィールドに値 -250 を入力してください。負の値は、バッファが内部バッファでなければならないことを意味しています。

  • バッファ結果をディゾルブする ボックスにチェックします。

  • 他の地方のベクトルファイルと同じディレクトリに出力ファイルを設定します。

  • 出力ファイル名を rural_buffer.shp とします。

  • 保存 をクリックします。

  • OK をクリックして処理が完了するのを待ちます。

  • 現れたダイアログで はい を選択します。

  • バッファ ダイアログを閉じます。

  • rural_dissolve レイヤを削除します。

  • マップを保存します。

3つの既存のラスタと同じ分析に農村地帯を組み込むためには、それは同様にラスタライズする必要があります。しかし、ラスタは、分析のために互換性があるようにするために、同じサイズにする必要があります。そのため、ラスタライズする前に次の3つのラスタと同じエリアにベクトルをクリップする必要があります。ベクトルは別のベクトルによってクリップできるのみなので、最初にラスタと同じサイズのバウンディングボックスポリゴンを作成する必要があります。

9.4.19. バウンディングボックスベクタの作成

  • メニュー項目 レイヤー - >新規 - >新規シェープファイルのレイヤ... をクリックしてください。

  • type 見出しの下で Polygon ボタンを選択します。

  • CRSを指定 をクリックし、基準座標系を :kbd:` WGS 84/UTMゾーン33S:EPSG:32733` に設定します。

  • OKをクリックします。

  • 新しいベクトルレイヤー ダイアログでも OK をクリックします。

  • Zoning ディレクトリにベクタを保存します。

  • 出力ファイル名を bbox.shp とします。

  • 新しい bbox レイヤーと再分類ラスタのレイヤーを除くすべてのレイヤーを非表示にします。

  • レイヤーリストbbox レイヤーが強調表示されていることを確認してください。

  • 表示>ツールバー メニュー項目に移動し、 Digitizing が選択されていることを確認します。その後、その上に鉛筆やコーキーと、ツールバーのアイコンが表示されるはずです。 編集を切り替え ボタンです。

  • 編集を切り替え ボタンをクリックして 編集モード に入ってください。これにより、ベクトルレイヤーが編集できるようになります。

  • 地物を追加 ボタンをクリックします、編集を切り替え ボタンの近くにあるはずです。これは、二重の矢印ボタンの後ろに隠れてすることができます。 Digitizing ツールバーの非表示のボタンもしそうなら、表示するために二重矢印をクリックしてください。

  • 地物を追加 ツールをアクティブにして、ラスタの角を左クリックしてください。それが正確であることを保証するために、マウスのホイールでズームインする必要があるかもしれません。このモードでは、地図をパンするには、マウスの中央ボタンかマウスホイールをクリックしたまま地図内でドラッグします。

  • 第四及び最終点に関しては、形状を確定するために右クリックします。

  • シェープIDの任意の番号を入力します。

  • OK をクリックします。

  • 編集を保存 ボタンをクリックします。

  • 編集セッションを停止するには、 :guilabel: 編集を切り替え ボタンをクリックしてください。

  • マップを保存します。

これでバウンディングボックスができましたので、農村地域のバッファレイヤーをクリップするためにそれを使用できます。

9.4.20. ベクタレイヤのクリップ

  • bboxrural_buffer レイヤーだけが、後者を上にして、表示されていることを確認してください。

  • ベクタ>ジオプロセシングツール>クリップ メニュー項目をクリックしてください。

  • 表示されたダイアログで、入力ベクトルレイヤーを rural_buffer に、クリップレイヤーを bbox に、両方とも 選択地物のみ使用 ボックスをチェックしないで、設定します。

  • Zoning ディレクトリの下に、出力ファイルを置きます。

  • 出力ファイル名を rural_clipped とします。

  • OK をクリックします。

  • TOCにレイヤーを追加するように求められたら、:guilabel: Yes をクリックしてください。

  • ダイアログを閉じます。

  • 3つのベクトルを比較し、自分のために結果を参照してください。

  • bboxrural_buffer レイヤーを削除し、地図を保存します。

これでラスタライズする準備ができました。

9.4.21. ベクタレイヤのラスタ化

作成した新しいラスタのピクセルサイズを指定する必要がありますので、まず既存のラスタの1の大きさを知っておく必要があります。

  • 3つの既存のラスタのいずれかの Properties ダイアログを開きます。

  • メタデータ タブに切り替えます。

  • メタデータテーブルの Dimensions 見出しの下 XY 値を書き留めておきます。

  • プロパティ ダイアログを閉じます。

  • ラスター->変換->Rasterize メニュー項目 をクリックしてください。データセットがサポートされていないことについて警告を受けることがあります。それをクリックして消し、無視します。

  • 入力レイヤとして rural_clipped を選択します。

  • Zoning ディレクトリ内の出力ファイルの場所を設定します。

  • 出力ファイル名を rural_raster.tif とします。

  • 新しいsize ボックスをチェックし、 XY に以前にノートにとった値を入力します。

  • キャンバスにロードします ボタンをチェックします。

  • 実行されるコマンドを表示するテキストフィールドの隣にある鉛筆アイコンをクリックします。既存のテキストの最後に、スペースを追加し、それからテキスト -burn 1 を追加します。これは、新しい ラスタ に既存の ベクタ を「焼き」、 ベクタ で覆われた領域に新たな 1 の値を与えるようラスタライズ機能に告げる(画像の残りの部分、自動的に 0 にされる、とは反対に)。

  • OK をクリックします。

  • それが計算された後、新たなラスタが地図に表示されるはずです。

  • 新しいラスタはグレーの長方形のようになります - 再分類ラスタのために行ったように、表示スタイルを変更できます。

  • マップを保存します。

今、全4つの基準それぞれを別々のラスタに持っていますので、領域がすべての基準を満たすかを確認するためにそれらを組み合わせる必要があります。それをするために、ラスタは互いに乗算されます。これが発生するとき、すべての重なる画素が値 1 を持つ場合は値 1 を保持しますが、画素で4つのラスタのいずれかに 0 値がある場合はその結果においては 0 になります。このようにして、結果には重なる領域だけが含まれます。

9.4.22. ラスタの結合

  • ラスタ‣ラスタ計算機... をクリックします。

  • (それらを呼ばれるものに応じて、そのレイヤーのための適切な名前で)次の式を構築します。

    [Rural raster] * [Reclassified aspect] * [Reclassified slope] *
    [Reclassified rainfall]
  • 出力場所を Rasterprac ディレクトリに設定します。

  • 出力ラスタの名称を cross_product.tif とします。

  • 結果をプロジェクトに追加する ボックスがチェックされていることを確認します。

  • OKをクリックします。

  • 他の再分類ラスタのスタイルを設定するのと同じ方法で、新しいラスタのシンボルを変更します。新しいラスタが正しく、すべての基準が満たされている領域を表示します。

最終的な結果を得るには、6000m2 より大きい領域を選択する必要があります。しかし、これらの領域を正確に計算することは ベクタレイヤ でのみ可能なので、ラスターをベクタ化する必要があります。

9.4.23. ラスタのベクタライズ

  • メニュー項目 ラスター->変換->Polygonize をクリックしてください。

  • cross_product ラスタを選択します。

  • 出力場所を Rasterprac に設定します。

  • candidate_areas.shp と改名します。

  • 終了時にキャンバスにロードします ボタンがチェックされていることを確認します。

  • OKをクリックします。

  • 処理が完了したらダイアログを閉じます。

ラスタのすべてのエリアはベクトル化されているので、1 の値を持っている領域だけを選択する必要があります。

  • 新しいベクターのため クエリ ダイアログを開きます。

  • クエリのビルド:

    "DN" = 1
    
  • OK をクリックします。

  • クエリが完了した後 candidate_areas ベクトルを保存することで、結果から新しいベクトルファイルを作成します(との値を持つ領域のみ 1 が表示されています)。このためのレイヤーの右クリックメニュー中の 名前を付けて保存... 機能を使用してください。

  • Rasterprac ディレクトリにファイルを保存します。

  • 候補領域のみ.shp と名前を付けます。

  • マップを保存します。

9.4.24. 各ポリゴンの面積の計算

  • 新規ベクタレイヤの右クリックメニューを表示します。

  • 属性テーブルを開く を選択します。

  • テーブルの下に沿った 編集モード切り替え ボタンをクリックするか、Ctrlキー+E を押します。

  • テーブル底部に沿った フィールドcalculatorを開く ボタンをクリックするか、Ctrlキー+I を押します。

  • 表示されるダイアログ中の 新しいフィールド 見出しの下に、フィールド名 面積 を入力します。出力フィールド型は整数、フィールド幅は 10 でなければならない。

  • フィールド演算式 に、タイプします:

    $area

    計算された値で、このフィールドの計算は、ベクトルレイヤーの各ポリゴンの面積を計算し、次いで( 面積 と呼ばれる)新しい整数列を移入することを意味します。

  • OK をクリックします。

  • id と呼ばれる別の新しいフィールドに同じことを行います。フィールド電卓expression 中にタイプします:

    $id

    これは、各ポリゴンは識別目的のためのユニークなIDを持っていることを保証します。

  • 再び 編集モード切り替え をクリックし、編集内容を保存するようプロンプトが表示されたら、そうします。

9.4.25. 与えられたサイズの面積を選択

今このエリアは知られています:

  • 6000メートルm2 よりも大きなポリゴンのみを選択するように(いつものように)クエリを作成します。クエリは次のとおりです。

    "area" > 6000
    
  • 選択を solution.shp と呼ばれる新しい ベクタレイヤ として保存します。

今はもう解領域が出ているので、家に最も近いものを選択します。

9.4.26. あなたの家のデジタイズ

  • 以前のように新しいベクトルレイヤーを作成しますが、今回は type 値が Point となるよう選択します。

  • それが正しいCRSであることを確認します!

  • 新規レイヤを house.shp とします。

  • 新規レイヤ作成の完了

  • (新規レイヤが選択された状態で)編集モードにします。

  • 街路をガイドとして使用しながら、家または居住の他の現在の場所がある点をクリックします。家を見つけるのを助けるために他のレイヤーを開く必要があります。近くのどこにも住んでいない場合は、単に家が考えられるかもしれない街の中のどこかをクリックします。

  • シェープIDの任意の番号を入力します。

  • OK をクリックします。

  • 編集内容を保存し、編集モードを終了します。

  • マップを保存します。

どれが家に最も近いかを決定するため、ソリューションエリアのポリゴンの重心(「質量中心」)を見つける必要があります。

9.4.27. ポリゴンの中心点の算出

  • ベクトル->ジオメトリツール->ポリゴンcentroids メニュー項目をクリックします。

  • 入力レイヤーを solution.shp と指定します。

  • 出力場所を Rasterprac と与えます。

  • 出力先ファイル solution_centroids.shp を呼び出します。

  • OK をクリックし、TOCに結果を追加し(レイヤーリスト)、その後ダイアログを閉じます。

  • 新しいレイヤーを、見えるようレイヤーの順序の一番上にドラッグします。

9.4.28. あなたの家に最も近い重心の計算

  • ベクトル- >分析ツール - >距離matrix メニュー項目をクリックしてください。

  • 入力 レイヤ はあなたの家、ターゲット レイヤ は solution_centroids である必要があります。これらの両方とも、ユニークなIDフィールドとして id フィールドを使用する必要があります。

  • 出力マトリクス型は linear になるはずです。

  • 適切な出力場所と名前を設定します。

  • OK をクリックします。

  • テキストエディタでファイルを開きます(またはスプレッドシートにインポート)。最短 距離 に関連付けられたターゲットIDに注意してください。同距離に複数あることもあります。

  • 家に最も近い唯一のソリューション領域を選択するために、QGISでクエリを作成します(id フィールド使用してそれを選択する)。

これは、研究の質問への最終的な答えです。

提出のために、お好みの魅力的な ラスタ (例えば DEM とか 傾斜 ラスタ、など)の上に半透明の陰影起伏の レイヤ を、また、最も近いソリューション領域(複数可)のポリゴンだけでなく、家を含めます。 出力 図を作成する際は地図作成のためのすべてのベストプラクティスに従ってください。