17. Working with Mesh Data

17.1. What’s a mesh?

A mesh is an unstructured grid usually with temporal and other components. The spatial component contains a collection of vertices, edges and/or faces, in 2D or 3D space:

  • vertices - XY(Z) points (in the layer’s coordinate reference system)

  • edges - connect pairs of vertices

  • faces - a face is a set of edges forming a closed shape - typically a triangle or a quadrilateral (quad), rarely polygons with more vertices

Relying on the above, mesh layers can thus have different types of structure:

  • 1D Meshes: consist of vertices and edges. An edge connects two vertices and can have assigned data (scalars or vectors) on it. The 1D mesh network can be for example used for modelling of an urban drainage system.

  • 2D meshes: consist of faces with triangles, regular or unstructured quads.

  • 3D layered meshes: consist of multiple stacked 2D unstructured meshes each extruded in the vertical direction (levels) by means of a vertical coordinate. The vertices and faces have the same topology in each vertical level. The mesh definition (vertical level extrusion) could in general change in time. The data is usually defined in volume centres or by some parametric function.

../../../_images/mesh_grid_types.png

Fig. 17.1 Different mesh types

Mesh provides information about the spatial structure. In addition, the mesh can have datasets (groups) that assign a value to every vertex. For example, having a triangular mesh with numbered vertices as shown in the image below:

../../../_images/triangual_grid_with_numered_vertices.png

Fig. 17.2 Triangular grid with numbered vertices

Each vertex can store different datasets (typically multiple quantities), and those datasets can also have a temporal dimension. Thus, a single file may contain multiple datasets.

The following table gives an idea about the information that can be stored in mesh datasets. Table columns represent indices of mesh vertices, each row represents one dataset. Datasets can have different datatypes. In this case, it stores wind velocity at 10m at a particular moments in time (t1, t2, t3).

In a similar way, the mesh dataset can also store vector values for each vertex. For example, wind direction vector at the given time stamps:

Table 17.1 Example of mesh dataset

10 metre wind

1

2

3

10 metre speed at time=t1

17251

24918

32858

10 metre speed at time=t2

19168

23001

36418

10 metre speed at time=t3

21085

30668

17251

10m wind direction time=t1

[20,2]

[20,3]

[20,4.5]

10m wind direction time=t2

[21,3]

[21,4]

[21,5.5]

10m wind direction time=t3

[22,4]

[22,5]

[22,6.5]

We can visualize the data by assigning colors to values (similarly to how it is done with Singleband pseudocolor raster rendering) and interpolating data between vertices according to the mesh topology. It is common that some quantities are 2D vectors rather than being simple scalar values (e.g. wind direction). For such quantities it is desirable to display arrows indicating the directions.

../../../_images/mesh_visualisation.png

Fig. 17.3 Possible visualisation of mesh data

17.2. Supported formats

QGIS accesses mesh data using the MDAL drivers, and natively supports a variety of formats. Whether QGIS can edit a mesh layer depends on the format and the mesh structure type.

To load a mesh dataset into QGIS, use the addMeshLayer Mesh tab in the Data Source Manager dialog. Read Loading a mesh layer for more details.

17.3. Mesh Dataset Properties

The Layer Properties dialog for a mesh layer provides general settings to manage dataset groups of the layer and their rendering (active dataset groups, symbology, 2D and 3D rendering). It also provides information about the layer.

To access the Layer Properties dialog:

  • In the Layers panel, double-click the layer or right-click and select Properties… from the pop-up menu;

  • Go to Layer ► Layer Properties… menu when the layer is selected.

The mesh Layer Properties dialog provides the following sections:

Table 17.2 Tabs of the Mesh Layer Properties

metadata Information

system Source

symbology Symbology[1]

3d 3D View[1]

temporal Temporal

elevationscale Elevation

rendering Rendering

editMetadata Metadata

[1] Also available in the Layer styling panel

Note

Most of the properties of a mesh layer can be saved to or loaded from a .qml using the Style menu at the bottom of the dialog. More details at Managing Custom Styles.

17.3.1. Information Properties

../../../_images/mesh_info_properties.png

Fig. 17.4 Mesh Layer Information Properties

The metadata Information tab is read-only and represents an interesting place to quickly grab summarized information and metadata on the current layer. Provided information are:

  • general such as name in the project, source path, list of auxiliary files, last save time and size, the used provider

  • based on the provider of the layer: extent, vertex, face, edges and/or dataset groups count

  • the Coordinate Reference System: name, units, method, accuracy, reference (i.e. whether it’s static or dynamic)

  • extracted from filled metadata: access, extents, links, contacts, history…

17.3.2. Source Properties

The system Source tab displays basic information about the selected mesh, including:

../../../_images/mesh_source.png

Fig. 17.5 Mesh Layer Source Properties

  • the layer name to display in the Layers panel

  • setting the Coordinate Reference System: Displays the layer’s Assigned Coordinate Reference System (CRS). You can change the layer’s CRS by selecting a recently used one in the drop-down list or clicking on setProjection Select CRS button (see Coordinate Reference System Selector). Use this process only if the CRS applied to the layer is wrong or if none was applied.

  • The Available datasets frame lists all the dataset groups (and subgroups) in the mesh layer, with their type and description in a tree view. Both regular datasets (i.e. their data is stored in the file) and virtual datasets (which are calculated on the fly) are listed.

    • Use the add Assign extra dataset to mesh button to add more groups to the current mesh layer.

    • collapseTree Collapse all and expandTree Expand all the dataset tree, in case of embedded groups

    • If you are interested in few datasets, you can uncheck the others and make them unavailable in the project

    • Double-click over a name and you can rename the dataset.

    • refresh Reset to defaults: checks all the groups and renames them back to their original name in the provider.

    • Right-click over a virtual dataset group and you can:

      • Remove dataset group from the project

      • Save dataset group as… a file on disk, to any supported format. The new file is kept assigned to the current mesh layer in the project.

  • Checking the unchecked Treat as static dataset group allows to ignore the map temporal navigation properties while rendering the mesh layer. For each active dataset group (as selected in symbology Symbology ► general Datasets tab), you can:

    • set to None: the dataset group is not displayed at all

    • Display dataset: e.g., for the “bed elevation” dataset which is not time aware

    • extract a particular date time: the dataset matching the provided time is rendered and stay fixed during map navigation.

17.3.3. Symbology Properties

Click the symbology Symbology button to activate the dialog. Symbology properties are divided into several tabs:

17.3.3.1. Datasets

The tab general Datasets is the main place to control and set which datasets will be used for the layer. It presents the following items:

  • Groups available in the mesh dataset, with whether they provide:

    • meshcontoursoff scalar dataset

    • or meshvectorsoff vector dataset: by default, each vector dataset has a scalar dataset representing its magnitude automatically generated.

    Click on the icon next to the dataset name to select the group and type of data to represent.

  • Selected dataset group(s) metadata, with details on:

    • the mesh type: edges or faces

    • the data type: vertices, edges, faces or volume

    • whether it’s of vector type or not

    • the original name in the mesh layer

    • the unit, if applicable

  • blending mode available for the selected datasets.

../../../_images/mesh_symbology_datasets.png

Fig. 17.6 Mesh Layer Datasets

You can apply symbology to the selected vector and/or scalar group using the next tabs.

17.3.3.2. Contours Symbology

Note

The meshcontours Contours tab can be activated only if a scalar dataset has been selected in the general Datasets tab.

In the meshcontours Contours tab you can see and change the current visualization options of contours for the selected group, as shown in Fig. 17.7 below:

../../../_images/mesh_symbology_contours.png

Fig. 17.7 Styling Contours in a Mesh Layer

  • For 1D mesh, set the Stroke width of the edges. This can be a fixed size for the whole dataset, or vary along the geometry (more details with the interpolated line renderer)

  • Use the slider or the spinbox to set the Opacity of the current group, if of a 2D mesh type.

  • Enter the range of values you want to represent on the current group: use refresh Load to fetch the min and max values of the current group or enter custom values if you want to exclude some.

  • For 2D/3D meshes, select the Resampling method to interpolate the values on the surrounding vertices to the faces (or from the surrounding faces to the vertices) using the Neighbour average method. Depending on whether the dataset is defined on the vertices (respectively on the faces), QGIS defaults this setting to None (respectively Neighbour average) method in order to use values on vertices and keep the default rendering smooth.

  • Classify the dataset using the color ramp shader classification.

17.3.3.3. Vectors Symbology

Note

The meshvectors Vectors tab can be activated only if a vector dataset has been selected in the general Datasets tab.

In the meshvectors Vectors tab you can see and change the current visualization options of vectors for the selected group, as shown in Fig. 17.8:

../../../_images/mesh_symbology_vectors.png

Fig. 17.8 Styling Vectors in a Mesh Layer with arrows

Mesh vector dataset can be styled using various types of Symbology:

  • Arrows: vectors are represented with arrows at the same place as they are defined in the raw dataset (i.e. on the nodes or center of elements) or on a user-defined grid (hence, they are evenly distributed). The arrow length is proportional to the magnitude of the arrow as defined in the raw data but can be scaled by various methods.

  • Streamlines: vectors are represented with streamlines seeded from start points. The seeding points can start from the vertices of the mesh, from a user grid or randomly.

  • Traces: a nicer animation of the streamlines, the kind of effect you get when you randomly throws sand in the water and see where the sand items flows.

Available properties depend on the selected symbology as shown in the following table.

Table 17.3 Availability and meaning of the vectors symbology properties

Label

Description and Properties

Arrow

Streamlines

Traces

Line width

Width of the vector representation

checkbox

checkbox

checkbox

Coloring method

  • a Single color assigned to all vectors

  • or a variable color based on vectors magnitude, using a Color ramp shader

checkbox

checkbox

checkbox

Filter by magnitude

Only vectors whose length for the selected dataset falls between a Min and Max range are displayed

checkbox

checkbox

Display on user grid

Places the vector on a grid with custom X spacing and Y spacing and interpolates their length based on neighbours

checkbox

checkbox

Head options

Length and Width of the arrow head, as a percentage of its shaft length

checkbox

Arrow length

  • Defined by Min and Max: You specify the minimum and maximum length for the arrows, QGIS will interpolate their size based on the underlying vector’s magnitude

  • Scale to magnitude: arrow length is proportional to their vector’s magnitude

  • Fixed: all the vectors are shown with the same length

checkbox

Streamlines seeding method

  • On mesh/grid: relies on the user grid to display the vectors

  • Randomly: vector placement is randomly done with respect to a certain density

checkbox

Particles count

The amount of “sand” you want to throw into visualisation

checkbox

Max tail length

The time until the particle fades out

checkbox

17.3.3.4. Rendering

In the tab meshframe Rendering tab, QGIS offers possibilities to display and customize the mesh structure. Line width and Line color can be set to represent:

  • the edges for 1D meshes

  • For 2D meshes:

    • Native mesh rendering: shows original faces and edges from the layer

    • Triangular mesh rendering: adds more edges and displays the faces as triangles

../../../_images/mesh_symbology_grid.png

Fig. 17.9 2D Mesh Rendering

17.3.3.5. Stacked mesh averaging method

3D layered meshes consist of multiple stacked 2D unstructured meshes each extruded in the vertical direction (levels) by means of a vertical coordinate. The vertices and faces have the same topology in each vertical level. Values are usually stored on the volumes that are regularly stacked over base 2d mesh. In order to visualise them on 2D canvas, you need to convert values on volumes (3d) to values on faces (2d) that can be shown in mesh layer. The meshaveraging Stacked mesh averaging method provides different averaging/interpolation methods to handle this.

You can select the method to derive the 2D datasets and corresponding parameters (level index, depth or height values). For each method, an example of application is shown in the dialog but you can read more on the methods at https://fvwiki.tuflow.com/index.php?title=Depth_Averaging_Results.

17.3.4. 3D View Properties

Mesh layers can be used as terrain in a 3D map view based on their vertices Z values. From the 3d 3D View properties tab, it’s also possible to render the mesh layer’s dataset in the same 3D view. Therefore, the vertical component of the vertices can be set equal to dataset values (for example, level of water surface) and the texture of the mesh can be set to render other dataset values with color shading (for example velocity).

../../../_images/mesh_3d.png

Fig. 17.10 Mesh dataset 3D properties

Check checkbox Enable 3D Renderer and you can edit following properties:

  • Under Triangle settings

    • Smooth triangles: Angles between consecutive triangles are smoothed for a better 3D rendering

    • Show wireframe whose you can set the Line width and Color

    • Level of detail: Controls how simplified the mesh layer to render should be. On the far right, it is the base mesh, and the more you go left, the more the layer is simplified and is rendered with less details. This option is only available if the Simplify mesh option under the Rendering tab is activated.

  • Vertical settings to control behavior of the vertical component

    of vertices of rendered triangles

    • Dataset group for vertical value: the dataset group that will be used for the vertical component of the mesh

    • uncheckedDataset value relative to vertices Z value: whether to consider the dataset values as absolute Z coordinate or relative to the vertices native Z value

    • Vertical scale: the scale factor to apply to the dataset Z values

  • Rendering color settings with a Rendering style that can be based on the color ramp shader set in Contours Symbology (2D contour color ramp shader) or as a Single color with an associated Mesh color

  • Show arrows: displays arrows on mesh layer dataset 3D entity, based on the same vector dataset group used in the vector 2D rendering. They are displayed using the 2D color setting. It’s also possible to define the Arrow spacing and, if it’s of a Fixed size or scaled on magnitude. This spacing setting defines also the max size of arrows because arrows can’t overlap.

17.3.5. Rendering Properties

Under the Scale dependent visibility group box, you can set the Maximum (inclusive) and Minimum (exclusive) scale, defining a range of scale in which mesh elements will be visible. Out of this range, they are hidden. The mapIdentification Set to current canvas scale button helps you use the current map canvas scale as boundary of the range visibility. See Scale Dependent Rendering for more information.

../../../_images/mesh_rendering.png

Fig. 17.11 Mesh rendering properties

As mesh layers can have millions of faces, their rendering can sometimes be very slow, especially when all the faces are displayed in the view whereas they are too small to be viewed. To speed up the rendering, you can simplify the mesh layer, resulting in one or more meshes representing different levels of detail and select at which level of detail you would like QGIS to render the mesh layer. Note that the simplify mesh contains only triangular faces.

From the rendering Rendering tab, check checkbox Simplify mesh and set:

  • a Reduction factor: Controls generation of successive levels of simplified meshes. For example, if the base mesh has 5M faces, and the reduction factor is 10, the first simplified mesh will have approximately 500 000 faces, the second 50 000 faces, the third 5000,… If a higher reduction factor leads quickly to simpler meshes (i.e. with triangles of bigger size), it produces also fewer levels of detail.

  • Minimum triangle size: the average size (in pixels) of the triangles that is permitted to display. If the average size of the mesh is lesser than this value, the rendering of a lower level of details mesh is triggered.

17.3.6. Temporal Properties

The temporal Temporal tab provides options to control the rendering of the layer over time. It allows to dynamically display temporal values of the enabled dataset groups. Such a dynamic rendering requires the temporal navigation to be enabled over the map canvas.

../../../_images/mesh_temporal.png

Fig. 17.12 Mesh Temporal properties

Layer temporal settings

  • Reference time of the dataset group, as an absolute date time. By default, QGIS parses the source layer and returns the first valid reference time in the layer’s dataset group. If unavailable, the value will be set by the project time range or fall back to the current date. The Start time and End time to consider are then calculated based on the internal timestamp step of the dataset.

    It is possible to set a custom Reference time (and then the time range), and revert the changes using the refresh Reload from provider button.

  • Dataset matching method: determines the dataset to display at the given time. Options are Find closest dataset before requested time or Find closest dataset from requested time (after or before).

Provider time settings

  • Time unit extracted from the raw data, or user defined. This can be used to align the speed of the mesh layer with other layers in the project during map time navigation. Supported units are Seconds, Minutes, Hours and Days.

17.3.7. Elevation Properties

The elevationscale Elevation tab provides options to control the layer elevation properties within a 3D map view and its appearance in the profile tool charts. Specifically, you can set:

../../../_images/mesh_elevation.png

Fig. 17.13 Mesh Elevation properties

  • Elevation Surface: how the mesh layer vertices Z values should be interpreted as terrain elevation. You can apply a Scale factor and an Offset.

  • Profile Chart Appearance: controls the rendering Style the mesh elevation will use when drawing a profile chart. It can be set as:

17.3.8. Metadata Properties

The editMetadata Metadata tab provides you with options to create and edit a metadata report on your layer. See Metadata for more information.

17.4. Editing a mesh layer

QGIS allows to create a mesh layer from scratch or based on an existing one. You can create/modify the geometries of the new layer whom you can assign datasets afterwards. It’s also possible to edit an existing mesh layer. Because the editing operation requires a frames-only layer, you will be asked to either remove any associated datasets first (make sure you have them available if they still are necessary) or create a copy (only geometries) of the layer.

Note

QGIS does not allow to digitize edges on mesh layers. Only vertices and faces are mesh elements that can be created. Also not all supported mesh formats can be edited in QGIS (see permissions).

17.4.1. Overview of the mesh digitizing tools

To interact with or edit a base mesh layer element, following tools are available.

Table 17.4 Tools for mesh digitizing

Label

Purpose

Location

allEdits Current Edits

Access to save, rollback or cancel changes in all or selected layers simultaneously

Digitizing toolbar

toggleEditing Toggle to Edit

Turn on/off the layer in edit mode

Digitizing toolbar

saveEdits Save Edits

Save changes done to the layer

Digitizing toolbar

undo Undo

Undo the last change(s) - Ctrl+Z

Digitizing toolbar

redo Redo

Redo the last undone action(s) - Ctrl+Shift+Z

Digitizing toolbar

cad Enable Advanced Digitizing tools

Turn on/off the Advanced Digitizing Panel

Advanced Digitizing toolbar

meshReindex Reindex Faces and Vertices

Recreate index and renumber the mesh elements for optimization

Mesh menu

meshDigitizing Digitize Mesh Elements

Select/Create vertices and faces

Mesh Digitizing toolbar

meshSelectPolygon Select Mesh Elements by Polygon

Select vertices and faces overlapped by a drawn polygon

Mesh Digitizing toolbar

meshSelectExpression Select Mesh Elements by Expression

Select vertices and faces using an expression

Mesh Digitizing toolbar

meshTransformByExpression Transform Vertices Coordinates

Modify coordinates of a selection of vertices

Mesh Digitizing toolbar

meshEditForceByVectorLines Force by Selected Geometries

Split faces and constrain Z value using a linear geometry

Mesh Digitizing toolbar

17.4.2. Exploring the Z value assignment logic

When a mesh layer is turned into edit mode, a Vertex Z value widget opens at the top right of the map canvas. By default, its value corresponds to the Default Z value set in Settings ► Options ► Digitizing tab. When there are selected vertices, the widget displays the average Z value of the selected vertices.

During editing, the Vertex Z value is assigned to new vertices. It is also possible to set a custom value: edit the widget, press Enter and you will override the default value and make use of this new value in the digitizing process. Click the clearText icon in the widget to reset its value to the Options default value.

17.4.2.1. Rules of assignment

When creating a new vertex, its Z value definition may vary depending on the active selection in the mesh layer and its location. The following table displays the various combinations.

Table 17.5 Matrix of Z value assignment to new vertex

Vertex creation

Are there selected vertices in mesh layer?

Source of assigned value

Assigned Z Value

“Free” vertex, not connected to any

face or edge of a face

No

Vertex Z value

Default or user defined

Advanced Digitizing Panel (if z widget is in locked Locked state)

z widget if in locked Locked state

Yes

Vertex Z value

Average of the selected vertices

Vertex on an edge

Mesh layer

Interpolated from the edge’s vertices

Vertex on a face

Mesh layer

Interpolated from the face’s vertices

Vertex snapped to a 2D vector feature

Vertex Z value

Default or user defined

Vertex snapped to a 3D vector vertex

Vector layer

Vertex

Vertex snapped to a 3D vector segment

Vector layer

Interpolated along the vector segment

Note

The Vertex Z value widget is deactivated if the Advanced Digitizing Panel is enabled and no mesh element is selected. The latter’s z widget then rules the Z value assignment.

17.4.2.2. Modifying Z value of existing vertices

To modify the Z value of vertices, the most straightforward way is:

  1. Select one or many vertices. The Vertex Z value widget will display the average height of the selection.

  2. Change the value in the widget.

  3. Press Enter. The entered value is assigned to the vertices and becomes the default value of next vertices.

Another way to change the Z value of a vertex is to move and snap it on a vector layer feature with the Z value capability. If more than one vertex are selected, the Z value can’t be changed in this way.

The Transform mesh vertices dialog also provides means to modify the Z value of a selection of vertices (along with their X or Y coordinates).

17.4.3. Selecting mesh elements

17.4.3.1. Using Digitize Mesh Elements

Activate the meshDigitizing Digitize Mesh Elements tool. Hover over an element and it gets highlighted, allowing you to select it.

  • Click on a vertex, and it is selected.

  • Click on the small square at the center of a face or an edge, and it gets selected. Connected vertices are also selected. Conversely, selecting all the vertices of an edge or a face also selects that element.

  • Drag a rectangle to select overlapping elements (a selected face comes with all their vertices). Press Alt key if you want to select only completely contained elements.

  • To add elements to a selection, press Shift while selecting them.

  • To remove an element from the selection, press Ctrl and reselect it. A deselected face will also deselect all their vertices.

17.4.3.2. Using Select Mesh Elements by Polygon

Activate the meshSelectPolygon Select Mesh Elements by Polygon tool and:

  • Draw a polygon (left-click to add vertex, Backspace to undo last vertex, Esc to abort the polygon and right-click to validate it) over the mesh geometries. Any partially overlapping vertices and faces will get selected. Press Alt key while drawing if you want to select only completely contained elements.

  • Right-click over the geometry of a vector layer’s feature, select it in the list that pops up and any partially overlapping vertices and faces of the mesh layer will get selected. Use Alt while drawing to select only completely contained elements.

  • To add elements to a selection, press Shift while selecting them.

  • To remove an element from the selection, press Ctrl while drawing over the selection polygon.

17.4.3.3. Using Select Mesh Elements by Expression

Another tool for mesh elements selection is meshSelectExpression Select Mesh Elements by Expression. When pressed, the tool opens the mesh expression selector dialog from which you can:

  1. Select the method of selection:

    • Select by vertices: applies the entered expression to vertices, and returns matching ones and their eventually associated edges/faces

    • Select by faces: applies the entered expression to faces, and returns matching ones and their associated edges/vertices

  2. Write the expression of selection. Depending on the selected method, available functions in the Meshes group will be filtered accordingly.

  3. Run the query by setting how the selection should behave and pressing:

    • expressionSelect Select: replaces any existing selection in the layer

    • selectAdd Add to current selection

    • selectRemove Remove from current selection

17.4.4. Modifying mesh elements

17.4.4.1. Adding vertices

To add vertices to a mesh layer:

  1. Press the meshDigitizing Digitize mesh elements button

  2. A Vertex Z value widget appears on the top right corner of the map canvas. Set this value to the Z coordinate you would like to assign to the subsequent vertices

  3. Then double-click:

    • outside a face: adds a “free vertex”, that is a vertex not linked to any face. This vertex is represented by a red dot when the layer is in editing mode.

    • on the edge of existing face(s): adds a vertex on the edge, splits the face(s) into triangles connected to the new vertex

    • inside a face: splits the face into triangles whose edges connect the surrounding vertices to the new vertex.

17.4.4.2. Adding faces

To add faces to a mesh layer:

  1. Press the meshDigitizing Digitize mesh elements button

  2. A Vertex Z value widget appears on the top right corner of the map canvas. Set this value to the Z coordinate you would like to assign to the subsequent vertices.

  3. Double-click to add a first vertex or move the cursor next to a vertex.

  4. Click the small triangle that appears next to the vertex and move the cursor to the next vertex position; you can snap to existing vertex or double-click to add a new one.

  5. Proceed as above to add as many vertices you wish for the face. Press Backspace button to undo the last vertex.

  6. While moving the mouse, a rubberband showing the shape of the face is displayed. If it is shown in green, then the expected face is valid and you can right-click to add it to the mesh. If in red, the face is not valid (e.g. because it self-intersects, overlaps an existing face or vertex, …) and can’t be added. You’d need to fix the geometry.

  7. Press Esc to abort the face digitizing.

  8. Right-click to validate the face.

17.4.4.3. Removing mesh elements

  1. Select the target elements

  2. Enable the meshDigitizing Digitize mesh elements tool

  3. Right-click and select:

    • Remove Selected Vertices and Fill Hole(s) or press Ctrl+Del: removes vertices and linked faces and fills the hole(s) by triangulating from the neighbor vertices

    • Remove Selected Vertices Without Filling Hole(s) or press Ctrl+Shift+Del: removes vertices and linked faces and do not fill hole(s)

    • Remove Selected Face(s) or press Shift+Del: removes faces but keeps the vertices

These options are also accessible from the contextual menu when hovering over a single item without selecting.

17.4.4.4. Moving mesh elements

To move vertices and faces of a mesh layer:

  1. Select the target elements

  2. Enable the meshDigitizing Digitize mesh elements tool

  3. To start moving the element, click on a vertex or the centroid of a face/edge

  4. Move the cursor to the target location (snapping to vector features is supported).

  5. If the new location does not generate an invalid mesh, the moved elements appear in green. Click again to release them at this location. Faces whose vertices are all selected are translated, their neighbors are reshaped accordingly.

17.4.4.5. Transforming mesh vertices

The meshTransformByExpression Transform Vertices Coordinates tool gives a more advanced way to move vertices, by editing their X, Y and/or Z coordinates thanks to expressions.

  1. Select the vertices you want to edit the coordinates

  2. Press meshTransformByExpression Transform Vertices Coordinates. A dialog opens with a mention of the number of selected vertices. You can still add or remove vertices from the selection.

  3. Depending on the properties you want to modify, you need to check the X coordinate, Y coordinate and/or Z value.

  4. Then enter the target position in the box, either as a numeric value or an expression (using the expression Expression dialog)

  5. With the vertexCoordinates Import Coordinates of the Selected Vertex pressed, the X, Y and Z boxes are automatically filled with its coordinates whenever a single vertex is selected. A convenient and quick way to adjust vertices individually.

  6. Press Preview Transform to simulate the vertices new location and preview the mesh with transformation.

    • If the preview is green, transformed mesh is valid and you can apply the transformation.

    • If the preview is red, the transformed mesh is invalid and you can not apply the transformation until it is corrected.

  7. Press Apply Transform to modify the selected coordinates for the set of vertices.

17.4.4.6. Reshaping mesh geometry

The contextual menu
  1. Enable the meshDigitizing Digitize mesh elements

  2. Select mesh item(s), or not

  3. Hover over a mesh element, it gets highlighted.

  4. Right-click and you can:

    • remove the item(s)

    • Split Selected Face(s) (Split Current Face): splits the face you are hovering over or each selected quad mesh faces into two triangles

    • Delaunay Triangulation with Selected vertices: builds triangular faces using selected free vertices.

    • Refine Selected Face(s) (Refine Current Face): splits the face into four faces, based on vertices added at the middle of each edge (a triangle results into triangles, a quad into quads). Also triangulates adjacent faces connected to the new vertices.

The edge markers

When the meshDigitizing Digitize mesh elements is active and you hover over an edge, the edge is highlighted and it is possible to interact with it. Depending on the context, following markers may be available:

  • a square, at the center of the edge: click on it to select extremity vertices.

  • a cross if the two faces on either side can be merged: click on it to delete the edge and merge the faces.

  • a circle if the edge is between two triangles: Click on it to flip the edge, i.e. connect it instead to the two other “free” vertices of the faces

The Force by Selected Geometries tool

The meshEditForceByVectorLines Force by Selected Geometries tool provides advanced ways to apply break lines using lines geometry. A break line will force the mesh to have edges along the line. Note that the break line will not be considered persistent once the operation is done; resulting edges will not act as constraints anymore and can be modified like any other edge. This can be used for example to locally modify a mesh layer with accurate lines, as river banks or border of road embankments.

  1. Enable the meshEditForceByVectorLines Force by Selected Geometries tool

  2. Indicate the geometry to use as “forcing line”; it can be:

    • picked from a line or polygon feature in the map canvas: right-click over the vector feature and select it from the list in the contextual menu.

    • a virtual line drawn over the mesh frame: left-click to add vertices, right-click for validation. Vertices Z value is set through the Vertex Z value widget or the z widget if the Advanced Digitizing Panel is on. If the line is snapped to a mesh vertex or a 3D vector feature’s vertex or segment, the new vertex takes the snapped element Z value.

Mesh faces that overlap the line geometry or the polygon’s boundary will be affected in a way that depends on options you can set from the meshEditForceByVectorLines Force by Selected Geometries tool drop-down menu:

  • checkbox Add new vertex on intersecting edges: with this option, a new vertex is added each time the forcing line intersect an edge. This option leads to split along the line each encountered faces.

    Without this option, encountered faces are removed and replaced by faces coming from a triangulation with only the existing vertices plus the vertices of the forcing lines (new vertices are also added on the boundary edge intersecting the forcing lines).

    ../../../_images/force_mesh_geometry.png

    Fig. 17.14 Force Mesh using a line geometry - Results without (middle) and with (right) new vertex on edges intersection

  • Interpolate Z value from: set how the new vertices Z value is calculated. It can be from:

    • the Mesh itself: the new vertices Z value is interpolated from vertices of the face they fall within

    • or the Forcing line: if the line is defined by a 3D vector feature or a drawn line then the new vertices Z value is derived from its geometry. In case of 2D line feature, the new vertices Z value is the Vertex Z value.

  • Tolerance: when an existing mesh vertex is closer to the line than the tolerance value, do not create new vertex on the line but use the existing vertex instead. The value can be set in Meters at Scale or in Map Units (more details at Unit Selector).

17.4.5. Reindexing meshes

During edit, and in order to allow quick undo/redo operations, QGIS keeps empty places for deleted elements, which may lead to growing memory use and inefficient mesh structuring. The Mesh ► meshReindex Reindex Faces and Vertices tool is designed to remove these holes and renumber the indices of faces and vertices so that they are continuous and somewhat reasonably ordered. This optimizes relation between faces and vertices and increases the efficiency of calculation.

Note

The meshReindex Reindex Faces and Vertices tool saves the layer and clear the undo/redo stacks, disabling any rollback.

17.5. Mesh Calculator

The Mesh Calculator tool from the top Mesh menu allows you to perform arithmetic and logical calculations on existing dataset groups to generate a new dataset group (see Fig. 17.15).

../../../_images/mesh_calculator.png

Fig. 17.15 Mesh Calculator

The Datasets list contains all dataset groups in the active mesh layer. To use a dataset group in an expression, double click its name in the list and it will be added to the Mesh calculator expression field. You can then use the operators to construct calculation expressions, or you can just type them into the box.

The Result Layer helps you configure properties of the output layer:

  • checkbox Create on-the-fly dataset group instead of writing layer to disk:

    • If unchecked, the output is stored on disk as a new plain file. An Output File path and an Output Format are required.

    • If checked, a new dataset group will be added to the mesh layer. Values of the dataset group are not stored in memory but each dataset is calculated when needed with the formula entered in the mesh calculator. That virtual dataset group is saved with the project, and if needed, it can be removed or made persistent in file from the layer Source properties tab.

    In either case, you should provide a Group Name for the output dataset group.

  • The Spatial extent to consider for calculation can be:

    • a Custom extent, manually filled with the X min, X max, Y min and Y max coordinate, or extracted from an existing dataset group (select it in the list and press Use selected layer extent to fill the abovementioned coordinate fields)

    • defined by a polygon layer (Mask layer) of the project: the polygon features geometry are used to clip the mesh layer datasets

  • The Temporal extent to take into account for datasets can be set with the Start time and End time options, selected from the existing dataset groups timesteps. They can also be filled using the Use all selected dataset times button to take the whole range.

The Operators section contains all available operators. To add an operator to the mesh calculator expression box, click the appropriate button. Mathematical calculations (+, -, *, … ) and statistical functions (min, max, sum (aggr), average (aggr), … ) are available. Conditional expressions (=, !=, <, >=, IF, AND, NOT, … ) return either 0 for false and 1 for true, and therefore can be used with other operators and functions. The NODATA value can also be used in the expressions.

The Mesh Calculator Expression widget shows and lets you edit the expression to execute.