14.4. Editando

O QGIS possui vários recursos para editar camadas e tabelas de vetores OGR, SpatiaLite, PostGIS, MSSQL Spatial e Oracle Spatial.

Nota

O procedimento para editar camadas do GRASS é diferente - consulte a seção Digitalizando e editando uma camada vetorial GRASS para mais detalhes.

Dica

Edições Simultâneas

Esta versão do QGIS não rastreia se outra pessoa estiver editando o mesmo recurso ao mesmo tempo que você. A última pessoa a salvar as edições vence.

14.4.1. Configurando a Tolerância de Atracção e Raio de Pesquisa

Para uma edição otimizada e precisa das geometrias da camada vetorial, precisamos definir um valor apropriado de tolerância de snap e raio de pesquisa para vértices de feições.

14.4.1.1. Tolerância de Atração

Quando você adiciona um novo vértice ou move um existente, a tolerância de snap é a distância que o QGIS usa para procurar o vértice ou segmento mais próximo ao qual você está tentando se conectar. Se você não estiver dentro da tolerância de encaixe, o QGIS deixará o vértice onde você solta o botão do mouse, em vez de encaixá-lo em um vértice ou segmento existente.

A configuração de tolerância de encaixe afeta todas as ferramentas que funcionam com tolerância.

Você pode ativar / desativar o snapping usando o | snapping | : sup: Ative o snapping no: guilabel:` Snapping Toolbar` ou pressione: kbd: s. O modo de encaixe, o valor de tolerância e as unidades também podem ser configurados nesta barra de ferramentas.

A configuração de encaixe também pode ser definida em: seleção de menu: Projeto -> Opções de encaixe ….

Existem três opções para selecionar as camadas nas quais ajustar:

  • : guilabel: Todas as camadas: configuração rápida para todas as camadas visíveis no projeto, para que o ponteiro se encaixe em todos os vértices e / ou segmentos. Na maioria dos casos, é suficiente usar esse modo de ajuste, mas tenha cuidado ao usá-lo em projetos com muitas camadas de vetores, pois isso pode afetar o desempenho.

  • : guilabel: Camada atual: somente a camada ativa é usada, uma maneira conveniente de garantir consistência topológica na camada que está sendo editada.

  • : guilabel: Configuração avançada: permite ativar e ajustar o modo de snap e a tolerância em uma camada (consulte figure_edit_snapping). Se você precisar editar uma camada e ajustar seus vértices a outra, verifique se a camada de destino está marcada e aumente a tolerância de ajuste para um valor mais alto. O snap não ocorrerá em uma camada que não esteja marcada na caixa de diálogo de opções de snap.

Quanto ao modo de encaixe, você pode escolher entre `` Para o vértice``, `` Para o segmento`` e `` Para o vértice e o segmento``.

Os valores de tolerância podem ser definidos nas `` unidades de mapa`` do projeto ou em `` pixels``. A vantagem de escolher `` pixels ‘’ é que ele mantém o snap constante em diferentes escalas do mapa. 10 a 12 pixels é normalmente um bom valor, mas depende do DPI da sua tela. O uso de unidades de mapa permite que a tolerância esteja relacionada às distâncias reais do solo. Por exemplo, se você tem uma distância mínima entre elementos, essa opção pode ser útil para garantir que você não adicione vértices muito próximos um do outro.

../../../_images/editProjectSnapping.png

Fig. 14.85 Opções de ajuste (modo de configuração avançada)

Nota

Por padrão, somente os recursos visíveis (os recursos cujo estilo é exibido, exceto as camadas em que a simbologia é “Nenhum símbolo”) podem ser ajustados. Você pode ativar o snap em recursos invisíveis marcando | desmarcado | : guilabel: Habilite o snap em recursos invisíveis na seção: menuselection:` Settings -> Options -> Digitizing`

Dica

** Ativar ajuste por padrão **

Você pode definir o encaixe para ser ativado por padrão em todos os novos projetos na: menuselection: Settings -> Options -> Digitizing Você também pode definir o modo de snap padrão, o valor de tolerância e as unidades, que preencherão a caixa de diálogo: guilabel: opções de snap.

14.4.1.2. Activar atracção nas intersecções

Outra opção disponível é usar | snappingIntersection | : guilabel: encaixe na interseção, que permite encaixar nas interseções geométricas das camadas habilitadas para encaixe, mesmo que não haja vértices nas interseções.

14.4.1.3. Raio de pesquisa

: guilabel: Raio de pesquisa por edições de vértices é a distância que o QGIS usa para` pesquisar` o vértice a ser selecionado quando você clica no mapa. Se você não estiver dentro do raio de pesquisa, o QGIS não encontrará e selecionará nenhum vértice para edição. O raio de pesquisa para edições de vértices pode ser definido em: menuselection: Settings -> | options | : menuselection: aba Options -> Digitizing (é aqui que você define os valores padrão do snap).

A tolerância ao snap e o raio de pesquisa são definidos em `` unidades de mapa`` ou `` pixels``. Pode ser necessário experimentar para acertar. Se você especificar uma tolerância muito grande, o QGIS poderá se ajustar ao vértice errado, especialmente se você estiver lidando com um grande número de vértices nas proximidades. Quanto menor o raio de pesquisa, mais difícil será atingir o que você deseja mover.

14.4.2. Edição Topológica

In addition to these snapping options, the Snapping options… dialog (Project ‣ Snapping options) and the Snapping toolbar allow you to enable / disable some other topological functionalities.

14.4.2.1. Ativar edição topológica

A | edição topopológica | : sup: botão Edição topológica ajuda na edição e manutenção de recursos com limites comuns. Com esta opção ativada, o QGIS ‘detecta’ limites compartilhados. Quando você move vértices / segmentos comuns, o QGIS também os move nas geometrias dos recursos vizinhos.

A edição topológica funciona com recursos de diferentes camadas, desde que as camadas estejam visíveis e no modo de edição.

14.4.2.2. Evite a sobreposição de novos polígonos

Quando o modo de ajuste é definido como `` Configuração avançada``, para camadas de polígono, existe uma opção chamada | checkbox | : guilabel: Evite sobreposição. Essa opção impede que você desenhe novos recursos que se sobrepõem aos existentes na camada selecionada, acelerando a digitalização de polígonos adjacentes.

Com a opção Evitar sobreposição ativada, se você já possui um polígono, pode digitalizar um segundo para que eles se cruzem. O QGIS cortará o segundo polígono no limite do existente. A vantagem é que você não precisa digitalizar todos os vértices do limite comum.

Nota

Se a nova geometria for totalmente coberta pelas existentes, ela será limpa e o QGIS mostrará uma mensagem de erro.

Aviso

** Use com cuidado a opção **: guilabel: Evitar sobreposição ** **

Como essa opção cortará novas geometrias sobrepostas de qualquer camada de polígono, você poderá obter geometrias inesperadas se esquecer de desmarcá-la quando não for mais necessária.

14.4.2.3. Verificador de Geometria

Um plug-in principal pode ajudar o usuário a encontrar a invalidez da geometria. Você pode encontrar mais informações sobre este plugin em: ref: geometry_checker.

14.4.2.4. Rastreamento automático

Geralmente, ao usar as ferramentas de captura de mapas (adicionar recurso, adicionar peça, adicionar anel, remodelar e dividir), você precisa clicar em cada vértice do recurso. Com o modo de rastreamento automático, você pode acelerar o processo de digitalização, pois não precisa mais colocar manualmente todos os vértices durante a digitalização:

  1. Ative o | rastreio | : sup: Tracing (na barra de ferramentas: guilabel:` Snapping`) pressionando o ícone ou pressionando: kbd: tecla T.

  2. : ref: Ajustar para um vértice ou segmento de um recurso que você deseja rastrear.

  3. Mova o mouse sobre outro vértice ou segmento que você deseja ajustar e, em vez da linha reta usual, a faixa de borracha digitalizada representa um caminho a partir do último ponto em que você ajustou a posição atual.

    O QGIS realmente usa a topologia de recursos subjacente para criar o caminho mais curto entre os dois pontos. O rastreamento exige que o snap seja ativado em camadas rastreáveis ​​para criar o caminho. Você também deve encaixar em um vértice ou segmento existente ao digitalizar e garantir que os dois nós sejam topologicamente conectáveis ​​pelas bordas dos recursos existentes; caso contrário, o QGIS não poderá conectá-los e, portanto, traçará uma única linha reta.

  4. Clique e QGIS posiciona os vértices intermediários seguindo o caminho exibido.

Desdobre o | rastreio | : sup: Ative o rastreio e defina a opção: guilabel:` Offset` para digitalizar um caminho paralelo aos recursos em vez de rastreá-los. Um valor positivo desloca o novo desenho para o lado esquerdo da direção de rastreamento e um valor negativo faz o oposto.

Nota

** Ajuste as configurações de escala ou ajuste do mapa para um rastreamento ideal **

Se houver muitos recursos na exibição do mapa, o rastreamento será desativado para evitar a preparação potencialmente longa da estrutura de rastreamento e a sobrecarga de memória. Após ampliar ou desativar algumas camadas, o rastreamento é ativado novamente.

Nota

** Não adiciona pontos topológicos **

Esta ferramenta não adiciona pontos às geometrias poligonais existentes, mesmo que: guilabel: Edição topológica esteja ativada. Se a precisão da geometria estiver ativada na camada editada, a geometria resultante poderá não seguir exatamente uma geometria existente.

Dica

** Ative ou desative rapidamente o rastreio automático pressionando a tecla **: kbd: T **

Pressionando a tecla: kbd: T, o rastreamento pode ser ativado / desativado a qualquer momento (mesmo durante a digitalização de um recurso), para que seja possível digitalizar partes do recurso com o rastreamento ativado e outras partes com o rastreamento desativado. As ferramentas se comportam como de costume quando o rastreamento está desativado.

14.4.3. Digitalizar uma camada existente

Por padrão, o QGIS carrega camadas somente leitura. Essa é uma salvaguarda para evitar a edição acidental de uma camada, se houver um deslizamento do mouse. No entanto, você pode optar por editar qualquer camada, desde que o provedor de dados a suporte (consulte: ref: supported_format), e a fonte de dados subjacente é gravável (ou seja, seus arquivos não são somente leitura).

Dica

** Restrinja a permissão de edição em camadas dentro de um projeto **

Na tabela: menuselection: Projeto -> Propriedades … -> Fontes de dados -> Recursos de camadas, você pode optar por definir qualquer camada somente leitura, independentemente da permissão do provedor. Essa pode ser uma maneira prática, em um ambiente de vários usuários, para evitar que usuários não autorizados editem camadas por engano (por exemplo, Shapefile), portanto, dados potencialmente corrompidos. Observe que essa configuração se aplica apenas ao projeto atual.

Em geral, as ferramentas para editar camadas vetoriais são divididas em uma barra de ferramentas de digitalização e uma avançada, descritas na seção: ref: sec_advanced_edit. Você pode selecionar e desmarcar os dois em: menuelection: View -> Barras de ferramentas ->.

Usando as ferramentas básicas de digitalização, você pode executar as seguintes funções:

Ícone

Finalidade

Ícone

Finalidade

allEdits

Edições actuais

toggleEditing

Alternar edição

saveEdits

Salvar edições da camada

newTableRow

Adicionar novo registro

capturePoint

Add Feature: Capture Point

captureLine

Adicionar recurso: Linha de captura

capturePolygon

Adicionar recurso: Capturar polígono

Ferramenta de vértice

Ferramenta de Vértice (todas as camadas)

|Camada ativa da ferramenta vértice|

Ferramenta Vértice (camada atual)

multiEdit

Modifique os atributos de todos os recursos selecionados simultaneamente

deleteSelectedFeatures

Apagar Selecionados

editCut

Cortar Elementos

editCopy

Copiar Elementos

editPaste

Colar Elementos

undo

Retroceder

redo

Retomar

Edição da Tabela: Edição básica da camada vectorial pela barra de ferramentas

Observe que, ao usar qualquer uma das ferramentas de digitalização, você ainda pode: ref: ampliar ou deslocar na tela do mapa sem perder o foco na ferramenta.

Todas as sessões de edição começam escolhendo o | toggleEditing | : sup: Alterna a edição encontrada no menu de contexto de uma determinada camada, no diálogo da tabela de atributos, na barra de ferramentas de digitalização ou na seleção: menuselection:` Edit`.

Quando a camada estiver no modo de edição, botões de ferramentas adicionais na barra de ferramentas de edição ficarão disponíveis e os marcadores aparecerão nos vértices de todos os recursos, a menos que: guilabel: Mostrar marcadores apenas para os recursos selecionados opção em: menuelection:` Settings -> Opções … -> O menu Digitalizar` está marcado.

Dica

Salvar Regularmente

Remember to saveEdits Save Layer Edits regularly. This will also check that your data source can accept all the changes.

14.4.3.1. Adicionando Elementos

Dependendo do tipo de camada, você pode usar o | newTableRow | : sup: Adicionar registro, | capturePoint | : sup: Adicionar recurso de ponto, | captureLine | : sup: Adicionar recurso de linha ou | capturePolygon | : sup: ícones Adicionar recurso de polígono na barra de ferramentas para adicionar novos recursos à camada atual.

Para adicionar um recurso sem geometria, clique no | newTableRow | : sup: botão Adicionar registro e você pode inserir atributos no formulário do recurso que é aberto. Para criar recursos com as ferramentas ativadas espacialmente, primeiro digitalize a geometria e, em seguida, insira seus atributos. Para digitalizar a geometria:

  1. Clique com o botão esquerdo na área do mapa para criar o primeiro ponto do seu novo recurso. Para recursos de ponto, isso deve ser suficiente e acionar, se necessário, o formulário de recurso para preencher seus atributos. Após definir: ref: geometry precision nas propriedades da camada, você pode usar: ref: snap to grid aqui para criar recursos com base em uma distância regular.

  2. Para geometrias de linha ou polígono, clique com o botão esquerdo do mouse em cada ponto adicional que você deseja capturar ou usar: ref: rastreio automático capacidade de acelerar a digitalização. Isso criará linhas retas consecutivas entre os vértices que você coloca.

    Nota

    Pressionar: kbd: Excluir ou: kbd: tecla Backspace `reverte o último nó y ou adicione.

  3. Quando você terminar de adicionar pontos, clique com o botão direito do mouse em qualquer lugar na área do mapa para confirmar que você terminou de inserir a geometria desse recurso.

    Nota

    Ao digitalizar geometrias de linhas ou polígonos, você pode alternar entre linear: guilabel: Adicionar recurso `tools e: ref: ferramentas de cordas circulares `para criar geometrias curvas compostas.

    Dica

    ** Personalize a faixa de borracha digitalizada **

    Ao capturar o polígono, o elástico vermelho por padrão pode ocultar recursos ou locais subjacentes que você deseja capturar um ponto. Isso pode ser corrigido configurando uma opacidade mais baixa (ou canal alfa) no menu: guilabel: Cor de preenchimento do elástico em: seleção de menu: Configurações -> Opções -> Digitalização. Você também pode evitar o uso do elástico marcando: guilabel: Não atualize o elástico durante a edição do nó.

  4. Uma janela do atributo permitido, permitindo que você insira como informações para o novo recurso. Figura_Edição_valor mostra a configuração de atributos para um novo rio fictício no Alasca. No entanto, no menu: guilabel: Digitalizando sob o menu: seleção de menus:` Configurações -> Opções`, você também pode ativar:

    • checkbox Suppress attributes pop-up windows after each created feature to avoid the form opening;

    • ou | caixa de seleção | : guilabel: Reutilizar os últimos valores de atributo inseridos para ter campos automaticamente preenchidos na abertura do formulário e apenas digitar valores alterados.

../../../_images/editDigitizing.png

Fig. 14.86 Caixa de diálogo Inserir valores de atributo após digitalizar um novo recurso de vetor

14.4.3.2. Ferramenta Vertex

Nota

** QGIS 3 grandes mudanças **

No QGIS 3, a ferramenta do nó foi totalmente redesenhada e renomeada para * ferramenta de vértice *. Ele estava trabalhando anteriormente com a ergonomia “clique e arraste” e agora usa um fluxo de trabalho “clique e clique”. Isso permite grandes melhorias, como tirar proveito do painel de digitalização avançado com a ferramenta vértice, enquanto digitaliza ou edita objetos de várias camadas ao mesmo tempo.

For any editable vector layer, the vertexToolActiveLayer Vertex tool (Current Layer) provides manipulation capabilities of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them altogether. The vertex tool also supports the topological editing feature. This tool is selection persistent, so when some operation is done, selection stays active for this feature and tool.

It is important to set the property Settings ‣ options Options ‣ Digitizing ‣ Search Radius: selectNumber to a number greater than zero. Otherwise, QGIS will not be able to tell which vertex is being edited and will display a warning.

Dica

Marcadores de Vértice

A versão atual do QGIS suporta três tipos de marcadores de vértice: ‘Círculo semitransparente’, ‘Cruz’ e ‘Nenhum’. Para alterar o estilo do marcador, escolha | opções | : menuselection: Options no menu: menu:` Settings , clique na guia: guilabel: Digitizing `e selecione a entrada apropriada.

14.4.3.2.1. Operações Básicas

Comece ativando a | Camada ativa da ferramenta | vértice | : sup: Ferramenta Vertex (camada atual). Círculos vermelhos aparecerão ao pairar vértices.

  • Selecting vertices: You can select vertices by clicking on them one at a time holding Shift key pressed, or by clicking and dragging a rectangle around some vertices. When a vertex is selected, its color changes to blue. To add more vertices to the current selection, hold down the Shift key while clicking. To remove vertices from the selection, hold down Ctrl.

  • Batch vertex selection mode: The batch selection mode can be activated by pressing Shift+R. Select a first node with one single click, and then hover without clicking another vertex. This will dynamically select all the nodes in between using the shortest path (for polygons).

    ../../../_images/vertex_batch_selection_mode.png

    Fig. 14.87 Batch vertex selection using Shift+R

    Press Ctrl will invert the selection, selecting the longest path along the feature boundary. Ending your node selection with a second click, or pressing Esc will escape the batch mode.

  • Adding vertices: To add a vertex, a virtual new node appears on the segment center. Simply grab it to add a new vertex. A double-click on any location of the boundary also creates a new node. For lines, a virtual node is also proposed at both extremities of a line to extend it.

    ../../../_images/vertex_add_node.png

    Fig. 14.88 Nós virtuais para adicionar vértices

  • ** Excluindo vértices **: selecione os vértices e clique na tecla: kbd: Excluir. A exclusão de todos os vértices de um recurso gera, se compatível com a fonte de dados, um recurso sem geometria. Observe que isso não exclui o recurso completo, apenas a parte da geometria. Para excluir um recurso completo, use o | deleteSelectedFeatures | : sup: ferramenta Excluir selecionados.

  • Moving vertices: Select all the vertices you want to move, click on a selected vertex or edge, and click again on the desired new location. All the selected vertices will move together. If snapping is enabled, the whole selection can jump to the nearest vertex or line. You can use Advanced Digitizing Panel constraints for distance, angles, exact X Y location before the second click.

    Here you can use the snap-to-grid feature. Having set a value for the geometry precision in the layer properties, a grid appears on a zoom level according to the Geometry precision.

    ../../../_images/vertex_snap_to_grid.png

    Fig. 14.89 Selecionando um vértice e movendo os vértices para a grade

Each change made with the vertex is stored as a separate entry in the Undo dialog. Remember that all operations support topological editing when this is turned on. On-the-fly projection is also supported, and the vertex tool provides tooltips to identify a vertex by hovering the pointer over it.

14.4.3.2.2. O painel do editor de vértices

When using the Vertex tool on a feature, it is possible to right click to open the Vertex Editor panel listing all the vertices of the feature with their x, y (z, m if applicable) coordinates and r (for the radius, in case of circular geometry). Simply select a row in the table does select the corresponding vertex in the map canvas, and vice versa. Simply change a coordinate in the table and your vertex position is updated. You can also select multiple rows and delete them altogether.

Nota

** Comportamento alterado no QGIS 3.4 **

Right click on a feature will immediately show the vertex editor and lock this feature, thus disabling the editing of any other features. While being locked, a feature is exclusive for editing: Selecting and moving of vertices and segments by clicking or dragging is only possible for this feature. New vertices can only be added to the locked feature. Also, the vertex editor panel now opens itself automatically upon activating the vertex tool, and its position/docked state remembered across uses.

../../../_images/vertex_editor_panel.png

Fig. 14.90 Painel do editor de vértices mostrando os nós selecionados

14.4.3.3. Cortando, Copiando e Colando Elementos

Os recursos selecionados podem ser recortados, copiados e colados entre as camadas no mesmo projeto QGIS, desde que as camadas de destino estejam definidas como | toggleEditing | : sup: Alterna a edição de antemão.

Dica

** Transforme o polígono em linha e vice-versa usando copiar / colar **

Copie um recurso de linha e cole-o em uma camada de polígono: O QGIS cola na camada de destino um polígono cujo limite corresponde à geometria fechada do recurso de linha. Essa é uma maneira rápida de gerar geometrias diferentes dos mesmos dados.

Features can also be pasted to external applications as text. That is, the features are represented in CSV format, with the geometry data appearing in the OGC Well-Known Text (WKT) format. WKT and GeoJSON features from outside QGIS can also be pasted to a layer within QGIS.

When would the copy and paste function come in handy? Well, it turns out that you can edit more than one layer at a time and copy/paste features between layers. Why would we want to do this? Say we need to do some work on a new layer but only need one or two lakes, not the 5,000 on our big_lakes layer. We can create a new layer and use copy/paste to plop the needed lakes into it.

Como exemplo, vamos copiar alguns lagos para uma nova camada:

  1. Carregue a camada que quer copiar a partir (camada de origem)

  2. Carregue ou crie a camada que quer copiar para (camada de destino)

  3. Começar a editar a camada de destino

  4. Ative a camada de origem clicando nela na legenda

  5. Use the selectRectangle Select Features by area or single click tool to select the feature(s) on the source layer

  6. Click on the editCopy Copy Features tool

  7. Ative a camada de destino clicando na legenda

  8. Clique no | editar Colar | : sup: ferramenta Colar recursos

  9. Parar a edição e salvar as alterações

What happens if the source and target layers have different schemas (field names and types are not the same)? QGIS populates what matches and ignores the rest. If you don’t care about the attributes being copied to the target layer, it doesn’t matter how you design the fields and data types. If you want to make sure everything - the feature and its attributes - gets copied, make sure the schemas match.

Nota

Congruência dos Elementos Colados

If your source and destination layers use the same projection, then the pasted features will have geometry identical to the source layer. However, if the destination layer is a different projection, then QGIS cannot guarantee the geometry is identical. This is simply because there are small rounding-off errors involved when converting between projections.

Dica

** Copiar atributo da string para outro **

If you have created a new column in your attribute table with type ‘string’ and want to paste values from another attribute column that has a greater length the length of the column size will be extended to the same amount. This is because the GDAL Shapefile driver starting with GDAL/OGR 1.10 knows to auto-extend string and integer fields to dynamically accommodate for the length of the data to be inserted.

14.4.3.4. Apagando os Elementos Selecionados

Se quisermos excluir um recurso inteiro (atributo e geometria), podemos fazer isso selecionando primeiro a geometria usando o regular | select Rectangle | : sup: Selecione Recursos por área ou clique único. A seleção também pode ser feita na tabela de atributos. Depois de definir a seleção, pressione: kbd: Excluir ou: kbd: Backspace ou use a tecla | delete Features Selecionadas | : sup: ferramenta Delete Selected para excluir os recursos. Vários recursos selecionados podem ser excluídos de uma só vez.

The editCut Cut Features tool on the digitizing toolbar can also be used to delete features. This effectively deletes the feature but also places it on a “spatial clipboard”. So, we cut the feature to delete. We could then use the editPaste Paste Features tool to put it back, giving us a one-level undo capability. Cut, copy, and paste work on the currently selected features, meaning we can operate on more than one at a time.

14.4.3.5. Retroceder e Retomar

The undo Undo and redo Redo tools allows you to undo or redo vector editing operations. There is also a dockable widget, which shows all operations in the undo/redo history (see Figure_edit_undo). This widget is not displayed by default; it can be displayed by right-clicking on the toolbar and activating the Undo/Redo Panel checkbox. The Undo/Redo capability is however active, even if the widget is not displayed.

../../../_images/redo_undo.png

Fig. 14.91 Refazer e desfazer etapas de digitalização

When Undo is hit or Ctrl+Z (or Cmd+Z) pressed, the state of all features and attributes are reverted to the state before the reverted operation happened. Changes other than normal vector editing operations (for example, changes done by a plugin) may or may not be reverted, depending on how the changes were performed.

Para usar a tela histórico de desfazer / refazer, basta clicar para selecionar uma operação na lista de histórico. Todas as feições serão revertidas para o estado em que estavam depois da operação selecionada.

14.4.3.6. Salvando as Camadas Editadas

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore, they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the saveEdits Save Layer Edits button. When you turn editing mode off with toggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

Se as alterações não puderem ser salvas (por exemplo, disco cheio ou os atributos tiverem valores fora do intervalo), o estado na memória do QGIS será preservado. Isso permite que você ajuste suas edições e tente novamente.

Dica

Integridade dos dados

É sempre uma boa idéia fazer backup da fonte de dados antes de começar a editar. Embora os autores do QGIS tenham se esforçado para preservar a integridade dos seus dados, não oferecemos garantia a esse respeito.

14.4.3.6.1. Salvando várias camadas ao mesmo tempo

Esse recurso permite a digitalização de várias camadas. Escolha | arquivo Salvar como | : guilabel: Salvar para camadas selecionadas para salvar todas as alterações feitas em várias camadas. Você também tem a oportunidade de | reverter edições | : guilabel: Reversão para camadas selecionadas, para que a digitalização possa ser retirada para todas as camadas selecionadas. Se você deseja parar de editar as camadas selecionadas, cancele Edições | : guilabel: Cancelar para a (s) camada (s) selecionada (s) é uma maneira fácil.

As mesmas funções estão disponíveis para a edição de todas as camadas do projeto.

Dica

** Use o grupo de transações para editar, salvar ou reverter várias alterações de camada ao mesmo tempo **

When working with layers from the same PostGreSQL database, activate the Automatically create transaction groups where possible option in Project ‣ Properties… ‣ Data Sources to sync their behavior (enter or exit the edit mode, save or rollback changes at the same time).

14.4.4. Digitalização Avançada

Ícone

Finalidade

Ícone

Finalidade

cad

Ativar ferramentas avançadas de digitalização

tracing

Ativar rastreamento

moveFeature moveFeatureLine moveFeaturePoint

Mover feições

mover cópia de recurso | | mover Linha de Cópia de Recursos | | mover Ponto de Cópia de Recurso |

Copy and Move Feature(s)

rotateFeature

Rodar Elemento(s)

simplifyFeatures

Simplificar elemento

addRing

Adicionar Anel

addPart

Adicionar Parte

fillRing

Preenchimento Anel

reverseLine

Swap direction

deleteRing

Apagar Anel

deletePart

Apagar Parte

offsetCurve

Curva de Afastamento

reshape

Refazer elementos

splitParts

Dividindo partes

splitFeatures

Dividir Elementos

mergeFeatAttributes

Juntar Atributos dos Elementos Selecionados

mergeFeatures

Juntar Elementos Selecionados

rotatePointSymbols

Rodar Símbolos de Pontos

offsetPointSymbols

Offset Point Symbols

trimExtend

Trim or Extend Feature

Tabela de edição avançada: Barra de ferramentas de edição avançada de camadas vetoriais

14.4.4.1. Mover feições

The moveFeature Move Feature(s) tool allows you to move existing features:

  1. Select the feature(s) to move.

  2. Click on the map canvas to indicate the origin point of the displacement; you can rely on snapping capabilities to select an accurate point.

    You can also take advantages of the advanced digitizing constraints to accurately set the origin point coordinates. In that case:

    1. Primeiro clique no | cad | para ativar o painel.

    2. Digite `` x`` e insira o valor correspondente ao ponto de origem que você deseja usar. Em seguida, pressione o botão | bloqueado | ao lado da opção para bloquear o valor.

    3. Do the same for the y coordinate.

    4. Click on the map canvas and your origin point is placed at the indicated coordinates.

  3. Move over the map canvas to indicate the destination point of the displacement, still using snapping mode or, as above, use the advanced digitizing panel which would provide complementary distance and angle placement constraints to place the end point of the translation.

  4. Click on the map canvas: the whole features are moved to new location.

Likewise, you can create a translated copy of the feature(s) using the moveFeatureCopy Copy and Move Feature(s) tool.

Nota

If no feature is selected when you first click on the map canvas with any of the Move Feature(s) or Copy and Move Feature(s) tools, then only the feature under the mouse is affected by the action. So, if you want to move several features, they should be selected first.

14.4.4.2. Rodar Elemento(s)

Use the rotateFeature Rotate Feature(s) tool to rotate one or multiple features in the map canvas:

  1. Press the rotateFeature Rotate Feature(s) icon

  2. Then click on the feature to rotate. The feature’s centroid is referenced as rotation center, a preview of the rotated feature is displayed and a widget opens showing the current Rotation angle.

  3. Click on the map canvas when you are satisfied with the new placement or manually enter the rotation angle in the text box. You can also use the Snap to ° box to constrain the rotation values.

  4. If you want to rotate several features at once, they shall be selected first, and the rotation is by default around the centroid of their combined geometries.

You can also use an anchor point different from the default feature centroid: press the Ctrl button, click on the map canvas and that point will be used as the new rotation center.

If you hold Shift before clicking on the map, the rotation will be done in 45 degree steps, which can be modified afterwards in the user input widget.

To abort feature rotation, press the ESC button or click on the rotateFeature Rotate Feature(s) icon.

14.4.4.3. Simplificar elemento

The simplifyFeatures Simplify Feature tool allows you to interactively reshape a line or polygon geometry by reducing or densifying the number of vertices, as long as the geometry remains valid:

  1. Select the simplifyFeatures Simplify Feature tool.

  2. Click on the feature or drag a rectangle over the features.

  3. A dialog pops up allowing you to define the Method to apply, ie whether you would like to:

    • simplify the geometry, meaning less vertices than the original. Available methods are Simplify by distance, Simplify by snapping to grid or simplify by area (Visvalingam). You’d then need to indicate the value of Tolerance in Layer units, Pixels or map units to use for simplification. The higher the tolerance is the more vertices can be deleted.

    • or densify the geometries with new vertices thanks to the Smooth option: for each existing vertex, two vertices are placed on each of the segments originated from it, at an Offset distance representing the percentage of the segment length. You can also set the number of Iterations the placement would be processed: the more iterations, the more vertices and smoother is the feature.

    Settings that you used will be saved when leaving a project or an edit session. So you can go back to the same parameters the next time you simplify a feature.

  4. A summary of the modifications that would apply is shown at the bottom of the dialog, listing number of features and number of vertices (before and after the operation and the ratio the change represents). Also, in the map canvas, the expected geometry is displayed over the existing one, using the rubberband color.

  5. When the expected geometry fits your needs, click OK to apply the modification. Otherwise, to abort the operation, you can either press Cancel or right-click in the map canvas.

Nota

Unlike the feature simplification option in Settings ‣ Options ‣ Rendering menu which simplifies the geometry just for rendering, the simplifyFeatures Simplify Feature tool permanently modifies feature’s geometry in data source.

14.4.4.4. Adicionar Parte

You can addPart Add Part to a selected feature generating a multipoint, multiline or multipolygon feature. The new part must be digitized outside the existing one which should be selected beforehand.

The addPart Add Part can also be used to add a geometry to a geometryless feature. First, select the feature in the attribute table and digitize the new geometry with the addPart Add Part tool.

14.4.4.5. Apagar Parte

The deletePart Delete Part tool allows you to delete parts from multifeatures (e.g., to delete polygons from a multi-polygon feature). This tool works with all multi-part geometries: point, line and polygon. Furthermore, it can be used to totally remove the geometric component of a feature. To delete a part, simply click within the target part.

14.4.4.6. Adicionar Anel

You can create ring polygons using the addRing Add Ring icon in the toolbar. This means that inside an existing area, it is possible to digitize further polygons that will occur as a ‘hole’, so only the area between the boundaries of the outer and inner polygons remains as a ring polygon.

14.4.4.7. Preenchimento Anel

The fillRing Fill Ring tool helps you create polygon feature that totally falls within another one without any overlapping area; that is the new feature covers a hole within the existing one. To create such a feature:

  1. Select the fillRing Fill Ring tool.

  2. Desenhe um novo polígono sobre o recurso existente: o QGIS adiciona um anel à sua geometria (como se você usasse a ferramenta | addRing |: sup: Add Ring) e cria um novo recurso cuja geometria corresponde ao anel (como se você: ref : traçado sobre os limites internos com a ferramenta | capturePolygon |: sup: Adicionar recurso de polígono).

  3. Or alternatively, if the ring already exists on the feature, place the mouse over the ring and left-click while pressing Shift: a new feature filling the hole is drawn at that place.

    The Feature Attributes form of the new feature opens, pre-filled with values of the “parent” feature and/or fields constraints.

14.4.4.8. Apagar Anel

The deleteRing Delete Ring tool allows you to delete rings within an existing polygon, by clicking inside the hole. This tool only works with polygon and multi-polygon features. It doesn’t change anything when it is used on the outer ring of the polygon.

14.4.4.9. Refazer elementos

You can reshape line and polygon features using the reshape Reshape Features tool on the toolbar. For lines, it replaces the line part from the first to the last intersection with the original line.

../../../_images/reshape_lines.png

Fig. 14.92 Reshape line

Dica

Extend linestring geometries with reshape tool

Use the reshape Reshape Features tool to extend existing linestring geometries: snap to the first or last vertex of the line and draw a new one. Validate and the feature’s geometry becomes the combination of the two lines.

For polygons, it will reshape the polygon’s boundary. For it to work, the reshape tool’s line must cross the polygon’s boundary at least twice. To draw the line, click on the map canvas to add vertexes. To finish it, just right-click. Like with the lines, only the segment between the first and the last intersections is considered. The reshape line’s segments that are inside the polygon will result in cropping it, where the ones outside the polygon will extend it.

../../../_images/reshape_polygon.png

Fig. 14.93 Reshape polygon

With polygons, reshaping can sometimes lead to unintended results. It is mainly useful to replace smaller parts of a polygon, not for major overhauls, and the reshape line is not allowed to cross several polygon rings, as this would generate an invalid polygon.

Nota

A ferramenta de mudança de forma pode alterar a posição inicial de um anel ou de uma linha poligonal fechada. Assim, o ponto que está representada ‘duas vezes’ não será o mesmo mais. Isto pode não ser um problema para a maioria das aplicações, mas é algo a considerar.

14.4.4.10. Curvas de Afastamento

The offsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (in which case it creates copies of the lines / rings and adds them to the edited layer). It is thus ideally suited for the creation of distance line layers. The User Input dialog pops-up, showing the displacement distance.

To create a shift of a line layer, you must first go into editing mode and activate the offsetCurve Offset Curve tool. Then click on a feature to shift it. Move the mouse and click where wanted or enter the desired distance in the user input widget. Your changes may then be saved with the saveEdits Save Layer Edits tool.

QGIS options dialog (Digitizing tab then Curve offset tools section) allows you to configure some parameters like Join style, Quadrant segments, Miter limit.

14.4.4.11. Reverse Line

Changing the direction of a line geometry can be useful for cartographical purposes or when preparing for network analysis.

To change a line direction:

  1. Activate the reverse line tool by clicking reverseLine Reverse line.

  2. Click on the line. The direction of the line is reversed.

14.4.4.12. Dividir Elementos

Use the splitFeatures Split Features tool to split a feature into two or more new and independent features, ie. each geometry corresponding to a new row in the attribute table.

To split line or polygon features:

  1. Select the splitFeatures Split Features tool.

  2. Draw a line across the feature(s) you want to split. If a selection is active, only selected features are split. When set, default values or clauses are applied to corresponding fields and other attributes of the parent feature are by default copied to the new features.

  3. You can then as usually modify any of the attributes of any resulting feature.

Dica

Split a polyline into new features in one-click

Using the splitFeatures Split Features tool, snap and click on an existing vertex of a polyline feature to split that feature into two new features.

14.4.4.13. Dividindo partes

No QGIS, é possível dividir as partes de um recurso de várias partes para aumentar o número de partes. Basta desenhar uma linha na parte que você deseja dividir usando o |  peças separadas | : sup: ícone Split Parts.

Dica

** Divida uma polilinha em novas peças com um clique **

Using the splitParts Split Parts tool, snap and click on an existing vertex of a polyline feature to split the feature into two new polylines belonging to the same feature.

14.4.4.14. Juntar elementos selecionados

The mergeFeatures Merge Selected Features tool allows you to create a new feature by merging existing ones: their geometries are merged to generate a new one. If features don’t have common boundaries, a multipolygon/multipolyline/multipoint feature is created.

  1. Primeiro, selecione os recursos que você deseja combinar.

  2. Em seguida, pressione o | mergeFeatures | : sup: botão “Mesclar recursos selecionados”.

  3. Na nova caixa de diálogo, a linha: guilabel: Merge na parte inferior da tabela mostra os atributos do recurso resultante. Você pode alterar qualquer um desses valores:

    • manually replacing the value in the corresponding cell;

    • selecting a row in the table and pressing Take attributes from selected feature to use the values of this initial feature;

    • pressing Skip all fields to use empty attributes;

    • or, expanding the drop down menu at the top of the table, select any of the above options to apply to the corresponding field only. There, you can also choose to aggregate the initial features attributes (Minimum, Maximum, Median, Sum, Count, Concatenation… depending on the type of the field. see Statistical Summary Panel for the full list of functions).

    Nota

    If the layer has default values or clauses present on fields, these are used as the initial value for the merged feature.

  4. Press OK to apply the modifications. A single (multi)feature is created in the layer, replacing the previously selected ones.

14.4.4.15. Juntar os atributos dos elementos selecionados

The mergeFeatAttributes Merge Attributes of Selected Features tool allows you to apply same attributes to features without merging their boundaries. The dialog is the same as the Merge Selected Features tool’s except that unlike that tool, selected objects are kept with their geometry while some of their attributes are made identical.

14.4.4.16. Rodar Símbolos de Pontos

The rotatePointSymbols Rotate Point Symbols allows you to change the rotation of point symbols in the map canvas.

  1. First of all, apply to the symbol a data-defined rotation:

    1. In the Layer Properties ‣ Symbology dialog, browse to the symbol editor dialog.

    2. Click the dataDefined Data-defined override widget near the Rotation option of the top Marker level (preferably) of the symbol layers.

    3. Choose a field in the Field Type combobox. Values of this field are hence used to rotate each feature’s symbol accordingly.

    Nota

    Make sure that the same field is assigned to all the symbol layers

    A configuração do campo de rotação definido por dados no nível mais alto da árvore de símbolos o propagará automaticamente para todas as camadas de símbolos, um pré-requisito para executar a rotação gráfica de símbolos com a ferramenta: guilabel: Rotate Point Symbols. De fato, se uma camada de símbolo não tiver o mesmo campo anexado à sua propriedade de rotação, a ferramenta não funcionará.

    ../../../_images/rotatepointsymbol.png

    Fig. 14.94 Girando um símbolo de ponto

  2. Em seguida, clique em um recurso de ponto na tela do mapa com o | rotatePointSymbols | : sup: Rotate Point Symbols e mova o mouse, mantendo o botão esquerdo pressionado. Uma seta vermelha com o valor de rotação será visualizada (consulte Figure_rotate_point).

  3. Release the left mouse button again, the symbol is defined with this new rotation and the rotation field is updated in the layer’s attribute table.

Dica

Se segurar a tecla Ctrl premido, a rotação irá ser feita em passos de 15 graus.

14.4.4.17. Offset Point Symbols

The offsetPointSymbols Offset Point Symbols allows you to interactively change the rendered position of point symbols in the map canvas. This tool behaves like the rotatePointSymbols Rotate Point Symbols tool except that it requires you to connect a field to the data-defined Offset (X,Y) property of the symbol, field which will then be populated with the offset coordinates while moving the symbol in the map canvas.

Nota

The offsetPointSymbols Offset Point Symbols tool doesn’t move the point feature itself; you should use the vertexToolActiveLayer Vertex Tool (Current Layer) or moveFeaturePoint Move Feature tool for this purpose.

14.4.4.18. Recortar / estender o recurso

Quando uma linha digitalizada é muito curta ou muito longa para encaixar em outra linha (faltando ou cruzando a linha), é necessário poder estender ou encurtar o segmento.

The trimExtend Trim/Extend tool allows you to also modify (multi)lines AND (multi)polygons. Moreover, it is not necessarily the end of the lines that is concerned; any segment of a geometry can be modified.

Nota

Isso pode levar a geometrias inválidas.

Nota

Você deve ativar o snap do segmento para que esta ferramenta funcione.

The tool asks you to select a limit (a segment) with respect to which another segment will be extended or trimmed. Unlike the vertex tool, a check is performed to modify only the layer being edited.

When both segments are in 3D, the tool performs an interpolation on the limit segment to get the Z value.

No caso de um corte, você deve selecionar a parte que será reduzida clicando nela.

14.4.5. Digitalização de forma

The Shape Digitizing toolbar offers a set of tools to draw regular shapes and curved geometries.

14.4.5.1. Add Circular string

The circularStringCurvePoint Add circular string or circularStringRadius Add circular string by radius buttons allow users to add line or polygon features with a circular geometry.

Creating features with these tools follow the same rule as of other digitizing tools: left-click to place vertices and right-click to finish the geometry. While drawing the geometry, you can switch from one tool to the other as well as to the linear geometry tools, creating some coumpound geometries.

Nota

Curved geometries are stored as such only in compatible data provider

Although QGIS allows to digitize curved geometries within any editable data format, you need to be using a data provider (e.g. PostGIS, memory layer, GML or WFS) that supports curves to have features stored as curved, otherwise QGIS segmentizes the circular arcs.

14.4.5.2. Desenhar círculos

Há um conjunto de ferramentas para desenhar círculos. As ferramentas são descritas abaixo.

Circles are converted into circular strings. Therefore, as explained in Add Circular string, if allowed by the data provider, it will be saved as a curved geometry, if not, QGIS will segmentize the circular arcs.

  • circle2Points Add circle from 2 points: The two points define the diameter and the orientation of the circle. (Left-click, right-click)

  • circle3Points Add circle from 3 points: Draws a circle from three known points on the circle. (Left-click, left-click, right-click)

  • circleCenterPoint Add circle from center and a point: Draws a circle with a given center and a point on the circle (Left-click, right-click). When used with the O painel Digitalização avançada this tool can become a “Add circle from center and radius” tool by setting and locking the distance value after first click.

  • circle3Tangents Add circle from 3 tangents: Draws a circle that is tangential to three segments. Note that you must activate snapping to segments (See Configurando a Tolerância de Atracção e Raio de Pesquisa). Click on a segment to add a tangent. If two tangents are parallel, an error message appears and the input is cleared. (Left-click, left-click, right-click)

  • circle2TangentsPoint Add circle from 2 tangents and a point: Similar to circle from 3 tangents, except that you have to select two tangents, enter a radius and select the desired center.

14.4.6. O painel Digitalização avançada

When capturing, reshaping, splitting new or existing geometries you also have the possibility to use the Advanced Digitizing panel. You can digitize lines exactly parallel or perpendicular to a particular angle or lock lines to specific angles. Furthermore, you can enter coordinates directly so that you can make a precise definition of your new geometry.

../../../_images/advanced_digitizing.png

Fig. 14.95 O painel Digitalização avançada

The Advanced Digitizing panel can be open either with a right-click on the toolbar, from View ‣ Panels ‣ menu or pressing Ctrl+4. Once the panel is visible, click the cad Enable advanced digitizing tools button to activate the set of tools.

Nota

As ferramentas não são habilitadas se a visão do mapa está em coordenadas geográficas.

14.4.6.1. Concepts

The aim of the Advanced Digitizing tool is to lock coordinates, lengths, and angles when moving the mouse during the digitalizing in the map canvas.

You can also create constraints with relative or absolute reference. Relative reference means that the next vertex constraints’ values will be relative to the previous vertex or segment.

14.4.6.2. Snapping Settings

Click the settings button to set the Advanced Digitizing Tool snapping settings. You can make the tool snap to common angles. The options are:

  • Do not snap to common angles

  • Snap to 30º angles

  • Snap to 45º angles

  • Snap to 90º angles

You can also control the snapping to features. The options are:

  • Do not snap to vertices or segments

  • Snap according to project configuration

  • Snap to all layers

14.4.6.3. Atalhos do Teclado

To speed up the use of Advanced Digitizing Panel, there are a couple of keyboard shortcuts available:

Key

Simple

Ctrl+ ou Alt+

Shift+

D

Set distance

Lock distance

A

Set angle

Lock angle

Toggle relative angle to last segment

X

Set X coordinate

Lock X coordinate

Toggle relative X to last vertex

Y

Set Y coordinate

Lock Y coordinate

Toggle relative Y to last vertex

C

Alternar modo de construção

P

Alternar entre modos perpendicular e paralelo

14.4.6.4. Absolute reference digitizing

When drawing a new geometry from scratch, it is very useful to have the possibility to start digitizing vertexes at given coordinates.

For example, to add a new feature to a polygonal layer, click the capturePolygon button. You can choose the X and Y coordinates where you want to start editing the feature, then:

  • Click the x text box (or use the X keyboard shortcut).

  • Type the X coordinate value you want and press Enter or click the locked button to their right to lock the mouse to the X axis on the map canvas.

  • Click the y text box (or use the Y keyboard shortcut).

  • Type the Y coordinate value you want and press Enter or click the locked button to their right to lock the mouse to the Y axis on the map canvas.

Two blue dotted lines and a green cross identify the exact coordinates you entered. Start digitizing by clicking on the map canvas; the mouse position is locked at the green cross.

../../../_images/advanced_digitizing_coordinates.png

Fig. 14.96 Start drawing at given coordinates

You can continue digitizing by free hand, adding a new pair of coordinates, or you can type the segment’s length (distance) and angle.

If you want to draw a segment of a given length, click the d (distance) text box (keyboard shortcut D), type the distance value (in map units) and press Enter or click the locked button on the right to lock the mouse in the map canvas to the length of the segment. In the map canvas, the clicked point is surrounded by a circle whose radius is the value entered in the distance text box.

../../../_images/advanced_digitizing_distance.png

Fig. 14.97 Fixed length segment

Finally, you can also choose the angle of the segment. As described before , click the a (angle) text box (keyboard shortcut A), type the angle value (in degrees), and press Enter or click the locked buttons on the right to lock it. In this way the segment will follow the desired angle:

../../../_images/advanced_digitizing_angle.png

Fig. 14.98 Fixed angle segment

14.4.6.5. Relative reference digitizing

Instead of using absolute values of angles or coordinates, you can also use values relative to the last digitized vertex or segment.

For angles, you can click the delta button on the left of the a text box (or press Shift+A) to toggle relative angles to the previous segment. With that option on, angles are measured between the last segment and the mouse pointer.

For coordinates, click the delta buttons to the left of the x or y text boxes (or press Shift+X or Shift+Y) to toggle relative coordinates to the previous vertex. With these options on, coordinates measurement will consider the last vertex to be the X and Y axes origin.

14.4.6.6. Continuous lock

Both in absolute or relative reference digitizing, angle, distance, X and Y constraints can be locked continuously by clicking the lockedRepeat Continuous lock buttons. Using continuous lock allows you to digitize several points or vertexes using the same constraints.

14.4.6.7. Parallel and perpendicular lines

All the tools described above can be combined with the cadPerpendicular Perpendicular and cadParallel Parallel tools. These two tools allow drawing segments perfectly perpendicular or parallel to another segment.

To draw a perpendicular segment, during the editing click the cadPerpendicular Perpendicular icon (keyboard shortcut P) to activate it. Before drawing the perpendicular line, click on the segment of an existing feature that you want to be perpendicular to (the line of the existing feature will be colored in light orange); you should see a blue dotted line where your feature will be snapped:

../../../_images/advanced_digitizing_perpendicular.png

Fig. 14.99 Perpendicular digitizing

To draw a parallel feature, the steps are the same: click on the cadParallel Parallel icon (keyboard shortcut P twice), click on the segment you want to use as reference and start drawing your feature:

../../../_images/advanced_digitizing_parallel.png

Fig. 14.100 Parallel digitizing

These two tools just find the right angle of the perpendicular and parallel angle and lock this parameter during your editing.

14.4.6.8. Construction mode

You can enable and disable construction mode by clicking on the cadConstruction Construction icon or with the C keyboard shortcut. While in construction mode, clicking the map canvas won’t add new vertexes, but will capture the clicks’ positions so that you can use them as reference points to then lock distance, angle or X and Y relative values.

As an example, the construction mode can be used to draw some point at an exact distance from an existing point.

With an existing point in the map canvas and the snapping mode correctly activated, you can easily draw other points at given distances and angles from it. In addition to the cad button, you have to activate also the construction mode by clicking the cadConstruction Construction icon or with the C keyboard shortcut.

Click next to the point from which you want to calculate the distance and click on the d box (D shortcut) type the desired distance and press Enter to lock the mouse position in the map canvas:

../../../_images/advanced_digitizing_distance_point.png

Fig. 14.101 Distance from point

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance entered.

You can also use the angle constraint to, for example, create another point at the same distance of the original one, but at a particular angle from the newly added point. Click the cadConstruction Construction icon or with the C keyboard shortcut to enter construction mode. Click the recently added point, and then the other one to set a direction segment. Then, click on the d text box (D shortcut) type the desired distance and press Enter. Click the a text box (A shortcut) type the angle you want and press Enter. The mouse position will be locked both in distance and angle.

../../../_images/advanced_digitizing_distance_angle_point.png

Fig. 14.102 Distance and angle from points

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance and angle entered. Repeating the process, several points can be added.

../../../_images/advanced_digitizing_distance_point_final.png

Fig. 14.103 Points at given distance and angle

14.4.7. The Processing in-place layer modifier

The Processing menu provides access to a large set of tools to analyze and create new features based on the properties of the input features or their relations with other features (within the same layer or not). While the common behavior is to create new layers as outputs, some algorithms also allow modifications to the input layer. This is a handy way to automate multiple features modification using advanced and complex operations.

To edit features in-place:

  1. Select the layer to edit in the Layers panel.

  2. Select the concerned features. You can skip this step, in which case the modification will apply to the whole layer.

  3. Press the processSelected Edit Features In-Place button at the top of the Processing toolbox. The list of algorithms is filtered, showing only those compatible with in-place modifications, i.e.:

    • They work at the feature source and not at the layer level.

    • They do not change the layer structure, e.g. adding or removing fields.

    • They do not change the geometry type, e.g. from line to point layer.

    ../../../_images/edit_inplace_algorithms.png

    Fig. 14.104 Processing algorithms: all (left) vs polygon in-place editors (right)

  4. Find the algorithm you’d like to run and double-click it.

    Nota

    If the algorithm does not need any additional user-set parameters (excluding the usual input and output layer parameters), then the algorithm is run immediately without any dialog popup.

    1. If parameters other than the usual input or output layers are needed, the algorithm dialog pops up. Fill in the required information.

    2. Click Modify Selected Features or Modify All Features depending on whether there’s an active selection.

    Changes are applied to the layer and placed in the edit buffer: the layer is indeed toggled to editing mode with unsaved modification as indicated by the editableEdits icon next to the layer name.

  5. As usual, press saveEdits Save layer edits to commit the changes in the layer. You can also press undo Undo to rollback the whole modification.