2.2. Lesson: Adding your first layers

Vamos iniciar a aplicação e criar um mapa básico para ser usado nos exemplos e exercícios.

O objetivo para esta lição: começar com um exemplo de mapa.

Nota

Antes de iniciar este exercício, o QGIS deve estar instalado no seu computador. Além disso, você deve ter baixado o sample data para usar.

Inicie o QGIS a partir do atalho na área de trabalho, item de menu etc, dependendo de como você configurou a sua instalação.

Nota

As capturas de tela deste curso foram tiradas no QGIS 3.4 em execução no Linux. Dependendo da sua configuração, as telas que você encontra podem parecer um pouco diferentes. No entanto, todos os mesmos botões ainda estarão disponíveis e as instruções funcionarão em qualquer sistema operacional. Você precisará do QGIS 3.4 (a versão mais recente no momento da redação) para usar este curso.

Vamos começar imediatamente!

2.2.1. basic Follow Along: Prepare um mapa

  1. Abra o QGIS. Você terá um novo mapa em branco.

    ../../../_images/add_blank_qgis.png
  2. A caixa de diálogo Gerenciador de Fonte de Dados permite escolher os dados a serem carregados, dependendo do tipo de dados. Vamos usá-lo para carregar nosso conjunto de dados: clique no botão dataSourceManager Abrir Gerenciador de Fonte de Dados.

    Se você não encontrar o ícone, verifique se a barra de ferramentas Gerenciador de Fonte de Dados está ativada no menu Exibir ‣ Barras de ferramentas.

    ../../../_images/add_data_dialog.png
  3. Carregue o conjunto de dados do vetor protected_areas.shp:

    1. Clique na guia Vetor.

    2. Ative o tipo de fonte radioButtonOnArquivo.

    3. Press the button next to Vector Dataset(s).

    4. Selecione o arquivo exercise_data/shapefile/protected_areas.shp em seu diretório de treinamento.

    5. Clique em Abrir. Você verá a caixa de diálogo original, com o caminho do arquivo preenchido.

      ../../../_images/add_vector_dialog.png
    6. Clique em Adicionar aqui também. Os dados que você especificou agora serão carregados: você pode ver um item protected_areas no painel Camadas (canto inferior esquerdo) com seus recursos mostrados na tela principal do mapa.

      ../../../_images/first_loaded_layer.png

Parabéns! Agora você já tem um mapa básico. Essa seria uma boa hora para salvar seu trabalho.

  1. Clique no botão Salvar como: fileSaveAs

  2. Salve o mapa na pasta solution ao lado de exercise_data e chame-o basic_map.qgz.

2.2.2. basic Try Yourself

Repita as etapas acima para adicionar as camadas places.shp e rivers.shp da mesma pasta (exercise_data/shapefile) ao mapa.

Verifique seus resultados

2.2.3. basic Follow Along: Loading vector data from a GeoPackage Database

Os bancos de dados permitem armazenar um grande volume de dados associados em um arquivo. Você já deve estar familiarizado com um sistema de gerenciamento de banco de dados (DBMS), como Libreoffice Base ou MS Access. Os aplicativos GIS também podem fazer uso de bancos de dados. DBMSes específicos de GIS (como PostGIS) têm funções extras, porque precisam lidar com dados espaciais.

O formato aberto GeoPackage é um contêiner que permite armazenar dados GIS (camadas) em um único arquivo. Diferentemente do formato ESRI Shapefile (por exemplo, o conjunto de dados protected_areas.shp que você carregou anteriormente), um único arquivo GeoPackage pode conter vários dados (dados vetoriais e raster) em diferentes sistemas de referência de coordenadas, além de tabelas sem informações espaciais; todos esses recursos permitem que você compartilhe dados facilmente e evite a duplicação de arquivos.

Para carregar uma camada de um GeoPackage, primeiro você precisa criar a conexão com ela:

  1. Clique no botão dataSourceManager Open Data Source Manager.

  2. À esquerda, clique na guia newGeoPackageLayer GeoPackage.

  3. Clique no botão Novo e navegue até o arquivo training_data.gpkg na pasta exercise_data que você baixou antes.

  4. Selecione o arquivo e pressione Abrir. O caminho do arquivo agora é adicionado à lista de conexões de Geopackage e aparece no menu drop-drown.

Agora você está pronto para adicionar qualquer camada deste GeoPackage ao QGIS.

  1. Click on the Connect button. In the central part of the window you should now see the list of all the layers contained in the GeoPackage file.

  2. Selecione a camada roads e clique no botão Adicionar.

    ../../../_images/add_data_dialog_geopackage.png

    Uma camada roads é adicionada ao painel Camadas com as feições exibidos na tela do mapa.

  3. Clique em Fechar.

Parabéns! Você carregou a primeira camada de um GeoPackage.

2.2.4. basic Follow Along: Loading vector data from a SpatiaLite Database with the Browser

O QGIS fornece acesso a muitos outros formatos de banco de dados. Como o GeoPackage, o formato de banco de dados SpatiaLite é uma extensão da biblioteca SQLite. Adicionar uma camada a partir de um provedor SpatiaLite segue as mesmas regras descritas acima: Crie a conexão –> Ative a conexão –> Adicione a(s) camada(s).

While this is one way to add SpatiaLite data to your map, let’s explore another powerful way to add data: the Browser.

  1. Clique no ícone dataSourceManager para abrir a janela Gerenciador de Fonte de Dados .

  2. Clique na guia fileOpen Navegador.

  3. Nesta guia, você pode ver todos os discos de armazenamento conectados ao seu computador, além de entradas para a maioria das guias à esquerda. Eles permitem acesso rápido a bancos de dados ou pastas conectados.

    Por exemplo, clique no ícone drop-down ao lado da entrada geoPackage GeoPackage. Você verá o arquivo training-data.gpkg ao qual nos conectamos anteriormente (e suas camadas, se expandidas).

  4. Clique com o botão direito do mouse na entrada spatialite SpatiaLite e selecione :guilabel:`Nova conexão… `.

  5. Navegue até a pasta exercise_data, selecione o arquivo landuse.sqlite e clique em Abrir.

    Observe que uma entrada dbSchema landuse.sqlite foi adicionada na SpatiaLite.

  6. Expanda a entrada dbSchema landuse.sqlite.

  7. Clique duas vezes na camada polygonLayer landuse ou selecione e arraste e solte na tela do mapa. Uma nova camada é adicionada ao painel Camadas e seus recursos são exibidos na tela do mapa.

    ../../../_images/spatialite_dialog_connected.png

Dica

Ative o painel Navegador em Exibir ‣ Painéis ‣ e use-o para adicionar seus dados. É um atalho útil para a guia :menus:`Gerenciador de Fonte de Dados --> Navegador`, com a mesma funcionalidade.

Nota

Remember to save your project frequently! The project file doesn’t contain any of the data itself, but it remembers which layers you loaded into your map.

2.2.5. moderate Try Yourself  Carregar Mais Dados Vetoriais

Load the following datasets from the exercise_data folder into your map using any of the methods explained above:

  • buildings

  • água

Check your results

2.2.6. Follow Along: Reordenando as Camadas

As camadas na lista de Camadas são desenhadas no mapa em uma determinada ordem. A camada mais abaixo na lista é desenhada em primeiro lugar e a camada na parte superior é desenhada por último. Alterando a ordem em que são mostradas na lista, você alterará a ordem em que elas são desenhadas.

Nota

Você pode alterar esse comportamento usando a caixa de seleção Controlar ordem de renderização abaixo do painel Ordem de Camada. No entanto, ainda não discutiremos esse recurso.

A ordem em que as camadas estão carregadas no mapa está provavelmente sem lógica nesta etapa. É possível que a camada road (via) esteja completamente escondida por que outras camadas estão sobre ela.

Por exemplo, esta ordem de camada…

../../../_images/incorrect_layer_order.png

… would result in roads and places being hidden as they run underneath the polygons of the landuse layer.

Para resolver este problema:

  1. Clique e arraste em uma camada na lista Camadas.

  2. Reordene-os para se parecer com isso:

../../../_images/correct_layer_order.png

Você verá que o mapa agora faz mais sentido visualmente, com estradas e edifícios que aparecem acima das regiões de uso da terra.

2.2.7. In Conclusion

Now you’ve added all the layers you need from several different sources and created a basic map!

2.2.8. What’s Next?

Now you’re familiar with the basic function of the Open Data Source Manager button, but what about all the others? How does this interface work? Before we go on, let’s take a look at some basic interaction with the QGIS interface. This is the topic of the next lesson.