Outdated version of the documentation. Find the latest one here.

.

Obsługiwane formaty danych

QGIS uses the OGR library to read and write vector data formats, including ESRI shapefiles, MapInfo and MicroStation file formats, AutoCAD DXF, PostGIS, SpatiaLite, Oracle Spatial and MSSQL Spatial databases, and many more. GRASS vector and PostgreSQL support is supplied by native QGIS data provider plugins. Vector data can also be loaded in read mode from zip and gzip archives into QGIS. As of the date of this document, 69 vector formats are supported by the OGR library (see OGR-SOFTWARE-SUITE in Literature and Web References). The complete list is available at http://www.gdal.org/ogr/ogr_formats.html.

Informacja

Not all of the listed formats may work in QGIS for various reasons. For example, some require external commercial libraries, or the GDAL/OGR installation of your OS may not have been built to support the format you want to use. Only those formats that have been well tested will appear in the list of file types when loading a vector into QGIS. Other untested formats can be loaded by selecting *.*.

Praca z danymi wektorowymi GRASS została opisana w rozdziale GRASS GIS Integration.

This section describes how to work with several common formats: ESRI shapefiles, PostGIS layers, SpatiaLite layers, OpenStreetMap vectors, and Comma Separated data (CSV). Many of the features available in QGIS work the same, regardless of the vector data source. This is by design, and it includes the identify, select, labeling and attributes functions.

ESRI Shapefiles

The standard vector file format used in QGIS is the ESRI shapefile. Support is provided by the OGR Simple Feature Library (http://www.gdal.org/ogr/).

Shapefile składa się właściwie z kilku plików. Wymagane są trzy poniższe:

  1. .shp zawierający geometrię obiektów

  2. .dbf zawierający atrybuty w formacie dBase

  3. .shx plik indeksu

Shapefile mogą również zawierać plik z rozszerzeniem .prj z informacją o układzie współrzędnych. Plik z układem jest bardzo przydatny, ale nie jest obowiązkowy. Zbiór danych Shapefile może zawierać jeszcze inne dodatkowe pliki. Więcej informacji o specyfikacji technicznej ESRI znajduje się pod adresem: http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

Loading a Shapefile

To load a shapefile, start QGIS and click on the mActionAddOgrLayer Add Vector Layer toolbar button, or simply press Ctrl+Shift+V. This will bring up a new window (see figure_vector_1).

Figure Vector 1:

../../../_images/addvectorlayerdialog.png

Add Vector Layer Dialog nix

From the available options check radiobuttonon File. Click on [Browse]. That will bring up a standard open file dialog (see figure_vector_2), which allows you to navigate the file system and load a shapefile or other supported data source. The selection box Filter selectstring allows you to preselect some OGR-supported file formats.

You can also select the encoding for the shapefile if desired.

Figure Vector 2:

../../../_images/shapefileopendialog.png

Open an OGR Supported Vector Layer Dialog nix

Selecting a shapefile from the list and clicking [Open] loads it into QGIS. Figure_vector_3 shows QGIS after loading the alaska.shp file.

Figure Vector 3:

../../../_images/shapefileloaded.png

QGIS with Shapefile of Alaska loaded nix

Wskazówka

Kolory warstwy

Gdy ładujesz warstwę do mapy, zostaje jej przypisany losowy kolor. Jeśli ładujesz naraz wiele warstw, wówczas każdej z nich przypisany zostaje inny kolor.

Once a shapefile is loaded, you can zoom around it using the map navigation tools. To change the style of a layer, open the Layer Properties dialog by double clicking on the layer name or by right-clicking on the name in the legend and choosing Properties from the context menu. See section Style Menu for more information on setting symbology of vector layers.

Wskazówka

Ładowanie warstwy i projektu z zewnętrznego źródła danych w OS X

W OS X zewnętrzne nośniki danych montowane poza głównym dyskiem nie są widoczne w menu Plik ‣ Otwórz projekt, chociaż tego właśnie byśmy oczekiwali. Pracujemy nad stworzeniem okna otwierania/zapisywania plików o naturze bliższej OS X, co powinno rozwiązać ten problem. Można obejść ten problem wpisując /Volumes w polu nazwy pliku i naciskając Enter. Możesz potem przeglądać dyski zewnętrze i sieciowe.

Improving Performance for Shapefiles

To improve the performance of drawing a shapefile, you can create a spatial index. A spatial index will improve the speed of both zooming and panning. Spatial indexes used by QGIS have a .qix extension.

Indeks przestrzenny tworzy się w następujący sposób:

  • Load a shapefile by clicking on the mActionAddOgrLayer Add Vector Layer toolbar button or pressing Ctrl+Shift+V.
  • Otwórz okno Właściwości warstwy dwukrotnie klikając na nazwie Shapefile lub klikając prawym przyciskiem myszy i wybierając z menu podręcznego Właściwości.

  • W zakładce Ogólne kliknij przycisk [Twórz indeks przestrzenny].

Problem loading a shape .prj file

If you load a shapefile with a .prj file and QGIS is not able to read the coordinate reference system from that file, you will need to define the proper projection manually within the General tab of the Layer Properties dialog of the layer by clicking the [Specify...] button. This is due to the fact that .prj files often do not provide the complete projection parameters as used in QGIS and listed in the CRS dialog.

For the same reason, if you create a new shapefile with QGIS, two different projection files are created: a .prj file with limited projection parameters, compatible with ESRI software, and a .qpj file, providing the complete parameters of the used CRS. Whenever QGIS finds a .qpj file, it will be used instead of the .prj.

Loading a MapInfo Layer

mActionAddOgrLayer To load a MapInfo layer, click on the mActionAddOgrLayer Add Vector Layer toolbar button; or type Ctrl+Shift+V, change the file type filter Files of type selectstring: to ‘Mapinfo File [OGR] (*.mif *.tab *.MIF *.TAB)’ and select the MapInfo layer you want to load.

Loading an ArcInfo Binary Coverage

mActionAddOgrLayer To load an ArcInfo Binary Coverage, click on the mActionAddOgrLayer Add Vector Layer toolbar button or press Ctrl+Shift+V to open the Add Vector Layer dialog. Select radiobuttonon Directory as Source type. Change the file type filter Files of type selectstring to ‘Arc/Info Binary Coverage’. Navigate to the directory that contains the coverage file, and select it.

Similarly, you can load directory-based vector files in the UK National Transfer Format, as well as the raw TIGER Format of the US Census Bureau.

Pliki tekstowe z danymi rozdzielanymi separatorami

Dane rozdzielane tabulatorem są bardzo popularnym i chętnie używanym formatem ze względu na jego prostotę i możliwości odczytu – dane mogą być przeglądane i edytowane nawet w w prostym edytorze tekstu. Tekst rozdzielany separatorami może stanowić tabelę atrybutów, której kolumny rozdzielone są pewnym umownym znakiem, a wiersze rozdziela znak złamania wiersza. Pierwszy wiersz zawiera zwykle nazwy kolumn. Popularnym typem tekstu rozdzielanego separatorem jest CSV (Comma Separated Values), w którym kolumny rozdzielone są przecinkiem.

Takie pliki danych mogą również zawierać informację przestrzenną w postaci:

  • współrzędnych punktów w oddzielnych kolumnych

  • jako geometria w postaci WKT (well-known text)

QGIS allows you to load a delimited text file as a layer or ordinal table. But first check that the file meets the following requirements:

  1. Plik musi posiadać nagłówek z nazwami pól rozdzielonymi separatorem. Musi to być pierwsza linia pliku tekstowego.

  2. Wiersz nagłówkowy musi zawierać pole lub pola definiujące geometrię. Pola te mogą mieć dowolną nazwę.

  3. Współrzędne X i Y (jeśli geometria opisana jest współrzędnymi) muszą być podane jako liczby. Układ współrzędnych nie ma znaczenia.

As an example of a valid text file, we import the elevation point data file elevp.csv that comes with the QGIS sample dataset (see section Przykładowe dane):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Uwagi dotyczące pliku tekstowego:

  1. W przykładowym pliku znakiem rozdzielającym jest ; (średnik). Można użyć dowolnego innego znaku do rozdzielenia pól.

  2. Pierwszy wiersz to nagłówki. Zawiera on pola X, Y oraz ELEV.

  3. Nie używa się cudzysłowu (") dla pól typu tekstowego.

  4. Współrzędne x podane są w polu X.

  5. Współrzędne y zawarte są w polu Y.

Ładowanie pliku tekstowego z separatorami

Click the toolbar icon delimited_text Add Delimited Text Layer in the Manage layers toolbar to open the Create a Layer from a Delimited Text File dialog, as shown in figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Delimited Text Dialog nix

First, select the file to import (e.g., qgis_sample_data/csv/elevp.csv) by clicking on the [Browse] button. Once the file is selected, QGIS attempts to parse the file with the most recently used delimiter. To enable QGIS to properly parse the file, it is important to select the correct delimiter. You can specify a delimiter by activating radiobuttonon Custom delimiters, or by activating radiobuttonon Regular expression delimiter and entering text into the Expression field. For example, to change the delimiter to tab, use \t (this is a regular expression for the tab character).

Once the file is parsed, set Geometry definition to radiobuttononPoint coordinates and choose the X and Y fields from the dropdown lists. If the coordinates are defined as degrees/minutes/seconds, activate the checkbox DMS coordinates checkbox.

Finally, enter a layer name (e.g., elevp), as shown in figure_delimited_text_1. To add the layer to the map, click [OK]. The delimited text file now behaves as any other map layer in QGIS.

Istnieje również możliwość obcinania spacji poprzedzających i następujących po tekście poprzez zaznaczenie pola wyboru checkbox Usuń spacje przed/po. W każdym rekordzie można też checkbox Pominąć puste kolumny. Można też, jeśli zachodzi taka konieczność, określić checkbox Przecinek jako separator dziesiętny.

If spatial information is represented by WKT, activate the radiobuttonon Well Known Text option and select the field with the WKT definition for point, line or polygon objects. If the file contains non-spatial data, activate radiobuttonon No geometry (attribute only table) and it will be loaded as an ordinal table.

Additionaly, you can enable:

  • checkbox Indeks przestrzenny aby poprawić wydajność wyświetlania i zapytań przestrzennych

  • checkbox Indeks filtrowania.

  • checkbox Watch file to watch for changes to the file by other applications while QGIS is running.

Dane OpenStreetMap

In recent years, the OpenStreetMap project has gained popularity because in many countries no free geodata such as digital road maps are available. The objective of the OSM project is to create a free editable map of the world from GPS data, aerial photography or local knowledge. To support this objective, QGIS provides suppport for OSM data.

Ładowanie warstw wektorowych OpenStreetMap

QGIS integrates OpenStreetMap import as a core functionality.

  • Aby połączyć się z serwerem OSM i ściągnąć dane otwórz menu Wektor‣ Openstreetmap ‣ Pobierz dane. Możesz pominąć ten krok, jeśli już ściągnąłeś plik XML .osm za pośrednictwem JOSM, Overpass API lub z innego źródła.

  • Polecenie Wektor ‣ OpenStreetMap ‣ Wczytaj topologię z XML... przetworzy plik .osm do bazy SpatiaLite i utworzy stosowne połączenie z tą bazą.

  • The menu Vector ‣ Openstreetmap ‣ Export topology to SpatiaLite then allows you to open the database connection, select the type of data you want (points, lines, or polygons) and choose tags to import. This creates a SpatiaLite geometry layer that you can add to your project by clicking on the mActionAddSpatiaLiteLayer Add SpatiaLite Layer toolbar button or by selecting the mActionAddSpatiaLiteLayer Add SpatiaLite Layer... option from the Layer menu (see section Warstwy SpatiaLite).

Warstwy PostGIS

PostGIS layers are stored in a PostgreSQL database. The advantages of PostGIS are the spatial indexing, filtering and query capabilities it provides. Using PostGIS, vector functions such as select and identify work more accurately than they do with OGR layers in QGIS.

Tworzenie połączenia z bazą danych

mActionAddPostgisLayer The first time you use a PostGIS data source, you must create a connection to the PostgreSQL database that contains the data. Begin by clicking on the mActionAddPostgisLayer Add PostGIS Layer toolbar button, selecting the mActionAddPostgisLayer Add PostGIS Layer... option from the Layer menu, or typing Ctrl+Shift+D. You can also open the Add Vector Layer dialog and select radiobuttonon Database. The Add PostGIS Table(s) dialog will be displayed. To access the connection manager, click on the [New] button to display the Create a New PostGIS Connection dialog. The parameters required for a connection are:

  • Nazwa: nazwa połączenia. Może być taka sama jak Baza danych

  • Usługa: parametr usługi, który może być używany zamiennie z host/port (i potencjalnie również z bazą danych). Można to zdefiniować w pg_service.conf.

  • Host: Name of the database host. This must be a resolvable host name such as would be used to open a telnet connection or ping the host. If the database is on the same computer as QGIS, simply enter ‘localhost’ here.
  • Port: numer portu, na którym nasłuchuje serwer bazy danych PostgreSQL. Domyślnym portem jest 5432.

  • Baza danych: nazwa bazy danych.

  • SSL mode: How the SSL connection will be negotiated with the server. Note that massive speedups in PostGIS layer rendering can be achieved by disabling SSL in the connection editor. The following options are available:
    • Wyłącz: nawiązane będzie połączenie nieszyfrowane.

    • Zezwól: spróbuj nawiązać połączenie bez SSL, a gdy będzie to niemożliwe, spróbuj nawiązać połączenie SSL.

    • Preferuj (domyślne): spróbuj nawiązać połączenie SSL, a gdy jest to niemożliwe, spróbuj nawiązać połączenie bez SSL.

    • Wymagaj: próbuj nawiązać jedynie połączenie SSL.

  • Użytkownik: nazwa użytkownika logującego się do bazy danych.

  • Hasło: hasło Użytkownika logującego się do bazy danych.

Można też zaznaczyć następujące pola wyboru:

  • checkbox Zapisz nazwę użytkownika

  • checkbox Zapisz hasło

  • checkbox Wyświetlaj tylko zarejestrowane warstwy

  • checkbox Nie sprawdzaj typu dla kolumn GEOMETRY

  • checkbox Sprawdź tylko schemat ‘public’

  • checkbox Pokaż także tabele bez geometrii

  • checkbox Użyj szacunkowych metadanych tabeli

Po podaniu parametrów i opcji połączenia można przetestować połączenie klikając na przycisk [Test połączenia].

Ładowanie warstwy PostGIS

mActionAddPostgisLayer Once you have one or more connections defined, you can load layers from the PostgreSQL database. Of course, this requires having data in PostgreSQL. See section Importowane danych do PostgreSQL for a discussion on importing data into the database.

W celu załadowania warstwy PostGIS wykonaj następujące czynności:

  • If the Add PostGIS layers dialog is not already open, selecting the mActionAddPostgisLayer Add PostGIS Layer... option from the Layer menu or typing Ctrl+Shift+D opens the dialog.
  • Wybierz połączenie z bazą z listy rozijalnej i naciśnij [Połącz].

  • Wybierz lub odznacz checkbox Pokaż także tabele bez geometrii.

  • Możesz również skorzystać z checkbox Opcji wyszukiwania aby określić, które obiekty z zaznaczonej warstwy załadować lub wykorzystać przycisk [Ustaw filtr], żeby otworzyć okno kreatora zapytań.

  • Na liście dostępnych warstw yszukaj warstwę(y), które chcesz dodać.

  • Zaznacz ją poprzez kliknięcie. Można zaznaczać więcej warstw przytrzymując w czasie klikania klawisz Shift. Zobacz Query Builder, gdzie opisano wykorzystanie kreatora zapytań PostgreSQL do jeszcze dokładniejszego określania warstw.

  • Naciśnij przycisk [Dodaj] aby dodać warstwę do mapy.

Wskazówka

Warstwy PostGIS

Normally, a PostGIS layer is defined by an entry in the geometry_columns table. From version 0.9.0 on, QGIS can load layers that do not have an entry in the geometry_columns table. This includes both tables and views. Defining a spatial view provides a powerful means to visualize your data. Refer to your PostgreSQL manual for information on creating views.

Kilka szczegółów o warstwach PostgreSQL

This section contains some details on how QGIS accesses PostgreSQL layers. Most of the time, QGIS should simply provide you with a list of database tables that can be loaded, and it will load them on request. However, if you have trouble loading a PostgreSQL table into QGIS, the information below may help you understand any QGIS messages and give you direction on changing the PostgreSQL table or view definition to allow QGIS to load it.

QGIS requires that PostgreSQL layers contain a column that can be used as a unique key for the layer. For tables, this usually means that the table needs a primary key, or a column with a unique constraint on it. In QGIS, this column needs to be of type int4 (an integer of size 4 bytes). Alternatively, the ctid column can be used as primary key. If a table lacks these items, the oid column will be used instead. Performance will be improved if the column is indexed (note that primary keys are automatically indexed in PostgreSQL).

If the PostgreSQL layer is a view, the same requirement exists, but views do not have primary keys or columns with unique constraints on them. You have to define a primary key field (has to be integer) in the QGIS dialog before you can load the view. If a suitable column does not exist in the view, QGIS will not load the layer. If this occurs, the solution is to alter the view so that it does include a suitable column (a type of integer and either a primary key or with a unique constraint, preferably indexed).

QGIS offers a checkbox Select at id that is activated by default. This option gets the ids without the attributes which is faster in most cases. It can make sense to disable this option when you use expensive views.

Wskazówka

Backup of PostGIS database with layers saved by QGIS

If you want to make a backup of your PostGIS database using the pg_dump and pg_restore commands the default layer styles as saved by QGIS are failing to restore afterwards. You need to set the XML option to DOCUMENT and the restore will work.

Importowane danych do PostgreSQL

Data can be imported into PostgreSQL/PostGIS using several tools, including the SPIT plugin and the command line tools shp2pgsql and ogr2ogr.

Zarządzanie bazami

QGIS comes with a core plugin named icon_dbmanager DB Manager. It can be used to load shapefiles and other data formats, and it includes support for schemas. See section DB Manager Plugin for more information.

shp2pgsql

PostGIS zawiera narzędziezwane shp2pgsql, które może być wykorzystane do importu shapefile do bazy PostGIS. Na przykład, aby zaimportować shapefile o nazwie lakes.shp do bazy PostgreSQL o nazwie gis_data, skorzystaj z następującego polecenia:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

Spowoduje to utworzenie nowej warstwy o nazwie lakes_new w bazie danych gis_data. Warstwa będzie miała miała nadany układ współrzędnych o identyfikatorze (SRID) 2964. Więcej informacji o układach odniesienia i odwzorowaniach znajdziesz w rozdziale Praca z układami współrzędnych.

Wskazówka

Eksportowanie zbiorów danych z PostGIS

Podobnie do narzędzia importu shp2pgsql istnieje również narzędzie do eksportowania zbiorów danych z PostGIS jako shapefile: pgsql2shp. Jest ono dołączone do twojej dystrybucji PostGIS.

ogr2ogr

Oprócz shp2pgsql i DB Menadżera jest jeszcze jedno narzędzie, któe może posłużyć do wsadzania danych do bazy PostGIS: ogr2ogr. Jest ono częścią instalacji GDAL.

Importowanie shapefile do PostGIS odbywa się w następujący sposób:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres
password=topsecret" alaska.shp

Spowoduje to wgranie shapefile alaska.shp do bazy danych PostGIS postgis przy użyciu użytkownika postgres z hasłem topsecret na hoście myhost.de.

Zwróć uwagę, że OGR musi być skompilowany z PostgreSQL, aby obsługiwać PostGIS. Można to sprawdzić wpisując (w nix)

ogrinfo --formats | grep -i post

Jeśli chciałbyś wykorzystać polecenie PostgreSQL COPY zamiast domyślnej metody INSERT INTO możesz określić następującą zmienną środowiskową (przynajmniej na nix i osx):

export PG_USE_COPY=YES

ogr2ogr nie tworzy indeksów przestrzennych, tak jak shp2pgsql. Musisz utworzyć go ręcznie osobnym poleceniem SQLa CREATE INDEX (opis znajdziesz w następnym rozdziale Zwiększanie wydajności).

Zwiększanie wydajności

Retrieving features from a PostgreSQL database can be time-consuming, especially over a network. You can improve the drawing performance of PostgreSQL layers by ensuring that a PostGIS spatial index exists on each layer in the database. PostGIS supports creation of a GiST (Generalized Search Tree) index to speed up spatial searches of the data (GiST index information is taken from the PostGIS documentation available at http://postgis.refractions.net).

Składnia tworzenia indeksu GIST jest następująca:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Zwróć uwagę, że dla większych tabel tworzenie indeksu może trwać długo. Po utworzeniu indeksu należy przeprowadzić VACUUM ANALYZE. Więcej informacji znajdziesz w dokumentacji PostGIS (POSTGIS-PROJECT Literature and Web References).

Poniżej znajduje się przykład tworzenia indeksu GIST:

[email protected]:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

Warstwy wektorowe przechodzące przez południk 180

Many GIS packages don’t wrap vector maps with a geographic reference system (lat/lon) crossing the 180 degrees longitude line (http://postgis.refractions.net/documentation/manual-2.0/ST_Shift_Longitude.html). As result, if we open such a map in QGIS, we will see two far, distinct locations, that should appear near each other. In Figure_vector_4, the tiny point on the far left of the map canvas (Chatham Islands) should be within the grid, to the right of the New Zealand main islands.

Figure Vector 4:

../../../_images/vectorNotWrapping.png

Map in lat/lon crossing the 180° longitude line nix

Można to obejść korzystając z funkcji PostGIS o nazwie ST_Shift_Longitude. Czyta ona każdy punkt/wierzchołek wszystkich części każdego obiektu w geometrii warstwy i, jeśli długość geogr. < 0°, dodaje do niej 360°. W wyniku tego otrzymujemy wersję danych w przedziale 0° - 360° wycentrowaną na południku 180°.

Figure Vector 5:

../../../_images/vectorWrapping.png

Przejście przez południk 180° z zastosowaniem funkcji ST_Shift_Longitude

Sposób użycia

  • Zaimportuj dane do PostGIS (Importowane danych do PostgreSQL) korzystając np. z wtyczki DB Menadżer.

  • Skorzystaj z linii poleceń PostGIS i wydaj następujące polecenie (jest to przykład, w którym “TABLE” jest właściwą nazwą tabeli PostGIS): gis_data=# update TABLE set the_geom=ST_Shift_Longitude(the_geom);

  • Jeśli wszystko pójdzie dobrze, otrzymasz potwierdzenie z liczbą obiektów, które zostały zaktualizowane i będziesz mógł załadować mapę i zobaczyć różnicę (Figure_vector_5)

Warstwy SpatiaLite

mActionAddSpatiaLiteLayer The first time you load data from a SpatiaLite database, begin by clicking on the mActionAddSpatiaLiteLayer Add SpatiaLite Layer toolbar button, or by selecting the mActionAddSpatiaLiteLayer Add SpatiaLite Layer... option from the Layer menu, or by typing Ctrl+Shift+L. This will bring up a window that will allow you either to connect to a SpatiaLite database already known to QGIS, which you can choose from the drop-down menu, or to define a new connection to a new database. To define a new connection, click on [New] and use the file browser to point to your SpatiaLite database, which is a file with a .sqlite extension.

Jeśli chcesz zapisać warstwę wektorową w formacie SpatiaLite, możesz to zrobić klikając prawym przyciskiem warstwę w legendzie i wybierając polecenie Zapisz jako..., następnie podaj nazwę pliku, jako format zapisu wybierz SpatiaLite i określ docelowy układ współrzędnych. Można również wybrać jako format zapisu ‘SQLite’, a następnie, w okienku opcji danych wpisać SPATIALITE=YES. W ten sposób OGR utworzy bazę SpatiaLite. Zobacz również http://www.gdal.org/ogr/drv_sqlite.html.

QGIS also supports editable views in SpatiaLite.

Tworzenie nowej warstwy SpatiaLite

Jeśli chcesz utworzyć nową warstwę SpatiaLite, zajrzyj do rozdziału Creating a new SpatiaLite layer.

Wskazówka

Wtyczki do zarządzania danymi SpatiaLite

For SpatiaLite data management, you can also use several Python plugins: QSpatiaLite, SpatiaLite Manager or DB Manager (core plugin, recommended). If necessary, they can be downloaded and installed with the Plugin Installer.

Warstwy MSSQL Spatial

mActionAddMssqlLayer QGIS also provides native MS SQL 2008 support. The first time you load MSSQL Spatial data, begin by clicking on the mActionAddMssqlLayer Add MSSQL Spatial Layer toolbar button or by selecting the mActionAddMssqlLayer Add MSSQL Spatial Layer... option from the Layer menu, or by typing Ctrl+Shift+M.

Warstwy Oracle Spatial

The spatial features in Oracle Spatial aid users in managing geographic and location data in a native type within an Oracle database. QGIS now has support for such layers.

Tworzenie połączenia z bazą danych

mActionAddOracleLayer The first time you use an Oracle Spatial data source, you must create a connection to the database that contains the data. Begin by clicking on the mActionAddOracleLayer Add Orcale Spatial Layer toolbar button, selecting the mActionAddOracleLayer Add Orcale Spatial Layer... option from the Layer menu, or typing Ctrl+Shift+O. To access the connection manager, click on the [New] button to display the Create a New Oracle Spatial Connection dialog. The parameters required for a connection are:

  • Nazwa: nazwa połączenia. Może być taka sama jak Baza danych

  • Database: SID lub SERVICE_NAME instancji Oracle.

  • Host: Name of the database host. This must be a resolvable host name such as would be used to open a telnet connection or ping the host. If the database is on the same computer as QGIS, simply enter ‘localhost’ here.
  • Port: Port number the Oracle database server listens on. The default port is 1521.
  • Użytkownik: nazwa użytkownika logującego się do bazy danych.

  • Hasło: hasło Użytkownika logującego się do bazy danych.

Można też zaznaczyć następujące pola wyboru:

  • checkbox Zapisz użytkownika Wskazuje, czy w danych konfiguracyjnych połączenia zapisać również nazwę użytkownika.

  • checkbox Zapisz hasło Wskazuje, czy w konfiguracji połączenia zapisać hasło użytkownika bazy.

  • checkbox Przeszukaj tylko meta data table Ogranicza wyświetlane tabele tylko do zapisanych w widoku all_sdo_geom_metadata. Może to znacząco przyspieszyć pierwsze wyświetlenie tabel przestrzennych.

  • checkbox Szukaj tylko tabel użytkownika Ogranicz poszukiwanie tabel przestrzennych do będących własnością użytkownika.

  • checkbox Pokaż także tabele bez geometrii. Wskazuje, czy wyszczególnione mają zostać również tabele bez geometrii.

  • checkbox Użyj szacunkowych metadanych tabeli Oracle przechowuje liczne metadane o tabelach, takie jak liczba rekordów, typ geometrii, zasięg przestrzenny danych geometrycznych. Jeśli tabela ma wiele rekordów, uzyskanie tych informacji może być czasochłonne. Włączenie tych opcji spowoduje przyspieszenie tych operacji poprzez: oszacowanie liczby rekordów z all_tables.num_rows. Zasięg tabeli będzie zawsze określany funkcją SDO_TUNE.EXTENTS_OF, nawet jeśli użyto filtra warstwy. Tabela geometrii jest określana z pierwszych 100 niepustych (NOT NULL) rekordów geometrii.

  • checkbox Tylko istniejące typy geometrii. Wyszczególniaj tylko istniejące typy geometrii i nie oferuj dodawania nowych.

Po podaniu parametrów i opcji połączenia można przetestować połączenie klikając na przycisk [Test połączenia].

Wskazówka

Ustawienia użytkownika QGIS a bezpieczeństwo

Depending on your computing environment, storing passwords in your QGIS settings may be a security risk. Passwords are saved in clear text in the system configuration and in the project files! Your customized settings for QGIS are stored based on the operating system:

  • nix Ustawienia przechowywane są w twoim katalogu domowym w ~/.qgis2.

  • win Ustawienia przechowywane są w rejestrze.

Ładowanie warstwy Oracle Spatial

mActionAddOracleLayer Once you have one or more connections defined, you can load layers from the Oracle database. Of course, this requires having data in Oracle.

W celu załadowania warstwy z Oracle Spatial wykonaj następujące kroki/l

  • If the Add Oracle Spatial layers dialog is not already open, click on the mActionAddOracleLayer Add Oracle Spatial Layer toolbar button.
  • Wybierz połączenie z bazą z listy rozijalnej i naciśnij [Połącz].

  • Wybierz lub odznacz checkbox Pokaż także tabele bez geometrii.

  • Możesz również skorzystać z checkbox Opcji wyszukiwania aby określić, które obiekty z zaznaczonej warstwy załadować lub wykorzystać przycisk [Ustaw filtr], żeby otworzyć okno kreatora zapytań.

  • Na liście dostępnych warstw yszukaj warstwę(y), które chcesz dodać.

  • Zaznacz ją poprzez kliknięcie. Można zaznaczać więcej warstw przytrzymując w czasie klikania klawisz Shift. Zobacz Query Builder, gdzie opisano wykorzystanie kreatora zapytań Oracle do jeszcze dokładniejszego określania warstw.

  • Naciśnij przycisk [Dodaj] aby dodać warstwę do mapy.

Wskazówka

Warstwy Oracle Spatial

Zwykle warstwa Oracle Spatial zdefiniowana jest poprzez wpis w tabeli USER_SDO_METADATA.