Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Informacja

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Wskazówka

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Wskazówka

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Właściwości projektu

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • Menu Układ współrzędnych umożliwia wybór układu dla bieżącego projektu oraz włączenie przeliczania w locie współrzędnych warstw wektorowych i rastrowych w przypadku, gdy zapisane są w innym układzie współrzędnych.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Opcje section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • W zakładce Makra tworzy się moduły Pythona dla projektu. Obecnie można zdefiniować trzy makra uruchamiane w czasie następujących zdarzeń: openProject(), saveProject() oraz closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • Zakładka Relacje służy do definiowania relacji 1:n. Gdy określone zostaną relacje dla którejś z warstw, w interfejsie użytkownika w widoku formularza pojawiać się będzie nowy element przedstawiający połączone obiekty (np. podczas użycia narzędzia informacji o obiekcie i włączeniu jego formularza). Daje to potężne możliwości przedstawiania dodatkowych informacji o obiektach, np. historycznych wynikach pomiarów rurociągu lub długości drogi. Więcej informacji o relacjach 1:n można znaleźć w rozdziale Creating one to many relations.

Opcje

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Zakładka Ogólne

Program

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Nie pokazuj ekranu powitalnego przy starcie

  • checkbox Pokazuj poradę przy starcie programu

  • checkbox Pogrubiony tytuł grupy

  • checkbox Styl QGIS grupy

  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

Pliki projektów

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Twórz nowe projekty na bazie domyślnego. Możesz wybrać :guilabel:Bieżący projekt jako domyślny` or lub Wyczyść domyślny. Możesz wskazać katalog, w którym znajdować się będą szablony projektów zdefiniowane przez użytkownika. Gdy zapiszesz projekt w tym katalogu, pojawi się on jako pozycja w menu Projekt ‣ Nowy z szablonu.

  • checkbox Informuj o konieczności zapisu, gdy projekt i źródło ulegną zmianie

  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Ostrzegaj przy otwieraniu projektów zapisanych w starszych wersjach QGIS

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Zakładka System

Środowisko

W zakładce System można teraz przeglądać wartości zmiennych środowiskowych, a wiele z nich można również edytować (zob. figure_environment_variables). Może się to przydać na platformach takich jak Mac, gdzie aplikacje GUI nie dziedziczą ustawień środowiskowych powłoki. Jest to również przydatne przy przeglądaniu i zmianie ustawień środowiska dla narzędzi zewnętrznych zarządzanych przez Geoprocesing (np. SAGA, GRASS) i przy włączaniu wyjścia debugowania dla określonych partii kodu źródłowego.

  • checkbox Zastosuj zmienne użytkownika (wymaga ponownego uruchomienia; zawiera separatory). Zmienne można [Dodać] i [Usunąć]. Zdefiniowane dotychczas zmienna wyświetlane są w ramce Aktualne zmienne środowiska, przy czym istnieje możliwość filtrowania zmiennych poprzez zaznaczenie opcji checkbox Pokaż jedynie zmienne QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Ścieżki wtyczek

[Dodaj] lub [Usuń] Ścieżki poszukiwań dodatkowych wtyczek C++

Zakładka Źródła danych

Tabela i atrybuty obiektów

  • checkbox Otwórz tabelę atrybutów w oknie dokowalnym (wymaga restarty QGIS-a)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Wartość NULL jest reprezentowana przez. Można tu określić wartość dla pól zawierających wartość NULL.

Obsługa źródeł danych

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Pytaj o podwarstwy rastrowe przy otwieraniu. Niektóre rastry obsługują podwarstwy — w GDAL nazywane są one podzbiorami danych (subdatasets). Przykładem mogą być pliki netcdf — gdy istnieje wiele wariantów netcdf, GDAL rozpoznaje każdy z nich jako podzbiór danych. Ta opcja dotyczy sposobu, w jaki traktowane mają być podwarstwy, gdy otwierany jest plik z podwarstwami. Mamy do wyboru:

    • ‘Zawsze’: zawsze pytaj (czy istnieją podwarstwy)

    • ‘Jeśli konieczne’: pytaj, czy warstwa nie ma pasm, a posiada podwarstwy

    • ‘Nigdy’: nigdy nie pytaj i nie ładuj podwarstw.

    • ‘Wczytaj wszystkie’: nigdy nie pytaj, ale załaduj wszystkie podwarstwy

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Dodaj warstwy Oracle podwójnym kliknięciem i wybierz w trybie rozszerzonym

Zakładka Renderowanie

Rendering behaviour

  • checkbox Domyślnie nowo dodawane warstwy są wyświetlane

  • checkbox Użyj pamięci podręcznej aby przyspieszyć odświeżanie.

  • checkbox Wykorzystuj wiele rdzeni CPU

  • checkbox ale nie więcej niż

  • Odświeżaj widok mapy co (dmyślnie 250 ms)

  • checkbox Enable feature simplication by default for newly added layers
  • Próg upraszczania (większe wartości to większe uproszczenia)

  • checkbox Upraszczaj w źródle danych (jeśli to możliwe)

  • Maksymalna skala upraszczania (1:1 - zawsze)

Jakość wyświetlania

  • checkbox Pokaż linie jako mniej postrzępione kosztem wydajności wyświetlania

Rastry

  • W Kanały RGB możesz określić numery kanałów czrwonego, zielonego i niebieskiego.

Wzmocnienie kontrastu

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Łączna liczba pikseli

  • Wielokrotność odchylenia standardowego

Śledzenie błędów

  • checkbox Odświeżanie obszaru mapy

Kolory

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Zakładka Mapa i legenda

Domyślny wygląd mapy (nadpisywany przez właściwości projektu)

  • Określ kolor obiektów zaznaczonych i kolor tła.

Legenda warstwy

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Można określić następujące opcje Stylu legendy:

    • checkbox Nazwy warstw dużą literą

    • checkbox Nazwy warstw pogrubione

    • checkbox Nazwy grup pogrubione

    • checkbox Wyświetl atrybuty klasyfikacji

    • checkbox Twórz miniatury warstw rastrowych (może spowolnić program)

Zakładka Narzędzia mapy

This menu offers some options regarding the behaviour of the Identify tool.

  • Promień wyszukiwania przy wskazywaniu obiektów i wyświetlaniu podpowiedzi jest wskaźnikiem tolerancji wyrażanym w procentach jednostkek mapy. Oznacza to, że narzędzie poda informacje o obiektach znajdujących się w promieniu mniejszym od tej tolerancji.

  • Kolor wybranych określa jakim kolorem rysowane będą identyfikowane obiekty.

  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Narzędzie pomiaru

  • Określenie koloru linijki dla narzędzi pomiarowych

  • Określenie Ilości cyfr dziesiętnych

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Przesuwanie i powiększanie

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Określanie Współczynnika powiększenia dla kółka myszy

Zdefiniowane skale

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Zakładka Wydruk

Domyślne ustawienia wydruku

You can define the Default font here.

Wygląd siatki

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Grid color

Grid and guide defaults

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Zakładka Digitalizacja

Tworzenie obiektów

  • checkbox Nie pokazuj okna z atrybutami po utworzeniu obiektu

  • checkbox Użyj ostatnich wprowadzonych wartości atrybutu

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Linijka

  • Określenie grubości linii i koloru linii

Przyciąganie

  • checkbox Dokowane okno opcji (wymaga restartu QGIS-a)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Domyślna tolerancja przyciągania w jednostkach mapy lub pikselach

  • Określ Promień wyszukiwania przy edycji wierzchołków w jednostkach mapy lub pikselach

Znaczniki wierzchołków

  • checkbox Wyświetl znaczniki jedynie dla wybranych obiektów

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Określ Rozmiar markera wierzchołków

Przesunięcie krzywych

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Advanced digitizing. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Styl połączenia

  • Segmentów kwadrantu

  • Limit fazy (uciosu)

Zakładka GDAL

GDAL jest biblioteką wymiany danych dla plików rastrowych. W tej zakładce można podać Opcje generowania i Opcje piramid dla rastrów. Można także określić, który ze sterowników GDAL ma być wykorzystany dla określonego formatu rastra, gdy, jak ma to czasem miejsce, dostępnych jest kilka.

Zakładka Układ współrzędnych

Domyślny układ współrzędnych dla nowych projektów

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Zawsze stosuj ten układ dla nowych projektów i wybierz jakiś układ

Układ współrzędnych dla nowych warstw

To pole pozwala określić, co ma się zdarzyć, gdy tworzona jest nowa warstwa lub ładowana jest warstwa bez określonego układu współrzędnych.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Domyślne transformacje układów odniesienia

  • checkbox Pytaj o transformację, gdy brak domyślnej

  • Jeśli korzystałeś już z reprojekcji w locie, informację o tym znajdziesz w okienku poniżej. Są tam informacje o źródłowych i docelowych układach współrzędnych płaskich i wysokościowych.

Zakładka Język

  • checkbox Nadpisz ustawienia lokalne i Wybierz wersję językową

  • Wykryte ustawienia lokalne w twoim systemie

Zakładka Sieć

Ogólne

  • Adres przeszukiwania WMS, domyślny to http://geopole.org/wms/search?search=\%1\&type=rss

  • Limit czasu dla zapytań sieciowych (ms) - domyślny wynosi 60000

  • Czas przedawnienia dla kafli WMSC/WMTS (h) - domyślny to 24

  • Można określić Limit prób przy błędach pobierania kafli

  • Klient użytkownika (User-Agent)

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Ustawienia cache

Katalog i Rozmiar dla cache.

  • checkbox Użyj serwera proxy przy dostępie do sieci wymaga podania ‘Hosta’ i opcjonalnie ‘Portu’, ‘Użytkownika’ oraz ‘Hasła’.

  • Set the Proxy type selectstring according to your needs.
    • Default Proxy: Proxy określany jest na podstawie ustawień aplikacji proxy

    • Socks5Proxy: ogólny proxy dla wszelkiego typu połączeń. Obsługuje TCP, UDP, binding do portu (dla połączeń przychodzących) oraz autoryzację.

    • HttpProxy: zaimplementowany z użyciem komendy “CONNECT”, obsługuje jedynie połączenia wychodzące. Obsługuje autoryzację.

    • HttpCachingProxy: Zaimplementowany przy użyciu zwykłych poleceń HTTP, użyteczny jedynie w kontekście zapytań HTTP.

    • FtpCachingProxy: Zaimplementowany przy użyciu pproxy FTP, użyteczny jedynie w kontekście zapytań FTP.

Można dodać wykluczenia niektórych URL w okienku tekstowym poniżej ustawień proxy (zob. Figure_Network_Tab).

Jeśli będziesz potrzebował bardziej szczegółowych informacji o ustawieniach proxy, zajrzyj do manuala w dokumentacji biblioteki QT, która dostępna jest pod adresem http://qt-project.org/doc/qt-4.8/qnetworkproxy.html#ProxyType-enum.

Wskazówka

Korzystanie z proxy

Korzystanie z proxy może być trudne. Można próbować kolejno wymienionych wyżej ustawień i sprawdzać, czy działają.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Ustawienia zapisywane są pliku tekstowym: $HOME/.config/QGIS/QGIS2.conf

  • osx swoje ustawienia znajdziesz w: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Ustawienia zapisane są w rejestrze pod: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalizacja

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.