Outdated version of the documentation. Find the latest one here.

.

Unterstützte Datenformate

QGIS uses the OGR library to read and write vector data formats, including ESRI shapefiles, MapInfo and MicroStation file formats, AutoCAD DXF, PostGIS, SpatiaLite, Oracle Spatial and MSSQL Spatial databases, and many more. GRASS vector and PostgreSQL support is supplied by native QGIS data provider plugins. Vector data can also be loaded in read mode from zip and gzip archives into QGIS. As of the date of this document, 69 vector formats are supported by the OGR library (see OGR-SOFTWARE-SUITE in Literatur und Internetreferenzen). The complete list is available at http://www.gdal.org/ogr/ogr_formats.html.

Bemerkung

Not all of the listed formats may work in QGIS for various reasons. For example, some require external commercial libraries, or the GDAL/OGR installation of your OS may not have been built to support the format you want to use. Only those formats that have been well tested will appear in the list of file types when loading a vector into QGIS. Other untested formats can be loaded by selecting *.*.

Das Arbeiten mit GRASS GIS Vektorlayern wird in Kapitel GRASS GIS Integration beschrieben.

This section describes how to work with several common formats: ESRI shapefiles, PostGIS layers, SpatiaLite layers, OpenStreetMap vectors, and Comma Separated data (CSV). Many of the features available in QGIS work the same, regardless of the vector data source. This is by design, and it includes the identify, select, labeling and attributes functions.

ESRI Shapes

The standard vector file format used in QGIS is the ESRI shapefile. Support is provided by the OGR Simple Feature Library (http://www.gdal.org/ogr/).

Ein Shape besteht derzeit aus mehreren Dateien. Die folgenden drei sind erforderlich:

  1. shp Datei (enthält die Geometrien)

  2. .dbf Datei (enthält die Attribute im dBase-Format)

  3. .shx Indexdatei

Darüber hinaus kann eine Datei mit .prj Endung existieren. Diese enthält die Projektionsinformationen des Shapes. Während es sehr nützlich ist eine Projektionsdatei zu verwenden ist dies nicht zwingend erforderlich. Ein Shape-Datensatz kann zusätzliche Dateien enthalten. Details dazu finden sich in der technischen Spezifikation von ESRI unter http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

Loading a Shapefile

To load a shapefile, start QGIS and click on the mActionAddOgrLayer Add Vector Layer toolbar button, or simply press Ctrl+Shift+V. This will bring up a new window (see figure_vector_1).

Figure Vector 1:

../../../_images/addvectorlayerdialog.png

Add Vector Layer Dialog nix

From the available options check radiobuttonon File. Click on [Browse]. That will bring up a standard open file dialog (see figure_vector_2), which allows you to navigate the file system and load a shapefile or other supported data source. The selection box Filter selectstring allows you to preselect some OGR-supported file formats.

You can also select the encoding for the shapefile if desired.

Figure Vector 2:

../../../_images/shapefileopendialog.png

Open an OGR Supported Vector Layer Dialog nix

Selecting a shapefile from the list and clicking [Open] loads it into QGIS. Figure_vector_3 shows QGIS after loading the alaska.shp file.

Figure Vector 3:

../../../_images/shapefileloaded.png

QGIS with Shapefile of Alaska loaded nix

Tipp

Farben von Vektorlayern

Wenn Sie einen neuen Vektorlayer in QGIS laden, werden Farben zufällig zugewiesen. Wenn Sie mehrere neue Vektorlayer laden, werden jeweils unterschiedliche Farben zugewiesen.

Once a shapefile is loaded, you can zoom around it using the map navigation tools. To change the style of a layer, open the Layer Properties dialog by double clicking on the layer name or by right-clicking on the name in the legend and choosing Properties from the context menu. See section Menü Stil for more information on setting symbology of vector layers.

Tipp

Layer und Projekte von externen Datenträgern laden unter OS X

Unter OS X werden externe Datenträger unter Datei ‣ Öffne Projekt nicht gemeinsam mit den internen Festplatten angezeigt. Dies soll zukünftig behoben werden. Solange können Sie ‘/Volumes’ in das Eingabefenster ‘Dateiname’ eintragen und Return drücken. Danach können Sie auch zu den externen Datenträgern bzw. Rechnern in einem Netzwerk browsen.

Improving Performance for Shapefiles

To improve the performance of drawing a shapefile, you can create a spatial index. A spatial index will improve the speed of both zooming and panning. Spatial indexes used by QGIS have a .qix extension.

Benutzen Sie folgende Schritte zum Erstellen eines räumlichen Index:

  • Load a shapefile by clicking on the mActionAddOgrLayer Add Vector Layer toolbar button or pressing Ctrl+Shift+V.
  • Öffnen Sie den Eigenschaften-Dialog des Vektorlayers, indem Sie auf den Namen des Layers in der Legende doppelklicken oder mit der rechten Maustaste Eigenschaften auswählen.

  • Im Menü Allgemein klicken Sie auf den [Räumlichen Index erzeugen] Knopf.

Problem loading a shape .prj file

If you load a shapefile with a .prj file and QGIS is not able to read the coordinate reference system from that file, you will need to define the proper projection manually within the General tab of the Layer Properties dialog of the layer by clicking the [Specify...] button. This is due to the fact that .prj files often do not provide the complete projection parameters as used in QGIS and listed in the CRS dialog.

For the same reason, if you create a new shapefile with QGIS, two different projection files are created: a .prj file with limited projection parameters, compatible with ESRI software, and a .qpj file, providing the complete parameters of the used CRS. Whenever QGIS finds a .qpj file, it will be used instead of the .prj.

Loading a MapInfo Layer

mActionAddOgrLayer To load a MapInfo layer, click on the mActionAddOgrLayer Add Vector Layer toolbar button; or type Ctrl+Shift+V, change the file type filter Files of type selectstring: to ‘Mapinfo File [OGR] (*.mif *.tab *.MIF *.TAB)’ and select the MapInfo layer you want to load.

Loading an ArcInfo Binary Coverage

mActionAddOgrLayer To load an ArcInfo Binary Coverage, click on the mActionAddOgrLayer Add Vector Layer toolbar button or press Ctrl+Shift+V to open the Add Vector Layer dialog. Select radiobuttonon Directory as Source type. Change the file type filter Files of type selectstring to ‘Arc/Info Binary Coverage’. Navigate to the directory that contains the coverage file, and select it.

Similarly, you can load directory-based vector files in the UK National Transfer Format, as well as the raw TIGER Format of the US Census Bureau.

Delimited Text Dateien

Tabellendaten sind ein sehr beliebtes und weit verbreitetes Format wegen seiner Einfachheit und Lesbarkeit - die Daten können sogar in einem Texteditor eingesehen und bearbeitet werden. Eine Delimited Text Datei ist eine Attributtabelle bei der jede Spalte durch ein definiertes Zeichen und jede Zeile durch einen Zeilenumbruch getrennt wird. Die erste Zeile enthält normalerweise die Spaltennamen. Ein gängiger Typ von Delimited Text Datei ist eine CSV-Datei (Comma Separated Values), bei der jede Spalte durch ein Komma getrennt wird.

Solche Datensätze können auch Positionsinformationen in zwei Formaten enthalten:

  • Als Punktkoordinaten in getrennten Spalten

  • Als WKT-Daten die die Geometrien darstellen

QGIS allows you to load a delimited text file as a layer or ordinal table. But first check that the file meets the following requirements:

  1. Die Datei muss eine begrenzte Kopfspalte mit Feldnamen besitzen. Dieses muss die erste Zeile in der Textdatei sein.

  2. Die Kopfspalte muss Feld(er) mit Geometriedefinitionen enthalten. Diese Feld(er) können jeden beliebigen Namen haben.

  3. Die X und Y Koordinaten (wenn die Geometrien anhand von Koordinaten definiert sind) müssen als Nummern angegeben werden. Das Koordinatensystem ist nicht wichtig.

As an example of a valid text file, we import the elevation point data file elevp.csv that comes with the QGIS sample dataset (see section Beispieldaten):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Einige weitere Anmerkungen zu Textdateien:

  1. Die Beispieldatei verwendet ; (Semikolon) als Trennzeichen. Es können auch andere Zeichen zum Trennen der Spalten verwendet werden.

  2. Die erste Zeile ist die Kopfzeile. Sie enthält die Spaltennamen X, Y und ELEV.

  3. Anführungszeichen (") dürfen nicht als Trennzeichen benutzt werden.

  4. Die X-Koordinaten sind in der Spalte X enthalten.

  5. Die Y-Koordinaten sind in der Spalte Y enthalten.

Eine Delimited Text Datei laden

Click the toolbar icon delimited_text Add Delimited Text Layer in the Manage layers toolbar to open the Create a Layer from a Delimited Text File dialog, as shown in figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Delimited Text Dialog nix

First, select the file to import (e.g., qgis_sample_data/csv/elevp.csv) by clicking on the [Browse] button. Once the file is selected, QGIS attempts to parse the file with the most recently used delimiter. To enable QGIS to properly parse the file, it is important to select the correct delimiter. You can specify a delimiter by activating radiobuttonon Custom delimiters, or by activating radiobuttonon Regular expression delimiter and entering text into the Expression field. For example, to change the delimiter to tab, use \t (this is a regular expression for the tab character).

Once the file is parsed, set Geometry definition to radiobuttononPoint coordinates and choose the X and Y fields from the dropdown lists. If the coordinates are defined as degrees/minutes/seconds, activate the checkbox DMS coordinates checkbox.

Finally, enter a layer name (e.g., elevp), as shown in figure_delimited_text_1. To add the layer to the map, click [OK]. The delimited text file now behaves as any other map layer in QGIS.

Es gibt auch eine Hilfeoption mit der Sie vorangehende und nachfolgende Leerzeichen von Feldern abschneiden können - checkbox Felder abschneiden. Es ist ebenfalls möglich checkbox Leere Felder überspringen anzuwenden. Falls nötig können Sie festlegen dass ein Komma der Dezimalseparator sein soll indem Sie checkbox Dezimalseparator ist Komma aktivieren.

If spatial information is represented by WKT, activate the radiobuttonon Well Known Text option and select the field with the WKT definition for point, line or polygon objects. If the file contains non-spatial data, activate radiobuttonon No geometry (attribute only table) and it will be loaded as an ordinal table.

Additionaly, you can enable:

  • checkbox Räumlichen index benutzen um die Performanz der Darstellung und räumlichen Selektion der Objekte zu verbessern.

  • checkbox Untermengenindex benutzen

  • checkbox Watch file to watch for changes to the file by other applications while QGIS is running.

OpenStreet Daten

In recent years, the OpenStreetMap project has gained popularity because in many countries no free geodata such as digital road maps are available. The objective of the OSM project is to create a free editable map of the world from GPS data, aerial photography or local knowledge. To support this objective, QGIS provides suppport for OSM data.

OpenStreetMap Vektordateien laden

QGIS integrates OpenStreetMap import as a core functionality.

  • Um sich mit dem OSM Server zu verbinden und Daten herunterzuladen öffnen Sie das Menü Vektor ‣ OpenStreetMap ‣ Daten herunterladen. Sie können diesen Schritt überspringen wenn Sie bereits eine .osm XML Datei über JOSM, Overpass API oder durch eine andere Quelle erhalten haben.

  • Das Menü Vektor ‣ OpenStreetMap ‣ Topologie aus XML importieren konvertiert Ihre .osm Datei in eine SpatiaLite Datenbank und erstellt eine entsprechende Datenbankverbindung.

  • The menu Vector ‣ Openstreetmap ‣ Export topology to SpatiaLite then allows you to open the database connection, select the type of data you want (points, lines, or polygons) and choose tags to import. This creates a SpatiaLite geometry layer that you can add to your project by clicking on the mActionAddSpatiaLiteLayer Add SpatiaLite Layer toolbar button or by selecting the mActionAddSpatiaLiteLayer Add SpatiaLite Layer... option from the Layer menu (see section SpatiaLite Layer laden).

PostGIS Layer laden

PostGIS layers are stored in a PostgreSQL database. The advantages of PostGIS are the spatial indexing, filtering and query capabilities it provides. Using PostGIS, vector functions such as select and identify work more accurately than they do with OGR layers in QGIS.

Erstellen einer PostGIS Anbindung

mActionAddPostgisLayer The first time you use a PostGIS data source, you must create a connection to the PostgreSQL database that contains the data. Begin by clicking on the mActionAddPostgisLayer Add PostGIS Layer toolbar button, selecting the mActionAddPostgisLayer Add PostGIS Layer... option from the Layer menu, or typing Ctrl+Shift+D. You can also open the Add Vector Layer dialog and select radiobuttonon Database. The Add PostGIS Table(s) dialog will be displayed. To access the connection manager, click on the [New] button to display the Create a New PostGIS Connection dialog. The parameters required for a connection are:

  • Name: Ein Name für die Verbindung. Kann derselbe wie für die Datenbank sein

  • Dienst: Dienstparameter der alternativ zu Hostname/port verwendet werden kann (und eventuell Datenbank). Dies kann in pg_service.conf definiert werden.

  • Host: Name of the database host. This must be a resolvable host name such as would be used to open a telnet connection or ping the host. If the database is on the same computer as QGIS, simply enter ‘localhost’ here.
  • Port: Port Nummer der Datenbank auf dem Server. Standard ist 5432.

  • Datenbank: Name der Datenbank.

  • SSL mode: How the SSL connection will be negotiated with the server. Note that massive speedups in PostGIS layer rendering can be achieved by disabling SSL in the connection editor. The following options are available:
    • Abschalten: Nur versuchen eine unverschlüsselte SSL-Verbindung herzustellen.

    • Erlauben: Eine nicht-SSL-Verbindung versuchen. Wenn dies misslingt, eine SSL-Verbindung versuchen.

    • Bevorzugen: Eine SSL-Verbindung versuchen. Wenn dies misslingt eine nicht-SSL-Verbindung versuchen.

    • Verlangen: Versuche nur eine SSL-Verbindung.

  • Name: Benutzername, um sich bei der Datenbank anzumelden.

  • Passwort: Passwort das zusammen mit Benutzername verwendet wird um sich bei der Datenbank anzumelden.

Bei Bedarf können Sie die folgenden Kontrollkästchen aktivieren:

  • checkbox Benutzernamen speichern

  • checkbox Passwort speichern

  • checkbox Nur in geometry_columns nachschauen

  • checkbox Geometrietyp von Spalten ohne Einschränkung nicht feststellen (GEOMETRY)

  • checkbox Nur im ‘public’ Schema nachschauen

  • checkbox Auch geometrielose Tabellen anzeigen

  • checkbox Gechätzte Tabellenmetadaten nutzen

Wenn alle Parameter eingetragen sind, kann die Verbindung getestet werden, indem Sie auf den Knopf [Verbindung testen] drücken.

Laden eines Layers aus der PostGIS Datenbank

mActionAddPostgisLayer Once you have one or more connections defined, you can load layers from the PostgreSQL database. Of course, this requires having data in PostgreSQL. See section Layer nach PostgreSQL/PostGIS importieren for a discussion on importing data into the database.

Um eine Ebene aus PostGIS zu laden, führen Sie folgende Schritte durch:

  • If the Add PostGIS layers dialog is not already open, selecting the mActionAddPostgisLayer Add PostGIS Layer... option from the Layer menu or typing Ctrl+Shift+D opens the dialog.
  • Wählen Sie eine Verbindung aus dem Drop-Down Menü und klicken auf [Verbinden].

  • Wählen Sie checkbox Auch geometrielose Tabelle anzeigen an oder ab.

  • Nutzen Sie gegebenenfalls die checkbox Suchoptionen um zu definieren welche Objekte aus dem Layer geladen werden sollen oder benutzen Sie den [Erstelle Abfrage] Knopf um den Abfrageerstellung Dialog zu starten.

  • Suchen Sie einen Layer den Sie laden möchten.

  • Wählen Sie es aus indem Sie darauf klicken. Sie können mehrere Layer gleichzeitig indem Sie die Umschalt-Taste gedrückt halten auswählen. Siehe Abschnitt Abfrageeditor für Informationen wie man die PostgreSQL-Abfrageerstellung für das weitere Definieren des Layers benutzt.

  • Klicken Sie auf den Knopf [Hinzufügen] um den Layer zu laden.

Tipp

PostGIS-Layer

Normally, a PostGIS layer is defined by an entry in the geometry_columns table. From version 0.9.0 on, QGIS can load layers that do not have an entry in the geometry_columns table. This includes both tables and views. Defining a spatial view provides a powerful means to visualize your data. Refer to your PostgreSQL manual for information on creating views.

Einige Details zu PostGIS-Layern

This section contains some details on how QGIS accesses PostgreSQL layers. Most of the time, QGIS should simply provide you with a list of database tables that can be loaded, and it will load them on request. However, if you have trouble loading a PostgreSQL table into QGIS, the information below may help you understand any QGIS messages and give you direction on changing the PostgreSQL table or view definition to allow QGIS to load it.

QGIS requires that PostgreSQL layers contain a column that can be used as a unique key for the layer. For tables, this usually means that the table needs a primary key, or a column with a unique constraint on it. In QGIS, this column needs to be of type int4 (an integer of size 4 bytes). Alternatively, the ctid column can be used as primary key. If a table lacks these items, the oid column will be used instead. Performance will be improved if the column is indexed (note that primary keys are automatically indexed in PostgreSQL).

If the PostgreSQL layer is a view, the same requirement exists, but views do not have primary keys or columns with unique constraints on them. You have to define a primary key field (has to be integer) in the QGIS dialog before you can load the view. If a suitable column does not exist in the view, QGIS will not load the layer. If this occurs, the solution is to alter the view so that it does include a suitable column (a type of integer and either a primary key or with a unique constraint, preferably indexed).

QGIS offers a checkbox Select at id that is activated by default. This option gets the ids without the attributes which is faster in most cases. It can make sense to disable this option when you use expensive views.

Tipp

Backup of PostGIS database with layers saved by QGIS

If you want to make a backup of your PostGIS database using the pg_dump and pg_restore commands the default layer styles as saved by QGIS are failing to restore afterwards. You need to set the XML option to DOCUMENT and the restore will work.

Layer nach PostgreSQL/PostGIS importieren

Data can be imported into PostgreSQL/PostGIS using several tools, including the SPIT plugin and the command line tools shp2pgsql and ogr2ogr.

DB-Manager

QGIS comes with a core plugin named icon_dbmanager DB Manager. It can be used to load shapefiles and other data formats, and it includes support for schemas. See section DB Manager Plugin for more information.

shp2pgsql

PostGIS beinhaltet ein Programm mit dem Namen shp2pgsql das dazu benutzt werden kann Shpadateien in eine PostGIS-fähige Datenbank zu importieren. Um z.B. eine Shapedatei lakes.shp in eine PostgreSQL-Datenbank mit dem Namen gis_data zu importieren verwenden Sie den folgenden Befehl:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

Dieser Befehl erzeugt eine neue Tabelle mit dem Namen lakes_new in der PostgreSQL/PostGIS Datenbank gis_data. Die neue Ebene wird die ID 2964 als ‘spatial reference identifier’ (SRID) tragen. Weitere Informationen zu räumlichen Referenzsystemen finden Sie in Abschnitt Arbeiten mit Projektionen.

Tipp

Layer aus PostGIS exportieren

Wie das Importprogramm shp2pgsql gibt es ebenfalls ein Werkzeug um PostGIS Datensätze als Shapedateien zu exportieren: pgsql2shp. Dies ist innerhalb der PostGIS-Installation enthalten.

ogr2ogr

Neben shp2pgsql und dem DB Manager gibt es noch ein anderes Programm um Geodaten PostGIS zuzuführen: ogr2ogr. Dies ist Teil Ihrer GDAL-Installation.

Um ein Shape nach PostGIS zu importieren, kann folgendes Kommando verwendet werden:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres
password=topsecret" alaska.shp

Dies wird die Shapedatei alaska.shp in die PostGIS-Datenbank postgis mit dem Benutzer postgres*und dem Passwort *topsecret auf dem Host-Server myhost.de importieren.

Beachten Sie dass OGR mit PostgreSQL gebaut werden muss um PostGIS-Unterstützung zu erhalten. Sie können dies überprüfen indem Sie eingeben (in nix)

ogrinfo --formats | grep -i post

Wenn Sie es vorziehen dem PostgreSQL COPY-Befehl anstelle der Standard INSERT INTO Methode zu arbeiten können Sie die folgende Umgebungsvariable (zumindest unter nix und osx zugänglich) benutzen

export PG_USE_COPY=YES

ogr2ogr erstellt keine räumlichen Indizes wie shp2pgsl das tut. Sie müssen diese hinterher als zusätzlichen Schritt manuell unter Zuhilfenahme des normalen SQL-Befehls CREATE INDEX erstellen (wie im nächsten Abschnitt Geschwindigkeit optimieren beschrieben).

Geschwindigkeit optimieren

Retrieving features from a PostgreSQL database can be time-consuming, especially over a network. You can improve the drawing performance of PostgreSQL layers by ensuring that a PostGIS spatial index exists on each layer in the database. PostGIS supports creation of a GiST (Generalized Search Tree) index to speed up spatial searches of the data (GiST index information is taken from the PostGIS documentation available at http://postgis.refractions.net).

Dies ist die Syntax für das Erstellen eines GiST-Index:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Bedenken Sie, dass das Erstellen eines Index bei großen Datenmengen zeitaufwendig ist. Nachdem der Index erstellt ist, sollte ein ‘VACUUM ANALYZE’ durchgeführt werden (vgl. PostGIS Dokumentation Literatur und Internetreferenzen).

Im Folgenden sehen Sie ein Beispiel, um einen GiST-Index zu erstellen:

[email protected]:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

Vektorlayer, die den Längengrad 180° überschreiten

Many GIS packages don’t wrap vector maps with a geographic reference system (lat/lon) crossing the 180 degrees longitude line (http://postgis.refractions.net/documentation/manual-2.0/ST_Shift_Longitude.html). As result, if we open such a map in QGIS, we will see two far, distinct locations, that should appear near each other. In Figure_vector_4, the tiny point on the far left of the map canvas (Chatham Islands) should be within the grid, to the right of the New Zealand main islands.

Figure Vector 4:

../../../_images/vectorNotWrapping.png

Map in lat/lon crossing the 180° longitude line nix

Eine Möglichkeit, dies zu umgehen, bietet PostGIS und die Funktion ST_Umschalt_Longitude (http://postgis.refractions.net/documentation/manual-1.4/ST_Umschalt_Longitude.html). Die Funktion liest alle Objekte der Karte ein und wenn der Längengrad <0° ist, werden 360° hinzugezählt. Das Ergebnis ist eine 0-360° Karte, die als Mittelpunkt den Längengrad 180° verwendet.

Figure Vector 5:

../../../_images/vectorWrapping.png

Das Überqueren von 180° Länge unter Verwendung der ST_Shift_Longitude Funktion

Beispielanwendung

  • Importieren Sie Daten in PostGIS (Layer nach PostgreSQL/PostGIS importieren) in dem Sie z.B. das DB Manager Plugin benutzen.

  • Öffnen Sie das PostGIS Kommandozeilenfenster und geben Sie folgendes Kommando ein (in diesem Beispiel steht der Name “TABELLE” für den tatsächlichen Namen der PostGIS Tabelle): gis_data=# update TABLE set the_geom=ST_Shift_Longitude(the_geom);

  • Wenn alles gut gelaufen ist sollten Sie jetzt eine Bestätigung über die Anzahl der Objekte die geupdated worden sind erhalten. Dann sollten Siedie Karte laden und den Unterschied sehen können (Figure_vector_5).

SpatiaLite Layer laden

mActionAddSpatiaLiteLayer The first time you load data from a SpatiaLite database, begin by clicking on the mActionAddSpatiaLiteLayer Add SpatiaLite Layer toolbar button, or by selecting the mActionAddSpatiaLiteLayer Add SpatiaLite Layer... option from the Layer menu, or by typing Ctrl+Shift+L. This will bring up a window that will allow you either to connect to a SpatiaLite database already known to QGIS, which you can choose from the drop-down menu, or to define a new connection to a new database. To define a new connection, click on [New] and use the file browser to point to your SpatiaLite database, which is a file with a .sqlite extension.

Wenn Sie einen Vektorlayer im SpatiaLite-Format abspeichern wollen, wählen Sie den Layer in der Legende aus, benutzen Sie das Kontextmenü der rechten Maustaste und klicken Sie auf Speichern als .... Geben Sie den Namen der Ausgabe an, wählen Sie sqlite als Format aus und das KBS. Danach fügen Sie noch SPATIALITE=YES in das Fenster ‘Datenquelle’. Damit sagen Sie OGR, dass eine SpatiaLite-Datenbank erstellt werden soll. Siehe http://www.gdal.org/ogr/drv_sqlite.html.

QGIS also supports editable views in SpatiaLite.

Einen neuen SpatiaLite Layer erzeugen

Wenn Sie einen neuen SpatiaLite Layer erzeugen wollen, finden Sie in Kapitel Einen neuen SpatiaLite Layer erstellen eine Anleitung.

Tipp

SpatiaLite Datenmanagement Plugin

For SpatiaLite data management, you can also use several Python plugins: QSpatiaLite, SpatiaLite Manager or DB Manager (core plugin, recommended). If necessary, they can be downloaded and installed with the Plugin Installer.

Räumliche MSSQL-Layer

mActionAddMssqlLayer QGIS also provides native MS SQL 2008 support. The first time you load MSSQL Spatial data, begin by clicking on the mActionAddMssqlLayer Add MSSQL Spatial Layer toolbar button or by selecting the mActionAddMssqlLayer Add MSSQL Spatial Layer... option from the Layer menu, or by typing Ctrl+Shift+M.

Oracle Spatial Layer

The spatial features in Oracle Spatial aid users in managing geographic and location data in a native type within an Oracle database. QGIS now has support for such layers.

Erstellen einer PostGIS Anbindung

mActionAddOracleLayer The first time you use an Oracle Spatial data source, you must create a connection to the database that contains the data. Begin by clicking on the mActionAddOracleLayer Add Orcale Spatial Layer toolbar button, selecting the mActionAddOracleLayer Add Orcale Spatial Layer... option from the Layer menu, or typing Ctrl+Shift+O. To access the connection manager, click on the [New] button to display the Create a New Oracle Spatial Connection dialog. The parameters required for a connection are:

  • Name: Ein Name für diese Verbindung. Er kann der gleiche wie Datenbankinstanz sein

  • Datenbank: SID oder SERVICE_NAME der Oracleinstanz.

  • Host: Name of the database host. This must be a resolvable host name such as would be used to open a telnet connection or ping the host. If the database is on the same computer as QGIS, simply enter ‘localhost’ here.
  • Port: Port number the Oracle database server listens on. The default port is 1521.
  • Benutzername: Benutzername der verwendet wird um sich in die Datenbank einzuloggen.

  • Passwort: Passwort das zusammen mit Benutzername verwendet wird um sich bei der Datenbank anzumelden.

Wahlweise können Sie die folgenden Kontrollkästchen aktivieren:

  • checkbox Benutzernamen speichern zeigt an ob der Datenbankbenutzername in der Verbindungskonfiguration gespeichert werden soll.

  • checkbox Passwort speichern zeigt an ob das Datenbankpasswort in den Verbindungseinstellungen gespeichert werden soll.

  • checkbox Nur in Metadatentabelle geometry_columns nachsehen. Schränkt die dargestellten Tabellen auf jene die sich im all_sdo_geom_metadata View befinden ein. Dies kann die Initialanzeige von räumlichen Tabellen verschnellern.

  • checkbox Nur nach Tabellen des Benutzers suchen. Beim Suchen nach räumlichen Tabellen die Suche auf Tabellen die dem Benutzer gehören einschränken.

  • checkbox Auch geometrielose Tabelle anzeigen zeigt dass Tabellen ohne Geometrie auch standardmäßig aufgeführt werden.

  • checkbox Verwende geschätzte Tabellenstatistiken für die Layermetadaten. Wenn der Layer aufgesetzt wird werden verschiedene Metadaten für die Oracletabelle benötigt. Dies beinhaltet Informationen wie die Tabellenspaltenanzahl, Geometrietyp und räumliche Ausdehnung der Daten in der Geometriespalte. Wenn die Tabelle eine große Anzahl von Spalten enthält kann das Festlegen dieser Daten zeitaufwändig sein. Indem Sie diese Optionen aktivieren werden die folgenden schnellen Tabellenmetadatenoptionen durchgeführt: die Spaltenanzahl wird durch all_tables.num_rows festgelegt. Die Tabellenausdehnung wird immer mit den SDO_TUNE.EXTENTS_OF Funktionen festgelegt, auch wenn ein Layerfilter angewendet wird. Die Tabellengeometrie wird von den ersten 100 nicht-null Geometriespalten der Tabelle festgelegt.

  • checkbox Nur bestehende Geometrietypen. Führt nur die bestehenden Geometrietypen auf fragt nicht nach anderen.

Wenn alle Parameter eingetragen sind, kann die Verbindung getestet werden, indem Sie auf den Knopf [Verbindung testen] drücken.

Tipp

QGIS Benutzereinstellungen und Sicherheit

Depending on your computing environment, storing passwords in your QGIS settings may be a security risk. Passwords are saved in clear text in the system configuration and in the project files! Your customized settings for QGIS are stored based on the operating system:

  • nix Die Einstellungen werden in Ihrem Homeverzeichnis in ~/.qgis2 gespeichert.

  • win Die Einstellungen werden in der Registry gespeichert.

Einen Oracle Spatial Layer laden

mActionAddOracleLayer Once you have one or more connections defined, you can load layers from the Oracle database. Of course, this requires having data in Oracle.

Um einen Layer von Oracle Spatial zu laden, führen Sie die folgenden Schritte durch:

  • If the Add Oracle Spatial layers dialog is not already open, click on the mActionAddOracleLayer Add Oracle Spatial Layer toolbar button.
  • Wählen Sie eine Verbindung aus dem Drop-Down Menü und klicken auf [Verbinden].

  • Wählen Sie checkbox Auch geometrielose Tabelle anzeigen an oder ab.

  • Verwenden Sie wahlweise checkbox Suchoptionen um zu definieren welche Objekte aus dem Layer geladen werden sollen oder verwenden Sie den [Abfrage erstellen] Knopf um den Dialog Abfrageerstellung zu starten.

  • Suchen Sie einen Layer den Sie laden möchten.

  • Wählen Sie ihn aus indem Sie darauf klicken. Sie können mehrere Layer auf einmal wählen indem Sie die Umschalt Taste beim Klicken gedrückt halten. Siehe Kapitel Abfrageeditor über Informationen wie man den Oracle Query Builder benutzt um den Layer weiter zu definieren.

  • Klicken Sie auf den Knopf [Hinzufügen] um den Layer zu laden.

Tipp

Oracle Spatial Layer

Normalerweise wird ein Oracle Spatial Layer durch einen Eintrag in der USER_SDO_METADATA Tabelle definiert.