Outdated version of the documentation. Find the latest one here.

.

Complemento eVis

(Esta seção é derivada do Horning, N., K. Koy, P. Ersts. 2009. eVis (v1.1.0) Guia do usuário. Museu Americano de História Natura, Centro para Biodiversidade e Conservação. Disponível em http://biodiversityinformatics.amnh.org/, e liberada sob a licença GNU FDL.)

O Mecanismo de Informáticas da Biodiversidade no Museu Americano de História Natural (MAHN) Centro para Biodiversidade e Conservação (CBC) desenvolveram a Ferramenta de Visualização de Eventos (eVis), outra programa de ferramenta para adicionar ao conjunto de monitoramento de conservação e ferramenta de apoio à decisão para orientar a área de proteção e planejamento da paisagem. Este plug-in permite aos usuários ligar facilmente fotografias georreferenciadas (ou seja, referenciado com latitude e longitude ou coordenadas X e Y), e outros documentos comprovativos, para dados vetoriais em OGIS.

eVis agora é automaticamente instalado e habilitado em novas versões do OGIS, e como com todos os complementos, pode ser ativado e desativado utilizando o Gerenciador de Documentos (ver: The Plugins Menus).

O plugin eVis é composto de três módulos: a “ferramenta de Conexão de Banco de Dados”, “ferramenta de Identificação de Evento”, e o “Navegador de Evento”. Estes trabalham em conjunto para permitir a visualização de fotografias geocodificadas e outros documentos que estão ligados aos recursos armazenados em arquivos vetoriais, banco de dados ou planilhas

Navegador de Evento

O módulo Navegador de Evento tem a funcionalidade de exibir fotografias georreferenciadas que são ligadas às características do vetor exibidas na janela do mapa QGIS. Dados pontuais, por exemplo, podem vir do arquivo vetorial que pode ser introduzido usando QGIS ou pode ser resultado da consulta ao banco de dados. O recurso vetorial deve ter informações atribuidas associadas com ele para descrever a localização e o nome do arquivo que contém a fotografia e, opcionalmente, a direção que estava apontada a bússola da câmera quando a imagem foi adquirida. Sua camada vetorial deve ser carregada no QGIS antes de executar o Navegador de Evento

Iniciando o módulo Navegador de Evento

Para iniciar o módulo Navegador de Eventos, clique em Banco de Dados‣ eVis ‣ eVis Navegador de Evento. Isto abrirá o Navegador genérico de Evento janela.

A janela Navegador de Evento tem três guias exibidas no topo da janela. A aba Exibir é usado para ver a fotografia e é associado aos dados atribuídos. A aba Opções fornece um número de ajustes que pode ser ajustado para controlar o comportamento to plug-in eVis. Por fim a aba Configurar Aplicações Externas é usado para permitir que o eVis exiba imagens de outros documentos.

Entendendo a Janela de Exibição

Para ver a janela Exibir , clique na aba Exibir na janela Navegado de Evento . A janela Exibir é usado para ver fotografias georreferenciadas e suas informações atribuídas associadas.

Figure eVis 1:

../../../_images/evisdisplay.png

A janela de exibição do “eVis”

  1. Display window: A window where the photograph will appear.
  2. Botão mais Zoom: Dê Zoom para ver mais detalhes. Se a imagem inteira não pode ser exibida na janela de exibição, barras de rolagem aparecerão no lado esquerdo e inferior da janela para permitir que você se movimente pela imagem

  3. Botão menos Zoom: Diminua o Zoom para ver mais área

  4. Botão Zoom para extensão total: Mostra toda a extensão da fotografia.

  5. Janela de informações de atributo: Toda as informações de atributo para o ponto associado com a fotografia que está sendo visualizada é apresentada aqui. Se o tipo do arquivo que está sendo referenciado no registro exibido não é uma imagem mas é um tipo de arquivo definido na aba Configurar Aplicações Externas , então quando você clica duas vezes sobre o campo de valor contendo o caminho para o arquivo, o aplicativo para abrir o arquivo será iniciado para ver ou ouvir o conteúdo do arquivo. Se as extensões do arquivo são reconhecidas, os dados do atributo serão exibidos em verde.

  6. Navigation buttons: Use the Previous and Next buttons to load the previous or next feature when more than one feature is selected.

Entendendo a janela Opções

Figure eVis 2:

../../../_images/evisoptions.png

A janela de Opções do “eVis”

  1. Caminho de arquivo: Uma lista suspensa para especificar o campo de atributo que contém o caminho do diretório ou URL para as fotografias ou outros documentos que estão sendo exibidos. Se a localização é um caminho relativo, então a caixa de seleção deve ser clicada. O caminho de base para um caminho relativo pode ser inserido na caixa de texto abaixo Caminho Base . Informação sobre diferentes opiniões para especificar a localização são anotadas na seção abaixo Especificando o local e o nome de uma fotografia .

  2. Bússola: Uma lista suspensa para especificar o campo de atributo que contém a bússola associada com a fotografia que está sendo exibida. Se a informação da bússola estiver disponível, é necessário clicar na caixa de seleção abaixo do titulo do menu suspenso

  3. Bússola compensada: Bússola compensada pode ser utilizado para compensar a declinação (para ajustar as direções coletadas usando direções magnéticas para a verdadeira direção norte). Clique no botão rádio radiobuttonon Manual para inserir a compensação na caixa de texto ou clique no botão rádio radiobuttonon Atributo De para selecionar o campo de atributo contendo a compensação. Para ambas as opções, declinações leste devem ser inseridas usando valores positivos, e declinações oeste valores negativos.

  4. Caminho Diretório base: O caminho de base para que o caminho relativo definido no Figure_eVis_2 (A) será anexado.

  5. Substituir caminho: Se esta caixa de seleção está selecionada, apenas o nome do arquivo a partir de A será anexado ao caminho de base.

  6. Aplicar regra a todos os documentos: Se marcado, as mesmas regras de caminho que são definidas para as fotografias serão usadas para os documentos não-imagem, como filmes, documentos de texto e arquivos de som. Se não marcado as regras de caminho só se aplica a fotografias e os outros documentos irão ignorar o parâmetro do caminho base.

  7. Salve as configurações: Se esta opção estiver marcada, os valores dos parâmetros associados serão salvos para a próxima sessão, quando a janela é fechada ou quando o botão [Salvar] abaixo é pressionado.

  8. Redefinir valores: Redefine os valores nesta linha para a configuração padrão.

  9. Restaurar padrões Isto redefinirá todos os campos para suas configurações originais. Tem o mesmo efeito que clicar no botão [Redefinir]

  10. Salvar: Isto salvará as configurações sem fechar o painel Opções

Entendendo a janela Configurar Aplicações Externas

Figure eVis 3:

../../../_images/evisexternal.png

A janela de Aplicações Externas do “eVis”

  1. **Arquivo tabela de referência **: Uma tabela contendo os tipos de arquivos que podem ser abertos usando eVis. Cada tipo de arquivo tem uma extensão de arquivo e o caminho para um aplicativo poder abrí-lo. Isso fornece a capacidade de abrir uma ampla gama de arquivos como filmes, gravações sonoras, e documentos de texto em vez de apenas imagens.

  2. Adicionar novo tipo de arquivo: Adiciona um novo tipo de arquivo com uma extensão única e o caminho para o aplicativo poder abrí-lo.

  3. ** Excluir linha atual **: Exclui o tipo de arquivo em destaque na tabela e definido por uma extensão de arquivo e um caminho para um aplicativo associado.

Especificando o local e o nome de uma fotografia

O local e o nome da fotografia podem ser armazenados usando um caminho absoluto ou relativo, ou um URL se a fotografia está disponível em um servidor web. Exemplos das diferentes abordagens estão listadas na Tabela eVis_examples `` _.

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  http://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:http://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

Especificando o local e o nome de outros documentos suportados

Documentos comprovativos tais como documentos de texto, videos e clipes de som podem ser exibidos ou executados pelo eVis. Para fazer isso, é necessário adicionar uma entrada na tabela de referência do arquivo que pode ser acessada do :guilabel`Configurar Aplicação Externa` janela no :guilabel`Navegador de Evento Genérico` que corresponde a extensão da aplicação que pode ser utilizado para abrir o arquivo. É preciso também ter o caminho da URL ou do arquivo que contém a tabela de atributos para a camada vetorial. Uma regra adicional pode ser utilizada para URLs que não contém uma extensão de arquivo para o documento. O formato é extension:URL``. A URL é precedida pela extensão do arquivo e dois pontos; isto é particularmente útil para acessar documentos de wikis e outros sites da web que usem banco de dados para administrar páginas da web (veja Tabela evis_examples).

Usando o Navegador de Evento

Quando a janela Navegador de Evento abre, uma fotografia aparecerá na janela de exibição se o documento referenciado no arquivo vetor tabela de atributos é uma imagem e se a informação do local do arquivo na janela :guilabel`Opções` está configurado corretamente. Se a fotografia é esperada e não aparece, será necessário ajustar os parâmetros na janela :guilabel`Opções`.

Se um documento de apoio (ou uma imagem que não tem uma extensão de arquivo reconhecida pelo eVis) está referenciada na tabela de atributos, o campo contendo a extensão do arquivo estará destacado em verde na janela de informação de atributo se esta extensão do arquivo é definido na tabela de referência do arquivo localizado na janela Configurar Aplicativos Externos. Para abrir o documento, dois cliques na linha destacada em verde na janela de atributo da informação. Se um documento de apoio é referenciado na janela de informação de atributo e o arquivo não está destacado em verde, então será necessário adicionar uma entrada para a extensão de arquivo do arquivo na janela Configurar Apicativos Externos. Se o caminho do arquivo está destacado em verde mas não abre quando é clicado duas vezes, será necessário ajustar os parâmetros na janela Opções então o arquivo pode ser localizado pelo eVis

Se nenhuma bússola é fornecida pela janela Opções, um asterisco vermelho será exibido no topo do vetor característico que está associado com a fotografia exibida. Se uma bússola é fornecida, então uma seta aparecerá apontando na direção indicada pelo valor da bússola exibida no campo na janela Navegador de Evento. A seta será centrada sobre o ponto que é associada com a fotografia ou outro documento.

Para fechar o Event Browser window, clique no botão [Fechar] no Exibir janela.

Ferramenta ID de Evento

O módulo ‘Identificador de Evento’ permite que você exiba uma fotografia clicando numa característica exibida na janela do mapa QGIS. A característica do vetor deve ter informações de atributo associadas a ele para descrever a localização e o nome do arquivo contendo a fotografia e, opcionalmente, a direção que a bússola da câmera estava apontada quando a imagem foi adquirida. Esta camada deve ser carregada no QGIS antes de executar a ferramenta ‘Identificador de Evento’

Iniciando o módulo Identificação de Evento

Para iniciar o módulo ‘Evento ID’, ou clique no ícone do event_id: sup:Event ID or clique em :menuselection: ‘Banco de Dados -> eVis -> Ferramenta de Eventos ID`. Isso fará com que o cursor se transforme em uma seta com um ‘i’ em cima dela o que significa que a ferramenta ID está ativa.

Para ver as fotografias ligadas às características do vetor na camada ativa do vetor exibida na janela do mapa QGIS, mova o cursor ID do Evento sobre o recurso e então clique o mouse. Depois de clicar no recurso, a janela Navegador de Evento é aberta e as fotografias em ou perto da localidade clicada estão disponíveis para visualização no navegador. Se mais de uma fotografia está disponível, você pode percorrer os diferentes recursos usando os botões [Anterior] e [Próximo]. Os outros controles estão descritos na seção ref:evis_browser deste guia

Conexão com o Banco de Dados

O módulo ‘Conexão de Banco de Dados’ fornece ferramentas para conectar e consultar o banco de dados ou outro recurso ODBC, como uma planilha

eVis pode realizar conexões diretas com os seguintes tipos de bancos de dados: PostgreSQL, MySQL e SQLite; ele também pode ler a partir de conexões ODBC (por ex., MS Access). Ao ler a partir de um banco de dados ODBC (como uma planilha do Excel), é necessário configurar o driver ODBC para o sistema operacional que você está usando.

Inicia o módulo Conexão com a Base de Dados

Para iniciar o módulo ‘Conexão de Banco de Dados’, clique no ícone apropriado evis_connect eVis Conexão de Banco de Dados ou clique em Banco de Dados -> eVis -> Conexão de Banco de Dados. Isto irá abrir a :guilabel: janela Conexão de Banco de Dados. A janela tem três abas: Consultas Pré-definidas, Conexão de Banco de Dados e Consulta SQL. A janela :guilabel: Console de saída na parte inferior da tela exibe o status de ações iniciadas pelas diferentes seções deste módulo.

Conectar a um banco de dados

Clique na aba: guilabel:Conexão de Banco de Dados para abrir a interface de conexão com o banco. Em seguida, utilize a caixa de combinação Tipo de Banco de Dados selectstring para selecionar o tipo de banco de dados que você deseja se conectar. Se for necessária uma senha ou nome de usuário, essa informação pode ser inserida nas caixas de texto :guilabel:’Nome de Usuário’ e Senha.

Digite o local hospedado do banco de dados na caixa de texto :guilabel: ‘Local do Banco de Dados`. Esta opção não estará disponível se você tiver selecionado ‘MS Access’ como o tipo de banco de dados. Se o banco de dados reside em seu desktop, você deve digitar “localhost”.

Entre o nome do banco de dados na caixa de texto Nome Banco de Dados . Se você selecionou ODBC como tipo de banco de dados, você precisa introduzir o nome da fonte de dados.

Quando todos os parâmetros são preenchidos, clique no botão ** [Connect] **. Se a conexão for bem sucedida, uma mensagem será gravada na janela :guilabel: Console de saída informando que a conexão foi estabelecida. Se uma conexão não foi estabelecida, você precisará checar os parâmetros que foram inseridos anteriormente.

Figure eVis 4:

../../../_images/evisdatabase.png

A janela de conexão do banco de dados do “eVis”

  1. Tipo de Base de dados: Uma lista suspensa para especificar o tipo de base de dados que será usado.

  2. Banco de dados hospedeiro: O nome do banco de dados hospedeiro.

  3. Porta: O numero da porta se uma base de dados MySQL ou PostgreSQL for selecionada.

  4. Nome do banco de dados: O nome do banco de dados.

  5. Conectar Um botão para conectar-se a banco de dados usando os parâmetros definidos acima.

  6. Console de Saída A janela do console onde as mensagens relacionadas ao processamento são exibidos.

  7. Nome de Usuário: Nome de usuário para uso quando uma base de dados é protegida por senha.

  8. Senha: Senha para uso quando um banco de dados é protegida por senha.

  9. Consultas pré-definidas: Guia para abrir a janela “Consultas pré-definidas”.

  10. **Conexão com o banco de dados **: Guia para abrir a janela “Conexão com o Banco de dados”.

  11. Consulta SQL: Guia para abrir a janela “Consulta SQL”.

  12. Ajuda: Mostra a ajuda online.

  13. OK: Fecha a janela principal do “Conexão com o Banco de Dados”.

Execução de consultas SQL

Consultas SQL são usadas para extrair informações de uma base de dados ou de recursos ODBC. Em eVis a saída dessas consultas é uma camada vetorial adicionado à janela de mapa do QGIS. Clique na guia Consultas SQL para exibir a interface de consulta SQL. Comandos SQL podem ser inseridos nesta janela de texto. Um tutorial útil em comandos SQL está disponível em http://www.w3schools.com/sql. Por exemplo, para extrair todos os dados de uma planilha em um arquivo do Excel, `` Selecione * de [Plan1 $] ``, onde `` Plan1 `` é o nome da planilha.

Clique no botão ** [Executar Consulta] ** para executar o comando. Se a consulta for bem sucedida, a janela Seleção de Arquivo de Banco de Dados será exibida. Se a consulta não for bem sucedida, uma mensagem de erro aparecerá na janela Console de Saída.

No Seleção de arquivo do banco de dados`janela, insira o nome da camada que será criada a partir dos resultados da consulta na caixa de texto :guilabel:`Nome da Nova Camada .

Figure eVis 5:

../../../_images/evissql_query.png

A tabela de consulta SQL do eVis

  1. Janela de Texto de Consulta SQL: Uma tela para escrever consultas SQL.

  2. Executar consulta: Botão que executa a consulta no SQL Janela de Consulta.

  3. Janela Console: A janela console onde as mensagens relacionadas ao processamento são exibidas.

  4. Ajuda: Mostra a ajuda online.

  5. OK: Fecha o principal Conexão banco de dados janela.

Utilize as caixas de combinação :guilabel: Coordenada X selectstring e Coordenada Y selectstring para selecionar os campos do banco de dados que armazena as coordenadas X (ou longitude) e Y (ou latitude). Clicando no botão ** [OK] ** faz com que a camada vetorial criada a partir da consulta SQL seja exibida na janela do QGIS.

Para salvar este arquivo vetor para uso futuro, você pode usar o comando QGIS ‘Salvar como...’ que é acessado clicando com o botão direito na camada nome na legenda QGIS do mapa e em seguida secionando ‘Salvar como...’

Dica

Criando uma camada vetorial a partir de uma planilha do Microsoft Excel

Ao criar uma camada vetorial a partir de uma planilha do Microsoft Excel, você pode visualizar que zeros indesejados (“0”) foram inseridos nas linhas da tabela abaixo dos dados válidos. Isso pode ser causado deletando os valores dessas células no Excel usando o tecla Backspace. Para corrigir esse problema, você precisa abrir o arquivo do Excel (você vai precisar fechar o QGIS se você estiver conectado ao arquivo, para permitir que você edite o arquivo) e em seguida vá em :menuselection:’Editar -> Excluir` para remover as linhas em branco do arquivo. Para evitar esse problema, você pode simplesmente apagar várias linhas na planilha do Excel acessando :menuselection:’Editar -> Excluir` antes de salvar o arquivo.

Executando consultas pré-definidas

Com consultas predefinidas você pode selecionar consultas previamente escritas e armazenadas no formato XML em um arquivo. Isto é particularmente útil se você não estiver familiarizado com os comandos SQL. Clique na guia :guilabel:`Consultas Predefinidas’ para exibir a interface de consulta pré definida.

Para carregar um conjunto de consultas pré-definidas, clique no ícone evis_file Abrir arquivo. Irá abrir a janela Abrir Arquivo, que é utilizada para localizar o arquivo que contém as consultas SQL. Quando as consultas são carregadas, seus títulos são definidos no arquivo XML que será exibido no menu suspenso localizado logo abaixo do ícone evis_file Abrir Arquivo. A descrição completa das consultas são exibidas na janela de texto no menu suspenso.

Selecione a consulta que você deseja executar no menu suspenso e, então clique em aba Consulta SQL para ver se a consulta foi carregada na janela Consulta. Se for a primeira vez que você estiver executando uma consulta predefinida ou estiver migrando bancos de dados, você precisa ter certeza de estar conectado ao banco de dados.

Clique no botão [Executar Consulta] na aba SQL Consulta para executar o comando. Se a consulta é bem sucedida, a janela Seleção do Banco de Dados do Arquivo será exibida. Se a consulta não for bem sucedida, uma mensagem de erro aparecerá na janela Console de Saída

Figure eVis 6:

../../../_images/evispredefined.png

A guia de Consultas Pré-definidas do “eVis”

  1. Abrir Arquivo: Inicia o navegador de arquivos “Abrir Arquivo” para procurar pelo arquivo XML mantendo as consultas pré-definidas.

  2. Consultas Pré-definidas: Uma lista suspensa com todas as consultas definidas pelo arquivo XML de consultas pré-definidas

  3. Consulta descrição: Uma breve descrição da consulta. Esta descrição é do arquivo consultas prédefinida XML.

  4. Janela Console: A janela console onde as mensagens relacionadas ao processamento são exibidas.

  5. Ajuda: Mostra a ajuda online.

  6. OK: Fecha a janela principal do “Conexão com o Banco de Dados”.

Formato XML para consultas predefinidas eVis

As marcas XML lidas por eVis

Marcas

Descrição

Consulta

Define o início e o fim de uma instrução de consulta.

Descrição Breve

Uma pequena descrição da consulta que aparece no menu suspenso do eVis

Descrição

Uma descrição mais detalhada da consulta exibida na janela de texto Consulta Predefinida.

Tipo de Base de Dados

O tipo de banco de dados, definido no menu suspenso Tipo de Banco de Dados na guia Conexão Banco de Dados

Porta da Base de Dados

O porto tal como definido na caixa de texto Porto na aba Conexão Banco de Dados

Nome da Base de Dados

O nome do banco de dados como definido na caixa de texto Nome Banco de Dados na aba Conexão Banco de Dados

Nome de Usuário da Base de Dados

O nome de usuário do banco de dados como definido na caixa de texto na aba Conexão de Banco de Dados

Senha de Base de Dados

A senha do banco de dados como definida na caixa de texto Senha na aba Conexão Banco de dados

Instrução SQL

O comando SQL.

autoconexão

Uma bandeira (“verdadeira” ou “falsa”) para especificar as classificações acima deverá ser usada para conectar automaticamente o banco de dados sem executar a conexão de rotina na aba banco de Dados

Um exemplo de arquivo XML completo com três consultas é exibido abaixo:

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>