Outdated version of the documentation. Find the latest one here.

.

OpenStreetMap

Nos últimos anos, o projeto OpenStreetMap ganhou popularidade porque, em muitos países há dados geográficos gratuitos, como roteiros digitais estão disponíveis. O objetivo do projeto OSM é criar um mapa livre e editável do mundo a partir de dados de GPS, fotografias aéreas ou de conhecimento local. Para apoiar este objetivo, QGIS fornece um complemento que permite que seus usuários trabalhem com dados OSM.

O complemento OpenStreetMap, um complemento nativo do QGIS, oferece as funcionalidades básicas de manipulação de dados OSM, o que inclui o carregamento de dados, importar, salvar, download, editar e fazer upload de dados de volta para o servidor OpenStreetMap. Ao implementar o plugin OSM a inspiração foi tirada de editores já existentes de dados OSM. O objetivo era o de combinar as suas funcionalidades para obter o melhor resultado possível.

A seção seguinte apresenta uma breve introdução aos princípios do projeto OSM.

Partes dos parágrafos à seguir são copiadas do site da OpenStreetMap em http://www.openstreetmap.org.

O projeto OpenStreetMap

OpenStreetMap é um projeto para criar um mapa livre editável do mundo. Os mapas são criados usando dados de dispositivos portáteis de GPS, fotografias aéreas, de outras fontes livres ou simplesmente a partir do conhecimento local. O projeto foi iniciado porque a maioria dos mapas têm restrições legais ou técnicas para sua utilização, restringindo as pessoas de usá-los de forma criativa, produtiva ou outras formas alternativas. Ambas as imagens fundidas e o conjunto de dados vetoriais do OSM estão disponíveis para download sob uma licença Creative Commons Attribution ShareAlike 2.0.

Figure OpenStreetMap 1:

../../../_images/osmweb.png

Dados OpenStreetMap na web

OpenStreetMap foi inspirado em sites como o Wikipédia - a visualização do mapa (ver Figura_OpenStreetMap_1 ) apresenta um proeminente :guilabel: guia Editar e um histórico de revisão completa é mantido. Os usuários registrados podem enviar registos de trajetos de GPS e editar os dados vetoriais, utilizando as ferramentas de edição de dados.

Dados primitivos OSM são uma classe de objetos que podem serem armazenados via API no servidor. Os três tipos de suporte de dados são: Node, Way e Relation.

  • Um nó é um par de coordenada de latitude/longitude. É usado como um bloco de construção para as outras características e como uma característica própria (pontos de interesse), para serem marcados, conforme necessário.

  • Um Caminho é uma lista de pelo menos dois nós que descrevem uma feição linear, tal como uma rua, ou similar. Os nós podem fazer parte de vários caminhos.

  • Uma relação é um grupo de zero ou mais com funções primitivas associadas. Ele é usado para especificar as relações entre objetos, e também pode modelar um objeto abstrato.

Diversas características lógicas diferentes de um mapa comum “Ponto de interesse”, ‘Estrada’, ‘linha elétrica’, ‘ponto de ônibus’ etc) são definidos por estes primitivos. Características do mapa são bem conhecidos na comunidade OSM e são armazenados como etiquetas, com base numa chave e um valor. OSM é normalmente distribuído em formato XML. Carga XML também é utilizada para a comunicação com o servidor do OSM.

QGIS - Conexão OSM

A primeira parte desta seção descreve como dados primitivos OSM são exibidos em camadas vetoriais QGIS. Como mencionado anteriormente, dados OSM consistem de Nós, Caminhos e Relações. No QGIS, eles são exibidos em três diferentes tipos de camada: camada de ponto, camada de linha e camada de polígono. Não é possível remover qualquer uma dessas camadas e trabalhar com as outras.

  • Uma Camada de Ponto exibe todas as feições de tipo nó que fica sozinho. Isso significa que apenas nós que não estão incluídos em qualquer Caminho pertence à camada Ponto.

  • Uma Camada de linha exibe as feições OSM de Caminho do tipo que não estão fechados. Isso significa que, nenhum desses Caminhos inicia e termina com o mesmo Nó.

  • Uma Camada de polígono exibe todos os Caminhos que não estão incluídos na camada Linha.

OpenStreetMap tem uns dados mais primitivos além dos três mencionados acima. Isto é chamado ** Relação **. Não existe propositadamente nenhuma camada vetor para exibir Relações. Uma relação define uma ligação entre qualquer número de dados primitivos. Depois que um ponto, linha ou polígono é identificado em um mapa, o complemento mostra uma lista de todas as relações que o recurso identificado faz parte.

Foi um desafio para projetar a conexão entre dados OSM e as ferramentas padrão de edição QGIS. Estas ferramentas são feitas para editar uma única camada vetor por vez, não importa que tipo de feição ele exibe. Isto significa que se os dados OSM são carregados para QGIS através do complemento, você poderia (teoricamente) editar a camada de Ponto, camada de Linha ou camada de Polígono com essas ferramentas padrão separadamente.

Uma camada de linha consiste em dois diferentes tipos de recursos OSM, Linha e Nós. Em formato de OSM, uma Linha é composta de Nós. Se você começar a editar uma única camada linha e mudar a forma de alguma linha, sua ação afeta não só a Linha OSM, mas também os Nós OSM que fazem parte dela.

Ferramentas de edição padrão QGIS não se comunicam com provedor OSM, que membros de qual linha foi alterada e como. Ele pode dizer apenas o que é a nova geometria e de qual linha, e isso não é o suficiente para realizar alterações para o banco de dados OSM corretamente. A camada de linha não saber também os identificadores dos membros de linha. O mesmo problema ocorre quando você tenta editar a camada de polígono.

Por esta razão, o complemento OSM precisa de suas próprias ferramentas para edição de dados OSM. Enquanto que são utilizados, as camadas OSM podem ser alteradas corretamente. O Complemento ferramentas de edição consiste em ferramentas para Ponto, Linha Polígono, e criação de Relações , deletar e mover.

Nota

Para criar uma conexão entre o complemento OSM e ferramentas de edição padrão, as mudanças no código fonte QuantumGIS seria necessário.

Instalação

O complemento OpenStreetMap é um complemento nativo do QGIS. O complemento ‘OpenStreetMap’ pode ser instalado via Gerenciador de Complementos como descrito na seção: ref: Carregando complementos nativos.

Interface básica do usuário

A primeira vez que o complemento OSM é iniciado (e após os primeiros dados serem carregados), vários novos ícones do complemento OSM aparecerão no menu da barra de ferramentas do QGIS juntamente com os novos componentes gráficos, como mostrado na figura_OpenStreetMap_2.

Figure OpenStreetMap 2:

../../../_images/osm_widgets.png

Complemento OSM interface com o usuário

Ferramenta de feições OSM

A ferramenta de feições OSM ajuda a identificar as feições do OSM. Ela mostra informações básicas sobre o tipo de recurso e identificador, bem como informações sobre quem mudou um recurso, e quando. A ferramenta de feições OSM também fornece todas as ferramentas de edição (na parte superior da mesma). Mais informações sobre essas ferramentas podem ser encontrados nas seções abaixo. A ferramenta é inicialmente desabilitada. E ativada depois do carregamento bem-sucedido de alguns dados OSM.

Ferramenta Desfazer/Refazer OSM

Este menu OSM desfazer / refazer é usado para desfazer e refazer ações de edição. Ele consiste não só num clássico menu desfazer e refazer , mas também mostra uma lista com uma breve descrição das ações de edição que foram feitas. O menu OSM desfazer / refazer é inicialmente fechado. Você pode visualizá-lo através de um botão no menu feições do OSM.

Ícones da barra de menu ferramentas

osm_load OSM Carregar do arquivo é usado para carregar dados de um arquivo XML especial OpenStreetMap.

osm_featureManager :sup:’Mostrar / Esconder Gerenciador de Feições OSM` é usado para mostrar ou ocultar o menu de botões das feições OSM. O Menu de feições OSM é um painel que ajuda na identificação de feições OSM e na edição de dados OSM.

osm_download :sup:`Download de dados OSM’ é usado para baixar dados do servidor do OpenStreetMap.

osm_upload Upload de dado OSM é usado para upload de alterações (no dado existente).

osm_import Importa dado para camada é usado para importar dados para a camada vetorial. Pelo menos uma camada de vetor deve ser carregada e os dados OSM atuais devem ser selecionados.

osm_save Salvar OSM para arquivo é usado para salvar dados OSM de volta para o arquivo XML.

Informações mais detalhadas sobre todos os menus, botões e diálogos podem ser encontradas nas seções apropriadas desta seção complemento de acordo com a sua funcionalidade (edição, identificação, etc.).

Carregando dados OSM

A primeira ação que deve ser feita após iniciar o complemento OSM é abrir dados de um arquivo OSM. Dados OSM podem ser importados, de arquivo shapefile ou baixado diretamente do servidor OpenStreetMap. Aqui estamos focando o primeiro método mencionado.

Para carregar dado proveniente do arquivo use o osm_load :sup: icone Carregar OSM do arquivo. Se não houver tal botão, talvez tenha sido desabilitado na barra de ferramentas OpenStreetMap em sua instalação no QGIS. Você pode habilitá-lo novamente selecionando: menuselection: ‘Configurações -> Barras de Ferramentas -> OpenStreetMap -> `.

Figure OpenStreetMap 3:

../../../_images/osmloaddialog.png

Janela carregar dados OSM

O propósito desses elementos é explicado a seguir.

Arquivo para carregar OpenStreetMap: Clique no botão para selecionar o arquivo:.osm se você deseja carregar os dados.

Adicionar colunas para etiquetas: Esta opção determina uma conexão entre OSM e dados do QGIS. Cada feição de dados OSM tem algumas etiquetas (pares de chaves e valores), que definem as propriedades da feição. Cada característica de uma camada de vetor QGIS também tem seus atributos (chave e valor). Com esta opção, você pode definir quais as propriedades dos objetos OSM devem estar visíveis ao exibir informações detalhadas sobre as feições do QGIS.

Substitua dados atuais: Ao marcar esta opção significa que novos dados devem substituir os dados atuais que o usuário está trabalhando. Camadas de dados atuais serão removidas e novas serão carregadas. Ao carregar dados OSM, pela primeira vez, esta opção não está ativa, porque não há nada para substituir.

Use renderização customizada: Esta opção determina o número de detalhes do mapa que serão usados. Há três estilos pré-definidos para OSM mapa exibido. Uso: guilabel: pequena escala se você quiser ver os dados OSM em nível baixo, para ver todos os detalhes e editar algo. Se não você pode usar: guilabel: escala Média ou: guilabel: larga escala. QGIS atual não permite alterar o estilo de processador de forma dinâmica.

Clique ** [OK] ** para carregar seus dados. Se esta for a primeira vez que o ficheiro de OSM é carregado, o complemento deve primeiro analisar o banco de dados. Isso pode demorar alguns segundos ou minutos - isso depende da quantidade de dados carregados.

Visualização de dados OSM

Depois que os dados são carregados OSM, você pode identificar características do mapa usando a ferramenta apropriada. Use a osm_identify :sup: botão Identificar feição no canto superior esquerdo do menu OSM. Usando esta ferramenta você pode facilmente explorar todos os objetos do mapa. Quando o cursor do mouse é colocado sobre um objeto, você pode ver todas as informações sobre ele diretamente no menu feições OSM. Há também um elástico dinâmico apresentado no mapa a fim de que o utilizador seja capaz de determinar qual a feição está atualmente identificada.

A Propriedades guia do menu contém de todas as etiquetas de feições. Clicando no: guilabel: guia Relação mostra uma lista de todas as relações relacionadas com identificação.

Se você quer manter uma feição por um tempo para poder ler suas propriedades e relações, mova o cursor do mouse simultaneamente, tentando clicar com seu botão esquerdo enquanto estiver sobre o recurso. Processo de identificação irá parar no próximo clique com o botão esquerdo do mouse.

Por vezes, não há mais do que um recurso em um ponto onde um clique com o botão esquerdo do mouse foi realizado. Isto acontece especialmente quando se clica em encruzilhadas ou se você não der o suficiente zoom no mapa. Nesta situação, apenas uma dessas feições é identificada (e marcada com o elástico), mas o complemento se lembra de todos eles. Então (ainda no modo de pausa), você pode percorrer as características identificadas pelo botão direito do mouse.

Editando dados OSM básicos

‘Dados básicos’ neste contexto significa feições OSM não-relacionais - nós e caminhos. Se preferir examinar como executar edição relacional, pule esta seção e passe para a próxima.

Dados básicos de edição é uma parte fundamental do complemento OSM. É possível alterar a propriedade de posição, ou a forma de qualquer feição da base vigente. Você pode remover funções ou adicionar novas. Todas as mudanças em nós e formas são lembradas por desfazer / refazer todas as alterações podem ser facilmente carregados para o servidor OpenStreetMap.

Mudanças nas etiquetas das feições

Mudança na propriedade/etiqueta de uma feição OSM pode ser feito diretamente na tabela de etiquetas da feição. A tabela etiquetas de feições básicas podem ser encontrados no menu OSM. Não se esqueça de identificar primeiro a feição.

Figure OpenStreetMap 4:

../../../_images/osm_changefeaturetag.png

Mudança de etiqueta na feição OSM

Se você quiser alterar um valor de etiqueta, basta clicar duas vezes na linha apropriada da coluna ‘Valor’ e tipo, ou selecionar um novo valor. Se você quiser remover uma etiqueta, clique na linha correspondente, então use o botão osm_removeTag Remover etiquetas selecionadas no canto inferior direito debaixo da tabela.

Para adicionar novas etiquetas basta digitar a chave e valor na última linha da tabela onde está escrito ‘ <próximo valor de etiqueta >’ . Observe que você não pode alterar a chave de um par de etiquetas existentes. Convenientemente, há algumas caixas de combinação de todas as chaves de etiquetas existentes e seus valores típicos.

Criar ponto

Para a criação do ponto há uma osm_createPoint: sup: botão Criar ponto no menu feição OSM. Para criar alguns pontos, basta clicar no botão e começar a clicar sobre o mapa. Se o cursor estiver sobre alguma feição do mapa, a feição será marcada / identificada imediatamente. Se você clicar no mapa quando uma linha ou polígono estiver marcada um novo ponto será criado diretamente na linha ou polígono, bem como seu novo membro. Se o cursor estiver sobre um ponto existente, um novo ponto não poderá ser criado. Nesse caso, o complemento OSM irá mostrar a seguinte mensagem:

Figure OpenStreetMap 5:

../../../_images/osm_pointcreation.png

Mensagem de criação de ponto OSM

O mecanismo de ajudar um usuário a tocar a linha ou polígono é chamado de ajuste e é ativado por padrão. Se você quiser criar um ponto muito próximo de alguma linha (mas não sobre ela), você deve desabilitar o ajuste mantendo o: kbd:pressionar primeiro a tecla Ctrl.

Criar linha

Para a criação da linha, há um osm_createLine: sup: botão Criar linha no menu feições OSM. Para criar uma linha basta clicar no botão esquerdo do mouse para e começar, clicando no mapa. Cada um de seus Cliques esquerdo é registrado como um dos vértices da nova linha. A criação da linha termina quando o primeiro clique com o botão direito do mouse for realizado. A nova linha irá aparecer imediatamente no mapa.

Nota

Uma linha com menos de dois vértices não pode ser criada. Em tal caso, a operação é ignorada.

O ajuste é realizado para todos os vértices do mapa - pontos da camada de vetor Ponto e Linha e todos os nós do Polígono. O ajuste pode ser desativado mantendo o: kbd: botão Ctrl pressionado.

Criar polígono

Para a criação de polígonos há um osm_createPolygon :sup: botão Criar polígono no menu feições OSM. Para criar um polígono basta clicar com o botão esquerdo e começar, clicando no mapa. Cada um de seus Cliques esquerdo é gravado como um vértice pertencente ao novo polígono. A criação Polígono termina quando o primeiro clique com o botão direito do mouse é realizado. O novo polígono aparecerá imediatamente no mapa. Polígono com menos de três vértices não pode ser criado. Em tal caso, a operação é ignorada. O Ajuste de aproximação é realizado para todos os vértices do mapa - pontos (de camada de vetor Ponto) e todo polígono linhas e vértices. Ajuste de aproximação pode ser desativado mantendo a: kbd: tecla`Ctrl`.

Movendo feições do mapa

Se você deseja mover uma feição (não importa o tipo) por favor use o osm_move :sup: botão`Mover feição` a partir do menu feições OSM. Depois, você pode navegar pelo mapa (feições serão identificadas de forma dinâmica quando você passar por cima delas) e clique sobre a feição que você deseja mover. Se uma feição errada for selecionada após o seu clique, não mova do lugar. Repita o clique com botão direito do mouse até que a feição correta seja identificada. Quando a seleção é feita e você mover o cursor, você não poderá mudar sua decisão que foi movida. Para confirmar a mudança, clique no botão esquerdo do mouse. Para cancelar o movimento, clique em outro botão do mouse.

Se você estiver movendo uma feição que está ligada a outras feições, essas conexões não serão danificadas. Outras feições só irá se adaptar a uma nova posição de uma feição movida.

Ajuste de aproximação também é suportado nesta operação, isto significa:

  • Ao mover uma entidade independente (que não faz parte de qualquer linha / polígono) ponto, ajuste de aproximação a todos os segmentos do mapa e vértices é realizado.

  • Ao mover um ponto que é membro de algumas linhas / polígonos, o ajuste de aproximação a todos os segmentos do mapa e vértices é realizado, exceto para os vértices de pontos mestre.

  • Ao mover uma linha / polígono, o ajuste de aproximação a todos os vértices mapa é realizado. Note que o complemento OSM tenta encaixar só para os 3 vértices mais próximos ao cursor de uma linha transferida / polígono, caso contrário, a operação seria muito lenta. O Ajuste de aproximação pode ser desativado por exploração :kbd:`Ctrl`durante a operação.

Remover feições do mapa

Se você quiser remover uma feição, você deve primeiro identificá-la. Para remover uma feição identificada, use o osm_removeFeat :sup: botão Remover esta feição no menu feição OSM. Ao remover uma linha / polígono, a linha / polígono propriamente dito é excluído, assim ocorrerá para todos os pontos de seus vértices que não pertencem a nenhuma outra linha / polígono.

Ao retirar um ponto que é membro de algumas linhas / polígonos, o ponto é eliminado e as geometrias de linhas / polígonos mestres são alteradas. A geometria nova mestra resultante, possuirá menos vértices do que a antiga.

Se a feição mestre era um polígono com três vértices, a sua nova geometria tem apenas dois vértices. E como não pode existir polígono com apenas dois vértices, como descrito acima, o tipo de feição é automaticamente alterada para a Linha.

Se a feição mestre era uma linha com dois vértices, e sua nova geometria tem apenas um vértice. Como não pode existir uma linha com apenas um vértice, o tipo de feição será automaticamente alterada para ponto.

Editando relações

Graças a existência de relações de OSM podemos juntar feições OSM em grupos e dar-lhes propriedades comuns - de tal forma que podemos modelar qualquer objeto do mapa possível: fronteiras de uma região (como o grupo de formas e pontos), rotas de ônibus, etc cada membro de uma relação tem sua função específica. Há um suporte muito bom para as Relações OSM em nosso complemento. Vamos ver como examinar, criar, atualizar ou remover.

Examinando relações

Se você quiser ver as propriedades de relações, identifique primeiro um de seus membros. Depois que abrir o :guilabel: guia Relações no menu feição OSM. No topo da página, você pode ver uma lista de todas as relações da feição identificada como parte. Por favor, escolha o que você quer examinar e olhe para as informações abaixo. Na primeira tabela chamada ‘Etiqueta relação’ você encontra as propriedades da relação selecionada. Na tabela chamada ‘membros relação’ você vê uma breve informação sobre os membros de relação. Se você clicar em um membro, o complemento abrirá um menu elástico sobre ele no mapa.

Criando relações

Existem 2 caminhos para criar uma relação:

  1. Você pode usar o osm_createRelation: sup: botão Criar relação no menu feição OSM.

  2. Você pode criá-lo a partir do :guilabel: aba ‘Relação` do menu feição OSM usando o osm_addRelation: sup: botão Adicionar relação.

Em ambos os casos, uma caixa de diálogo irá aparecer. Para o segundo caso, a feição que está identificada é automaticamente considerada o membro relação em primeiro lugar, de modo que o diálogo é previamente preenchido um pouco. Ao criar uma relação, por favor, selecione o seu primeiro tipo. Você pode selecionar um dos tipos de relação predefinidos ou escrever o seu próprio tipo. Depois que preencher as etiquetas relações e escolher seus membros.

Se você já selecionou um tipo de relação, tente usar o osm_generateTags: sup: botão gerar etiquetas. Ele irá gerar etiquetas típicas para o seu tipo de relação. Então, espera-se que introduza valores para as chaves. A escolha dos membros relação pode ser feita escrevendo identificadores membros, tipos e funções ou usando o | osm_identify|: sup: ferramenta Identificar e clicando no mapa.

Finalmente, quando tipos, etiquetas e membros são escolhidos, o diálogo pode ser submetido. Nesse caso, o complemento cria uma nova relação para você.

Alterando relações

Se você quiser alterar uma relação existente, identifique-a primeiro (seguindo os passos acima escritos na Seção: ref: examining_relation). Depois disso, clique no osm_editRelation :sup: botão Editar relação. Você vai encontrá-lo no menu feição OSM. Uma nova caixa de diálogo aparece, quase a mesmo que surge para a ação “relação criar”. O diálogo é pré-preenchido com informações sobre as relações dadas. Você pode alterar as etiquetas relação, membros ou até mesmo o seu tipo. Depois de apresentar o diálogo de suas alterações serão cometidos.

Baixando dados OSM

Para baixar os dados do servidor OpenStreetMap clique em osm_download :sup: botão Download dados OSM. Se não houver o tal botão, a barra do OSM pode estar desabilitada na sua instalação no QGIS. Você pode habilitá-la novamente em :menuselection: ‘Exibir -> Barra de Ferramentas -> OpenStreetMap -> `. Depois de clicar no botão um diálogo ocorre e fornece as seguintes funcionalidades:

Figure OpenStreetMap 6:

../../../_images/osm_downloaddialog.png

Janela baixando OSM

Extensão: Especifique uma área para download de dados a partir de intervalos de latitude e longitude em graus. Porque há alguma restrição do servidor OpenStreetMap da quantidade de dados que podem ser baixados, os intervalos não deve ser muito grandes. Informações mais detalhadas sobre a especificação extensão permitida é mostrado após clicar no osm_questionMark :sup: `Ajuda ` botão à direita.

Baixar para: Aqui você deverá escrever um caminho para o arquivo onde os dados serão armazenados. Se você não se lembra a estrutura do seu disco, não entre em pânico. O botão de navegação browsebutton vai te ajudar.

Abrir dados automaticamente após baixar: Determina, se o processo de baixar deve ser seguido para carregar o processo de dados ou não. Se você prefere não carregar os dados agora, você pode fazê-lo mais tarde usando o osm_load :sup: botão Carregar OSM do arquivo.

Substituir os dados atuas: Esta opção só está ativa se radiobuttonon :guilabel: Dados abertos automaticamente após baixar estiver marcada. Selecionar esta opção significa que os dados baixados devem substituir os dados atuais que estamos trabalhando agora. Camadas de dados atuais serão removidas e novas serão carregadas. Ao iniciar o QGIS e baixar dados OSM pela primeira vez, esta opção é inicialmente inativa, porque não há nada para substituir.

Use editor personalizado: Esta opção só está ativa se o radiobuttonon Dados abertos automaticamente após baixar caixa estiver marcada. Ela determina quantos detalhes estarão no mapa. Há três estilos pré-definidos para exibição no mapa OSM. Use ‘pequena escala’ se você quiser ver os dados OSM em nível baixo, para ver todos os detalhes e editar algo. Se você não pode usar ‘escala Média’ ou ‘escala grande’. QGIS |CUTTENT| não permite alterar o estilo de edição de forma dinâmica.

Clique o botão [Baixar] para iniciar o processo de baixar.

Um diálogo do progresso continuamente informará sobre o quanto de dados já foi baixado. Quando ocorrer um erro durante o processo de baixar, uma caixa de diálogo dirá porquê. Quando a ação for concluída com sucesso, tanto as caixas de diálogo do progresso e do diálogo de download irão fechar-se.

Subindo dados OSM

Note que o upload é sempre feito nos dados correntes de OSM. Antes de abrir o diálogo Upload OSM, certifique-se de que você realmente tem direito sobre a camada ativa dados OSM.

Para fazer upload de dados atuais para o servidor OSM clique no osm_upload :sup: Botão Upload dados OSM `. Se não houver o tal botão, em sua barra de ferramentas OSM , ela está desativada instalação do QGIS. Você pode habilitá-la novamente em :menuselection: `Exibir -> Barra de Ferramentas -> OpenStreetMap. Depois de clicar no botão ** [Upload] ** uma nova caixa de diálogo irá aparecer.

Figure OpenStreetMap 7:

../../../_images/osm_uploaddialog.png

Janela upload OSM

No topo da caixa de diálogo, você pode verificar, se você esta carregando os dados corretos. Haverá um nome curto de um banco de dados atual. Na tabela, você encontrará informações sobre quantas mudanças irão ser carregadas. As estatísticas são apresentadas separadamente para cada tipo de feição.

Na caixa Comentário sobre as alterações, você pode escrever uma breve informação sobre o significado de sua operação de upload. Basta registrar a breve mudança de dados que você fez ou deixar a caixa vazia. Faça login na ‘conta OSM’ para que o servidor possa autenticar você. Se você não tem uma conta no servidor de OSM, é o melhor momento para criar uma em http://www.openstreetmap.org. Finalmente use ** [Upload] ** para começar uma operação de upload.

Salvando dados OSM

Para salvar os dados da extensão do mapa atual para um arquivo XML clique no osm_save :sup: botão Salvar OSM para o arquivo. Se não houver o tal botão, na barra de OSM provavelmente está desativado na instalação QuantumGIS. Você pode habilitá-lo novamente em Exibir ‣ Barra de Ferramentas ‣ OpenStreetMap. Depois de clicar no botão uma nova caixa de diálogo aparecerá.

Figure OpenStreetMap 8:

../../../_images/osm_savedialog.png

Janela salvando OSM

Selecionar as feições que você deseja salvar em arquivo XML e o arquivo em si. Use a [OK] para iniciar a operação. O processo irá criar um arquivo XML, em que os dados OSM de sua extensão atual do mapa estão representados. A versão OSM do arquivo de saída é de 0.6. Elementos de dados OSM (<node>, <way>, <relation>) não contêm informações sobre suas changesets e uids. Esta informação não é obrigatória, no entanto, ver DTD para OSM XML versão 0.6. No arquivo de saída OSM elementos não são ordenados.

Note-se que não apenas dados da tela de extensão atual são salvos. No arquivo de saída os polígonos e linhas inteiras são gravados, mesmo os que apenas tiveram uma pequena parte visível na extensão de tela atual. Para cada linha / polígono salvos, todos os nós de seus membros também serão salvos.

Importar dados OSM

Para importar dados OSM de uma camada vetorial, aberta, e não-OSM siga estas instruções: Escolha dados OSM atuais, clicando em sua camada. Clique no osm_import :sup: botão Importar dados da camada. Se não houver o tal botão, provavelmente foi desativada a barra de ferramentas do OpenStreetMap em sua instalação do QGIS. Você pode habilitá-la novamente em Exibir ‣ Barra de Ferramentas ‣ OpenStreetMap.

Depois de clicar no botão a seguinte mensagem poderá aparecer:

Figure OpenStreetMap 9:

../../../_images/osm_importdialog.png

Janela mensagem de importação OSM

Nesse caso, não há nenhuma camada vetor atualmente carregada. A importação deve ser feito a partir de uma camada carregada - por favor, coloque uma camada de vetor da qual você deseja importar os dados. Depois de aberta uma camada ser aberta, sua segunda tentativa deve dar-lhe um melhor resultado (não se esqueça de marcar novamente a atual camada OSM):

Figure OpenStreetMap 10:

../../../_images/osm_importtoosmdialog.png

Janela importando dados para OSM

Use o diálogo submeter para iniciar o processo de importação de dados OSM. Rejeite caso você não tem certeza que deseja importar alguma coisa.