# Contents

1 コースのイントロダクション ........................................ 1
   1.1 序文 .................................................................. 1
   1.2 練習データの準備 .............................................. 3

2 Module: インタフェース ............................................. 11
   2.1 Lesson: はじめに ............................................. 11
   2.2 Lesson: 第一レイヤの追加 .................................... 12
   2.3 Lesson: インタフェースのあらまし ......................... 14

3 Module: 基礎的な地図作成 .......................................... 17
   3.1 Lesson: ベクタデータの操作 ................................ 17
   3.2 Lesson: シンポジオシ ........................................ 21

4 Module: ベクタデータの分類 ....................................... 51
   4.1 Lesson: Attribute Data ........................................ 51
   4.2 Lesson: ラベルツール ........................................ 52
   4.3 Lesson: Classification ......................................... 71

5 Module: マップの作成 .............................................. 91
   5.1 Lesson: Using Map Composer ................................. 91
   5.2 Assignment 1 .................................................. 100

6 Module: ベクタデータの作成 ....................................... 101
   6.1 Lesson: Creating a New Vector Dataset .................. 101
   6.2 Lesson: 地物のトポロジー .................................. 111
   6.3 Lesson: フォーム ............................................ 122
   6.4 Lesson: アクション .......................................... 134

7 Module: ベクタ分析 ............................................... 147
   7.1 Lesson: データの再投影と変形 .............................. 147
   7.2 Lesson: ベクタ分析 .......................................... 156
   7.3 Lesson: ネットワーク分析 .................................. 174
   7.4 Lesson: 空間統計 ............................................ 185

8 Module: ラスタ ................................................... 205
   8.1 Lesson: ラスタデータの操作 ................................. 205
   8.2 Lesson: ラスタシンポジオシの変更 ......................... 211
   8.3 Lesson: 地形解析 ............................................ 220

9 Module: 分析の完了 ............................................... 233
   9.1 Lesson: ラスタのベクタへの変換 ........................................ 233
   9.2 Lesson: 分析を組み合わせる ................................ 236
   9.3 課題 .......................................................... 237
   9.4 Lesson: 補足の実習 ......................................... 237

10 Module: プラグイン ............................................... 251
    10.1 Lesson: プラグインのインストールと管理 ................ 251
    10.2 Lesson: 役に立つ QGIS プラグイン .................... 255
<table>
<thead>
<tr>
<th>Number</th>
<th>Module:</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Module:</td>
<td>オンラインリソース</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>11.1</td>
<td>Lesson: Web Mapping Services</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>11.2</td>
<td>Lesson: Web Feature Services</td>
<td>274</td>
</tr>
<tr>
<td>12</td>
<td>Module:</td>
<td>GRASS</td>
<td>283</td>
</tr>
<tr>
<td></td>
<td>12.1</td>
<td>Lesson: GRASS のセットアップ</td>
<td>283</td>
</tr>
<tr>
<td></td>
<td>12.2</td>
<td>Lesson: GRASS ツール</td>
<td>294</td>
</tr>
<tr>
<td>13</td>
<td>Module:</td>
<td>評価</td>
<td>303</td>
</tr>
<tr>
<td></td>
<td>13.1</td>
<td>ベースマップの作成</td>
<td>303</td>
</tr>
<tr>
<td></td>
<td>13.2</td>
<td>Analyze the data</td>
<td>305</td>
</tr>
<tr>
<td></td>
<td>13.3</td>
<td>最終的なマップ</td>
<td>305</td>
</tr>
<tr>
<td>14</td>
<td>Module:</td>
<td>Forestry Application</td>
<td>307</td>
</tr>
<tr>
<td></td>
<td>14.1</td>
<td>Lesson: Forestry Module Presentation</td>
<td>307</td>
</tr>
<tr>
<td></td>
<td>14.2</td>
<td>Lesson: Georeferencing a Map</td>
<td>308</td>
</tr>
<tr>
<td></td>
<td>14.3</td>
<td>Lesson: Digitizing Forest Stands</td>
<td>314</td>
</tr>
<tr>
<td></td>
<td>14.4</td>
<td>Lesson: Updating Forest Stands</td>
<td>328</td>
</tr>
<tr>
<td></td>
<td>14.5</td>
<td>Lesson: Systematic Sampling Design</td>
<td>339</td>
</tr>
<tr>
<td></td>
<td>14.6</td>
<td>Lesson: Creating Detailed Maps with the Atlas Tool</td>
<td>345</td>
</tr>
<tr>
<td></td>
<td>14.7</td>
<td>Lesson: Calculating the Forest Parameters</td>
<td>360</td>
</tr>
<tr>
<td></td>
<td>14.8</td>
<td>Lesson: DEM from LiDAR Data</td>
<td>366</td>
</tr>
<tr>
<td></td>
<td>14.9</td>
<td>Lesson: Map Presentation</td>
<td>375</td>
</tr>
<tr>
<td>15</td>
<td>Module:</td>
<td>PostgreSQL でのデータベース概念</td>
<td>383</td>
</tr>
<tr>
<td></td>
<td>15.1</td>
<td>Lesson: Introduction to Databases</td>
<td>383</td>
</tr>
<tr>
<td></td>
<td>15.2</td>
<td>Lesson: データモデルの実装</td>
<td>388</td>
</tr>
<tr>
<td></td>
<td>15.3</td>
<td>Lesson: Adding Data to the Model</td>
<td>393</td>
</tr>
<tr>
<td></td>
<td>15.4</td>
<td>Lesson: 検索</td>
<td>396</td>
</tr>
<tr>
<td></td>
<td>15.5</td>
<td>Lesson: ビュー</td>
<td>400</td>
</tr>
<tr>
<td></td>
<td>15.6</td>
<td>Lesson: ルール</td>
<td>401</td>
</tr>
<tr>
<td>16</td>
<td>Module:</td>
<td>空間データベースの概念と PostGIS</td>
<td>403</td>
</tr>
<tr>
<td></td>
<td>16.1</td>
<td>Lesson: PostGIS の設定</td>
<td>403</td>
</tr>
<tr>
<td></td>
<td>16.2</td>
<td>Lesson: 単純地物モデル</td>
<td>406</td>
</tr>
<tr>
<td></td>
<td>16.3</td>
<td>Lesson: インポートとエクスポート</td>
<td>411</td>
</tr>
<tr>
<td></td>
<td>16.4</td>
<td>Lesson: 空間検索</td>
<td>413</td>
</tr>
<tr>
<td></td>
<td>16.5</td>
<td>Lesson: ジオメトリの構成</td>
<td>421</td>
</tr>
<tr>
<td>17</td>
<td>QGIS プロセッシングガイド</td>
<td>429</td>
<td></td>
</tr>
<tr>
<td></td>
<td>17.1</td>
<td>Introduction</td>
<td>429</td>
</tr>
<tr>
<td></td>
<td>17.2</td>
<td>An important warning before starting</td>
<td>429</td>
</tr>
<tr>
<td></td>
<td>17.3</td>
<td>プロセッシングフレームワークを構成する</td>
<td>431</td>
</tr>
<tr>
<td></td>
<td>17.4</td>
<td>Running our first algorithm. The toolbox</td>
<td>433</td>
</tr>
<tr>
<td></td>
<td>17.5</td>
<td>More algorithms and data types</td>
<td>436</td>
</tr>
<tr>
<td></td>
<td>17.6</td>
<td>CRSs. Reprojecting</td>
<td>443</td>
</tr>
<tr>
<td></td>
<td>17.7</td>
<td>Selection</td>
<td>446</td>
</tr>
<tr>
<td></td>
<td>17.8</td>
<td>Running an external algorithm</td>
<td>448</td>
</tr>
<tr>
<td></td>
<td>17.9</td>
<td>The processing log</td>
<td>453</td>
</tr>
<tr>
<td></td>
<td>17.10</td>
<td>The raster calculator. No-data values</td>
<td>455</td>
</tr>
<tr>
<td></td>
<td>17.11</td>
<td>Vector calculator</td>
<td>460</td>
</tr>
<tr>
<td></td>
<td>17.12</td>
<td>Defining extents</td>
<td>463</td>
</tr>
<tr>
<td></td>
<td>17.13</td>
<td>HTML outputs</td>
<td>467</td>
</tr>
<tr>
<td></td>
<td>17.14</td>
<td>First analysis example</td>
<td>468</td>
</tr>
<tr>
<td></td>
<td>17.15</td>
<td>Clipping and merging raster layers</td>
<td>477</td>
</tr>
<tr>
<td></td>
<td>17.16</td>
<td>Hydrological analysis</td>
<td>487</td>
</tr>
<tr>
<td></td>
<td>17.17</td>
<td>Starting with the graphical modeler</td>
<td>498</td>
</tr>
<tr>
<td></td>
<td>17.18</td>
<td>More complex models</td>
<td>509</td>
</tr>
<tr>
<td></td>
<td>17.19</td>
<td>Numeric calculations in the modeler</td>
<td>514</td>
</tr>
</tbody>
</table>
Chapter 1

コースのイントロダクション

1.1 序文

1.1.1 背景

In 2008 we launched the Gentle Introduction to GIS, a completely free, open content resource for people who want to learn about GIS without being overloaded with jargon and new terminology. It was sponsored by the South African government and has been a phenomenal success, with people all over the world writing to us to tell us how they are using the materials to run University Training Courses, teach themselves GIS and so on. The Gentle Introduction is not a software tutorial, but rather aims to be a generic text (although we used QGIS in all examples) for someone learning about GIS. There is also the QGIS manual which provides a detailed functional overview of the QGIS application. However, it is not structured as a tutorial, but rather as a reference guide. At Linfiniti Consulting CC, we frequently run training courses and have realised that a third resource is needed - one that leads the reader sequentially through learning the key aspects of QGIS in a trainer-trainee format - which prompted us to produce this work.

QGIS、PostgreSQLとPostGISの上で5日のコースをたどるために必要なすべての材料を提供することを、このトレーニング・マニュアルは目的とします。コースは同様に初心者向きで、中間体と上級者のための内容も構築されており、テキストを通じて多くのエクササイズを注釈がついている答えを完備したようにします。

1.1.2 ライセンス


自由にこの作品をコピーして、修正して、分担し直すことができる自由なライセンスで、我々はこのQGISトレーニング・マニュアルを出版しました。ライセンスの完全なコピーは、この文書の終わりに利用できます。単純な条件として、使用ガイドラインは以下の通りです：

・ あなたの自身の作品として、この作品を表現したり、この作品から任意の著作者のテキストやクレジットを削除することはできません。

・ それが提供されたときのものより制限された権限下で、この作品を再配布することはできません。
If you add a substantive portion to the work and contribute it back to the project (at least one complete module) you may add your name to the end of the authors list for this document (which will appear on the front page).

If you sponsor a module or lesson, you may request the author to include an acknowledgement in the beginning of each lesson contributed, e.g.:

If you add a substantive portion to the work and contribute it back to the project (at least one complete module) you may add your name to the end of the authors list for this document (which will appear on the front page).

If you sponsor a module or lesson, you may request the author to include an acknowledgement in the beginning of each lesson contributed, e.g.:

"Translated by Joe Bloggs"

If you sponsor a module or lesson, you may request the author to include an acknowledgement in the beginning of each lesson contributed, e.g.:

You may not commercialise this work, except with the expressed permission of the authors. To be clear, by commercialisation we mean that you may not sell for profit, create commercial derivative works (e.g. selling content for use as articles in a magazine). The exception to this is if all the profits are given to the QGIS project. You may (and we encourage you to do so) use this work as a text book when conducting training courses, even if the course itself is commercial in nature. In other words, you are welcome to make money by running a training course that uses this work as a text book, but you may not profit off the sales of the book itself - all such profits should be contributed back to QGIS.

This work is by no means a complete treatise on all the things you can do with QGIS and we encourage others to add new materials to fill any gaps. Linfiniti Consulting CC. can also create additional materials for you as a commercial service, with the understanding that all such works produced should become part of the core content and be published under the same license.

Rüdiger Thiede (rudi@linfiniti.com) - Rudi は QGIS 教材や PostGIS マテリアルの一部を書いています。

Tim Sutton (tim@linfiniti.com) - Tim は監督やガイドプロジェクトおよび PostgreSQL と PostGIS の部分を共同執筆しています。Tim はまた、このマニュアルで使用するカスタム sphinx テーマを執筆しています。

Horst Dster (horst.duester@kappasys.ch) - Horst は、PostgreSQL と PostGIS の部分を共同執筆

Marcelle Sutton (marcelle@linfiniti.com) - Marcelle は、この作品の作成中にブルーフリーディングおよび編集上の助言を提供しました。

あなたの名前をここに！

Cape Peninsula University of Technology
1.1.7 データ

**ノート:** マニュアルで使用するサンプルデータはこちらからダウンロードできます:
http://qgis.org/downloads/data/training_manual_exercise_data.zip

このリソースに付属のサンプルデータは、自由に利用可能で、次のルースに由来しています:
- OpenStreetMap (http://www.openstreetmap.org/) 由来の道路と地名データセット
- Property boundaries (urban and rural), water bodies from NGI (http://www.ngi.gov.za/)
- SRTM DEM from the CGIAR-CGI (http://srtm.csi.cgiar.org/)

1.1.8 最新バージョン


**ノート:** 上記のホームページの右下隅、マニュアルの PDF と epub バージョンへのリンクがあります。

Tim Sutton, May 2012

1.2 練習データの準備

トレーニングマニュアルと一緒に提供されているサンプルデータは Swellendam とその周辺の町を指します。Swellendam は南アフリカの西ケープ州ケープタウンの約 2 時間の東に位置しています。データセットは英語とアフリカーンス語の両方で地名を含みます。

誰もが無理なく、このデータセットを使用することができますが、自分の国や故郷からのデータを使用することを好むかもしれません。あなたがそうすることを選択した場合は、ローカライズされたデータは、モジュール 3 からモジュール 7.2 のすべてのレッスンで使用されます。それ以外のモジュールは、お住まいの地域ではご使用になれない場合があり、より複雑なデータソースを使用しています。

**ノート:** このプロセスはコース召集者、または、それらのコースのために専門的なサンプル・データセットをつくいたりより多くの QGIS ユーザーを経験しました。デフォルト・データセットはトレーニングマニュアルとともに提供されています。しかし、デフォルトデータセットを置き換えるなら、あなたはこれらの指示に従うかもしれません。

**ノート:** マニュアルで使用されるサンプルデータはここからダウンロードできます:
http://qgis.org/downloads/data/training_manual_exercise_data.zip

1.2.1 🚀 Try Yourself

**ノート:** 以下の手順では、QGIS の十分な知識を持っており、教材として使用されることを意図していないと仮定します。

あなたのコースにローカライズされたデータに設定されたデフォルトのデータを交換したい場合、QGIS に組み込まれたツールを使って簡単に行うことができます。あなたが使おうとする領域は、都市部と農村部の適当な混合地であり、河川や水面、道路、地域の境界 (自然保護区や農場など) などが分かれる必要があります。

- QGIS プロジェクトを開く

1.2. 練習データの準備 3
・ベクタメニューのドロップダウンではOpenStreetMap ->データのダウンロードを選択します。その後、手動で使用したい地域の座標を入力することもできますし、座標を設定するために、既存のレイヤを使用することができます。

・結果の保存場所となる.osmファイルを選択し、Okをクリックします。

・Add Vector Layerボタンを使って.osmファイルを開くことができます。ブラウザウィンドウ内でAll filesを選択するか、QGISのウィンドウにドラッグ＆ドロップすることができます。

・表示されたダイアログで、except the other_relationsとmultilinestrings layerのすべてのレイヤを選択します。
これは、OSMの命名規則に関連して、地図に4つのレイヤをロードします（あなたはベクトルデータを見るためにはズームイン/アウトする必要があるかもしれません）。

これらのレイヤから利用するデータを抽出し、それらの名前を変更し、対応するシェーブファイルを作成する必要があります。

- まず、multipolygonsレイヤをダブルクリックし、レイヤプロパティダイアログを開きます。
- Generalタブの中でQuery Builderをクリックし、Query builderウィンドウを開きます。

このレイヤは、トレーニングマニュアルで使用するために抽出する必要がある3つのフィールドを含みます:

- building
- :kbd:`natural`（特に、水部）
- landuse
You can sample the data your region contains in order to see what kind of results your region will yield. If you find that “landuse” returns no results, then feel free to exclude it.

あなたは、必要となるデータを抽出するために、各フィールドのフィルタ式を作成する必要があります。ここでは例として、「建物」フィールドを使用します。

- Enter the following expression into the text area: `building != "NULL"` and click Test to see how many results the query will return. If the number of results is small, you may wish to have a look at the layer’s Attribute Table to see what data OSM has returned for your region:

![Query Builder dialog]

- Ok をクリックし、マップから建物でない属性のレイヤーが削除されていることを確認します。

コース中に使用するため、結果データはシェープファイルとして保存する必要があります。

- Right-click the multipolygons layer and select Save As...

- ファイルの種類が ESRI Shapefile であることを確認し、"epsg4326" ディレクトリの下に、新しい exercise_data ディレクトリにファイルを保存します。

- 必ず No Symbology が選択されていることを確認します（後にコースの一部でシンボルを追加します）。

- You can also select Add saved file to map.

buildings がマップに追加されると、次の式を利用して natural と landuse フィールドのための手順を繰り返すことができます。
ノート：次のフィルタ式を実行する前に multipolygons レイヤから Layer properties ダイアログを使って前kopフィルタをクリアしてください！

- natural: “natural = ‘water’”
- landuse: “landuse != ‘NULL’”

得られた各データセットは、“epsg4326”ディレクトリの下の新しい exercise_data ディレクトリ内に保存する必要があります（つまり，“water”、“landuse”）。

その後、lines と points のフィールドを抽出しレイヤに対応するディレクトリへ保存する必要があります。

- lines: “highway != ‘NULL’” to roads, and “waterway != ‘NULL’” to rivers
- points: “place != ‘NULL’” to places

上記のデータを抽出することができたら multipolygons、lines、points の各レイヤを削除することができます。

これで、次のようなマップになっています必要があります（シンボルは異なるものになりますが、それは問題ありません）。

重要なことは、上に示したものと同じ6つのレイヤがあり、すべてのレイヤはいくつかのデータを持っていることです。

最後のステップは、もちろん使用するために landuse レイヤから spatialite ファイルを作成することです。

- landuse レイヤを右クリックし、名前を付けて保存…を選択します。
- フォーマットとして SpatialLite を選択し、“epsg4326”ディレクトリの下に landuse というファイルを保存します。
- Click Ok。
- Delete the landuse.shp and its related files (if created).

### 1.2.2 🚀 Try Yourself SRTM DEM tiff ファイルの作成

For Module 6 (Creating Vector Data) and Module 8 (Rasters), you’ll also need raster images (SRTM DEM) which cover the region you have selected for your course.
SRTM DEM は CGIAR-CGI: http://srtm.csi.cgiar.org/からダウンロードできます。
必要なファイルをダウンロードしたら、“raster/SRTM/” ディレクトリの下にある”exercise_data” ディレクトリへ保存してください。
In Module 6, Lesson 1.2 shows close-up images of three school sports fields which students are asked to digitize. You’ll therefore need to reproduce these images using your new SRTM DEM tiff file(s). There is no obligation to use school sports fields: any three school land-use types can be used (e.g. different school buildings, playgrounds or car parks).
参考までに、サンプルデータの画像があります:
1.2.3 Try Yourself トークンの置き換え

Having created your localised dataset, the final step is to replace the tokens in the `conf.py` file so that the appropriate names will appear in your localised version of the Training Manual.

置き換える必要のあるトークンは次のとおりです:

- `majorUrbanName`: これはデフォルト"Swellendam"ですが、選んだ範囲の主要な町の名前に置き換れます。

- `schoolAreaType1`: これはデフォルト"athletics field"ですが、選んだ範囲で最大の学校エリアの名前に置き換れます。

- `largeLandUseArea`: これはデフォルト"Bontebok National Park"ですが、選んだ範囲で広範囲な土地利用ポリゴン名に置き換れます。

- `srtmFileName`: これはデフォルト `srtm_41_19.tif`ですが、SRTM DEM ファイルのファイル名に置き換えてください。

- `localCRS`: これはデフォルト WGS 84 / UTM 34Sですが、これをあなたの地域に合わせて、正しい CRS に置き換える必要があります。
Chapter 2

Module: インタフェース

2.1 Lesson: はじめに

私達のコースへようこそ! これより QGIS の簡単で効率的な使い方について、数日をかけて教えていきます。もし QGIS を使うのが初めての場合は、はじめかたについても説明します。もし既に使用している場合であっても、あなたが使いたい全ての機能を QGIS で実現する方法についてより知ることができるはずです。

ここでは QGIS のユーザーインターフェースだけでなく、プロジェクトについても説明していきます。

このセクションを終えれば、QGIS 画面の要素を性格に把握することができ、それぞれどのように機能するのか、そして shapefile の読み込み方を知ることができるようになります。

警告: このコースでは GIS データセットの追加、消去、そして変更のしかたについて紹介します。練習用にデータセットを用意しております。ここで紹介する機能を実際に自分のデータに使用する前には必ずデータのバックアップを取っておいて下さい。

2.1.1 チュートリアルの使いかた

こんな感じの文字は、画面上でクリックできることを示します。
looks → like → this のテキストはメニューの指示です。
この種のテキストは、あなたがタイプできるコマンド、パス、ファイル名のようなものを指します。

2.1.2 階層型コースの目的

このコースでは、異なるユーザの経験レベルの内容を用意する。どのカテゴリがあなたに合うと考えるかによりますが、当然結果の異なるコースのセットを期待することができます。各カテゴリには、次のために必須である情報が含まれているので、経験レベルの、または下にあるすべての演習を行うことが重要です。

緑の絵

このカテゴリにおいて、コースは、理論的な GIS の知識や GIS プログラムの動作にほとんど、またはまったく経験を持っていないことを前提としています。

限られた理論的背景は、プログラムで実行されるアクションの目的を説明するために提供されますが、重点は、実行して学習することにあります。

あなたはコースを完了すると、GIS の可能性と、どのように QGIS を経由してその力を活用していくかのよりよいコンセプトを持つことになります。
Extensive help and documentation is available. If you're stuck with anything, you can turn to the extensive documentation, your fellow QGIS users, or even the developers.

Now that you know why you want to use QGIS, we can show you how. The first lesson will guide you in creating your first QGIS map.

2.2 Lesson: 第一レイヤの追加

アプリケーションを起動し、その例と演習で使用する基本的なマップを作成します。

このレッスンの目標: 例のようなマップを始める

ノート: この演習を始める前に、QGIS をあなたのコンピュータにインストールしておく必要があります。また、QGIS data downloads area から training_manual_exercise_data.zip ファイルをダウンロードしておきます。
2.2. Lesson: 第一レイヤの追加

デスクトップのショートカット、メニュー、アイテムなどから QGIS を起動します。この設定はインストール時の設定に依存します。

ノート: このコースのスクリーンショットは、MacOS の上で実行されている QGIS2.0 で撮影されました。あなたの設定に応じて、あなたが遭遇した画面と仕様が異なる場合があります。しかし、利用可能なボタンはすべて同じであり、コマンドはいかなる OS 上で動作します。あなたはこのコースを使用するには QGIS2.0（執筆時点での最新版）が必要です。

すぐはじめましょう！

2.2.1 Follow Along: マップの準備

- QGIS を開きます。新規に空白のマップがあります。
- Look for the Add Vector Layer button:
- それをクリックすると次のダイアログが開きます：

![マップの準備](image)

- Click on the Browse button and navigate to the file exercise_data/epsg4326/roads.shp (in your course directory). With this file selected, click Open. You will see the original dialog, but with the file path filled in. Click Open here as well. The data you specified will now load.

おめでとうございます！ベースマップがあります。作業を保存するにはよいタイミングでしょう。

- Click on the Save As button:
- Save the map under exercise_data/ and call it basic_map.qgs.

結果の確認

2.2.2 In Conclusion

レイヤの追加方法とベースマップの作成について学びました！
2.2.3 What's Next?

Now you’re familiar with the function of the Add Vector Layer button, but what about all the others? How does this interface work? Before we go on with the more involved stuff, let’s first take a good look at the general layout of the QGIS interface. This is the topic of the next lesson.

2.3 Lesson: インタフェースのあらまし

インターフェースの基本的な構造を形成するメニュー、ツールバー、マップキャンバスとレイヤーリストに慣れてもらえるよう、私たちは、QGIS のユーザーインターフェイスを探る。
このレッスンの目標: QGIS のユーザインタフェースの基礎を理解する。

2.3.1 Try Yourself:基礎

上の図で特定される要素は以下のとおりです:
1. レイヤリスト/ブラウザパネル
2. ツールバー
3. マップキャンバス
4. ステータスバー
5. サイドツールバー

レイヤリスト

レイヤリストでは、いつでも、あなたが利用可能な時に、すべてのレイヤのリストを見ることができます。
Try to identify the four elements listed above on your own screen, without referring to the diagram above. See if you can identify their names and functions. You will become more familiar with these elements as you use them in the coming days.

Check your results
### 2.3.3 Try Yourself 2

Try to find each of these tools on your screen. What is their purpose?

1. 
2. 
3. 
4. 
5. 

**Note:** If any of these tools is not visible on the screen, try enabling some toolbars that are currently hidden. Also keep in mind that if there isn’t enough space on the screen, a toolbar may be shortened by hiding some of its tools. You can see the hidden tools by clicking on the double right arrow button in any such collapsed toolbar. You can see a tooltip with the name of any tool by holding your mouse over the tool for a while.

**Check your results**

### 2.3.4 What’s Next?

Now you’ve seen how the QGIS interface works, you can use the tools available to you and start improving on your map! This is the topic of the next lesson.
Chapter 3

Module: 基礎的な地図作成

このモジュールでは、QGIS の機能性のさらなるデモンストレーションに基づいて、後で使用される基本的な
マップを作成します。

3.1 Lesson: ベクトルデータの操作

おそらくベクトルデータは、あなたが毎日 GIS を使うデータの中で最も一般的な種類でしょう。ここでは地
理データに関してのラインとポリゴンについて説明しています。ベクトルデータセット内のすべてのオブ
ジェクトは**"feature"**と呼ばれ、その特徴を記述したデータに関連付けられています。

このレッスンの目標：ベクトルデータの構造と、どのようにマップへのベクトルデータをロードするかを学び
ます。

3.1.1 Follow Along: レイヤー属性の表示

これは、オブジェクトが**""**などの場所**"**にあるのか、使用されているデータだけで表現されていない事を知っ
ておくのが重要です。またこれらのオブジェクトが**""**のようなもの**"**であるかがわかります。

前のレッスンで使用した roads レイヤーがマップにロードされている必要があります。今あなたが見ること
ができるのは単なる道路の位置だけです。

選択された roads を見えるように表示するには、レイヤーパネル:

- ボタンをクリックします。

roads に関してより多くのデータが記録されたテーブルが表示されます。この追加データは 属性データ と
呼ばれています。行はマップ上で道路をどのように表現するかを表しています。

これらの定義は一般的に GIS で使用されているので、定義を覚えておくことは不可欠です！

- ここで属性テーブルを開じてください。

ベクトルデータは、座標平面上で点、線、多角形の面での地物を表しています。これは通常、道路や街区のよ
うな個別の地物を格納するために使用されています。

3.1.2 Follow Along: シェープファイルによるベクトルデータのロード

シェープファイルは、関連するグループのファイルに GIS データを保存することができる特定のファイル形
式です。各レイヤは、同じ名前で拡張子の異なる複数のファイルで構成されます。シェープファイルはほと
んどの GIS ソフトウェアで読むことができるの、あちこちに送ることが容易です。
ベクトルレイヤを追加する方法については、前のセクションでの練習を参照してください。
同じ方法に従ってマップへデータセットをロードします。

• “places”
• “water”
• “rivers”
• “buildings”

Check your results

3.1.3 Follow Along: データベースによるベクトルデータのロード

Databases allow you to store a large volume of associated data in one file. You may already be familiar with a database management system (DBMS) such as Microsoft Access. GIS applications can also make use of databases. GIS-specific DBMSes (such as PostGIS) have extra functions, because they need to handle spatial data.

• のアイコンをクリックします。
(もしそれが全く表示されない場合は、レイヤ管理ツールバーのチェックが有効になっているか確認します。)
新しいダイアログが表示されます。このダイアログで:

• Click the New button.
• In the same folder as the other data, you should find the file landuse.sqlite. Select it and click Open.

You will now see the first dialog again. Notice that the dropdown select above the three buttons now reads “land_use.db@…”, followed by the path of the database file on your computer.

• 接続ボタンをクリックします。空のボックスでどのように見えるはずです。
Click on the landuse layer to select it, then click Add

Note: Remember to save the map often! The map file doesn’t contain any of the data directly, but it remembers which layers you loaded into your map.

3.1.4 Follow Along: レイヤの順序入れ替え

The layers in your Layers list are drawn on the map in a certain order. The layer at the bottom of the list is drawn first, and the layer at the top is drawn last. By changing the order that they are shown on the list, you can change the order they are drawn in.

Note: Depending on the version of QGIS that you are using, you may have a checkbox beneath your Layers list reading Control rendering order. This must be checked (switched on) so that moving the layers up and down in the Layers list will bring them to the front or send them to the back in the map. If your version of QGIS doesn’t have this option, then it is switched on by default and you don’t need to worry about it.

The order in which the layers have been loaded into the map is probably not logical at this stage. It’s possible that the road layer is completely hidden because other layers are on top of it.

たとえば、このレイヤ順は …
... would result in roads and places being hidden as they run *underneath* urban areas.

問題を解決するために:

- Click and drag on a layer in the Layers list.
- こう見えるようにそれらの順番を入れ替えます:

You’ll see that the map now makes more sense visually, with roads and buildings appearing above the land use regions.

### 3.1.5 In Conclusion

Now you’ve added all the layers you need from several different sources.

### 3.1.6 What’s Next?

Using the random palette automatically assigned when loading the layers, your current map is probably not easy to read. It would be preferable to assign your own choice of colors and symbols. This is what you’ll learn to do in the next lesson.
3.2 Lesson: シンボロジー

レイヤのシンボルは、地図上の外観です。空間的な側面を持つデータを表現する他の方法以上の GIS の基本的な強みは、GIS を使用すると、作業データの動的な視覚表現を持っているということです。

Therefore, the visual appearance of the map (which depends on the symbology of the individual layers) is very important. The end user of the maps you produce will need to be able to easily see what the map represents. Equally as important, you need to be able to explore the data as you’re working with it, and good symbology helps a lot.

つまり、適切なシンボルを持つことは、高級でもなくまたは単に素晴らしいことではありません。実際にには、適切に GIS を使用して、地図や、人々が使用できる情報を生成するためにそれが不可欠です。

**このレッスンの目標:**ベクタレイヤに、あなたが望むシンボロジーを作成できるようになる

3.2.1 Follow Along: 色の変更

レイヤのシンボロジーを変更するには、そのレイヤのレイヤのプロパティを表示します。landuse レイヤの色を変更するのを始めましょう。

- レイヤリストで landuse レイヤを右クリックします。
- Select the menu item Properties in the menu that appears.

ノート：デフォルトでは、レイヤリストでリスト上でダブルクリックすることで、レイヤプロパティにアクセスできます。

プロパティウィンドウにて:

- 左のスタイルタブを選択します。
3.2.2 _try yourself_{

水レイヤを薄い青色に変更しましょう。
結果の確認

3.2.3  follow along: シンボル構造の変更

これはこれまでのところ良いものですが、ちょうどその色よりも、レイヤのシンボルに適したものがあります。次に、視覚的に雰囲くなるように様々な土地利用エリア間のラインを削除したいと思います。

- Open the Layer Properties window for the landuse layer.
In the Symbol Layers panel, expand the Fill dropdown (if necessary) and select the Simple fill option:

- Click on the Border style dropdown. At the moment, it should be showing a short line and the words Solid Line.
- Click OK.

今、landuse レイヤでは、エリア間にいかなるラインを持ちません。

3.2.4 Try Yourself

- 濃い青の外形線を持つため、water レイヤのシンボロジーを再度変えます。
- 水路の表示を明確に表現するため rivers レイヤのシンボロジーを変更します。

結果の確認
3.2.5 Follow Along: スケールにもとづく表示

Sometimes you will find that a layer is not suitable for a given scale. For example, a dataset of all the continents may have low detail, and not be very accurate at street level. When that happens, you want to be able to hide the dataset at inappropriate scales.

我々のケースでは、小さなスケールで視界から建物を非表示にすることを決定することができます。このマップは、たとえば...

- Open the Layer Properties dialog for the buildings layer.
- 一般情報 タブをアクティブにします。
- Enable scale-based rendering by clicking on the checkbox labeled Scale dependent visibility:
• Change the Maximum value to 1:10,000.
• Click OK.

Now that you know how to change simple symbology for layers, the next step is to create more complex symbology. QGIS allows you to do this using symbol layers.

- Go back to the landuse layer’s symbol properties panel (by clicking Simple fill in the Symbol layers panel).

In this example, the current symbol has no outline (i.e., it uses the No Pen border style).

Select the Fill in the Symbol layers panel. Then click the Add symbol layer button:
・それをクリックし、ダイアログがこのような見え方に変わります:
Now there’s a second symbol layer. Being a solid color, it will of course completely hide the previous kind of symbol. Plus, it has a Solid Line border style, which we don’t want. Clearly this symbol has to be changed.

(Note: It’s important not to get confused between a map layer and a symbol layer. A map layer is a vector (or raster) that has been loaded into the map. A symbol layer is part of the symbol used to represent a map layer. This course will usually refer to a map layer as just a layer, but a symbol layer will always be called a symbol layer, to prevent confusion.)

With the new Simple Fill layer selected:

- Set the border style to No Pen, as before.
- Change the fill style to something other than Solid or No brush. For example:
• Click OK. Now you can see your results and tweak them as needed.

複数シンボルレイヤを追加し、そのようにレイヤのテクスチャの種類を作成することができます。
It’s fun! But it probably has too many colors to use in a real map...

### 3.2.7  Try Yourself

- Remembering to zoom in if necessary, create a simple, but not distracting texture for the *buildings* layer using the methods above.

### 3.2.8  Follow Along: シンボルレベルの順序

When symbol layers are rendered, they are also rendered in a sequence, similar to the way the different map layers are rendered. This means that in some cases, having many symbol layers in one symbol can cause unexpected results.

- Give the *roads* layer an extra symbol layer (using the method for adding symbol layers demonstrated above).
- Give the base line a *Pen width* of 0.3, a white color and select *Dashed Line* from the *Pen Style* dropdown.
- Give the new, uppermost layer a thickness of 1.3 and ensure that it is a *Solid Line.*

あなたはこれが発生したことがわかります。
To prevent this from happening, you can sort the symbol levels and thereby control the order in which the different symbol layers are rendered.

To change the order of the symbol layers, select the Line layer in the Symbol layers panel, then click Advanced -> Symbol levels... in the bottom right-hand corner of the window. This will open a dialog like this:
Select *Enable symbol levels*. You can then set the layer ordering of each symbol by entering the corresponding level number. 0 is the bottom layer.

我々のケースでは、このように順序を入れ替えたいと思います:
これは太い黒線の上に破線、白線をレンダリングします。

・OK を 2 回クリックし、マップに戻ります。
マップはこのように見られるでしょう:
Also note that the meeting points of roads are now “merged”, so that one road is not rendered above another.

When you’re done, remember to save the symbol itself so as not to lose your work if you change the symbol again in the future. You can save your current symbol style by clicking the Save Style ... button under the Style tab of the Layer Properties dialog. Generally, you should save as QGIS Layer Style File.

Save your style under exercise_data/styles. You can load a previously saved style at any time by clicking the Load Style ... button. Before you change a style, keep in mind that any unsaved style you are replacing will be lost.

3.2.9  Try Yourself

• Change the appearance of the roads layer again.

The roads must be narrow and mid-gray, with a thin, pale yellow outline. Remember that you may need to change the layer rendering order via the Advanced -> Symbol levels... dialog.
Symbol levels also work for classified layers (i.e., layers having multiple symbols). Since we haven’t covered classification yet, you will work with some rudimentary pre-classified data.

- Create a new map and add only the `roads` dataset.
- Apply the style `advanced_levels_demo.qml` provided in `exercise_data/styles`.
- Swellendam のエリアにズームします。
- Using symbol layers, ensure that the outlines of layers flow into one another as per the image below:
3.2.11 Follow Along: シンボルレイヤタイプ

In addition to setting fill colors and using predefined patterns, you can use different symbol layer types entirely. The only type we’ve been using up to now was the Simple Fill type. The more advanced symbol layer types allow you to customize your symbols even further.

Each type of vector (point, line and polygon) has its own set of symbol layer types. First we will look at the types available for points.

ポイントシンボルレイヤタイプ

- ベーシックマップ プロジェクトを開きます。
- Change the symbol properties for the places layer:
You can access the various symbol layer types by selecting the
*Simple marker* layer in the *Symbol layers* panel, then click the *Symbol layer type* dropdown:
• Investigate the various options available to you, and choose a symbol with styling you think is appropriate.

• If in doubt, use a round Simple marker with a white border and pale green fill, with a size of 3.00 and an Outline width of 0.5.

ラインシンボルレイヤタイプ

To see the various options available for line data:

• Change the symbol layer type for the roads layer’s topmost symbol layer to Marker line:

![Symbol layer type window](image)

• Select the Simple marker layer in the Symbol layers panel. Change the symbol properties to match this dialog:
・間隔を1,00に変更します：
• Ensure that the symbol levels are correct (via the Advanced -> Symbol levels dialog we used earlier) before applying the style.

Once you have applied the style, take a look at its results on the map. As you can see, these symbols change direction along with the road but don’t always bend along with it. This is useful for some purposes, but not for others. If you prefer, you can change the symbol layer in question back to the way it was before.

ポリゴンシンボルレイヤータイプ

To see the various options available for polygon data:

• Change the symbol layer type for the water layer, as before for the other layers.
• Investigate what the different options on the list can do.
• これらのうち、適した１つを選択します。
• If in doubt, use the Point pattern fill with the following options:
• Add a new symbol layer with a normal *Simple fill*.
• Make it the same light blue with a darker blue border.
• Move it underneath the point pattern symbol layer with the *Move down* button:
As a result, you have a textured symbol for the water layer, with the added benefit that you can change the size, shape and distance of the individual dots that make up the texture.

3.2.12 🚨 Follow Along: カスタム SVG 塗りつぶしの作成

ノート: To do this exercise, you will need to have the free vector editing software Inkscape installed.

- Inkscape プログラムを起動します。
以下のインタフェースを確認できるでしょう。
You should find this familiar if you have used other vector image editing programs, like Corel.

First, we’ll change the canvas to a size appropriate for a small texture.

- Click on the menu item File → Document Properties. This will give you the Document Properties dialog.
- Change the Units to px.
- Change the Width and Height to 100.
- 実行後はダイアログを閉じます。
- Click on the menu item View → Zoom → Page to see the page you are working with.
- 円ツールを選択します。
• Click and drag on the page to draw an ellipse. To make the ellipse turn into a circle, hold the `ctrl` button while you’re drawing it.

• Right-click on the circle you just created and open its Fill and Stroke:

• Change the Stroke paint to a pale grey-blue and the Stroke style to a darker color with thin stroke:
• Click once to start the line. Hold ctrl to make it snap to increments of 15 degrees.
• Click once to end the line segment, then right-click to finalize the line.
• Change its color and width to match the circle’s stroke and move it around as necessary, so that you end up with a symbol like this one:
• Save it as `landuse_symbol` under the directory that the course is in, under `exercise_data/symbols`, as an SVG file.

QGIS では:

• Open the Layer Properties for the `landuse` layer.
• Change the symbol structure to the following and find your SVG image via the Browse button:
You may also wish to update the svg layer’s border:
Your landuse layer should now have a texture like the one on this map:
3.2.13 In Conclusion

Changing the symbology for the different layers has transformed a collection of vector files into a legible map. Not only can you see what’s happening, it’s even nice to look at!

3.2.14 Further Reading

Examples of Beautiful Maps

3.2.15 What’s Next?

Changing symbols for whole layers is useful, but the information contained within each layer is not yet available to someone reading these maps. What are the streets called? Which administrative regions do certain areas belong to? What are the relative surface areas of the farms? All of this information is still hidden. The next lesson will explain how to represent this data on your map.

ノート：最近のマップを保存するのを覚えてますか？
Chapter 4

Module: ベクタデータの分類

ベクタデータを分類することで、その属性に応じ、地物（同一レイヤ内の異なるオブジェクト）に異なるシンボルを割り当てることができます。これは、マップを使う人が、様々な地物の属性を簡単に表示することを可能にします。

4.1 Lesson: Attribute Data

Up to now, none of the changes we have made to the map have been influenced by the objects that are being shown. In other words, all the land use areas look alike, and all the roads look alike. When looking at the map, the viewers don’t know anything about the roads they are seeing; only that there is a road of a certain shape in a certain area.

But the whole strength of GIS is that all the objects that are visible on the map also have attributes. Maps in a GIS aren’t just pictures. They represent not only objects in locations, but also information about those objects.

The goal of this lesson: To explore the attribute data of an object and understand what the various data can be useful for.

4.1.1 Follow Along: Attribute data

Open the attribute table for the places layer (refer back to the section “Working with Vector Data” if necessary). Which field would be the most useful to represent in label form, and why?

Check your results

4.1.2 In Conclusion

You now know how to use the attribute table to see what is actually in the data you’re using. Any dataset will only be useful to you if it has the attributes that you care about. If you know which attributes you need, you can quickly decide if you’re able to use a given dataset, or if you need to look for another one that has the required attribute data.

4.1.3 What’s Next?

Different attributes are useful for different purposes. Some of them can be represented directly as text for the map user to see. You’ll learn how to do this in the next lesson.
4.2 Lesson: ラベルツール

オブジェクトに関する情報を表示するためにラベルを地図に追加することができます。任意のベクタレイヤはそれに関連するラベルを持つことができます。ラベルの内容はレイヤの属性データに依存します。

ノート: レイヤプロパティダイアログはラベルタブを持ち同じ機能を提供していますが、この例ではツールバーのボタンからアクセスできるラベルツールを使用します。

このレッスンの目標: 役に立ち見栄えの良いラベルをレイヤに適用します。

4.2.1 Follow Along: ラベルの使用

ラベルツールにアクセスする前に、それがアクティブになっていることを確認する必要があります。

- メニュー項目ビュー→ツールバーに移動します。
- ラベルアイテムの横にチェックマークがあることを確認して下さい。もしなければラベルアイテムをクリックするとアクティブになります。
- レイヤリストでplacesレイヤをクリックしてハイライト表示させます。

- このツールバーのボタンをクリックします:

レイヤラベリング設定ダイアログが表示されます。

- このレイヤのラベルの隣のボックスをチェックします。

ラベルに使用する属性フィールドを選択します。前のレッスンであればこの目的にはNAMEフィールドが最も適していると決めました。

- リストからnameを選択します:
・OK をクリックします。
今、地図にはこのようなラベルが表示されるはずです:

4.2. Lesson: ラベルツール
4.2.2 Green Follow Along: ラベルオプションの変更

以前のレッスンであなたが選択したスタイルによってはラベルが適切にフォーマットされず、重複していたりポイントマーカーから遠く離れていたりしているかもしれません。

- 前のようにツールバーのボタンを押して ラベルツール を再度開きます。
- Make sure Text is selected in the left-hand options list, then
  update the text formatting options to match those shown here:
フォントの問題が解決されました！では、ポイントにラベルが重なる問題を見てみましょう。しかし、その前に バッファ オプションを見てみます。

・ ラベルツール ダイアログを開きます。
・ 左側のオプションリストから バッファ を選択します。
・ Select the checkbox next to Draw text buffer, then choose options to match those shown here:
QGIS Training Manual, リリース 2.2

・適用 をクリックします。
着色されたバッファまたは境界線が場所ラベルに追加されて地図上で見分けやすくなりました:

56 Chapter 4. Module: ベクタデータの分類
ポイントマーカーに相対的なラベルの配置に取りかかります。

- ラベルツール ダイアログで 配置 タブに移ります。
- Change the value of Distance to 2mm and make sure that Around point is selected:

Around point is selected:
4.2.3 Follow Along: レイヤシンボロジの代わりにラベルを使用する

多くの場合、ポイントの位置はあまり的確である必要はありません。たとえば、places レイヤのポイントのほとんどは町全体や郊外を指し示し、そのような地物に関連するポイントは大縮尺ではそれほど的確ではありません。実際には、詳細すぎるポイントを与えるとしばしば地図を読む人に混乱を招くことがあります。

例を挙げると：例えば、世界地図上では欧州連合のために与えられた点はポーランドのどこかにあります。European Union のラベルの付いたポイントがポーランドにあるので、地図を読んでいる人には欧州連合の首都はポーランドにあるように見える場合があります。

だから、この種の誤解を防ぐためにポイントシンボルを非アクティブ化してラベルに完全に置き換えるのがよい場合があります。

QGIS ではラベルが参照するポイントの直上にラベルの位置を変更することによってこれを行うことができます。

- places レイヤの レイヤラベリング設定 ダイアログを開きます。
- オプションリストの中から 配置 オプションを選択します。
- ポイントからのオフセット ボタンをクリックします。
ポイントマーカーとの相対位置でラベルの位置を設定することのできる 象限 オプションが現れます。この場合、私たちはラベルを点を中心に配置したいので中央の象限を選択します。

- ポイントシンポルを隠すためにいつものようにレイヤスタイルを編集して、機能マーカー の幅と高さのサイズを 0 に設定します:

4.2. Lesson: ラベルツール
・OK をクリックすると、この結果が表示されます。
マップ上でズームアウトした場合にはラベルの一部がより小さな縮尺では重なりを避けるために消えていることがわかりました。これは多くのポイントを持つデータセットを扱う場合に都合がよい場合がありますが、有用な情報を失ってしまう場合もあります。このレッスンの後ほどのエクササイズでは、このような場合で処理するための別の手段を取り上げます。

### 4.2.4 Try Yourself ラベルのカスタマイズ

- シンボルとラベルの設定をポイントマーカーと 2.00mm のラベルオフセットに戻します。この段階でポイントマーカーやラベルのスタイリングを調整したいと思うことがあります。

結果をチェックする

- 地図の縮尺を 1:100000 に設定します。ステータスバーのスケールボックスに入力することでこれを行うことができます。
- この縮尺での表示に合うようにラベルを変更します。

結果をチェックする

---

4.2. Lesson: ラベルツール 61
4.2.5  フォローアロン：ラインのラベリング

今、あなたはラベリングがどのように動作するか知っていますが、まだ別の問題があります。ポイントとポリゴンにラベルを付けるのは簡単ですが、ラインはどうでしょうか？ポイントと同じようにラベルを付ける場合、このようなになります:

では、roads レイヤのラベルの体裁を理解しやすいように再調整します。
- 気が散らないように Places レイヤを非表示にします。
- streets レイヤのラベルを前に有効化します。
- より多くのラベルが表示されるようにフォントサイズを 10 に設定します。
- Swellendam の市街地にズームインします。
- ラベルツールダイアログの配置オプションで次の設定をします:
おそらく、テキストスタイルが既定値を使用していてその結果としてラベルは非常に読みづらいことがわかります。ラベルテキストの書式に暗い灰または黒の色と淡黄色のバッファを設定します。
地図は縮尺に応じてこのように見えます:

4.2. Lesson: ラベルツール
いくつかの道路名が複数回表示されますがいつも必要だとは限りません。これを防ぐには:

・レイヤーベリング設定 ダイアログで レンダリング オプションを選択し、重複ラベルを除去するため
に接続するラインを結合する を選択します.
• OK をクリックします
もう1つの有用な機能はラベルを付けるには短すぎる地物にラベルが描画されないようにするものです。

• 同じレンダリングパネルでこれより地物が小さい場合ラベルを行わないの値を 5mm に設定します。適用ボタンをクリックした時に表示される結果に注目して下さい。

同様にして異なる配置設定を試してみて下さい。前に見てきたように水平オプションはこの場合にはお勧めできません。その代わりに曲がってオプションを試してみましょう。

• レイヤラベル設定ダイアログの配置パネルで曲がってオプションを選択します。
この結果です:
ご覧のように、それらのいくつかは曲がりくねった街路に沿わせると判読可能な状態ではなくなってしまうので、以前表示されていたラベルの多くが非表示になります。より有用であるようにと考えるか、またはより格好がよくなるようにと考えるかによって、これらのオプションのどれを使うかを決めることが可能です。

### 4.2.6 Follow Along: データ定義による設定

- *Streets* レイヤのラベリングを無効にします。
- *Places* レイヤのラベリングを再度有効にします。

ボタンをクリックして Places の属性テーブルを開きます。

今私たちに関心のあるフィールドが 1 つあります。place は各オブジェクトの都市エリアの種類を定義します。このデータを用いてラベルスタイルに影響を与えることができます。

- *places* の ラベル ダイアログの テキスト パネルに変更します。
- イタリックテキスト の右側のボタンをクリックし、編集... を選択して 式文字列ビルダー を開きます。
テキスト入力で "place" = ‘town’ と入力し、Ok を 2 回クリックします:
その効果に注目してください：
4.2.7 Try Yourself データ定義による設定の使用

ノート：私たちはいくつかの高度なラベルリング設定を示すために、ここで少し先にジャンプしています。高度なレベルでは以下のことが何を意味するか知っていることを想定しています。そうでなければこのセクションはスキップして必要なマテリアルをカバーした後に戻って来て下さい。

- places の属性テーブルを開きます。
- このボタンをクリックして編集モードにします：
- 新しい列を追加します:

- このように構成します:
4.2.8 ラベリングのさらなる可能性

このコースではすべてのオプションをカバーすることはできませんが、ラベルツールには他にも多くの有用な機能があることを知っておいてください。縮尺ベースのレンダリングを設定したり、ラベルのレンダリングの優先順位を変更したり、すべてのラベルオプションをレイヤの属性を用いて設定したりすることができます。ラベルの回転や XY 位置、その他のプロパティを設定することもできます（この目的のために割り当てられた属性フィールドを持っている場合）。そして、これらのプロパティをメインのラベルツールの隣にあるツールを使って編集することができます。

(これらのツールが必要な属性フィールドが存在して、編集モードの場合にアクティブになります。)

ラベリングシステムの可能性をもっと探してみて下さい。

4.2.9 In Conclusion

あなたは動的なラベル作成のためにレイヤの属性を使用する方法を学びました。これによりあなたの地図の情報量を増やし、地図をスタイリッシュにすることができます！
4.2.10 What’s Next?

属性によって地図に視覚的な違いを生じさせる方法がわかりました。オブジェクトそれ自体のシンボロジーを変更するのに属性を使用することはどうでしょう？次のレッスンのトピックです！

4.3 Lesson: Classification

Labels are a good way to communicate information such as the names of individual places, but they can’t be used for everything. For example, let’s say that someone wants to know what each landuse area is used for. Using labels, you’d get this:

This makes the map’s labeling difficult to read and even overwhelming if there are numerous different landuse areas on the map.

The goal for this lesson: To learn how to classify vector data effectively.

4.3.1 🌿 Follow Along: Classifying Nominal Data

- Open the Layer Properties dialog for the landuse layer.
- Go to the Style tab.
- Click on the dropdown that says Single Symbol and change it to Categorized:

![Map with classified landuse areas]
• In the new panel, change the Column to landuse and the Color ramp to Greens.
• Click the button labeled Classify:
• Click OK.

You’ll see something like this:
• Click the arrow (or plus sign) next to landuse in the Layer list, you’ll see the categories explained:

Now our landuse polygons are appropriately colored and are classified so that areas with the same land use are the same color. You may wish to remove the black border from the landuse layer:
• Open Layer Properties, go to the Style tab and select Symbol.
• Change the symbol by removing the border from the Simple Fill layer and click OK.
You’ll see that the landuse polygon outlines have been removed, leaving just our new fill colours for each categorisation.
• If you wish to, you can change the fill color for each landuse area by double-clicking the relevant color block:

Notice that there is one category that’s empty:
This empty category is used to color any objects which do not have a landuse value defined or which have a NULL value. It is important to keep this empty category so that areas with a NULL value are still represented on the map. You may like to change the color to more obviously represent a blank or NULL value. Remember to save your map now so that you don’t lose all your hard-earned changes!

### 4.3.2 Try Yourself More Classification

If you’re only following the basic-level content, use the knowledge you gained above to classify the buildings layer. Set the categorisation against the building column and use the Spectral color ramp.

**Note:** Remember to zoom into an urban area to see the results.

### 4.3.3 Follow Along: Ratio Classification

There are four types of classification: nominal, ordinal, interval and ratio.

In nominal classification, the categories that objects are classified into are name-based; they have no order. For example: town names, district codes, etc.
In ordinal classification, the categories are arranged in a certain order. For example, world cities are given a rank depending on their importance for world trade, travel, culture, etc.

In interval classification, the numbers are on a scale with positive, negative and zero values. For example: height above/below sea level, temperature above/below freezing (0 degrees Celsius), etc.

In ratio classification, the numbers are on a scale with only positive and zero values. For example: temperature above absolute zero (0 degrees Kelvin), distance from a point, the average amount of traffic on a given street per month, etc.

In the example above, we used nominal classification to assign each farm to the town that it is administered by. Now we will use ratio classification to classify the farms by area.

- Save your landuse symbology (if you want to keep it) by clicking on the Save Style ... button in the Style dialog.

We’re going to reclassify the layer, so existing classes will be lost if not saved.

- Close the Style dialog.
- Open the Attributes Table for the landuse layer.

We want to classify the landuse areas by size, but there’s a problem: they don’t have a size field, so we’ll have to make one.

- Enter edit mode by clicking this button:

- Add a new column with this button:

- Set up the dialog that appears, like this:
Click OK.

The new field will be added (at the far right of the table; you may need to scroll horizontally to see it). However, at the moment it is not populated, it just has a lot of NULL values.

To solve this problem, we’ll need to calculate the areas.

- Open the field calculator:

You’ll get this dialog:
• Change the values at the top of the dialog to look like this:

![Field calculator dialog](image)

• In the Function List, select Geometry → $area$:
Double-click on it so that it appears in the Expression field.

Click OK.

Now your AREA field is populated with values (you may need to click the column header to refresh the data). Save the edits and click OK.

These areas are in degrees. Later, we will compute them in square meters.

Open the Layer properties dialog’s Style tab.

Change the classification style from Categorized to Graduated.

Change the Column to AREA:

Under Color ramp, choose the option New color ramp... to get this dialog:
Choose Gradient (if it’s not selected already) and click OK. You’ll see this:
You’ll be using this to denote area, with small areas as *Color 1* and large areas as *Color 2*.

- Choose appropriate colors.

In the example, the result looks like this:
• Click OK.
• Choose a suitable name for the new color ramp.
• Click OK after filling in the name.

Now you’ll have something like this:
Leave everything else as-is.

- Click Ok:
4.3.4 💧 Try Yourself: Refine the Classification

- Get rid of the lines between the classes.
- Change the values of Mode and Classes until you get a classification that makes sense.

*Check your results*

4.3.5 🔴 Follow Along: Rule-based Classification

It’s often useful to combine multiple criteria for a classification, but unfortunately normal classification only takes one attribute into account. That’s where rule-based classification comes in handy.

- Open the Layer Properties dialog for the landuse layer.
- Switch to the Style tab.
- Switch the classification style to Rule-based. You’ll get this:
• Click the Add rule button: 
• A new dialog then appears.
• Click the ellipsis ... button next to the Filter text area.
• Using the query builder that appears, enter the criterion "landuse" = ‘residential’ AND "name" != ‘|majorUrbanName|’ , click Ok and choose a pale blue-grey for it and remove the border:
4.3. Lesson: Classification

Expression string builder

Function List

Search

- Operators
- Conditionals
- Math
- Conversions
- Date and Time
- String
- Color
- Geometry
- Record
- Fields and Values

Selected Function Help

Operators Group

This group contains operators e.g. + - *

Operators

Expression

"landuse" = 'residential'

Output preview: 0

OK
• Add a new criterion "landuse" != 'residential' AND AREA >= 0.00005 and choose a mid-green color.

• Add another new criterion "name" = ' |majorUrbanName| ' and assign it a darker grey-blue color in order to indicate the town’s importance in the region.

• Click and drag this criterion to the top of the list.

These filters are exclusive, in that they collectively exclude some areas on the map (i.e. those which are smaller that 0.00005, are not residential and are not ‘Swellendam’). This means that the excluded polygons take the style of the default (no filter) category.

We know that the excluded polygons on our map cannot be residential areas, so give the default category a suitable pale green color.

Your dialog should now look like this:
• Apply this symbology.

Your map will look something like this:
Now you have a map with Swellendam the most prominent residential area and other non-residential areas colored according to their size.

4.3.6 In Conclusion

Symbology allows us to represent the attributes of a layer in an easy-to-read way. It allows us as well as the map reader to understand the significance of features, using any relevant attributes that we choose. Depending on the problems you face, you’ll apply different classification techniques to solve them.

4.3.7 What’s Next?

Now we have a nice-looking map, but how are we going to get it out of QGIS and into a format we can print out, or make into an image or PDF? That’s the topic of the next lesson!
Chapter 5

Module: マップの作成

このモジュールでは、品質のよい地図を作成するため、必要なマップコンポーネントとともに、QGIS のマップコンポーネーターの使い方について学習します。

5.1 Lesson: Using Map Composer

Now that you’ve got a map, you need to be able to print it or to export it to a document. The reason is, a GIS map file is not an image. Rather, it saves the state of the GIS program, with references to all the layers, their labels, colors, etc. So for someone who doesn’t have the data or the same GIS program (such as QGIS), the map file will be useless. Luckily, QGIS can export its map file to a format that anyone’s computer can read, as well as printing out the map if you have a printer connected. Both exporting and printing is handled via the Map Composer.

The goal for this lesson: To use the QGIS Map Composer to create a basic map with all the required settings.

5.1.1 Follow Along: The Composer Manager

QGIS allows you to create multiple maps using the same map file. For this reason, it has a tool called the Composer Manager.

- Click on the Project → Composer Manager menu entry to open this tool. You’ll see a blank Composer manager dialog appear.
- Click the Add button and give the new composer the name of Swellendam.
- Click OK.
- Click the Show button.

(You could also close the dialog and navigate to a composer via the File → Print Composers menus, as in the image below.)
Whichever route you take to get there, you will now see the *Print Composer* window:
5.1.2 ➔ Follow Along: Basic Map Composition

In this example, the composition was already the way we wanted it. Ensure that yours is as well.

- In the Print Composer window, check that the values under Composition → Paper and Quality are set to the following:
  - Size: A4 (210x297mm)
  - Orientation: Landscape
  - Quality: 300dpi

Now you’ve got the page layout the way you wanted it, but this page is still blank. It clearly lacks a map. Let’s fix that!

- Click on the Add New Map button:

With this tool activated, you’ll be able to place a map on the page.

- Click and drag a box on the blank page:

The map will appear on the page.

- Move the map by clicking and dragging it around:
• Resize it by clicking and dragging the boxes in the corners:

-Cola: Your map may look a lot different, of course! This depends on how your own project is set up. But not to worry! These instructions are general, so they will work the same regardless of what the map itself looks like.

• Be sure to leave margins along the edges, and a space along the top for the title.

• Zoom in and out on the page (but not the map!) by using these buttons:

• Zoom and pan the map in the main QGIS window. You can also pan the map using the Move item content.
When zooming in, the map view will not refresh by itself. This is so that it doesn’t waste your time redrawing the map while you’re zooming the page to where you want it, but it also means that if you zoom in or out, the map will be at the wrong resolution and will look ugly or unreadable.

- Force the map to refresh by clicking this button:

Remember that the size and position you’ve given the map doesn’t need to be final. You can always come back and change it later if you’re not satisfied. For now, you need to ensure that you’ve saved your work on this map. Because a Composer in QGIS is part of the main map file, you’ll need to save your main project. Go to the main QGIS window (the one with the Layers list and all the other familiar elements you were working with before), and save your project from there as usual.

5.1.3 Follow Along: Adding a Title

Now your map is looking good on the page, but your readers/users are not being told what’s going on yet. They need some context, which is what you’ll provide for them by adding map elements. First, let’s add a title.

- Click on this button: 
- Click on the page, above the map, and a label will appear at the top of the map.
- Resize it and place it in the top center of the page. It can be resized and moved in the same way that you resized and moved the map.

As you move the title, you’ll notice that guidelines appear to help you position the title in the center of the page. However, there is also a tool to help position the title relative to the map (not the page):

- Click the map to select it.
- Hold in shift on your keyboard and click on the label so that both the map and the label are selected.
- Look for the Align button and click on the dropdown arrow next to it to reveal the positioning options and click Align center.
To make sure that you don’t accidentally move these elements around now that you’ve aligned them:

- Right-click on both the map and the label.

A small lock icon will appear in the corner to tell you that an element can’t be dragged right now. You can always right-click on an element again to unlock it, though.

Now the label is centered to the map, but not the contents. To center the contents of the label:

- Select the label by clicking on it.
- Click on the Item Properties tab in the side panel of the Composer window.
- Change the text of the label to “Swellendam”:
- Use this interface to set the font and alignment options:

  - Choose a large but sensible font (the example will use the default font with a size of 36) and set the Horizontal Alignment to Center.

You can also change the font color, but it’s probably best to keep it black as per the default.

The default setting is not to add a frame to the title’s text box. However, if you wish to add a frame, you can do so:

- In the Item Properties tab, scroll down until you see the Frame option.
- Click the Frame checkbox to enable the frame. You can also change the frame’s color and width.

In this example, we won’t enable the frame, so here is our page so far:
5.1.4 Follow Along: Adding a Legend

The map reader also needs to be able to see what various things on the map actually mean. In some cases, like the place names, this is quite obvious. In other cases, it’s more difficult to guess, like the colors of the farms. Let’s add a new legend.

- Click on this button: 
- Click on the page to place the legend, and move it to where you want it:
5.1.5 Follow Along: Customizing Legend Items

Not everything on the legend is necessary, so let’s remove some unwanted items.

- In the Item Properties tab, you’ll find the Legend items panel.
- Select the buildings entry.
- Delete it from the legend by clicking the minus button:

You can also rename items.

- Select a layer from the same list.
- Click the Edit button:
- Rename the layers to Places, Roads and Streets, Surface Water, and Rivers.
- Set landuse to Hidden, then click the down arrow and edit each category to name them on the legend.

You can also reorder the items:

As the legend will likely be widened by the new layer names, you may wish to move and resize the legend and or map. This is the result:
5.1.6 Follow Along: Exporting Your Map

Did you remember to save your work often?

Finally the map is ready for export! You’ll see the export buttons near the top left corner of the Composer window:

The button on the left is the Print button, which interfaces with a printer. Since the printer options will differ depending on the model of printer that you’re working with, it’s probably better to consult the printer manual or a general guide to printing for more information on this topic.

The other three buttons allow you to export the map page to a file. There are three export formats to choose from:

- Export as Image
- Export as SVG
- Export as PDF

Exporting as an image will give you a selection of various common image formats to choose from. This is probably the simplest option, but the image it creates is “dead” and difficult to edit.

The other two options are more common.

If you’re sending the map to a cartographer (who may want to edit the map for publication), it’s best to export as an SVG. SVG stands for “Scalable Vector Graphic”, and can be imported to programs like Inkscape or other vector image editing software.

If you need to send the map to a client, it’s most common to use a PDF, because it’s easier to set up printing options for a PDF. Some cartographers may prefer PDF as well, if they have a program that allows them to import and edit this format.

For our purposes, we’re going to use PDF:

- Click the Export as PDF button:
• Choose a save location and a file name as usual.
• Click Save.

5.1.7 In Conclusion

• Close the Composer window.
• Save your map.
• Find your exported PDF using your operating system’s file manager.
• Open it.
• Bask in its glory.

Congratulations on your first completed QGIS map project!

5.1.8 What’s Next?

On the next page, you will be given an assignment to complete. This will allow you to practice the techniques you have learned so far.

5.2 Assignment 1

Open your existing map project and revise it thoroughly. If you have noticed small errors or things you’d have liked to fix earlier, do so now.

While customizing your map, keep asking yourself questions. Is this map easy to read and understand for someone who’s unfamiliar with the data? If I saw this map on the Internet, or on a poster, or in a magazine, would it capture my attention? Would I want to read this map if it wasn’t mine?

If you’re doing this course at a Basic or Intermediate level, read up on techniques from the more advanced sections. If you see something you’d like to do in your map, why not try to implement it?

If this course is being presented to you, the course presenter may require you to submit a final version of your map, exported to PDF, for evaluation. If you’re doing this course by yourself, it’s recommended that you evaluate your own map using the same criteria. Your map will be evaluated on the overall appearance and symbology of the map itself, as well as the appearance and layout of the map page and elements. Remember that the emphasis for evaluating the appearance of maps will always be ease of use. The nicer the map is to look at and the easier it is to understand at a glance, the better.

Happy customizing!

5.2.1 In Conclusion

The first four modules have taught you how to create and style a vector map. In the next four modules, you’ll learn how to use QGIS for a complete GIS analysis. This will include creating and editing vector data; analyzing vector data; using and analyzing raster data; and using GIS to solve a problem from start to finish, using both raster and vector data sources.
Chapter 6

Module: ベクタデータの作成

既存のデータを使用してマップを作成することはまだ始まったばかりです。このモジュールでは、既存のベクタデータを変更して、まったく新しいデータセットを作成する方法を学びます。

6.1 Lesson: Creating a New Vector Dataset

The data that you use has to come from somewhere. For most common applications, the data exists already; but the more particular and specialized the project, the less likely it is that the data will already be available. In such cases, you’ll need to create your own new data.

The goal for this lesson: To create a new vector dataset.

6.1.1 Follow Along: The Layer Creation Dialog

Before you can add new vector data, you need a vector dataset to add it to. In our case, you’ll begin by creating new data entirely, rather than editing an existing dataset. Therefore, you’ll need to define your own new dataset first.

You’ll need to open the New Vector Layer dialog that will allow you to define a new layer.

• Navigate to and click on the menu entry Layer → New → New Shapefile Layer.

You’ll be presented with the following dialog:
It’s important to decide which kind of dataset you want at this stage. Each different vector layer type is “built differently” in the background, so once you’ve created the layer, you can’t change its type.

For the next exercise, we’re going to be creating new features which describe areas. For such features, you’ll need to create a polygon dataset.

• Click on the Polygon radio button:
This has no impact on the rest of the dialog, but it will cause the correct type of geometry to be used when the vector dataset is created.

The next field allows you to specify the Coordinate Reference System, or CRS. A CRS specifies how to describe a point on Earth in terms of coordinates, and because there are many different ways to do this, there are many different CRSs. The CRS of this project is WGS84, so it’s already correct by default:

Next there is a collection of fields grouped under New attribute. By default, a new layer has only one attribute, the id field (which you should see in the Attributes list) below. However, in order for the data you create to be useful, you actually need to say something about the features you’ll be creating in this new layer. For our current purposes, it will be enough to add one field called name.

- Replicate the setup below, then click the Add to attributes list button:

- Check that your dialog now looks like this:
• Click **OK**. A save dialog will appear.

• Navigate to the `exercise_data` directory.

• Save your new layer as `school_property.shp`.

The new layer should appear in your **Layers list**.
6.1.2 Follow Along: Data Sources

When you create new data, it obviously has to be about objects that really exist on the ground. Therefore, you’ll need to get your information from somewhere.

There are many different ways to obtain data about objects. For example, you could use a GPS to capture points in the real world, then import the data into QGIS afterwards. Or you could survey points using a theodolite, and enter the coordinates manually to create new features. Or you could use the digitizing process to trace objects from remote sensing data, such as satellite imagery or aerial photography.

For our example, you’ll be using the digitizing approach. Sample raster datasets are provided, so you’ll need to import them as necessary.

- Click on the Add Raster Layer button.
- Navigate to exercise_data/raster/.
- Select the file 3420C_2010_327_RGB_LATLNG.tif.
- Click Open. An image will load into your map.
- Find the new image in the Layers list.
- Click and drag it to the bottom of the list so that you can still see your other layers.
- Find and zoom to this area:

---

日本語：If your buildings layer symbology is covering part or all of the raster layer, you can temporarily disable the layer by deselecting it in the Layers panel. You may also wish to hide the roads symbology if you find it distracting.

You’ll be digitizing these three fields:
In order to begin digitizing, you’ll need to enter **edit mode**. GIS software commonly requires this to prevent you from accidentally editing or deleting important data. Edit mode is switched on or off individually for each layer.

To enter edit mode for the *school_property* layer:

- Click on the layer in the **Layer list** to select it. (Make very sure that the correct layer is selected, otherwise you’ll edit the wrong layer!)

- Click on the **Toggle Editing** button: 🌋

If you can’t find this button, check that the **Digitizing** toolbar is enabled. There should be a check mark next to the **View → Toolbars → Digitizing** menu entry.

As soon as you are in edit mode, you’ll see the digitizing tools are now active:

![Digitizing tools](image)

Four other relevant buttons are still inactive, but will become active when we start interacting with our new data:

![Other tools](image)

From left to right on the toolbar, they are:

- **Save Edits**: saves changes made to the layer.
- **Add Feature**: start digitizing a new feature.
• Move Feature(s): move an entire feature around.
• Node Tool: move only one part of a feature.
• Delete Selected: delete the selected feature.
• Cut Features: cut the selected feature.
• Copy Features: copy the selected feature.
• Paste Features: paste a cut or copied feature back into the map.

You want to add a new feature.

• Click on the Add Feature button now to begin digitizing our school fields.

You’ll notice that your mouse cursor has become a crosshair. This allows you to more accurately place the points you’ll be digitizing. Remember that even as you’re using the digitizing tool, you can zoom in and out on your map by rolling the mouse wheel, and you can pan around by holding down the mouse wheel and dragging around in the map.

The first feature you’ll be digitizing is the athletics field:

• Start digitizing by clicking on a point somewhere along the edge of the field.
• Place more points by clicking further along the edge, until the shape you’re drawing completely covers the field.
• After placing your last point, right-click to finish drawing the polygon. This will finalize the feature and show you the Attributes dialog.
• Fill in the values as below:
• Click OK and you’ve created a new feature!

Remember, if you’ve made a mistake while digitizing a feature, you can always edit it after you’re done creating it. If you’ve made a mistake, continue digitizing until you’re done creating the feature as above. Then:

• Select the feature with the Select Single Feature tool:

You can use:

• the Move Feature(s) tool to move the entire feature,

• the Node Tool to move only one point where you may have miss-clicked,

• Delete Selected to get rid of the feature entirely so you can try again, and
• the Edit → Undo menu item or the ctrl + z keyboard shortcut to undo mistakes.

6.1.3 Try Yourself

• Digitize the school itself and the upper field. Use this image to assist you:

Remember that each new feature needs to have a unique id value!

Note: When you’re done adding features to a layer, remember to save your edits and then exit edit mode.

Note: You can style the fill, outline and label placement and formatting of the school_property using techniques learnt in earlier lessons. In our example, we will use a dashed outline of light purple color with no fill.

6.1.4 Try Yourself

• Create a new line feature called routes.shp with attributes id and type. (Use the approach above to guide you.)
• We’re going to digitize two routes which are not already marked on the roads layer; one is a path, the other is a track.

Our path runs along the southern edge of the suburb of Railton, starting and ending at marked roads:

Our track is a little further to the south:

One at a time, digitize the path and the track on the routes layer. Try to follow the routes as accurately as possible, using points (left-click) at any corners or turns.

When creating each route, give them the type attribute value of path or track.
You’ll probably find that only the points are marked; use the Layer Properties dialog to add styling to your routes. Feel free to give different styles to the path and track.

Save your edits and toggle Edit mode.

Check your results

6.1.5 In Conclusion

Now you know how to create features! This course doesn’t cover adding point features, because that’s not really necessary once you’ve worked with more complicated features (lines and polygons). It works exactly the same, except that you only click once where you want the point to be, give it attributes as usual, and then the feature is created.

Knowing how to digitize is important because it’s a very common activity in GIS programs.

6.1.6 What’s Next?

Features in a GIS layer aren’t just pictures, but objects in space. For example, adjacent polygons know where they are in relation to one another. This is called topology. In the next lesson you’ll see an example of why this can be useful.

6.2 Lesson: 地物のトポロジー

オーバーラップやギャップなどのエラーを最小限に抑えるためトポロジはベクタデータレイヤの有用な側面です。

たとえば、2つの地物が境界線を共有し、あなたがトポロジを使用して境界線を編集する場合、はじめの地物を編集し、そしてもう1つの地物を編集して、それらが合うように慎重に境界線を描く必要はありません。あなたはそれらの共有された境界線を編集することができ、両方の地物は同時に変化します。

このレッスンの目標：例を用いてトポロジーを理解します。

6.2.1 Follow Along: スナップ

トポロジ編集を簡単に行うにはスナップを有効にするのがベストです。これによってデジタイズ中にマウスカーソルが他のオブジェクトにスナップします。スナップオプションを設定するには:

- メニューパントリ 設定 → スナップオプション… に移動します。
- 次のように スナップオプション ダイアログを設定します:
QGIS Training Manual, リリース 2.2

- 交差禁止列のボックスがチェックされていることを確認します。
- OKをクリックして変更を保存し、ダイアログボックスを離れます。
- landuseレイヤを選択して編集モードにします。
- ピュー →ツールバーで先進的なデジタイズツールバーが有効になっていることを確認します。
- このエリアにズームします（必要に応じてレイヤとラベルを有効にします）。

- Bontebok National Partのこの新しい（架空の）エリアをデジタイズします。
6.2.2  💧 Follow Along: トポロジカル地物の修正

トポロジ地物は時々更新しなければならないことがあります。この例では、landuse レイヤは最近 1 つのエリアに結合された複雑な森林エリアをいくつか含みます：
新しいポリゴンを作って森林エリアを結合するのではなく、ノードツールを使って既存のポリゴンを編集し、それらを結合しましょう。

- まだアクティブになっていないなら編集モードにします。
- ノードツールを選択します。
- 森林の1つのエリアを選んで、2つの森林区域が触れ合うように頂点を選択し隣接する頂点へ移動させます:

- 所定の位置にスナップされるまでノードをドラッグします。
6.2. Lesson: 地物のトポロジ

トポロジとして正しい境界線はこのようになります:

ノードツールを使ってさらにいくつかのエリアを結合させます。適切な場合には地物の追加ツールを使用できます。私たちの例のデータを使っているならば、森林エリアはこのように見えます：
あなたが結合した森林エリアがよしのくても、より少なくても、違うエリアであったとしても気にしないで下さい。

6.2.3 Follow Along: ツール: 地物の簡素化

これは地物の簡素化ツールです:

- それをクリックしてアクティブにします。
- ノードツールまたは地物の追加ツールを使用して結合したエリアの1つをクリックします。このダイアログボックスが表示されます:

  ![Simplify line tolerance dialog](image)

  - スライダーを左右に動かして何が起こるか見て下さい:
これで複雑な地物のノードの量を減らすことができます。

- Okをクリックします

このツールがトポロジー何をするかに注目して下さい。簡素化されたポリゴンは、もはや隣接するポリゴンには触れていません。このツールは独立した地物の一般化に関していることがわかります。その利点は、それが一般化するためのシンプルで直感的なインターフェイスを提供することです。

次へ進む前に、最後の変更を元に戻すことでポリゴンを元の状態に戻します。

### 6.2.4 Try Yourself ソール：リングの追加

これはリングの追加ツールです:

このツールを試してみると現在のスナップオプションによりポリゴンの真ん中にリングを作成できないことがわかります。もしあなたが除こうとするエリアがポリゴンの境界線につながっている場合にはよいでしょう。

- 以前に使用したダイアログで土地利用レイヤのスナップを無効にします。
- Now try using the Add Ring tool tool to create a gap in the middle of the Bontebok National Part.
・リングの削除ツールを使用して新しい地物を削除します:

ノート：リングを削除するにはその隅を選択する必要があります。

結果をチェックする

6.2.5 Try Yourself ツール：部分の追加

これは部分の追加ツールです:

これを使うとメインの地物に直接つながっていない余分な部分を作成することができます。たとえば、南アフリカ共和国の本土の境界線をデジタイズしたが、プリンス・エドワード諸島をまだ追加していない場合は、このツールを使用して作成します。

・このツールを使用するには、まず 1 個の地物を選択するツールを使用して、部分を追加したいポリゴンを選択する必要があります:

・部分の追加ツールを使って Bontebok National Part に外部のエリアを追加してみます。
・部分の削除ツールを使って新しい地物を削除します:

ノート：それを削除するには部分の頂点を選択する必要があります。

結果をチェックする

6.2.6 Follow Along: ツール: 地物の変形

これは地物の変形ツールです:

これを使うと既存の地物にこぶを追加できます。このツールを選択して:

・Bontebok National Part の内部を左クリックしてポリゴンの描画を開始します。
・3 つの点を追加します。最後は元のポリゴンの内側に戻り、1 辺が開いた長方形を描きます。
・右クリックしてポイントのマーキングを終了します:
これは次のような結果をもたらします:

逆の操作を行こともできます:
・ ポリゴンの外側をクリックします。
・ ポリゴンに長方形を描画します。
・ ポリゴンの外側を再度右クリックします:
以上の結果:

6.2.7 Try Yourself ソール: 地物の分割

地物の分割 ソールは 2 つの部分の一方を削除しない点を除いて農場の一部を取り除いた方法と似ています。このツールではそれらの両方を保持します。
まず *landuse* レイヤのスナップを再度有効にします。
ツールを使って Bontebok National Part からコーナーを分割します。

- 地物の分離 ツールを選択し、線の描画を開始する点をクリックします。分割するコーナーの反対側の点をクリックし、右クリックして線を完成させます。

この時点では何も起こっていないように見えるかもしれません。しかし *landuse* レイヤのシンボロジにはボーダーがないことを思い出してください。したがって新しい区分線は表示されません。

- 1 個の地物を選択する を使用して今しがた分割したコーナーを選択します。新しい地物がハイライト表示されます。
6.2.8 Try Yourself ソール: 地物の結合

作成した地物を元のポリゴンに結合します:

・ 選択地物の結合 と 選択地物の属性結合 ソールを試します。
・ 相違点に注目してください。

結果をチェックする

6.2.9 In Conclusion

トポロジ編集はトポロジの観点からの正しさを維持しながら迅速かつ容易にオブジェクトの作成や変更ができる強力なツールです。

6.2.10 What's Next?

オブジェクトの形状を簡単にデジタイズする方法がわかりましたが、属性を追加することにはまだ少し不安があります! 次は属性の編集がより簡単でより効果的であるようにフォームの使い方を学びます。

6.3 Lesson: フォーム

デジタイズで新しいデータを追加する場合、その地物の属性を入力するダイアログが表示されます。ただし、このダイアログボックスは既定ではあまり見当たがよくありません。これは特に大規模なデータセッ トを作成する場合や他の人にデジタイズを手伝って貰うときに既定のフォームではわかりにくい場合に、ユーザビリティ上の問題を引き起こす可能性があります。

幸いにも、QGIS ではレヤに独自のカスタムダイアログを作成することができます。このレッスンではその方法について説明します。
このレッスンの目標：レイヤのフォームを作成します。

6.3.1 Follow Along: QGIS のフォームデザイン機能の使用

• レイヤリストで roads レイヤを選択します。
• 前のように編集モードにします。
• 属性テーブルを開きます。
• テーブル内の任意のセルを右クリックします。フォームのオープンエントリのある短いメニューが表示されます。
• それをクリックすると QGIS がこのレイヤのために生成したフォームが表示されます。

明らかに、毎回属性テーブルで特定の街路を検索するのではなく、地図を見ながらこれを行うことができるといいですね。
• 設定 → オプションに移動します。
• 表示されるダイアログでマップツールタブを選択します。
• 単一の地物が確認された場合地物フォームを開くチェックボックスをチェックします:

![フォームデザイン機能の使用](image.png)

• Ok をクリックします。
• レイヤリストで roads レイヤを選択します。
• 地物情報表示ツールを使って地図上の任意の街路をクリックします。

通常の地物情報ダイアログの代わりに、今ではおなじみのフォームが表示されます:

6.3. Lesson: フォーム
6.3.2 Try Yourself フォームを使った値の編集

編集モードの場合は、このフォームを使用して地物の属性を編集することができます。

- 編集モードをアクティブにします（まだアクティブになっていない場合）。
- 地物情報表示ツールを使用して Swellendam を通り抜けるメインストリートをクリックします：
・highwayの値を変更してsecondaryにします。
・編集内容を保存します。
・編集モードを終了します。
・属性テーブルを開いて、属性テーブルの値が更新されていること、すなわちソースデータが更新されていることに注意して下さい。

ノート：デフォルトのデータセットを使用している場合は、地図にはVoortrek Streetと呼ばれる道が複数あることがわかります。

6.3.3  Follow Along: フォームのフィールドタイプの設定

フォームを使用して編集するのはよいのですが、まだ何もかも手で入力しなければいけません。幸いにも、フォームには様々な方法でデータの編集ができる様々な種類の、いわゆるウィジェットを持ちます。
・roadsレイヤのレイヤプロパティを開きます。
・フィールドタブに切り替えます。次が表示されます:

6.3. Lesson: フォーム 125
• *man_made* と同じ行の 行編集 ボタンをクリックしてダイアログを開きます。
• オプションのリストから チェックボックス を選択します。
QGIS Training Manual, リリース 2.2

6.3.4 🔄 Try Yourself

highway フィールドに、より適切なフォームウィジェットを設定します。
結果をチェックする

6.3.5 🔄 Try Yourself テストデータの作成

まったくのゼロから独自のカスタムフォームを設計することもできます。
- test-data という名前で 2 つの属性を持つ単純なポイントレイヤを作成します:
  - 名前 (テキスト)
  - 年齢 (テキスト)
・デジタイズツールを使用して新しいレイヤ上にいくつかのポイントを追加してテスト用データを作成します。新しいポイントをキャプチャするたびに QGIS の既定の属性フォームが表示されます。

ノート：以前の作業の時からスナップを有効にしたままの場合、スナップを無効にする必要があります。
6.3.6 Follow Along: 新しいフォームの作成

では、属性データのキャプチャ段階のための独自のカスタムフォームを作成したいと思います。これには Qt4 Designer がインストールされている必要があります（フォームを作成する人だけに必要です）。Windows を使用している場合はコース教材の一部として提供されているはずです。他の OS を使用している場合はそれ求める必要があります。Ubuntu ではターミナルで次の操作を行います:

ノート: 執筆時点では Qt5 は利用可能な最新バージョンです。しかし、このプロセスは具体的に Qt4 を必要とし、必ずしも Qt5 と互換性がありません。

```
sudo apt-get install qt4-designer
```
...
とすれば自動的にインストールされるはずです。そうでなければ ソフトウェアセンター で探します。

- Windows の スタートメニュー を開き (またはお使いの OS に適切なアプローチで)、デザイナ を開始します。
- 表示されるダイアログで新しいダイアログボックスを作成します:
• 画面の左側（デフォルト）にあるウィジェットボックスでLine Editアイテムを探します。
• このアイテムをクリックしてフォームにドラッグします。フォーム上に新しいLine Editが作成されます。
• Line Edit要素を選択すると、そのプロパティが画面の片側に沿って表示されます（デフォルトで右側）：
### 6.3. Lesson: \( \Leftrightarrow \) 131

#### Property Editor

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>QObject</strong></td>
<td></td>
</tr>
<tr>
<td><strong>objectName</strong></td>
<td>lineEdit</td>
</tr>
<tr>
<td><strong>QWidget</strong></td>
<td></td>
</tr>
<tr>
<td>enabled</td>
<td>check</td>
</tr>
<tr>
<td><strong>geometry</strong></td>
<td>[(80, 40), 113 x 21]</td>
</tr>
<tr>
<td>sizePolicy</td>
<td>[Expanding, Fixed, 0, 0]</td>
</tr>
<tr>
<td>minimumSize</td>
<td>0 x 0</td>
</tr>
<tr>
<td>maximumSize</td>
<td>16777215 x 16777215</td>
</tr>
<tr>
<td>sizeIncrement</td>
<td>0 x 0</td>
</tr>
<tr>
<td>baseSize</td>
<td>0 x 0</td>
</tr>
<tr>
<td>palette</td>
<td>Inherited</td>
</tr>
<tr>
<td><strong>font</strong></td>
<td>A [.Lucida Grande UI, 13]</td>
</tr>
<tr>
<td>cursor</td>
<td>IBeam</td>
</tr>
<tr>
<td>mouseTracking</td>
<td>check</td>
</tr>
<tr>
<td>focusPolicy</td>
<td>StrongFocus</td>
</tr>
<tr>
<td>contextMenuPolicy</td>
<td>DefaultContextMenu</td>
</tr>
<tr>
<td>acceptDrops</td>
<td>check</td>
</tr>
<tr>
<td><strong>toolTip</strong></td>
<td></td>
</tr>
<tr>
<td><strong>statusTip</strong></td>
<td></td>
</tr>
<tr>
<td>whatsThis</td>
<td></td>
</tr>
<tr>
<td><strong>accessibleName</strong></td>
<td></td>
</tr>
<tr>
<td><strong>accessibleDescription</strong></td>
<td></td>
</tr>
<tr>
<td>layoutDirection</td>
<td>LeftToRight</td>
</tr>
<tr>
<td><strong>autoFillBackgroundColor</strong></td>
<td></td>
</tr>
<tr>
<td><strong>locale</strong></td>
<td>English, SouthAfrica</td>
</tr>
<tr>
<td>inputMethodHints</td>
<td>ImhNone</td>
</tr>
</tbody>
</table>

#### QLineEdit

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>inputMask</strong></td>
<td></td>
</tr>
<tr>
<td><strong>text</strong></td>
<td></td>
</tr>
<tr>
<td>maxLength</td>
<td>32767</td>
</tr>
<tr>
<td>frame</td>
<td>check</td>
</tr>
<tr>
<td>echoMode</td>
<td>Normal</td>
</tr>
<tr>
<td>cursorPosition</td>
<td>0</td>
</tr>
<tr>
<td><strong>alignment</strong></td>
<td>AlignLeft, AlignVCenter</td>
</tr>
<tr>
<td>dragEnabled</td>
<td></td>
</tr>
<tr>
<td>readOnly</td>
<td></td>
</tr>
<tr>
<td><strong>placeholderText</strong></td>
<td></td>
</tr>
<tr>
<td><strong>LogicalMoveStyle</strong></td>
<td></td>
</tr>
</tbody>
</table>
名前を Name に設定します。
同様にして新しい Spin Box を作成し、名前を Age に設定します。
新しい人の追加 というテキストで Label を追加します。フォントは太字にします (設定項目はオブジェクトプロパティで見つける)。あるいは (ラベルを追加する代わりに) ダイアログ自体のタイトルを設定することもできます。
ダイアログの任意の場所をクリックします。
垂直に並べる ボタンを見つけます (デフォルトでは画面の上端に沿うツールバーにあります)。これはダイアログを自動的にレイアウトします。
プロパティでダイアログの最大サイズを 200 (width) x 100 (height) に設定します。
exercise_data/forms/add_people.ui として新しいフォームを保存します。
保存が完了したら Qt デザイナプログラムを開じます。

6.3.7 Follow Along: レイヤをフォームに関連付ける

QGISに戻ります。
凡例で test-data レイヤをダブルクリックしてプロパティにアクセスします。
レイヤプロパティダイアログのフィールドタブをクリックします。
属性エディタレイアウトドロップダウンボックスで ui-ファイルを提供するを選択します。
省略記号ボタンをクリックして、作成した add_people.ui を選択します。
• レイヤプロパティ ダイアログの OK をクリックします。
• 編集モードに切り替えて、新しいポイントを追加します。
• そうするとカスタムダイアログが表示されます (QGIS が通常作成するものの代わりに)。
• 地物情報表示ツールを使ってポイントの 1 つをクリックした場合、地物情報ウィンドウで右クリックしてコンテキストメニューから地物フォームを見るを選択するとフォームを起動することができます。
• このレイヤが編集モードの場合はコンテキストメニューには代わりに 地物編集フォーム が表示されます。キャプチャ後でもフォームで属性の調整ができます。

6.3.8 In Conclusion
フォームを使用すればデータの編集や作成がもっと楽になります。ウィジェットの種類を編集するか全くのゼロから新しいフォームを作成することで、新しいデータをデジタイズをする人のエクスペリエンスをコントロールできます。それによって誤解や不必要的エラーを最小限に抑えることができます。
6.3.9 Further Reading

もし上の高度なセクションを完了して、Pythonの知識がある場合にはこのプログラエントリをチェックしてみて下さい。Pythonロジックを用いたカスタム地物フォームの作成についての記事で、データ検証や自動補完などの高度な機能を可能にしています。

6.3.10 What's Next?

地物フォームを開くことはQGISができる標準的な操作の1つです。一方であなたが定義したカスタムアクションを実行させることもできます。これは次のレッスンのテーマです。

6.4 Lesson: アクション

前のレッスンでは既定のアクションを見てきました。今度はあなたの独自のアクションを定義します。アクションは地物をクリックしたときに起きるものですが、それは地図に多くの特別な機能を追加できます。たとえば、オブジェクトに関する追加情報を取得することができます。アクションを割り当てることで地図に全く新しい次元を追加できます！

このレッスンの目標：カスタムアクションを追加する方法を学びます。

6.4.1 🟢 Follow Along: 画像を開く

以前作成したschool_propertyレイヤを使用します。コース資料にはあなたがデジタイズした3つの地所のそれぞれの写真が含まれます。私たちが次にやろうとしていることはそれぞれの地所とその画像に関してすることです。それでは、地所をクリックした時にその画像を開くアクションを作成しましょう。

6.4.2 🟢 Follow Along: 画像のためのフィールドの追加

school_propertyレイヤにはまだ画像と地所を関連付ける方法がありません。まずこの目的のためのフィールドを作成します。

・レイヤプロパティダイアログを開きます。
・フィールドタブをクリックします。
・編集モードに切り替えます:
新しい列を追加します:
下記の値を入力します:
フィールドを作成した後、新しいフィールドの横にある行編集ボタンをクリックします。
そこでファイル名を設定します。
・レイヤプロパティダイアログのOKをクリックします。
・地物情報表示ツールを使用してschool_propertyレイヤの3つの地物のいずれかをクリックします。
編集モードのままなので、ダイアログがアクティブになり、このようになるはずです:
6.4.3 Follow Along: アクションの作成

- `school_property` レイヤのアクションフォームを開きます。
- アクションプロパティパネルで 名称 フィールドに 画像表示 と入力します:
次に何をすべきかはオペレーティングシステムによって異なりますので、次で適切なコマンドを選択して下さい:

Windows

・タイプ ドロップダウンリストをクリックし、開くを選択します。

Ubuntu Linux

・Gnome Image Viewer を使用する場合は Action に eog と入力します。ImageMagick を使用する場合は display と入力します。コマンドの後に空白を 1 つ入れることを覚えておいて下さい！

MacOS

・タイプ ドロップダウンリストをクリックし、Mac を選択します。

・Under Action, write :kbd:`open` 1. Remember to put a space after the command!
コマンドの入力の続き

あなたは画像を聞きたい。そして QGIS は画像の場所を知っている。あとはアクションに画像がどこにあるかを知らせるだけです。

- リストから image を選択します:

![image list](image.png)

- フィールドを挿入 ボタンをクリックします。QGIS はアクションフィールドに ["image"] の句を追加します。
- アクションリストへの追加 ボタンをクリックします。
- レイヤプロパティ ダイアログの OK をクリックします。

さて新しいアクションをテストしましょう:

- レイヤリストで school_property レイヤをクリックしてハイライトさせます。
- 地物アクションの実行 ボタンを見つけます(属性テーブルを開く ボタンと同じツールバーにあります):

![tool: toolbar](tool.png)

- このボタンの右にある下向き矢印をクリックします。これまでのところ、このレイヤにはあなたが今定義した 1 つのアクションだけがあります。
- ボタン自体をクリックしてツールをアクティブにします。
- このツールを使用して、3 つの地所のいずれかをクリックします。
- その地所の画像が表示されます。

### 6.4.4 Follow Along: インターネットの検索

私たちは地図を見ていて農場がある地域についてもっと知りたくなったとしましょう。その地域について何も知らず、それについての一般的な情報を見つけたいとします。あなたが今コンピュータを使用しているならば、あなたの最初の衝動はおそらく地名を Google で検索することでしょう。では、QGIS にそれを自動的にさせてみましょう!

- landuse レイヤの属性テーブルを開きます。
- name フィールドを使ってそれぞれの土地利用地域を Google で検索するようにします。

![tool: toolbar](tool.png)

- 属性テーブルを開じます。
- レイヤプロパティのアクションに戻ります。
- アクションプロパティ → 名称フィールドに Google 検索と入力します。

次に何をすべきかはオペレーティングシステムによって異なりますので、次で適切なコースを選択して下さい:

6.4. Lesson: アクション 141
Windows

・タイプで開くを選択します。これは Windows に Internet Explorer 等の既定のブラウザーでインターネットアドレスを開かせます。

Ubuntu Linux

・アクションにxdg-openと入力します。これは Ubuntu に Chrome や Firefox 等の既定のブラウザーでインターネットアドレスを開かせます。

MacOS

・アクションにopenと入力します。これは MacOS に Safari 等の既定のブラウザーでインターネットアドレスを開かせます。

コマンドの入力の続き

上でどのコマンドを使った場合でも次に、開くべきインターネットアドレスを知らせなければいけません。Google を訪問させて語句を自動的に検索させます。

通常 Google を使用するときは Google の検索バーに検索語句を入力します。しかしこの場合はコンピュータにこれをさせます。Google で何か検索をするには (検索バーを直接使わない場合)、インターネットブラウザにアドレス http://www.google.com/search?q=SEARCH_PHRASE を与えます。ここで SEARCH_PHRASE はあなたが検索したい何かです。私たちはまだ検索する語句を知らないのではじめの部分 (検索語句はない) だけ入力します。

・アクションフィールドに http://www.google.com/search?q= と入力します。コマンドが入力されている場合はコマンドの後にスペースを追加してください!

QGIS でクリックされた地物の name の値をブラウザで Google 検索するようにしましょう。

・名称フィールドを選択します。
　・フィールドを挿入 をクリックします:
これは QGIS に次の句を追加させます:

```
Type Mac
Name Google Search
Action open http://www.google.com/search?q=[% "name" %]
```

これが意味することは QGIS がブラウザを開き、それにアドレス http://www.google.com/search?q=[% "name" %] を送ることです。しかし、 [% "name" %] は QGIS に検索語句として name フィールドの内容を使わせます。

6.4.5 Follow Along: QGIS で直接 Web ページを開く

これまで外部のブラウザで Web ページを開く方法を見ました。このアプローチには不可欠な依存関係を追加するという点で若干の欠点があります。エンドユーザが自分のシステムでアクションを実行するのに必要なソフトウェアを持っているでしょうか？これまで見てきたように、どの OS を使っているかがらなければ同じようなアクションのための同じような基本コマンドが見当たるはずです。OS のバージョンによってはブラウザを開く上記コマンドがうまく動作しないかもしれません。これは克服できない問題である可能性があります。

しかし、QGIS は信じられないほど強力で汎用性の高いQt4ライブラリの上にあります。さらにQGISのアクションには任意でトーケン化された（すなわち、フィールドの属性の内容にもとづいた変数情報を使用する）Python コマンドが使えます！

ではPythonアクションを使用してWebページを表示する方法を説明します。それは外部のブラウザでサイトを開くと大体同じ考え方ですが、Qt4のQWebView クラス (webkit ベースの HTML ワイジェット）を使用してポップアップウィンドウでコンテンツを表示するのでユーザのシステムにはブラウザは何が必要ありません。

今回は Google の代わりに Wikipedia を使ってみましょう。そうするとリクエストの URL は次のようになります:

http://wikipedia.org/wiki/SEARCH_PHRASE

レイヤアクションを作成するには:

- レイヤプロパティ ダイアログを開いてアクションタブへ向かいます。
- Set up a new action using the following properties for the action: * Type: Python * Name: Wikipedia * Action (all on one line):

```python
from PyQt4.QtCore import QUrl; from PyQt4.QtWebKit import QWebView; myWV = QWebView(None); myWV.load(QUrl('http://wikipedia.org/wiki/%{
"name" %}')); myWV.show()
```
ここでは:

- すべての Python のコードはコマンドがセミコロンで区切られて 1 行になっています（通常 Python のコマンドは改行で区切ります）。
- [% "name" %] はアクションが呼び出される時に実際の属性値と置き換えられます（これまでのように）。
- コードは単に新しい QWebView インスタンスを作成し、その URL を設定し、ユーザーのデスクトップ上のウィンドウとして表示させる `show()` を呼び出します。

これはいくらぶん不自然な例であることご注意ください。Python では意味的に重要なインデントが使われますので、セミコロンで区切ることは記述の最良の方法ではありません。ですから現実の世界では、Python モジュールからロジックをインポートして、引数にフィールド属性をとる関数を呼び出す可能性が高いと思います。

同様にしてユーザのシステムに特定のイメージビューアがあなたを要求せずに画像を表示するアプローチを使用できるでしょう。

- 今しごた作成した Wikipedia アクションを使用して Wikipedia のページを読み込む上記の方法を試して下さい。
6.4.6 In Conclusion

アクションを使えば地図に特別な機能を与えることができます。それはQGISで同じ地図を見るエンドユーザに役立ちます。Pythonだけでなく任意のオペレーティングシステムのシェルコマンドも使用することができます。あなたが具体化できる機能に関して不可能はありません！

6.4.7 What’s Next?

あなたはあらゆる種類のベクタデータ作成を行いました。問題を解決するためにこのデータを分析する方法を学びます。それは次のモジュールのトピックです。
Chapter 7

Module: ベクタ分析

今、あなたはいくつかの地物を編集したので、次はそれらを使って他に何ができるかを汁必要があります。属性を持つ特徴を持つことはいいですが、すべてが実行されたとき、実際には標準的な GIS でないマップができないことがわかりません。

GIS の主な利点は以下です：*GIS は質問に答えることができます*。

次の 3 つのモジュールでは、GIS の機能を使って研究課題に答えるよう努めます。例えばあなたが不動産業者であり、Swellendam において次の基準を持っているクライアントのために住宅を探しています：

1. Swellendam である必要がある。
2. 学校前の距離が、合理的にアクセスできる距離（例えば 1km）である必要がある。
3. サイズが 100m 四方以上である必要がある。
4. 主要道路から 50m より近い。
5. レストランから 500m 以内にある。

次のいくつかのモジュールの中で、我々はこの新しい住宅開発に適したファームのプロパティを見つけるために、GIS 解析ツールの力を利用します。

7.1 Lesson: データの再投影と変形

座標参照系（CRSs）について再度話しましょう。前にも触れましたが、それは実際に何を意味するのか議論していませんでした。

このレッスンの目標: ベクタデータセットの再投影と変形をする。

7.1.1 Follow Along: 投影法

マップ自身だけでなくすべてのデータの CRS は WGS84 と呼ばれてています。これはデータを表現するのに一般的な空間参照系（GCS）です。しかし、我々が見るように、問題があります。

- 現在のマップを保存します。
- exercise_data/world/world.qgs で確認できる世界地図を開きます。
- Zoom in to South Africa by using the Zoom In tool.
- Try setting a scale in the Scale field, which is in the Status Bar along the bottom of the screen. While over South Africa, set this value to 1:5000000 (one to five million).
- スケールフィールドに着目してままマップ周辺をパンニングします。
Notice the scale changing? That’s because you’re moving away from the one point that you zoomed into at 1:5000000, which was at the center of your screen. All around that point, the scale is different.

To understand why, think about a globe of the Earth. It has lines running along it from North to South. These longitude lines are far apart at the equator, but they meet at the poles.

In a GCS, you’re working on this sphere, but your screen is flat. When you try to represent the sphere on a flat surface, distortion occurs, similar to what would happen if you cut open a tennis ball and tried to flatten it out. What this means on a map is that the longitude lines stay equally far apart from each other, even at the poles (where they are supposed to meet). This means that, as you travel away from the equator on your map, the scale of the objects that you see gets larger and larger. What this means for us, practically, is that there is no constant scale on our map!

To solve this, let’s use a Projected Coordinate System (PCS) instead. A PCS “projects” or converts the data in a way that makes allowance for the scale change and corrects it. Therefore, to keep the scale constant, we should reproject our data to use a PCS.

7.1.2 Follow Along: “オンザフライ”再投影

QGIS allows you to reproject data “on the fly”. What this means is that even if the data itself is in another CRS, QGIS can project it as if it were in a CRS of your choice.

- To enable “on the fly” projection, click on the CRS Status button in the Status Bar along the bottom of the QGIS window:

- In the dialog that appears, check the box next to Enable ‘on the fly’ CRS transformation.

- Type the word global into the Filter field. One CRS (NSIDC EASE-Grid Global) should appear in the list below.

- **NSIDC EASE-Grid Global**をクリックしてそれを選択します。それからOKをクリックします。

- 南アフリカの形状が変化するのに注意してください。すべて投影法の変更によって地球の見た目としでの形状が変わります。

- 前のように、再度1:5000000のスケールにズームします。

- マップをパンニングします。

- スケールは同じであることにお気をつけします！

“オンザフライ”再投影は異なる CRS のデータセットを組み合わせて使う際にも用いられます。

- “オンザフライ”再投影を再び無効にする:
  - CRSステータスボタンを再度クリックします。
  - ‘オンザフライ’ CRS 変換を有効にするのチェックを解除します。
  - Clicking OK.

- In QGIS 2.0, the ‘on the fly’ reprojection is automatically activated when layers with different CRSs are loaded in the map. To understand what ‘on the fly’ reprojection does, deactivate this automatic setting:

  - Go to Settings → Options...
  - On the left panel of the dialog, select CRS.
  - Un-check :guilabel:`Automatically enable ‘on the fly’ reprojection if layers have different CRS`. * Click OK.
• Add another vector layer to your map which has the data for South Africa only. You’ll find it as `exercise_data/world/RSA.shp`.

何に気づくのですか?
レイヤは表示されません！しかし、修正するのは簡単ですね？

• Right-click on the RSA layer in the Layers list.

• レイヤの領域にズームを選択します。

そう、今は南アフリカが見えます … しかし世界の残りはどこですか？

It turns out that we can zoom between these two layers, but we can’t ever see them at the same time. That’s because their Coordinate Reference Systems are so different. The continents dataset is in degrees, but the RSA dataset is in meters. So, let’s say that a given point in Cape Town in the RSA dataset is about 4 100 000 meters away from the equator. But in the continents dataset, that same point is about 33.9 degrees away from the equator.

This is the same distance - but QGIS doesn’t know that. You haven’t told it to reproject the data. So as far as it’s concerned, the version of South Africa that we see in the RSA dataset has Cape Town at the correct distance of 4 100 000 meters from the equator. But in the continents dataset, Cape Town is only 33.9 meters away from the equator! You can see why this is a problem.

QGIS doesn’t know where Cape Town is supposed to be - that’s what the data should be telling it. If the data tells QGIS that Cape Town is 34 meters away from the equator and that South Africa is only about 12 meters from north to south, then that is what QGIS will draw.

これを正すには:

• Click on the CRS Status button again and switch

Enable ‘on the fly’ CRS transformation on again as before. * Zoom to the extents of the RSA dataset.

Now, because they’re made to project in the same CRS, the two datasets fit perfectly:

When combining data from different sources, it’s important to remember that they might not be in the same CRS. “On the fly” reprojection helps you to display them together.

Before you go on, you probably want to have the ‘on the fly’ reprojection to be automatically activated whenever you open datasets having different CRS:

7.1. Lesson: データの再投影と変形
•再度設定→オプション…を実行し、CRSを選択します。
•もしレイヤーが異なる座標系を持つ場合、自動で‘オンザフライ’リプロジェクションを有効にするをチェックします。

### 7.1.3 Follow Along: 他のCRSに設定したデータセットの保存

Remember when you calculated areas for the buildings in the Classification lesson? You did it so that you could classify the buildings according to area.

• あなたの通常のマップ（Swellendamデータを含む）を開きます。
• Open the attribute table for the buildings layer.
• :kbd:`AREA`フィールドが見えるまで右側にスクロールします。

Notice how the areas are all very small; probably zero. This is because these areas are given in degrees - the data isn’t in a Projected Coordinate System. In order to calculate the area for the farms in square meters, the data has to be in square meters as well. So, we’ll need to reproject it.

But it won’t help to just use ‘on the fly’ reprojection. ‘On the fly’ does what it says - it doesn’t change the data, it just reprojects the layers as they appear on the map. To truly reproject the data itself, you need to export it to a new file using a new projection.

• Right-click on the buildings layer in the Layers list.
• Select Save As… in the menu that appears. You will be shown the Save vector layer as… dialog.
• Click on the Browse button next to the Save as field.
• Navigate to exercise_data/ and specify the name of the new layer as buildings_reprojected.shp.
• エンコーディングはそのままにしておきます。
• Change the value of the Layer CRS dropdown to Selected CRS.
• ドロップダウン下のブラウスボタンをクリックします。
• CRSセレクタダイアログが表示されるでしょう。
• :guilabel:`フィルター'フィールドで、:kbd:`34S`を検索します。
• リストから:guilabel:`WGS 84 / UTM zone 34S`を選択します。
• Leave the Symbology export unchanged.

The Save vector layer as… dialog now looks like this:
• Click OK.
• Start a new map and load the reprojected layer you just created.

Refer back to the lesson on Classification to remember how you calculated areas.

• Update (or add) the AREA field by running the same expression as before:
This will add an `AREA` field with the size of each building in square meters

- To calculate the area in another unit of measurement, for example hectares, use the `AREA` field to create a second column:
Look at the new values in your attribute table. This is much more useful, as people actually quote building size in metres, not in degrees. This is why it’s a good idea to reproject your data, if necessary, before calculating areas, distances, and other values that are dependent on the spatial properties of the layer.

7.1.4 🚨 Follow Along: 独自の投影法の作成

There are many more projections than just those included in QGIS by default. You can also create your own projections.

- マップを新規に開始します。
- Load the world/oceans.shp dataset.
- Go to Settings → Custom CRS... and you’ll see this dialog:
• Click on the Add new CRS button to create a new projection.

An interesting projection to use is called Van der Grinten I.

• 名称フィールドでその名称を入力します。

This projection represents the Earth on a circular field instead of a rectangular one, as most other projections do.

• そのパラメータとして、次のような文字列を使います：

```
+proj=vandg +lon_0=0 +x_0=0 +y_0=0 +R_A +a=6371000 +b=6371000 +units=m +no_defs
```
• Click OK.
• “オンザフライ” 再投影を有効にします。
• Choose your newly defined projection (search for its name in the Filter field).
• この投影法を適用するため、したがってマップは再投影されるでしょう。
7.1.5 In Conclusion

Different projections are useful for different purposes. By choosing the correct projection, you can ensure that the features on your map are being represented accurately.

7.1.6 Further Reading

Materials for the Advanced section of this lesson were taken from this article.
Further information on Coordinate Reference Systems is available here.

7.1.7 What’s Next?

次のレッスンでは、QGIS の様々なベクタ分析ツールを使ってベクタデータの分析をする方法について学習します。

7.2 Lesson: ベクタ分析

Vector data can also be analyzed to reveal how different features interact with each other in space. There are many different analysis-related functions in GIS, so we won’t go through them all. Rather, we’ll pose a question and try to solve it using the tools that QGIS provides.
**このレッスンの目標:** 質問を尋ね、分析ツールを使ってそれを解決すること。

7.2.1 🌍 GIS プロセス

始める前に、任意の GIS の問題を解決するために使用できるプロセスの簡単な概要を与えることが有用でしょう。それを行う方法は次のとおりです。
1. 問題の状態
2. データの入手
3. 問題の分析
4. 結果のプレゼン

7.2.2 問題

Let’s start off the process by deciding on a problem to solve. For example, you are an estate agent and you are looking for a residential property in Swellendam for clients who have the following criteria:

1. Swellendam である必要がある。
2. 学校前の距離が、合理的にアクセスできる距離（例えば 1km）である必要がある。
3. サイズが 100m 四方以上である必要がある。
4. 主要道路から 50m より近い。
5. レストランから 500m 以内にある。

7.2.3 データ

これらの疑問に答えるため、次のデータが必要になるでしょう:

1. このエリアの住宅地属性 (建物)。
2. 街とその周辺の道路
3. 学校とレストランの位置
4. 建物のサイズ

All of this data is available through OSM and you should find that the dataset you have been using throughout this manual can also be used for this lesson. However, in order to ensure we have the complete data, we will re-download the data from OSM using QGIS’ built-in OSM download tool.

ノート: Although OSM downloads have consistent data fields, the coverage and detail does vary. If you find that your chosen region does not contain information on restaurants, for example, you may need to chose a different region.

7.2.4 Follow Along: プロジェクトの開始

• 新規の QGIS プロジェクトの開始
• Use the OpenStreetMap data download tool found in the Vector -> OpenStreetMap menu to download the data for your chosen region.
• Save the data as osm_data.osm in your exercise_data folder.
• Note that the osm format is a type of vector data. Add this data as a vector layer as usually Layer -> Add vector layer…, browse to the new osm_data.osm file you just downloaded. You may need to select Show All Files as the file format.
• osm_data.osm を選択し 開く をクリックします。
• 表示されたダイアログで、except the other_relations と multilinestrings layer: のすべてのレイヤを選択します。
The data you just downloaded from OSM is in a geographic coordinate system, WGS84, which uses latitude and longitude coordinates, as you know from the previous lesson. You also learnt that to calculate distances in meters, we need to work with a projected coordinate system. Start by setting your project’s coordinate system to a suitable CRS for your data, in the case of Swellendam, WGS 84 / UTM zone 34S:

- Open the Project Properties dialog, select CRS and filter the list to find WGS 84 / UTM zone 34S.
- Click OK.

We now need to extract the information we need from the OSM dataset. We need to end up with layers representing all the houses, schools, restaurants and roads in the region. That information is inside the multipolygons layer and can be extracted using the information in its Attribute Table. We’ll start with the schools layer:

- Right-click on the multipolygons layer in the Layers list and open the Layer Properties.
- Under Feature subset click on the [Query Builder] button to open the Query builder dialog.
- In the Fields list on the left of this dialog until you see the field amenity.
- それを1回だけクリックします。
- '値'リストで'すべて'ボタンをクリックします:

さて我々は QGIS に:kbd:amenity が:kbd:'school'に等しいポリゴンであることを示す必要があります。

- フィールドリストのamenityをダブルクリックします。
- Watch what happens in the Provider specific filter expression field below:
The word "amenity" has appeared. To build the rest of the query:

- [:guilabel:'演算子'から] :guilabel:='ボタンをクリックします。
- 値リストで school の値をダブルクリックします。
- OK を 2 回クリックします。

This will filter OSM’s multipolygon layer to only show the schools in your region. You can now either:

- Rename the filtered OSM layer to schools and re-import the multipolygons layer from osm_data.osm, OR
- Duplicate the filtered layer, rename the copy, clear the Query Builder and create your new query in the Query Builder.

7.2.5 🚩 [TY] OSM からの必要なレイヤの抽出

Using the above technique, use the Query Builder tool to extract the remaining data from OSM to create the following layers:

- roads (OSM の lines レイヤ由来)
- restaurants (OSM の multipolygons レイヤ由来)
• houses (OSM の multipolygons レイヤ由来)

前のレッスンで作成した roads.shp を再利用するのが望ましいです。

結果の確認

• Save your map under exercise_data, as analysis.qgs.

• In your operating system’s file manager, create a new folder under exercise_data and call it residential_development. This is where you’ll save the datasets that will be the results of the analysis functions.

### 7.2.6 Try Yourself 主要道路の検索

Some of the roads in OSM’s dataset are listed as unclassified, tracks, path and footway. We want to exclude these from our roads dataset.

• Open the Query Builder for the roads layer, click Clear and build the following query:

```
"highway" != 'NULL' AND "highway" != 'unclassified' AND "highway" != 'track' AND "highway" != 'path' AND "highway" != 'footway'
```

You can either use the approach above, where you double-clicked values and clicked buttons, or you can copy and paste the command above.

### 7.2.7 Try Yourself レイヤ CRS の変換

Because we are going to be measuring distances within our layers, we need to change the layers’ CRS. To do this, we need to select each layer in turn, save the layer to a new shapefile with our new projection, then import that new layer into our map.

ノート: In this example, we are using the WGS 84 / UTM zone 34S CRS, but you may use a UTM CRS which is
more appropriate for your region.

- Right click the roads layer in the Layers panel.
- Save as... をクリックします。
- In the Save Vector As dialog, choose the following settings and click Ok (making sure you select Add saved file to map):

新しいシェープファイルが作成され、あなたのマップに結果のレイヤとして追加されます。
If you don’t have activated Enable ‘on the fly’ CRS transformation or the Automatically enable ‘on the fly’ reprojection if layers have different CRS settings (see previous lesson), you might no be able to see the new layers you just added to the map. In this case, you can focus the map on any of the layers by right click on any layer and click Zoom to layer extent, or just enable any of the mentioned ‘on the fly’ options.

Repeat this process for each layer, creating a new shapefile and layer with “_34S” appended to the original name and removing each of the old layers.

Once you have completed the process for each layer, right click on any layer and click Zoom to layer extent to focus the map to the area of interest.

Now that we have converted OSM’s data to a UTM projection, we can begin our calculations.

### 7.2.8 Follow Along: 問題の分析：学校と道路からの距離

QGIS はいかなるベクタからの距離を計算することができます。

- Make sure that only the roads_34S and houses_34S layers are visible, to simplify the map while you’re working.
- Click on the Vector → Geoprocessing Tools → Buffer(s) tool:

新しいダイアログを表示します。
- このように設定します:
The **Buffer distance** is in meters because our input dataset is in a Projected Coordinate System that uses meter as its basic measurement unit. This is why we needed to use projected data.

- Save the resulting layer under `exercise_data/residential_development/` as `roads_buffer_50m.shp`.
- **OK** をクリックし、バッファを作成します。
- When it asks you if it should “add the new layer to the TOC”, click Yes. (“TOC” stands for “Table of Contents”, by which it means the *Layers list*).
- Close the **Buffer(s)** dialog.

今すぐあなたのマップは次のようになります:
If your new layer is at the top of the Layers list, it will probably obscure much of your map, but this gives us all the areas in your region which are within 50m of a road.

However, you’ll notice that there are distinct areas within our buffer, which correspond to all the individual roads. To get rid of this problem, remove the layer and re-create the buffer using the settings shown here:
パッファのディゾルブ結果 ボックスを今チェックしていることに注目ください。

- Save the output under the same name as before (click Yes when it asks your permission to overwrite the old one).
- OK をクリックし パッファ ダイアログを再度閉じます。

レイヤリストにいったんレイヤを追加すると、このように見えます:
7.2.9  Try Yourself 学校からの距離

- Use the same approach as above and create a buffer for your schools.

It needs to be 1 km in radius, and saved under the usual directory as schools_buffer_1km.shp.

7.2.10  Follow Along: 重複エリア

Now we have areas where the road is 50 meters away and there’s a school within 1 km (direct line, not by road). But obviously, we only want the areas where both of these criteria are satisfied. To do that, we’ll need to use the Intersect tool. Find it under Vector → Geoprocessing Tools → Intersect. Set it up like this:
The two input layers are the two buffers; the save location is as usual; and the file name is `road_school_buffers_intersect.shp`. Once it’s set up like this, click OK and add the layer to the Layers list when prompted.

In the image below, the blue areas show us where both distance criteria are satisfied at once!
You may remove the two buffer layers and only keep the one that shows where they overlap, since that’s what we really wanted to know in the first place:

7.2.11 **Follow Along: 建物の選択**

Now you’ve got the area that the buildings must overlap. Next, you want to select the buildings in that area.

- Click on the menu entry *Vector → Research Tools → Select by location*. A dialog will appear.
• This way:

![Select by location dialog box](image)

• OK をクリックし、閉じる をクリックします。

• You’ll probably find that not much seems to have changed. If so, move the `school_roads_intersect` layer to the bottom of the layers list, then zoom in:

![Map view with school_roads_intersect layer at bottom](image)
The buildings highlighted in yellow are those which match our criteria and are selected, while the buildings in green are those which do not. We can now save the selected buildings as a new layer.

- Right-click on the houses_34S layer in the Layers list.
- Select Save Selection As....
- ダイアログにてこれに設定します:

• ファイル名は well_located_houses.shp です。
• Click OK.
Now you have the selection as a separate layer and can remove the houses_34S layer.

### 7.2.12 Try Yourself Further Filter our Buildings

We now have a layer which shows us all the buildings within 1km of a school and within 50m of a road. We now need to reduce that selection to only show buildings which are within 500m of a restaurant.

Using the processes described above, create a new layer called houses_restaurants_500m which further filters your well_located_houses layer to show only those which are within 500m of a restaurant.

### 7.2.13 Follow Along: 正しいサイズの建物の選択

To see which buildings are the correct size (more than 100 square metres), we first need to calculate their size.

- Open the attribute table for the houses_restaurants_500m layer.
- 編集モードにし、フィールド演算を開きます。
- このように設定します:
• If you can’t find AREA in the list, try creating a new field as you did in the previous lesson of this module.
• Click OK.
• Scroll to the right of the attribute table; your AREA field now has areas in metres for all the buildings in your houses_restaurants_500m layer.
• Click the edit mode button again to finish editing, and save your edits when prompted.
• Build a query as earlier in this lesson:
• Click OK. Your map should now only show you those buildings which match our starting criteria and which are more than 100m squared in size.

7.2.14 Try Yourself

• Save your solution as a new layer, using the approach you learned above for doing so. The file should be saved under the usual directory, with the name solution.shp.

7.2.15 In Conclusion

Using the GIS problem-solving approach together with QGIS vector analysis tools, you were able to solve a problem with multiple criteria quickly and easily.

7.2.16 What’s Next?

In the next lesson, we’ll look at how to calculate the shortest distance along the road from one point to another.
7.3 Lesson: ネットワーク分析

2点間の最短距離を計算するために一般的なGISを使用することです。このツールをQGISは搭載していますが、それは、デフォルトでは表示されていません。この短いレッスンでは、始めるために必要な方法を紹介します。

このレッスンの目的: 道路グラフ プラグインの有効化、設定と利用。

7.3.1 Follow Along: ソールの有効化

QGISは、その基本的な機能に追加する多くのプラグインがあります。これらのプラグインの多くは、入手後すぐにプログラムと一緒に利用できるため便利です。それらはまだしかし、デフォルトでは非表示にしています。そのため、それらを使用するためには、まず有効にする必要があります。

道路グラフ プラグインの有効化:

• QGISのメイン画面にあるメニューのプラグイン → プラグインの管理とインストール... をクリックすることで、プラグインマネージャを起動します。ダイアログが表示されます。

• このようにプラグインを選択します。

　・ プラグインマネージャの閉じるをクリックします。

ノート: If you do not see the the plugin in your interface, go to View → Panels and ensure that Shortest path has a check mark next to it.

このパネルはインタフェースで表示されるでしょう:
7.3.2  Follow Along: ツールの設定

To have a layer to calculate on, first save your current map. If you haven’t already done so, save your roads_34S layer to a shapefile by right-clicking the layer and selecting Save as... Create a new map and load this layer into it.

Since so many different configurations are possible when analyzing networks, the plugin doesn’t assume anything before you’ve set it up. This means that it won’t do anything at all if you don’t set it up first.

- Click on the menu item Vector → Road graph → settings. A dialog will appear.
- このように設定されていることを確認します（特に指定しない限りデフォルトを使用）。
• 時間の単位: 時間
• 距離の単位: km
• レイヤ: roads_34S
• 速度フィールド: 常にデフォルトを使用 / km/h
Follow Along: ツールの使用

Find two points, on roads, on your map. They do not need to have any significance, but they should be connected by roads and separated by a reasonable distance:
• In the plugin panel, click on the *Capture Point* button next to the *Start* field:
• 選択した始点でクリックします。
• Use the Capture Point button next to the Stop field and capture your chosen end point.
• Click on the Calculate button to see the solution:
7.3.4  Follow Along: 階級の使用

ノート: Section developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

- Add your restaurants_34S layer to the map (extract it from your analysis map if necessary).
- Open the attribute table for the roads_34S layer and enter edit mode.
- Add a new column with the name SPEED, and give it the type
  \textit{Whole number (integer)} with a width of 3.
- In the main window, activate the Select Features by Rectangle tool:
• Select any main roads in urban - but not residential - areas:

(To select more than one road, hold the `ctrl` button and drag a box across any road that you want to include in the selection.)

• In the attribute table, select *Show selected features*.
• Set the SPEED value for all the selected streets to 60:

In context, this means that you’re setting the speed limit on those roads to 60 km/h.

• Select any highways or major roads outside urban areas:
• Set the SPEED value for all the selected streets to 120.
• Close the attribute table, save your edits, and exit edit mode.
• Check the Vector → Road graph → Road graph settings to ensure that it’s set up as explained previously in this lesson, but with the Speed value set to the SPEED field you just created.
• In the Shortest path panel, click the Start point button.
• Set the starting point on a minor road on one side of Swellendam and the end point on a major road on the other side of town:
• In the Criterion drop-down list in the Shortest path panel, select Length.
• Click Calculate. The route will be calculated for the shortest distance:

Notice the values of Length and Time in the Shortest path panel.
• Set the Criterion to Time.
• Click Calculate again. The route will be calculated for the shortest time:

You can switch back and forth between these criteria, recalculating each time, and note the changes in the Length and Time taken. Remember that the assumption being made to arrive at the time taken to travel a route does not
account for acceleration, and assumes that you will be traveling at the speed limit at all times. In a real situation, you may want to split roads into smaller sections and note the average or expected speed in each section, rather than the speed limit.

If, on clicking Calculate, you see an error stating that a path could not be found, make sure that the roads you digitized actually meet each other. If they’re not quite touching, either fix them by modifying the features, or set the Topology tolerance in the plugin’s settings. If they’re passing over each other without intersecting, use the Split features tool to “split” roads at their intersections:

Remember that the Split features tool only works in edit mode on selected features, though!

You might also find that the shortest route is also the quickest if this error is returned.

### 7.3.5 In Conclusion

Now you know how to use the Road Graph plugin to solve shortest-path problems.

### 7.3.6 What’s Next?

Next you’ll see how to run spatial statistics algorithms on vector datasets.

### 7.4 Lesson: 空間統計

**Note:** Lesson developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

空間統計では、分析し、与えられたベクタデータセットで何が起こっているかを理解することができます。QGIS は、この点で有用であることが分かる統計分析のためのいくつかの標準的なツールが含まれています。

**このレッスンの目標:** QGIS の空間統計ツールの使い方を知ること。

#### 7.4.1 Follow Along: テストデータセットの作成

ポイントデータセットの操作を知るために、ポイントのランダムセットを作成します。
そのためには、ポイントを作成したいエリアの範囲を定義するポリゴンデータセットが必要です。
ストリートで覆われているエリアを使います。

- 空のマップを新規に開始します。
- roads_34S レイヤと exercise_data/raster/SRTM/ にある srtm_41_19.tif raster (elevation data) を追加します。

**Note:** あなたの SRTM の DEM レイヤは道路レイヤとは異なる CRS を持っていることがわかるかもしれません。その場合は、それ以前のこのモジュールの学んだ技術を使用して、道路または DEM レイヤのいずれかを再投影することができます。

- Use the Convex hull(s) tool (available under Vector → Geoprocessing Tools) to generate an area enclosing all the roads:
• Save the output under `exercise_data/spatial_statistics/` as `roads_hull.shp`.

• メッセージが表示されたら TOC (Layers list) に追加されます。

ランダム点群の作成

• ベクタ → 調査ツール → ランダム点群ツールを使用して、このエリアにランダム点群を作成します。
QGIS Training Manual, リリース 2.2

exercise_data/spatial_statistics/ 以下に random_points.shpとして保存します。
メッセージが表示されたら（レイヤリスト）に追加します。
データのサンプリング

- ラスタからサンプルデータセットを作成するため、ポイントサンプルツールプラグインを使う必要があるでしょう。
- 必要に応じてプラグインで、モジュールを先に参照してください。
- Plugin -> プラグインの管理とインストール... でpoint sampling というフレーズで検索し、このプラグインを見つけます。
- プラグインマネージャで有効化されたら、プラグイン → 分析 → ポイントサンプリングツール を見つけることができます。
Now you can check the sampled data from the raster file in the attributes table of the `random_samples` layer, they will be in a column named `srtm_41_19.tif`.

サンプルレイヤはここで示すとおりです:
より暗い点が低い高度であるように、サンプル点はそれらの値によって分類されます。
あなたは、残りの統計クエササイズのためにこのサンプルレイヤを使っています。

7.4.2 Follow Along: 基本統計

さて、このレイヤに対して基本統計を取得しましょう。

- Click on the Vector → Analysis Tools → Basic statistics menu entry.
- In the dialog that appears, specify the random_samples layer as the source.
- Make sure that the Target field is set to srtm_41_19.tif which is the field you will calculate statistics for.
- OK をクリックします。結果はこのようになります。
You can copy and paste the results into a spreadsheet. The data uses a (colon : ) separator.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mean</td>
<td>341.41</td>
</tr>
<tr>
<td>StdDev</td>
<td>246.158692514</td>
</tr>
<tr>
<td>Sum</td>
<td>34141.0</td>
</tr>
<tr>
<td>Min</td>
<td>58.0</td>
</tr>
<tr>
<td>Max</td>
<td>1145.0</td>
</tr>
<tr>
<td>N</td>
<td>100.0</td>
</tr>
<tr>
<td>CV</td>
<td>0.721006099744</td>
</tr>
<tr>
<td>Number of unique values</td>
<td>94</td>
</tr>
<tr>
<td>Range</td>
<td>1087.0</td>
</tr>
<tr>
<td>Median</td>
<td>256.0</td>
</tr>
</tbody>
</table>

Press Ctrl+C to copy results to the clipboard.
To understand the statistics above, refer to this definition list:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mean</td>
<td>The mean (average) value is simply the sum of the values divided by the amount of values.</td>
</tr>
<tr>
<td>StdDev</td>
<td>The standard deviation. Gives an indication of how closely the values are clustered around the mean. The smaller the standard deviation, the closer values tend to be to the mean.</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td></td>
</tr>
<tr>
<td>N</td>
<td></td>
</tr>
<tr>
<td>CV</td>
<td></td>
</tr>
<tr>
<td>Number of unique values</td>
<td>The number of values that are unique across this dataset. If there are 90 unique values in a dataset with N=100, then the 10 remaining values are the same as one or more of each other.</td>
</tr>
<tr>
<td>Range</td>
<td></td>
</tr>
</tbody>
</table>

7.4.3 **Follow Along: 距離マトリクスの算出**

- Create a new point layer in the same projection as the other datasets (WGS 84 / UTM 34S).
- Enter edit mode and digitize three point somewhere among the other points.
- Alternatively, use the same random point generation method as before, but specify only three points.
- 新規レイヤーを distance_points.shp として保存します。

これらのポイントを使って距離マトリクスを生成します。

- Open the tool Vector → Analysis Tools → Distance matrix.
- Select the distance_points layer as the input layer, and the random_samples layer as the target layer.
- このように設定します:
• Save the result as `distance_matrix.csv`.
• OK をクリックし、距離マトリックスを生成します。
• Open it in a spreadsheet program to see the results. Here is an example:
7.4.4 Green Follow Along: 最小近傍分析

最小近傍分析を行うために:

- Click on the menu item Vector $\to$ Analysis Tools $\to$ Nearest neighbor analysis.
- In the dialog that appears, select the random_samples layer and click OK.
- The results will appear in the dialog’s text window, for example:

<table>
<thead>
<tr>
<th>InputID</th>
<th>MEAN</th>
<th>STDDEV</th>
<th>MIN</th>
<th>MAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>0.195448627921</td>
<td>0</td>
<td>0.195448627921</td>
<td>0.195448627921</td>
</tr>
<tr>
<td>2</td>
<td>0.174928758638</td>
<td>0</td>
<td>0.174928758638</td>
<td>0.174928758638</td>
</tr>
<tr>
<td>1</td>
<td>0.174928758638</td>
<td>0</td>
<td>0.174928758638</td>
<td>0.174928758638</td>
</tr>
</tbody>
</table>

ノート: You can copy and paste the results into a spreadsheet. The data uses a (colon :) separator.
7.4.5  **Follow Along: 平均座標**

データセットの平均座標を取得するために:

- Click on the Vector → Analysis Tools → Mean coordinate(s) menu item.
- In the dialog that appears, specify *random_samples* as the input layer, but leave the optional choices unchanged.
- Specify the output layer as *mean_coords.shp*.
- Click OK.

メッセージが表示されたら レイヤリスト に追加されます。

Let’s compare this to the central coordinate of the polygon that was used to create the random sample.

- Click on the Vector → Geometry Tools → Polygon centroids menu item.
- In the dialog that appears, select *roads_hull* as the input layer.
- Save the result as *center_point*.

メッセージが表示されたら (*Layers list*) に追加されます。

As you can see from the example below, the mean coordinates and the center of the study area (in orange) don’t necessarily coincide:

---

7.4.6  **Follow Along: イメージヒストグラム**

The histogram of a dataset shows the distribution of its values. The simplest way to demonstrate this in QGIS is via the image histogram, available in the Layer Properties dialog of any image layer.

- In your *Layers list*, right-click on the SRTM DEM layer.
- プロパティ を選択します。
- Choose the tab *Histogram*. You may need to click on the Compute Histogram button to generate the graphic.

You will see a graph describing the frequency of values in the image.

---

7.4.  **Lesson: 空間統計**

195
• Select the Metadata tab, you can see more detailed information inside the Properties box.

The mean value is 332.8, and the maximum value is 1699! But those values don’t show up on the histogram. Why not? It’s because there are so few of them, compared to the abundance of pixels with values below the mean. That’s also why the histogram extends so far to the right, even though there is no visible red line marking the frequency of values higher than about 250.

Therefore, keep in mind that a histogram shows you the distribution of values, and not all values are necessarily visible on the graph.

• (You may now close Layer Properties.)

7.4.7 Follow Along: 空間的補間

Let’s say you have a collection of sample points from which you would like to extrapolate data. For example, you might have access to the random_samples dataset we created earlier, and would like to have some idea of what the terrain looks like.

To start, launch the Grid (Interpolation) tool by clicking on the Raster → Analysis → Grid (Interpolation) menu item.

• In the Input file field, select random_samples.
• Check the Z Field box, and select the field srtm_41_19.
• Set the Output file location to exercise_data/spatial_statistics/interpolation.tif.
• Check the Algorithm box and select Inverse distance to a power.
• Set the Power to 5.0 and the Smoothing to 2.0. Leave the other values as-is.
• Check the Load into canvas when finished box and click OK.
• When it’s done, click OK on the dialog that says Process completed, click OK on the dialog showing feedback information (if it has appeared), and click Close on the Grid (Interpolation) dialog.

Here’s a comparison of the original dataset (left) to the one constructed from our sample points (right). Yours may look different due to the random nature of the location of the sample points.

![Comparison of original and interpolated datasets](image)

As you can see, 100 sample points aren’t really enough to get a detailed impression of the terrain. It gives a very general idea, but it can be misleading as well. For example, in the image above, it is not clear that there is a high, unbroken mountain running from east to west; rather, the image seems to show a valley, with high peaks to the west. Just using visual inspection, we can see that the sample dataset is not representative of the terrain.

### 7.4.8 Try Yourself

• Use the processes shown above to create a new set of 1000 random points.
• Use these points to sample the original DEM.
• Use the Grid (Interpolation) tool on this new dataset as above.
• Set the output filename to interpolation_1000.tif, with Power and Smoothing set to 5.0 and 2.0, respectively.

The results (depending on the positioning of your random points) will look more or less like this:
The border shows the `roads_hull` layer (which represents the boundary of the random sample points) to explain the sudden lack of detail beyond its edges. This is a much better representation of the terrain, due to the much greater density of sample points.

Here is an example of what it looks like with 10,000 sample points:

---

**Note:** It’s not recommended that you try doing this with 10,000 sample points if you are not working on a fast computer, as the size of the sample dataset requires a lot of processing time.
7.4.9  Follow Along:  追加の空間統計ツール

Originally a separate project and then accessible as a plugin, the SEXTANTE software has been added to QGIS as a core function from version 2.0. You can find it as a new QGIS menu with its new name Processing from where you can access a rich toolbox of spatial analysis tools allows you to access various plugin tools from within a single interface.

- Activate this set of tools by enabling the Processing → Toolbox menu entry. The toolbox looks like this:

You will probably see it docked in QGIS to the right of the map. Note that the tools listed here are links to the actual tools. Some of them are SEXTANTE’s own algorithms and others are links to tools that are accessed from external applications such as GRASS, SAGA or the Orfeo Toolbox. This external applications are installed with QGIS so you are already able to make use of them. In case you need to change the configuration of the Processing tools or, for example, you need to update to a new version of one of the external applications, you can access its setting from Processing → Options and configurations.

7.4.10  Follow Along:  Spatial Point Pattern Analysis

For a simple indication of the spatial distribution of points in the random_samples dataset, we can make use of SAGA’s Spatial Point Pattern Analysis tool via the Processing Toolbox you just opened.

- In the Processing Toolbox, search for this tool Spatial Point Pattern Analysis.
- サーチクリックしそのダイアログを開きます。
SAGA のインストール

**Windows で**

Included in your course materials you will find the SAGA installer for Windows.

- Start the program and follow its instructions to install SAGA on your Windows system. Take note of the path you are installing it under!

Once you have installed SAGA, you’ll need to configure SEXTANTE to find the path it was installed under.

- Click on the menu entry *Analysis → SAGA options and configuration*.
- In the dialog that appears, expand the SAGA item and look for *SAGA folder*. Its value will be blank.
- In this space, insert the path where you installed SAGA.

**Ubuntu で**

- Search for *SAGA GIS* in the *Software Center*, or enter the phrase `sudo apt-get install saga-gis` in your terminal. (You may first need to add a SAGA repository to your sources.)
- QGIS will find SAGA automatically, although you may need to restart QGIS if it doesn’t work straight away.

**Mac で**

Homebrew users can install SAGA with this command:

- `saga-core` の BREW インストール

If you do not use Homebrew, please follow the instructions here:


インストール後

Now that you have installed and configured SAGA, its functions will become accessible to you.

**SAGA の利用**

- SAGA ダイアログを開きます。
- SAGA produces three outputs, and so will require three output paths.
- Save these three outputs under *exercise_data/spatial_statistics/*, using whatever file names you find appropriate.
The output will look like this (the symbology was changed for this example):
The red dot is the mean center; the large circle is the standard distance, which gives an indication of how closely the points are distributed around the mean center; and the rectangle is the bounding box, describing the smallest possible rectangle which will still enclose all the points.

### 7.4.11 🌊 Follow Along: 最小距離分析

Often, the output of an algorithm will not be a shapefile, but rather a table summarizing the statistical properties of a dataset. One of these is the Minimum Distance Analysis tool.

- Find this tool in the Processing Toolbox as :guilabel:`'Minimum Distance Analysis'.

It does not require any other input besides specifying the vector point dataset to be analyzed.

- Choose the `random_points` dataset.
- Click OK. On completion, a DBF table will appear in the Layers list.
- Select it, then open its attribute table. Although the figures may vary, your results will be in this format:
### 7.4.12 In Conclusion

QGIS allows many possibilities for analyzing the spatial statistical properties of datasets.

### 7.4.13 What’s Next?

Now that we’ve covered vector analysis, why not see what can be done with rasters? That’s what we’ll do in the next module!
Chapter 8

Module: ラスタ

我々は以前にデジタイズするためのラスタを使用しましたが、ラスタデータは、直接使用することができ
ます。このモジュールでは、どのようにして QGIS で行うのかがわかります。

8.1 Lesson: ラスタデータの操作

ラスタデータはベクタデータとは全く異なります。ベクタデータは頂点で構成され、そしてことによりと
ラインやエリアとつながる離散的な地物を有します。しかしラスタデータは画像のようなものです。そ
れは多分現実世界のオブジェクトのさまざまな属性を表現しますが、これらのオブジェクトは個別のオブジェ
クトとして存在していません。むしろ、それはさまざまな異なる色の値の画素を用いて表現されます。

この単位の間に、あなたは既存の GIS 解析を補うためにラスタデータを使用します。
このレッスンの目標: QGIS でラスタデータを操作する方法を学習します。

8.1.1 Follow Along: ラスタデータの読み込み

- Open your analysis.qgs map.
- solution と important_roads レイヤを除く全てのレイヤを非アクティブにします。
- ラスタレイヤの追加 ボタンをクリックします。

ラスタレイヤの追加 ダイアログが開きます。このプロジェクトのためのデータは exercise_data/raster
にあります。

- それらをすべて別個に読み込むか、ctrl を押しながら 4 つ全てを順にクリックしてから一度に開き
ます。

はじめはあなたは地図上で何も起こっているように見えないと思うでしょう。ラスタは読み込まれていな
いないのでしょうか? いま、それは レイヤリスト にはありますので明らかに読み込まれています。問題は
それらが同じ投影にないということです。幸いなことに、私たちは既にこのような状況で何をすべきかを
見てきました。

- メニューの プロジェクト → プロジェクトのプロパティ を選択します:
- メニューの CRS タブを選択します:
- “オフサファイ” 再投影を有効にします。
- 他のデータと同じ投影 (WGS 84 / UTM zone 33S) に設定します。
- OK をクリックします。
ラスタはうまくフィットするはずです:

私たちの全体の研究領域をカバーする4つの航空写真があります。

8.1.2 Follow Along: 仮想ラスタの作成

これからわかるように、あなたの solution レイヤは4つのすべての写真にわたっています。これが意味するとはあなたは4つのラスタで作業する必要があるということです。それは理想的ではありません。1つの(コンポジット)イメージに対して1つのファイルになっている方が良いと思うでしょう?

幸いなことに、QGISではこれを行うことができます。それでも新しいラスタファイルを実際に作成して、多くのスペースを取ることなしに、あなたは仮想ラスタを作成することができます。これはよくカタログとも呼ばれることがあります。この名前はその機能を説明しています。それは本当に新しいラスタではありません。既存のラスタを1つのカタログ、つまりアクセスを容易にするための一つのファイルに構成する方法です。

カタログを作成するには:

- メニュー項目 ラスタ → その他 → バーチャルラスタの構築(カタログ)をクリックします。
- 表示されるダイアログで、入力に可視のラスタレイヤを使うの隣のチェックボックスをオンにします。
- 出力場所に exercise_data/residential_development を入力します。
- ファイル名に aerial_photos.vrt を入力します。
終了時にキャンパスにロードします ボタンをチェックします。
下にあるテキストフィールドに注目してください。このダイアログが実際にやっているのは、あなたのためにそのテキストを書くことです。それは QGIS が実行しようとしている長いコマンドです。

ノート：コマンドテキストが編集可能であることに留意してください。もし望むなら、さらにコマンドをカスタマイズすることができます。初期コマンド (この場合は、gdalbuildvrt) の構文についてのヘルプはオンラインで検索して下さい。

OK をクリックしてコマンドを実行します。

それが完了するまでに時間がかかる場合があります。終わったらメッセージボックスでそう教えてくれます。

OK をクリックしてメッセージボックスを閉じます。
• 仮想ラスタの構築 (カタログ) ダイアログの閉じるをクリックします。 （もう一度コマンドの実行が開始されてしまうので OK はクリックしないで下さいね。）

• これでレイヤーリストから元の 4 つのラスタを削除することができます。

• 必要であれば、新しい aerial_photos ラスタカタログレイヤをクリックして、レイヤーリストの一一番下にドラッグすると他のアクティブなレイヤが見えるようになります。

8.1.3 vertisement ラスタデータの変換

上記の方法では、カタログを使用してデータセットを仮想的にマージし、それらを“オンザフライ” に再投影することができます。しかし、もしあなたが長期間使用することになるデータを用意しているならば、マージされ再投影された新しいラスタを作成する方が効率的かもしれません。はじめに用意をするのに少し時間がかかりますが、そうしておけば地図でラスタを使う際のパフォーマンスが向上します。

ラスタの再投影

• メニュー項目 ラスタ → 投影法 → ワープ (再投影) をクリックします。

このツールはディレクトリ全体の内容を再投影するための便利なバッチオプションを備えています。仮想ラスタ (カタログ) も再投影することができ、マルチスレッド処理モードを有効にすることもできます。
ラスタのマージ

- メニュー項目 ラスタ → その他 → 結合 をクリックします。
あなたは単一のファイルのかわりにディレクトリ全体を処理することもできます。とても便利なバッチ処理機能です。入力ファイルとして仮想ラスタを指定することもでき、全ての構成ラスタが処理されます。
また、生成オプション チェックボックスとリストを使用して独自のコマンドラインオプションを追加することができます。あなたが GDAL ライブラリの操作についての知識を持っている場合にのみ利用できます。
Choose input directory instead of files
Input files
Output file
No data value
Layer stack
Use intersected extent
Grab pseudocolor table from the first image
Creation Options
Profile
Default
Name Value
Load into canvas when finished
gdal_merge.py
Help Close OK
8.1.4 In Conclusion

QGIS では既存のプロジェクトにラスタデータを入れることが簡単です。

8.1.5 What’s Next?

次は航空画像ではないラスターデータを使用して、同様にラスタの場合にシンボライズはどのように有用であるか見ていきます。

8.2 Lesson: ラスタシンボロジーの変更

ラスタデータは航空写真ばかりではありません。ラスタデータには他にも多くの形態があり、それらの多くの場合ではデータが適切に表示されて役立つように適切にシンボライズすることが不可欠です。

このレッスンの目標: ラスタレイヤのシンボロジーを変更します。

8.2.1 Try Yourself

- Start with the current map from the previous exercise analysis.qgs.
- 新しいラスタデータセットをロードするには Add Raster Layer ボタンを使います。
- データセット srtm_41_19.tif を読み込みます。exercise_data/raster/SRTM/ ディレクトリにあります。
- Layers list に表示されたらその名前を DEM に変更します。
- このレイヤの領域にズームします。レイヤリストを右クリックしてレイヤの領域にズーム を選択します。

このデータセットは数値標高モデル (DEM) です。それは地形の標高を表す地図で、例えば山や谷はどこにあるかも知ることができします。

それがロードされると、DEM の基本的な引き伸ばされたグレースケール表現が表示されます。上にベクトルレイヤを重ねるとこのように表示されます:
QGIS は可視化のためにイメージに引きのぼしを自動的に適用しました。引き続いて私たちはこれがどのように機能するかについて詳しく学びます。

8.2.2 🟢 Follow Along: ラスタレイヤのシンボロジーの変更

- SRTM レイヤのレイヤプロパティ ダイアログを開きます。レイヤツリーのレイヤを右クリックしてプロパティを選択します。
- スタイル タブに移ります。
現在の設定は QGIS がデフォルトで適用したものでです。それは DEM の表示の一つの方法にすぎません。では他の方法を探りましょう。

- レンダータイプを 単バンド疑似カラー に変更します。与えられたデフォルトオプションを使います。
- 分類 ボタンをクリックして新しい色の分類を生成します。 Ok をクリックして DEM にこの分類を適用します。
このようにラスタが見えるでしょう。
これは DEM を表示する興味深い方法ですが、多分私たちはこれらの色を使ってシンボライズしたいとは思いません。

・もう一度レイヤプロパティダイアログを開きます。
・レンダータイプを単バンドグレーに戻します。
・OKをクリックしてラスタにこの設定を適用します。
あまり有用ではないすべて灰色の四角形が表示されます。
これはコントラストをつけるために色の値を" 引きのばす" デフォルト設定を失ったからです。
それではもう一度 DEM のデータの範囲に基づいて色の値を" 引きのばす" に QGIS に指示しましょう。
QGIS に使用可能な全ての色を使われます (Grayscale の、黒と白とそれらの間の灰色のすべての色合い)。

- 最小 と 最大 の値を次に示す通りに指定します。
- コントラスト拡張 を 最小最大に引き延ばす に設定します:
しかし、引き延ばしのために使用されるべき最小値と最大値とは何でしょうか？最小と最大の値の下に現在あるものは前に私たちに灰色の矩形を与えた値と同じです。そのかわりに私たちは画像の中にある実際の最小値と最大値を使用するべきでしょうか？幸いなことに、ラスタの最小値と最大値をロードすることによって、これらの値は簡単に決定することができます。

- 最小値/最大値のロードの下の最小最大オプションを選択します。
- 読み込みボタンをクリックします：

Custom min / max values が DEM の実際の値を反映するように変わったことに注目して下さい。

8.2. Lesson: ラスタシンボロジーの変更 217
OK をクリックしてこれらの設定をイメージに適用します。
これでラスタの値は再び適切に表示されます。より暗い色は谷を、より明るい色は山を表しています。
でも、もっといい、もっと簡単な方法はないでしょうか？

はい、あります。何がされる必要があるのかをあなたは理解しているので、このすべてを簡単に行うためのツールがあることを知って嬉しくなるでしょう。

・レイヤリストから今ある DEM を削除します。
・ラスタをもう一度ロードして、前と同じように DEM に名前を変えます。再び灰色の矩形が現れました...
・ビュー → タルバー → ラスタ を有効にして必要なツールを有効化します。これらのアイコンがインターフェイスに現れるでしょう。

左から 3 番目のボタン Local Histogram Stretch はあなたがズームしている地域に最もよいコントラストを与えるために自動的に最小値と最大値を引きのぼります。これは大規模なデータセットの場合に便利です。左のボタン 表示範囲内でヒストグラムの累積的カットと引き伸ばし... は画像全体にわたる一定値に最小値と最大値を引きのぼります。
・左から 4 番目のボタン (ヒストグラムをフルデータセットに伸ばす) をクリックします。データが前のように正しく表示されます。

このツールバーの他のボタンを試してみて、ローカルエリアにズームインした時や完全にズームアウトした時に画像の引きのぼしがどのように変わるかを見てみましょう。
8.2.3 In Conclusion

これらはあなたがラスタシンボロジーを使い始めるための基本的な機能にすぎません。QGIS は標準偏差を用いたレイヤのシンボロジーやマルチスペクトル画像の異なるバンドを異なる色で表現することもできます。

8.2.4 リファレンス

SRTM データセットは http://srtm.csi.cgiar.org/ から入手しました。

8.2.5 What’s Next?

私たちはデータを適切に表示することができるようになりました。それではさらに、それを解析する方法を調べてみましょう。

8.3 Lesson: 地形解析

ラスタの特定の種類からはそれが表す地形の洞察をより多く得ることができます。数値標高モデル (DEM) はこの点で特に有用です。このレッスンでは先ほどからの住宅開発案の調査地域についてより詳しく調べるのに地形解析ツールを使用します。

このレッスンの目標: 地形に関する詳細な情報を取得するために地形解析ツールを使用します。

8.3.1 Follow Along: 陰影起伏の計算

マップ上で今ある DEM は地形の標高を示していますが、それは少し抽象的に見えことがあるかもしれません。それはあなたが必要とする地形に関するすべての 3D 情報を含んでいますが、3D オブジェクトのようには見えません。地形がより良く見えるようにするために、陰影起伏を計算することが可能です。それは 3D に見える画像を作成するために光と影を使って地形を表すラスタです。

DEM を扱うには QGIS のオールインワン DEM (地形モデル) 解析ツールを使用します。

• メニュー項目 ラスタ → 解析 → DEM (地形モデル) をクリックします。
• 表示されるダイアログで 入力ファイル が DEM であることを確認します。
• 出力ファイル を exercise_data/residential_development ディレクトリ の hillshade.tif に設定します。
• モード オプションで 陰影図 が選択されていることも確認します。
• 終了時にキャンバスにロードします の隣にあるボックスをチェックします。
• 他のオプションは変更しないままにしておけばいいです。
• OK をクリックして陰影図を生成します。
• 処理が完了したら、OK をクリックしてメッセージを閉じます。
• DEM (地形モデル) のメインダイアログの 閉じる をクリックします。

hillshade と呼ばれる新しいレイヤが次のように表示されます:
それは素晴らしい3Dに見えますが、私たちはこれを改善することができますか？陰影図はそれだけでなく石膏模型のように見えます。どうかしてそれを他のよりカラフルなラスタと一緒に使用することができないでしょうか？もちろんできます。オーバーレイとして陰影図を使用します。

8.3.2 Follow Along: 陰影図のオーバーレイとしての使用

陰影図は一日のある時点の日光について非常に有用な情報を提供することができますが審美的な目的で使うこともできます。それを使えば地図をよりよく見せることができ、陰影図をほとんど透過させる設定をその鍵となります。

- 前の演習と同様に、オリジナルのDEMのシンボロジーを疑似カラースキームを使うように変更します。
-DEMとhillshadeレイヤを除くすべてのレイヤを非表示にします。
-レイヤリストでDEMをクリックしてhillshadeレイヤの下になるようにドラッグします。
hillshadeレイヤを透過させるためにレイヤプロパティを開き、透過性タブに移動します。
-全体の透過率を50%に設定します。
-レイヤプロパティダイアログのOKをクリックします。このような結果を得るでしょう：

8.3. Lesson: 地形解析
・それがもうたらした違えを見るためにレイヤリストの hillshade レイヤの非表示にして、元のよう表示させます。

このように陰影図を使用すると景観のトポグラフィを誇張することが可能です。その効果があなたにとって十分な強さだと思えない場合には、hillshade レイヤの透過度を変更すればいいですが、もちろん、陰影起伏がより明るくなるほど、その背後の色は薄暗くなります。ちょうど良いバランスを見つける必要があるます。

完了したら地図を保存することを忘れないで下さい。

ノート: 次の2つの演習では新しい地図を使用して下さい。それには DEM ラスタデータセットだけを読み込みます (exercise_data/raster/SRTM/srtm_41_19.tif)。これはラスタ解析ツールを使う作業を簡単にすすむためです。地図を exercise_data/raster_analysis.qgs として保存します。

8.3.3 隆起の計算

地形の傾斜がどれほど急であるかを知るのも有用なことです。たとえば、あなたが土地に家を建てたい場合には比較的平坦な土地を必要とします。

地形の傾斜を知るには DEM（地形モデル）の傾斜モードを使用します。

・前と同じようにツールを開きます。

・モードオプションで傾斜を選択します:
QGIS Training Manual, リリース 2.2

- 保存場所を exercise_data/residential_development/slope.tif に設定します
- 終了時にキャンバスに... チェックボックスをオンにします。
- OK をクリックし、処理が完了したら 閉じる をクリックしてダイアログを閉じます。あなたの地図に新しいラスタが読み込まれて表示されます。
- レイヤリストで新しいラスタを選択して ヒストグラムをフルデータセットに伸ばす ボタンをクリックします。そうすると地形の傾斜が、平坦な地形は黒のピクセルで、急な地形は白のピクセルで表示されます。

8.3.4 ⬬ Try Yourself 斜面方位の計算

地形の 斜面方位 はそれが地に方位を指します。この研究は南半球で実施されているので、建物は日当たりがよいように理想的には北向き斜面に建てるのが好ましいです。

- DEM (地形モデル) ツールの 斜面方位 モードを使って地形の斜面方位を計算します。

結果をチェックする

8.3.5 ⬬ Follow Along: ラスタ計算機の使用

不動産仲介業者の問題を振り返ってみましょう。この前 ベクタ分析 レッスンの中で取り組みました。買い手は建物を購入してその地に小さなコテージを建てたいとしましょう。私たちは南半球では開発に理想的な小地場所は北向きで傾斜が 5 度未満の場所であることを知っています。しかし、もし傾斜が 2 度未満の場合、斜面方位は重要ではありません。

幸いにも、あなたは既に斜面方位だけではなく傾斜を示すラスタを持っているが、両方の条件が同時に満たされている場所を知る方法がありません。この分析はどのように行うことができるでしょうか?
その答えは ラスタ計算機 です。

・ このツールを起動するには ラスタ > ラスタ計算機... をクリックします。

・ aspect データセットを利用するために左側にある ラスタバンド リストの aspect@1 アイテムをダブルクリックします。それは下の ラスタ演算式 テキストフィールドに現れます。

北が 0(ゼロ) 度ですので、地形が北面するには斜面方位は 270 度より大きく、90 度未満でなければいけません。

・ ラスタ演算式 フィールドにこの式を入力します:

    aspect@1 <= 90 OR aspect@1 >= 270

・ 出力ファイル を exercise_data/residential_development/ ディレクトリ の aspect_north.tif に設定します。

・ 結果をプロジェクトに追加する ボックスがチェックされていることを確認します。

・ OK をクリックして処理を開始します。

あなたの結果はこのようになります:

8.3. Lesson: 地形解析
8.3.6  Try Yourself

斜面方位の次は DEM レイヤの新しい 2 つの独立した分析を行います。

・1 番目は斜面傾斜が 2 度以下のすべての地域を識別します。
・2 番目は似ていますが、傾斜が 5 度以下です。
・exercise_data/residential_development/ に slope_lte2.tif と slope_lte5.tif
として保存します。

結果をチェックする

8.3.7  Follow Along: ラスター解析結果を組み合わせる

今、あなたは DEM レイヤから作られた 3 つの新しいラスタを持っています:

・aspect_north: 地形が北に面している
・slope_lte2: 斜面傾斜が 2 度以下
・slope_lte2: 斜面傾斜が 5 度以下

これらのレイヤでは条件が満たされている場所は 1 に等しく、そうでない場所は 0 に等しいです。したがって、これらのラスタの 1 つを他の 1 つと乗算すれば両方が 1 に等しい場所が得られます。

満たされるべき条件は、5 度以下の傾斜で地形は北に面していなければならない。しかし、2 度以下の斜面では地形の方位は問題ではない。
したがって、傾斜が 5 度以下 AND 地形は北に面している OR 傾斜は 2 度以下 である場所を見つける必要があります。このような地形は開発に適しているでしょう。

これらの抽出条件を満たすエリアを計算します:

・ ラスタ計算機 をもう一度開きます。
・ ラスタバンドリストと演算子ボタン、そしてキーボードを使って ラスタ演算式 テキストエリアにこの式を作成します:

\[
( \text{aspect\_north@1 = 1 AND slope\_lte5@1 = 1} ) \text{ OR } \text{slope\_lte2@1 = 1}
\]

・ exercise_data/residential_development/に all_conditions.tif として出力を保存します。
・ ラスタ計算機の OK をクリックします。あなたの結果は:

8.3.8 Follow Along: ラスタの簡素化

上の画像からわかるように、複合解析は条件を満たしている多くの非常に小さなエリアを残しました。しかし、これらは何かを建築するには小さすぎるので私たちの解析にとって本当に有用ではありません。小さく使用できないエリアをすべて取り除きましょう。

・ ふるいツールを開きます (ラスタ → 解析 → ふるい)。
・ 入力ファイルを all_conditions に、出力ファイルを all_conditions_sieve.tif に設定します(exercise_data/residential_development/ディレクトリ)。
・ しきい値 と ピクセルの連結 の両方を 8 に設定して、ツールを実行します。
処理が完了すると、新しいレイヤはキャンパスに読み込まれます。しかし、データを表示するためにヒストグラムストレッチツールを使用しようとすると次のようになります:
どうなっているのでしょうか？答えは新しいラスタファイルのメタデータにあります。

・レイヤプロパティダイアログのメタデータタブでメタデータを表示します。プロパティセクションを見て下さい。
このラスタは派生元のものと同様に 1 と 0 の値しか持たないので STATISTICS_MINIMUM の値はとても絶対値の大きな負の数になっています。データを調べたところ、この数は NULL 値として作用することがわかりました。私たちは除外されなかったエリアだけを求めているので、これらの NULL 値を 0 に設定しましょう。

- ラスタ計算機を再度開いて次の計算式を作成します:

\[(\text{all_conditions_sieve} \& 1 <= 0) = 0\]

これは既存のすべてのゼロの値を維持しつつ、負の数をゼロにし、すべての 1 の値をもつエリアをそのままにします。

- `exercise_data/residential_development/` に `all_conditions_simple.tif` として出力を保存します。

出力はこのようになります:
これは期待されたもので、以前の結果を簡素化したものです。あなたが得た結果が期待したものでない場合は、メタデータ（および該当する場合はベクタの属性）を見ると問題を解決するための要点がわかることを覚えておいて下さい。

8.3.9 In Conclusion

DEM から様々な種類の分析結果を取り出す方法を見てきました。陰影起伏や傾斜、斜面方位の計算をしました。またこれらの結果をさらに分析し結合するためにラスタ計算機の使用方法を見てきました。

8.3.10 What’s Next?

あなたは2つの分析結果を持っています。潜在的に適した小地所を示すベクタ分析の結果と潜在的に適した地形を示すラスタ分析の結果です。この問題の最終的な結果に到達するためにどのようにこれらを組み合わせるか？それが次のレッスンのトピックです。次のモジュールで始まります。
Chapter 9

Module: 分析の完了

Converting between raster and vector formats allows you to make use of both raster and vector data when solving a GIS problem, as well as using the various analysis methods unique to these two forms of geographic data. This increases the flexibility you have when considering data sources and processing methods for solving a GIS problem.

**This lesson's goal:** Follow along to transform rasters to vectors.

9.1.1 Follow Along: The Raster to Vector Tool

Start with the map from the last module, `raster_analysis.qgs`. There you should have the `all_conditions_simple.tif` calculated during the previous exercises.

- Click on `Raster` → `Conversion` → `Polygonize (Raster to Vector)`. The tool dialog will appear.
- This way, you will:

Follow along to transform rasters to vectors.
• Change the field name (describing the values of the raster) to suitable.
• Save the shapefile under exercise_data/residential_development as all_terrain.shp.

Now you have a vector file which contains all the values of the raster, but the only areas you’re interested in are those that are suitable; i.e., those polygons where the value of suitable is 1. You can change the style of this layer if you want to have a clearer visualization of it.

### 9.1.2 Try Yourself

ベクタ分析のモジュールに戻って参照ください。

• Create a new vector file that contains only the polygons where suitable has the value of 1.
• Save the new file as exercise_data/residential_development/suitable_terrain.shp.

結果の確認

### 9.1.3 Follow Along: The Vector to Raster Tool

Although unnecessary for our current problem, it’s useful to know about the opposite conversion from the one performed above. Convert to raster the suitable_terrain.shp vector file you just created in previous step.

• Click on Raster → Conversion → Rasterize (Vector to Raster) to start this tool, then set it up as in the screenshot below:
• 入力ファイル は all_terrain;
• Output file... is exercise_data/residential_development/raster_conversion.tif;
• 幅と高さ はそれぞれ 837 と 661 です。

ノート: The size of the output image is specified here to be the same as the original raster which was vectorized. To view the dimensions of an image, open its metadata (Metadata tab in the Layer Properties).

• Click OK on the dialog to begin the conversion process.
• When it is complete, gauge its success by comparing the new raster with the original one. They should match up exactly, pixel for pixel.

9.1.4 In Conclusion
Converting between raster and vector formats allows you to widen the applicability of data, and need not lead to data degradation.

9.1.5 What’s Next?
Now that we have the results of the terrain analysis available in vector format, they can be used to solve the problem of which buildings we should consider for the residential development.

9.1. Lesson: ラスタのベクタへの変換
9.2 Lesson: 分析を組み合わせる

ベクトル化されたラスタ分析の結果を使用して、適当な地形の上の建物のみを選択することができます。このレッスンの目標: 適当な小地所を選び出すためにベクトル化された地形の結果を使用します。

9.2.1 Try Yourself

- 現在の地図を保存します(raster_analysis.qgs)。
- Open the map in which you did the vector analysis earlier (analysis.qgs)。
- レイヤリストでこれらのレイヤを有効にします:
  - hillshade,
  - solution (または buildings_over_100)
- 前に作業した時から既に地図に読み込まれているはずであるこれらのレイヤに加え、suitable_terrain.shp データセットも追加します。
- もしレイヤに見つからないものがある場合は、exercise_data/residential_development/から見つけて下さい。
- 交差ツール（ベクタ -> 空間演算ツール）を使って suitable_terrain レイヤと交差する建物だけが含まれる new_solution.shp という新しいベクタレイヤを作成します。

あなたは解として特定の建物を示すレイヤを持っているはずです。例えば:

ノート: 交差ツールからどんな結果も得られない場合は各レイヤの CRS 設定をチェックして下さい。比較しているレイヤの両方が同じ CRS でなければなりません。要求される CRS を用いて新しいシェープファイルとしてレイヤを保存することによって片方のレイヤを投影変換する必要があるかもしれません。私たちの例では suitable_terrain レイヤは WGS 84 / UTM 34S に投影変換され、suitable_terrain_34S と名付けられました。
9.2.2  Try Yourself 結果の検査

new_solution レイヤの各建物を見て下さい。new_solution レイヤのシンボロジーをアウトラインだけに変更して、それらを suitable_terrain レイヤと比較して下さい。建物のいくつかを見た時に気づきましたか？それらは suitable_terrain レイヤと交差しているからといってすべて適当ですか？その理由は？どれが不適当だと考えますか？
結果をチェックする

9.2.3  Try Yourself 分析結果の改良

結果に含まれていた建物の中には本当に通していないものがありましたので分析結果を改良しましょう。
私たちの分析では suitable_terrain レイヤの中に完全に収まる建物だけが選ばれるようにしたい。これによってどのように違ったのか？1つ以上のベクタ解析ツールを使用します。そして私たちの建物の大きさは 100 倍に小さめを持っておりますことを覚えておいて下さい。
結果をチェックする

9.2.4 In Conclusion

あなたは当初の研究課題に答え、どの地所を開発するべきかに関する推奨の意見を（無理なく、分析に支えられて）提供できます。

9.2.5 What’s Next？

次は 2 番目の研究課題の一部としてこれらの結果を提示します。

9.3 課題

マップコンポーネントを用いて分析結果を表す新しいマップを作って下さい。これらのレイヤを含めて下さい:

• places (ラベル付き),
• hillshade,
• solution (または new_solution),
• roads と
• aerial_photos または DEM のいずれか。

それにも連携する短い説明文を書いて下さい。適当な建物への推奨を説明するだけではなく家の購入とその後の開発を考えるのに使用された基準を文章に含みなさい。

9.4 Lesson: 補足の実習

このレッスンでは、QGIS での完全な GIS 解析を通じて案内します。

ノート: Lesson developed by Linfiniti and S Motala (Cape Peninsula University of Technology)
9.4.1 問題の状態

You are tasked with finding areas in and around the Cape Peninsula that are a suitable habitat for a rare fynbos plant species. The extent of your area of investigation in the Cape Peninsula is: south of Melkbosstrand, west of Strand. Botanists have provided you with the following preferences exhibited by the species in question:

• それは、東向き斜面に生えています。
• It grows on slopes with a gradient between 15% and 60%.
• It grows in areas that have a total annual rainfall of > 1200 mm.
• It will only be found at least 250 m away from any human settlement.
• The area of vegetation in which it occurs should be at least 6000m² in area.

As a volunteer for Cape Nature, you have agreed to search for the plant on the closest suitable piece of land to your house. Use your GIS skills to determine where you should go to look.

9.4.2 ソリューションの概要

In order to solve this problem, you will have to use the available data (available in exercise_data/more_analysis) to find the candidate area that is closest to your house. If you don’t live in Cape Town (where this problem is based) you can choose any house in the Cape Town region. The solution will involve:

• analysing the DEM to find the east facing slopes and the slopes with the correct gradients;
• analysing the rainfall raster to find the areas with the correct amount of rainfall;
• analysing the Zoning vector layer to find areas that are away from human settlement and are of the correct size.

9.4.3 マップの設定

• Click on the “CRS status” button in the extreme lower right corner of the screen. Under the CRS tab of the screen that appears, you will see the box Coordinate reference systems of the world.
• In this box, navigate to Projected Coordinate Systems → Universal Transverse Mercator (UTM).
• Select the entry WGS 84 / UTM zone 33S (with the EPSG code 32733).
• OK をクリックします。マップはUTM33S の CRS です。
• Save the map by clicking on the Save Project As toolbar button, or use the File → Save Project As... menu item.
• Save the map in a directory called Rasterprac that you should create somewhere on your computer. You will save whatever layers you create in this directory as well.

9.4.4 マップへの地図の読み込み

In order to process the data, you will need to load the necessary layers (street names, zones, rainfall, DEM) into the map canvas.

ペクタにとっては...

• Click on the Add Vector Layer button, or use the Layer → Add Vector Layer... menu item.
• 表示されるダイアログで、ファイルのラジオボタンが選択されているかを確認します。
• ブラウス ボタンをクリックします。
• 表示されるダイアログで、exercise_data/more_analysis/streets ディレクトリを開きます。
• Street_Names_UTM33S.shp を選択します。
• Click Open.

The dialog closes and shows the original dialog, with the file path specified in the text field next to the Browse button. This allows you to ensure that the correct file is selected. It is also possible to enter the file path in this field manually, should you wish to do so.

• Click Open. The vector layer will load in your map. Its color is automatically assigned. It will be changed later.
• レイヤを Streets にリネームします。
• Right-click on it in the Layers list (by default, the pane along the left-hand side of the screen).
• Click Rename in the dialog that appears and rename it, pressing the Enter key when done.
• Repeat the vector adding process, but this time select the Generalised_Zoning_Dissolve_UTM33S.shp file in the Zoning directory.
• Rename it to Zoning.

ラスタでは …

• Click on the Add Raster Layer button, or use the Layer → Add Raster Layer... menu item.
• Navigate to the appropriate file, select it, and click Open.
• Do this for each of the two raster files. The files you want are DEM/reproject/DEM and Rain-fall/reprojected/rainfall.tif.
• Rename the rainfall raster to Rainfall (with an initial capital). Initially when you load them, the images will be gray rectangles. Don’t worry, this will be changed later.
• マップを保存します。

In order to properly see what’s going on, the symbology for the layers needs to be changed.

9.4.5 ベクトレイヤのシンボロジの変更

• In the Layers list, right-click on the Streets layer.
• Select Properties from the menu that appears.
• 表示されているダイアログでスタイル タブに切り替えます。
• Click on the button labeled Change, with a square showing the current color of the Streets layer.
• 表示されるダイアログで新しい色を選択します。
• Click OK.
• Click OK again in the Layer Properties dialog. This will change the color of the Streets layer.
• Follow a similar process for the Zoning layer and choose an appropriate color for it.

9.4.6 ラスタレイヤのシンボロジの変更

ラスタレイヤシンボロジはどこが違います。

• Open the Properties dialog for the Rainfall raster.
• Switch to the Style tab. You’ll notice that this style dialog is very different from the version used for vector layers.
• Ensure that the button Use standard deviation is selected.
• Change the value in the associated box to 2.00 (it should be set to 0.00 by default).
• Under the heading Contrast enhancement, change the value of the Current dropdown list to Stretch to MinMax.
• Click OK. The “Rainfall” raster, if visible, should change colors, allowing you to see different brightness values for each pixel.
• Repeat this process for the DEM, but set the standard deviations used for stretching to 4.00.

9.4.7 レイヤ順の変更

• In the Layers list, click and drag layers up and down to change the order they appear in on the map.
• Newer versions of QGIS may have a Control rendering order checkbox beneath the Layers list. Ensure that it is checked.

Now that all the data is loaded and properly visible, the analysis can begin. It is best if the clipping operation is done first. This is so that no processing power is wasted on computing values in areas that aren’t going to be used anyway.

9.4.8 正しい地区の検索

• Load the vector layer admin_boundaries/Western_Cape_UTM33S.shp into your map.
• Districts にリネームします。
• Right-click on the Districts layer in the Layers list.
• In the menu that appears, select the Query... menu item. The Query Builder dialog appears.
You will now build a query to select only the following list of districts:
• Bellville,
• Cape,
• Goodwood,
• Kuils River,
• Mitchells Plain,
• Simons Town, そして
• Wynberg.
• In the Fields list, double-click on the NAME_2 field. It appears in the SQL where clause text field below.
• Click the = button; an = sign is added to the SQL query.
• Click the All button below the (currently empty) Values list. After a short delay, this will populate the Values list with the values of the selected field (NAME_2).
• Double-click the value Bellville in the Values list. As before, this will be added to the SQL query.

In order to select more than one district, you’ll need to use the OR boolean operator.

• Click the OR button and it will be added to the SQL query.
• Using a process similar to the above, add the following to the existing SQL query:
  "NAME_2" = 'Cape'
• Add another OR operator, then work your way through the list of districts above in a similar fashion.
• The final query should be
"NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" = 'Simons Town' OR "NAME_2" = 'Wynberg'

• Click OK. The districts shown in your map are now limited to those in the list above.

9.4.9 ラスタのクリップ

Now that you have an area of interest, you can clip the rasters to this area.

• Ensure that the only layers that are visible are the DEM, Rainfall and Districts layers.
• Districts must be on top so that they are visible.
• Open the clipping dialog by selecting the menu item Raster → Extraction → Clipper.
• In the Input file (raster) dropdown list, select the DEM layer.
• Specify an output location in the Output file text field by clicking the Select... button.
• districts shown in your map are now limited to those in the list above.

• Click OK. The districts shown in your map are now limited to those in the list above.

9.4.10 マップをクリーンアップします。

• Remove the original Rainfall and DEM layers from the Layers list:
• これらのレイヤ上で右クリックし、削除を選択します。
  – This will not remove the data from your storage device, it will merely take it out of your map.
• Deactivate the labels on the Streets layer:
  – ラベルのボタンをクリックします。
  – Uncheck the Label this layer with box.
  – Click OK.
• 再度 Streets をすべて表示します。
  – Right-click on the layer in the Layers list.
  – クエリを選択します。
• In the Query dialog that appears, click the Clear button, then click OK.

9.4. Lesson: 補足の実習
• Wait while the data is loaded. All the streets will now be visible.
• Change the raster symbology as before (see Changing the symbology of raster layers).
• マップを保存します。
• You can now hide the vector layers by unchecking the box next to them in the Layers list. This will make the map render faster and will save you some time.

In order to create the hillshade, you will need to use a plugin that was written for this purpose.

9.4.11 Activating the Raster Terrain Analysis plugin

This plugin is included by default in QGIS 1.8. However, it may not be immediately visible. To check if it is accessible on your system:

• Click on the menu item Plugins → Manage Plugins....
• Ensure that the box next to Raster Terrain Analysis plugin is selected.
• Click OK.

You will now have access to this plugin via the Raster → Terrain analysis menu item.

Remember that plugins may sometimes depend on certain Python modules being installed on your system. Should a plugin refuse to work while complaining of missing dependencies, please ask your tutor or lecturer for assistance.

9.4.12 陰影図の作成

• In the Layers list, ensure that the DEM is the active layer (i.e., it is highlighted by having been clicked on).
• Click on the Raster → Terrain analysis → Hillshade menu item to open the Hillshade dialog.
• Specify an appropriate location for the output layer and call it hillshade.
• Check the Add result to project box.
• Click OK.

処理が完了するのを待ちます。

The new hillshade layer has appeared in your Layers list.

• Right-click on the hillshade layer in your Layers list and bring up the Properties dialog.
• Click on the Transparency tab and set the transparency slider to 80%.
• ダイアログでOKをクリックします。
• Note the effect when the transparent hillshade is superimposed over the clipped DEM.

9.4.13 傾斜

• Click on the menu item Raster → Terrain analysis.
• Select the Slope analysis type, with the clipped DEM as the input layer.
• Specify an appropriate file name and location for output purposes.
• Check the Add result to project box.
• Click OK.

The slope image has been calculated and added to the map. However, as usual it is just a gray rectangle. To properly see what’s going on, change the symbology as follows.

• Open the layer Properties dialog (as usual, via the right-click menu of the layer).
・スタイル タブをクリックします。
・Where it says Grayscale (in the Color map dropdown menu), change it to Pseudocolor.
・Ensure that the Use standard deviation radio button is selected.

9.4.14 傾斜方位

・Use the same approach as for calculating the slope, but select Aspect in the initial dialog box.
Remember to save the map periodically.

9.4.15 ラスタの再階級

・Click the menu item Raster → Raster calculator.
・Specify your Rasterprac directory as the location for the output layer.
・Ensure that the Add result to project box is selected.

In the Raster bands list on the left, you will see all the raster layers in your Layers list. If your Slope layer is called slope, it will be listed as slope@1.

The slope needs to be between 15 and 60 degrees. Everything less than 15 or greater than 60 must therefore be excluded.

・Using the list items and buttons in the interface, build the following expression:

\[((\text{slope@1} < 15) \text{ OR } (\text{slope@1} > 60)) = 0\]

・Set the Output layer field to an appropriate location and file name.
・Click OK.

Now find the correct aspect (east-facing: between 45 and 135 degrees) using the same approach.

・次の式を組み立てます:

\[((\text{aspect@1} < 45) \text{ OR } (\text{aspect@1} > 135)) = 0\]

・Find the correct rainfall (greater than 1200mm) the same way. Build the following expression:

\[(\text{rainfall@1} < 1200) = 0\]

Having reclassified all the rasters, you will now see them displayed as gray rectangles in your map (assuming that they have been added to the map correctly). To properly display raster data with only two classes (1 and 0, meaning true or false), you will need to change their symbology.

9.4.16 再階級されたレイヤのスタイルの設定

・Open the Style tab in the layer’s Properties dialog as usual.
・Under the heading Load min / max values from band, select the Actual (slower) radio button.
・Click the Load button.

The Custom min / max values fields should now populate with 0 and 1, respectively. (If they do not, then there was a mistake with your reclassification of the data, and you will need to go over that part again.)

・Under the heading Contrast enhancement, set the Current dropdown list to Stretch To MinMax.
・Click OK.
・Do this for all three reclassified rasters, and remember to save your work!
The only criterion that remains is that the area must be $250\text{m}$ away from urban areas. We will satisfy this requirement by ensuring that the areas we compute are $250\text{m}$ or more from the edge of a rural area. Hence, we need to find all rural areas first.

### 9.4.17 農村地域の検索

- Hide all layers in the *Layers list*.
- Unhide the *Zoning* vector layer.
- Right-click on it and bring up the *Query* dialog.
- 次のクエリをビルズします:
  
  "Gen_Zoning" = 'Rural'

  See the earlier instructions for building the *Streets* query if you get stuck.
- When you’re done, close the *Query* dialog.

You should see a collection of polygons from the *Zoning* layer. You will need to save these to a new layer file.

- On the right-click menu for *Zoning*, select *Save as*....
- Save your layer under the *Zoning* directory.
- 出力ファイル名を rural.shp とします。
- Click *OK*.
- レイヤをマップに追加します。
- Click the menu item *Vector → Geoprocessing Tools → Dissolve*.
- Select the *rural* layer as your input vector layer, while leaving the *Use only selected features* box unchecked.
- Under *Dissolve field*, select — Dissolve all —.
- Save your layer under the *Zoning* directory.
- Click *OK*. A dialog will appear asking whether you want to add the new layer to the TOC (*Table of Contents*, referring to the *Layers list*).
- はいをクリックします。
- ディゾルブ ダイアログを閉じます。
- Remove the *rural* and *Zoning* layers.
- マップを保存します。

Now you need to exclude the areas that are within $250\text{m}$ from the edge of the rural areas. Do this by creating a negative buffer, as explained below.

### 9.4.18 Creating a negative buffer

- Click the menu item *Vector → Geoprocessing Tools → Buffer(s)*.
- In the dialog that appears, select the *rural_dissolve* layer as your input vector layer (*Use only selected features* should not be checked).
- Select the *Buffer distance* button and enter the value $-250$ into the associated field; the negative value means that the buffer must be an internal buffer.
- Check the *Dissolve buffer results* box.
- Set the output file to the same directory as the other rural vector files.
- Name the output file rural_buffer.shp.
• Click **Save**.
• Click **OK** and wait for the processing to complete.
• Select **Yes** on the dialog that appears.
• Close the **Buffer** dialog.
• Remove the *rural_dissolve* layer.

In order to incorporate the rural zones into the same analysis with the three existing rasters, it will need to be rasterized as well. But in order for the rasters to be compatible for analysis, they will need to be the same size. Therefore, before you can rasterize, you’ll need to clip the vector to the same area as the three rasters. A vector can only be clipped by another vector, so you will first need to create a bounding box polygon the same size as the rasters.

### 9.4.19 パウンディングボックス作成

- Click on the menu item **Layer -> New -> New Shapefile Layer**...  
- Under the **Type** heading, select the **Polygon** button.
- Click **Specify CRS** and set the coordinate reference system **WGS 84 / UTM zone 33S : EPSG:32733**.
- **OK** をクリックします。
- Click **OK** on the **New Vector Layer** dialog as well.
- Save the vector in the **Zoning** directory.
- Name the output file **bbox.shp**.
- Hide all layers except the new **bbox** layer and one of the reclassified rasters.
- Ensure that the **bbox** layer is highlighted in the **Layers list**.
- Navigate to the **View > Toolbars** menu item and ensure that **Digitizing** is selected. You should then see a toolbar icon with a pencil or koki on it. This is the **Toggle editing** button.
- Click the **Toggle editing** button to enter **edit mode**. This allows you to edit a vector layer.
- Click the **Add feature** button, which should be nearby the **Toggle editing** button. It may be hidden behind a double arrow button; if so, click the double arrows to show the **Digitizing** toolbar’s hidden buttons.
- With the **Add feature** tool activated, left-click on the corners of the raster. You may need to zoom in with the mouse wheel to ensure that it is accurate. To pan across the map in this mode, click and drag in the map with the middle mouse button or mouse wheel.
- For the fourth and final point, right-click to finalize the shape.
- **シェープ ID の任意の番号を入力します。**
- Click **OK**.
- 編集を保存 ボタンをクリックします。
- Click the **Toggle editing** button to stop your editing session.
- マップを保存します。

Now that you have a bounding box, you can use it to clip the rural buffer layer.
9.4.20 ベクタレイヤのクリップ

- Ensure that only the bbox and rural_buffer layers are visible, with the latter on top.
- Click the menu item Vector > Geoprocessing Tools > Clip.
- In the dialog that appears, set the input vector layer to rural_buffer and the clip layer to bbox, with both Use only selected features boxes unchecked.
- Put the output file under the Zoning directory.
- Name the output file rural_clipped.
- Click OK.
- When prompted to add the layer to the TOC, click Yes.
- Click on the menu item Vector > Geoprocessing Tools > Clip.
- Compare the three vectors and see the results for yourself.
- Remove the bbox and rural_buffer layers, then save your map.

Now it’s ready to be rasterized.

9.4.21 ベクタレイヤのラスタ化

You’ll need to specify a pixel size for a new raster that you create, so first you’ll need to know the size of one of your existing rasters.

- Open the Properties dialog of any of the three existing rasters.
- Switch to the Metadata tab.
- Make a note of the X and Y values under the heading Dimensions in the Metadata table.
- Click on the menu item Vector > Geoprocessing Tools > Rasterize.
- Select rural_clipped as your input layer.
- Set an output file location inside the Zoning directory.
- Name the output file rural_raster.tif.
- Check the New size box and enter the X and Y values you made a note of earlier.
- Check the Load into canvas box.
- Click the pencil icon next to the text field which shows the command that will be run. At the end of the existing text, add a space and then the text -burn 1. This tells the Rasterize function to “burn” the existing vector into the new raster and give the areas covered by the vector the new value of 1 (as opposed to the rest of the image, which will automatically be 0).
- Click OK.
- The new raster should show up in your map once it has been computed.
- The new raster will look like a grey rectangle you may change the display style as you did for the reclassified rasters.
- The new raster should show up in your map once it has been computed.

Now that you have all four criteria each in a separate raster, you need to combine them to see which areas satisfy all the criteria. To do so, the rasters will be multiplied with each other. When this happens, all overlapping pixels with a value of 1 will retain the value of 1, but if a pixel has the value of 0 in any of the four rasters, then it will be 0 in the result. In this way, the result will contain only the overlapping areas.
9.4.22 ラスタの結合

- Click the Raster → Raster calculator menu item.
- Build the following expression (with the appropriate names for your layers, depending on what you called them):
  
  \[ [\text{Rural raster}] \times [\text{Reclassified aspect}] \times [\text{Reclassified slope}] \times [\text{Reclassified rainfall}] \]

- Set the output location to the Rasterprac directory.
- Name the output raster cross_product.tif.
- Ensure that the Add result to project box is checked.
- OK をクリックします。
- Change the symbology of the new raster in the same way as you set the style for the other reclassified rasters. The new raster now properly displays the areas where all the criteria are satisfied.

To get the final result, you need to select the areas that are greater than 6000m^2. However, computing these areas accurately is only possible for a vector layer, so you will need to vectorize the raster.

9.4.23 ラスタのベクトライズ

- Click on the menu item Raster → Conversion → Polygonize.
- Select the cross_product raster.
- Set the output location to Rasterprac.
- Name the file candidate_areas.shp.
- Ensure that Load into canvas when finished is checked.
- OK をクリックします。
- 処理が完了したらダイアログを閉じます。

All areas of the raster have been vectorized, so you need to select only the areas that have a value of 1.

- Open the Query dialog for the new vector.
- クエリのビルト:
  
  "DN" = 1

- Click OK.
- Create a new vector file from the results by saving the candidate_areas vector after the query is complete (and only the areas with a value of 1 are visible). Use the Save as... function in the layer’s right-click menu for this.
- Save the file in the Rasterprac directory.
- Name the file candidate_areas_only.shp.
- マップを保存します。

9.4.24 各ポリゴンの面積の計算

- Open the new vector layer’s right-click menu.
- 属性テーブルを開くを選択します。
- Click the Toggle editing mode button along the bottom of the table, or press Ctrl+E.
- Click the Open field calculator button along the bottom of the table, or press Ctrl+I.
• Under the New field heading in the dialog that appears, enter the field name area. The output field type should be an integer, and the field width should be 10.

• In Field calculator expression, type:

\$area

This means that the field calculator will calculate the area of each polygon in the vector layer and will then populate a new integer column (called area) with the computed value.

• Click OK.

• Do the same thing for another new field called id. In Field calculator expression, type:

\$id

This ensures that each polygon has a unique ID for identification purposes.

• Click Toggle editing mode again, and save your edits if prompted to do so.

9.4.25 与えられたサイズの面積を選択

Now that the areas are known:

• Build a query (as usual) to select only the polygons larger than 6000m^2. The query is:

"area" > 6000

• Save the selection as a new vector layer called solution.shp.

You now have your solution areas, from which you will pick the one nearest to your house.

9.4.26 あなたの家のデジタイズ

• Create a new vector layer as before, but this time, select the Type value as being a Point.
• Ensure that it is in the correct CRS!
• Name the new layer house.shp.
• Finish creating the new layer.
• Enter edit mode (while the new layer is selected).
• Click the point where your house or other current place of residence is, using the streets as a guide. You might have to open other layers to help you find your house. If you don’t live anywhere nearby, just click somewhere among the streets where a house could conceivably be.

• シェープ ID の任意の番号を入力します。
• Click OK.
• Save your edits and exit edit mode.
• マップを保存します。

You will need to find the centroids (“centers of mass”) for the solution area polygons in order to decide which is closest to your house.

9.4.27 ポリゴンの中心点の算出

• Click on the Vector → Geometry Tools → Polygon centroids menu item.
• Specify the input layer as solution.shp.
• Provide the output location as Rasterprac.
• Call the destination file solution_centroids.shp.
• Click OK and add the result to the TOC (Layers list), then close the dialog.
• Drag the new layer to the top of the layer order so that you can see it.

9.4.28 Calculate which centroid is closest to your house

• Click on the menu item Vector –> Analysis Tools –> Distance matrix.
• The input layer should be your house, and the target layer solution_centroids. Both of these should use the id field as their unique ID field.
• The output matrix type should be linear.
• Set an appropriate output location and name.
• Click OK.
• Open the file in a text editor (or import it into a spreadsheet). Note which target ID is associated with the shortest Distance. There may be more than one at the same distance.
• Build a query in QGIS to select only the solution areas closest to your house (selecting it using the id field).

This is the final answer to the research question.

For your submission, include the semi-transparent hillshade layer over an appealing raster of your choice (such as the DEM or the slope raster, for example). Also include the polygon of the closest solution area(s), as well as your house. Follow all the best practices for cartography in creating your output map.
Chapter 10

Module: プラグイン

プラグインを使用すると、QGIS の機能的な提供を拡張することができます。このモジュールでは、プラグインを有効にして使用する方法をお見せします。

10.1 Lesson: プラグインのインストールと管理

プラグインを使い始めるにはそれらをどのようにダウンロードし、インストールし、有効化するのか知る必要があります。では、プラグインインストーラ と プラグインマネージャ の使い方を学びましょう。

このレッスンの目標: QGIS のプラグインシステムを理解して使います。

10.1.1 Follow Along: プラグインの管理

・プラグインマネージャ を開くには、メニュー プラグイン → プラグインの管理とインストール をクリックします。

・開かれたダイアログで Processing プラグインを探しましょう。
・このプラグインの隣のボックスをクリックしてチェックを外し、プラグインをアンインストールします。

・Close をクリックします。

・メニューを見ると Processing メニューがなくなったことに気付くでしょう。あなたが以前使っていたプロセッシングの機能の多くが消えてしまいます。それらはプロセッシング プラグインの一部だからです。再び使用するには有効化される必要があります。

・プラグインマネージャをもう一度開き、プロセッシング プラグインの隣のチェックボックスをクリックして再有効化し、閉じる をクリックします。

・プロセッシング メニューが再び利用可能になったはずです。

10.1.2 Follow Along: 新しいプラグインのインストール
有効化・無効化できるプラグインはインストールされているものです。

・新しいプラグインをインストールするには プラグインマネージャ ダイアログのインストールされていないオプションを選択します。あなたがインストール可能なプラグインはここにリストされます。このリストはあなたのシステム設定によって異なります。
・表示されている一覧の中から任意のプラグインを選択するとその情報を見ることができます。

・プラグイン情報パネルの下にあるプラグインをインストールボタンをクリックするとプラグインをインストールすることができます。

10.1.3 🟢 Follow Along: 追加的なプラグインリポジトリの設定
あなたが利用可能なプラグインはどのプラグインリポジトリが設定されているかによって変わります。QGISのプラグインはオンラインでリポジトリに保存されています。デフォルトでは公式リポジトリだけが
有効になっていて、公式プラグインにだけアクセスすることができます。これらは通常あなたが最初に利用しようと思うプラグインです。なぜなら、これらはよくテストされておりデフォルトで QGIS に含まれているものであるためです。

しかしデフォルトのものより多くのプラグインを試すこともできます。まず追加的なリポジトリの設定をします。

- プラグインマネージャ ダイアログの 設定 タブを開きます:

  ![プラグインマネージャ ダイアログ](image)

  - 新しいリポジトリを追加するには 追加 をクリックします。
  - 設定したい新しいリポジトリの名前と URL を入力します。利用可能にするチェックボックスがチェックされていることを確認します。

  ![Repository details](image)

  - 新しいプラグインリポジトリがプラグインリポジトリの一覧の中に表示されます。
10.1.4 In Conclusion
QGISでプラグインをインストールするのは単純で効果的です！

10.1.5 What’s Next?
次に、例としていくつかの便利なプラグインを紹介します。

10.2 Lesson: 役に立つQGISプラグイン
プラグインをインストールして有効化・無効化することができるようになりました。それでもいくつかの便利なプラグインの例を見て、これが実際にどのように役に立つか見ていきましょう。
このレッスンの目標：プラグインインターフェースに慣れ、いくつかの便利なプラグインを使ってみる。

10.2.1 Follow Along: ラスタ地形解析プラグイン
・新しい地図にexercise_data/raster/SRTMのsrtm_41_19.tifラスタデータセットを読み込みます。
ラスタ解析に関するレッスンから、あなたは既にラスタの解析機能を知っています。あなたは GDAL ツール（ラスタ -> 解析）からアクセス可能）を使用しました。しかし、ラスタ地形解析プラグインについても知っておく方がいいでしょう。これは QGIS の新しいバージョンでは標準機能なので、別にインストールする必要はありません。

・プラグインマネージャを開き、ラスタ地形解析プラグインが有効になっていることをチェックします。

・ラスタメニューを開くと、地形解析サブメニューがあります。
・地形解析 → レリーフをクリックして、次のオプションを入力します:

・新しいファイルを exercise_data/plugins/relief.tif に保存します（必要なら新しいフォルダを作成します）。
10.2. Lesson: 役立つ QGIS プラグイン

- 出力形式とZファクタは変更しません。
- 結果をプロジェクトに追加するボックスはチェックされていることを確認します。
- 自動的に作成するボタンをクリックします。下にリストが作成されます:

これらのプラグインがレリーフを作成するのに使う色です。
- お好みに応じてこれらの色は変更することができます。変更するには各色の横棒をダブルクリックします。例えば:

- OK を押すとレリーフが作成されます:
Follow Along: OpenLayers プラグイン

- Start a new map and add the roads.shp layer to it.
- Zoom in over the Swellendam area.
- Using the Plugin Manager, find a new plugin by entering the word OpenLayers in the Filter field.
- Select the OpenLayers Layers plugin from the filtered list:
• Click the Install plugin button to install.
• When it’s done, close the Plugin Manager.

Before using it, make sure that both your map and the plugin are configured properly:
• Open the plugin’s settings by clicking on Plugins → OpenLayers plugin → OpenLayers Overview.
• Use the panel to choose a map type you want. In this example, we’ll use the “Hybrid” type map, but you can choose any others if you want.

• Open the Project Properties Dialog by selecting Project → Project Properties from the menu.
• Enable “on the fly” projection and use the Google Mercator projection:
Now use the plugin to give you a Google map of the area. You can click on **Plugins → OpenLayers Plugin → Add Google Hybrid Layer** to add it:

This will load a new raster image in from Google that you can use as a backdrop, or to help you find out where you are on the map. Here is such a layer, with our own vector road layer as overlay:
You may need to drag your roads layer above the Google layer to make it visible above the background layer. It may also be necessary to zoom to the extent of the roads layer to re-center the map.

10.2.3 Follow Along: GeoSearch プラグイン

- Start a new map with no datasets.
- Open the Plugin Manager and filter for the GeoSearch Plugin and click Install Plugin to install it.
• Close the Plugin Manager.

• You can now use the GeoSearch plugin to search for placenames. Click on Plugins –> GeoSearch Plugin –> GeoSearch to open the GeoSearch dialog.

• Search for Swellendam in the GeoSearch Dialog to locate it on your map:
10.2.4 In Conclusion

QGISではたくさんの便利なプラグインを利用することができます。ビルトインツールを用いてこれらのプラグインを管理すれば、新しいプラグインを見つけ、それらを最適に利用することができます。

10.2.5 What’s Next?

次はリモートサーバにホストされているレイヤをリアルタイムで使う方法を見ていきます。
Chapter 11

Module: オンラインリソース

マップのデータソースを検討する際に、あなたが使っているコンピュータ上に保存したデータに限定される必要はありません。あなたがインターネットに接続されている限り、ロードすることができるオンラインのデータソースがあります。

このモジュールでは、2種類の Web ベースの GIS サービスについて学習します: Web Mapping Services (WMS) と Web Feature Services (WFS)。

11.1 Lesson: Web Mapping Services

Web Mapping Service (WMS) は、リモートサーバ上でホストされたサービスです。ウェブサイトと同じ様に、サーバーへの接続することでアクセスができます。QGIS を使用すると、既存のマップに直接 WMS をロードすることができます。

From the lesson on plugins, you will remember that it's possible to load a new raster image from Google, for example. However, this is a once-off transaction: once you have downloaded the image, it doesn't change. A WMS is different in that it's a live service that will automatically refresh its view if you pan or zoom on the map.

**このレッスンの目標:** WMS を使用して制限を知ること。

11.1.1 Follow Along: WMS レイヤの読み込み

For this exercise, you can either use the basic map you made at the start of the course, or just start a new map and load some existing layers into it. For this example, we used a new map and loaded the original places and landuse layers and adjusted the symbology:
Before starting to add the WMS layer, first deactivate “on the fly” projection. This may cause the layers to no longer overlap properly, but don’t worry: we’ll fix that later.

WMS 레이어을 추가하는 경우, WMS 레이어의 추가 버튼을 클릭합니다.

Remember how you connected to a SpatiaLite database at the beginning of the course. The landuse, places, and water layers are in that database. To use those layers, you first needed to connect to the database. Using a WMS is similar, with the exception that the layers are on a remote server.

To create a new connection to a WMS, click on the New button.

You’ll need a WMS address to continue. There are several free WMS servers available on the Internet. One of these is terrestris, which makes use of the OpenStreetMap dataset.

この WMS を利用するには、このように、今表示しているダイアログで設定します。
• The value of the URL field should be http://ows.terrestris.de/osm/service.

• Click OK. You should see the new WMS server listed:
• Click Connect. In the list below, you should now see these new entries loaded:

WMSサーバにホストされたレイヤがすべてあります。
• Click once on the OSM-WMS layer. This will display its Coordinate Reference System:

Since we’re not using WGS 84 for our map, let’s see all the CRSs we have to choose from.

• Click the Change button. You will see a standard Coordinate Reference System Selector dialog.

• We want a projected CRS, so let’s choose WGS 84 / Pseudo Mercator.
• Click OK.
• Click Add and the new layer will appear in your map as OSM-WMS.
• In the Layers list, click and drag it to the bottom of the list.

You will notice that your layers aren’t located correctly. This is because “on the fly” projection is disabled. Let’s enable it again, but using the same projection as the OSM-WMS layer, which is WGS 84 / Pseudo Mercator.
• “オンザフライ” 再投影を有効にします。
• In the CRS tab (Project Properties dialog), enter the value pseudo in the Filter field:
• リストから WGS 84 / Pseudo Mercator を選択します。

• Click OK.

• Now right-click on one of your own layers in the Layers list and click Zoom to layer extent. You should see the Swellendam area:
Note how the WMS layer’s streets and our own streets overlap. That’s a good sign!

WMS の性質と限界

By now you may have noticed that this WMS layer actually has many features in it. It has streets, rivers, nature reserves, and so on. What’s more, even though it looks like it’s made up of vectors, it seems to be a raster, but you can’t change its symbology. Why is that?

This is how a WMS works: it’s a map, similar to a normal map on paper, that you receive as an image. What usually happens is that you have vector layers, which QGIS renders as a map. But using a WMS, those vector layers are on the WMS server, which renders it as a map and sends that map to you as an image. QGIS can display this image, but can’t change its symbology, because all that is handled on the server.

This has several advantages, because you don’t need to worry about the symbology. It’s already worked out, and should be nice to look at on any competently designed WMS.

On the other hand, you can’t change the symbology if you don’t like it, and if things change on the WMS server, then they’ll change on your map as well. This is why you sometimes want to use a Web Feature Service (WFS) instead, which gives you vector layers separately, and not as part of a WMS-style map.

This will be covered in the next lesson, however. First, let’s add another WMS layer from the terrestris WMS server.

11.1.2 Try Yourself

- レイヤリストで OSM-WSM レイヤを隠します。
- Add the “ZAF CGS 1M Bedrock Lithostratigraphy” WMS server at this URL: http://196.33.85.22/cgi-bin/ZAF_CGS_Bedrock_Geology/wms
- Load the BEDROCKGEOLOGY layer into the map (use the Add WMS Layer button as before). Remember to check that it’s in the same WGS 84 / World Mercator projection as the rest of your map!
- You might want to set its Encoding to JPEG and its Tile size option to 200 by 200, so that it loads faster:
11.1.3  🌈 Try Yourself

• 背景で不要にレンダリングされるのを防ぐため、すべての WMS レイヤを非表示にします。
• Add the “OGC” WMS server at this URL: http://ogc.gbif.org:80/wms
• bluemarble レイヤを追加します。

結果の確認

11.1.4  🌍 Try Yourself

Part of the difficulty of using WMS is finding a good (free) server.

• Find a new WMS at spatineo.com (or elsewhere online). It must not have associated fees or restrictions, and must have coverage over the Swellendam study area.

Remember that what you need in order to use a WMS is only its URL (and preferably some sort of description).

結果の確認

11.1.5 In Conclusion

Using a WMS, you can add inactive maps as backdrops for your existing map data.

11.1.6 Further Reading

• spatineo.com
• Geopole.org
• OpenStreetMap.org list of WMS servers
11.1.7 What’s Next?

Now that you’ve added an inactive map as a backdrop, you’ll be glad to know that it’s also possible to add features (such as the other vector layers you added before). Adding features from remote servers is possible by using a Web Feature Service (WFS). That’s the topic of the next lesson.

11.2 Lesson: Web Feature Services

Web Feature Service (WFS) は QGIS で直接読み込む形式の GIS データをユーザに提供します。編集できない地図のみを提供する WMS とは異なり、WFS では地物それ自体へアクセスすることができます。

このレッスンの目標: WFS を使用して WMS との違いを理解します。

11.2.1 Follow Along: WFS レイヤの読み込み

- 新しい地図を開きます。これはデモを目的としており保存されません。
- “オンラインライ” 再投影がオフになっていることを確認して下さい。
- WFS レイヤの追加 ボタンをクリックします:

- 新規 ボタンをクリックします。
- 表示されるダイアログで 名称に nsidc.org, URL に http://nsidc.org/cgi-bin/atlas_south?version=1.1.0 と入力します。

- OK をクリックすると新しい接続が サーバーコネクション に表示されます。
- 接続 をクリックします。利用可能なレイヤのリストが表示されます:
• `south_poles_wfs`レイヤを見つけます。

• レイヤをクリックして選択します:
・追加 をクリックします。
レイヤの読み込みにしばらく時間がかかることがあります。読み込みが完了したら地図に表示されます。南極大陸の輪郭の上に表示するとこうなります（同じサーバで antarctica_country_border の名前で利用可能です）:

WMS レイヤとはどのように違うのですか? それはレイヤの属性を見ると明らかになります。
・south_poles_wfs レイヤの属性テーブルを開きます。このように見えるはずです:

ポイントは属性を持つのでシンボロジを変更し、ラベルを付けることができます。例を示します:
このレイヤの属性データを活用するためにレイヤにラベルを追加します。

WMS レイヤからの違い

A Web Feature Service returns the layer itself, not just a map rendered from it. This gives you direct access to the data, meaning that you can change ts symbology and run analysis functions on it. However, this is at the cost of much more data being transmitted. This will be especially obvious if the layers you’re loading have complicated shapes, a lot of attributes, or many features; or even if you’re just loading a lot of layers. WFS layers typically take a very long time to load because of this.

11.2.2 藍 Follow Along: WFS レイヤのクエリ

WFS レイヤをロードした後に問い合わせをする事は可能ですが、ロードする前に問い合わせをする方が多くの場合に効率的です。そのようにして必要な地物だけを要求すればはるかに少ない帯域幅の使用で済むことになります。

たとえば、現在使用している WFS サーバに countries (excluding Antarctica) というレイヤがあります。既に読み込まれている south_poles_wfs レイヤに対する南アフリカ共和国の位置を知りたいとしましょう（そしておそらく antarctica_country_border レイヤに対する位置も）。これを行うには 2 つの方法があります。countries ... レイヤの全体をロードしてから、いつかのようにクエリを作成することができますが、世界中の国のデータを送信してから南アフリカのデータだけを使用するのは少し帯域幅の無駄と思われます。あなたの接続によっては、このデータセットの読み込みに数分かかることがあります。

サーバからレイヤを読み込む前にフィルターとしてクエリを作成することもできます。

- WFS レイヤの追加 ダイアログで前に使用したサーバに接続して、利用可能なレイヤリストを表示させます。

- Filter フィールドの countries ... レイヤの隣をダブルクリックするか クエリ作成 をクリックします。
・表示されるダイアログでクエリ "Countryeng" = 'South Africa' を作成します.
Filter の値として表示されます。
• 上のように countries レイヤを選択した状態で追加をクリックします。Countryeng の値が South Africa の国だけがレイヤから読み込まれます:

実際にやる必要はありませんが、もし両方の方法を試してみたらフィルタする前にすべての国をロードする方法に比べてはるかに早いことがわかります！

WFS の有用性に関するノート

あなたのニーズが非常に具体的であれば、あなたが必要とする WFS サーバを見つけることは稀です。WFS サービスが比較的まれのある理由は地物全体を表現するには大量のデータを送信する必要があるからです。それゆえに画像だけを送信する WMS ではなく WFS をホストすることは費用対効果がありよくあります。
11.2.3 In Conclusion

あなたがレイヤの属性とジオメトリに直接アクセスする必要がある場合には WFS レイヤは WMS レイヤより好ましいですが、ダウンロードされるデータの量を考慮すると(速度の問題そして容易に利用可能な公開 WFS サーバの不足へとつながります)、必ずしも WMS の代わりに WFS が使用できるとは限りません。

11.2.4 What’s Next?

次は有名な GRASS GIS のためのフロントエンドとして QGIS を使用する方法を説明します。
Chapter 12

Module: GRASS

GRASS (Geographic Resources Analysis Support System) は、幅広く便利な GIS 機能を持つオープンソース GIS として知られています。1984年初めてリリースされ、それ以来、多くの改善や追加機能が見られました。QGIS では、パワフルな GIS ツールとして GRASS を直接利用できます。

12.1 Lesson: GRASS のセットアップ

QGIS で GRASS を使用するにはインターフェイスを少し異なる方法で考える必要があります。QGIS で直接作業しているのではなく QGIS を通じて GRASS で作業していることを覚えておいて下さい。

このレッスンの目標: QGIS で GRASS のプロジェクトを始めます。

12.1.1 Follow Along: 新しい GRASS プロジェクトの開始

QGIS から GRASS を起動するには他のプラグインと同じようにそれをアクティブにする必要があります。まず新しい QGIS プロジェクトを開きます。

・ プラグインマネージャで GRASS を有効にします:
GRASS のツールバーが表示されます:

GRASS を使用する前に マップセットを作成する必要があります。GRASS は常にデータベース環境で動作します。これはあなたが使いたいすべてのデータは GRASS データベースへインポートする必要があることを意味します。

- 新規マップセット ボタンをクリックします:

   GRASS マップセットの構造を説明するダイアログボックスが表示されます。

- exercise_data に grass_db という名前の新しいディレクトリを作成します。

- データベースを構成するためにそれを GRASS が使用するディレクトリとして設定します:
*次へをクリックします。*

GRASS では”ロケーション”を作成する必要があります。それはあなたが作業しようとする地理的地域の最大範囲を記述します。

*新しいロケーション South_Africa を作成しましょう:*
• 次へをクリックします。
• WGS 84 で作業していますので、検索してこの CRS を選択します:
次へをクリックします。
ドロップダウンリストから South Africa の領域を選択して、設定をクリックします。
・次へをクリックします。
・マップセットを作成します。あなたがこれから作業するマップファイルです。
完了したら、設定が正しいことを確認するダイアログが表示されます。

- 完了をクリックします。
- 成功ダイアログで OK をクリックします。

### 12.1.2 Follow Along: GRASS にベクタデータを読み込む

空の地図が用意されました。GRASS にデータを読み込むには 2 段階のプロセスを実行する必要があります。

- QGIS にいつものようにデータを読み込みます。さしあたり roads.shp データセット (exercise_data/epsg4326/ にあります) を使用します。
- 読み込まれたら GRASS ツールボタンをクリックします:
新しいダイアログでモジュールリストを選択します。
フィルタで `v.in.ogr.qgis`と入力してベクタインポートツールを検索します。

`v` は"ベクタ", `in` は GRASS データベースにデータをインポートする関数を意味し、`ogr` はベクタデータの読み込みに使用するソフトウェア・ライブラリです。そして、`qgis` はそのツールが QGIS に既に読み込まれたベクタの中からベクタを探すことを意味します。

このツールを見つけたらクリックして起動します。

ロードされたレイヤに `roads` を設定し、GRASS での名前を混乱を防ぐために `g.roads` に設定します。
ノート：別のインポートオプションがアドバンスドオプションで提供されています。データのインポートに使用する SQL クエリの WHERE 句を追加する機能が含まれます。

- 実行をクリックしてインポートを開始します。
- それが終わったら出力を見るをクリックして新しくインポートされた GRASS レイヤを地図に表示します。
- Close first the import tool (click the Close button to the immediate right of View output), then close the GDAL Tools window.
- オリジナルの roads レイヤを削除します。

今、QGIS の地図に表示されているのはインポートされた GRASS レイヤだけです。

12.1.3 Follow Along: GRASS にラスタデータを読み込む

私たちの DEM は投影座標系の UTM 33S / WGS 84 ですが、GRASS プロジェクトは地理座標系の WGS 84 であることを思い出しましょう。それではまず DEM を再投影します。

- いつものように ラスタレイヤの追加ツールを使用して QGIS の地図に srtm_41_19.tif データセット (exercise_data/raster/SRTM/) の下にあります）を読み込みます。
・GDAL ワープツール (ラスタ → 投影 → ワープ (再投影)) を用いて再投影します。次のように設定します:

![Warp (Reproject) dialog box](image)

・ラスタをオリジナルと同じフォルダに、ファイル名を DEM_WGS84.tif として保存します。それが地図に表示されたたら srtm_41_19.tif データセットを レイヤリスト から削除します。DEM が再投影されたので GRASS データベースに読み込むことができます。
• GRASSツールダイアログを再度開きます。
• モジュールリストタブをクリックします。
• `r.in.gdal.qgis`を検索します。ツールをダブルクリックしてダイアログを開きます。
• 入力レイヤを`DEM_WGS84`に、出力を`g_dem`に設定します。

![GRASS Tools: SouthAfrica/grass_mapset](image)

• 実行をクリックします。
• 処理が完了したら出力を見るをクリックします。
• 現在のタブを閉じ、そしてダイアログボックスを閉じます。
・オリジナルの DEM_WGS84 レイヤは削除できます。

12.1.4 In Conclusion

GRASS はデータを空間データベース構造にロードするため、GRASS のデータ収集ワークフローは QGIS の方法とは多少異なります。しかし、フロントエンドとして QGIS を使用することによって GRASS のデータソースとして QGIS 内の既存レイヤを使用でき、GRASS マップセットのセットアップを簡単にすることができます。

12.1.5 What’s Next?

データは GRASS にインポートされました。GRASS の高度な分析操作を見ることができます。

12.2 Lesson: GRASS ツール

このレッスンでは、あなたに GRASS の機能についてのアイデアを与えるために選り抜きのツールを紹介します。

12.2.1 Follow Along: ラスタの色の設定

・GRASS ツールダイアログを開きます。
・モジュールリストタブのフィルタフィールドで検索することによって r.colors.table モジュールを探します。
・ツールを開き、このように設定します:
ツールを実行するとラスタの色が変更されます:
12.2.2 ースリア: 3D でデータの視覚化

GRASS では DEM を使用して 3 次元でデータを視覚化することができます。使用しようとするツールは GRASS 領域で動作します。現時点ではあなたが前に設定した南アフリカ全体の範囲に設定されています。

- ラスタデータセットのみをカバーする範囲に再定義するために、このボタンをクリックします:

When this tool is activated, your cursor will turn into a cross whe over the QGIS map canvas.

- このツールを使用して、GRASS ラスタの縁を囲む長方形を描きます。
- それができたら GRASS Region 設定 ダイアログの OK をクリックします。
- nviz ツールを検索します:
・このように設定します。
2つのラスタ選択ドロップダウンメニューの右側の地図の領域を使用しますボタンを両方とも有効にして下さい。これで NVIZ がラスタの解像度を正しく評価できるようになります。

実行ボタンをクリックします。

NVIZ は選択されたラスタとベクタを用いて 3D 環境を構成します。これはハードウェアに依存し時間がかかる場合があります。それが終わったら新しいウィンドウで 3D でレンダリングされた地図が表示されます。
height や z-exag, View method の設定を変えてデータの表示を変更してみましょう。ナビゲーション方法に慣れるのに少し時間がかかるかもしれません。

試用を終えたら、NVIZ ウィンドウを閉じます。

12.2.3  Follow Along: Mapcalc ツール

- GRASS ツールのモジュールリストタブで calc を検索します。
- モジュールのリストから r.mapcalc を選択します (r.mapcalcldator ではありません。それはより基本的なもので)
- ツールを起動します。

Mapcalc ダイアログではラスタまたはラスタのコレクションに対して実行される一連の分析を構築することができます。これらのツールを使います:

順番に:
- 地図の追加: 現在の GRASS マップセットからラスタファイルを追加します。
- 定数値を追加: 関数で使用する定数値を追加します。
- 演算子または機能を追加: 入力と出力に接続する演算子や関数を追加します。
- 接続の追加: 要素を接続します。このツールを使用して 1 つのアイテムの赤いドットから他のアイテムの赤いドットへクリック、ドラッグします。正しくコネクタ線に接続されたドットは灰色になります。線やドットが赤の場合、それは正しく接続されていません!
- アイテムを選択: アイテムを選択し、選択したアイテムを移動します。
選択したアイテムを削除: 現在の Mapcalc シートから選択したアイテムを削除します（ラスタはマップセットからは削除されません）。

これらのツールを使用して:

次のアルゴリズムを作成します:

実行をクリックすると、出力はこのようになります:
12.2. Lesson: GRASSツール

• 出力を見るをクリックすると出力が地図に表示されます:

これは地形が500メートルより低いか1000メートルより高いすべての地域を示しています。
12.2.4 In Conclusion

このレッスンでは、GRASSが提供する多くのツールのうちのわずかしかカバーしていません。自分でGRASSの機能を探索するには GRASSツールダイアログを開き、モジュールリストを下へスクロールします。より構造化されたアプローチがよければ モジュールツリー タブではツールが種類ごとに整理されています。
Chapter 13

Module: 評価

Before doing any data analysis, you will need a base map, which will provide your analysis result with context.

13.1 ベースマップの作成

Before doing any data analysis, you will need a base map, which will provide your analysis result with context.

13.1.1 ポイントレイヤの追加

- Add in the point layer. Based on the level that you’re doing the course at, do only what is listed in the appropriate section below:

  - Label the points according to a unique attribute, such as place names. Use a small font and keep the labels inconspicuous. The information should be available, but shouldn’t be a main feature of the map.
  - Classify the points themselves into different colors based on a category. For example, categories could include “tourist destination”, “police station”, and “town center”.

  - Classify the point size by importance: the more significant a feature, the larger its point. However, don’t exceed the point size of 2.00.
  - For features that aren’t located at a single point (for example, provincial/regional names, or town names at a large scale), don’t assign any point at all.
• Don’t use point symbols to symbolize the layer at all. Instead, use labels centered over the points; the point symbols themselves should have no size.

• Use Data defined settings to style the labels into meaningful categories.

• Add appropriate columns to the attribute data if necessary. When doing so, don’t create fictional data - rather, use the Field Calculator to populate the new columns, based on appropriate existing values in the dataset.

13.1.2 ラインレイヤの追加

• Add the road layer and then change its symbology. Don’t label the roads.

• Change the road symbology to a light color with a broad line. Make it somewhat transparent as well.

• Create a symbol with multiple symbol layers. The resulting symbol should look like a real road. You can use a simple symbol for this; for example, a black line with a thin white solid line running down the center. It can be more elaborate as well, but the resulting map should not look too busy.

• If your dataset has a high density of roads at the scale you want to show the map at, you should have two road layers: the elaborate road-like symbol, and a simpler symbol at smaller scales. (Use scale-based visibility to make them switch out at appropriate scales.)

• All symbols should have multiple symbol layers. Use symbols to make them display correctly.

• Do the same as in the section above.

• In addition, roads should be classified. When using realistic road-like symbols, each type of road should have an appropriate symbol; for example, a highway should appear to have two lanes in either direction.

13.1.3 ポリゴンレイヤの追加

• Add the land use layer and change its symbology.

• Classify the layer according to land use. Use solid colors.
• Classify the layer according to land use. Where appropriate, incorporate symbol layers, different symbol types, etc. Keep the results looking subdued and uniform, however. Keep in mind that this will be part of a backdrop!

• Use rule-based classification to classify the land use into general categories, such as “urban”, “rural”, “nature reserve”, etc.

### 13.1.4 Create the raster backdrop

• Create a hillshade from the DEM, and use it as an overlay for a classified version of the DEM itself. You could also use the Relief plugin (as shown in the lesson on plugins).

### 13.1.5 Finalize the base map

• Using the resources you above, create a base map using some or all of the layers. This map should include all the basic information needed to orient the user, as well as being visually unified / “simple”.

### 13.2 Analyze the data

• You are looking for a property that satisfies certain criteria.
• You can decide on your own criteria, which you must document.
• There are some guidelines for these criteria:
  – the target property should be of (a) certain type(s) of land use
  – it should be within a given distance from roads, or be crossed by a road
  – it should be within a given distance from some category of points, like a hospital for example

#### 13.2.1

• Include raster analysis in your results. Consider at least one derived property of the raster, such as its aspect or slope.

### 13.3 最終的なマップ

• Use the Map Composer to create a final map, which incorporates your analysis results.
• Include this map in a document along with your documented criteria. If the map has become too visually busy due to the added layer(s), deselect the layers which you feel are the least necessary.
• Your map must include a title and a legend.
Chapter 14

Module: Forestry Application

In modules 1 through 13, you have already learned quite a lot about QGIS and how to work with it. If you are interested in learning about some basic forestry applications of GIS, following this module will give you the ability to apply what you have learned and will show you some new useful tools.

The development of this module has been sponsored by the European Union.

14.1 Lesson: Forestry Module Presentation

Following this module about a forestry application requires the knowledge you have learned through the modules 1 to 11 of this training manual. The exercises in the following lessons assume you are already capable of doing many of the basic operations in QGIS and only tools that have not been used before are presented in more detail.

Nevertheless, the module follows a basic level throughout the lessons so that if you have previous experience with QGIS, you can probably follow the instructions without problems.

Note that you need to download an additional data package for this module.

14.1.1 Forestry Sample Data

The sample data used in this module can be downloaded here (125 Mb). Download the zip file and extract the forestry\ folder into your exercise_data\ folder.

The forestry related sample data (forestry map, forest data), has been provided by the EVO-HAMK forestry school. The datasets have been modified to adapt to the lessons needs.

The general sample data (aerial images, LiDAR data, basic maps) has been obtained from the National Land Survey of Finland open data service, and adapted for the purposes of the exercises. The open data file download service can be accessed in English here.

警告: As for the rest of the training manual, this module includes instructions on adding, deleting and altering GIS datasets. We have provided training datasets for this purpose. Before using the techniques described here on your own data, always ensure you have proper backups!
14.2 Lesson: Georeferencing a Map

A common forestry task would be the update of the information for a forestry area. It is possible that the previous information for that area dates several years back and was collected analogically (that is, in paper) or perhaps it was digitized but all you have left is the paper version of that inventory data.

Most likely you would like to use that information in your GIS to, for example, compare later with later inventories. This means that you will need to digitize the information at hand using your GIS software. But before you can start the digitizing, there is an important first step to be done, scanning and georeferencing your paper map.

The goal for this lesson: To learn to use the Georeferencer tool in QGIS.

14.2.1 Scan the map

The first task you will have to do is to scan your map. If your map is too big, then you can scan it in different parts but keep in mind that you will have to repeat preprocessing and georeferencing tasks for each part. So if possible, scan the map in as few parts as possible.

If you are going to use a different map that the one provided with this manual, use your own scanner to scan the map as an image file, a resolution of 300 DPI will do. If your map has colors, scan the image in color so that you can later use those colors to separate information from your map into different layers (for ex., forest stands, contour lines, roads...).

For this exercise you will use a previously scanned map, you can find it as rautjarvi_map.tif in the data folder exercise_data/forestry

14.2.2 Follow Along: Georeferencing the scanned map

Open QGIS and set the project’s CRS to ETRS89 / ETRS–TM35FIN in Project → Project Properties → CRS, which is the currently used CRS in Finland. Make sure that Enable ‘on the fly’ CRS transformation is checked, since we will be working with old data that is another CRS.
Save the QGIS project as \texttt{map_digitizing.qgs}.

You will use the georeferencing plugin from QGIS, the plugin is already installed in QGIS. Activate the plugin using the plugin manager as you have done in previous modules. The plugin is named \textit{Georeferencer GDAL}.

To georeference the map:

- Open the georeference tool, \textit{Raster} $\rightarrow$ \textit{Georeferencer} $\rightarrow$ \textit{Georeferencer}.
- Add the the map image file, \texttt{:kdb:\textasciitilde{rautjarvi\_map.tif}}, as the image to georeferenciate, \textit{File} $\rightarrow$ \textit{Open raster}.
- When prompted find and select the \textit{KKJ / Finland zone 2} CRS, it is the CRS that was used in Finland back in 1994 when this map was created.
- Click \textit{OK}.

Next you should define the transformation settings for georeferencing the map:

- Open \textit{Settings} $\rightarrow$ \textit{Transformation settings}.
- Click the icon next to the \textit{Output raster} box, go to the folder and create the folder \texttt{exercise\_data\forestry\digitizing} and name the file as \texttt{rautjarvi\_georef.tif}.
- Set the rest of parameters as shown below.
• Click OK.

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeferenciate this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer’s window.

• Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, x and y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

• Select the Add point tool and click in the intersection of the cross-hairs (pan and zoom as needed).

• In the Enter map coordinates dialogue write the coordinates that appear in the map (X: 2557000 and Y: 6786000).

• Click OK.

The first coordinate for the georeferencing is now ready.
Look for other cross-hairs in the black lines image, they are separated 1000 meters from each other both in North and East direction. You should be able to calculate the coordinates of those points in relation to the first one.

Zoom out in the image and move to the right until you find other cross-haig, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible. Digitize at least three more ground control points in the same way you did the first one. You should end up with something similar to this:

With already three digitized ground control points you will be able to see the georeferencing error as a red line coming out of the points. The error in pixels can be seen also in the GCP table in the $dX[pixels]$ and $dY[pixels]$ columns. The error in pixels should not be higher than 10 pixels, if it is you should review the points you have digitized and the coordinates you have entered to find what the problem is. You can use the image above as a guide.

Once you are happy with your control points save your ground control points, in case that you will need them later, and you will:

- File → Save GCP points as....

14.2. Lesson: Georeferencing a Map 311
In the folder exercise_dataforestrydigitizing, name the file :kdb:'rautjarvi_map.tif.points'.

Finally, georeference your map:

- File → Start georeferencing.
- Note that you named the file already as rautjarvi_georef.tif when you edited the Georeferencer settings.

Now you can see the map in QGIS project as a georeferenced raster. Note that the raster seems to be slightly rotated, but that is simply because the data is KKV / Finland zone 2 and your project is in ETRS89 / ETRS-TM35FIN.

To check that your data is properly georeferenced you can open the aerial image in the exercise_dataforestry folder, named rautjarvi_aerial.tif. Your map and this image should match quite well. Set the map transparency to 50% and compare it to the aerial image.
Save the changes to your QGIS project, you will continue from this point for the next lesson.

14.2.3 In Conclusion

As you have seen, georeferencing a paper map is a relatively straightforward operation.

14.2.4 What’s Next?

In the next lesson, you will digitize the forest stands in your map as polygons and add the inventory data to them.
14.3 Lesson: Digitizing Forest Stands

Unless you are going to use your georeferenced map as a simple background image, the next natural step is to digitize elements from it. You have already done so in the exercises about creating vector data in ..\create_vector_data\create_new_vector, when you digitized the school fields. In this lesson, you are going to digitize the forest stands’ borders that appear in the map as green lines but instead of doing it using an aerial image, you will use your georeferenced map.

The goal for this lesson: Learn a technique to help the digitizing task, digitizing forest stands and finally adding the inventory data to them.

14.3.1 Follow Along: Extracting the Forest Stands Borders

Open your map_digitizing.qgs project in QGIS, that you saved from the previous lesson.

Once you have scanned and georeferenced your map you could start to digitize directly by looking at the image as a guide. That would most likely be the way to go if the image you are going to digitize from is, for example, an aerial photograph.

If what you are using to digitize is a good map, as it is in our case, it is likely that the information is clearly displayed as lines with different colors for each type of element. Those colors can be relatively easy extracted as individual images using an image processing software like GIMP. Such separate images can be used to assist the digitizing, as you will see below.

The first step will be to use GIMP to obtain an image that contains only the forest stands, that is, all those greenish lines that you could see in the original scanned map:

• Open GIMP (if you don’t have it installed yet, download it from the internet or ask your teacher).

• Open the original map image, File → Open, rautjarvi_map.tif in the exercise_data/forestry folder. Note that the forest stands are represented as green lines (with the number of the stand also in green inside each polygon).
Now you can select the pixels in the image that are making up the forest stands’ borders (the greenish pixels):

- Open the tool *Select → By color*.
- With the tool active, zoom into the image (*Ctrl + mouse wheel*) so that a forest stand line is close enough to differentiate the pixels forming the line. See the left image below.
- Click and drag the mouse cursor in the middle of the line so that the tool will collect several pixel color values.
- Release the mouse click and wait a few seconds. The pixels matching the colors collected by the tool will be selected through the whole image.
- Zoom out to see how the greenish pixels have been selected throughout the image.
- If you are not happy with the result, repeat the click and drag operation.
- You pixel selection should look something like the right image below.
Once you are done with the selection you need to copy this selection as a new layer and then save it as separate image file:

- Copy (Ct+C) the selected pixels.
- And paste the pixels directly (Ct+V), GIMP will display the pasted pixels as a new temporary layer in the Layers - Brushes panel as a Floating Selection (Pasted Layer).
- Right click that temporary layer and select To New Layer.
- Click the “eye” icon next to the original image layer to switch it off, so that only the Pasted Layer is visible:
Finally, select File → Export..., set Select File Type (By Extension) as a TIFF image, select the digitizing folder and name it rautjarvi_map_green.tif. Select no compression when asked. You could do the same process with other elements in the image, for example extracting the black lines that represent roads or the brown ones that represent the terrain’ contour lines. But for us, the forest stands is enough.

14.3.2 Try Yourself Georeference the Green Pixels Image

As you did in the previous lesson, you need to georeference this new image to be able to use it with the rest of your data.

Note that you don’t need to digitize the ground control points any more because this image is basically the same image as the original map image, as far as the Georeferencer tool is concerned. Here are some things you should remember:

- This image is also, of course, in KKJ / Finland zone 2 CRS.
- You should use the ground control points you saved, File → Load GCP points.
- Remember to review the Transformation settings.
- Name the output raster as rautjarvi_green_georef.tif in the digitizing folder.

Check that the new raster is fitting nicely with the original map.

14.3.3 Follow Along: Creating Supporting Points for Digitizing

Having in mind the digitizing tools in QGIS, you might already be thinking that it would be helpful to snap to those green pixels while digitizing. That is precisely what you are going to do next create points from those pixels to use them later to help you follow the the forest stands’ borders when digitizing, by using the snapping tools available in QGIS.

- Use the Raster → Conversion → Polygonize (Raster to Vector) tool to vectorize your green lines to polygons. If you don’t remember how, you can review it in Lesson: ラスタのベクタへの変換.
- Save as rautjarvi_green_polygon.shp inside the digitizing folder.

Zoom in and see what the polygons look like. You will get something like this:
Next one option to get points out of those polygons is to get their centroids:

- Open Vector → Geometry tools → Polygon centroids.
- Set your the polygon layer you just got as the input file for the tool.
- Name the output as green_centroids.shp inside the digitizing folder.
- Check Add result to canvas.
- Run the tool to calculate the centroids for the polygons.
Now you can remove the `rautjarvi_green_polygon` layer from the TOC.

Change the symbology of the centroids layer as:

- Open the `Layer Properties` for `green_centroids`.
- Go to the `Style` tab.
- Set the `Unit` to Map unit.
- Set the `Size` to 1.

It is not necessary to differentiate points from each other, you just need them to be there for the snapping tools to use them. You can use those points now to follow the original lines much easily than without them.

### 14.3.4 Follow Along: Digitize the Forest Stands

Now you are ready to start with the actual digitizing work. You would start by creating a vector file of `polygon` type, but for this exercise, there is a shapefile with part of the area of interest already digitized. You will just finish digitizing the half of the forest stands that are left between the main roads (wide pink lines) and the lake:
• Go to the digitizing folder using your file manager browser.
• Drag and drop the forest_stands.shp vector file to your map.

Change the new layer’s symbology so that it will be easier to see what polygons have already been digitized:
  • The filling of the polygon to green.
  • The polygons’ borders to 1 mm.
  • and set the transparency to 50%.

Now, if you remember past modules, we have to set up and activate the snapping options:
  • Go to Settings → Snapping options....
• Activate the snapping the `green_centroids` and the `forest_stands` layers.
• Set their Tolerance to 5 map units.
• Check the Avoid Int. box for the `forest_stands` layer.
• Check Enable topological editing.
• Click Apply.

With these snapping settings, whenever you are digitizing and get close enough to one of the points in the centroids layer or any vertex of your digitized polygons, a pink cross will appear on the point that will be snapped to.

Finally, turn off the visibility of all the layers except `forest_stands` and `rautjarvi_georef`. Make sure that the map image has not transparency any more.

A couple of important things to note before you start digitizing:

• Don’t try to be too accurate with the digitizing of the borders.
• If a border is a straight line, digitize it with just two nodes. In general, digitize using as few nodes as possible.
• Zoom in to close ranges only if you feel that you need to be accurate, for example, at some corners or when you want a polygon to connect with another polygon at a certain node.
• Use the mouse’s middle button to zoom in/out and to pan as you digitize.
• Digitize only one polygon at a time.
• After digitizing one polygon, write the forest stand id that you can see from the map.

Now you can start digitizing:

• Locate the forest stand number 357 in the map window.
• Enable editing for the `forest_stands.shp` layer.
• Select the Add feature tool.
• Start digitizing the stand 357 by connecting some of the dots.
• Note the pink crosses indicating the snapping.
• When you are done, right click to end digitizing that polygon.
• Enter the forest stand id (in this case 357).
• Click OK.

If you were not prompted for the polygon id when you finished digitizing it, go to Settings → Options → Digitizing and make sure that the Suppress attribute form pop-up after feature creation is not checked.

Your digitized polygon will look like this:
Now for the second polygon, pick up the stand number 358. Make sure that the Avoid int. is checked for the forest_stands layer. This option does not allow intersecting polygons at digitizing, so that if you digitize over an existing polygon, the new polygon will be trimmed to meet the border of the already existing polygon/s. You can use this characteristic to automatically obtain a common border.

- Begin digitizing the stand 358 at one of the common corners with the stand 357.
- Then continue normally until you get to the other common corner for both stands.
- Finally, digitize a few points inside polygon 358 making sure that the common border is not intersected. See left image below.
- Right click to finish editing the forest stand 358.
- Enter the id as 358.
- Click OK, your new polygon should show a common border with the stand 357 as you can seen in the image on the right.
The part of the polygon that was overlapping the existing polygon has been automatically trimmed out and you are left with a common border, as you intended it to be.

14.3.5 ⚪ Try Yourself Finish Digitizing the Forest Stands

Now you have two forest stands ready. And a good idea on how to proceed. Continue digitizing on your own until you have digitized all the forest stands that are limited by the main road and the lake.

It might look like a lot of work, but you will soon get used to digitizing the forest stands. It should take you about 15 minutes.

During the digitizing you might need to edit or delete nodes, split or merge polygons. You learned about the necessary tools in ..create_vector_data/topo_editing, now is probably a good moment to go read about them again.

Remember that having Enable topological editing activated, allows you to move nodes common to two polygons so that the common border is edited at the same time for both polygons.

Your result will look like this:
14.3.6  Follow Along: Joining the Forest Stand Data

It is possible that the forest inventory data you have for your map is also written in paper. In that case, you would have to first write that data to a text file or a spreadsheet. For this exercise, the information from the inventory for 1994 (the same inventory as the map) is ready as a comma separated text (csv) file.

Open the rautjarvi_1994.csv file from the exercise_data\forestry in a text editor and note that the inventory data file has an attribute called ID that has the numbers of the forest stands. Those numbers are the same as the forest stands ids you have entered for your polygons and can be used to link the data from the text file to your vector file. You can see the metadata for this inventory data in the file rautjarvi_1994_legend.txt in the same folder.

- Open the .csv in QGIS with the Layer → Add Delimited Text Layer... tool. In the dialog, set it as follows:
To add the data from the .csv file:

- Open the Layer Properties for the forest_stands layer.
- Go to the Joins tab.
- Click the plus sign on the bottom of the dialog box.
- Select rautjarvi_1994.csv as the Join layer and ID as the Join field.
- Make sure that the Target field is also set to id.
- Click OK two times.

The data from the text file should be now linked to your vector file. To see what has happened, open the attribute table for the forest_stands layer. You can see that all the attributes from the inventory data file are now linked to your digitized vector layer.

14.3.7  Try Yourself Renaming Attribute Names and Adding Area and Perimeter

The data from the .csv file is just linked to your vector file. To make this link permanent, so that the data is actually recorded to the vector file you need to save the forest_stands layer as a new vector file. Close the attribute table and right click the forest_stands layer to save it as forest_stands_1994.shp.

Open your new forest_stands_1994.shp in your map if you did not added yet. Then open the attribute table. You notice that the names of the columns that you just added are no very useful. To solve this:

- Add the plugin Table Manager as you have done with other plugins before.
• Make sure the plugin is activated.
• In the TOC select the layer forest_stands_1994.shp.
• Then, go to Vector → Table Manger → Table manager.
• Use the dialogue box to edit the names of the columns to match the ones in the .csv file.

![Table Manager: forest_stands_1994](image)

• Click on Save.
• Select Yes to keep the layer style.
• Close the Table Manager dialogue.

To finish gathering the information related to these forest stands, you might calculate the area and the perimeter of the stands. You calculated areas for polygons in Lesson: Digitizing Forest Stands. Go back to that lesson if you need to and calculate the areas for the forest stands, name the new attribute Area and make sure that the values calculated are in hectares.

Now your forest_stands_1994.shp layer is ready and packed with all the available information.

Save your project to keep the current map presentation in case you need to come back later to it.

14.3. Lesson: Digitizing Forest Stands
14.3.8 In Conclusion

It has taken a few clicks of the mouse but you now have your old inventory data in digital format and ready for use in QGIS.

14.3.9 What’s Next?

You could start doing different analysis with your brand new dataset, but you might be more interested in performing analysis in a dataset more up to date. The topic of the next lesson will be the creation of forest stands using current aerial photos and the addition of some relevant information to your dataset.

14.4 Lesson: Updating Forest Stands

Now that you have digitized the information from the old inventory maps and added the corresponding information to the forest stands, the next step would be to create the inventory of the current state of the forest.

You will digitize new forest stands from scratch following an aerial photo from that forest area. The forestry map you digitized in the previous lesson was created from an aerial Color Infrared (CIR) photograph. This type of imagery, where the infrared light is recorded instead of the blue light, are widely used to study vegetated areas. You will also use a CIR photograph in this lesson.

After digitizing the forest stands, you will add information such as new constraints given by conservation regulations.

The goal for this lesson: To digitize a new set of forest stands from CIR aerial photographs and add information from other data-sets.

14.4.1 Green Icon Comparing the Old Forest Stands to Current Aerial Photographs

The National Land Survey of Finland has an open data policy that allows you downloading a variety of geographical data like aerial imagery, traditional topographic maps, DEM, LiDAR data, etc. The service can be accessed also in English here. The aerial image used in this exercise has been created from two orthorectified CIR images downloaded from that service (M4134F_21062012 and M4143E_21062012).

- Open QGIS and set the project’s CRS to ETRS89 / ETRS-TM35FIN in Project → Project Properties → CRS.
- Make sure that Enable ‘on the fly’ CRS transformation is checked.
- From the exercise_data\forestry\ folder, add the CIR image rautjarvi_aerial.tif and containing the digitized lakes.
- Then save the QGIS project as digitizing_2012.qgs.

The CIR images are from 2012. You can compare the stands that were created in 1994 with the situation almost 20 years ago.

- Add your forest_stands_1994.shp layer.
- Set its styling so that you can see through your polygons.
- Review how the old forest stands follow (or not) what you might visually interpret as an homogeneous forest.

Zoom and pan around the area. You probably will notice that some of the old forest stands might be still corresponding with the image but others are not.

This is a normal situation, as some 20 years have passed by and different forest operations have been done (harvesting, thinning...). It is also possible that the forest stands looked homogeneous back in 1992 to the person who
digitized them but as time has passed some forest has developed in different ways. Or simply the priorities for the forest inventory were different that they are today.

Next, you will create new forest stands for this image without using the old ones. Later you can compare them to see the differences.

14.4.2 Interpreting the CIR Image

Let’s digitize the same area that was covered by the old inventory, limited by the roads and the lake. You don’t have to digitize the whole area, as in the previous exercise you can start with a vector file that already contains most of the forest stands.

• Remove the forest_stands_1994.shp layer.
• Add the forest_stands_2012.shp layer, located in the exercise_data\forestry\ folder.
• Set the styling of this layer so that the polygons have no fill and the borders are visible.
You can see that a region to the North of the inventory area is still missing. That will be your task, digitizing the missing forest stands.

But before you start, spend some time reviewing the forest stands already digitized and the corresponding forest in the image. Try to get an idea about how the stands borders are decided, it helps if you have some forestry knowledge.

Some ideas about what you could identify from the images:

- What forests are deciduous species (in Finland mostly birch forests) and which ones are conifers (in this region pine or spruce). In CIR images, deciduous species will often come as bright red color whereas conifers present dark green colors.

- When a forest stand age changes, by looking at the sizes of the tree crowns that can be identified in the imagery.

- The different forest stands’ densities, for example forest stand were a thinning operation has recently been done would clearly show spaces between the tree crowns and should be easy to differentiate from other
forest stands around it.

- Blueish areas indicate barren terrain, roads and urban areas, crops that have not started to grow etc.
- Don’t use zooms too close to the image when trying to identify forest stands a scale between 1:3 000 and 1:5 000 should be enough for this imagery. See the image below (1 : 4 000 scale):

14.4.3 Try Yourself Digitizing Forest Stands from CIR Imagery

When digitizing the forest stands, you should try to get forest areas that are as homogeneous as possible in terms of tree species, forest age, stand density... Don’t be too detailed though, or you will end up making hundreds of small forest stands that would not be useful at all. You should try to get stands that are meaningful in the context of forestry, not too small (at least 0.5 ha) but not too big either (no more than 3 ha).

With this indications in mind, you can now digitize the missing forest stands.

- Enable editing for forest_stands_2012.shp.
- Set up the snapping and topology options as in the image.
- Remember to click Apply or OK.
Start digitizing as you did in the previous lesson, with the only difference that you don’t have any point layer that you are snapping to. For this area you should get around 14 new forest stands. While digitizing, fill in the Stand_id field with numbers starting at 901.

When you are finished your layer should look something like:

Now you have a new set of polygons defining the different forest stands for the current situation as can interpreted from the CIR images. But you are obviously still missing the forest inventory data, right? For that you will still need to visit the forest and get some sample data that you will use to estimate the forest attributes for each of the forest stands. You will see how to do that in the next lesson.
For the moment, you still can improve your vector layer with some extra information that you have about conservation regulation that should be taken into account for this area.

14.4.4 Follow Along: Updating Forest Stands with Conservation Information

For the area you are working with, it has been researched that the following conservation regulations must be taken into account while doing the forest planning:

- Two locations of a protected species of Siberian flying squirrel (Pteromys volans) have been identified. According to the regulation, an area of 15 meters around the spots must be left untouched.
- A riparian forest of special interest growing along a stream in the area must be protected. In a visit to the field, it was found that 20 meters to both sides of the stream must be protected.

You have one vector file containing the information about the squirrel locations and another containing the digitized stream running in the North area towards the lake. From the exercise_data\forestry\ folder, add the vector files squirrel.shp and stream.shp.

For the protection of the squirrels locations, you are going to add a new attribute (column) to your new forest stands that will contain information about point locations that have to be protected. That information will later be available whenever a forest operation is planned, and the field team will be able to mark the area that has to be left untouched before the work starts.

- Open the attribute table for the squirrel layer.
- You can see that there are two locations that are defined as Siberian flying squirrel, and that the area to be protected is indicated by a distance of 15 meters from the locations.

To join the information about the squirrels to your forest stands, you can use the Join attributes by location:

- Set the forest_stands_2012.shp layer as the gui: Target vector layer.
- As gui: Join vector layer select the squirrel.shp point layer.
- Name the output file as stands_squirrel.shp.
- In gui: Output table select gui: Keep all records (including non-matching target records). So that you keep all the forest stands in the layer instead of only keeping those that are spatially related to the squirrel locations.
- Click gui: OK.
- Select Yes when prompted to add the layer to the TOC.
- Close the dialogue box.
Now you have a new forest stands layer, stands_squirrel where there are new attributes corresponding to the protection information related to the Siberian flying squirrel.

Open the table of the new layer and order it so that the forest stands with information for the Protection attribute. You should have now two forest stands where the squirrel has been located:
Although this information might be enough, look at what areas related to the squirrels should be protected. You know that you have to leave a buffer of 15 meters around the squirrels location:

- Open Vector → Geoprocessing Tools → Buffer.
- Make a buffer of 15 meters for the squirrel layer.
- Name the result squirrel_15m.shp.
You will notice that if you zoom in to the location in the Northern part of the area, the buffer area extends to the neighbouring stand as well. This means that whenever a forest operation would take place in that stand, the protected location should also be taken into account.
From your previous analysis, you did not get that stand to register information about the protection status. To solve this problem:

- Run the *Join attributes by location* tool again.
- But this time use the *squirrel_15m* layer as join layer.
- Name the output file as *stands_squirrel_15m.shp*. 
Open the attribute table for the this new layer and note that now you have three forest stands that have the information about the protection locations. The information in the forest stands data will indicate to the forest manager that there are protection considerations to be taken into account. Then he or she can get the location from the squirrel dataset, and visit the area to mark the corresponding buffer around the location so that the operators in the field can avoid disturbing the squirrels environment.

14.4.5  Try Yourself Updating Forest Stands with Distance to the Stream

Following the same approach as indicated for the protected squirrel locations you can now update your forest stands with protection information related to the stream identified in the field:

- Remember that the buffer in this case is 20 meters around it.
• You want to have all the protection information in the same vector file, so use the `stands_squirrel_15m` layer as the target.

• Name your output as `forest_stands_2012_protect.shp`.

Open the attributes table for the new vector layer and confirm that you now have all the protection information for the stands that are affected by the protection measures to protect the riparian forest associated with the stream.

Save your QGIS project.

14.4.6 In Conclusion

You have seen how to interpret CIR images to digitize forest stands. Of course it would take some practice to make more accurate stands and usually using other information like soil maps would give better results, but you know now the basis for this type of task. And adding information from other datasets resulted to be quite a trivial task.

14.4.7 What’s Next?

The forest stands you digitized will be used for planning forestry operations in the future, but you still need to get more information about the forest. In the next lesson, you will see how to plan a set of sampling plots to inventory the forest area you just digitized, and get the overall estimate of forest parameters.

14.5 Lesson: Systematic Sampling Design

You have already digitized a set of polygons that represent the forest stands, but you don’t have information about the forest just yet. For that purpose you can design a survey to inventory the whole forest area and then estimate its parameters. In this lesson you will create a systematic set of sampling plots.

When you start planning your forest inventory it is important to clearly define the objectives, the types of sample plots that will be used, and the data that will be collected to achieve the objectives. For each individual case, those will depend on the type of forest and the management purpose; and should be carefully planned by someone with forestry knowledge. In this lesson, you will implement a theoretical inventory based on a systematic sampling plot design.

**The goal for this lesson:** To create a systematic sampling plot design to survey the forest area.

14.5.1 Inventorying the Forest

There are several methods to inventory forests, each of them suiting different purposes and conditions. For example, one very accurate way to inventory a forest (if you consider only tree species) would be to visit the forest and make a list of every tree and their characteristics. As you can imagine this is not commonly applicable except for some small areas or some special situations.

The most common way to find out about a forest is by sampling it, that is, taking measurements in different locations at the forest and generalizing that information to the whole forest. These measurements are often made in *sample plots* that are smaller forest areas that can be easily measured. The sample plots can be of any size (for ex. 50 m², 0.5 ha) and form (for ex. circular, rectangular, variable size), and can be located in the forest in different ways (for ex. randomly, systematically, along lines). The size, form and location of the sample plots are usually decided following statistical, economical and practical considerations. If you have no forestry knowledge, you might be interested in reading [this Wikipedia article](https://en.wikipedia.org/wiki/Sampling_in_forest_inventory).
14.5.2 Follow Along: Implementing a Systematic Sampling Plot Design

For the forest you are working with, the manager has decided that a systematic sampling design is the most appropriate for this forest and has decided that a fixed distance of 80 meters between the sample plots and sampling lines will yield reliable results (for this case, ±5% average error at a probability of 68%). Variable size plots has been decided to be the most effective method for this inventory, for growing and mature stands, but a 4 meters fixed radius plots will be used for seedling stands.

In practice, you simply need to represented the sample plots as points that will be used by the field teams later:

- Open your `digitizing_2012.qgs` project from the previous lesson.
- Remove all the layers except for `forest_stands_2012`.
- Save your project now as `forest_inventory.qgs`.

Now you need to create a rectangular grid of points separated 80 meters from each other:

- Open `Vector → Research Tools → Regular points`.
- In the `Area definitions` select `Input Boundary Layer`.
- And as input layer set the `forest_stands_2012` layer.
- In the `Grid Spacing` settings, select `Use this point spacing` and set it to 80.
- Save the output as `systematic_plots.shp` in the `forestry\sampling\` folder.
- Check `Add result to canvas`.
- Click `OK`.

The suggested `Regular points` creates the systematic points starting in the corner upper-left corner of the extent of the selected polygon layer. If you want to add some randomness to this regular points, you could use a randomly calculated number between 0 and 80 (80 is the distance between our points), and then write it as the `Initial inset from corner (LH side)` parameter in the tool’s dialog.

You notice that the tool has used the whole extent of your stands layer to generate a rectangular grid of points. But you are only interested on those points that are actually inside your forest area (see the images below):
• Open Vector → Geoprocessing Tools → Clip.
• Select systematic_plots as Input vector layer.
• Set forest_stands_2012 as the Clip layer.
• Save the result as systematic_plots_clip.shp.
• Check Add result to canvas.
• Click OK.

You have now the points that the field teams will use to navigate to the designed sample plots locations. You can still prepare these points so that they are more useful for the field work. At the least you will have to add meaningful names for the points and export them to a format that can be used in their GPS devices.

Let’s start with the naming of the sample plots. If you check the Attribute table for the plots inside the forest area, you can see that you have the default id field automatically generated by the Regular points tool. Label the points to see them in the map and consider if you could use those numbers as part of your sample plot naming:

• Open the Layer Properties –> Labels for your systematic_plots_clip.
• Check Label this layer with and select the field ID.
• Go to the Buffer options and check the "Draw text buffer", set the Size to 1.
• Click OK.

Now look at the labels on your map. You can see that the points have been created and numbered first West to East and then North to South. If you look at the attribute table again, you will notice that the order in the table is following also that pattern. Unless you would have a reason to name the sample plots in a different way, naming them in a West-East/North-South fashion follows a logical order and is a good option.

..note:: If you would like to order or name them in a different way, you could use a spreadsheet to be able to order and combine rows and columns in any different way.

14.5. Lesson: Systematic Sampling Design 341
Nevertheless, the number values in the *id* field are not so good. It would be better if the naming would be something like *p_1, p_2,...*. You can create a new column for the `systematic_plots_clip` layer:

- Go to the *Attribute table* for `systematic_plots_clip`.
- Enable the edit mode.
- Open the *Field calculator* and name the new column *Plot_id*.
- Set the *Output field type* to *Text (string)*.
- In the *Expression* field, write, copy or construct this formula `concat('P_', $rownum )`. Remember that you can also double click on the elements inside the *Function list*. The `concat` function can be found under *String* and the `$rownum` parameter can be found under *Record*.

- Click *OK*.
- Disable the edit mode and save your changes.

Now you have a new column with plot names that are meaningful to you. For the `systematic_plots_clip` layer, change the field used for labeling to your new *Plot_id* field.
14.5.3 Follow Along: Exporting Sample Plots as GPX format

The field teams will be probably using a GPS device to locate the sample plots you planned. The next step is to export the points you created to a format that your GPS can read. QGIS allows you to save your point and line vector data in GPS eXchange Format (GPX)<http://en.wikipedia.org/wiki/GPS_Exchange_Format>, which is an standard GPS data format that can be read by most of the specialized software. You need to be careful with selecting the CRS when you save your data:

- Right click systematic_plots_clip and select Save as.
- In Format select GPS eXchange Format [GPX].
• Save the output as plots_wgs84.gpx.
• In CRS select Selected CRS.
• Browse for as WGS 84 (EPSG:4326).

..note:: The GPX format accepts only this CRS, if you select a different one, QGIS will give no error but you will get an empty file.

• Click OK.

• In the dialog that opens, select only the waypoints layer (the rest of the layers are empty).

The inventory sample plots are now in a standard format that can be managed by most of the GPS software. The field teams can now upload the locations of the sample plots to their devices. That would be done by using the specific devices own software and the plots_wgs84.gpx file you just saved. Other option would be to use the GPS Tools plugin but it would most likely involve setting the tool to work with your specific GPS device. If you are working with your own data and want to see how the tool works you can find out information about it in the section Working with GPS Data in the QGIS User Manual.

Save your QGIS project now.
14.5.4 In Conclusion

You just saw how easily you can create a systematic sampling design to be used in a forest inventory. Creating other types of sampling designs will involve the use of different tools within QGIS, spreadsheets or scripting to calculate the coordinates of the sample plots, but the general idea remains the same.

14.5.5 What’s Next?

In the next lesson you will see how to use the Atlas capabilities in QGIS to automatically generate detailed maps that the field teams will be using to navigate to the sample plots assigned to them.

14.6 Lesson: Creating Detailed Maps with the Atlas Tool

The systematic sampling design is ready and the field teams have loaded the GPS coordinates in their navigation devices. They also have a field data form where they will collect the information measured at every sample plot. To easier find their way to every sample plot, they have requested a number of detail maps where some ground information can be clearly seen along with a smaller subset of sample plots and some information about the map area. You can use the Atlas tool to automatically generate a number of maps with a common format.

The goal for this lesson: Learn to use the Atlas tool in QGIS to generate detailed printable maps to assist in the field inventory work.

14.6.1 Follow Along: Preparing the Map Composer

Before we can automate the detailed maps of the forest area and our sampling plots, we need to create a map template with all the elements we consider useful for the field work. Of course the most important will be a properly styled but, as you have seen before, you will also need to add lots of other elements that complete the printed map.

Open the QGIS project from the previous lesson forest_inventory.qgs. You should have at least the following layers:

• forest_stands_2012 (with a 50% transparency, green fill and darker green border lines).
• systematic_plots_clip.
• rautjarvi_aerial.

Save the project with a new name, map_creation.qgs.

To create a printable map, remember that you use the Composer Manager:

• Open Project → Composer Manager...
• In the Composer manager dialog.
• Click the Add button and name your composer forest_map.
• Click OK.
• Click the Show button.

Set up the printer options so that your maps will suit your paper and margins, for an A4 paper:

• Open menu selection: Composer → Page Setup.
• Size is A4 (217 x 297 mm).
• Orientation is Landscape.
• Margins (milimeters) are all set to 5.
In the *Print Composer* window, go to the *Composition* tab (on the right panel) and make sure that these settings for *Paper and quality* are the same you defined for the printer:

- **Size**: A4 (210x297mm).
- **Orientation**: Landscape.
- **Quality**: 300dpi.

Composing a map is easier if you make use of the canvas grid to position the different elements. Review the settings for the composer grid:

- In the *Composition* tab expand the *Grid* region.
- Check that *Spacing* is set to 10 mm.
- And that *Tolerance* is set to 2 mm.

You need to activate the use of the grid:

- Open the *View* menu.
- Check *Show grid*.
- Check *Snap to grid*.
- Notice that options for using *guides* are checked by default, which allows you to see red guiding lines when you are moving elements in the composer.

Now you can start to add elements to your map canvas. Add first a map element so you can review how it looks as you will be making changes in the layers symbology:

- Click on the *Add New Map* button: ![Add New Map](image)
- Click and drag a box on the canvas so that the map occupies most of it.

Notice how the mouse cursor snaps to the canvas grid. Use this function when you add other elements. If you want to have more accuracy, change the grid *Spacing* setting. If for some reason you don’t want to snap to the grid at some point, you can always check or uncheck it in the *View* menu.
14.6.2  Green  Follow Along: Adding Background Map

Leave the composer open but go back to the map. Let's add some background data and create some styling so that the map content is as clear as possible.

- Add the background raster `basic_map.tif` that you can find in the `exercise_data\forestry\` folder.
- When prompted select the ETRS89 / ETRS–TM35FIN CRS for the raster.

As you can see the background map is already styled. This type of ready to use cartography raster is very common. It is created from vector data, styled in a standard format and stored as a raster so that you don't have to bother styling several vector layers and worrying about getting a good result.

- Now zoom to your sample plots, so that you can see only about four or five lines of plots.

The current styling of the sample plots is not the best, but how does it look in the map composer?:

While during the last exercises, the white buffer was OK on top of the aerial image, now that the background image is mostly white you barely can see the labels. You can also check how it looks like on the composer:

- Go to the Print Composer window.
- Use the button to select the map element in the composer.
- Go to the Item properties tab.
- Under Extents click on Set to map canvas extent.
- If you need to refresh the element, under Main properties click on the Update preview.

Obviously this is not good enough, you want to make the plot numbers as clearly visible as possible for the field teams.

14.6.3  Green  Try Yourself Changing the Symbology of the Layers

You have been working in ../training_manual/basic_map/index with symbology and in Module: ベクタデータの分類 with labeling. Go back to those modules if you need to refresh about some of the available options and tools. Your goal is to get the plots locations and their name to be as clearly visible as possible but always allowing to see the background map elements. You can take some guidance from this image:
You will use later the the green styling of the forest_stands_2012 layer. In order to keep it, and have a visualization of it that shows only the stand borders:

- Right click on forest_stands_2012 and select Duplicate
- you get a new layer named forest_stands_2012 copy that you can use to define a different style, for example with no filling and red borders.

Now you have two different visualizations of the forest stands and you can decide which one to display for your detail map.

Go back to the Print composer window often to see what the map would look like. For the purposes of creating detailed maps, you are looking for a symbology that looks good not at the scale of the whole forest area (left image below) but at a closer scale (right image below). Remember to use Update preview and Set to map canvas extent whenever you change the zoom in your map or the composer.
14.6.4 🟢 Try Yourself Create a Basic Map Template

Once you have a symbology you’re happy with, you are ready to add some more information to your printed map. Add at least the following elements:

- Title.
- A scale bar.
- Grid frame for your map.
- Coordinates on the sides of the grid.

You have created a similar composition already in Module: マップの作成. Go back to that module as you need. You can look at this example image for reference:

Export your map as an image and look at it.

- Composer → Export as Image.
- Use for example the JPG format.

That is what it will look like when printed.

14.6.5 🟢 Follow Along: Adding More Elements to the Composer

As you probably noticed in the suggested map template images, there are plenty of room on the right side of the canvas. Let’s see what else could go in there. For the purposes of our map, a legend is not really necessary, but an overview map and some text boxes could add value to the map.

The overview map will help the field teams place the detail map inside the general forest area:

- Add another map element to the canvas, right under the title text.
- In the Item properties tab, open the Overview dropdown.
Set the Overview frame to Map 0. This creates a shadowed rectangle over the smaller map representing the extent visible in the bigger map.

Check also the Frame option with a black color and a Thickness of 0.30.

Notice that your overview map is not really giving an overview of the forest area which is what you want. You want this map to represent the whole forest area and you want it to show only the background map and the forest_stands_2012 layer, and not display the sample plots. And also you want to lock its view so it does not change anymore whenever you change the visibility or order of the layers.

Go back to the map, but don’t close the Print composer.

Right click the forest_stands_2012 layer and click on Zoom to Layer Extent.

Deactivate all layers except for basic_map and forest_stands_2012.

Go back to the Print composer.

With the small map selected, click the Set to map canvas extent to set its extents to what you can see in the map window.

Lock the view for the overview map by checking Lock layers for map item under Main properties.

Now your overview map is more what you expected and its view will not change anymore. But, of course, now your detail map is not showing anymore the stand borders nor the sample plots. Lets fix that:

Go to the map window again and select the layers you want to be visible (systematic_plots_clip, forest_stands_2012_copy and Basic_map).

Zoom again to have only a few lines of sample plots visible.

Go back to the Print composer window.

Select the bigger map in your composer.

In Item properties click on Update preview and Set to map canvas extent.
Notice that only the bigger map is displaying the current map view, and the small overview map is keeping the same view you had when you locked it.

Note also that the overview is showing a shaded frame for the extent shown in the detail map.

Your template map is almost ready. Add now two text boxes below the map, one containing the text ‘Detailed map zone:’ and the other one ‘Remarks:’. Place them as you can see in the image above.

You can also add a North arrow to the overview map:

- Use the Add image tool.
- Click at the upper right corner of the overview map.
- In Item properties, open Search directories and browse for an arrow image.
- Under Image rotation, check the Sync with map and select Map 1 (the overview map).
- Uncheck Background.
- Resize the arrow image to a size that looks good on the small map.

The basic map composer is ready, now you want to make use of the Atlas tool to generate as many detail maps in this format as you consider necessary.

### 14.6.6 🎨 Follow Along: Creating an Atlas Coverage

The Atlas coverage is just a vector layer that will be used to generate the detail maps, one map for every feature in the coverage. To get an idea of what you will do in the next, here is a full set of detail maps for the forest area:
The coverage could be any existing layer, but usually it makes more sense to create one for the specific purpose. Let’s create a grid of polygons covering the forest area:

- In the QGIS map view, open Vector → Research Tools → Vector grid.
- Set the tool as shown in this image:
14.6. Lesson: Creating Detailed Maps with the Atlas Tool

- Save the output as atlas_coverage.shp.
- Style the new atlas_coverage layer so that the polygons have no filling.

The new polygons are covering the whole forest area and you have already an idea of what each map (created from each polygon) will contain.
14.6.7 Follow Along: Setting Up the Atlas Tool

The last step is to set up the Atlas tool:

- Go back to the Print Composer.
- In the panel on the right, go to the Atlas generation tab.
- Set the options as follows:
That tells the Atlas tool to use the features (polygons) inside `atlas_coverage` as the focus for every detail map. It will output one map for every feature in the layer. The `Hidden coverage layer` tells the Atlas to not show the polygons in the output maps.

One more thing needs to be done. You need to tell the Atlas tool what map element is going to be updated for every output map. By now, you probably can guess that the map to be changed for every feature is the one you have prepared to contain detail views of the sample plots, that is the bigger map element in your canvas:

- Select the bigger map element.
- Go to the `Item properties` tab.
- In the list, check `Controlled by atlas`.
- And set the `Marging around feature` to 10%. The view extent will be 10% bigger than the polygons, which means that your detail maps will have a 10% overlap.
Now you can use the preview tool for Atlas maps to review what your maps will look like:

- Activate the Atlas previews using the button or if your Atlas toolbar is not visible, via Atlas → Preview Atlas.
- You can use the arrows in the Atlas toolbar or in the Atlas menu to move through maps that will be created.

Note that some of them cover areas that are not interesting. Let’s do something about it and save some trees by not printing those useless maps.

14.6.8 Follow Along: Editing the Coverage Layer

Besides removing the polygons for those areas that are not interesting, you can also customize the text labels in your map to be generated with content from the Attribute table of your coverage layer:

- Go back to the map view.
- Enable editing for the atlas_coverage layer.
• Select the polygons that are selected (in yellow) in the image below.
• Remove the selected polygons.
• Disable editing and save the edits.

You can go back to the Print Composer and check that the previews of the Atlas use only the polygons you left in the layer.

The coverage layer you are using does not yet have useful information that you could use to customize the content of the labels in your map. The first step is to create them, you can add for example a zone code for the polygon areas and a field with some remarks for the field teams to have into account:

• Open the Attribute table for the atlas_coverage layer.
• Enable editing.
• Use the calculator to create and populate the following two fields.
• Create a field named Zone and type Whole number (integer).
• In the Expression box write/copy/construct $rownum.
• Create another field named Remarks, of type Text (string) and a width of 255.
- In the Expression box write ‘No remarks.’. This will set all the default value for all the polygons.

The forest manager will have some information about the area that might be useful when visiting the area. For example, the existence of a bridge, a swamp or the location of a protected species. The atlas_coverage layer is probably in edit mode still, add the following text in the Remarks field to the corresponding polygons (double click the cell to edit it):

- For the Zone 2: Bridge to the North of plot 19. Siberian squirrel between p_13 and p_14.
- For the Zone 6: Difficult to transit in swamp to the North of the lake.
- For the Zone 7: Siberian squirrel to the South East of p_94.

Disable editing and save your edits.

Almost ready, now you have to tell the Atlas tool that you want some of the text labels to use the information from the atlas_coverage layer’s attribute table.

- Go back to the Print Composer.
- Select the text label containing Detailed map....
- Set the Font size to 12.
- Set the cursor at the end of the text in the label.
- In the Item properties tab, inside the Main properties click on Insert an expression.
- In the Function list double click on the field Zone under Field and Values.
- Click OK.

The text inside the box in the Item properties should show Detail map inventory zone: [% "Zone" %]. Note that the [% "Zone" %] will be substituted by the value of the field Zone for the corresponding feature from the atlas_coverage.

Test the contents of the label by looking at the different Atlas preview maps.

Do the same for the labels with the text Remarks: using the field whit the zone information. You can leave a break line before you enter the expression. You can see the result for the preview of zone 2 in the image below:
Use the Atlas preview to browse through all the maps you will be creating soon and enjoy!

### 14.6.9  Follow Along: Printing the Maps

Last but not least, printing or exporting your maps to image files or PDF files. You can use the `Atlas → Export Atlas as Images...` or `Atlas → Export Atlas as PDF...`. Currently the SVG export format is not working properly and will give a poor result.

Let’s print the maps as a single PDF that you can send to the field office for printing:

- Go to the `Atlas generation` tab on the right panel.
- Under the `Output` check the `Single file export when possible`. This will put all the maps together into a PDF file, if this option is not checked you will get one file for every map.
- Open `Composer → Export as PDF...`
- Save the PDF file as `inventory_2012_maps.pdf` in your `exercise_data\forestry\samplig\map_creation\` folder.

Open the PDF file to check that everything went as expected.

You could just as easily create separate images for every map (remember to uncheck the single file creation), here you can see the thumbnails of the images that would be created:
In the Print Composer, save your map as a composer template as forestry_atlas.qpt in your exercise_data\forestry\map_creation\ folder. Use Composer → Save as Template. You will be able to use this template again and again.

Close the Print Composer and save your QGIS project.

14.6.10 In Conclusion

You have managed to create a template map that can be used to automatically generate detail maps to be used in the field to help navigate to the different plots. As you noticed, this was not an easy task but the benefit will come when you need to create similar maps for other regions and you can use the template you just saved.

14.6.11 What’s Next?

In the next lesson, you will see how you can use LiDAR data to create a DEM and then use it to your enhance your data and maps visibility.

14.7 Lesson: Calculating the Forest Parameters

Estimating the parameters of the forest is the goal of the forest inventory. Continuing the example from previous lesson, you will use the inventory information gathered in the field to calculate the forest parameters, for the whole forest first, and then for the stands you digitized before.

The goal for this lesson: Calculate forest parameters at general and stand level.

14.7.1 Follow Along: Adding the Inventory Results

The field teams visited the forest and with the help of the information you provided, gathered information about the forest at every sample plot.

Most often the information will be collected into paper forms in the field, then typed to a spreadsheet. The sample plots information has been condensed into a .csv file that can be easily open in QGIS.

Continue with the QGIS project from the lesson about designing the inventory, you probably named it forest_inventory.qgs.

First, add the sample plots measurements to your QGIS project:

- Go to Layer → Add Delimited Text Layer....
• Browse to the file systematic_inventory_results.csv located in exercise_data\forestry\results.\n• Make sure that the Point coordinates option is checked.\n• Set the fields for the coordinates to the X and Y fields.\n• Click OK.\n• When prompted, select ETRS89 / ETRS-TM35FIN as the CRS.\n• Open the new layer’s Attribute table and have a look at the data.

You can read the type of data that is contained in the sample plots measurements in the text file legend_2012_inventorydata.txt located in the exercise_data\forestry\results\ folder. The systematic_inventory_results layer you just added is actually just a virtual representation of the text information in the .csv file. Before you continue, convert the inventory results to a real shapefile:

• Right click on the systematic_inventory_results layer.\n• Browse to exercise_data\forestry\results\ folder.\n• Name the file sample_plots_results.shp.\n• Check Add saved file to map.\n• Remove the systematic_inventory_results layer from your project.

14.7.2  Follow Along: Whole Forest Parameters Estimation

You can calculate the averages for this whole forest area from the inventory results for the some interesting parameters, like the volume and the number of stems per hectare. Since the systematic sample plots represent equal areas, you can directly calculate the averages of the volumes and number of stems per hectare from the sample_plots_results layer.

You can calculate the average of a field in a vector layer using the Basic statistics tool:

• Open Vector → Analysis Tools → Basic statistics.\n• Select the sample_plots_results as the Input Vector Layer.\n• Select Vol as Target field.\n• Click OK.

The average volume in the forest is 135.2 m³/ha.

You can calculate the average for the number of stems in the same way, 2745 stems/ha.
14.7.3 Follow Along: Estimating Stand Parameters

You can make use of those same systematic sample plots to calculate estimates for the different forest stands you digitized previously. Some of the forest stands did not get any sample plot and for those you will not get information. You could have planned some extra sample plots when you planned the systematic inventory, so that the field teams would have measured a few extra sample plots for this purpose. Or you could send a field team later to get estimates of the missing forest stands to complete the stand inventory. Nevertheless, you will get information for a good number of stands just using the planned plots.

What you need is to get the averages of the sample plots that are falling within each of the forest stands. When you want to combine information based on their relative locations, you perform a spatial join:

- Open the Vector → Data Management → Join attributes by location tool.
- Set forest_stands_2012 as the Target vector layer. The layer you want the results for.
- Set sample_plots_results as the Join vector layer. The layer you want to calculate estimates from.
- Check Take summary of intersecting features.
- Check to calculate only the Mean.
- Name the result as forest_stands_2012_results.shp and save it in the exercise_data\forestry\results\ folder.
- Finally select Keep all records..., so you can check later what stands did not get information.
- Click OK.
- Accept adding the new layer to your project when prompted.
- Close the Join attributes by location tool.

Open the Attribute table for forest_stands_2012_results and review the results you got. Note that a number of forest stands have NULL as the value for the calculations, those are the ones having no sample plots. Select them all review them in the map, they are some of the smaller stands:
Lets calculate now the same averages for the whole forest as you did before, only this time you will use the averages you got for the stands as the bases for the calculation. Remember that in the previous situation, each sample plot represented a theoretical stand of $80\times80$ m. Now you have to consider the area of each of the stands individually instead. That way, again, the average values of the parameters that are in, for example, m$^3$/ha for the volumes are converted to total volumes for the stands.

You need to first calculate the areas for the stands and then calculate total volumes and stem numbers for each of them:

- In the Attributes table enable editing.
- Open the Field calculator.
- Create a new field called area.
• Leave the Output field type to Decimal number (real).
• Set the Precision to 2.
• In the Expression box, write $area / 10000. This will calculate the area of the forest stands in ha.
• Click OK.

Now calculate a field with the total volumes and number of stems estimated for every stand:
• Name the fields s_vol and s_stem.
• The fields can be integer numbers or you can use real numbers also.
• Use the expressions "area" * "MEANVol" and "area" * "MEANStems" for total volumes and total stems respectively.
• Save the edits when you are finished.
• Disable editing.

In the previous situation, the areas represented by every sample plot were the same, so it was enough to calculate the average of the sample plots. Now to calculate the estimates, you need to divide the sum of the stands volumes or number of stems by the sum of the areas of the stands containing information.
• In the guilabel: Attributes table for the forest_stands_2012_results layer, select all the stands containing information.
• Open Vector → Analysis Tools → Basic statistics.
• Select the forest_stands_2012_results as the Input Vector Layer.
• Select area as Target field.
• Check the Use only selected features
• Click OK.
As you can see, the total sum of the stands’ areas is 66.04 ha. Note that the area of the missing forest stands is only about 7 ha.

In the same way, you can calculate that the total volume for these stands is 8908 m3/ha and the total number of stems is 179594 stems.

Using the information from the forest stands, instead of directly using that from the sample plots, gives the following average estimates:

- 184.9 m3/ha and
- 2719 stems/ha.

Save your QGIS project, forest_inventory.qgs.

### 14.7.4 In Conclusion

You managed to calculate forest estimates for the whole forest using the information from your systematic sample plots, first without considering the forest characteristics and also using the interpretation of the aerial image into forest stands. And you also got some valuable information about the particular stands, which could be used to plan the management of the forest in the coming years.
14.7.5 What’s Next?

In the following lesson, you will first create a hillshade background from a LiDAR dataset which you will use to prepare a map presentation with the forest results you just calculated.

14.8 Lesson: DEM from LiDAR Data

You can improve the look of your maps by using different background images. You could use the basic map or the aerial image you have been using before, but a hillshade raster of the terrain will look nicer in some situations. You will use LAStools to extract a DEM from a LiDAR dataset and then create a hillshade raster to use in your map presentation later.

**The goal for this lesson:** Install LAStools and calculate a DEM from LiDAR data and a hillshade raster.

14.8.1 ✨ Follow Along: Installing Lastools

Managing LiDAR data within QGIS is possible using the Processing framework and the algorithms provided by LAStools.

You can obtain a digital elevation model (DEM) from a LiDAR point cloud and then create a hillshade raster that is visually more intuitive for presentation purposes. First you will have to set up the :guilabel:`Processing` framework settings to properly work with LAStools:

- Close QGIS, if you have already started it.
- An old lidar plugin might be installed by default in your system in the folder `C:/Program Files/QGIS Valmiera/apps/qgis/python/plugins/processing/`.
- If you have a folder named `lidar`, delete it. This is valid for some installations of QGIS 2.2 and 2.4.
• Go to the exercise_data\forestry\lidar\ folder, there you can find the file QGIS_2_2_toolbox.zip. Open it and extract the lidar folder to replace the one you just deleted.

• If you are using a different QGIS version, you can see more installation instructions in this tutorial.

Now you need to install the LAStools to your computer. Get the newest lastools version here and extract the content of the lastools.zip file into a folder in your system, for example, c:\lastools\. The path to the lastools folder cannot have spaces or special characters.

>Note: Read the LICENSE.txt file inside the lastools folder. Some of the LAStools are open source and other are closed source and require licensing for most commercial and governmental use. For education and evaluation purposes you can use and test LAStools as much as you need to.

The plugin and the actual algorithms are now installed in your computer and almost ready to use, you just need to set up the Processing framework to start using them:

• Open a new project in QGIS.
• Set the project’s CRS to ETRS89 / ETRS-TM35FIN.
• Save the project as forest_lidar.qgs.

To setup the LAStools in QGIS:

• Go to Processing → Options and configuration.
• In the Processing options dialog, go to Providers and then to Tools for LiDAR data.
• Check Activate.
• For LASTools folder set c:\lastools\ (or the folder you extracted LASTools to).
14.8.2  🟢 Follow Along: Calculating a DEM with LASTools

You have already used the Processing toolbox in Lesson: 空間統計 to run some SAGA algorithms. Now you are going to use it to run LASTools programs:

- Open Processing → Toolbox.
- In the dropdown menu at the bottom, select Advanced interface.
- You should see the Tools for LiDAR data category.
• Expand it to see the tools available, and expand also the LASTools category (the number of algorithms may vary).

• Scroll down until you find the lasview algorithm, double click it to open.

• At Input LAS/LAZ file, browse to exercise_data\forestry\lidar\ and select the rautjarvi_lidar.laz file.
• Click Run.

Now you can see the LiDAR data in the just a little LAS and LAZ viewer dialog window:

There are many things you can do within this viewer, but for now you can just click and drag on the viewer to pan the LiDAR point cloud to see what it looks like.

Note: If you want to know further details on how the LAStools work, you can read the README text files.
about each of the tools, in the C:\lastools\bin\ folder. Tutorials and other materials are available at the Rapidlasso webpage.

- Close the viewer when you are ready.

Creating a DEM with LAStools can be done in two steps, first one to classify the point cloud into ground and no ground points and then calculating a DEM using only the ground points.

- Go back to the Processing Toolbox.
- Note the Search... box, write lasground.
- Double click to open the lasground tool and set it as shown in this image:

![lasground tool](image)

- The output file is saved to the same folder where the rautjarvi_lidar.laz is located and it is named rautjarvi_lidar_1.las.

You can open it with lasview if you want to check it.
The brown points are the points classified as ground and the gray ones are the rest, you can click the letter g to visualize only the ground points or the letter u to see only the unclassified points. Click the letter a to see all the points again. Check the lasview_README.txt file for more commands. If you are interested, also this tutorial about editing LiDAR points manually will show you different operations within the viewer.

- Close the viewer again.
- In the Processing Toolbox, search for las2dem.
- Open the las2dem tool and set it as shown in this image:
The result DEM is added to your map with the generic name **Output raster file**.

José: The lasground and las2dem tools require licensing. You can use the unlicensed tool as indicated in the license file, but you get the diagonals you can appreciate in the image results.

### 14.8.3 ✨ Follow Along: Creating a Terrain Hillshade

For visualization purposes, a hillshade generated from a DEM gives a better visualization of the terrain:

- Open **Raster → Terrain analysis → Hillshade**.
- As the **Output layer**, browse to `exercise_data\forestry\lidar\` and name the file `hillshade.tif`.
- Leave the rest of parameters with the default settings.
• Select ETRS89 / ETRS-TM35FIN as the CRS when prompted.

Despite the diagonal lines remaining in the hillshade raster result, you can clearly see an accurate relief of the area. You can even see the different soil drains that have been dug in the forests.
14.8.4 In Conclusion

Using LiDAR data to get a DEM, specially in forested areas, gives good results with not much effort. You could also use ready LiDAR derived DEMs or other sources like the SRTM 9m resolution DEMs. Either way, you can use them to create a hillshade raster to use in your map presentations.

14.8.5 What’s Next?

In the next, and final step in this module, lesson you will use the hillshade raster and the forest inventory results to create a map presentation of the results.

14.9 Lesson: Map Presentation

In the previous lessons you have imported an old forest inventor as a GIS project, updated it to the current situation, designed a forest inventory, created maps for the field work and calculated forest parameters from the field measurements.

It is often important to create maps with the results of a GIS project. A map presenting the results of the forest inventory will make it easier for anyone to have a good idea of what the results are in a quick glance, without looking at the specific numbers.
The goal for this lesson: Create a map to present the inventory results using a hillshade raster as background.

14.9.1 🌿 Follow Along: Preparing the Map Data

Open the QGIS project from the parameters calculations lesson, forest_inventory.qgs. Keep at least the following layers:

- forest_stands_2012_results.
- basic_map.
- rautjarvi_aerial.
- lakes (if you don’t have it, add it from the exercise_data\forestry\ folder).

You are going to present the average volumes of your forest stands in a map. If you open the Attribute table for the forest_stands_2012_results layer, you can see the NULL values for the stands without information. To be able to get also those stands into your styling you should change the NULL values to, for example, -999, knowing that those negative numbers mean there is no data for those polygons.

For the forest_stands_2012_results layer:

- Open the Attribute table and enable editing.
- Select the polygons with NULL values.
- Use the calculator to update the values of the MEANVol field to -999 only for the selected features.
- Disable editing and save the changes.

Now you can use a saved style for this layer:

- Go to the Style tab.
- Click on Load Style.
- Select the forest_stands_2012_results.qml from the exercise_data\forestry\results\ folder.
- Click OK.
Your map will look something like this:
14.9.2 🟢 Try Yourself Try Different Blending Modes

The style you loaded:
is using the **Hard light** mode for the *Layer blending mode*. Note that the different modes apply different filters combining the underlying and overlying layers, in this case the hillshade raster and your forest stands are used. You can read about these modes in the [User Guide](https://qgis.org). Try with different modes and see the differences in your map. Then choose the one you like better for your final map.

### 14.9.3 Try Yourself Using a Composer Template to Create the Map result

Use a template prepared in advance to present the results. The template `forest_map.qpt` is located in the `exercise_data\forestry\results\` folder. Load it using the `Project → Composer Manager...` dialog.
Open the map composer and edit the final map to get a result you are happy with.

The map template you are using will give a map similar to this one:
Save your QGIS project for future references.
14.9.4 In Conclusion

Through this module you have seen how a basic forest inventory can be planned and presented with QGIS. Many more forest analysis are possible with the variety of tools that you can access, but hopefully this manual has given you a good starting point to explore how you could achieve the specific results you need.
Chapter 15

Module: PostgreSQL でのデータベース

15.1 Lesson: Introduction to Databases

Before using PostgreSQL, let’s make sure of our ground by covering general database theory. You will not need to enter any of the example code; it’s only there for illustration purposes.

The goal for this lesson: To understand fundamental database concepts.

15.1.1 What is a Database?

A database consists of an organized collection of data for one or more uses, typically in digital form. - Wikipedia

A database management system (DBMS) consists of software that operates databases, providing storage, access, security, backup and other facilities. - Wikipedia

15.1.2 Tables

In relational databases and flat file databases, a table is a set of data elements (values) that is organized using a model of vertical columns (which are identified by their name) and horizontal rows. A table has a specified number of columns, but can have any number of rows. Each row is identified by the values appearing in a particular column subset which has been identified as a candidate key. - Wikipedia

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>age</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tim</td>
<td>20</td>
</tr>
<tr>
<td>2</td>
<td>Horst</td>
<td>88</td>
</tr>
</tbody>
</table>

(2 rows)

In SQL databases a table is also known as a relation.

15.1.3 Columns / Fields

A column is a set of data values of a particular simple type, one for each row of the table. The columns provide the structure according to which the rows are composed. The term field is often used interchangeably with column,
although many consider it more correct to use field (or field value) to refer specifically to the single item that exists at the intersection between one row and one column. - Wikipedia

A column:

<table>
<thead>
<tr>
<th>name</th>
</tr>
</thead>
</table>
+------+
| Tim  |
| Horst |

A field:

| Horst |

15.1.4 Records

A record is the information stored in a table row. Each record will have a field for each of the columns in the table.

2 | Horst | 88 <-- one record

15.1.5 Datatypes

Datatypes restrict the kind of information that can be stored in a column. - Tim and Horst

There are many kinds of datatypes. Let’s focus on the most common:

- String - to store free-form text data
- Integer - to store whole numbers
- Real - to store decimal numbers
- Date - to store Horst’s birthday so no one forgets
- Boolean - to store simple true/false values

You can tell the database to allow you to also store nothing in a field. If there is nothing in a field, then the field content is referred to as a ‘null’ value:

insert into person (age) values (40);

select * from person;

Result:

id | name | age
----|------|-----
1   | Tim  | 20
2   | Horst| 88
4   |      | 40 <- null for name
(3 rows)

There are many more datatypes you can use - check the PostgreSQL manual!

15.1.6 Modelling an Address Database

Let’s use a simple case study to see how a database is constructed. We want to create an address database.
Try Yourself

Write down the properties which make up a simple address and which we would want to store in our database.

Check your results

Address Structure

The properties that describe an address are the columns. The type of information stored in each column is its datatype. In the next section we will analyse our conceptual address table to see how we can make it better!

15.1.7 Database Theory

The process of creating a database involves creating a model of the real world; taking real world concepts and representing them in the database as entities.

15.1.8 Normalisation

One of the main ideas in a database is to avoid data duplication / redundancy. The process of removing redundancy from a database is called Normalisation.

Normalization is a systematic way of ensuring that a database structure is suitable for general-purpose querying and free of certain undesirable characteristics - insertion, update, and deletion anomalies - that could lead to a loss of data integrity. - Wikipedia

There are different kinds of normalisation ‘forms’.

Let’s take a look at a simple example:

Table "public.people"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td></td>
<td></td>
<td>nextval('people_id_seq'::regclass)</td>
</tr>
<tr>
<td>name</td>
<td>character varying(50)</td>
<td></td>
</tr>
<tr>
<td>address</td>
<td>character varying(200)</td>
<td>not null</td>
</tr>
<tr>
<td>phone_no</td>
<td>character varying</td>
<td></td>
</tr>
</tbody>
</table>

Indexes:
"people_pkey" PRIMARY KEY, btree (id)

select * from people;

id | name           | address                                  | phone_no
---|----------------|------------------------------------------|-----------------|
1  | Tim Sutton     | 3 Buirski Plein, Swellendam              | 071 123 123     |
2  | Horst Duester  | 4 Avenue du Roix, Geneva                 | 072 121 122     |

(2 rows)

Imagine you have many friends with the same street name or city. Every time this data is duplicated, it consumes space. Worse still, if a city name changes, you have to do a lot of work to update your database.

15.1.9 Try Yourself

Redesign the theoretical *people* table above to reduce duplication and to normalise the data structure.
You can read more about database normalisation [here](#).

**Check your results**

### 15.1.10 Indexes

A database index is a data structure that improves the speed of data retrieval operations on a database table. - *Wikipedia*

Imagine you are reading a textbook and looking for the explanation of a concept - and the textbook has no index! You will have to start reading at one cover and work your way through the entire book until you find the information you need. The index at the back of a book helps you to jump quickly to the page with the relevant information:

```
create index person_name_idx on people (name);
```

Now searches on name will be faster:

Table "public.people"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td></td>
<td></td>
<td>nextval('people_id_seq':regclass)</td>
</tr>
<tr>
<td>name</td>
<td>character varying(50)</td>
<td></td>
</tr>
<tr>
<td>address</td>
<td>character varying(200)</td>
<td>not null</td>
</tr>
<tr>
<td>phone_no</td>
<td>character varying</td>
<td></td>
</tr>
</tbody>
</table>

Indexes:
- "people_pkey" PRIMARY KEY, btree (id)
- "person_name_idx" btree (name)

### 15.1.11 Sequences

A sequence is a unique number generator. It is normally used to create a unique identifier for a column in a table.

In this example, id is a sequence - the number is incremented each time a record is added to the table:

```
id | name | address | phone_no
---+--------------+-----------------------------+-------------
1  | Tim Sutton   | 3 Birski Plein, Swellendam | 071 123 123 |
2  | Horst Duster | 4 Avenue du Roix, Geneva   | 072 121 122 |
```

(2 rows)

### 15.1.12 Entity Relationship Diagramming

In a normalised database, you typically have many relations (tables). The entity-relationship diagram (ER Diagram) is used to design the logical dependencies between the relations. Consider our non-normalised `people` table from earlier in the lesson:

```
select * from people;
```

```
id | name | address | phone_no
---+--------------+-----------------------------+-------------
1  | Tim Sutton   | 3 Birski Plein, Swellendam | 071 123 123 |
2  | Horst Duster | 4 Avenue du Roix, Geneva   | 072 121 122 |
```

(2 rows)

With a little work we can split it into two tables, removing the need to repeat the street name for individuals who live in the same street:
```sql
select * from streets;

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Plein Street</td>
</tr>
</tbody>
</table>

(1 row)

and:

```sql
select * from people;

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Horst Duster</td>
<td>4</td>
<td>1</td>
<td>072 121 122</td>
</tr>
</tbody>
</table>

(1 row)
```

We can then link the two tables using the ‘keys’ streets.id and people.streets_id.

If we draw an ER Diagram for these two tables it would look something like this:

![ER Diagram](image)

The ER Diagram helps us to express ‘one to many’ relationships. In this case the arrow symbol show that one street can have many people living on it.

**Try Yourself**

Our people model still has some normalisation issues - try to see if you can normalise it further and show your thoughts by means of an ER Diagram.

*Check your results*

### 15.1.13 Constraints, Primary Keys and Foreign Keys

A database constraint is used to ensure that data in a relation matches the modeller’s view of how that data should be stored. For example a constraint on your postal code could ensure that the number falls between 1000 and 9999.

A Primary key is one or more field values that make a record unique. Usually the primary key is called id and is a sequence.

A Foreign key is used to refer to a unique record on another table (using that other table’s primary key).

In ER Diagramming, the linkage between tables is normally based on Foreign keys linking to Primary keys.

If we look at our people example, the table definition shows that the street column is a foreign key that references the primary key on the streets table:

```
Table "public.people"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td>name</td>
<td>character varying(50)</td>
<td></td>
</tr>
<tr>
<td>house_no</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>street_id</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>phone_no</td>
<td>character varying</td>
<td></td>
</tr>
</tbody>
</table>
```

---

15.1. Lesson: Introduction to Databases 387
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)

15.1.14 Transactions

When adding, changing, or deleting data in a database, it is always important that the database is left in a good state if something goes wrong. Most databases provide a feature called transaction support. Transactions allow you to create a rollback position that you can return to if your modifications to the database did not run as planned.

Take a scenario where you have an accounting system. You need to transfer funds from one account and add them to another. The sequence of steps would go like this:

• remove R20 from Joe
• add R20 to Anne

If something goes wrong during the process (e.g. power failure), the transaction will be rolled back.

15.1.15 In Conclusion

Databases allow you to manage data in a structured way using simple code structures.

15.1.16 What’s Next?

Now that we’ve looked at how databases work in theory, let’s create a new database to implement the theory we’ve covered.

15.2 Lesson: データモデルの実装

私たちはすべての理論をカバーしたので新しいデータベースを作成してみましょう。このデータベースは後に続くレッスンの実習で使います。
このレッスンの目標: 必要なソフトウェアをインストールしてサンプルデータベースの実装に使用します。

15.2.1 PostgreSQL のインストール

ノート: このドキュメントの範囲外ではありますが、Mac ユーザは Homebrew を用いて PostgreSQL をインストールすることができます。Windows ユーザはここにあるグラフィカルなインストーラを使うことができます: http://www.postgresql.org/download/windows/ このドキュメントでは Ubuntu で QGIS を動作させているユーザを想定しています。

Ubuntu で:

```
sudo apt-get install postgresql-9.1
```

このようなメッセージを取得するはずです:

```
[sudo] password for qgis:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
postgresql-client-9.1 postgresql-client-common postgresql-common
Suggested packages:
```
oidentd ident-server postgresql-doc-9.1
The following NEW packages will be installed:
postgresql-9.1 postgresql-client-9.1 postgresql-client-common postgresql-common
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 5,012kB of archives.
After this operation, 19.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

Y and Enterキーを押し、ダウンロードとインストールが完了するまで待ちます。

15.2.2 ヘルプ

PostgreSQLには非常に良いオンラインドキュメントがあります。

15.2.3 データベースユーザの作成

Ubuntuで:

インストールが完了したらこのコマンドを実行してpostgresユーザになり、新しいデータベースユーザを作成します:

```
sudo su - postgres
```

入力を求められたら通常のログインパスワードを入力します（sudo権限を持っている必要があります）。
では、postgresユーザでのbashプロンプトでデータベースユーザを作成します。ユーザ名はunixログイン名と一致させて下さい。そうするとログインする時にpostgresが自動的に認証するのでいろいろと楽になります。

```
createuser -d -E -i -l -P -r -s qgis
```

入力を求められたらパスワードを入力します。ログインパスワードとは異なるパスワードを使用するべきです。
これらのオプションはどういう意味ですか？

- `d`, `--createdb` role can create new databases
- `E`, `--encrypted` encrypt stored password
- `i`, `--inherit` role inherits privileges of roles it is a member of (default)
- `l`, `--login` role can login (default)
- `P`, `--pwprompt` assign a password to new role
- `r`, `--createrole` role can create new roles
- `s`, `--superuser` role will be superuser

次のように入力してpostgresユーザのbashシェル環境を去ります:

```
exit
```

15.2.4 新しいアカウントの確認

```
psql -l
```

このように返されるはずです:

```
Name   | Owner | Encoding | Collation | Ctype |
--------+-------+----------+-----------+-------|
postgres | postgres | UTF8   | en_ZA.utf8 | en_ZA.utf8 |
template0 | postgres | UTF8   | en_ZA.utf8 | en_ZA.utf8 |
template1 | postgres | UTF8   | en_ZA.utf8 | en_ZA.utf8 |
(3 rows)
```
15.2.5 データベースの作成

createdb コマンドは新しいデータベースを作成するのに使います。bash シェルプロンプトから実行します:

```
createdb address -O qgis
```

このコマンドを使用して新しいデータベースの存在を確認できます:

```
psql -l
```

このように返されるはずです:

<table>
<thead>
<tr>
<th>Name</th>
<th>Owner</th>
<th>Encoding</th>
<th>Collation</th>
<th>Ctype</th>
<th>Access privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>address</td>
<td>qgis</td>
<td>UTF8</td>
<td>en_ZA.utf8</td>
<td>en_ZA.utf8</td>
<td></td>
</tr>
<tr>
<td>postgres</td>
<td>postgres</td>
<td>UTF8</td>
<td>en_ZA.utf8</td>
<td>en_ZA.utf8</td>
<td></td>
</tr>
<tr>
<td>template0</td>
<td>postgres</td>
<td>UTF8</td>
<td>en_ZA.utf8</td>
<td>en_ZA.utf8</td>
<td>=c/postgres: postgres=CTc/postgres</td>
</tr>
<tr>
<td>template1</td>
<td>postgres</td>
<td>UTF8</td>
<td>en_ZA.utf8</td>
<td>en_ZA.utf8</td>
<td>=c/postgres: postgres=CTc/postgres</td>
</tr>
</tbody>
</table>

(4 rows)

q を入力して終了します。

15.2.6 データベースのシェルセッションの開始

このようにして簡単にデータベースに接続することができます:

```
psql address
```

```
psql データベースシェルを終了するには:
\q
シェルのヘルプを見るには:
? 
sql コマンドのヘルプを見るには:
\help
特定のコマンドのヘルプを表示するには (例):
\help create table
```

Psql cheat sheet も参照して下さい。ここで利用可能です。

15.2.7 SQL でテーブルを作成する

いくつかのテーブルを作ってみましょう! ガイドとして ER 図を使用します。まず、address データベースに接続します:

```
psql address
```

```
streets テーブルを作成します:
create table streets (id serial not null primary key, name varchar(50));
```
serial と varchar はデータ型です。serial は新しいレコードのそれぞれに id を自動的に設定するために PostgreSQL に整数シーケンス（自動番号割り当て）を開始させます。varchar(50) は PostgreSQL に長さ 50 文字の文字列フィールドを作成させます。

コマンドが、で終わっていることに気づきましたか。すべての SQL コマンドはこのように終わるべきです。Enter キーを押すと psql は次のように報告します:

NOTICE: CREATE TABLE will create implicit sequence "streets_id_seq" for serial column "streets.id"
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "streets_pkey" for table "streets"

CREATE TABLE

streets.id を使用する主キー streets_pkey を持つテーブルが正しく作成されました。

注：; を入力せずに Enter キーを押すと address-# のようなプロンプトが表示されます。PG はさらなる入力を期待しています。コマンドを実行するには; を入力して下さい。

テーブルのスキーマを表示するにはこうします:

\d streets

このように表示されるはずです:

Table "public.streets"
<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td></td>
<td></td>
<td>nextval('streets_id_seq'::regclass)</td>
</tr>
<tr>
<td>name</td>
<td>character varying(50)</td>
<td></td>
</tr>
</tbody>
</table>

Indexes:
"streets_pkey" PRIMARY KEY, btree (id)

テーブルの内容を表示するにはこうします:

select * from streets;

このように表示されるはずです:

id | name
---+------
(0 rows)

ご覧のようにテーブルは現在空です。

Try Yourself

上記のアプローチを使用して people というテーブルを作成します:

Add fields such as phone number, home address, name, etc. (these aren’t all valid names: change them to make them valid). Make sure you give the table an ID column with the same data-types as above.

結果をチェックする

15.2.8 SQL でキーを作成する

上記のソリューションの問題はデータベースが people と streets に論理的な関係があることを知らないことです。この関係を表現するには、streets テーブルの主キーを指す外部キーを定義する必要があります。

15.2. Lesson: データモデルの実装
このページでは、QGIS プロジェクトの PostgreSQL インストールと設定について説明します。特に、データベースの作成と管理に必要な SQL ステートメントを示します。

### 15.2.9 PostgreSQL でのデータベースの作成と管理

QGIS の一部として使用される PostgreSQL データベースの作成と管理について説明します。まずは、データベースの作成から始めます。

#### データベースの作成

QGIS には、データベースの設定を行うためのスクリプトが用意されています。このスクリプトは、QGIS の設定を反映したデータベースを初期化します。

```sql
create database qgis;
```

#### テーブルの作成

QGIS には、さまざまなテーブルが用意されています。これらのテーブルは、QGIS の設定や使用に応じて作成されます。

```sql
create table qgis (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### テーブルのインデックス

QGIS のテーブルには、インデックスが用意されています。これは、データベースの検索速度を向上させるためです。

```sql
create index people_name_idx on people(name);
```

#### SQL でのテーブルのインデックス追加

SQL ステートメントでは、テーブルのインデックスを追加することもできます。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
create table people (id serial not null primary key, name varchar(50), house_no int not null, street_id int references streets(id) not null, phone_no varchar null);
```

#### 外部キーの設定

データベースのテーブルに外部キーを設定することもできます。これは、データベースの信頼性を向上させるためです。

```sql
alter table people
    add constraint people_streets_fk foreign key (street_id) references streets(id);
```
15.2.10 SQL でテーブルを削除する

テーブルを取り除きたい場合は drop コマンドを使用します:

drop table streets;

ノート: 現在の例では上記のコマンドは動作しないでしょう。なぜでしょうか。こちらを参照して下さい。

people テーブルに同じ drop table コマンドを使う場合は正しく削除されるでしょう:

drop table people;

ノート: 実際にそのコマンドを入力して people テーブルを削除した場合は、再度作成して下さい。次の演習で必要になります。

15.2.11 pgAdmin III 上の単語

We are showing you the SQL commands from the psql prompt because it’s a very useful way to learn about databases. However, there are quicker and easier ways to do a lot of what we are showing you. Install pgAdminIII and you can create, drop, alter etc tables using 'point and click' operations in a GUI.

Ubuntu ではこのようにインストールします:

```bash
sudo apt-get install pgadmin3
```

pgAdmin III は別のモジュールで詳しく取り上げます。

15.2.12 In Conclusion

真新しいデータベースを完全にゼロから作成する方法を見ていきました。

15.2.13 What’s Next?

次は DBMS を使用して新しいデータを追加する方法を学びます。

15.3 Lesson: Adding Data to the Model

The models we’ve created will now need to be populated with the data they’re intended to contain.

The goal for this lesson: To learn how to insert new data into the database models.
15.3.1 Insert statement

How do you add data to a table? The sql INSERT statement provides the functionality for this:

```
insert into streets (name) values ('High street');
```

A couple of things to note:

- After the table name (`streets`), you list the column names that you will be populating (in this case only the `name` column).
- After the `values` keyword, place the list of field values.
- Strings should be quoted using single quotes.
- Note that we did not insert a value for the `id` column; this is because it is a sequence and will be auto-generated.
- If you do manually set the `id`, you may cause serious problems with the integrity of your database.

You should see `INSERT 0 1` if it is successful.

You can see the result of your insert action by selecting all the data in the table:

```
select * from streets;
```

Result:

```
select * from streets;
  id | name
----+-----------------+
   1 | High street
(1 row)
```

**Try Yourself**

Use the INSERT command to add a new street to the `streets` table.

**Check your results**

15.3.2 Sequencing Data Addition According to Constraints

15.3.3 Try Yourself

Try to add a person object to the `people` table with the following details:

Name: Joe Smith
House Number: 55
Street: Main Street
Phone: 072 882 33 21

**Note:** Recall that in this example, we defined phone numbers as strings, not integers.

At this point, you should have an error report if you try to do this without first creating a record for Main Street in the `streets` table.

You should have also noticed that:

- You can’t add the street using its name
- You can’t add a street using a street `id` before first creating the street record on the streets table
Remember that our two tables are linked via a Primary/Foreign Key pair. This means that no valid person can be created without there also being a valid corresponding street record.

Using the above knowledge, add the new person to the database.

Check your results

15.3.4 Select data

We have already shown you the syntax for selecting records. Let’s look at a few more examples:

select name from streets;
select * from streets;
select * from streets where name='Main Road';

In later sessions we will go into more detail on how to select and filter data.

15.3.5 Update data

What if you want to make a change to some existing data? For example, a street name is changed:

update streets set name='New Main Road' where name='Main Road';

Be very careful using such update statements - if more than one record matches your WHERE clause, they will all be updated!

A better solution is to use the primary key of the table to reference the record to be changed:

update streets set name='New Main Road' where id=2;

It should return UPDATE 1.

15.3.6 Delete Data

In order to delete an object from a table, use the DELETE command:

delete from people where name = 'Joe Smith';

Let’s look at our people table now:

address=# select * from people;

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

(0 rows)

15.3.7 Try Yourself

Use the skills you have learned to add some new friends to your database:

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
<td>2</td>
<td>072 887 23 45</td>
</tr>
<tr>
<td>Jane Smith</td>
<td>55</td>
<td>3</td>
<td>072 837 33 35</td>
</tr>
</tbody>
</table>

15.3. Lesson: Adding Data to the Model
15.3.8 In Conclusion

Now you know how to add new data to the existing models you created previously. Remember that if you want to add new kinds of data, you may want to modify and/or create new models to contain that data.

15.3.9 What’s Next?

Now that you’ve added some data, you’ll learn how to use queries to access this data in various ways.

15.4 Lesson: 検索

When you write a SELECT ... command it is commonly known as a query - you are interrogating the database for information.

The goal of this lesson: To learn how to create queries that will return useful information.

<table>
<thead>
<tr>
<th>ノート:</th>
<th>If you did not do so in the previous lesson, add the following people objects to your people table. If you receive any errors related to foreign key constraints, you will need to add the ‘Main Road’ object to your streets table first</th>
</tr>
</thead>
</table>

insert into people (name,house_no, street_id, phone_no)
values ('Joe Bloggs',3,2,'072 887 23 45');
insert into people (name,house_no, street_id, phone_no)
values ('Jane Smith',55,3,'072 837 33 35');
insert into people (name,house_no, street_id, phone_no)
values ('Roger Jones',33,1,'072 832 31 38');
insert into people (name,house_no, street_id, phone_no)
values ('Sally Norman',83,1,'072 932 31 32');

15.4.1 並べ替え結果

Let’s retrieve a list of people ordered by their house numbers:

select name, house_no from people order by house_no;

結果:

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
</tr>
<tr>
<td>Roger Jones</td>
<td>33</td>
</tr>
<tr>
<td>Jane Smith</td>
<td>55</td>
</tr>
<tr>
<td>Sally Norman</td>
<td>83</td>
</tr>
</tbody>
</table>
(4 rows)

You can sort the results by the values of more than one column:

select name, house_no from people order by name, house_no;

結果:
### 15.4.2 フィルタリング

Often you won’t want to see every single record in the database - especially if there are thousands of records and you are only interested in seeing one or two.

Here is an example of a numerical filter which only returns objects whose `house_no` is less than 50:

```sql
select name, house_no from people where house_no < 50;
```

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
</tr>
<tr>
<td>Roger Jones</td>
<td>33</td>
</tr>
</tbody>
</table>

(2 rows)

You can combine filters (defined using the `WHERE` clause) with sorting (defined using the `ORDER BY`):

```sql
select name, house_no from people where house_no < 50 order by house_no;
```

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
</tr>
<tr>
<td>Roger Jones</td>
<td>33</td>
</tr>
</tbody>
</table>

(2 rows)

You can also filter based on text data:

```sql
select name, house_no from people where name like '%s%';
```

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
</tr>
<tr>
<td>Roger Jones</td>
<td>33</td>
</tr>
</tbody>
</table>

(2 rows)

Here we used the `LIKE` clause to find all names with an `s` in them. You’ll notice that this query is case-sensitive, so the `Sally Norman` entry has not been returned.

If you want to search for a string of letters regardless of case, you can do a case-insensitive search using the `ILIKE` clause:

```sql
select name, house_no from people where name ilike '%r%';
```

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roger Jones</td>
<td>33</td>
</tr>
<tr>
<td>Sally Norman</td>
<td>83</td>
</tr>
</tbody>
</table>

(2 rows)

That query returned every `people` object with an `r` or `R` in their name.
15.4.3 JOIN

What if you want to see the person’s details and their street’s name instead of the ID? In order to do that, you need to join the two tables together in a single query. Let’s look at an example:

```sql
select people.name, house_no, streets.name
from people, streets
where people.street_id = streets.id;
```

Note: With joins, you will always state the two tables the information is coming from, in this case people and streets. You also need to specify which two keys must match (foreign key & primary key). If you don’t specify that, you will get a list of all possible combinations of people and streets, but no way to know who actually lives on which street!

Here is what the correct output will look like:

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
<th>name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
<td>Low Street</td>
</tr>
<tr>
<td>Roger Jones</td>
<td>33</td>
<td>High street</td>
</tr>
<tr>
<td>Sally Norman</td>
<td>83</td>
<td>High street</td>
</tr>
<tr>
<td>Jane Smith</td>
<td>55</td>
<td>Main Road</td>
</tr>
</tbody>
</table>

(4 rows)

We will revisit joins as we create more complex queries later. Just remember they provide a simple way to combine the information from two or more tables.

15.4.4 Sub-Select

Sub-selections allow you to select objects from one table based on the data from another table which is linked via a foreign key relationship. In our case, we want to find people who live on a specific street.

First, let’s do a little tweaking of our data:

```sql
insert into streets (name) values('QGIS Road');
insert into streets (name) values('OGR Corner');
insert into streets (name) values('Goodle Square');
update people set street_id = 2 where id=2;
update people set street_id = 3 where id=3;
```

Let’s take a quick look at our data after those changes: we can reuse our query from the previous section:

```sql
select people.name, house_no, streets.name
from people, streets
where people.street_id = streets.id;
```

<table>
<thead>
<tr>
<th>name</th>
<th>house_no</th>
<th>name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roger Jones</td>
<td>33</td>
<td>High street</td>
</tr>
<tr>
<td>Sally Norman</td>
<td>83</td>
<td>High street</td>
</tr>
<tr>
<td>Jane Smith</td>
<td>55</td>
<td>Main Road</td>
</tr>
<tr>
<td>Joe Bloggs</td>
<td>3</td>
<td>Low Street</td>
</tr>
</tbody>
</table>

(4 rows)

Now let’s show you a sub-selection on this data. We want to show only people who live in street_id number 1:

```sql
select people.name
from people, (select *
Although this is a very simple example and unnecessary with our small data-sets, it illustrates how useful and important sub-selections can be when querying large and complex data-sets.

### 15.4.5 クエリの集約

One of the powerful features of a database is its ability to summarise the data in its tables. These summaries are called aggregate queries. Here is a typical example which tells us how many people objects are in our people table:

```sql
select count(*) from people;
```

### 結果:

<table>
<thead>
<tr>
<th>count</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
</tr>
</tbody>
</table>

(1 row)

If we want the counts to be summarised by street name we can do this:

```sql
select count(name), street_id
from people
group by street_id;
```

### 結果:

<table>
<thead>
<tr>
<th>count</th>
<th>street_id</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
</tr>
</tbody>
</table>

(3 rows)

ノート: Because we have not used an ORDER BY clause, the order of your results may not match what is shown here.

### Try Yourself

Summarise the people by street name and show the actual street names instead of the street_ids.

Check your results

### 15.4.6 In Conclusion

You've seen how to use queries to return the data in your database in a way that allows you to extract useful information from it.
15.4.7 What’s Next?

Next you’ll see how to create views from the queries that you’ve written.

15.5 Lesson: ビュー

クエリを記述するときはそれを考案するのに多くの時間と労力が必要です。ビューを使えば SQL クエリの定義を再利用可能な ‘仮想テーブル’ に保存できます。

このレッスンの目標：クエリをビューとして保存します。

15.5.1 ビューの作成

ビューはテーブルのように扱うことができますが、そのデータはクエリから供給されます。上記に基づいて単純なビューを作りましょう:

```
cREATE VIEW roads_count_v AS
  SELECT count(people.name), streets.name
  FROM people, streets
  WHERE people.street_id = streets.id
  GROUP BY people.street_id, streets.name;
```

はじめの `create view roads_count_v as` の部分だけが異なります。そのビューからデータを選択することができます:

```
SELECT * FROM roads_count_v;
```

結果:

```
count | name
-------+-------------
   1 | Main Road
   2 | High street
   1 | Low Street
(3 rows)
```

15.5.2 ビューの変更

ビューは固定されておらず、’実データ’ を持ちません。つまりデータベースの中のデータに影響を与えることなく簡単に変更することができます:

```
CREATE OR REPLACE VIEW roads_count_v AS
  SELECT count(people.name), streets.name
  FROM people, streets
  WHERE people.street_id = streets.id
  GROUP BY people.street_id, streets.name
  ORDER BY streets.name;
```

（また、この例はすべての SQL キーワードには大文字を使用する最良慣行を示しています。）

```
SELECT * FROM roads_count_v;
```

結果:

```
count | name
-------+-------------
   2 | High street
   1 | Low Street
   1 | Main Road
(3 rows)
```
15.5.3 ビューの削除

不要になったビューはこのように削除できます:

drop view roads_count_v;

15.5.4 In Conclusion

ビューを用いてクエリを保存し、テーブルであるかのようにその結果へアクセスできます。

15.5.5 What's Next?

データを変更する時に変更がデータベースの中の他の場所へ影響を及ぼすのが望ましい場合があります。次のレッスンではこの方法を紹介します。

15.6 Lesson: ルール

ルールは "query tree" に書き換えることができます。一つの一般的な使用法は、更新可能ビューを含めて実装することです。Wikipedia より

このレッスンの目標：データベースの新しいルールを作成する方法を学習する。

15.6.1 Materialised ビュー (ルールのベースビュー)

people テーブルにある phone_no の変更すべてを people_log テーブルにログとして記録したいとする。その場合には新しいテーブルを設定する

create table people_log (name text, time timestamp default NOW());

次のステップでは、people テーブル内の phone_no の変更すべてを people_log テーブルにログとして記録するルールを作成

create rule people_log as on update to people
    where NEW.phone_no <> OLD.phone_no
    do insert into people_log values (OLD.name);

ルールが正しく機能することを確認するには、電話番号を変更してみましょう

update people set phone_no = '082 555 1234' where id = 2;

people テーブルが正しく更新されたことを確認してください

select * from people where id=2;

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Joe Bloggs</td>
<td>3</td>
<td>2</td>
<td>082 555 1234</td>
</tr>
</tbody>
</table>

(1 row)

今、作成したルールによって、people_log テーブルは次のようになります

select * from people_log;

<table>
<thead>
<tr>
<th>name</th>
<th>time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe Bloggs</td>
<td>2014-01-11 14:15:11.953141</td>
</tr>
</tbody>
</table>

(1 row)
ノート: time フィールドの値は、現在の日付と時刻に依存します。

15.6.2 In Conclusion
ルールを使用すると、データベースの他の部分の変更を反映するために、自動的にデータベース内でデータを追加または変更することができます。

15.6.3 What’s Next?
次のセクションは、これらのデータベースの概念を使い、GIS データに適用した PostGIS を使用する、空間データベースを紹介します。
Chapter 16

Module: 空間データベースの概念とPostGIS

空間データベースはデータベース内にジオメトリを格納できるようにするだけではなく、これらのジオメトリを用いてクエリを実行してレコードを取得する機能を提供します。このモジュールで私たちはPostgreSQLの拡張であるPostGISを使って空間データベースをセットアップし、シェープファイルからデータをデータベースへインポートし、PostGISの地理的な関数を利用する方法を学びます。

このセクションで作業をしている間、あなたはBoston GIS user groupから入手可能なPostGIS cheat sheetのコピーを持っていることも構いません。もう一つの有用なリソースはオンラインPostGISドキュメントです。

Boundless GeoからPostGISと空間データベースに関するいくつかのより広範なチュートリアルも入手可能です。

- Introduction to PostGIS
- Spatial Database Tips and Tricks

PostGIS onlineも参照して下さい。

16.1 Lesson: PostGISの設定

PostGISの関数を設定することで、PostgreSQLの中から空間関数にアクセス可能になります。
このレッスンの目的: 空間関数をインストールし、それらの効果を簡単にデモする。

ノート: ここではPostGISバージョン2.1を使用を前提としています。インストールとデータベースの設定方法は以前のバージョンと異なりますが、この資料の残りの部分はまだ有効です。インストールおよびデータベースの設定については、お使いのプラットフォームのドキュメントを参照してください。

16.1.1 Ubuntuでのインストール

PostGISはaptから簡単にインストールできます。

\$ sudo apt-get install postgis

\$ sudo apt-get install postgresql-9.1-postgis

本当に簡単です...

ノート: 使用しているUbuntuのバージョンや設定されているリポジトリによって、PostGIS 1.5もしくは2.1がインストールされます。psqlや他のツールでselect PostGIS_full_version();クエリを発行すれば、インストールされたバージョンを知ることができます。
PostGIS最新版をインストールするには、以下のコマンドが使用できます。

$ sudo apt-add-repository ppa:sharpie/for-science
$ sudo apt-add-repository ppa:sharpie/postgis-nightly
$ sudo apt-get update
$ sudo apt-get install postgresql-9.1-postgis-nightly

16.1.2 Windowsでのインストール

Windowsでのインストールは少し複雑ですが、それでも大変ではありません。PostGISのスタックをインストールするには、オンラインである必要があることに注意してください。
まずこのダウンロードページを参照します。
そしてこのガイドに従ってください。
Windowsでのインストールに関する詳細な情報はPostGISのウェブサイトに掲載されています。

16.1.3 その他のプラットフォームでのインストール

The PostGIS websiteには、他のプラットフォームでのインストールの情報を含んでいる情報があります。

16.1.4 PostGISを使用するためのデータベースの設定

Once PostGIS is installed, you will need to configure your database to use the extensions. If you have installed PostGIS version > 2.0, this is as simple as issuing the following command with psql using the address database from our previous exercise.

$ psql -d address -c "CREATE EXTENSION postgis;"

ノート：If you are using PostGIS 1.5 and a version of PostgreSQL lower than 9.1, you will need to follow a different set of steps in order to install the postgis extensions for your database. Please consult the PostGIS Documentation for instructions on how to do this. There are also some instructions in the previous version of this manual.

16.1.5 インストールされたPostGIS関数を見る

PostGIS can be thought of as a collection of in-database functions that extend the core capabilities of PostgreSQL so that it can deal with spatial data. By ‘deal with’, we mean store, retrieve, query and manipulate. In order to do this, a number of functions are installed into the database.

Our PostgreSQL address database is now geospatially enabled, thanks to PostGIS. We are going to delve a lot deeper into this in the coming sections, but let’s give you a quick little taster. Let’s say we want to create a point from text. First we use the psql command to find functions relating to point. If you are not already connected to the address database, do so now. Then run:

\df *point*

This is the command we’re looking for: st_pointfromtext. To page through the list, use the down arrow, then press q to quit back to the psql shell.

このコマンドを実行してみましょう:

select st_pointfromtext('POINT(1 1)');

結果:
st_pointfromtext
--------------------------------------------
010100000000000000000000000000000F03F00000000000000000000000F03F
(1 row)

The resulting row is in the OGC format called ‘Well Known Binary’ (WKB). We will look at this format in detail in the next section.

To get the results back as text, we can do a quick scan through the function list for something that returns text:
\df *text

The query we’re looking for now is st_astext. Let’s combine it with the previous query:

select st_astext(st_pointfromtext('POINT(1 1)'));

Here, we entered the string POINT(1,1), turned it into a point using st_pointfromtext(), and turned it back into a human-readable form with st_astext(), which gave us back our original string.

What did that do? It created a buffer of 1 degree around our point, and returned the result as text.

### 16.1.6 空間参照系

In addition to the PostGIS functions, the extension contains a collection of spatial reference system (SRS) definitions as defined by the European Petroleum Survey Group (EPSG). These are used during operations such as coordinate reference system (CRS) conversions.

We can inspect these SRS definitions in our database as they are stored in normal database tables.

First, let’s look at the schema of the table by entering the following command in the psql prompt:
\d spatial_ref_sys

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>srid</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>auth_name</td>
<td>character varying(256)</td>
<td></td>
</tr>
<tr>
<td>auth_srid</td>
<td>integer</td>
<td></td>
</tr>
<tr>
<td>srtext</td>
<td>character varying(2048)</td>
<td></td>
</tr>
<tr>
<td>proj4text</td>
<td>character varying(2048)</td>
<td></td>
</tr>
</tbody>
</table>

indexes:
"spatial_ref_sys_pkey" PRIMARY KEY, btree (srid)
QGIS Training Manual, リリース 2.2

You can use standard SQL queries (as we have learned from our introductory sections), to view and manipulate this table - though its not a good idea to update or delete any records unless you know what you are doing.

One SRID you may be interested in is EPSG:4326 - the geographic / lat lon reference system using the WGS 84 ellipsoid. Let’s take a look at it:

```sql
select * from spatial_ref_sys where srid=4326;
```

結果:

```
srid  | 4326
auth_name | EPSG
auth_srid | 4326
srtext  | GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.25723563,AUTHORITY["EPSG","7030"]],TOWGS84[0, 0,0,0,0,0,0],AUTHORITY["EPSG","6326"],PRIMEM["Greenwich",0, AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251994328, AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]
proj4text | +proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs
```

The `srtext` is the projection definition in well known text (you may recognise this from .prj files in your shapefile collection).

16.1.7 In Conclusion

You now have PostGIS functions installed in your copy of PostgreSQL. With this you’ll be able to make use of PostGIS’ extensive spatial functions.

16.1.8 What’s Next?

次はデータベースにおける空間フィーチャの表現方法について学習しましょう。

16.2 Lesson: 単純地物モデル

データベースの中にどのように地物を保存し、表現できるでしょうか? このレッスンでは OGC によって定義されている単純地物モデルを見ていきます。

このレッスンの目標: SFS モデルとは何か、それをどうやって使うかを学習します。

16.2.1 OGC とは

The Open Geospatial Consortium (OGC), an international voluntary consensus standards organization, originated in 1994. In the OGC, more than 370+ commercial, governmental, nonprofit and research organizations worldwide collaborate in an open consensus process encouraging development and implementation of standards for geospatial content and services, GIS data processing and data sharing. - Wikipedia

16.2.2 SFS モデルとは

The Simple Feature for SQL (SFS) モデルとはデータベースに地理空間データを格納する 非トポロジカル な方法で、データへのアクセス、操作、構築のための関数を定義しています。
モデルはポイントやラインストリング、ポリゴンのタイプ（そしてそれらの集合）で地理空間データを定義します。
詳細については OGC Simple Feature for SQL 標準を参照して下さい。

16.2.3 ジオメトリフィールドをテーブルに追加する

people テーブルにポイントフィールドを追加してみましょう:

```sql
alter table people add column the_geom geometry;
```

16.2.4 ジオメトリタイプに基づく制約を追加する

ジオメトリフィールドの型はどのタイプのジオメトリであるかを指定していないことがわかるでしょう。そこで制約が必要となります:

```sql
alter table people
add constraint people_geom_point_chk
    check(st_geometrytype(the_geom) = 'ST_Point':text OR the_geom IS NULL);
```

これはポイントジオメトリまたは null 値だけを受け入れる制約をテーブルに追加します。

16.2.5 Try Yourself

cities という新しいテーブルを作成して、それに適切な列を追加します。それにはポリゴン（市の境界）を格納するジオメトリフィールドを含めて、ジオメトリをポリゴンに制限する制約を追加して下さい。

結果をチェックする

16.2.6 geometry_columns テーブルの設定

この時点で geometry_columns テーブルにもエントリを追加する必要があります:

```sql
insert into geometry_columns values
    ('','public','people','the_geom',2,4326,'POINT');
```
なぜでしょう？geometry_columns はデータベースの中のどのテーブルがジオメトリデータを持っているかをアプリケーションが認識するために使われます。

ノート: 上記の INSERT ステートメントでエラーが発生する場合にはまずこのクエリを実行します:

```
select * from geometry_columns;
```

If the column :kbd:`f_table_name` contains the value :kbd:`people`, then this table has already been registered and you don’t need to do anything more.

2 の値は次元の数を指しています。この場合は 2 です: x と y.

4326 の値は私たちが使っている投影法を指しています。WGS 84 は 4326 の数字で参照されます (EPSG に関する以前の解説を参照して下さい)。

Try Yourself

新しい cities レイヤのための適切なエントリを geometry_columns に追加して下さい

結果をチェックする

16.2.7 SQL を使用してテーブルにジオメトリレコードを追加する

私たちのテーブルにジオメトリを格納することができるようになりました:

```
insert into people (name,house_no, street_id, phone_no, the_geom)
values ('Fault Towers',
    34,
    3,
    '072 812 31 28',
    'SRID=4326;POINT(33 -33)');
```

ノート: 上記の新しいエントリには使用する投影法 (SRID) を指定する必要があります。これはプレーンテキストを用いて新しいポイントのジオメトリを入力すると正しい投影情報が自動的に付加されないためです。新しいポイントはデータセットと同じ SRID を使用する必要がありますのでそれを指定しなければいけません。

もしグラフィカルなインターフェイスを使用していていれば、たとえば、各ポイントの投影法は自動で指定されます。つまり以前行ったようにデータセットに投影法を指定しておけば、すべてのポイントに対して正しい投影法を指定してなくてもよいのです。

では QGIS を開いて people テーブルを表示します。そしてデータベースでレコードの編集/追加/削除を試し、選択クエリを実行してデータがどのように変更されたかを見ます。

QGIS で PostGIS レイヤーを読み込むには レイヤ → PostGIS レイヤの追加 メニューオプションまたは次のツールバー・ボタンを使用します:

ダイアログが表示されます:
新規 ボタンをクリックしてこのダイアログを開きます:
新しい接続を定義します。例えば：

Name: myPG
Service: 
Host: localhost
Port: 5432
Database: address
User: 
Password: 

QGIS が address データベースを見つけたかどうか、そしてユーザ名とパスワードが正しいことを確認するには、接続テストをクリックします。正しく動作したらユーザ名の保存とパスワード保存の横にあるチェックボックスをチェックします。そして OK ボタンをクリックしてこの接続を作成します。
PostGIS レイヤの追加 ダイアログに戻り 接続 をクリックし、いつものようにプロジェクトにレイヤを追加します。

Try Yourself

人の名前と街路の名前、位置 (the_geom 列) をブレーンテキストとして表示するクエリを作成して下さい。
結果をチェックする

16.2.8 In Conclusion

空間オブジェクトをデータベースに追加して GIS ソフトウェアで表示する方法を見てきました。

16.2.9 What’s Next?

次はデータベースへデータをインポートする方法、およびデータベースからデータをエクスポートする方法を見ていきます。

16.3 Lesson: インポートとエクスポート

もちろん、簡単にデータを移行する方法はなく、そこから多く使用されることがありません。しかし、幸いなことに簡単にデータを移動でき、PostGIS に出力するツールがいくつかあります。

16.3.1 shp2pgsql

shp2pgsql は、ESRI シェーブファイルをデータベースへインポートするためのコマンドラインツールです。Unixでは新しいPostGISのテーブルをインポートするために、次のようなコマンドを使用できます:

```
shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> | \n  psql -d <databasename> -h <hostname> -U <username>
```

Windowsでは2ステップでインポート処理を実行します

```
shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> > import.sql
psql -d <databasename> -h <hostname> -U <username> -f import.sql
```

次のようなエラーが発生することがあります

```
ERROR: operator class "gist_geometry_ops" does not exist for access method "gist"
```

これは、インポートするデータのために空間インデックス in situ を作成するための既知の問題です。エラーを回避するためには、-1 パラメータを外します。これは空間インデックスが直接作成されないことを意味します。データがインポートされた後にデータベースに空間インデックスを作成する必要があります (空間インデックスの作成は、次のレッスンで説明します。)

16.3.2 psql2shp

psql2shp は、PostGIS のテーブル、ビュー、または SQL の select クエリをエクスポートするためのコマンドラインツールです。Unixでは次のように実行します

```
psql2shp -f <path to new shapefile> -g <geometry column name> \
 -h <hostname> -U <username> <databasename> <table | view>
```
クエリを使用してデータをエクスポートするには

```
pgsql2shp -f <path to new shapefile> -g <geometry column name> \
-he <hostname> -U <username> "<query>"
```

16.3.3 ogr2ogr

`ogr2ogr` は、PostGIS を多くのデータフォーマットに変換する強力なツールです。`ogr2ogr` は、GDAL/OSR ソフトウェアの一部であり、個別にインストールする必要があります。テーブルを PostGIS から GML へエクスポートするには、このコマンドを使用することができます。

```
ogr2ogr -f GML export.gml PG:'dbname=<databasename> user=<username> \
host=<hostname>’ <Name of PostGIS-Table>
```

16.3.4 SPIT

SPIT は QGIS と一緒に配布される QGIS プラグインです。PostGIS に ESRI シェープファイルをアップロードするために SPIT を使用することができます。

`Plugin Manager` を介して SPIT プラグインを追加したら、このボタンを探します:

このボタンをクリックするか、メニューから Database -> Spite -> Import Shapefiles to PostgreSQL のように多たら、SPIT ダイアログを表示できます。

![SPIT - Shapefile to PostGIS Import Tool](image.png)
Add ボタンをクリックすることでファイルブラウザウィンドウを開き、データベースにシェープファイルを追加することができます。

16.3.5 DB Manager

Database メニュー内の DB Manager という別のオプションに気づいているかもしれません。これは PostGIS を含む空間データベースと対話する統一的なインターフェースを持った QGIS 2.0 の新しいツールです。このツールもインポートしたデータベースから他のフォーマットにエクスポートすることができます。次のようなモジュールは、主にこのツールを使うことを念頭に置いているので、ここでは簡単にそれを説明します。

16.3.6 In Conclusion

データベースとの間でデータをインポート及びエクスポートは、多様な方法で行うことができます。異なるデータベースを使用する場合は特に、この機能（またはこの機能に似た機能）を使用します。

16.3.7 What’s Next?

次に、私たちが以前に作成したデータを参照する方法を見ていきます。

16.4 Lesson: 空間検索

地理空間情報のクエリは、その他のデータベースのクエリと変わりなく、同じように利用できます。PostGIS をインストールすることでデータベースのクエリの機能が追加されます。

このレッスンの目的は地理空間関数が、一般的な地理空間以外の関数と同様に導入できることを明らかにすることです。

16.4.1 地理空間オペレータ

ある地点 (X,Y) から 2 度距離がある地点を特定したい場合以下の操作ができます

```sql
select * 
from people 
where st_distance(the_geom,'SRID=4326;POINT(33 -34)') < 2;
```

結果:

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
<th>the_geom</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Fault Towers</td>
<td>34</td>
<td>3</td>
<td>072 812 31 28</td>
<td>01010008040C0</td>
</tr>
</tbody>
</table>
(1 row)

ノート: 上記 geom value は当サイトのスペースを残すため削除されました。human-readable coordinates を確認するためには、"View a point as WKT" セクションと類似した操作で確認することができます。

上述のクエリが 2 度という空間内にある地点をすべてかえすということはどうしたらわかりますでしょうか？なぜメートル、あるいはその他の単位ではないのでしょうか？

結果をご確認ください

16.4. Lesson: 空間検索
16.4.2 地理空間インデックス

地理空間のインデックスも定義することができます。地理空間のインデックスはクエリを高速化します。地理空間のインデックスをジオカラムに作成するには:

```
CREATE INDEX people_geo_idx
ON people
USING gist
(the_geom);
```

\d people

結果:

Table "public.people"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td>name</td>
<td>character varying</td>
<td>nextval('people_id_seq'::regclass)</td>
</tr>
<tr>
<td>house_no</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>street_id</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>phone_no</td>
<td>character varying</td>
<td></td>
</tr>
<tr>
<td>the_geom</td>
<td>geometry</td>
<td></td>
</tr>
</tbody>
</table>

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_geo_idx" gist (the_geom) <-- new spatial key added
"people_name_idx" btree (name)

Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) = 'ST_Point':::text
OR the_geom IS NULL)

Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)

16.4.3 Try Yourself

Modify the cities table so its geometry column is spatially indexed.

結果の確認

16.4.4 PostGIS 空間関数デモ

PostGIS の空間関数のデモを行うため、いくつかの（架空の）データを含む新しいデータベースを作成します。

開始のため、新しいデータベース（第一に psql シェルが存在する）を作成します:

```
createdb postgis_demo
```

Remember to install the postgis extensions:

```
psql -d postgis_demo -c "CREATE EXTENSION postgis;"
```

Next, import the data provided in the exercise_data/postgis/ directory. Refer back to the previous lesson for instructions, but remember that you’ll need to create a new PostGIS connection to the new database. You can import from the terminal or via SPT. Import the files into the following database tables:

- points.shp into building
- lines.shp into road
- polygons.shp into region
Load these three database layers into QGIS via the Add PostGIS Layers dialog, as usual. When you open their attribute tables, you’ll note that they have both an id field and a gid field created by the PostGIS import.

Now that the tables are imported, we can use PostGIS to query the data. Go back to your terminal (command line) and enter the psql prompt by running:

```
psql postgis_demo
```

We’ll demo some of these select statements by creating views from them, so that you can open them in QGIS and see the results.

場所による選択

Get all the buildings in the KwaZulu region:

```
SELECT a.id, a.name, st_astext(a.the_geom) as point 
  FROM building a, region b 
  WHERE st_within(a.the_geom, b.the_geom) 
  AND b.name = 'KwaZulu';
```

結果:

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>point</th>
</tr>
</thead>
<tbody>
<tr>
<td>30</td>
<td>York</td>
<td>POINT(1622345.23785063 6940490.65844485)</td>
</tr>
<tr>
<td>33</td>
<td>York</td>
<td>POINT(1622495.65620524 6940403.87862489)</td>
</tr>
<tr>
<td>35</td>
<td>York</td>
<td>POINT(1622403.09106394 6940212.96302097)</td>
</tr>
<tr>
<td>36</td>
<td>York</td>
<td>POINT(1622287.38463732 6940357.59605424)</td>
</tr>
<tr>
<td>40</td>
<td>York</td>
<td>POINT(1621888.19746548 6940508.01440885)</td>
</tr>
</tbody>
</table>

(5 rows)

Or, if we create a view from it:

```
CREATE VIEW vw_select_location AS 
  SELECT a.gid, a.name, a.the_geom 
  FROM building a, region b 
  WHERE st_within(a.the_geom, b.the_geom) 
  AND b.name = 'KwaZulu';
```

Add the view as a layer and view it in QGIS:
近傍の選択

北海道地区に隣接するエリアの名称すべてのリストを表示します。

```sql
SELECT b.name 
FROM region a, region b 
WHERE st_touches(a.the_geom, b.the_geom) 
AND a.name = 'Hokkaido';
```

結果:

```
name  
-----
Missouri
Saskatchewan
Wales
(3 rows)
```

見た目として:

```sql
CREATE VIEW vw_regions_adjoining_hokkaido AS
SELECT b.gid, b.name, b.the_geom 
FROM region a, region b 
WHERE TOUCHES(a.the_geom, b.the_geom) 
AND a.name = 'Hokkaido';
```

QGIS では:
Note the missing region (Queensland). This may be due to a topology error. Artifacts such as this can alert us to potential problems in the data. To solve this enigma without getting caught up in the anomalies the data may have, we could use a buffer intersect instead:

```
CREATE VIEW vw_hokkaido_buffer AS
  SELECT gid, ST_BUFFER(the_geom, 100) as the_geom
  FROM region
  WHERE name = 'Hokkaido';
```

北海道の周囲に100m のバッファを作成します。
暗いエリアがバッファです:
Select using the buffer:

CREATE VIEW vw_hokkaido_buffer_select AS
SELECT b.gid, b.name, b.the_geom
FROM (
    SELECT * FROM vw_hokkaido_buffer
) a,
region b
WHERE ST_INTERSECTS(a.the_geom, b.the_geom)
AND b.name != 'Hokkaido';

In this query, the original buffer view is used as any other table would be. It is given the alias a, and its geometry field, a.the_geom, is used to select any polygon in the region table (alias b) that intersects it. However, Hokkaido itself is excluded from this select statement, because we don’t want it; we only want the regions adjoining it.

QGIS では:
It is also possible to select all objects within a given distance, without the extra step of creating a buffer:

```
CREATE VIEW vw_hokkaido_distance_select AS
    SELECT b.gid, b.name, b.the_geom
    FROM region a, region b
    WHERE ST_DISTANCE (a.the_geom, b.the_geom) < 100
    AND a.name = 'Hokkaido'
    AND b.name != 'Hokkaido';
```

This achieves the same result, without need for the interim buffer step:
Select unique values

クイーンズランド州に所在する建物の所在地の村の名前をリストにします。

```
SELECT DISTINCT a.name
    FROM building a, region b
    WHERE st_within(a.the_geom, b.the_geom)
    AND b.name = 'Queensland';
```

結果:
```
name
---------
Beijing
Berlin
Atlanta
(3 rows)
```

その他の事例

```
CREATE VIEW vw_shortestline AS
    SELECT b.gid AS gid, ST_ASTEXT(ST_SHORTESTLINE(a.the_geom, b.the_geom)) as text, ST_SHORTESTLINE(a.the_geom, b.the_geom) AS the_geom
    FROM road a, building b
    WHERE a.id=5 AND b.id=22;

CREATE VIEW vw_longestline AS
    SELECT b.gid AS gid, ST_ASTEXT(ST_LONGESTLINE(a.the_geom, b.the_geom)) as text, ST_LONGESTLINE(a.the_geom, b.the_geom) AS the_geom
    FROM road a, building b
    WHERE a.id=5 AND b.id=22;

CREATE VIEW vw_road_centroid AS
    SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom
    FROM road a
    WHERE a.id = 1;

CREATE VIEW vw_region_centroid AS
    SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom
    FROM region a
    WHERE a.name = 'Saskatchewan';

SELECT ST_PERIMETER(a.the_geom)
    FROM region a
    WHERE a.name='Queensland';

SELECT ST_AREA(a.the_geom)
    FROM region a
    WHERE a.name='Queensland';

CREATE VIEW vw_simplify AS
    SELECT gid, ST_Simplify(the_geom, 20) AS the_geom
    FROM road;

CREATE VIEW vw_simplify_more AS
    SELECT gid, ST_Simplify(the_geom, 50) AS the_geom
    FROM road;

CREATE VIEW vw_convex_hull AS
    SELECT
        ROW_NUMBER() over (order by a.name) as id,
        a.name as town,
```
ST_CONVEXHULL(ST_COLLECT(a.the_geom)) AS the_geom
FROM building a
GROUP BY a.name;

16.4.5 In Conclusion

You have seen how to query spatial objects using the new database functions from PostGIS.

16.4.6 What’s Next?

Next we’re going to investigate the structures of more complex geometries and how to create them using PostGIS.

16.5 Lesson: ジオメトリの構成

このセクションではシンプルなジオメトリが SQL でどのように構成されているか少し掘り下げます。実際には、複雑なジオメトリをデジタイジングツールを使用して作るためには、QGIS のような GIS を使用するでしょう。しかし、それらがどのように形作られているかを知ることは、クエリを書いたりデータベースがどのように作られているかを理解するのに役立ちます。

このレッスンの目的 PostgreSQL/PostGIS で空間要素を直接作成する方法をよく理解する。

16.5.1 ラインストリングの作成

Going back to our address database, let’s get our streets table matching the others; i.e., having a constraint on the geometry, an index and an entry in the geometry_columns table.

16.5.2 Try Yourself

- Modify the streets table so that it has a geometry column of type ST_LineString. * Don’t forget to do the accompanying update to the geometry columns table! * Also add a constraint to prevent any geometries being added that are not LINESTRINGS or null. * Create a spatial index on the new geometry column.

結果の確認

では、ラインストリングを streets テーブルに挿入しましょう。この場合は、既存の道路のレコードを更新します。

update streets set the_geom = 'SRID=4326;LINESTRING(20 -33, 21 -34, 24 -33)' where streets.id=2;

結果を QGIS で確認してみます。（"レイヤ" パネルの streets レイヤを右クリックし、"レイヤの領域にズームする" を選択する必要があるかもしれません。）

いくつかは QGIS から、いくつかはコマンドラインから道路の要素をもう少し追加します。

16.5.3 ポリゴンの作成

ポリゴンを作成することも簡単です。覚えておくことは、定義により、ポリゴンは最低 4 つの頂点を持ち、最初と最後の頂点は同じ場所になるということです。

insert into cities (name, the_geom) values ('Tokyo', 'SRID=4326;POLYGON((10 -10, 5 -32, 30 -27, 10 -10))');

16.5. Lesson: ジオメトリの構成
ノート: A polygon requires double brackets around its coordinate list; this is to allow you to add complex polygons with multiple unconnected areas. For instance

```
insert into cities (name, the_geom) values ('Tokyo Outer Wards', 'SRID=4326;POLYGON((20 10, 20 20, 35 20, 20 10), (-10 -30, -5 0, -15 -15, -10 -30))');
```

If you followed this step, you can check what it did by loading the cities dataset into QGIS, opening its attribute table, and selecting the new entry. Note how the two new polygons behave like one polygon.

### 16.5.4 練習:Cities を People にリンクする

For this exercise you should do the following:

- Delete all data from your people table.
- Add a foreign key column to people that references the primary key of the cities table.
- Use QGIS to capture some cities.
- Use SQL to insert some new people records, ensuring that each has an associated street and city.

Your updated people schema should look something like this:

```sql
\d people
Table "public.people"
Column | Type          | Modifiers
-------------------------+-----------------------------+--------------------------------------------
id           | integer | not null
|             |        | default nextval('people_id_seq':regclass)
name        | character varying(50) |
house_no    | integer | not null
street_id   | integer | not null
phone_no    | character varying |
the_geom    | geometry |
city_id     | integer | not null
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_name_idx" btree (name)
Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) = 'ST_Point':text OR the_geom IS NULL)
Foreign-key constraints:
"people_city_id_fkey" FOREIGN KEY (city_id) REFERENCES cities(id)
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)
```

### 16.5.5 スキーマに着目する

スキーマはこのように見えるべきです:
16.5.6 Try Yourself

Create city boundaries by computing the minimum convex hull of all addresses for that city and computing a buffer around that area.

16.5.7 Access Sub-Objects

With the SFS-Model functions, you have a wide variety of options to access sub-objects of SFS Geometries. When you want to select the first vertex point of every polygon geometry in the table myPolygonTable, you have to do this in this way:

- Transform the polygon boundary to a linestring:
  
  ```sql
  select st_boundary(geometry) from myPolygonTable;
  ```

- Select the first vertex point of the resultant linestring:
  
  ```sql
  select st_startpoint(myGeometry)
  from (select st_boundary(geometry) as myGeometry
         from myPolygonTable) as foo;
  ```

16.5.8 データプロセッシング

PostGIS supports all OGC SFS/MM standard conform functions. All these functions start with `ST_`.

16.5.9 クリッピング

To clip a subpart of your data you can use the `ST_INTERSECT()` function. To avoid empty geometries, use:

```sql
where not st_isempty(st_intersection(a.the_geom, b.the_geom))
```
select st_intersection(a.the_geom, b.the_geom), b.*
from clip as a, road_lines as b
where not st_isempty(st_intersection(st_setsrid(a.the_geom, 32734),
    b.the_geom));
16.5.10 Building Geometries from Other Geometries

From a given point table, you want to generate a linestring. The order of the points is defined by their id. Another ordering method could be a timestamp, such as the one you get when you capture waypoints with a GPS receiver.

To create a linestring from a new point layer called ‘points’, you can run the following command:

```sql
select ST_LineFromMultiPoint(st_collect(the_geom)), 1 as id
from (select the_geom
       from points
       order by id
     ) as foo;
```

To see how it works without creating a new layer, you could also run this command on the ‘people’ layer, although of course it would make little real-world sense to do this.
16.5.11 ジオメトリクリーニング

You can get more information for this topic in this blog entry.

16.5.12 Differences between tables

To detect the difference between two tables with the same structure, you can use the PostgreSQL keyword EXCEPT:

```
select * from table_a
except
select * from table_b;
```

As the result, you will get all records from table_a which are not stored in table_b.

16.5.13 表領域

You can define where postgres should store its data on disk by creating tablespaces:

```
CREATE TABLESPACE homespace LOCATION '/home/pg';
```

When you create a database, you can then specify which tablespace to use e.g.:
16.5.14 In Conclusion

You’ve learned how to create more complex geometries using PostGIS statements. Keep in mind that this is mostly to improve your tacit knowledge when working with geo-enabled databases through a GIS frontend. You usually won’t need to actually enter these statements manually, but having a general idea of their structure will help you when using a GIS, especially if you encounter errors that would otherwise seem cryptic.
Chapter 17

QGIS プロセッシングガイド

このモジュールは Victor Olaya 氏による貢献です。

内容:

17.1 Introduction

このガイドでは、QGIS プロセッシングフレームワークを使用する方法について説明します。これはプロセッシングフレームワークや、フレームワークが依存するアプリケーションなどについての知識を必要とするものではありません。QGIS の基本的な知識が必要とされるのみです。

このガイドは自習用に設計されたプロセッシングワークショップを実行するためのものです。

このガイドは QGIS 2.0 を対象としています。それ以外のバージョンでは動作しないか、利用できない場合があります。

This guide is comprised of a set of small exercises of progressive complexity. If you have never used the processing framework, you should start from the very beginning. If you have some previous experience, feel free to skip lessons. They are more or less independent from each other, and each one introduces some new concept or some new element, which is indicated in the chapter title and the short introduction at the beginning of each chapter. That should make it easy to locate lessons dealing with a particular topic.

すべてのフレームワークコンポーネントとその使用方法の体系的な説明のために、QGIS マニュアルの該当する章を確認することをお勧めします。このガイドに沿ってサポートテキストとしてください。

All the exercises in this guide use free data set that can be downloaded here. The zip file to download contains several folders corresponding to each one of the lessons in this guide. In each of them you will find a QGIS project file. Just open it and you will be ready to start the lesson.

Enjoy!

17.2 An important warning before starting

Just like the manual of a word processor doesn’t teach you how to write a novel or a poem, or a CAD tutorial doesn’t show you how to calculate the size of a beam for a building, this guide will not teach you spatial analysis. Instead, it will show you how to use the QGIS processing framework, a powerful tool for performing spatial analysis, but it is up to you to learn the required concepts that are needed to understand that type of analysis. Without them, there is no point on using the framework and its algorithms, although you might be tempted to try.

Let’s show this more clearly with an example.

Given a set of points and a value of a given variable value at each point, you can calculate a raster layer from them using the Kriging geoalgorithm. The parameters dialog for that module is like the following one.
It look complex, right?

By reading this manual, you will learn things such as how to use that module, how to run it in a batch process to create raster layers from hundreds of points layers in a single run, or what happens if the input layer has some points selected. However, the parameters themselves are not explained. A seasoned analyst with a good knowledge of geostatistics will have no problem understanding those parameters. If you are not one of them and sill, range, or nugget are not familiar concepts to you, then you should not use the Kriging module. More than that, you are far from being ready to use the Kriging module, since it requires learning about concepts such as spatial autocorrelation or semivariograms, which probably you also haven’t heard before, or at least haven’t studied long enough. You should first study and understand them, and then come back to QGIS to actually run it and perform the analysis. Ignoring this will result in wrong results and poor (and most likely useless) analysis.

Although not all algorithms are as complex as kriging (but some of them are even more complex!), almost all of them require understanding the fundamental analysis ideas that they are based on. Without that knowledge, using them will most likely lead to poor results.

Using geoolgorithms without having a good foundation of spatial analysis is like trying to write a novel without
knowing anything about grammar or syntax, and having no knowledge about storytelling. You might get a result, but it is likely to have no value at all. Please, don’t fool yourself and think that after reading this guide you are already capable of performing spatial analysis and get sound results. You need to study spatial analysis as well.

Here is a good reference that you can read to learn more about spatial data analysis.


It is available online here

17.3 プロセッシングフレームワークを構成する

プロセッシングフレームワークを使う前に環境設定をします。設定項目は多くないので簡単です。
その後、我々は、利用可能なアルゴリズムのリストを拡張するために使用されている外部アプリケーションを構成する方法を示しますが、今は我々だけでフレームワーク自体で作業しようとしています。

The processing framework is a core QGIS plugin, which means that, if you are running QGIS 2.0, it should already be installed in your system, since it is included with QGIS. In case it is active, you should see a menu called Processing in your menu bar. There you will find an access to all the framework components.

メニューや見つけられない場合、プラグインマネージャでそれを有効にすることで、プラグインを使用可能にする必要があります。
The main element that we are going to work with is the toolbox. Click on the corresponding menu entry and you will see the toolbox docked at the right side of the QGIS window.

By default, you will see the simplified mode, which groups algorithms according to the kind of operation they perform. Although some of the algorithms that you will see in the toolbox depend on other external applications (most of them do, in fact), you will not see any mention to those applications. The origin of algorithms is hidden in this mode, which is a facade that simplifies using algorithms through the processing framework.

Examples in this guide only use the simplified mode. The advanced mode has some additional features and algorithms, but it requires understanding the applications that are called, so they are a more advanced topic. Some of these more advanced ideas are introduced in the final lessons of this book, but for the rest of them we will just use the simplified interface.

ツールボックスはすべての利用可能なアルゴリズムのリストを含み、グループで分けられています。構成するこれらのアルゴリズムを表示する方法は2つあります: advanced mode と *simplified* モードです。
If you have reached this point, now you are ready to use geoalgorithms. There is no need to configure anything else by now. We can already run our first algorithm, which we will do in the next lesson.

### 17.4 Running our first algorithm. The toolbox

#### メモ: In this lesson we will run our first algorithm, and get our first result from it.

As we have already mentioned, the processing framework can run algorithms from other applications, but it also contains native algorithm that need no external software to be run. To start exploring the processing framework, we are going to run one of those native algorithms. In particular, we are going to calculate the centroids of set of polygons.

First, open the QGIS project corresponding to this lesson. It contains just a single layer with two polygons.
Now go to the text box at the top of the toolbox. That is the search box, and if you type text in it, it will filter the list of algorithms so just those ones containing the entered text are shown. Type *centroids* and you should see something like this.

![Processing Toolbox](image)

The search box is a very practical way of finding the algorithm you are looking for.

To execute an algorithm, you just have to double-click on its name in the toolbox. When you double-click on the *Centroids* algorithm, you will see the following dialog.
All algorithms have a similar interface, which basically contains input parameters that you have to fill, and outputs that you have to select where to store. In this case, the only inputs we have are a vector layer with polygons and a selector to select whether we want several centroids for a single feature in case it is a multipart features, or the algorithm should generate just one centroid for each feature.

Select the Polygons layer as input. The other field will have no effect at all, since the input layer has no multi-part features.

The algorithm has a single output, which is the centroids layer. There are two options to define where a data output is saved: enter a filepath or save it to a temporary filename.

In case you want to set a destination and not save the result in a temporary file, the format of the output is defined by the filename extension. To select a format, just select the corresponding file extension (or add it if you are directly typing the filepath instead). If the extension of the filepath you entered does not match any of the supported ones, a default extension (usually .dbf for tables, .tif for raster layers and .shp for vector ones) will be appended to the filepath and the file format corresponding to that extension will be used to save the layer or table.

In all the exercises in this guide, we will be saving results to a temporary file, since there is no need to save them for a later use. Feel free to save them to a permanent location if you want to.

Notice that temporary files are deleted once you close QGIS. If you create a project with an output that was saved as a temporary output, QGIS will complain when you try to open back the project later, since that output file will not exist.

Once you have configured the algorithm dialog, press Run to run the algorithm.

You will get the following output.
The output has the same CRS as the input. Geoalgorithms assumes all input layers share the same CRS and does not perform any reprojection. Except in the case of some special algorithms (for instance, reprojection ones), the outputs will also have that same CRS. We will see more about this soon.

Try yourself saving it using different file formats (use, for instance, .shp and .geojson as extensions). Also, if you do not want the layer to be loaded in QGIS after it is generated, you can check off the check box that is found below the output path box.

### 17.5 More algorithms and data types

**Note**: In this lesson we will run three more algorithms, learn how to use other input types, and configure outputs to be saved to a given folder automatically.

For this lesson we will need a table and a polygons layer. We are going to create a points layer based on coordinates in the table, and then count the number of points in each polygon. If you open the QGIS project corresponding to this lesson, you will find a table with X and Y coordinates, but you will find no polygons layer. Don't worry, we will create it using a processing geoalgorithm.

The first thing we are going to do is to create a points layer from the coordinates in the table, using the Convert table to points algorithm. You now know how to use the search box, so it should not be hard for you to find it. Double-click on it to run it and get to its following dialog.

This algorithm, like the one from the previous lesson, just generates a single output, and it has three inputs:

- **Table**: the table with the coordinates. You should select here the table from the lesson data.
- **X and Y fields**: these two parameters are linked to the first one. The corresponding selector will show the name of those fields that are available in the selected table. Select the $XCOORD$ field for the $X$ parameter, and the $YCOORD$ field for the $Y$ parameter.
- **CRS**: Since this algorithm takes no input layers, it cannot assign a CRS to the output layer based on them. Instead, it asks you to manually select the CRS that the coordinates in the table use. Click on the button on the left-hand side to open the QGIS CRS selector, and select EPSG:4326 as the output CRS. We are using this CRS because the coordinates in the table are in that CRS.
Your dialog should look like this.

![Image of Points layer from table dialog]

Now press the Run button to get the following layer:

![Image of Points layer from table result]

The next thing we need is the polygon layer. We are going to create a regular grid of polygons using the Create grid algorithm, which has the following parameters dialog.
The inputs required to create the grid are all numbers. When you have to enter a numerical value, you have two options: typing it directly on the corresponding box or clicking the button on the right-hand side to get to a dialog like the one shown next.
The dialog contains a simple calculator, so you can type expressions such as $11 * 34.7 + 4.6$, and the result will be computed and put in the corresponding text box in the parameters dialog. Also, it contains constants that you can use, and values from other layers available.

In this case, we want to create a grid that covers the extent of the input points layer, so we should use its coordinates to calculate the center coordinate of the grid and its width and height, since those are the parameters that the algorithm takes to create the grid. With a little bit of math, try to do that yourself using the calculator dialog and the constants from the input points layer.

Select Rectangles (polygons) in the Type field.

As in the case of the last algorithm, we have to enter the CRS here as well. Select EPSG:4326 as the target CRS, as we did before.

In the end, you should have a parameters dialog like this:
Press Run and you will get the graticule layer.
The last step is to count the points in each of the rectangles of that graticule. We will use the \textit{Count points in polygons} algorithm.

Now we have the result we were looking for.

Before finishing this lesson, here is a quick tip to make your life easier in case you want to persistently save your data. If you want all your output files to be saved in a given folder, you do not have to type the folder name each time. Instead, go to the processing menu and select the \textit{Options and configuration} item. It will open the
configuration dialog.

In the *Output folder* entry that you will find in the *General* group, type the path to your destination folder.
Now when you run an algorithm, just use the filename instead of the full path. For instance, with the configuration shown above, if you enter graticule.shp as the output path for the algorithm that we have just used, the result will be saved in D:\processing_output\graticule.shp. You can still enter a full path in case you want a result to be saved in a different folder.

Try yourself the Create grid algorithm with different grid sizes, and also with different types of grids. We will use the hexagonal one in a later chapter.

### 17.6 CRSs. Reprojecting

**Note:** In this lesson we will discuss how Processing uses CRSs. We will also see a very useful algorithm: reprojecting.

CRS’s are a great source of confusion for QGIS Processing users, so here are some general rules about how they are handled by geoolgirms when creating a new layer.

- If there are input layers, it will use the CRS of the first layer. This is assumed to be the CRS of all input layers, since they should have the same one. If you use layers with unmatching CRS’s, QGIS will warn you about it. Notice that the CRS of input layers is shown along with its name in the parameters dialog.

- If there are no input layers, it will use the project CRS, unless the algorithm contains a specific CRS field (as it happenend in the last lesson with the graticule algorithm)

Open the project corresponding to this lesson and you will see two layers named 23030 and 4326. They both contain the same points, but in different CRSs (EPSG:23030 and EPSG:4326). They appear in the same place...
because QGIS is reprojecting on the fly to the project CRS (EPSG:4326), but they are not actually the same layer.

Open the Export/Add geometry columns algorithm.

This algorithm add new columns to the attributes table of a vector layer. The content of the columns depend on the type of geometry of the layer. In the case of points, it adds new columns with the X and Y coordinates of each point.

In the list of available layers that you will find in the input layer field, you will see each one with its corresponding CRS. That means that, although they appear in the same place in your canvas, they will be treated differently. Select the 4326 layer.

The other parameter of the algorithm allows to set how the algorithm uses coordinates to calculate the new value that it will add to the resulting layers. Most algorithms do not have an option like that, and just use the coordinates directly. Select the Layer CRS option to just use coordinates as they are. This is how almost all geoalgorithms work.

You should get a new layer with exactly the same points as the other two layers. If you right click on the name of the layer and open its properties, you will see that it shares the same CRS of the input layer, that is, EPSG:4326. When the layer is loaded into QGIS, you will not be asked to enter the CRS of the layer, since QGIS already knows about it.

If you open the attributes table of the new layer you will see that it contains two new fields with the X and Y coordinates of each point.
Those coordinate values are given in the layer CRS, since we chose that option. However, even if you choose another option, the output CRS of the layer would have been the same, since the input CRS is used to set the CRS of the output layer. Choosing another option will cause the values to be different, but not the resulting point to change or the CRS of the output layer to be different to the CRS of the input one.

Now do the same calculation using the other layer. You should find the resulting layer rendered exactly in the same place as the other ones, and it will have the EPSG:23030 CRS, since that was the one of the input layer.

If you go to its attribute table, you will see values that are different to the ones in the first layer that we created.

This is because the original data is different (it uses a different CRS), and those coordinates are taken from it.

What should you learn from this? The main idea behind these examples is that geoalgorithms use the layer as it is in its original data source, and completely ignore the reprojections that QGIS might be doing before rendering. In other words, do not trust what you see in the canvas, but always have in mind that the original data will be used. That is no so important in this case, since we are just using one single layer at a time, but in an algorithm that needs several of them (such as a clip algorithm), layers that appear to match or overlay might be very far one from each other, since they might have different CRSs.

Algorithms performs no reprojection (except in the reprojection algorithm that we will see next), so it is up to you to make sure that layers have matching CRS’s.

An interesting module that deals with CRS’s is the reprojection one. It represents a particular case, since it has an input layer (the one to reproject), but it will not use its CRS for the the output one.

Open the Reprojection algorithm.
Select any of the layers as input, and select EPSG:23029 as the destination CRS. Run the algorithm and you will get a new layer, identical to the input one, but with a different CRS. It will appear on the same region of the canvas, like the other ones, since QGIS will reproject it on the fly, but its original coordinates are different. You can see that by running the \textit{Add geometry columns} algorithm using this new layer as input, and verifying that the added coordinates are different to the ones in the attribute tables of both of the two layers that we had computed before.

### 17.7 Selection

\textbf{Note:} In this lesson we will see how processing algorithms handle selections in vector layers that are used as inputs, and how to create a selection using a particular type of algorithm.

Unlike other analysis plugins in QGIS, you will not find in processing geoalgorithms any “Use only selected features” checkbox or similar. The behaviour regarding selection is set for the whole plugin and all its algorithms, and not for each algorithm execution. Algorithms follow the following simple rules when using a vector layer.

- If the layer has a selection, only selected features are used.
- If there is no selection, all features are used.

You can test that yourself by selecting a few points in any of the layers that we used in the last chapter, and running the reprojection algorithm on them. The reprojected layer that you will obtain will contain only those points that were selected, unless there was no selection, which will cause the resulting layer to contain all points from the origin layer.

To make a selection, you can use any of the available methods and tools in QGIS. However, you can also use a geoalgorithm to do so. Algorithms for creating a selection are found in the toolbox under \textit{Vector/Selection}.
Open the Random selection algorithm.

Leaving the default values, it will select 10 points from the current layer.
You will notice that this algorithm does not produce any output, but modifies the input layer (not the layer itself, but its selection). This is an uncommon behaviour, since all the other algorithms will produce new layers and not alter the input layers.

Since the selection is not part of the data itself, but something that only exist within GIS, these selection algorithms only must be used selecting a layer that is open in QGIS, and not with the file selection option that you can find in the corresponding parameter value box.

The selection we have just made, like most of the ones created by the rest of the selection algorithms, can also be done manually from QGIS, so you might be wondering what is the point on using an algorithm for that. Although now this might not make much sense to you, we will later see how to create models and scripts. If you want to make a selection in the middle of a model (which defines a processing workflow), only a geoalgorithm algorithms can be added to a model, and other QGIS elements and operations cannot be added. That is the reason why some processing algorithms duplicate functionality that is also available in other QGIS elements.

By now, just remember that selections can be made using processing geoalgorithms, and that algorithms will only use the selected features if a selection exists, or all features otherwise.

### 17.8 Running an external algorithm

This lesson we will see how to use algorithms that depend on a third-party application, particularly SAGA, which is one of the main algorithm providers.

All the algorithms that we have run so far are part of processing framework. That is, they are native algorithms implemented in the plugin and run by QGIS just like the plugin itself is run. However, one of the greatest features of the processing framework is that it can use algorithms from external application and extend the possibilities of those applications. Such algorithms are wrapped and included in the toolbox, so you can easily use them from QGIS, and use QGIS data to run them.

Some of the algorithms that you see in the simplified view require third party applications to be installed in your system. One algorithm provider of special interest is SAGA (System for Automated Geospatial Analysis). At the end of this lesson we will run an algorithm called *Convergence index*, which is provided by SAGA and computes a morphometrical measurement from a DEM. But first, we need to configure everything so QGIS can correctly call SAGA. This is not difficult, but it’s important to understand how it works. Each external application has its own configuration, and later in this same manual we will talk about some of the other ones, but SAGA is going to be our main backend, so we will discuss it here.

If you are on Windows, the best way to work with external algorithms is to install QGIS using the OSGeo4W installer. It will take care of installing all the needed dependencies, including SAGA, so if you have used it, there is nothing else to do. You can open the settings dialog and go to the Providers/SAGA group.
The SAGA path should already be configured and pointing to the folder where SAGA is installed.

If you have installed QGIS not using the OSGeo4W installer, then you must enter the path to your SAGA installation (which you must have installed separately) there. The required version is SAGA 2.1.

In case you are using Linux, you do not have to set the path to your SAGA installation in the processing configuration. Instead, you must install SAGA and make sure that the SAGA folder is in PATH, so it can be called from the console (just open a console and type `saga_cmd` to check it). Under Linux, the target version for SAGA is also 2.1, but in some installations (such as the OSGeo Live DVD) you might have just 2.0.8 available. There are some 2.1 packages available, but they are not commonly installed and might have some issues, so if you prefer to use the more common and stable 2.0.8, you can do it by enabling 2.0.8 compatibility in the configuration dialog, under the SAGA group.
Once SAGA is installed, you can launch a SAGA algorithm double clicking on its name, as with any other algorithm. Since we are using the simplified interface, you do not know which algorithms are based on SAGA or in another external application, but if you happen to double-click on one of them and the corresponding application is not installed, you will see something like this.

In our case, and assuming that SAGA is correctly installed and configured, you should not see this window, and you will get to the parameters dialog instead.

Let’s try with a SAGA–based algorithm, the one called *Split shapes layer randomly*. 
Use the points layer in the project corresponding to this lesson as input, and the default parameter values, and you will get something like this (the split is random, so your result might be different).

The input layer has been split in two layer, each one with the same number of points. This result has been computed by SAGA, and later taken by QGIS and added to the QGIS project.

If all goes fine, you will not notice any difference between this SAGA–based algorithm and one of the others that we have previously run. However, SAGA might, for some reason, not be able to produce a result and not generate the file that QGIS is expecting. In that case, there will be problems adding the result to the QGIS project, and an error message like this will be shown.
This kind of problems might happen, even if SAGA (or any other application that we are calling from the processing framework) is correctly installed, and it is important to know how to deal with them. Let’s produce one of those error messages.

Open the Create graticule from extent algorithm and use the following values.

We are using width and height values that is larger than the specified extent, so SAGA cannot produce any output.
In other words, the parameter values are wrong, but they are not checked until SAGA gets them and tries to create the graticule. Since it cannot create it, it will not produce the expected layer, and you will see the error message shown above.

Understanding this kind of problems will help you solve them and find an explanation to what is happening. As you can see in the error message, a test is performed to check that the connection with SAGA is working correctly, indicating you that there might be a problem in how the algorithm was executed. This applies not only to SAGA, but also to other external applications as well.

In the next lesson we will introduce the processing log, where information about commands run by geoalgorithms is kept, and you will see how to get more detail when issues like this appear.

### 17.9 The processing log

**Note:** This lesson describes the processing log

All the analysis performed with the processing framework is logged in its own logging system. This allows you to know more about what has been done with the processing tools, to solve problems when they happen, and also to re-run previous operations, since the logging system also implements some interactivity.

To open the log, select the corresponding entry in the processing menu. You will see the following dialog.

![Image of processing log dialog]

It contains four blocks of information: *Info*, *Error*, *Warnings* and *Algorithms*. Here is a description of all of them.

- **Info.** Some algorithms might leave here information about their execution. For instance, those algorithms that call an external application usually log the console output of that application to this entry. If you have a look at it, you will see that the output of the SAGA algorithm that we just run (and that fail to execute because input data was not correct) is stored here.
This is helpful to understand what is going on. Advanced users will be able to analyze that output to find out why the algorithm failed. If you are not an advanced user, this will be useful for others to help you diagnose the problem you are having, which might be a problem in the installation of the external software or an issue with the data you provided.

- **Warnings.** Even if the algorithm could be executed, some algorithms might leave warnings in case the result might not be right. For instance, when executing an interpolation algorithm with a very small amount of points. The algorithm can run and will produce a result, but it is likely that it will not be correct, since more points should be used. It’s a good idea to regularly check for this type of warnings if you are not sure about some aspect of a given algorithm.

- **Error.** Errors that appear and are not directly related to external applications are logged in this section.

- **Algorithms.** All algorithms that are executed, even if they are executed from the GUI and not from the console (which will be explained later in this manual) are stored in this part of the log as a console call. That means that everytime you run an algorithm, a console command is added to the log, and you have the full history of your working session. Here is how that history looks like
This can be very useful when starting working with the console, to learn about the syntax of algorithms. We will use it when we discuss how to run analysis commands from the console.

The history is also interactive, and you can re-run any previous algorithm just by double-clicking on its entry. This is an easy way of replicating the work we already did before.

For instance, try the following. Open the data corresponding to the first chapter of this manual and run the algorithm explained there. Now go to the log dialog and locate the last algorithm in the list, which corresponds to the algorithm you have just run. Double-click on it and a new result should be produced, just like when you run it using the normal dialog and calling it from the toolbox.

17.9.1 Advanced

You can also modify the algorithm. Just copy it, open the Plugins → Python console, click on Import class → Import Processing class, then paste it to re-run the analysis; change the text as will. To display the resulting file, type iface.addVectorLayer('/path/filename.shp', 'Layer name in legend', 'ogr').

17.10 The raster calculator. No-data values

In this lesson we will see how to use the raster calculator to perform some operations on raster layers. We will also explain what are no-data values and how the calculator and other algorithms deal with them.

The raster calculator is one of the most powerful algorithms that you will find. It’s a very flexible and versatile algorithm that can be used for many different calculations, and one that will soon become an important part of
your toolbox.

In this lesson we will be performing some calculation with the raster calculator, most of them rather simple. This will let us see how it is used and how it deals with some particular situations that it might find. Understanding that is important to later get the expected results when using the calculator, and also to understand certain techniques that are commonly applied with it.

Open the QGIS project corresponding to this lesson and you will see that it contains several raster layers.

Now open the toolbox and open the dialog corresponding to the raster calculator.

The dialog contains 2 parameters.

- The layers to use for the analysis. This is a multiple input, that meaning that you can select as many layers as you want. Click on the button on the right–hand side and then select the layers that you want to use in the dialog that will appear.

- The formula to apply. The formula uses the layers selected in the above parameter, which are named using alphabet letters (a, b, c...) or g1, g2, g3... as variable names. That is, the formula \( a + 2 \times b \) is the same as \( g1 + 2 \times g2 \) and will compute the sum of the value in the first layer plus two times the value in the second layer. The ordering of the layers is the some ordering that you see in the selection dialog.

**警告:** the calculator is case sensitive

To start with, we will change the units of the DEM from meters to feet. The formula we need is the following one:

\[ h' = h \times 3.28084 \]

Select the DEM in the layers field and type \( a \times 3.28084 \) in the formula field.

**警告:** for non English users: use always ".", not ","
Click *Run* to run the algorithm. You will get a layer that has the same appearance of the input layer, but with different values. The input layer that we used has valid values in all its cells, so the last parameter has no effect at all.

Let’s now perform another calculation, this time on the *accflow* layer. This layer contains values of accumulated flow, a hydrological parameter. It contains those values only within the area of a given watershed, with no-data values outside of it. As you can see, the rendering is not very informative, due to the way values are distributed. Using the logarithm of that flow accumulation will yield a much more informative representation. We can calculate that using the raster calculator.

Open the algorithm dialog again, select the *accflow* layer as the only input layer, and enter the following formula: \( \log(a) \).

Here is the layer that you will get.

If you select the *Identify* tool to know the value of a layer at a given point, select the layer that we have just created, and click on a point outside of the basin, you will see that it contains a no-data value.
For the next exercise we are going to use two layers instead of one, and we are going to get a DEM with valid elevation values only within the basin defined in the second layer. Open the calculator dialog and select both layers of the project in the input layers field. Enter the following formula in the corresponding field:

\[ \frac{a}{a} \times b \]

\(a\) refers to the accumulated flow layer (since it is the first one to appear in the list) and \(b\) refers to the DEM. What we are doing in the first part of the formula here is to divide the accumulated flow layer by itself, which will result in a value of 1 inside the basin, and a no–data value outside. Then we multiply by the DEM, to get the elevation value in those cells inside the basin (DEM \(*\) 1 = DEM) and the no–data value outside (DEM \(*\) no_data = no_data)

Here is the resulting layer.

This technique is used frequently to mask values in a raster layer, and is useful whenever you want to perform calculations for a region other that the arbitrary rectangular region that is used by raster layer. For instance, an elevation histogram of a raster layer doesn’t have much meaning. If it is instead computed using only values corresponding to a basin (as in the case above), the result that we obtain is a meaningful one that actually gives
information about the configuration of the basin.

There are other interesting things about this algorithm that we have just run apart from the no–data values and how they are handled. If you have a look at the extents of the layers that we have multiplied (you can do it double–clicking on their names of the layer in the table of contents and looking at their properties), you will see that they are not the same, since the extent covered by the flow accumulation layer is smaller that the extent of the full DEM.

That means that those layers do not match, and that they cannot be multiplied directly without homogenizing those sizes and extents by resampling one or both layers. However, we did not do anything. QGIS takes care of this situation and automatically resamples input layers when needed. The output extent is the minimum covering extent calculated from the input layers, and the minimum cell size of their cellsizes.

In this case (and in most cases), this produces the desired results, but you should always be aware of the additional operations that are taking place, since they might affect the result. In cases when this behaviour might not be the desired, manual resampling should be applied in advance. In later chapters, we will see more about the behaviour of algorithms when using multiple raster layers.

Let’s finish this lesson with another masking exercise. We are going to calculate the mean slope in all areas with an elevation between 1000 and 1500 meters.

In this case, we do not have a layer to use as a mask, but we can create it using the calculator.

Run the calculator using the DEM as only input layer and the following formula

\[
\text{ifelse}(\text{abs}(a-1250) < 250, 1, 0/0)
\]

As you can see, we can use the calculator not only to do simple algebraic operations, but also to run more complex calculation involving conditional sentences, like the one above.

The result has a value of 1 inside the range we want to work with, and no-data in cells outside of it.

The no-data value comes from the 0/0 expression. Since that is an undetermined value, SAGA will add a NaN (Not a Number) value, which is actually handled as a no-data value. With this little trick you can set a no-data value without needing to know what the no–data value of the cell is.

Now you just have to multiply it by the slope layer included in the project, and you will get the desired result.

All that can be done in a single operation with the calculator. We leave that as an exercise for the reader.
17.11 Vector calculator

In this lesson we will see how to add new attributes to a vector layer based on a mathematical expression, using the vector calculator.

We already know how to use the raster calculator to create new raster layers using mathematical expressions. A similar algorithm is available for vector layer, and generates a new layer with the same attributes of the input layer, plus an additional one with the result of the expression entered. The algorithm is called Field calculator and has the following parameters dialog.

Here are a couple of examples of using that algorithm.

First, let's calculate the population density of white people in each polygon, which represents a census. We have two fields in the attributes table that we can use for that, namely WHITE and SHAPE_AREA. We just have to divide them and multiply by one million (to have density per square km), so we can use the following formula in the corresponding field:

\[
\frac{\text{WHITE}}{\text{SHAPE\_AREA}} \times 1000000
\]

The parameters dialog should be filled as shown below.

This will generate a new field named WHITE\_DENS.

Now let's calculate the ratio between the MALES and FEMALES fields to create a new one that indicates if male population is predominant over female population.

Enter the following formula:

\[
\text{float(MALES)} / \text{FEMALES}
\]
This time the parameters window should look like this before pressing the OK button.
Both fields are of type integer, and the result would be truncate to an integer. That’s why we have added the `float()` function, to indicate that we want floating point number a result. You can use other Python functions as needed, since the calculator supports python commands (the raster calculator, however, doesn’t).

Since the formula field accepts Python syntax, we can have a new field with `male` or `female` text strings instead of those ratio value, using the following formula instead.

‘male’ if MALES > FEMALES else ‘female’

The parameters windows should look like this.

![Field calculator parameters window](image)

A more powerful python field calculator is available in the “Advanced Python field calculator”, which will not be detailed here.
17.12 Defining extents

In this lesson we will see how to define extents, which are needed by some algorithms, specially raster ones.

Some algorithms require an extent to define the area to be covered by the analysis they perform, and usually to define the extent of the resulting layer.

When an extent is required, it can be defined manually but entering the four values that define it (min X, min Y, max X, max Y), but there are other more practical and more interesting ways of doing it as well. We will see all of them in this lesson.

First, let’s open an algorithm that requires an extent to be defined. Open the Shapes to grid algorithm, which creates a raster layer from a vector layer.
All the parameters, except for the last two ones, are used to define which layer is to be rasterized, and configure how the rasterization process should work. The two last parameters, on the other hand, define the characteristics of the output layer. That means that they define the area that is covered (which is not necessarily the same area covered by the input vector layer), and the resolution/cellsize (which cannot be inferred from the vector layer, since vector layers do not have a cellsize).

The first thing you can do is to type the 4 defining values explained before, separated by commas.

That doesn’t need any extra explanation. While this is the most flexible option, it is also the less practical in some cases, and that’s why other options are implemented. To access them, you have to click on the button on the right-hand side of the extent text box.

Let’s see what each one of them does.

The first option is Use layer/canvas extent, which will show the selection dialog shown below.
Here you can select the extent of the canvas (the extent covered by the current zoom), or the extension any of the available layers. Select it and click on OK, and the text box will be automatically filled with the corresponding values.

The second option is Select extent on canvas. In this case, the algorithm dialog disappears and you can click and drag on the QGIS canvas to define the desired extent.

Once you release the mouse button, the dialog will reappear and the text box will already have the values corresponding to the defined extent.

The last option is Use min covering extent from input layers, which is the default option. This will compute the min covering extent of all layers used to run the algorithm, and there is no need to enter any value in the text box. In the case of a single input layer, as in the algorithm we are running, the same extent can be obtained by selecting that same input layer in the Use layer/canvas extent that we already saw. However, when there are several input layers, the min covering extent does not correspond to any of the input layer extent, since it is computed from all of them together.

We will use this last method to execute our rasterization algorithm.

Fill the parameters dialog as shown next, and press OK.
You will get a rasterized layer that covers exactly the area covered by the original vector layer.

In some cases, the last option, *Use min covering extent from input layers*, might not be available. This will happen in those algorithms that do not have input layers, but just parameters of other types. In that case, you will have to
enter the value manually or use any of the other options.

Notice that, when a selection exist, the extent of the layer is that of the whole set of features, and the selection is not used to compute the extent. In that case, you might want to actually create a new layer from the selection, and then use it as input.

17.13 HTML outputs

In this lesson we learn how QGIS handles outputs in HTML format, which are used to produce text outputs and graphs.

All the outputs we have produced so far were layers (whether raster or vector). However, some algorithms generate outputs in the form of text and graphics. All this outputs are wrapped in HTML files and displayed in the so-called Results viewer, which is another element of the processing framework.

Let’s see one of those algorithms to understand how they work.

Open the project with the data to be used in this lesson and then open the Basic statistics for numeric fields algorithm.

The algorithm is rather simple, and you just have to select the layer to use and one of its field (a numeric one). The output is of type HTML, but the corresponding box works exactly like the one that you can find in the case of a raster or vector output. You can enter a filepath or leave it blank to save to a temporary file. In this case, however, only the html and htm extensions are allowed, so there is no way of altering the output format by using a different one.

Run the algorithm selecting the only layer in the project as input, and the POP2000 field, and a new dialog like the one shown next will appear once the algorithm is executed and the parameters dialog is closed.
This is the *Results viewer*. It keeps all the HTML result generated during the current session, easily accessible, so you can check them quickly whenever you need it. As it happens with layers, if you have saved the output to a temporary file, it will be deleted once you close QGIS. If you have saved to a non-temporary path, the file will remain, but it will not appear in the *Results viewer* the next time you open QGIS.

Some algorithms generate text that cannot be divided into other more detailed outputs. That is the case if, for instance, the algorithm captures the text output from an external process. In other cases, the output is presented as text, but internally is divided into several smaller outputs, usually in the form of numeric values. The algorithm that we have just executed is one of them. Each one of those values is handled as a single output, and stored in a variable. This has no importance at all now, but once we move to the graphical modeler, you will see that it will allow us to use those values as numeric inputs for other algorithms.

### 17.14 First analysis example

*Note:* In this lesson we will perform some real analysis using just the toolbox, so you can get more familiar with the processing framework elements.

Now that everything is configured and we can use external algorithms, we have a very powerful tool to perform spatial analysis. It is time to work out a larger exercise with some real–world data.

We will be using the well-known dataset that John Snow used in his groundbreaking work, and we will get some interesting results. The analysis of this dataset is pretty obvious and there is no need for sophisticated GIS techniques to end up with good results and conclusions, but it is a good way of showing how these spatial problems can be analyzed and solved by using different processing tools.
The dataset contains shapefiles with cholera deaths and pump locations, and an OSM rendered map in TIFF format. Open the corresponding QGIS project for this lesson.

The first thing to do is to calculate the Voronoi diagram (a.k.a. Thyessen polygons) of the pumps layer, to get the influence zone of each pump. The Voronoi Diagram algorithm can be used for that.
Pretty easy, but it will already give us interesting information.
Clearly, most cases are within one of the polygons

To get a more quantitative result, we can count the number of deaths in each polygon. Since each point represents a building where deaths occurred, and the number of deaths is stored in an attribute, we cannot just count the points. We need a weighted count, so we will use the *Count points in polygon (weighted)* tool.
The new field will be called \textit{DEATHS}, and we use the \textit{COUNT} field as weighting field. The resulting table clearly reflects that the number of deaths in the polygon corresponding to the first pump is much larger than the other ones.
Another good way of visualizing the dependence of each point in the Cholera_deaths layer with a point in the Pumps layer is to draw a line to the closest one. This can be done with the Distance to closest hub tool, and using the configuration shown next.
The result looks like this:
Although the number of lines is larger in the case of the central pump, do not forget that this does not represent the number of deaths, but the number of locations where cholera cases were found. It is a representative parameter, but it is not considering that some locations might have more cases than other.

A density layer will also give us a very clear view of what is happening. We can create it with the Kernel density algorithm. Using the Cholera_deaths layer and its COUNT field as weight field, and with a radius of 100, we get something like this.
The resulting layer has the extent and cellsize of the streets raster layer.

Remember that, to get the output extent, you do not have to type it. Click on the button on the right-hand side and select Use layer/canvas extent.
Select the streets raster layer and its extent will be automatically added to the text field. You must do the same with the cellsize, selecting the cellsize of that layer as well.

Combining with the pumps layer, we see that there is one pump clearly in the hotspot where the maximum density of death cases is found.

17.15 Clipping and merging raster layers

**Note:** In this lesson we will see another example of spatial data preparation, to continue using geoalgorithms in real-world scenarios.

For this lesson, we are going to calculate a slope layer for an area surrounding a city area, which is given in a vector layer with a single polygon. The base DEM is divided in two raster layers that, together, cover an area much larger than that around the city that we want to work with. If you open the project corresponding to this lesson, you will see something like this.
These layers have two problems:

• They cover an area that is too large for what we want (we are interested in a smaller region around the city center)

• They are in two different files. (The city limits fall into just one single raster layer, but, as it’s been said, we want some extra area around it).

Both of them are easily solvable with the appropriate geoalgorithms.

First, we create a rectangle defining the area that we want. To do it, we create a layer containing the bounding box of the layer with the limits of the city area, and then we buffer it, so as to have a raster layer that covers a bit more that the strictly necessary.

To calculate the bounding box, we can use the Polygon from layer extent algorithm.
To buffer it, we use the *Fixed distance buffer* algorithm, with the following parameter values.

Here is the resulting bounding box obtained using the parameters shown above.
It is a rounded box, but we can easily get the equivalent box with square angles, by running the *Polygon from layer extent* algorithm on it. We could have buffered the city limits first, and then calculate the extent rectangle, saving one step.

You will notice that the rasters has a different projection from the vector. We should therefore reproject them before proceeding further, using the *Warp (reproject)* tool.
With this layer that contains the bounding box of the raster layer that we want to obtain, we can crop both of the raster layers, using the *Clip Grid with Polygons algorithm*. 
Once the layers have been cropped, they can be merged using the *Merge raster layers* algorithm.

A cellsize is needed for the merged layer. We will use the same one of the input ones. You do not need to know it.
in advance before calling the algorithm. Just click on the button in the right-hand size of the text field and you will have a dialog to enter small mathematical formulas, and a list of frequently used values, among them the cellsizes and bounding coordinates of all available layers.

Note: You can save time merging first and then cropping, and you will avoid calling the clipping algorithm twice. However, if there are several layers to merge and they have a rather big size, you will end up with a large layer than it can later be difficult to process. In that case, you might have to call the clipping algorithm several times, which might be time consuming, but don’t worry, we will soon see that there are some additional tools to automate that operation. In this example, we just have two layers, so you shouldn’t worry about that now.

With that, we get the final DEM we want.

Now it is time to compute the slope layer.

A slope layer can be computed with the \textit{Slope, Aspect, Curvature} algorithm, but the DEM obtained in the last step is not suitable as input, since elevation values are in meters but cellsize is not expressed in meters (the layer uses a CRS with geographic coordinates). A reprojection is needed. To reproject a raster layer, the \textit{Warp (reproject)} algorithm can be used again. We reproject into a CRS with meters as units, so we can then correctly calculate the slope.

Here is the reprojected DEM.
With the new DEM, slope can now be computed.
And here is the resulting slope layer.
The slope produced by the Slope, Aspect, Curvature algorithm is expressed in radians, but degrees are a more practical and common unit. The Metric conversions algorithm will help us to do the conversion (but in case you didn’t know that algorithm existed, you could use the raster calculator that we have already used).
Reprojecting the converted slope layer back with the **Reproject raster layer**, we get the final layer we wanted.

The reprojection processes have caused the final layer to contain data outside the bounding box that we calculated in one of the first steps. This can be solved by clipping it again, as we did to obtain the base DEM.

## 17.16 Hydrological analysis

In this lesson we will perform some hydrological analysis. This analysis will be used in some of the following lessons, as it constitutes a very good example of an analysis workflow, and we will use it to demonstrate some advanced features.

In this lesson, we are going to do some hydrological analysis. Starting with a DEM, we are going to extract a channel network, delineate watersheds and calculate some statistics.

The first thing is to load the project with the lesson data, which just contains a DEM.
The first module to execute is *Catchment area (Parallel)*. You can use anyone of the others named *Catchment area*. They have different algorithms underneath, but the results are basically the same.

Select the DEM in the *Elevation* field, and leave the default values for the rest of parameters.
This algorithm calculates many layers, but the *Catchment Area* one is the only one we will be using.

You can get rid of the other ones if you want.

The rendering of the layer is not very informative.

To know why, you can have a look at the histogram and you will see that values are not evenly distributed (there are a few cells with very high value, those corresponding to the channel network). Calculating the logarithm of the catchment area value yields a layer that conveys much more information (you can do it using the raster calculator).
The catchment area (also known as flow accumulation), can be used to set a threshold for channel initiation. This can be done using the *Channel network* algorithm. Here is how you have to set it up.
Use the original catchment area layer, not the logarithm one. That one was just for rendering purposes.

If you increase the *Initiation threshold* value, you will get a more sparse channel network. If you decrease it, you will get a denser one. With the proposed value, this is what you get.
The image above shows just the resulting vector layer and the DEM, but there should be also a raster one with the same channel network. That raster one will be, in fact, the one we will be using.

Now, we will use the Watersheds basins algorithm to delineate the subbasins corresponding to that channel network, using as outlet points all the junctions in it. Here is how you have to set the corresponding parameters dialog.
And this is what you will get.

This is a raster result. You can vectorise it using the *Vectorise grid classes* algorithm.
Now, let’s try to compute statistics about the elevation values in one of the subbasins. The idea is to have a layer that just represents the elevation within that subbasin and then pass it to the module that calculates those statistics.
First, let’s clip the original DEM with the polygon representing a subbasin. We will use the *Clip Grid with Polygon* algorithm. If we select a single subbasin polygon and then call the clipping algorithm, we can clip the DEM to the area covered by that polygon, since the algorithm is aware of the selection.

Select a polygon.

and call the clipping algorithm with the following parameters:
The element selected in the input field is, of course, the DEM we want to clip.

You will get something like this.
This layer is ready to be used in the *Raster layer statistics* algorithm.

The resulting statistic are the following ones.

We will use both the basin calculations procedure and the statistics calculation in other lessons, to find out how other elements can help us automate both of them and work more effectively.
17.17 Starting with the graphical modeler

In this lesson we will use the graphical modeler, a powerful component that we can use to define a workflow and run a chain of algorithms.

A normal session with the processing tools includes more than running a single algorithm. Usually several of them are run to obtain a result, and the outputs of some of those algorithms are used as input for some of the other ones.

Using the graphical modeler, that workflow can be put into a model, which will run all the necessary algorithms in a single run, thus simplifying the whole process and automating it.

To start this lesson, we are going to calculate a parameter named Topographic Wetness Index. The algorithm that computes it is called *Topographic Wetness Index (TWI)*

As you can see, there are two mandatory inputs: *Slope* and *Catchment area*. There is also an optional input, but we will not be using it, so we can ignore it.

The data for this lesson contains just a DEM, so we do not have any of the required inputs. However, we know how to calculate both of them from that DEM, since we have already seen the algorithms to compute slope and catchment area. So we can first compute those layers and then use them for the TWI algorithm.

Here are the parameter dialogs that you should use to calculate the 2 intermediate layers.
17.17. Starting with the graphical modeler
And this is how you have to set the parameters dialog of the TWI algorithm.
This is the result that you will obtain (the default singleband pseudocolor inverted palette has been used for rendering).

What we will try to do now is to create an algorithm that calculates the TWI from a DEM in just one single step. That will save us work in case we later have to compute a TWI layer from another DEM, since we will need just
one single step to do it instead of the 3 ones above. All the processes that we need are found in the toolbox, so what we have to do is to define the workflow to wrap them. This is where the graphical modeler comes in.

Open the modeler by selecting its menu entry in the processing menu.

Two things are needed to create a model: setting the inputs that it will need, and defining the algorithm that it contains. Both of them are done by adding elements from the two tabs in the left-hand side of the modeler window: Inputs and Algorithms

Let’s start with the inputs. In this case we do not have much to add. We just need a raster layer with the DEM, and that will be our only input data.

Double click on the Raster layer input and you will see the following dialog.

Here will have to define the input we want. Since we expect this raster layer to be a DEM, we will call it DEM. That’s the name that the user of the model will see when running it. Since we need that layer to work, we will define it as a mandatory layer.

Here is how the dialog should be configured.
Click on OK and the input will appear in the modeler canvas.

Now let’s move to the Algorithms tab. The first algorithm we have to run is the Slope, aspect, curvatures algorithm. Locate it in the algorithm list, double-click on it and you will see the dialog shown below.
This dialog is very similar to the one that you can find when running the algorithm from the toolbox, but the element that you can use as parameter values are not taken from the current QGIS project, but from the model itself. That means that, in this case, we will not have all the raster layers of our project available for the Elevation field, but just the ones defined in our model. Since we have added just one single raster input named DEM, that will be the only raster layer that we will see in the list corresponding to the Elevation parameter.

Output generated by an algorithm are handled a bit differently when the algorithm is used as a part of a model. Instead of selecting the filepath where you want to save each output, you just have to specify if that output is an intermediate layer (and you do not want it to be preserved after the model has been executed), or it is a final one. In this case, all layers produced by this algorithm are intermediate. We will only use one of them (the slope layer), but we do not want to keep it, since we just need it to calculate the TWI layer, which is the final result that we want to obtain.

When layers are not a final result, you should just leave the corresponding field. Otherwise, you have to enter a name that will be used to identify the layer in the parameters dialog that will be shown when you run the model later.

There is not much to select in this first dialog, since we do not have but just one layer in or model (The DEM input that we created). Actually, the default configuration of the dialog is the correct one in this case, so you just have to press OK. This is what you will no have in the modeler canvas.
The second algorithm we have to add to our model is the catchment area algorithm. We will use the algorithm named \textit{Catchment area (Parallel)}. We will use the DEM layer again as input, and none of the outputs it produces are final, so here is how you have to fill the corresponding dialog.
Now your model should look like this.
The last step is to add the Topographic Wetness Index algorithm, with the following configuration.

In this case, we will not be using the DEM as input, but instead, we will use the slope and catchment area layers that are calculated by the algorithms that we previously added. As you add new algorithms, the outputs they produce become available for other algorithms, and using them you link the algorithms, creating the workflow.

In this case, the output TWI layer is a final layer, so we have to indicate so. In the corresponding textbox, enter
the name that you want to be shown for this output.

Now our model is finished and it should look like this.

Enter a name and a group name in the upper part of the model window, and then save it clicking on the *Save* button.

You can save it anywhere you want an open it later, but if you save it in the models folder (which is the folder that you will see when the save file dialog appears), your model will also be available in the toolbox as well. So stay on that folder and save the model with the filename that you prefer.

Now close the modeler dialog and go to the toolbox. In the *Models* entry you will find your model.

You can run it just like any normal algorithm, double-clicking on it.
As you can see, the parameters dialog contain the input that you added to the model, along with the outputs that you set as final when adding the corresponding algorithms.

Run it using the DEM as input and you will get the TWI layer in just one single step.

17.18 More complex models

In this lesson we will work with a more complex model in the graphical modeler.

The first model that we created in the previous chapter was a very simple one, with just one input and 3 algorithms. More complex models can be created, with different types of inputs and containing more step. For this chapter we will work with a model that creates a vector layer with watersheds, based on a DEM and a threshold value. That will be very useful for calculating several vector layers corresponding to different thresholds, without having to repeat each single step each time.

This lesson does not contain instructions about how to create you model. You already know the necessary steps (we saw them in a previous lesson) and you have already seen the basic ideas about the modeler, so you should try it yourself. Spend a few minutes trying to create your model, and don’t worry about making mistakes. Remember: first add the inputs and then add the algorithms that use them to create the workflow.

In case you could not create the full model yourself and you need some extra help, the data folder corresponding to this lesson contains and ‘almost’ finished version of it. Open the modeler and then open the model file that you will find in the data folder. You should see something like this.
This model contains all the steps needed to complete the calculation, but it just has one input: the DEM. That means that the threshold for channel definition uses a fixed value, which makes the model not as useful as it could be. That is not a problem, since we can edit the model, and that is exactly what we will do.

First, let’s add a numerical input. That will ask the user for a numerical input that we can use when such a value is needed in any of the algorithms included in our model. Click on the Numerical value entry in the inputs tree, and you will see the corresponding dialog. Fill it with the values shown next.

Now your model should look like this.
The input that we have just added is not used, so the model hasn’t actually changed. We have to link that input to the algorithm that uses it, in this case the `Channel network` one. To edit an algorithm that already exists in the modeler, just double click on its corresponding box in the canvas. If you click on the `Channel network` algorithm, you will see something like this.

The dialog is filled with the current values used by the algorithm. You can see that the threshold parameter has a fixed value of 1000000 (this is also the default value of the algorithm, but any other value could be put in there). However, you might notice that the parameter is not entered in a common text box, but in an option menu. If you
 unfolded it, you will see something like this.

![Channel network dialog box](image)

The input that we added is there and we can select it. Whenever an algorithm in a model requires a numerical value, you can hardcode it and directly type it, or you can use any of the available inputs and values (remember that some algorithms generate single numerical values. We will see more about this soon.). In the case of a string parameter, you will also see string inputs and you will be able to select one of them or type the desired fixed value.

Select the *Threshold* input in the *Threshold* parameter and click on *OK* to apply the changes to your model. Now the design of the model should look like this.
The model is now complete. Try to run it using the DEM that we have used in previous lessons, and with different threshold values. Here you have a sample of the result obtained for different values. You can compare with the result for the default value, which is the one we obtained in the hydrological analysis lesson.

Threshold = 100000
17.19 Numeric calculations in the modeler

Threshold = 10000000

For this lesson, we are going to modify the hydrological model that we created in the last chapter (open it in the modeler before starting), so we can automate the calculation of a valid threshold value and we do not have to ask the user to enter it. Since that value refers to the variable in the threshold raster layer, we will extract it from that layer, based on some simple statistical analysis.

Starting with the aforementioned model, let’s do the following modifications:

First, calculate statistics of the flow accumulation layer using the Raster layer statistics algorithm.
This will generate a set of statistical values that will now be available for all numeric fields in other algorithms.

If you double click on the Channel network algorithm to modify it, as we did in the last lesson, you will see now that you have other options apart from the numeric input that you added.
However, none of these values is suitable for being used as a valid threshold, since they will result in channel networks that will not be very realistic. We can, instead, derive some new parameter based on them, to get a better result. For instance, we can use the mean plus 2 times the standard deviation.

To add that arithmetical operation, we can use the calculator that you will find in the Geoalgorithms/modeler/modeler-tools group. This group contains algorithms that are not very useful outside of the modeler, but that provide some useful functionality when creating a model.

The parameters dialog of the calculator algorithm looks like this:
As you can see, the dialog is different to the other ones we have seen, but you have there the same variables that were available in the Threshold field in the Channel network algorithm. Enter the above formula and click on OK to add the algorithm.

If you expand the outputs entry, as shown above, you will see that the model is connected to two of the values, namely the mean and the standard deviation, which are the ones that we have used in the formula.

Adding this new algorithm will add a new numeric value. If you go again to the Channel network algorithm, you can now select that value in the Threshold parameter.
Click on OK and your model should look like this.

We are not using the numeric input that we added to the model, so it can be removed. Right-click on it and select Remove.

Our new model is now finished.

17.20 A model within a model

警告: Beware, this chapter is not well tested, please report any issue; images are missing

Note: In this lesson we will see how to use a model within a bigger model.

We have already created a few models, and in this lesson we are going to see how we can combine them on a single bigger one. A model behaves like any other algorithm, which means that you can add a model that you have already created as part of another one that you create after that.

In this case, we are going to expand our hydrological model, by adding the mean TWI value in each of the basins that it generates as result. To do that, we need to calculate the TWI, and the to compute statistics. Since we have already created a model to calculate TWI from a DEM, it is a good idea to reuse that model instead of adding the algorithms it contains individually.
Let’s start with the model we used as starting point for the last lesson.  

First, we will add the TWI model. For it to be available, it should have been saved on the models folder, since otherwise it will not be shown in the toolbox or the algorithms list in the modeler. Make sure you have it available.

Add it to the current model and use the input DEM as its input. The output is a temporary one, since we just want the TWI layer to compute the statistics. The only output of this model we are creating will still be the vector layer with the watersheds.

Here is the corresponding parameters dialog:

Now we have a TWI layer that we can use along with the watersheds vector layer, to generate a new one which contains the values of the TWI corresponding to each watershed.

This calculation is done using the Grid statistics in polygons algorithm. Use the layers mentioned above as input, to create the final result.

The output of the Vectorize grid classes algorithm was originally our final output, but now we just want it as an intermediate result. To change that, we have to edit the algorithm. Just double-click on it to see its parameters dialog, and delete the name of the output. That will make it a temporary output, as it is by default.

This is how the final model should look like:

As you see, using a model in another model is nothing special, and you can add it just like you add another algorithm, as long as the model is saved in the models folder and is available in the toolbox.

### 17.21 Interpolation

In this lesson, we are going to interpolate points data to obtain a raster layer. Before doing it, we will have to do some data preparation, and after interpolating we will add some extra processing to modify the resulting layer, so we will have a complete analysis routine.

Open the example data for this lesson, which should look like this.
The data correspond to crop yield data, as produced by a modern harvester, and we will use it to get a raster layer of crop yield. We do not plan to do any further analysis with that layer, but just to use it as a background layer for easily identifying the most productive areas and also those where productivity can be improved.

The first thing to do is to clean–up the layer, since it contains redundant points. These are caused by the movement of the harvester, in places where it has to do a turn or it changes its speed for some reason. The Point filter algorithm will be useful for this. We will use it twice, to remove points that can be considered outliers both in the upper and lower part of the distribution.

For the first execution, use the following parameter values. [Note: this does not work, resulting file empty]
Now for the next one, use the configuration shown below.
Notice that we are not using the original layer as input, but the output of the previous run instead.

The final filter layer, with a reduced set of points, should look similar to the original one, but it contains a smaller number of points. You can check that by comparing their attribute tables.

Now let’s rasterize the layer using the *Shapes to grid* algorithm.
The *Filtered points* layer refers to the resulting one of the second filter. It has the same name as the one produced by the first filter, since the name is assigned by the algorithm, but you should not use the first one. Since we will not be using it for anything else, you can safely remove it from your project to avoid confusion, and leave just the last filtered layer.

The resulting raster layer looks like this.
It is already a raster layer, but it is missing data in some of its cells. It only contain valid values in those cells that contained a point from the vector layer that we have just rasterized, and a no–data value in all the other ones. To fill the missing values, we can use the *Close gaps* algorithm.
The layer without no-data values looks like this.
To restrict the area covered by the data to just the region where crop yield was measured, we can clip the raster layer with the provided limits layer.
And for a smoother result (less accurate but better for rendering in the background as a support layer), we can apply a Gaussian filter to the layer.
With the above parameters you will get the following result

![Image of result]

17.22 More interpolation

**Note:** This chapter shows another practical case where interpolation algorithms are used.

Interpolation is a common technique, and it can be used to demonstrate several techniques that can be applied using the QGIS processing framework. This lesson uses some interpolation algorithms that were already introduced, but has a different approach.

The data for this lesson contains also a points layer, in this case with elevation data. We are going to interpolate it much in the same way as we did in the previous lesson, but this time we will save part of the original data to use it for assessing the quality of the interpolation process.

First, we have to rasterize the points layer and fill the resulting no-data cells, but using just a fraction of the points in the layer. We will save 10% of the points for a later check, so we need to have 90% of the points ready for the interpolation. To do so, we could use the Split shapes layer randomly algorithm, which we have already used in a previous lesson, but there is a better way to do that, without having to create any new intermediate layer. Instead of that, we can just select the points we want to use for the interpolation (the 90% fraction), and then run the algorithm. As we have already seen, the rasterizing algorithm will use only those selected points and ignore the rest. The selection can be done using the Random selection algorithm. Run it with the following parameters.
That will select 90% of the points in the layer to rasterize.

The selection is random, so your selection might differ from the selection shown in the above image.

Now run the Shapes to grid to get the first raster layer, and then run the Close gaps algorithm to fill the no-data.
cells [Cell resolution: 100 m].

To check the quality of the interpolation, we can now use the points that are not selected. At this points, we know the real elevation (the value in the points layer) and the interpolated elevation (the value in the interpolated raster layer). We can compare the by computing the differences between those values.

Since we are going to use the points that are not selected, first, let’s invert the selection.

The points contain the original values, but not the interpolated ones. To add them in a new field, we can use the
The raster layer to select (the algorithm supports multiple raster, but we just need one) is the resulting one from the interpolation. We have renamed it to `interpolate` and that layer name is the one that will be used for the name of the field to add.

Now we have a vector layer that contains both values, with points that were not used for the interpolation.
Now, we will use the fields calculator for this task. Open the *Field calculator* algorithm and run it with the following parameters.
If your field with the values from the raster layer has a different name, you should modify the above formula accordingly. Running this algorithm, you will get a new layer with just the points that we haven’t used for the interpolation, each of them containing the difference between the two elevation values. Representing that layer according to that value will give us a first idea of where the largest discrepancies are found.

Interpolating that layer will get you a raster layer with the estimated error in all points of the interpolated area.
Your results might differ from these ones, since there is a random component introduced when running the random selection, at the beginning of this lesson.

17.23 Iterative execution of algorithms

We already know the graphical modeler, which is one way of automating processing tasks. However, in some situations, the modeler might not be what we need to automate a given task. Let’s see one of those situation and how to easily solve it using a different functionality: the iterative execution of algorithms.

Open the data corresponding to this chapter. It should look like this.
You will recognize our well-known DEM from previous chapters and a set of watersheds extracted from it. Imagine that you need to cut the DEM into several smaller layers, each of them containing just the elevation data corresponding to a single watershed. That will be useful if you later want to calculate some parameters related to each watershed, such as its mean elevation or its hypsographic curve.

This can be a lengthy and tedious task, especially if the number of watersheds is large. However, it is a task that can be easily automated, as we will see.

The algorithm to use for clipping a raster layer with a polygon layer is called *Clip grid with polygons*, and has the following parameters dialog.
Yo can run it using the watersheds layer and the DEM as input, and you will get the following result.

As you can see, the area covered by all the watershed polygons is used.

You can have the DEM clipped with just a single watershed by selecting the desired watershed and then running...
the algorithm as we did before.

Since only selected features are used, only the selected polygon will be used to crop the raster layer.

Doing this for all the watersheds will produce the result we are looking for, but it doesn’t look like a very practical way of doing it. Instead, let’s see how to automate that select and crop routine.

First of all, remove the previous selection, so all polygons will be used again. Now open the Clip grid with polygon algorithm and select the same inputs as before, but this time click on the button that you will find in the right-hand side of the vector layer input where you have selected the watersheds layer.
This button will cause the selected input layer to be split into as many layer as feature are found in it, each of them containing a single polygon. With that, the algorithm will be called repeatedly, one for each one of those single-polygon layers. The result, instead of just one raster layer in the case of this algorithm, will be a set of raster layers, each one of them corresponding to one of the executions of the algorithm.

Here’s the result that you will get if you run the clipping algorithm as explained.
For each layer, the black and white color palette, (or whatever palette you are using), is adjusted differently, from its minimum to its maximum values. That’s the reason why you can see the different pieces and the colors do not seem to match in the border between layers. Values, however, do match.

If you enter an output filename, resulting files will be named using that filename and a number corresponding to each iteration as suffix.

17.24 More iterative execution of algorithms

| ノート: | This lessons shows how to combine the iterative execution of algorithm with the modeler to get more automation |

The iterative execution of algorithms is available not just for built-in algorithms, but also for the algorithms that you can create your self, such as models. We are going to see how to combine a model and the iterative execution of algorithms, so we can obtain more complex results with ease.

The data the we are going to use for this lesson is the same one that we already used for the last one. In this case, instead of just clipping the DEM with each watershed polygon, we will add some extra steps and calculate a hypsometric curve for each of them, to study how elevation is distributed within the watershed.

Since we have a workflow that involves several stapes (clipping + computing the hypsometric curve), we should go to the modeler and create the corresponding model for that workflow.

You can find the model already created in the data folder for this lesson, but it would be good if you first try to create it yourself. The clipped layer is not a final result in this case, since we are just interested in the curves, so this model will not generated any layers, but just a table with the curve data.

The model should look like this:
Add the model to your models folder, so it is available in the toolbox, and now execute it.

Select the DEM and watersheds basins, and do not forget to toggle the button that indicates that the algorithm has to be run iteratively.

The algorithm will be run several times, and the corresponding tables will be created and open in your QGIS project.
We can make this example more complex by extending the model and computing some slope statistics. Add the *Slope, aspect, curvatures* algorithm to the model, and then the *Raster statistics* algorithm, which should use the slope output as its only input.

If you now run the model, apart from the tables you will get a set of pages with statistics. These pages will be available in the results dialog.

## 17.25 The batch processing interface

*Note:* This lesson introduces the batch processing interface, which allows to execute a single algorithm with a set of different input values.
Sometimes a given algorithm has to be executed repeatedly with different inputs. This is, for instance, the case when a set of input files have to be converted from one format to another, or when several layers in a given projection must be converted into another projection.

In that case, calling the algorithm repeatedly on the toolbox is not the best option. Instead, the batch processing interface should be used, which greatly simplifies performing a multiple execution of a given algorithm. To run an algorithm as a batch process, find it in the toolbox, and instead of double-clicking on it, right-click on it and select *Run as batch process*.

For this example, we will use the *Reproject algorithm*, so find it and do as described above. You will get to the following dialog.

If you have a look at the data for this lesson, you will see that it contains a set of three shapefiles, but no QGIS project file. This is because, when an algorithm is run as a batch process, layer inputs are not selected from the current QGIS project, but from files instead. This makes it easier to process large amounts of layers, such as, for instance, all the layers in a given folder.

Each row in the table of the batch processing dialog represents a single execution of the algorithm. Cells in a row correspond to the parameter needed by the algorithm, which are not arranged one above the other, as in the normal single-execution dialog, but horizontally in that row.

Defining the batch process to run is one by filling the table with the corresponding values, and the dialog itself contains several tools to make this task easier.

Let’s start filling the fields one by one. The first column to fill is the *Input layer* one. Instead of entering the names of each one of the layers we want to process, you can select all of them and let the dialog put one in each row. Click on the button in the upper-left cell, and in the file selection dialog that will popup, select the three
files to reproject. Since only one of them is needed for each row, the remaining ones will be used to fill the rows underneath.

The default number of rows is 3, which is exactly the number of layers we have to convert, but if you select more layers, new rows will be added automatically. If you want to fill the entries manually, you can add more rows using the Add row button.

We are going to convert all those layers to the EPSG:23029 CRS, so we have to select that CRS in the second field. We want the same on for all rows, but we do not have to do it for every single row. Instead, set that CRS for the first row (the one at the top) using the button in the corresponding cell, and then double click on the column header. That causes all the cells in the column to be filled using the value of the top cell.
Finally, we have to select an output file for each execution, which will contain the corresponding reprojected layer. Once again, let’s do it just for the first column. Click on the button in the upper cell and, in a folder where you want to put your output files, enter a filename (for instance, `reprojected.shp`).

Now, when you click **OK** on the file selection dialog, the file does not automatically gets written to the cell, but an input box like the following one is shown instead.

If you select the first option, only the current cell will be filled. If you select any of the other ones, all the rows below will be filled with a given pattern. In this case, we are going to select the **Fill with parameter value** option, and then the **Input Layer** value in the drop down menu below. That will cause the value in the **Input Layer** (that is, the layer name) to be added to the filename we have added, making each output filename different. The batch processing table should now look like this.
The last column sets whether or not to add the resulting layers to the current QGIS project. Leave the default Yes option, so you can see your results in this case.

Click on OK and the batch process will be run. If everything went fine, all your layers will have been processed, and 3 new layers would have been created.

17.26 Models in the batch processing interface

警告: Beware, this chapter is not well tested, please report any issue; images are missing

ノート: This lesson shows another example of the batch processing interface, but this time using a model instead of a built-in algorithm

Model are just like any other algorithm, and they can be used in the batch processing interface. To demonstrate that, here is a brief example that we can do using our already well-known hydrological model.

Make sure you have the model added to your toolbox, and then run it in batch mode. This is what the batch processing dialog should look like.

Add rows up to a total of 5. Select the DEM file corresponding to this lesson as the input for all of them. Then enter 5 different threshold values as shown next.
As you see the batch processing interface can be run not just to run the same process on different datasets but also on the same dataset with different parameters.
Click on OK and you should get 5 new layers with watersheds corresponding to the specified 5 threshold values.

17.27 Other programs

Module contributed by Paolo Cavallini - Faunalia

ノート：This chapter shows how to use additional programs from inside Processing. To complete it, you must have installed, with the tools of your operating system, the relevant packages.

17.27.1 GRASS

GRASS is a free and open source GIS software suite for geospatial data management and analysis, image processing, graphics and maps production, spatial modeling, and visualization
It is installed by default on Windows through the OSGeo4W standalone installer (32 and 64 bit), and it is packaged for all major Linux distributions.

17.27.2 R

R is a free and open source software environment for statistical computing and graphics.
It has to be installed separately, together with a few necessary libraries (LIST).
The beauty of Processing implementation is that you can add your own scripts, simplex or complex ones, and they may then be used as any other module, piped into more complex workflows, etc.

17.27.3 OTB

OTB (also known as Orfeo ToolBox) is a free and open source library of image processing algorithms. It is installed by default on Windows through the OSGeo4W standalone installer (32 bit). Paths should be configured in Processing.
In a standard OSGeo4W Windows installation, the paths will be:

OTB application folder C:\OSGeo4W\apps\orfeotoolbox\applications
OTB command line tools folder C:\OSGeo4W\bin

On Debian and derivatives, it will be /usr/bin

17.27.4 Others

TauDEM is a suite of Digital Elevation Model (DEM) tools for the extraction and analysis of hydrologic information. Availability in various operating system varies.
LASTools is a set of mixed, free and proprietary commands to process and analyze LiDAR data. Availability in various operating system varies.
More tools are available through additional plugins, e.g.:

- **LecoS**: a suite for land cover statistics and landscape ecology
- **lwgeom**: formerly part of PostGIS, this library brings a few useful tools for geometry cleanup
- **Animove**: tools to analyse the home range of animals.

More will come.

### 17.27.5 Comparison among backends

#### Buffers and distances

Let’s load `points.shp` and type `buf` in the filter of the Toolbox, then double click on:

- **Fixed distance buffer**: Distance 10000
- **Variable distance buffer**: Distance field SIZE
- **v.buffer.distance**: distance 10000
- **v.buffer.column**: bufcolumn SIZE
- **Shapes Buffer**: fixed value 10000 (dissolve and not), attribute field (with scaling)

See how speed is quite different, and different options are available.

**Exercise for the reader**: find the differences in geometry output between different methods.

Now, raster buffers and distances:

- first, load and rasterize the vector `rivers.shp` with GRASS → `v.to.rast.value`; beware: cell size must be set to 100 m, otherwise the computation time will be enormous; resulting map will have 1 and NULLs
- same, with SAGA → **Shapes to Grid** → COUNT (resulting map: 6 to 60)
- then, **proximity** (value= 1 for GRASS, a list of rivers ID for SAGA), `r.buffer` with parameters 1000,2000,3000, `r.grow.distance` (the first of the two maps).

#### Dissolve

Dissolve features based on a common attribute:

- **GRASS** → `v.dissolve` municipalities.shp on PROVINCIA
- **QGIS** → **Dissolve** municipalities.shp on PROVINCIA
- **SAGA** → **Polygon Dissolve** municipalities.shp on PROVINCIA (NB: the same attribute has to be chosen 3 times)

| 警告: | The last one is broken in SAGA <=2.10 |

**Exercise for the reader**: find the differences (geometry and attributes) between different methods.

### 17.28 Interpolation and contouring

Module contributed by Paolo Cavallini - Faunalia

| ノート: | This chapter shows how to use different backends to calculate different interpolations. |


17.28.1 Interpolation

The project shows a gradient in rainfall, from south to north. Let’s use different methods for interpolation, all based on vector points.shp, parameter RAIN:

- **GRASS → v.surf.rst**
- **SAGA → Multilevel B-Spline Interpolation**
- **SAGA → Inverse Distance Weighted** [Power: 4; Search range: Global]
- **GDAL → Grid (Inverse Distance to a power)** [Power:4]
- **GDAL → Grid (Moving average)** [Radius1&2: 50000]

17.28.2 Contour

Various methods to draw contour lines [always step= 10]:

- **GRASS → r.contour.step**
- **SAGA → Contour Lines from Grid**
- **GDAL → Contour**
Chapter 18

Module: QGIS での空間データベースの利用

このモジュールでは、クエリによって分析を実行するだけでなく、データベース内のデータを管理、表示、そして操作するために QGIS で空間データベースを使用する方法について学習します。我々は主に PostgreSQL と PostGIS（前のセクションで説明）を使用しますが、spatialite を含む他の空間データベースの実装でも同じ概念が適用可能です。

18.1 Lesson: Working with Databases in the QGIS Browser

In the previous 2 modules we looked at the basic concepts, features and functions of relational databases as well as extensions that let us store, manage, query and manipulate spatial data in a relational database. This section will dive deeper into how to effectively use spatial databases in QGIS.

The goal for this lesson: To learn how to interact with spatial databases using the QGIS Browser interface.

18.1.1 Follow Along: Adding Database Tables to QGIS using the Browser

We have already briefly looked at how to add tables from a database as QGIS layers, now let’s look at this in a bit more detail and look at the different ways this can be done in QGIS. Let’s start by looking at the new Browser interface.

• Start a new empty map in QGIS.
• Open the Browser by clicking the Browser tab at the bottom of the Layer Panel.
• Open the PostGIS portion of the tree and you should find your previously configured connection available (you may need to click the Refresh button at the top of the browser window).
• Double clicking on any of the table/layers listed here will add it to the Map Canvas.
• Right Clicking on a table/layer in this view will give you a few options. Click on the Properties item to look at the properties of the layer.
Of course you can also use this interface to connect to PostGIS databases hosted on a server external to your workstation. Right clicking on the PostGIS entry in the tree will allow you to specify connection parameters for a new connection.

18.1.2 🟢 Follow Along: Adding a filtered set of records as a Layer

Now that we have seen how to add an entire table as a QGIS layer it might be nice to learn how to add a filtered set of records from a table as a layer by using queries that we learned about in previous sections.

- Start a new empty map with no layers
- Click the Add PostGIS Layers button or select Layer –> Add PostGIS Layers from the menu.
- In the Add PostGIS Table(s) dialog that comes up, connect to the postgis_demo connection.
- Expand the public schema and you should find the three tables we were working with previously.
- Click the lines layer to select it, but instead of adding it, click the Set Filter button to bring up the Query Builder dialog.
- Construct the following expression using the buttons or by entering it directly:

  "roadtype" = 'major'

- Click OK to complete editing the filter and click Add to add the filtered layer to your map.
• Rename the lines layer in the tree to roads_primary.

You will notice that only the Primary Roads have been added to your map rather than the entire layer.

18.1.3 In Conclusion

You have seen how to interact with spatial databases using the QGIS Browser and how to add layers to your map based on a query filter.

18.1.4 What’s Next?

Next you’ll see how to work with the DB Manager interface in QGIS for a more complete set of database management tasks.

18.2 Lesson: Using DB Manager to work with Spatial Databases in QGIS

We have already seen how to perform many database operations with QGIS as well as with other tools, but now it’s time to look at the DB Manager tool which provides much of this same functionality as well as more management oriented tools.

The goal for this lesson: To learn how to interact with spatial databases using the QGIS DB Manager.

18.2.1 Follow Along: Managing PostGIS Databases with DB Manager

You should first open the DB Manager interface by selecting Database -> DB Manager -> DB Manager on the menu or by selecting the DB Manager icon on the toolbar.

You should already see the previous connections we have configured and be able to expand the myPG section and its public schema to see the tables we have worked with in previous sections.

The first thing you may notice is that you can now see some metadata about the Schemas contained in your database.
Schemas are a way of grouping data tables and other objects in a PostgreSQL database and a container for permissions and other constraints. Managing PostgreSQL schemas is beyond the scope of this manual, but you can find more information about them in the PostgreSQL documentation. You can use the DB Manager to create new Schemas, but will need to use a tool like pgAdmin III or the command line interface to manage them effectively.

DB Manager can also be used to manage the tables within your database. We have already looked at various ways to create and manage tables on the command line, but now lets look at how to do this in DB Manager.

First, its useful to just look at a table’s metadata by clicking on its name in tree and looking in the Info tab.
In this panel you can see the General Info about the table as well the information that the PostGIS extension maintains about the geometry and spatial reference system.

If you scroll down in the Info tab, you can see more information about the Fields, Constraints and Indexes for the table you are viewing.
Its also very useful to use DB Manager to simply look at the records in the database in much the same way you might do this by viewing the attribute table of a layer in the Layer Tree. You can browse the data by selecting the Table tab.
There is also a Preview tab which will show you the layer data in a map preview.

Right Clicking on a layer in the tree and clicking Add to Canvas will add this layer to your map.

So far we have only been viewing the database its schemas and tables and their metadata, but what if we wanted to alter the table to add an additional column perhaps? DB Manager allows you to do this directly.

- Select the table you want to edit in the tree
- Select Table -> Edit Table from the menu to open the Table Properties dialog.

You can use this dialog to Add Columns, Add geometry columns, edit existing columns or to remove a column completely.

Using the Constraints tab, you can manage which fields are used as the primary key or to drop existing constraints.
The *Indexes* tab can be used to add and delete both spatial and normal indexes.
18.2.2 Follow Along: Creating a New Table

Now that we have gone through the process of working with existing tables in our database, let’s use DB Manager to create a new table.

- If it is not already open, open the DB Manager window, and expand the tree until you see the list of tables already in your database.
- From the menu select Table –> Create Table to bring up the Create Table dialog.
- Use the default Public schema and name the table places.
- Add the id, place_name, and elevation fields as shown below.
- Make sure the id field is set as the primary key.
- Click the checkbox to Create geometry column and make sure it is set to a POINT type and leave it named geom and specify 4326 as the SRID.
- Click the checkbox to Create spatial index and click Create to create the table.
• Dismiss the dialog letting you know that the table was created and click Close to close the Create Table Dialog.

You can now inspect your table in the DB Manager and you will of course find that there is no data in it. From here you can Toggle Editing on the layer menu and begin to add places to your table.

18.2.3 Follow Along: Basic Database Administration

The DB Manager will also let you do some basic Database Administration tasks. It is certainly not a substitute for a more complete Database Administration tool, but it does provide some functionality that you can use to maintain your database.

Database tables can often become quite large and tables which are being modified frequently can end up leaving around remnants of records that are no longer needed by PostgreSQL. The VACUUM command takes care of doing a kind of garbage collection to compact and optionally analyze your tables for better performance.

Lets take a look at how we can perform a VACUUM ANALYZE command from within DB Manager.

• Select one of your tables in the DB Manager Tree.

• Select Table -> Run Vacuum Analyze from the menu.

Thats it! PostgreSQL will perform the operation. Depending on how big your table is, this may take some time to complete.

You can find more information about the VACUUM ANALYZE process in the PostgreSQL Documentation.
18.2.4  

Follow Along: Executing SQL Queries with DB Manager

DB Manager also provides a way for you to write queries against your database tables and to view the results. We have already seen this type of functionality in the Browser panel, but let's look at it again here with DB Manager.

- Select the lines table in the tree.
- Select the SQL window button in the DB Manager toolbar.

- Compose the following SQL query in the space provided:

```sql
select * from lines where roadtype = 'major';
```

- Click the Execute (F5) button to run the query.
- You should now see the records that match in the Result panel.

- Click the checkbox for Load as new layer to add the results to your map.
- Select the id column as the Column with unique integer values and the geom column as the Geometry column.
- Enter roads_primary as the Layer name (prefix).
- Click Load now! to load the results as a new layer into your map.
The layers that matched your query are now displayed on your map. You can of course use this query tool to execute any arbitrary SQL command including many of the ones we looked at in previous modules and sections.

18.2.5 Importing Data into a Database with DB Manager

We have already looked at how to import data into a spatial database using command line tools and also looked at how to use the SPIT plugin, so now lets learn how to use DB Manager to do imports.

- Click the Import layer/file button on the toolbar in the DB Manager dialog.

- Select the urban_33S.shp file from exercise_data/projected_data as the input dataset.
- Click the Update Options button to pre-fill some of the form values.
- Make sure that the Create new table option is selected
- Specify the Source SRID as 32722 and the Target SRID as 4326.
- Enable the checkbox to Create Spatial Index
- Click OK to perform the import.
• Dismiss the dialog letting you know that the import was successful
• Click the Refresh button on the DB Manager Toolbar.

You can now inspect the table in your database by clicking on it in the Tree. Verify that the data has been reprojected by checking that the Spatial ref: is listed as WGS 84 (4326)
Right clicking on the table in the Tree and a selecting *Add to Canvas* will add the table as a layer in your map.

### 18.2.6 Exporting Data from a Database with DB Manager

Of course DB Manager can also be used to export data from your spatial databases, so let's take a look at how that is done.

- Select the *lines* layer in the Tree and click the *Export to File* button on the toolbar to open the *Export to vector file* dialog.
- Click the *...* button to select the *Output file* and save the data to your *exercise_data* directory as *urban_4326*.
- Set the *Target SRID* as *4326*.
- Click *OK* to initialize the export.
• Dismiss the dialog letting you know the export was successful and close the DB Manager.

You can now inspect the shapefile you created with the Browser panel.
18.2.7 In Conclusion

You have now seen how to use the DB Manager interface in QGIS to manage your spatial databases, to execute SQL queries against your data and how to import and export data.

18.2.8 What’s Next?

Next, we will look at how to use many of these same techniques with spatialite databases.

18.3 Lesson: QGIS における SpatiaLite データベースの操作

While PostGIS is generally used on a server to provide spatial database capabilities to multiple users at the same time, QGIS also supports the use of a file format called spatialite that is a lightweight, portable way to store an entire spatial database in a single file. Obviously, these 2 types of spatial databases should be used for different purposes, but the same basic principles and techniques apply to both. Let’s create a new spatialite database and explore the functionality provided to work with these databases in QGIS.

このレッスンの目標：QGIS ブラウザのインターフェイスを使用して SpatiaLite データベースを利用する方法を学ぶ。

18.3.1 Follow Along: ブラウザで SpatiaLite データベースを作成する

ブラウザのパネルを使って新しいSpatiaLite データベースを作成し、QGISで使用するための準備をすることができます。

- Spatialite エントリを右クリックし、Create Database を選択します。
- qgis-sl.db という名前でファイルシステム上に保存します。
- 再びブラウザツリー内の Spatialite を右クリックし、New Connection を選択して先ほど作成したファイルを探して開きます。

これでブラウザツリーに新しいデータベースが構成され、その下には何も持たないことから、行える操作は削除できるだけだということがわかります。このデータベースには何のテーブルも追加していないのでこれは当然です。それでは先に進んでみましょう。

- Find the button to create a new layer and use the dropdown to create a new new Spatialite layer, or select Layer -> New -> New Spatialite Layer.

羽毛
- 前の手順で作成したデータベースをドロップダウン内から選択します。
- レイヤに places という名前を付けてください。
- 次に Create an auto-incrementing primary key のチェックボックスを選択します。
- 下のような 2 つの属性を追加
- OK をクリックしてテーブルを作成します。
ブラウザ上部にある更新ボタンをクリックすると、places テーブルの一覧が表示されます。
テーブルを右クリックして、前のレッスンで行ったようにプロパティを表示することができます。
ここから編集のセッションを開始して直接新しいデータベースにデータを追加することができます。
DB Manager を利用してデータベースにデータをインポートする方法を学びました。新しい SpatiaLite データベースにデータをインポートするためにこの手法を用いることができます。

18.3.2 In Conclusion

ここでは SpatiaLite データベースを作成し、そこにテーブルを追加して QGIS のレイヤとしてテーブルを利用する方法を見てきました。
Chapter 19

Appendix: Contributing To This Manual

To add materials to this course, you must follow the guidelines in this Appendix. You are not to alter the conditions in this Appendix except for clarification. This is to ensure that the quality and consistency of this manual can be maintained.

19.1 リソースのダウンロード

The source of this document is available at GitHub. Consult GitHub.com for instructions on how to use the git version control system.

19.2 マニュアルの形式

This manual is written using Sphinx, a Python document generator using the reStructuredText markup language. Instructions on how to use these tools are available on their respective sites.

19.3 モジュールの追加

- To add a new module, first create a new directory (directly under the top-level of the qgis-training-manual directory) with the name of the new module.
- Under this new directory, create a file called index.rst. Leave this file blank for now.
- Open the index.rst file under the top-level directory. Its first lines are:

```
.. toctree::
   :maxdepth: 2

foreword/index
introduction/index
```

You will note that this is a list of directory names, followed by the name index. This directs the top-level index file to the index files in each directory. The order in which they are listed determines the order they will have in the document.

- Add the name of your new module (i.e., the name you gave the new directory), followed by /index, to this list, wherever you want your module to appear.
- Remember to keep the order of the modules logical, such that later modules build on the knowledge presented in earlier modules.
• Open your new module’s own index file ([module name]/index.rst).
• Along the top of the page, write a line of 80 asterisks (*). This represents a module heading.
• Follow this with a line containing the markup phrase |MOD| (which stands for “module”), followed by the name of your module.
• End this off with another line of 80 asterisks.
• Leave a line open beneath this.
• Write a short paragraph explaining the purpose and content of the module.
• Leave one line open, then add the following text:

```rst
.. toctree::
   :maxdepth: 2

   lesson1
   lesson2
```

... where lesson1, lesson2, etc., are the names of your planned lessons.

The module-level index file will look like this:

```
*******************************************************************************
|MOD| Module Name
*******************************************************************************

Short paragraph describing the module.
```

```rst
.. toctree::
   :maxdepth: 2

   lesson1
   lesson2
```

### 19.4 レッスンの追加

新規または既存のモジュールにレッスンを追加:

- モジュールディレクトリを開く
- Open the index.rst file (created above in the case of new modules).
- Ensure that the name of the planned lesson is listed underneath the toctree directive, as shown above.
- Create a new file under the module directory.
- Name this file exactly the same as the name you provided in the module’s index.rst file, and add the extension .rst.

**Note:** For editing purposes, a .rst file works exactly like a normal text file (.txt).

- To begin writing the lesson, write the markup phrase |LS|, followed by the lesson name.
- In the next line, write a line of 80 equal signs (=).
- Leave a line open after this.
- Write a short description of the lesson’s intended purpose.
- Include a general introduction to the subject matter. See the existing lessons in this manual for examples.
- Beneath this, start a new paragraph, beginning with this phrase:
**The goal for this lesson:**

* Briefly explain the intended outcome of completing this lesson.
* If you can’t describe the goal of the lesson in one or two sentences, consider breaking the subject matter up into multiple lessons.

Each lesson will be subdivided into multiple sections, which will be addressed next.

19.5 セクションの追加

There are two types of sections: “follow along” and “try yourself”.

* A “follow along” section is a detailed set of directions intended to teach the reader how to use a given aspect of QGIS. This is typically done by giving click-by-click directions as clearly as possible, interspersed with screenshots.
* A “try yourself” section gives the reader a short assignment to try by themselves. It is usually associated with an entry in the answer sheet at the end of the documentation, which will show or explain how to complete the assignment, and will show the expected outcome if possible.

Every section comes with a difficulty level. An easy section is denoted by |basic|, moderate by |moderate|, and advanced by |hard|.

19.5.1 Adding a “follow along” section

* To start this section, write the markup phrase of the intended difficulty level (as shown above).
* Leave a space and then write |FA| (for “follow along”).
* Leave another space and write the name of the section (use only an initial capital letter, as well as capitals for proper nouns).
* In the next line, write a line of 80 minuses/dashes (-). Ensure that your text editor does not replace the default minus/dash character with a long dash or other character.
* Write a short introduction to the section, explaining its purpose. Then give detailed (click-by-click) instructions on the procedure to be demonstrated.
* In each section, include internal links, external links and screenshots as needed.
* Try to end each section with a short paragraph that concludes it and leads naturally to the next section, if possible.

19.5.2 Adding a “try yourself” section

* To start this section, write the markup phrase of the intended difficulty level (as shown above).
* Leave a space and then write |TY| (for “try yourself”).
* In the next line, write a line of 80 minuses/dashes (-). Ensure that your text editor does not replace the default minus/dash character with a long dash or other character.
* Explain the exercise that you want the reader to complete. Refer to previous sections, lessons or modules if necessary.
* Include screenshots to clarify the requirements if a plain textual description is not clear.

In most cases, you will want to provide an answer regarding how to complete the assignment given in this section. To do so, you will need to add an entry in the answer sheet.

* First, decide on a unique name for the answer. Ideally, this name will include the name of the lesson and an incrementing number.
• この回答へのリンクを作成:
  :ref:`Check your results <answer-name>`

• Open the answer sheet (answers/answers.rst).

• Create a link to the “try yourself” section by writing this line:
  .. _answer-name:

• Write the instructions on how to complete the assignment, using links and images where needed.

• To end it off, include a link back to the “try yourself” section by writing this line:
  :ref:`Back to text <backlink-answer-name>`

• To make this link work, add the following line above the heading to the “try yourself” section:
  .. _backlink-answer-name:

Remember that each of these lines shown above must have a blank line above and below it, otherwise it could cause errors while creating the document.

### 19.6 Add a Conclusion

• To end a lesson, write the phrase \[IC\] for “in conclusion”, followed by a new line of 80 minuses/dashes (-). Write a conclusion for the lesson, explaining which concepts have been covered in the lesson.

### 19.7 Add a Further Reading Section

• このセクションは追加です。

• Write the phrase FR for “further reading”, followed by a new line of 80 minuses/dashes (-).

• Include links to appropriate external websites.

### 19.8 Add a What’s Next Section

• Write the phrase \[WN\] for “what’s next”, followed by a new line of 80 minuses/dashes (-).

• Explain how this lesson has prepared students for the next lesson or module.

• Remember to change the “what’s next” section of the previous lesson if necessary, so that it refers to your new lesson. This will be necessary if you have inserted a new lesson among existing lessons, or after an existing lesson.

### 19.9 Using Markup

To adhere to the standards of this document, you will need to add standard markup to your text.

#### 19.9.1 New concepts

• If you are explaining a new concept, you will need to write the new concept’s name in italics by enclosing it in asterisks (*).
This sample text shows how to introduce a *new concept*.

19.9.2 Emphasis

- To emphasize a crucial term which is not a new concept, write the term in bold by enclosing it in double asterisks (**).  
- Use this sparingly! If used too much, it can seem to the reader that you are shouting or being condescending.

This sample text shows how to use **emphasis** in a sentence. Include the punctuation mark if it is followed by a **comma,** or at the **end of the sentence.**

19.9.3 Images

- When adding an image, save it to the folder _static/lesson_name/_.
- Include it in the document like this:

  .. image:: /static/training_manual/lesson_name/image_file.extension
    :align: center

- Remember to leave a line open above and below the image markup.

19.9.4 Internal links

- To create an anchor for a link, write the following line above the place where you want the link to point to:

  .. _link-name:

- To create a link, add this line:

  :ref:'Descriptive link text <link-name>'

- Remember to leave a line open above and below this line.

19.9.5 External links

- To create an external link, write it out like this:

  'Descriptive link text <link-url>'

- Remember to leave a line open above and below this line.

19.9.6 Using monospaced text

- When you are writing text that the user needs to enter, a path name, or the name of a database element such as a table or column name, you must write it in monospaced text. For example:

  Enter the following path in the text box: :kbd:'path/to/file'.

19.9.7 Labeling GUI items

- If you are referring to a GUI item, such as a button, you must write its name in the GUI label format. For example:
To access this tool, click on the `Tool Name` button.

- This also applies if you are mentioning the name of a tool without requiring the user to click a button.

19.9.8 Menu selections

- If you are guiding a user through menus, you must use the `menu → selection → format`. For example:

  To use the `Tool Name` tool, go to `Plugins --> Tool Type --> Tool Name`.

19.9.9 Adding notes

- You might need to add a note in the text, which explains extra details that can’t easily be made part of the flow of the lesson. This is the markup:

  ```plaintext
  [Normal paragraph.]
  .. note:: Note text.
  New line within note.
  New paragraph within note.
  [Unindented text resumes normal paragraph.]
  ```

19.9.10 Adding a sponsorship/authorship note

If you are writing a new module, lesson or section on behalf of a sponsor, you must include a short sponsor message of their choice. This must notify the reader of the name of the sponsor and must appear below the heading of the module, lesson or section that they sponsored. However, it may not be an advertisement for their company.

If you have volunteered to write a module, lesson or section in your own capacity, and not on behalf of a sponsor, you may include an authorship note below the heading of the module, lesson or section that you authored. This must take the form `This [module/lesson/section] contributed by [author name].` Do not add further text, contact details, etc. Such details are to be added in the “Contributors” section of the Foreword, along with the name(s) of the part(s) you added. If you only made enhancements, corrections and/or additions, list yourself as an editor.

19.10 Thank You!

Thank you for contributing to this project! By so doing, you are making QGIS more accessible to users and adding value to the QGIS project as a whole.
Chapter 20

Answer Sheet

20.1 Results For Adding Your First Layer

20.1.1 Preparation

You should see a lot of lines, symbolizing roads. All these lines are in the vector layer that you just loaded to create a basic map.

Back to text

20.2 Results For An Overview of the Interface

20.2.1 Overview (Part 1)

Refer back to the image showing the interface layout and check that you remember the names and functions of the screen elements.

Back to text

20.2.2 Overview (Part 2)

1. Save as
2. Zoom to layer
3. Help
4. Rendering on/off
5. Measure line

Back to text
20.3 Results For Working with Vector Data

20.3.1 Shapefiles

There should be five layers on your map:

- places
- water
- buildings
- rivers and
- roads.

Back to text

20.3.2 Databases

All the vector layers should be loaded into the map. It probably won’t look nice yet though (we’ll fix the ugly colors later).

Back to text

20.4 Results For Symbology

20.4.1 Colors

- Verify that the colors are changing as you expect them to change.
- It is enough to change only the water layer for now. An example is below, but may look different depending on the color you chose.
If you want to work on only one layer at a time and don’t want the other layers to distract you, you can hide a layer by clicking in the check box next to its name in the Layers list. If the box is blank, then the layer is hidden.

20.4.2 Symbol Structure

Your map should now look like this:
If you are a Beginner-level user, you may stop here.

- Use the method above to change the colors and styles for all the remaining layers.
- Try using natural colors for the objects. For example, a road should not be red or blue, but can be gray or black.
- Also feel free to experiment with different Fill Style and Border Style settings for the polygons.

20.4.3 🔄 Symbol Layers

- Customize your buildings layer as you like, but remember that it has to be easy to tell different layers apart on the map.

Here’s an example:
20.4.4  Symbol Levels

To make the required symbol, you need two symbol layers:
The lowest symbol layer is a broad, solid yellow line. On top of it there is a slightly thinner solid gray line.

- If your symbol layers resemble the above but you’re not getting the result you want, check that your symbol levels look something like this:
Now your map should look like this:
20.4.5  Symbol Levels

- Adjust your symbol levels to these values:

- Experiment with different values to get different results.
- Open your original map again before continuing with the next exercise.

20.5  Results For Attribute Data

20.5.1  Attribute Data

The NAME field is the most useful to show as labels. This is because all its values are unique for every object and are very unlikely to contain NULL values. If your data contains some NULL values, do not worry as long as most of your places have names.
20.6 Results For The Label Tool

20.6.1 Label Customization (Part 1)

Your map should now show the marker points and the labels should be offset by 2.0 mm: The style of the markers and labels should allow both to be clearly visible on the map:

Back to text

20.6.2 Label Customization (Part 2)

One possible solution has this final product:
To arrive at this result:

- Use a font size of 10, a *Label distance* of 1.5 mm, *Symbol width* and *Symbol size* of 3.0 mm.
- In addition, this example uses the *Wrap label on character* option:
Enter a space in this field and click Apply to achieve the same effect. In our case, some of the place names are very long, resulting in names with multiple lines which is not very user friendly. You might find this setting to be more appropriate for your map.

**20.6.3 Using Data Defined Settings**

- Still in edit mode, set the FONT_SIZE values to whatever you prefer. The example uses 16 for towns, 14 for suburbs, 12 for localities and 10 for hamlets.
- Remember to save changes and exit edit mode.
- Return to the Text formatting options for the places layer and select FONT_SIZE in the Attribute field of the font size data override dropdown:
Your results, if using the above values, should be this:
20.7 Results For Classification

20.7.1 Refine the Classification

- Use the same method as in the first exercise of the lesson to get rid of the borders:

The settings you used might not be the same, but with the values $\text{Classes} = 6$ and $\text{Mode} = \text{Natural Breaks (Jenks)}$ (and using the same colors, of course), the map will look like this:
20.8 Results ForCreating a New Vector Dataset

20.8.1 Digitizing

The symbology doesn’t matter, but the results should look more or less like this:

20.8.2 Topology: Add Ring Tool

The exact shape doesn’t matter, but you should be getting a hole in the middle of your feature, like this one:
• Undo your edit before continuing with the exercise for the next tool.

Back to text

20.8.3  🔄 Topology: Add Part Tool

• First select the Bontebok National Part:
• Now add your new part:

• Undo your edit before continuing with the exercise for the next tool.

20.8.4  

Merge Features

• Use the Merge Selected Features tool, making sure to first select both of the polygons you wish to merge.

• Use the feature with the OGC_FID of 1 as the source of your attributes (click on its entry in the dialog, then click the Take attributes from selected feature button):

\[\text{If you’re using a different dataset, it is highly likely that your original polygon’s OGC_FID will not be 1. Just choose the feature which has an OGC_FID.}\]

\[\text{Using the Merge Attributes of Selected Features tool will keep the geometries distinct, but give them the same attributes.}\]

20.8.5  

Forms

For the TYPE, there is obviously a limited amount of types that a road can be, and if you check the attribute table for this layer, you’ll see that they are predefined.

• Set the widget to Value Map and click Load Data from Layer.
• Select *roads* in the *Label* dropdown and *highway* for both the *Value* and *Description* options:

![Image](image-url)

• Click *Ok* three times.

• If you use the *Identify* tool on a street now while edit mode is active, the dialog you get should look like this:

![Image](image-url)
20.9 Results For Vector Analysis

20.9.1 Extract Your Layers from OSM Data

For the purpose of this exercise, the OSM layers which we are interested in are multipolygons and lines. The multipolygons layer contains the data we need in order to produce the houses, schools and restaurants layers. The lines layer contains the roads dataset.

The Query Builder is found in the layer properties:

Using the Query Builder against the multipolygon layer, create the following queries for the houses, schools, restaurants and residential layers:
20.9. Results For Vector Analysis

![QGIS Layer Properties - multipolygons](image)

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>building</td>
<td>telephone_exchange</td>
</tr>
</tbody>
</table>

Filter expression:

```
"building" = 'church' AND "building" = 'commercial' AND "building" = 'garage' AND "building" = 'hangar' AND "building" = 'retail' AND "building" = 'telephone_exchange'
```
Once you have entered each query, click OK. You’ll see that the map updates to show only the data you have selected. Since you need to use again the multipolygon data from the OSM dataset, at this point, you can use one of the following methods:

- Rename the filtered OSM layer and re-import the layer from osm_data.osm, OR
- Duplicate the filtered layer, rename the copy, clear the query and create your new query in the Query Builder.

**Note:** Although OSM’s building field has a house value, the coverage in your area - as in ours - may not be complete. In our test region, it is therefore more accurate to exclude all buildings which are defined as anything other than house. You may decide to simply include buildings which are defined as house and all other values that have not a clear meaning like yes.

To create the roads layer, build this query against OSM’s lines layer:
You should end up with a map which looks similar to the following:
20.9.2 🌟 *Distance from High Schools*

- Your buffer dialog should look like this:

![Buffer dialog](image)

The *Buffer distance* is 1000 meters (i.e., 1 kilometer).

- The *Segments to approximate* value is set to 20. This is optional, but it’s recommended, because it makes the output buffers look smoother. Compare this:
To this:

The first image shows the buffer with the *Segments to approximate* value set to 5 and the second shows the value set to 20. In our example, the difference is subtle, but you can see that the buffer’s edges are smoother with the higher value.

*Back to text*
20.9.3  Distance from Restaurants

To create the new houses_restaurants_500m layer, we go through a two step process:

- First, create a buffer of 500m around the restaurants and add the layer to the map:
• Next, select buildings within that buffer area:

![Select by location dialog]

• Now save that selection to our new houses_restaurants_500m layer:
Your map should now show only those buildings which are within 50m of a road, 1km of a school and 500m of a restaurant:
20.10 Results For *Raster Analysis*

20.10.1 *Calculate Aspect*

- Set your *DEM (Terrain analysis)* dialog up like this:
20.10. Results For *Raster Analysis*

QGIS Training Manual, リリース 2.2
Your result:

20.10.2 Calculate Slope (less than 2 and 5 degrees)

- Set your Raster calculator dialog up like this:
• For the 5 degree version, replace the 2 in the expression and file name with 5.

Your results:

• 2 degrees:
• 5 degrees:
20.11 Results For Completing the Analysis

20.11.1  Raster to Vector

- Open the Query Builder by right-clicking on the all_terrain layer in the Layers list, select the General tab.
- Then build the query "suitable" = 1.
- Click OK to filter out all the polygons where this condition isn’t met.

When viewed over the original raster, the areas should overlap perfectly:

- You can save this layer by right-clicking on the all_terrain layer in the Layers list and choosing Save As..., then continue as per the instructions.
20.11.2  Inspecting the Results

You may notice that some of the buildings in your new_solution layer have been “sliced” by the Intersect tool. This shows that only part of the building - and therefore only part of the property - lies on suitable terrain. We can therefore sensibly eliminate those buildings from our dataset.

Back to text

20.11.3  Refining the Analysis

At the moment, your analysis should look something like this:

Consider a circular area, continuous for 100 meters in all directions.
If it is greater than 100 meters in radius, then subtracting 100 meters from its size (from all directions) will result in a part of it being left in the middle.

Therefore, you can run an interior buffer of 100 meters on your existing suitable_terrain vector layer. In the output of the buffer function, whatever remains of the original layer will represent areas where there is suitable terrain for 100 meters beyond.

To demonstrate:

• Go to Vector → Geoprocessing Tools → Buffer(s) to open the Buffer(s) dialog.
• Set it up like this:

![Buffer dialog window](image)

- Use the `suitable_terrain` layer with 10 segments and a buffer distance of -100. (The distance is automatically in meters because your map is using a projected CRS.)
- Save the output in `exercise_data/residential_development/` as `suitable_terrain_continuous100m.shp`.
- If necessary, move the new layer above your original `suitable_terrain` layer.

Your results will look like something like this:
• Now use the Select by Location tool (Vector → Research Tools → Select by location).

• Set up like this:

• Select features in \textit{new\_solution} that intersect features in \textit{suitable\_terrain\_continuous\_100m.shp}. 
This is the result:

The yellow buildings are selected. Although some of the buildings fall partly outside the new `suitable_terrain_continuous100m` layer, they lie well within the original `suitable_terrain` layer and therefore meet all of our requirements.

- Save the selection under `exercise_data/residential_development/` as `final_answer.shp`.

20.12 Results For WMS

20.12.1 Adding Another WMS Layer

Your map should look like this (you may need to re-order the layers):
20.12.2  🚢 Adding a New WMS Server

• Use the same approach as before to add the new server and the appropriate layer as hosted on that server:
If you zoom into the Swellendam area, you’ll notice that this dataset has a low resolution:

Therefore, it’s better not to use this data for the current map. The Blue Marble data is more suitable at global or national scales.

Back to text

20.12.3 Finding a WMS Server

You may notice that many WMS servers are not always available. Sometimes this is temporary, sometimes it is permanent. An example of a WMS server that worked at the time of writing is the World Mineral Deposits WMS
at http://apps1.gdr.nrcan.gc.ca/cgi-bin/worldmin_en-ca_ows. It does not require fees or have access constraints, and it is global. Therefore, it does satisfy the requirements. Keep in mind, however, that this is merely an example. There are many other WMS servers to choose from.

20.13 Results For Database Concepts

20.13.1 Address Table Properties

For our theoretical address table, we might want to store the following properties:

- House Number
- Street Name
- Suburb Name
- City Name
- Postcode
- Country

When creating the table to represent an address object, we would create columns to represent each of these properties and we would name them with SQL-compliant and possibly shortened names:

- house_number
- street_name
- suburb
- city
- postcode
- country

20.13.2 Normalising the People Table

The major problem with the people table is that there is a single address field which contains a person’s entire address. Thinking about our theoretical address table earlier in this lesson, we know that an address is made up of many different properties. By storing all these properties in one field, we make it much harder to update and query our data. We therefore need to split the address field into the various properties. This would give us a table which has the following structure:

<table>
<thead>
<tr>
<th>id</th>
<th>name</th>
<th>house_no</th>
<th>street_name</th>
<th>city</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tim Sutton</td>
<td>3</td>
<td>Buirski Plein</td>
<td>Swellendam</td>
<td>071 123 123</td>
</tr>
<tr>
<td>2</td>
<td>Horst Duester</td>
<td>4</td>
<td>Avenue du Roix</td>
<td>Geneva</td>
<td>072 121 122</td>
</tr>
</tbody>
</table>

In the next section, you will learn about Foreign Key relationships which could be used in this example to further improve our database’s structure.

20.13.3 Further Normalisation of the People Table

Our people table currently looks like this:
The `street_id` column represents a ‘one to many’ relationship between the `people` object and the related `street` object, which is in the `streets` table.

One way to further normalise the table is to split the name field into `first_name` and `last_name`:

```
<table>
<thead>
<tr>
<th>id</th>
<th>first_name</th>
<th>last_name</th>
<th>house_no</th>
<th>street_id</th>
<th>phone_no</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Horst</td>
<td>Duster</td>
<td>4</td>
<td>1</td>
<td>072 121 122</td>
</tr>
</tbody>
</table>
```

We can also create separate tables for the town or city name and country, linking them to our `people` table via ‘one to many’ relationships:

```
<table>
<thead>
<tr>
<th>id</th>
<th>first_name</th>
<th>last_name</th>
<th>house_no</th>
<th>street_id</th>
<th>town_id</th>
<th>country_id</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Horst</td>
<td>Duster</td>
<td>4</td>
<td>1</td>
<td>2</td>
<td>1</td>
</tr>
</tbody>
</table>
```

An ER Diagram to represent this would look like this:

```
Streets

People

Towns

Countries
```

**20.13.4 Create a People Table**

The SQL required to create the correct `people` table is:

```sql
create table people (id serial not null primary key,
                     name varchar(50),
                     house_no varchar(50),
                     street_id int not null,
                     phone_no varchar null);
```

The schema for the table (enter `d people`) looks like this:
### Table "public.people"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>integer</td>
<td>not null default</td>
</tr>
<tr>
<td></td>
<td></td>
<td>nextval('people_id_seq'::regclass)</td>
</tr>
<tr>
<td>name</td>
<td>character varying(50)</td>
<td></td>
</tr>
<tr>
<td>house_no</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>street_id</td>
<td>integer</td>
<td>not null</td>
</tr>
<tr>
<td>phone_no</td>
<td>character varying</td>
<td></td>
</tr>
</tbody>
</table>

Indexes:
- "people_pkey" PRIMARY KEY, btree (id)

For illustration purposes, we have purposely omitted the fkey constraint.

---

#### 20.13.5 The DROP Command

The reason the DROP command would not work in this case is because the `people` table has a Foreign Key constraint to the `streets` table. This means that dropping (or deleting) the `streets` table would leave the `people` table with references to non-existent `streets` data.

*Note:* It is possible to ‘force’ the `streets` table to be deleted by using the CASCADE command, but this would also delete the `people` and any other table which had a relationship to the `streets` table. Use with caution!

---

#### 20.13.6 Insert a New Street

The SQL command you should use looks like this (you can replace the street name with a name of your choice):

```sql
insert into streets (name) values ('Low Road');
```

---

#### 20.13.7 Add a New Person With Foreign Key Relationship

Here is the correct SQL statement:

```sql
insert into streets (name) values ('Main Road');
insert into people (name, house_no, street_id, phone_no)
values ('Joe Smith', 55, 2, '072 882 33 21');
```

If you look at the streets table again (using a select statement as before), you’ll see that the `id` for the Main Road entry is 2.

That’s why we could merely enter the number 2 above. Even though we’re not seeing Main Road written out fully in the entry above, the database will be able to associate that with the `street_id` value of 2.

*Note:* If you have already added a new `street` object, you might find that the new Main Road has an ID of 3 not 2.

---

20.13. Results For Database Concepts
20.13.8  Return Street Names

Here is the correct SQL statement you should use:

```sql
select count(people.name), streets.name
from people, streets
where people.street_id=streets.id
group by streets.name;
```

Result:

<table>
<thead>
<tr>
<th>count</th>
<th>name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Low Street</td>
</tr>
<tr>
<td>2</td>
<td>High street</td>
</tr>
<tr>
<td>1</td>
<td>Main Road</td>
</tr>
</tbody>
</table>

(3 rows)

This needs to be done whenever the field name is ambiguous (i.e. not unique across all tables in the database).

20.14  Results For Spatial Queries

20.14.1  The Units Used in Spatial Queries

The units being used by the example query are degrees, because the CRS that the layer is using is WGS 84. This is a Geographic CRS, which means that its units are in degrees. A Projected CRS, like the UTM projections, is in meters.

Remember that when you write a query, you need to know which units the layer's CRS is in. This will allow you to write a query that will return the results that you expect.

20.14.2  Creating a Spatial Index

```sql
CREATE INDEX cities_geo_idx
ON cities
USING gist (the_geom);
```

20.15  Results For Geometry Construction

20.15.1  Creating Linestrings
alter table streets add column the_geom geometry;
alter table streets add constraint streets_geom_point_chk check
    (st_geometrytype(the_geom) = 'ST_LineString':text OR the_geom IS NULL);
insert into geometry_columns values ("" ,"public" ,"streets" ,"the_geom" ,2,4326,
    'LINESTRING');
create index streets_geo_idx
    on streets
    using gist
    (the_geom);

Back to text

20.15.2 Linking Tables

delete from people;
alter table people add column city_id int not null references cities(id);

(capture cities in QGIS)

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
    values ('Faulty Towers',
        34,
        3,
        '072 812 31 28',
        1,
        'SRID=4326;POINT(33 33)');

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
    values ('IP Knightly',
        32,
        1,
        '071 812 31 28',
        1,
        'SRID=4326;POINT(32 -34)');

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
    values ('Rusty Bedsprings',
        39,
        1,
        '071 822 31 28',
        1,
        'SRID=4326;POINT(34 -34)');

If you’re getting the following error message:

ERROR: insert or update on table "people" violates foreign key constraint
    "people_city_id_fkey"
DETAIL: Key (city_id)=(1) is not present in table "cities".

then it means that while experimenting with creating polygons for the cities table, you must have deleted some of them and started over. Just check the entries in your cities table and use any id which exists.

Back to text
20.16 Results For Simple Feature Model

20.16.1 Populating Tables

create table cities (id serial not null primary key,
name varchar(50),
the_geom geometry not null);

alter table cities
add constraint cities_geom_point_chk
check (st_geometrytype(the_geom) = 'ST_Polygon':text );

Back to text

20.16.2 Populate the Geometry_Columns Table

insert into geometry_columns values
('','public','cities','the_geom',2,4326,'POLYGON');

Back to text

20.16.3 Adding Geometry

select people.name,
    streets.name as street_name,
    st_astext(people.the_geom) as geometry
from streets, people
where people.street_id=streets.id;

Result:

<table>
<thead>
<tr>
<th>name</th>
<th>street_name</th>
<th>geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roger Jones</td>
<td>High street</td>
<td></td>
</tr>
<tr>
<td>Sally Norman</td>
<td>High street</td>
<td></td>
</tr>
<tr>
<td>Jane Smith</td>
<td>Main Road</td>
<td></td>
</tr>
<tr>
<td>Joe Bloggs</td>
<td>Low Street</td>
<td></td>
</tr>
<tr>
<td>Fault Towers</td>
<td>Main Road</td>
<td>POINT(33 -33)</td>
</tr>
</tbody>
</table>

(5 rows)

As you can see, our constraint allows nulls to be added into the database.

Back to text
Chapter 21

索引とテーブル

• genindex
• modindex
• search