Outdated version of the documentation. Find the latest one here.

14.3. Lesson: Numériser les massifs forestiers

Unless you are going to use your georeferenced map as a simple background image, the next natural step is to digitize elements from it. You have already done so in the exercises about creating vector data in ..create_vector_data/create_new_vector , when you digitized the school fields. In this lesson, you are going to digitize the forest stands’ borders that appear in the map as green lines but instead of doing it using an aerial image, you will use your georeferenced map.

Objectif de cette leçon : Apprendre une technique d’aide à la tâche de numérisation, en numérisant des massifs forestiers et en leur ajoutant finalement les données d’inventaire.

14.3.1. basic Follow Along: Extraction des bordures des massifs forestiers

Ouvrez dans QGIS votre projet map_digitizing.qgs, que vous aviez sauvegardé dans la leçon précédente.

Une fois que vous avez scanné et géoréférencé votre carte, vous pouvez directement commencer la numérisation en regardant l’image comme un guide. Cela sera probablement la façon avec laquelle vous procéderez si l’image que vous avez numérisé est, par exemple, une photographie aérienne.

If what you are using to digitize is a good map, as it is in our case, it is likely that the information is clearly displayed as lines with different colors for each type of element. Those colors can be relatively easy extracted as individual images using an image processing software like GIMP. Such separate images can be used to assist the digitizing, as you will see below.

La première étape sera d’utiliser GIMP pour obtenir une image qui ne contienne que les massifs forestiers, c’est-à-dire toutes ces lignes verdâtres que vous pouvez voir sur la carte scannée d’origine :

  • Ouvrez GIMP (si vous ne l’avez pas déjà installé, téléchargez-le depuis internet ou demandez à votre professeur).

  • Ouvrez l’image originale de la carte, Fichier ‣ Ouvrir, rautjarvi_map.tif dans le répertoire exercise_data/forestry. Notez que les massifs forestiers sont représentés par des lignes vertes (avec le numéro du massif également en vert à l’intérieur de chaque polygone).

../../../_images/gimp_map.png

Now you can select the pixels in the image that are making up the forest stands’ borders(the greenish pixels):

  • Ouvrez l’outil Sélection ‣ Par couleur.

  • Avec l’outil activé, zoomez sur l’image (Ctrl + molette de la souris) afin qu’une ligne de massif forestier soit suffisamment proche pour différencier les pixels formant la ligne. Voyez l’image de gauche ci-dessous.

  • Cliquez et faites glisser le curseur de la souris au milieu de la ligne afin que l’outil collecte plusieurs valeurs de couleur de pixels.

  • Relâchez le clic de la souris et attendez quelques secondes. Les pixels aux couleurs récupérées par l’outil seront sélectionnés à travers toute l’image.

  • Dézoomez pour voir comment les pixels verdâtres ont été sélectionnés sur toute l’image.

  • Si vous n’êtes pas content du résultat, répétez l’opération de cliquer et glisser la souris.

  • You pixel selection should look something like the right image below.
../../../_images/green_px_selected.png

Une fois que vous en avez terminé avec la sélection, vous devez copier cette sélection comme nouvelle couche et ensuite la sauvegarder séparément comme fichier image :

  • Copiez (Ctr+C) les pixels sélectionnés.

  • Et collez directement les pixels (Ctr+V), GIMP affichera les pixels collés comme une nouvelle couche temporaire dans l’onglet Couches - Remplissage en tant que Sélection flottante (Couche collée).

  • Faites un clic-droit sur la couche temporaire et sélectionnez Vers une nouvelle couche.

  • Cliquez sur l’icône “oeil” à côté de la couche de l’image d’origine pour la désactiver, afin que seule la Couche collée soit visible :

../../../_images/saving_green_px.png
  • Finalement, sélectionnez Fichier ‣ Exporter..., mettez une image TIFF à Sélectionner le type de fichier (par extension), sélectionnez le dossier digitizing et nommez-la rautjarvi_map_green.tif. Sélectionnez pas de compression lorsqu’on vous le demande.

Vous pouvez faire le même processus avec d’autres éléments de l’image, par exemple extraire les lignes noires représentant les routes, ou les brunes qui représentent les lignes de contour du terrain. Mais pour nous, les massifs forestiers sont suffisants.

14.3.2. basic Try Yourself Géoréférencer l’image de pixels verts

Comme vous l’avez fait dans la leçon précédente, vous devez géoréférencer cette nouvelle image pour pouvoir l’utiliser avec le reste de vos données.

Notez que vous n’avez pas besoin de numériser plus les points de contrôle car cette image est en fait la même image que l’image d’origine de la carte, dans la mesure où l’outil Géoréférencer est concerné. Voici quelques choses que vous devriez vous rappelez :

  • Cette image est aussi, évidemment, dans le SCR KKJ / Finland zone 2.

  • Vous devriez utiliser les points de contrôle que vous avez sauvegardé, Fichier ‣ Charger des points de contrôle (GCP).

  • Temember to review the Transformation settings.
  • Nommez le raster de sortie rautjarvi_green_georef.tif dans le dossier digitizing.

Vérifiez que le nouveau raster se superpose parfaitement avec la carte d’origine.

14.3.3. basic Follow Along: Création de points d’appui pour la numérisation

Having in mind the digitizing tools in QGIS, you might already be thinking that it would be helpful to snap to those green pixels while digitizing. That is precisely what you are going to do next create points from those pixels to use them later to help you follow the the forest stands’ borders when digitizing, by using the snapping tools available in QGIS.

  • Utilisez l’outil Raster ‣ Conversion ‣ Polygoniser (Raster à Vecteur) pour vectoriser vos lignes vertes en polygones. Si vous ne vous souvenez plus comment faire, vous pouvez le revoir dans Lesson: Conversion Raster vers Vecteur.

  • Sauvegardez en tant que rautjarvi_green_polygon.shp dans le dossier digitizing.

Zoomez et voyez à quoi ressemblent les polygones. Vous obtiendrez quelque chose comme ça :

../../../_images/green_polygons.png

Next one option to get points out of those polygons is to get their centroids:

  • Ouvrez Vecteur ‣ Outils géométriques ‣ Centroïdes de polygones.

  • Set your the polygon layer you just got as the input file for the tool.
  • Nommez la sortie green_centroids.shp dans le dossier the digitizing.

  • Cochez Ajouter le résultat au canevas.

  • Lancez l’outil pour calculer les centroïdes des polygones.

../../../_images/green_points.png

Vous pouvez maintenant enlever la couche rautjarvi_green_polygon de la Légende la carte.

Changez la symbologie de la couche des centroïdes comme suit :

  • Ouvrez les Propriétés de la couche pour green_centroids.

  • Rendez-vous à l’onglet Style.

  • Configurez l’Unité avec Unité de la carte.

  • Mettez la Taille à 1.

Il n’est pas nécessaire de différencier les points les uns des autres, vous avez seulement besoin de les avoir pour que les outils d’accrochage puissent les utiliser. Vous pouvez maintenant utiliser ces points pour suivre les lignes d’origine plus facilement que sans eux.

14.3.4. basic Follow Along: Numériser les massifs forestiers

Now you are ready to start with the actual digitizing work. You would start by creating a vector file of polygon type, but for this exercise, there is a shapefile with part of the area of interest already digitized. You will just finish digitizing the half of the forest stands that are left between the main roads (wide pink lines) and the lake:

../../../_images/forest_stands_to_digitize.png
  • Rendez-vous au dossier digitizing en utilisant votre navigateur de gestion de fichier.

  • Faites glisser et déposez le fichier vecteur forest_stands.shp dans votre carte.

Changez la symbologie de la nouvelle couche afin qu’il soit plus facile de voir quel polygone a déjà été numérisé :

  • Le remplissage du polygone en vert.

  • Les bordures des polygones à 1 mm.

  • Et mettez la transparence à 50%.

Maintenant, si vous vous souvenez des modules passés, nous devons définir et activer les options d’accrochage :

  • Rendez-vous aux Préférences ‣ Options d’accrochage....

  • Activez l’accrochage pour les couches green_centroids et forest_stands.

  • Fixez leur Tolérance à 5 unités de carte.

  • Cochez la case Éviter les intersections pour la couche forest_stands.

  • Cochez Activer l’édition topologique.

  • Cliquez sur Appliquer.

../../../_images/snapping_settings_forest.png

With these snapping settings, whenever you are digitizing and get close enough to one of the points in the centroids layer or any vertex of your digitized polygons, a pink cross will appear on the point that will be snapped to.

Finalement, désactivez la visibilité de toutes les couches sauf de forest_stands et rautjarvi_georef. Assurez-vous que l’image de la carte n’a plus de transparence.

Quelques choses importantes à noter avec que vous démarriez la numérisation :

  • N’essayez pas d’être trop précis avec la numérisation des bordures.

  • Si une bordure est une ligne droite, numérisez-la avec seulement deux noeuds. En général, la numérisation utilise aussi peu de noeuds que possible.

  • Zoomez pour fermer les plages seulement si vous pensez que vous devez être précis, par exemple, à un coin ou lorsque vous voulez connecter un polygone avec un autre polygone à un certain noeud.

  • Utilisez le bouton du milieu de la souris pour zoomer/dézoomer et vous déplacer lors de la numérisation.

  • Numérisez seulement un polygone à la fois.

  • Après avoir numérisé un polygone, écrivez l’id du massif forestier que vous pouvez voir sur la carte.

Vous pouvez maintenant commencer la numérisation :

  • Localisez le massif forestier numéro 357 dans la fenêtre de la carte.

  • Activez l’édition pour la couche forest_stands.shp.

  • Sélectionner l’outil Ajouter une entité.

  • Commencez la numérisation de la place 357 en connectant certains des points.

  • Notez que les croix roses indiquent l’accrochage.

../../../_images/dgitizing_357_1.png
  • Quand vous avez terminé, faites un clic-droit pour terminer la numérisation du polygone.

  • Entrez l’id de la plage forestière (dans ce cas 357).

  • Cliquez sur OK.

Si on ne vous a pas demandé l’id du polygone lorsque vous avez terminé sa numérisation, rendez-vous aux Paramètres ‣ Options ‣ Numérisation et assurez-vous que Supprimer les avertissements de formulaire d’attribut lors de la création d’entité n’est pas coché.

Votre polygone numérisé ressemblera à cela :

../../../_images/dgitizing_357_3.png

Now for the second polygon, pick up the stand number 358. Make sure that the Avoid int. is checked for the forest_stands layer. This option does not allow intersecting polygons at digitizing, so that if you digitize over an existing polygon, the new polygon will be trimmed to meet the border of the already existing polygon/s. You can use this characteristic to automatically obtain a common border.

  • Commencez à numériser le massif 358 à un des angles communs avec le massif 357.

  • Puis continuez normalement jusqu’à ce que vous arriviez à l’autre coin commun aux deux massifs.

  • Finally, digitize a few points inside polygon 358 making sure that the common border is not intersected. See left image below.
  • Faites un clic-droit pour terminer la modification du massif forestier 358.

  • Entrez 358 comme id.

  • Cliquez sur OK, votre nouveau polygone devrait montrer une bordure commune avec la plage 357, comme vous pouvez le voir sur l’image de droite.

../../../_images/dgitizing_358_5.png

The part of the polygon that was overlapping the existing polygon has been automatically trimmed out and you are left with a common border, as you intended it to be.

14.3.5. basic Try Yourself Finir la numérisation des massifs forestiers

Vous avez maintenant deux plages de forêts prêtes. Et une bonne idée de comment procéder. Continuez à numériser de vous-même jusqu’à ce que vous ayez numérisé toutes les plages de forêt qui sont limitées par la route principale et le lac.

Cela peut sembler être beaucoup de travail, mais vous serez bientôt habitué à la numérisation des massifs forestiers. Cela devrait vous prendre environ 15 minutes.

During the digitizing you might need to edit or delete nodes, split or merge polygons. You learned about the necessary tools in ..create_vector_data/topo_editing, now is probably a good moment to go read about them again.

Souvenez-vous qu’en ayant coché Activer l’édition topologique, cela vous permet de déplacer des noeuds communs à deux polygones afin que la bordure commune soit modifiée en même temps pour les deux polygones.

Votre résultat devra ressembler à cela :

../../../_images/stands_fully_digitized.png

14.3.6. basic Follow Along: Jointure des données du massif forestier

Il est possible que les données d’inventaire des forêts que vous avez pour votre carte soit aussi écrites sur papier. Dans ce cas, vous devrez tout d’abord écrire ces données dans un fichier texte ou un tableur. Pour cet exercice, les informations de l’inventaire de 1994 (le même inventaire que la carte) sont prêtes dans un fichier texte séparé par des virgule (fichier csv).

Open the rautjarvi_1994.csv file from the exercise_data\forestry in a text editor and note that the inventory data file has an attribute called ID that has the numbers of the forest stands. Those numbers are the same as the forest stands ids you have entered for your polygons and can be used to link the data from the text file to your vector file. You can see the metadata for this inventory data in the file rautjarvi_1994_legend.txt in the same folder.

  • Ouvrez le .csv dans QGIS avec l’outil Couche ‣ Ajouter une couche de texte délimité.... Dans la boîte de dialogue, faites la configuration comme suit :

../../../_images/inventory_csv_import.png

Pour ajouter les données depuis un fichier .csv :

  • Ouvrez les Propriétés de la couche pour la couche forest_stands.

  • Rendez-vous à l’onglet Jointure.

  • Cliquez sur le signe plus en bas de la boîte de dialogue.

  • Sélectionnez rautjarvi_1994.csv pour la Couche de jointure et ID pour le champ Jointure.

  • Assurez-vous que le champ Cible est aussi mis sur id.

  • Cliquez sur OK deux fois.

Les données du fichier texte devraient être maintenant liées à votre fichier vectoriel. Pour voir ce qu’il s’est passé, ouvrez la table attributaire pour la couche forest_stands. Vous pouvez voir que tous les attributs du fichier de données d’inventaire sont maintenant liées à votre couche vectorielle numérisée.

14.3.7. basic Try Yourself Changement du nom des attributs et ajout de l’aire et du périmètre

Les données du fichier .csv sont juste liées à votre fichier vectoriel. Pour rendre ce lien permanent, afin que les données soient effectivement enregistrées dans le fichier vectoriel, vous devez sauvegarder la couche forest_stands comme un nouveau fichier vectoriel. Fermez la table attributaire et faites un clic droit sur la couche forest_stands pour la sauvegarder en tant que forest_stands_1994.shp.

Ouvrez votre nouveau forest_stands_1994.shp dans votre carte si vous ne l’avez pas encore ajouté. Puis, ouvrez la table attributaire. Vous remarquerez que le noms des colonnes que vous venez d’ajouter ne sont pas très utiles. Pour résoudre ceci :

  • Ajoutez l’extension Table Manager comme vous l’avez fait avec d’autres extensions précédemment.

  • Assurez-vous que l’extension est activée.

  • Dans la Légende de la carte, sélectionnez la couche forest_stands_1994.shp.

  • Then, go to Vector ‣ Table Manger ‣ Table manager.
  • Utilisez la boîte de dialogue pour modifier les noms des colonnes correspondants à ceux du fichier .csv.

../../../_images/forestry_table_manager.png
  • Cliquez sur Sauvegarder.

  • Sélectionnez Oui pour garder le style de la couche.

  • Fermez la boîte de dialogue Table Manager.

To finish gathering the information related to these forest stands, you might calculate the area and the perimeter of the stands. You calculated areas for polygons in Lesson: Exercice Supplémentaire. Go back to that lesson if you need to and calculate the areas for the forest stands, name the new attribute Area and make sure that the values calculated are in hectares.

Maintenant votre couche forest_stands_1994.shp est prête et contient toute l’information disponible.

Sauvegardez votre projet pour garder la présentation de la carte actuelle au cas où vous auriez besoin d’y revenir plus tard.

14.3.8. In Conclusion

Cela a pris plusieurs clics de souris mais vous avez désormais vos anciennes données d’inventaire dans un format numérique et prêtes à être utilisées dans QGIS.

14.3.9. What’s Next?

You could start doing different analysis with your brand new dataset, but you might be more interested in performing analysis in a dataset more up to date. The topic of the next lesson will be the creation of forest stands using current aerial photos and the addition of some relevant information to your dataset.