Outdated version of the documentation. Find the latest one here.

.

Complemento Visualización de Eventos

(En esta sección se deriva de Horning, N., K, Koy, P. Ersts. 2009. eVis (v1.1.0) Guía de Usuario. Museo Americano de Historia Natural, Centro para la Biodiversidad y Conservación. Disponible de http://biodiversityinformatics.amnh.org/, y realizado bajo GNU FDL.)

El mecanismo de información sobre biodiversidad en el Museo Americano de Historia Natural(AMNH) Centro para la Biodiversidad y la Conservación (CBC) ha desarrollado la herramienta de visualización de eventos (eVis), otra herramienta de software para añadir al suite de monitoreo de conservación y herramienta de apoyo a las decisiones para guiar un área protegida y la planificación del paisaje. Este complemento permite a los usuarios enlazar fácilmente la geocodificación (es decir., se hacer referencia con latitud y longitud o coordenadas X y Y) de fotografías, y otros documentos de apoyo, a los datos vectoriales en QGIS.

eVis ahora esta automáticamente instalado y habilitado en nuevas versiones de QGIS, y como todos los demás complementos, se puede habilitar y deshabilitar utilizando el Administrador de Complementos (ver The Plugins Menus).

El complemento de visualización de eventos se compone de tres módulos: la ‘Herramienta para conexión a la base de datos’, ‘Herramienta de ID evento’, y el ‘Eventos del navegador’. Estos trabajan juntos para permitir la visualización de fotografías geocodificadas y otros documentos que están vinculados a objetos espaciales almacenados en archivo de vectores, base de datos o hojas de cálculo.

Explorador de Eventos

El módulo de Explorador de eventos proporciona la funcionalidad de desplegar fotografías geocodificadas que están vinculadas con un objetos espacial vectorial desplegado en la ventana de mapa de QGIS. Datos específicos, por ejemplo, puede ser desde un archivo vectorial que se puede ingresar mediante QGIS o puede ser a partir del resultado de una consulta de base de datos. El vector del objeto espacial debe tener información del atributo asociado con él para describir la ubicación y el nombre del archivo que contiene la fotografía y, opcionalmente, la dirección de la brújula de la cámara fue indicado cuando fue adquirida la imagen. Su capa vectorial se debe cargar en QGIS antes de ejecutar el explorador de eventos.

Iniciar el módulo de Explorador de eventos

Para poner en marcha el modulo Explorador de Eventos, haga clic en Base de datos‣ eVis ‣ Explorador de Eventos eVis. Esto abrirá la ventana Explorador de Eventos Genérico.

La ventana Explorador de eventos tiene tres pestañas desplegadas en la parte superior de la ventana. La pestaña Visualizar se utiliza para ver las fotografías y los datos de sus atributos asociados. La pestaña Opciones proporciona un número de ajustes para controlar el funcionamiento del complemento eVis. Por último, la pestaña Configuración de aplicaciones externas se utiliza para mantener una tabla de extensiones de archivos y su aplicación asociada para permitir a eVis desplegar documentos que no sean imágenes.

Comprender la ventana Visualizar

Para ver la ventana Visualizar, haga clic en la pestaña Visualizar en la ventana Explorador de Eventos. La ventana Visualizar se utiliza para visualizar las fotografías geocodificadas y los atributos asociados a ellas.

Figure eVis 1:

../../../_images/evisdisplay.png

La ventana de eVis visualizar

  1. Ventana de Visualizar: Una ventana donde la fotografía aparece.

  2. Botón de Acercar zoom: Acercar zoom para ver más detalle. Si la imagen completa no puede ser visualizada en la ventana de visualizar, las barras de desplazamiento aparecerán en del lado izquierdo e inferior de la ventana para permitirle desplazarse por la imagen.

  3. Botón de Alejar zoom: Alejar zoom para ver más área.

  4. Botón Zum general: Despliega la fotografía completa.

  5. Ventana de información de atributos: Toda la información de atributos del punto asociado con la foto que se está viendo se muestra aquí. Si el tipo de archivo al que hace referencia del registro mostrado no es una imagen sino un tipo de archivo definido en la pestaña Configurar aplicaciones externas cuando haga doble clic en el valor del campo que contiene la ruta al archivo se abrirá la aplicación para ver u oír el contenido del archivo. Si se reconoce la extensión del archivo los datos de los atributos se mostrarán en verde.

  6. Botones de Navegación: Utiliza el botón anterior y siguiente para cargar el objeto anterior o siguiente cuando mas de un objeto espacial esta seleccionado.

Comprender la ventana de Opciones

Figure eVis 2:

../../../_images/evisoptions.png

La ventana de eVis Opciones

  1. Ruta del archivo: Una lista desplegable para especificar el campo de atributo que contiene la ruta del directorio o URL para las fotografías u otros documentos que se muestran. Si la ubicación es una ruta relativa, entonces la casilla de verificacion debe hacer clic. LA ruta base para una ruta relativa puede ser introducida en la caja de texto Ruta Base a continuación. La información sobre las diferentes opciones para especificar la ubicación del archivo se indica en la sección Especificar la ubicación y nombre de la fotografía a continuación.

  2. Rumbo de la brújula: Una lista desplegable para especificar el campo de atributo que contiene el rumbo de la brújula asociado con las fotografías que se muestran. Si la información del rumbo de la brújula esta disponible, es necesario hacer clic en casilla de verificación a continuación el título del menú desplegable.

  3. Desplazamiento de la brújula: El desplazamiento de la brújula se puede utilizar para compensar la declinación (para ajustar los rodamientos recolectados usando cojinetes magnéticos para el rumbo del norte verdadero). Haga clic en el botón de radio radiobuttonon Manual para ingresar el desplazamiento en la caja de texto o haga clic en el botón de radio De atributo para seleccionar el campo del atributo que contiene los desplazamientos. Para ambas opciones, declinaciones del este deben introducirse utilizando valores positivos, y declinaciones al oeste deben utilizar valores negativos.

  4. Ruta del archivo: La ruta de la base sobre la que se añadirá la ruta relativa se define en Figure_eVis_2 (A).

  5. Sustituir la ruta: Si esta casilla de verificación esta marcada, solo el nombre del archivo de A se anexará a la ruta base.

  6. Aplicar regla a todos los documentos: Si se marco, las mismas reglas de ruta que están definidas para las fotografías se utilizarán para los documentos sin imagen, tales como películas, documentos de texto y archivos de sonido. Si no se marca, las reglas de ruta sólo se aplicarán a las fotografías, y los otros documentos ignorarán el parámetro de la ruta base.

  7. Recordar ajustes: Si la casilla de verificación es marcada, los valores de los parámetros asociados se guardarán para la siguiente sesión cuando la ventana se cierra o cuando el botón [Guardar] de abajo sea presionado.

  8. Restablecer: Restablecer los valores en esta línea a la configuración predeterminada.

  9. Restaurar los valores predeterminados: Esto restablecerá todos los campos a su configuración predeterminada. Tiene el mismo efecto hacer clic en todos los botones de [Restablecer].

  10. Guardar: Esto guardará los ajustes sin cerrar el panel Opciones.

Comprender la ventana de Configurar aplicaciones externas

Figure eVis 3:

../../../_images/evisexternal.png

La ventana de eVis Aplicaciones externas

  1. Tabla de referencia de archivo: Una tabla contiene los tipos de archivo que se pueden abrir utilizando eVis. Cada tipo de archivo necesita una extensión de archivo y la ruta de una aplicación que pueda abrir ese tipo de archivo. Esto proporciona la capacidad de abrir una amplia gama de archivos tales como películas, grabaciones sonoras y documentos de texto en lugar de solo imágenes.

  2. Añadir nuevo tipo de archivo: Añadir un nuevo tipo de archivo con una única extensión y la ruta para la aplicación que puede abrirlo.

  3. Borrar la fila actual: Borrar el tipo de archivo destacado en la tabla y definido por una extensión de archivo y una ruta a una aplicación asociada.

Especificar la ubicación y nombre de la fotografía

La ubicación y nombre de la fotografía se pueda almacenar utilizando una ruta relativa o absoluta, o una URL, si la fotografía esta disponible en el servidor web. Ejemplos de los diferentes enfoques están listados en la tabla evis_examples.

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  http://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:http://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

Especificar la ubicación y nombre de otros documentos soportados

Los documentos de apoyo tales como documentos de texto, videos, y clips de sonido también se pueden visualizar o reproducir por eVis. Para ello, es necesario añadir una entrada en el archivo de tabla de referencia que se puede acceder desde la ventana Configurar Aplicaciones Externas ` en el :guilabel:`Generic Event Browser que coincide con la extensión de archivo a una aplicación que se puede utilizar para abrir el archivo. También es necesario disponer de la ruta o URL para el archivo en la tabla de atributos de la capa vectorial. Una regla adicional que puede ser utilizada para las direcciones URL que no contienen una extensión de archivo para el documento que desea abrir es especificar la extensión del archivo antes de la URL. El formato es — file extension:URL. La URL es precedida por la extensión de archivo y dos puntos; esto es particularmente útil para el acceso a los mismos a partir de los wikis y otros sitios web que utilizan una base de datos para gestionar las páginas web (véase Table evis_examples).

Utilizar el Explorador de eventos

Cuando la ventana :guilabel: Navegador de Eventos se abre, una fotografía aparecerá en la pantalla si el documento se hace referencia en la tabla de atributos de archivo vectorial es una imagen y si la información de la ubicación del archivo en la ventana Opciones es correctamente establecida. Si se espera una fotografía y no aparece, será necesario ajustar los parámetros en la ventana :guilabel: Opciones.

Si un documento de apoyo (o una imagen que no tiene una extensión de archivo reconocido por eVis) se hace referencia en la tabla de atributos, el campo que contiene la ruta del archivo se resaltará en verde en la ventana de información de atributos si esa extensión de archivo se define en el archivo de la tabla de referencia se encuentra en la ventana Configurar Aplicaciones Externas. Para abrir el documento, haga doble clic en la línea verde resaltado en la ventana de información de atributos. Si un documento de apoyo se hace referencia en la ventana de información de atributos y la ruta del archivo no está resaltado en verde, entonces será necesario añadir una entrada para la extensión de nombre de archivo del archivo en la ventana Configurar Aplicaciones Externas. Si la ruta del archivo se resalta en verde, pero no se abre al hacer doble clic, será necesario ajustar los parámetros en la ventana :guilabel: Opciones por lo que el archivo puede ser localizado por eVis.

Si no se proporciona una brújula en la ventana :guilabel: Opciones, un asterisco rojo se mostrará en la parte superior de la característica de vector que se asocia con la fotografía que se muestra. Si se proporciona una brújula, a continuación, aparecerá una flecha apuntando en la dirección indicada por el valor en el campo de visualización de brújula en la ventana :guilabel: Navegador de Eventos. La flecha estará centrado sobre el punto que se asocia con la fotografía u otro documento.

Para cerrar la ventana Explorador de eventos, haga clic en el botón [Cerrar] de la ventana Visualizar.

Herramienta ID evento

The ‘Event ID’ module allows you to display a photograph by clicking on a feature displayed in the QGIS map window. The vector feature must have attribute information associated with it to describe the location and name of the file containing the photograph and, optionally, the compass direction the camera was pointed when the image was acquired. This layer must be loaded into QGIS before running the ‘Event ID’ tool.

Iniciar el módulo ID evento

To launch the ‘Event ID’ module, either click on the event_id Event ID icon or click on Database ‣ eVis ‣ Event ID Tool. This will cause the cursor to change to an arrow with an ‘i’ on top of it signifying that the ID tool is active.

Para ver las fotografías vinculadas con entidades vectoriales en la capa vectorial activa se muestra en la ventana de mapa de QGIS, mova el cursor del Evento ID sobre el objeto espacial y hacer clic en el ratón. Después de hacer clic en el objeto, la ventana Explorador de eventos se abrirá y las fotografías sobre o cerca de la ubicación donde se ha hecho clic están disponibles para su visualización en el navegador. Si más de una fotografía está disponible, se puede rotar entre las distintas entidades utilizando los botones ** [Anterior] ** y ** [Siguiente] **. Los otros controles se describen en la sección ref:evis_browser de esta guía.

Conexión a base de datos

El módulo ‘Conexión a base de datos’ proporciona herramientas para conectar a y consultar una base de datos u otros recursos ODBC, tales como una hoja de cálculo.

eVis can directly connect to the following types of databases: PostgreSQL, MySQL, and SQLite; it can also read from ODBC connections (e.g., MS Access). When reading from an ODBC database (such as an Excel spreadsheet), it is necessary to configure your ODBC driver for the operating system you are using.

Iniciar el módulo de Conexión a base de datos

To launch the ‘Database Connection’ module, either click on the appropriate icon evis_connect eVis Database Connection or click on Database ‣ eVis ‣ Database Connection. This will launch the Database Connection window. The window has three tabs: Predefined Queries, Database Connection, and SQL Query. The Output Console window at the bottom of the window displays the status of actions initiated by the different sections of this module.

Conectar a una base de datos

Click on the Database Connection tab to open the database connection interface. Next, use the Database Type selectstring combo box to select the type of database that you want to connect to. If a password or username is required, that information can be entered in the Username and Password textboxes.

Introduzca el host de base de datos en el cuadro de texto :guilabel: Host de Base de Datos. Esta opción no está disponible si ha seleccionado ‘MS Access’ como el tipo de base de datos. Si la base de datos reside en su equipo, usted debe seleccionar “localhost”.

Introducir el nombre de la base de datos en la caja de texto Nombre de la base de datos. Si seleccionó ‘ODBC’ como el tipo de base de datos, es necesario introducir el nombre de la fuente de datos.

When all of the parameters are filled in, click on the [Connect] button. If the connection is successful, a message will be written in the Output Console window stating that the connection was established. If a connection was not established, you will need to check that the correct parameters were entered above.

Figure eVis 4:

../../../_images/evisdatabase.png

La ventana de conexión a base de datos eVis

  1. Tipo de base de datos: Una lista desplegable para especificar el tipo de base de datos que se utilizará.

  2. Host de la base de datos: El nombre del host de la base de datos.

  3. Puerto: El numero de puerto si una un tipo de base de datos MySQL o PostgreSQL es seleccionado.

  4. Nombre de la base de datos: EL nombre de la base de datos.

  5. Conectar: Un botón para conectar a la base de datos utilizando los parámetros definidos anteriormente.

  6. Salidas a la Consola: La ventana de consola donde los mensajes relacionados a procesos son mostrados.

  7. Nombre del Usuario: Nombre del usuario para utilizar cuando una base de datos este protegida con contraseña.

  8. Contraseña: Para usar cuando la base de datos esta protegida con contraseña.

  9. Consultas predefinidas: Pestaña para abrir la ventana “Consultas Predefinidas”.

  10. Conexión a base de datos: Pestaña para abrir la ventana “Conexión a base de datos”.

  11. Consulta SQL: Pestaña para abrir la ventana “Consulta SQL”.

  12. Ayuda: Muestra la ayuda en línea.

  13. Aceptar: Cierra la ventana principal “Conexión a Base de datos”

Ejecutar consultas SQL

SQL queries are used to extract information from a database or ODBC resource. In eVis, the output from these queries is a vector layer added to the QGIS map window. Click on the SQL Query tab to display the SQL query interface. SQL commands can be entered in this text window. A helpful tutorial on SQL commands is available at http://www.w3schools.com/sql. For example, to extract all of the data from a worksheet in an Excel file, select * from [sheet1$] where sheet1 is the name of the worksheet.

Click on the [Run Query] button to execute the command. If the query is successful, a Database File Selection window will be displayed. If the query is not successful, an error message will appear in the Output Console window.

En la ventana Selección de archivo de base de datos, introduzca el nombre de la capa que será creada de los resultados de la consulta en la caja de texto Nombre de la nueva capa

Figure eVis 5:

../../../_images/evissql_query.png

La pestaña Consulta SQL de eVis

  1. Ventana de texto de consulta SQL: Una pantalla para consultas tipo SQL.

  2. Ejecutar consulta: El botón para ejecutar la consulta introducida en la Consulta SQL.

  3. Consola de salida: La consola de salida donde se muestran los mensajes relacionados con el procesamiento.

  4. Ayuda: Muestra la ayuda en línea.

  5. Aceptar: Cierra la ventana principal Conexión a base de datos.

Use the X Coordinate selectstring and Y Coordinate selectstring combo boxes to select the fields from the database that stores the X (or longitude) and Y (or latitude) coordinates. Clicking on the [OK] button causes the vector layer created from the SQL query to be displayed in the QGIS map window.

Para guardar este archivo vectorial para usarlo en el futuro, se puede utilizar el comando de QGIS ‘Guardar como...’ que se accede al hacer clic derecho sobre el nombre de la capa en la leyenda del mapa de QGIS y después seleccione ‘Guardar como...’

Truco

Crear una capa vectorial de una Hoja de cálculo de Microsoft Excel

When creating a vector layer from a Microsoft Excel Worksheet, you might see that unwanted zeros (“0”) have been inserted in the attribute table rows beneath valid data. This can be caused by deleting the values for these cells in Excel using the Backspace key. To correct this problem, you need to open the Excel file (you’ll need to close QGIS if you are connected to the file, to allow you to edit the file) and then use Edit ‣ Delete to remove the blank rows from the file. To avoid this problem, you can simply delete several rows in the Excel Worksheet using Edit ‣ Delete before saving the file.

Ejecutar consultas predefinidas

Con las consultas predefinidas, se pueden seleccionar consultas escritas previamente almacenadas en un archivo de formato XML. Esto es particularmente útil, si no esta familiarizado con comandos SQL. Haga clic en la pestaña Consultas predefinidas para visualizar la interfaz de consultas predefinidas.

To load a set of predefined queries, click on the evis_file Open File icon. This opens the Open File window, which is used to locate the file containing the SQL queries. When the queries are loaded, their titles as defined in the XML file will appear in the drop-down menu located just below the evis_file Open File icon. The full description of the query is displayed in the text window under the drop-down menu.

Seleccione la consulta que desee ejecutar del menú desplegable y después haga clic en la pestaña Consulta SQL para ver las consultas que se han estado cargando en la ventana de consultas. Si es la primera vez puede ejecutar una consulta predefinida o esta cambiando a base de datos, necesita estar seguro para conectarse a la base de datos.

Click on the [Run Query] button in the SQL Query tab to execute the command. If the query is successful, a Database File Selection window will be displayed. If the query is not successful, an error message will appear in the Output Console window.

Figure eVis 6:

../../../_images/evispredefined.png

La pestaña de eVis Consultas predefinidas

  1. Abrir Archivo: Iniciar el archivo “Abrir Archivo” navegar para buscar el archivo XML manteniendo las consultas predefinidas.

  2. Consultas predefinidas: Una lista desplegable con todas las consultas definidas por el archivo XML de consultas predefinidas.

  3. Descripción de consulta: Una descripción corta de la consulta. Esta descripción es del archivo XML de consultas predefinidas.

  4. Consola de salida: La consola de salida donde se muestran los mensajes relacionados con el procesamiento.

  5. Ayuda: Muestra la ayuda en línea.

  6. Aceptar: Cierra la ventana principal “Conexión a Base de datos”

El formato XML para consultas predefinidas eVis

Las etiquetas XML leídas por eVis

Etiquetas

Descripción

Consulta

Definir el inicio y fin de una sentencia de consulta.

Descripción corta

Una descripción corta de la consulta que aparece en el menú desplegable de eVis.

Descripción

Una descripción más detallada de la consulta desplegada en la ventana de texto de consulta predefinida.

Tipo de base de datos

El tipo de la base de datos, definido en el menú desplegable de Tipo de base de datos en la pestaña de Conexión a base de datos.

Puerto

El puerto como se define en el cuadro de texto Puerto en la pestaña de Conexión a base de datos.

Nombre de la base de datos

El nombre de la base de datos como se define en el cuadro de texto en la pestaña de Conexión a base de datos.

Nombre de usuario

El nombre de usuario de la base de datos como se define en el cuadro de texto Nombre de usuario en la pestaña de Conexión a base de datos.

databasepassword

La contraseña de la base de datos como se define en el cuadro de texto Contraseña en la pestaña Conexión a base de datos.

Sentencia sql

El comando SQL

autoconectar

Una bandera (“verdadero” o “falso”) para especificar si las etiquetas anteriores deben utilizarse para conectarse automáticamente a la base de datos sin ejecutar la rutina de conexión de base de datos en la solapa Conexión de Base de Datos.

Se muestra un archivo XML de ejemplo completo con tres preguntas a continuación:

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>