Outdated version of the documentation. Find the latest one here.

.

eVis Plugin

(Dieses Kapitel ist von Horning, N., K. Koy, P. Ersts. 2009. eVis (v1.1.0) User’s Guide abgeleitet. American Museum of Natural History, Center for Biodiversity and Conservation. Erhältlich unter http://biodiversityinformatics.amnh.org/, and released under the GNU FDL.)

Der Biodiversitäts-Informatik Fachbereich am American Museum of Natural History’s (AMNH) Center for Biodiversity and Conservation (CBC) hat das Event Viualization Tool (eVis) entwickelt, ein weiteres Softwaretool das der Reihe der Konservationsmonitoring- und Entscheidungstools für das Managen von Schutzgebieten und Landschaftsplanung hinzugefügt werden kann. Mit diesem Plugin kann der Benutzer auf einfache Weise georeferenzierte (z.B. mit Länge und Breite oder mit X und Y Koordinaten) Fotos und andere unterstützende Dokumente mit Vektordaten in QGIS verlinken.

Das eVis Plugin wird jetzt automatisch in neuen Versionen von QGIS installiert und aktiviert und wie bei allen Plugins kann es mit dem Erweiterungsmanager deaktiviert und aktiviert werden (siehe Abschnitt The Plugins Menus).

Es besteht aus drei Modulen: der eVis-Datenbankverbindung, dem eVis-Ereignis-ID-Werkzeug und dem eVis-Ereignisbrowser. Diese Werkzeuge arbeiten zusammen, damit das Darstellen von georeferenzierten Fotos und anderen Dokumenten, die mit Vektorobjekten, Datenbanken oder Tabellen verlinkt sind, funktioniert.

Ereignisbrowser

Der Ereignisbrowser verfügt über Funktionen, um georeferenzierte Fotos anzuzeigen, die mit Vektorobjekten verknüpft sind, die im Kartenfenster dargestellt sind. Die Punktdaten können dabei z.B. ein in QGIS geladener Vektorlayer oder das Ergebnis einer Datenbankabfrage sein. Das Vektorobjekt muss Attribute mit Informationen zu dem Ort und dem Namen der darzustellenden Datei mit dem Foto enthalten und gegebenenfalls auch die Himmelsrichtung, in welche die Kamera gerichtet war, als das Bild geschossen wurde. Der Vektorlayer muss bereits in QGIS geladen sein, bevor Sie den Ereignisbrowser starten können.

Den eVis-Ereignisbrowser starten

Um den Ereignisbrowser zu starten, klicken Sie entweder auf das event_browser eVis Event Browser Icon oder auf Datenbank ‣ eVis ‣ eVis Ereignisbrowser. Dies öffnet den Ereignisbrowser Dialog.

Der Ereignisbrowser-Dialog besteht aus drei Reitern am oberen linken Rand. Der Reiter Anzeigen wird verwendet, um das Foto anzuzeigen und das damit verbundene Datenattribut. Der Reiter Optionen enthält eine Reihe von Einstellungen, die angepasst werden, um das Verhalten des Plugins zu verändern. Schließlich gibt es noch den Reiter Externe Anwendungen konfigurieren, um eine Tabelle mit Dateierweiterungen und damit verbundenen Anwendungen zu managen, um andere Dokumente als Bilder anzeigen zu können.

Der Anzeigen-Reiter

Um das Anzeigen Fenster zu sehen, klicken Sie auf den Anzeigen Reiter im Dialog Ereignisbrowser. Der Reiter Anzeigen des Ereignisbrowsers wird verwendet, um georeferenzierte Fotos und damit verknüpfte Attribute anzuzeigen.

Figure eVis 1:

../../../_images/evisdisplay.png

Das eVis Anzeigen Fenster

  1. Anzeigefenster: Ein Fenster, in dem das Foto erscheint.

  2. Hineinzoomen: Zoomen, um Details zu sehen. Wenn das gesamte Bild nicht im Anzeigefenster dargestellt werden kann, erscheinen Scrollbars auf der linken und unteren Seite des Fensters, um das Foto verschieben zu können.

  3. Herauszoomen: Aus dem Bild herauszoomen, um einen Überblick zu haben.

  4. Zur vollen Ausdehnung zoomen: Zeigt die volle Ausdehnung des Fotos an.

  5. Attributfenster: Alle Attribute des Vektorpunktes, der mit dem Foto verlinkt ist werden hier angezeigt. Wenn der Datentyp, auf den verwiesen wird kein Foto ist, sondern ein anderer Datentyp, der im Reiter Externe Applikationen konfigurieren definiert ist, dann öffnet sich die Anwendung mit dem speziellen Datentyp, indem Sie auf das Feld mit dem Pfad doppelkicken. Die Anwendung wird dann gestartet und Sie können den Inhalt anschauen oder anhören. Wenn die Datenendung erkannt wird, wird sie automatisch in grün angezeigt.

  6. Navigation: Verwenden Sie den ‘Vorheriges’ und ‘Nächstes’ Knopf, um weitere Objekte zu laden, falls vorhanden und selektiert.

Der Optionen-Reiter

Figure eVis 2:

../../../_images/evisoptions.png

Das eVis Optionen Fenster

  1. Dateipfad: Eine Dropdown-Liste, um das Attributfeld zu definieren, welches den Verzeichnispfad oder die URL für die Fotos oder anderen Dokumente enthält. Wenn es ein relativer Pfad ist, dann wählen Sie das Kontrollkästchen checkbox Pfad ist relaitiv, links neben dem Dropdown-Menü. Der Grundpfad für den relativen Pfad kann in dem Grundpfad eingegeben werden. Informationen über die verschiedenen Optionen zur Angabe des Speicherortes der Datei werden weiter unten im Abschnitt Den Ort und Namen eines Fotos festlegen beschrieben.

  2. Kompassrichtung: Eine Dropdownliste um das Attributfeld anzugeben, das die Kompassrichtung des angezeigten Fotos enthält. Wenn Kompassversatzinformationen zur Verfügung stehen, ist es erforderlich das Kontrollkästchen unter dem Dropdownmenütitel zu klicken.

  3. Kompassversatz: Kompassversätze können dazu benutzt werden Deklinationen zu kompensieren (um Versätze, die unter Anwendung von Magnetlagern gesamelt wurden, zu geographisch Nord anzupassen). Klicken Sie den radiobuttonon Manuell Radiobutton um den Versatz in das Textfenster einzugeben oder klicken Sie den radiobuttonon Aus Attribut Radiobutton um das Attributfeld, das die Versätze enthält, auszuwählen. Für beide dieser Optionen sollten Ostdeklinationen mit positiven Werten und Westdeklinationen mit negativen Werten eingegeben werden.

  4. Relativer Pfad: Der Grundpfad, auf den sich die relativen Pfade der Fotos und Dokumente beziehen wie in Abbildung Figure_eVis_2 (A) und wird angehängt.

  5. Gesamten Pfad ersetzen: Wenn dieses Kontrollkästchen aktiviert ist, wird nur der Dateiname an den Grundpfad angehängt, der als Attributspalte im Bereich Dateipfad definiert wurde.

  6. Bildpfad auf alle Dokumente anwenden: Wenn dieses Kontrollkästchen aktiviert ist, wird derselbe Grundpfad, der für Fotos verwendet wird, auch auf alle anderen Dokumente wie Filme, Texte, usw. verwendet. Ansonsten werden die definierten Pfadangaben nur für die Fotos verwendet. Alle anderen Dokumente ignorieren den Grundpfad.

  7. Dies merken: Wenn dieses Kontrollkästchen aktiviert ist, werden alle damit in Verbindung stehenden Parameter für die nächste Sitzung gespeichert. Sie können dazu auch global den Knopf [Speichern] drücken.

  8. Zurücksetzen: Setzt die Werte der jeweiligen Zeile auf die Standardwerte zurück.

  9. Voreinstellungen. This setzt alle Felder auf ihre voreingestellten Einstellungen. Es hat den gleichen Effekt wie das Klicken auf die [Zurücksetzen] Knöpfe.

  10. Speichern: Dieser Knopf speichert alle Einstellungen, ohne den Dialog zu schließen.

Der Externe Applikationen konfigurieren Reiter

Figure eVis 3:

../../../_images/evisexternal.png

Das eVis Externe Anwendungen konfigurieren Fenster

  1. Datei Referenztabelle: Eine Tabelle mit den Datentypen, die mit eVis geöffnet werden können. Jeder Datentyp benötigt eine Dateiendung, und den Pfad zu einer Anwendung, die den entsprechenden Datentyp anzeigen oder ausführen kann. Dies schließt neben Fotos u.a. auch Textdokumente, Filme oder Hörspiele mit ein.

  2. Neuen Dateityp hinzufügen: Füge einen neuen Dateityp mit einer einzigartigen Dateiendung hinzu, sowie einen Pfad zu der Applikation, mit der dieser Datentyp geöffnet werden kann.

  3. Aktuelle Zeile löschen: Löschen Sie den ausgewählten Dateityp aus der Referenztabelle.

Den Ort und Namen eines Fotos festlegen

Der Ort und Name eines Fotos kann über einen absoluten oder relativen Pfad festgelegt werden. Wenn das Foto auf einem Webserver liegt, kann auch eine URL verwendet werden. Beispiele für die verschiedenen Varianten finden Sie in Tabelle evis_examples.

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  http://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:http://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

Den Ort und Namen anderer Dokumente und Dateien festlegen

Belege wie Text-Dokumente, Videos und Sound-Clips können ebenfalls angezeigt oder abgespielt werden. Dazu ist es notwendig, einen Eintrag in der Referenztabelle zu erstellen, über den die Quelle dann geöffnet werden kann. Außerdem ist es notwendig, den Pfad oder eine URL in die Attributtabelle des Vektorlayers für das entsprechende Objekt einzutragen. Eine weitere Regel, die für URLs verwendet werden kann, die keine Dateiendung für das Dokument enthalten, das Sie öffnen möchten, besteht darin, die Dateierweiterung vor der URL anzugeben. Das Format ist dann — Dateiendung:URL. Vor die URL wird die Dateiendung mit einem Doppelpunkt geschrieben. Dies ist besonders nützlich für den Zugriff auf Dokumente in Wikis und anderen Webseiten, die eine Datenbank verwenden, um die Webseiten zu verwalten (siehe Tabelle evis_examples).

Den eVis-Ereignisbrowser anwenden

Wenn Sie den Ereignisbrowser starten, öffnet sich ein Foto und wird im Display angezeigt, wenn in der Attributtabelle auf das entsprechende Foto verwiesen wird, und wenn der Speicherort der Datei im Reiter Optionen richtig eingestellt ist. Wenn Sie ein Foto erwarten, es aber nicht angezeigt wird, kontrollieren Sie die Parameter nochmals im Optionen Fenster.

Wenn auf ein Dokument (oder ein Bild, das nicht über eine eVis bekannte Dateierweiterung verfügt) in der Attributtabelle verwiesen wird, wird das Feld mit dem Dateipfad grün hervorgehoben dargestellt, wenn die Dateierweiterung sich in der definierten Referenztabelle im Reiter Externe Applikationen konfigurieren befindet. Um das Dokument zu öffnen, doppelklicken Sie auf die grün markierte Zeile im Attribut Informationsfenster. Wenn auf ein Objekt in der Attributtabelle verwiesen wird und der Dateipfad nicht grün markiert ist, dann müssen Sie einen Eintrag für die Dateierweiterung entsprechend ergänzen. Wenn der Dateipfad grün markiert ist, sich aber nicht bei einem Doppelklick öffnet, müssen Sie die Parameter im Reiter Optionen einstellen, damit die Datei von eVis gefunden und dargestellt werden kann.

Wenn keine Kompassrichtung vorhanden ist, wird im Reiter Optionen ein rotes Sternchen angezeigt, sofern das Vektorobjekt, das mit dem Foto verlinkt ist, angezeigt wird. Wenn eine Kompassrichtung vorhanden ist, erscheint ein Pfeil und weist in die Richtung, die durch die der Wert in der Anzeige Kompassrichtung definiert ist. Der Pfeil wird über dem Vektorpunkt, der mit dem Foto oder einem anderen Dokument verknüpft ist, zentriert dargestellt.

Um den Ereignisbrowser zu schließen, klicken Sie auf den Knopf [Schließen] im Dialogfenster.

Ereignis-ID-Werkzeug

Das ‘Ereignis-ID-Werkzeug’ ermöglicht es Ihnen, ein Foto oder Dokument anzuzeigen, indem Sie auf ein Objekt eines aktivierten Vektorlayers im QGIS Kartenfenster klicken. Das Vektorobjekt muss auf Attribute verweisen, welche Informationen zum Pfad und Namen der Datei und gegebenenfalls der Kompassrichtung während der Aufnahme mit einer Kamera enthalten. Der Vektorlayer muss vor der Ausführung des ‘Ereignis-ID-Werkzeugs’ in QGIS geladen worden sein.

Starten des Ereignis-ID-Werkzeugs

Um das ‘Ereignis-ID’ Modul zu öffnen klicken Sie entweder auf das event_id eVis-Ereignis-ID Icon oder Datenbank ‣ eVis ‣ eVis-Ereignis-ID-Werkzeug. Dies bewirkt, dass der Cursor in einen Pfeil mit einem ‘i’ am oberen Ende wechselt, was bedeutet, dass das ID Werkzeug aktiv ist.

Um die mit den Vektorobjekten verlinkten Fotos in dem aktiven Vektorlayer anzuzeigen, bewegen Sie den Ereignis-ID Mauszeiger über das Objekt und klicken dann auf die linke Maustaste. Nach einem Klick auf das Objekt, wird der Ereignisbrowser geöffnet und die Fotos auf oder in der Nähe des angeklickten Ortes werden angezeigt. Wenn mehr als ein Foto zur Verfügung steht, können Sie durch die verschiedenen Objekte wandeln, indem Sie auf die Schaltflächen [Vorheriges] und [Nächstes] drücken. Die anderen Steuerelemente sind in Kapitel Ereignisbrowser beschrieben.

Datenbankverbindung

Der Dialog Datenbankverbindung ermöglicht es, sich mit einer Datenbank oder anderen ODBC Quelle, z.B. Excel-Tabellen zu verbinden.

eVis kann sich direkt mit den folgenden Typen von Datenbanken verbinden: PostgreSQL, MySQL und SQLite; es kann auch ODBC-Verbindungen auslesen (z.B. MS Access). Wenn Sie eine ODBC Datenbank auslesen (wie eine Excel Tabellenblatt) ist es erforderlich Ihren ODBC-Treiber für das Betriebssystem, das Sie verwenden, zu konfigurieren.

Starten des Dialogs Datenbankverbindung

Um das ‘Datenbankverbindung’ Modul zu starten klicken Sie auf das entsprechende Icon evis_connect eVis Datenbankverbindung oder klicken Sie auf Datenbank ‣ eVis ‣ eVis-Datenbankverbindung. Dies öffnet das Datenbankverbindung Fenster. Das Fenster hat drei Reiter: Vordefinierte Abfragen, Datenbankverbindung und SQL-Abfrage. Das Ausgabekonsole Fenster im unteren Teil des Fensters stellt den Status der Aktionen, die von verschiedenen Abschnitten dieses Moduls initiiert wurden, dar.

Verbinden mit einer Datenbank

Drücken Sie auf den Reiter Datenbankverbindung und definieren Sie dann im Dropdown-Menü den Datenbanktyp, mit dem Sie sich verbinden wollen. Wenn ein Passwort oder Benutzername erforderlich ist, können diese Informationen in den Feldern Benutzername und Passwort eingegeben werden.

Geben Sie den Datenbank-Host in das Datenbank-Host Textfenster ein. Diese Option steht nicht zur Verfügung wenn Sie ‘MS Access’ als Datenbanktyp ausgewählt haben. Wenn die Datenbank auf Ihrem Desktop vorgehalten wird sollten Sie ‘’localhost’’ eingeben.

Geben Sie den Namen der Datenbank in das Datenbankname Textfeld ein. Wenn Sie ‘ODBC’ als Datenbanktyp eingegeben haben, müssen Sie den Datenquellenname eingeben.

Nachdem Sie alle Parameter angegeben haben, klicken Sie auf den [Verbinden] Knopf. Wenn die Verbindung erfolgreich ist, wird dies in der Ausgabekonsole angezeigt. Im anderen Fall müssen Sie die Parameter nochmal überprüfen, die Sie eingegeben haben.

Figure eVis 4:

../../../_images/evisdatabase.png

Das eVis Datenbankverbindung Fenster

  1. Datenbanktyp: Eine Dropdown-Liste, um den zu verwendenen Datenbanktyp festzulegen.

  2. Datenbank-Host: Der Name des Datenbank-Hosts.

  3. Port: Die Portnummer, wenn MYSQL oder PostgreSQL benutzt wird.

  4. Datenbankname: Der Name der Datenbank.

  5. Verbinden: Ein Knopf, um sich mit der Datenbank, die die oben definierten Parameter verwendet, zu verbinden.

  6. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  7. Benutzername: Benutzername, um sich mit einer passwortgeschützten Datenbank zu verbinden.

  8. Passwort: Passwort, wenn die Datenbank passwortgeschützt ist.

  9. Vordefinierte Abfragen: Reiter, um den Dialog ‘Vordefinierte Abfragen’ zu öffnen.

  10. Datenbankverbindung: Reiter, um den Dialog ‘Datenbankverbindung’ zu öffnen.

  11. SQL-Abfrage: Reiter, um den Dialog ‘SQL-Abfrage’ zu öffnen.

  12. Hilfe: Zeigt die Online-Hilfe an.

  13. OK: Schließt das Fenster ‘Datenbankverbindung’.

SQL-Abfrage durchführen

SQL-Abfragen werden verwendet, um Informationen aus einer Datenbank oder ODBC-Ressource zu extrahieren. In eVis wird die Abfrage als Vektorlayer zum QGIS Kartenfenster hinzugefügt. Klicken Sie auf den Reiter SQL-Abfrage, um die SQL-Abfrage-Schnittstelle zu öffnen. Sie können dann SQL-Kommandos in dem Textfenster eingeben. Ein hilfreiches Tutorial über SQL-Befehle finden Sie unter der http://www.w3schools.com/sql. Um z.B. einen Auszug aller Daten aus einer Excel-Datei zu erstellen, können Sie eingeben select * from [Blatt1\$] wobei ‘Blatt1’ der Name des Arbeitsblattes ist.

Klicken Sie dann auf die Knopf [Abfrage ausführen], um den Befehl auszuführen. Wenn die Abfrage erfolgreich ist, wird ein Auswahlfenster angezeigt. Wenn die Abfrage nicht erfolgreich ist, erscheint eine Fehlermeldung in der Ausgabekonsole.

Im Datenbank Dateiauswahl Fenster geben Sie den Namen des Layers an, der aus dem Ergebnis der Abfrage erstellt werden soll.

Figure eVis 5:

../../../_images/evissql_query.png

Der eVis SQL-Abfrage Reiter

  1. SQL-Abfrage: Ein Fenster zur Eingabe von SQL-Abfragen.

  2. Abfrage ausführen: Knopf, um die SQL-Abfrage auszuführen.

  3. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  4. Hilfe: Zeigt die Online-Hilfe an.

  5. OK: Schließt das Fenster Datenbankverbindung.

Verwenden Sie die Dropdown-Menüs X Koordinate selectstring und Y Koordinate selectstring, um die Spalten der Datenbank zu selektieren, in denen die X (oder Longitude) and Y (oder Latitude) Koordinaten abgelegt sind. Wenn Sie nun auf den [OK] Knopf drücken, wird ein Vektorlayer entsprechend der SQL-Abfrage erstellt und als neuer Layer in QGIS angezeigt.

Sie können den Layer als Shapefile speichern, wenn Sie mit dem Mauspfeil auf den Layernamen in der Legende zeigen und dann auf die rechte Maustaste klicken. Dort erscheint dann die Option ‘Speichern als...’

Tipp

Einen Vektorlayer von einem Microsoft Excel Arbeitsblatt erstellen

Beim Erstellen eines Vektorlayers aus einem Microsoft Excel-Arbeitsblattes entdecken Sie vielleicht, dass unerwünschte Nullwerte (“0’‘) gemeinsam mit gültigen Daten in den Tabellenzeilen vorhanden sind. Dies kann verursacht werden, wenn Sie die Felder in Excel mit der Rücktaste Taste gelöscht haben. Um dieses Problem zu beheben, müssen Sie die Excel-Datei öffnen. (Sie müssen dazu QGIS und die Verbindung zur Excel-Tabelle zuerst beenden.) Dann können Sie die Datei in Excel bearbeiten und die leeren Zeilen über das Bearbeiten ‣ Löschen entfernen und dann wieder abspeichern. Um dieses Problem zu verhindern können Sie einfach mehrere Zeilen in der Exceltabelle löschen indem Sie Bearbeiten ‣ Löschen vor dem Speichern der Datei verwenden.

Vordefinierte Abfragen starten

Über den Reiter Vordefinierte Abfragen können Sie zuvor schriftlich erstellte SQL-Abfragen, die als Datei im XML-Format gespeichert werden, wieder aufrufen. Dies ist besonders hilfreich, wenn Sie nicht vertraut mit SQL-Befehlen sind. Klicken Sie auf den Reiter Vordefinierte Abfragen, um die vordefinierte Abfrage-Schnittstelle zu öffnen.

Um eine Reihe von vordefinierten Abfragen zu laden, klicken Sie auf das evis_file Datei öffnen Icon. Dies öffnet das Datei öffnen Fenster, das dazu verwendet wird die Datei mit den SQL-Abfragen ausfindig zu machen. Wenn die Abfragen geladen sind, erscheinen ihre Titel wie in der XML-Datei definiert im Dropdownmenü gerade unter dem evis_file Datei öffnen Icon. Die ausführliche Beschreibung der Abfrage wird im Textfenster unter dem Dopdownmenü dargestellt.

Wählen Sie die Abfrage, die Sie aus dem Dropdownmenü ausführen wollen und klicken Sie dann auf den SQL-Abfrage Reiter um zu sehen, dass die Abfrage in das Abfragefenster geladen worden ist. Wenn Sie das erste Mal eine vordefinierte Abfrage ausführen oder die Datenbank wechseln müssen Sie sich vergewissern, dass Sie mit der Datenbank verbunden sind.

Klicken Sie auf den Knopf [Abfrage ausführen] im Reiter SQL-Abfrage. Wenn die Abfrage erfolgreich ist, wird ein Auswahlfenster angezeigt. Wenn die Abfrage nicht erfolgreich ist, erscheint eine Fehlermeldung in der Ausgabekonsole.

Figure eVis 6:

../../../_images/evispredefined.png

Der eVis Vordefinierte Abfragen Reiter

  1. Datei öffnen: Öffnet den ‘’Datei öffnen’’ Dateibrowser um nach der XML-Datei, die die vordefinierten Abfragen vorhält, zu suchen.

  2. Vordefinierte Abfragen: Eine Dropdown-Liste mit allen Abfragen der bereits erstellten XML-Datei.

  3. Abfragebeschreibung: Eine Beschreibung der Abfrage. Diese Beschreibung ist in der XML-Datei enthalten.

  4. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  5. Hilfe: Zeigt die Online-Hilfe an.

  6. OK: Schließt das Fenster ‘Datenbankverbindung’.

XML-Format für vordefinierte Abfragen in eVis

Die von eVis gelesenen XML-Tags

Tag

Beschreibung

query

Definiert den Anfang und das Ende einer Abfrage.

shortdescription

Eine kurze Beschreibung der Abfrage, die im eVis Dropdown-Menü erscheint.

description

Eine detailiertere Beschreibung der Abfrage, die in der eVis Abfragebeschreibung angezeigt wird.

databasetype

Der Datenbanktyp, definiert im Datenbanktyp Dropdownmenü im Datenbankverbindung Reiter.

databaseport

Der Port, wie er in der Port Textfenster im Datenbankverbindung Reiter definiert ist.

databasename

Der definierte Datenbankname aus dem Datenbankname Textfeld im Reiter Datenbankverbindung.

databaseusername

Der Datenbank Benutzername wie im Username Textfeld im Datenbankverbindung Reiter definiert.

databasepassword

Das Datenbank Passwort wie im Passwort Textfeld im Reiter Datenbankverbindung definiert.

sqlstatement

Die SQL-Abfrage.

autoconnect

Eine Option (‘’true” oder “false”), die festlegt, ob automatisch anhand der oben angegeben Tags mit der Datenbank verbunden werden soll, ohne die Routine aus dem Reiter Datenbankverbindung zu durchlaufen.

Ein Beispiel einer XML-Datei mit drei Abfragen ist unten dargestellt:

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>