Outdated version of the documentation. Find the latest one here.

eVis プラグイン

(このセクションN.、K・コイ、P・アーズツ 2009 EVIS(V1.1.0)はユーザーズガイド、米国自然史博物館、生物多様性保全センター、ホーニングから導出されます。http://biodiversityinformatics.amnh.org/から利用でき、およびGNU FDLの下でリリース。)

生物多様性保全のための自然史の(AMNH)センター(CBC)のアメリカの博物館での生物多様性情報ファシリティは、保護導くための保全モニタリングおよび意思決定支援ツールのスイートに追加する別のソフトウェア・ツールをイベントの可視化ツール(EVIS)を開発しました地域と景観計画。このプラグインは、簡単にQGISのベクトルデータ、写真、およびその他の書類(即ち、緯度及び経度又はX及びY座標と参照される)ジオコードをリンクすることができます。

eVisは今QGISの新バージョンでは自動的にインストールされ、有効になり、すべてのプラグインと同じように、それはプラグインマネージャーを使用して無効と有効にできます( プラグインダイアログ 参照)。

eVis プラグインは3つのモジュールで構成されています: ‘データベースコネクションツール’, ‘イベントIDツールl’, と ‘イベントブラウザ’ です. それらはジオコードされた写真の閲覧やベクタファイル,データベースまたはスプレッドシートに格納されたリンクで示されるドキュメントの閲覧をするために協調して動作します.

イベントブラウザ

イベントブラウザモジュールは、QGISマップウィンドウに表示ベクター地物にリンクされているジオコード写真を表示する機能を提供します。ポイントデータは、例えば、QGISを使用して入力できるベクターファイルからであってもよく、またはそれは、データベースクエリの結果であることができます。ベクター地物は、必要に応じて、画像が取得されたときにカメラが指摘されたコンパス方向写真を含むファイルの場所と名前を記述し、それに関連付けられた属性情報を有していなければなりません。ベクトルレイヤーは、イベントブラウザを実行する前に、QGISにロードする必要があります。

イベントブラウザモジュールを起動する

イベントブラウザモジュールを起動するには、 データベース - > eVis->eVisイベントBrowser をクリックします。これは 汎用イベントBrowser ウィンドウを開きます。

イベントBrowser ウィンドウはウィンドウの上部に表示された3つのタブがあります。Display ]タブには、写真とそれに関連する属性データを表示するために使用されます。 Options タブはeVisプラグインの動作を制御するために調整できる設定の数を提供します。最後に、 設定外部Applications タブはEVISが画像以外の文書を表示できるようにするファイル拡張子のテーブルとそれに関連するアプリケーションを維持するために使用されます。

ディスプレイウィンドウを理解する

Display ウィンドウを表示するには、 イベントBrowser ウィンドウで Display タブをクリックしてください。 Display ウィンドウはジオコード写真、それらに関連する属性データを表示するために使用されます。

Figure eVis 1:

../../../_images/evisdisplay.png

*eVis*表示ウィンドウ

  1. ディスプレイウィンドウ:フォトを表示する場所のウィンドウ。

  2. ズームインボタン: さらに詳細を見るためズームインを行います. ディスプレイウィンドウにイメージ全体を表示できない場合,左と下部にスクロールバーが表示されイメージをパンすることができます.

  3. ズームアウトボタン: もっと広い領域を見るためにズームアウトします.

  4. 全領域にズーム ボタン: 写真の全領域えお表示します.

  5. 情報ウィンドウ属性 :写真を見ているに関連付けられているポイントの属性情報の全てがここに表示されます。表示されているレコードで参照されているファイルの種類が画像ではなく、中に定義されているファイルタイプのものである場合 設定外部Applications タブ、へのパスを含むフィールドの値をダブルクリックしたときファイルは、ファイルを開くアプリケーションは、ファイルの内容を表示したり、聞いて起動されます。ファイルの拡張子が認識された場合、属性データは緑色で表示されます。

  6. ナビゲーションボタン: 前ボタンと次ボタンは1個以上の地物が選択されている場合前と後の地物をロードする場合に利用されます.

オプションウィンドウを理解する

Figure eVis 2:

../../../_images/evisoptions.png

*eVis*オプションウィンドウ

  1. ファイルのパス:表示されている写真または他の文書のディレクトリ・パスやURLが含まれている属性フィールドを指定するには、ドロップダウンリスト。場所は、相対パスである場合は、チェックボックスをクリックする必要があります。相対パスのベースパスは、以下の ベースPATH テキストボックスに入力できます。ファイルの場所を指定するためのさまざまなオプションに関する情報は、下記 写真の場所と名前を指定します セクションに記載されています。

  2. コンパスベアリング:写真が表示されているに関連付けられているコンパス方位が含まれている属性フィールドを指定するには、ドロップダウンリスト。コンパス方位情報が利用可能な場合、ドロップダウンメニュータイトルの下のチェックボックスをクリックする必要があります。

  3. コンパスオフセット :(真北軸受に磁気軸受を使用して収集したベアリングを調整するために)コンパスのオフセットが偏角を補償するために使用できます。 radioButtonOn Manual ラジオボタンをクリックして、テキストボックスにオフセットを入力するか、または radioButtonOn 属性から をクリックしてラジオボタンのオフセットを含む属性フィールドを選択します。これらのオプションの両方のために、東の偏角は正の値を使用して入力する必要があり、西偏角は負の値を使用する必要があります。

  4. ディレクトリベースパス:Figure_eVis_2_(A)で定義された相対パスが付加され、その上にベースパス。

  5. パスを置換 :このチェックボックスがチェックされている場合、Aからファイル名のみがベースパスに追加されます。

  6. すべての文書に規則を適用 :チェックすると、写真のために定義されている同じパスの規則が、映画、テキスト文書、およびサウンドファイルなどの非画像文書に使用されます。チェックされていない場合は、パスの規則は写真のみに適用され、他の文書はベースパスのパラメータを無視します。

  7. 設定を記憶する :このチェックボックスをチェックすると、ウィンドウが閉じられたとき、または下記の [保存] ボタンが押されたときに、関連するパラメータは、次のセッションのために保存されるための値。

  8. 値のリセット: この業の値をリセットし、デフォルト設定に戻します。

  9. デフォルトを復元:これはデフォルト設定にすべてのフィールドをリセットします。これは、ボタン** ** [リセット]のすべてをクリックするのと同じ効果があります。

  10. Save: この機能を使うと設定を Options ペインを閉じないで保存します.

外部アプリケーションの設定を理解する

Figure eVis 3:

../../../_images/evisexternal.png

The eVis External Applications window

  1. ファイルの参照テーブル:EVISを使用して開くことができるファイルの種類を含むテーブル。各ファイルタイプは、ファイル拡張子やファイルの種類を開くことができるアプリケーションへのパスが必要です。これは、映画、録音、およびだけではなく、画像のテキスト文書としてファイルの広い範囲を開く機能を提供します。

  2. 新しいファイルタイプの追加: 新しいファイルタイプをユニークなファイル拡張子と開くためのアプリケーションのパスと一緒に追加して下さい.

  3. 現在の行を削除:ファイルタイプがテーブルに強調表示され、ファイル拡張子と関連するアプリケーションへのパスによって定義削除。

写真の場所と名前を指定します

写真の位置と名前は、写真は、ウェブサーバ上で利用可能である場合、絶対または相対パス、またはURLを使用して格納することができます。異なるアプローチの例は、表 `evis_examples`_に記載されています。

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  http://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:http://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

他の書類の場所と名前を指定します

そのようなテキスト文書、ビデオ、サウンドクリップなどの書類も表示またはEVISで再生できます。これを行うには、からアクセスできるファイル参照テーブルにエントリを追加する必要がある 設定外部Applications ウィンドウで 汎用イベントBrowser そのアプリケーションにファイル拡張子に一致しますファイルを開くために使用できます。ベクターレイヤの属性テーブル内のファイルへのパスまたはURLを持つことも必要です。開きたい文書のファイル拡張子を含まないURLのために使用できる1つの追加的なルールは、URLの前に、ファイルの拡張子を指定することです。形式は、ファイルの拡張子 `` —です:URL``。URLは、ファイル拡張子とコロンが先行しています。これはウィキやWebページを管理するためのデータベースを使用する他のウェブサイトからの文書にアクセスするために特に有用である(表 evis_examples を参照)。

イベントブラウザの利用

イベントBrowser ウィンドウが開くとき、 Options ウィンドウが適切であるファイルの位置情報があれば、写真はベクトルファイル属性テーブルで参照されるドキュメントが画像であれば表示ウィンドウに表示されますセット。 Options 窓写真が予想され、それが表示されない場合は、内のパラメータを調整する必要があります。

支持文書(またはEVISによって認識されるファイル拡張子を持っていない画像)属性テーブルで参照されている場合は、そのファイルの拡張子が定義されている場合、ファイルパスを含むフィールドは、属性情報ウィンドウに緑色で強調表示されます 設定外部Applications ウィンドウにあるファイルの参照テーブル。文書を開くには、属性情報ウィンドウで緑強調表示された行をダブルクリックします。 設定外部Applications ウィンドウサポート文書は属性情報ウィンドウとファイルパスで参照されている場合は緑色で強調表示されていない、ファイルのファイル名の拡張子のエントリを追加する必要があります。ファイルパスは緑色で強調表示されているが、ダブルクリック時に開かない場合は、ファイルはeVisで配置できるように Options ウィンドウ内のパラメータを調整する必要があります。

コンパスベアリングが Options ウィンドウ内に設けられていない場合、 、赤いアスタリスクは、写真が表示されて関連付けられているベクター地物の上部に表示されます。 イベントBrowser ウィンドウコンパスベアリングが設けられている場合、矢印は、でコンパス方位表示フィールドの値によって示される方向に向い現れます。矢印は、写真や他のドキュメントに関連付けられたポイント上にセンタリングされます。

Display ウィンドウを閉じるには、 イベントBrowser ウィドウから [閉じる] ボタンをクリックします。

イベントIDツール

「イベントID」モジュールを使用すると、QGISマップウィンドウに表示機能をクリックして、写真を表示することができます。ベクターの特徴は、必要に応じて、画像が取得されたときにカメラが指摘されたコンパス方向写真を含むファイルの場所と名前を記述し、それに関連付けられた属性情報を有していなければなりません。この層は、「イベントID」ツールを実行する前に、QGISにロードする必要があります。

イベントIDモジュールを実行する

「イベントID」モジュールを起動するには、 eventId イベントID アイコンクリック、または データベース->eVis->イベントIDツール をクリックしてください。これは、カーソルがIDツールがアクティブであることを意味する、その上に「i」との矢印に変化します。

QGISマップウィンドウに表示されるアクティブなベクターレイヤーにベクター地物にリンクされている写真を表示するには、地物上にイベントIDカーソルを移動し、マウスをクリックしてください。地物をクリックした後、 イベントBrowser ウィンドウが開かれ、クリックされた地域にまたはそれに近い写真は、ブラウザでの表示が可能です。複数の写真が利用可能である場合は、別の地物を循環使用できます [前へ][次へ] ボタン。他のコントロールは、このガイドの イベントブラウザ セクションに記載されています。

データベース接続

「データベース接続」モジュールは、スプレッドシートなどに接続し、データベースまたは他のODBCリソースを照会するためのツールを提供します。

EVISは、直接データベースの次のタイプに接続できます。PostgreSQLのは、MySQL、SQLiteの。それはまた、ODBC接続(例えば、MSアクセス)から読み取ることができます。(例えばExcelスプレッドシートなど)ODBCデータベースから読み込む場合、あなたが使用しているオペレーティングシステム用のODBCドライバを設定する必要があります。

データベース接続モジュールを実行する

「データベース接続」モジュールを起動し、いずれかの適切なアイコンをクリックしてください evisConnect EVISデータベースConnection またはオンクリック データベース - > EVIS - >データベースConnection。guilabel: データベースConnection`ウィンドウこれが起動します。 :guilabel:`定義済みのQueriesデータベースConnection 、と SQL Query ウィンドウには、3つのタブがあります。ウィンドウの下部にある 出力Console ウィンドウには、このモジュールの異なるセクションによって開始されたアクションのステータスが表示されます。

データベースとの接続

データベース接続インターフェースを開くために、 データベースConnection タブをクリックします。次に、 データベースtype selectString コンボボックスを使用して、接続するデータベースの種類を選択します。パスワードまたはユーザ名が必要な場合は、その情報が UsernamePassword テキストボックスで入力できます。

データベースHost テキストボックスに、データベースのホストを入力します。データベース・タイプとして「MSアクセス」を選択した場合、このオプションは使用できません。データベースは、デスクトップ上に存在する場合は、「ローカルホスト」を入力してください。

データベース名 テキストボックスにデータベースの名前を入力します。データベース・タイプとして「ODBC」を選択した場合は、データソース名を入力する必要があります。

すべてのパラメータが記入されている場合は、 [接続] ボタンをクリックします。接続に成功すると、メッセージはに書き込まれます 接続が確立されたことを示す出力Console ウィンドウ。接続が確立されていなかった場合は、正しいパラメータが上記の入力されたことを確認する必要があります。

Figure eVis 4:

../../../_images/evisdatabase.png

eVis データベースコネクションウィンドウ

  1. データベースタイプ: 使用するデータベースの種類を特定するためのドロップダウンリスト

  2. データベースホスト: データベースホストの名称

  3. ポート: MySQL または PostgreSQLデータベースのタイプを選択した場合のポート番号

  4. データベース名称: データベースの名称

  5. 接続:上で定義したパラメータを使ってデータベースに接続するボタン

  6. 出力コンソール:処理に関連するメッセージが表示されたコンソールウィンドウ

  7. ユーザ名:データベースがパスワードで保護されている場合使用するユーザ名

  8. パスワード:データベースがパスワードで保護されている場合に使用するパスワード

  9. 定義済クエリ: “定義済クエリ” ウィンドウを表示するタブ

  10. データベース接続: “データベース接続”ウィンドウを表示するタブ

  11. SQL クエリ: “SQLクエリ”ウィンドウを表示するタブ

  12. ヘルプ:オンラインヘルプを表示する

  13. OK: メインの “データベース接続”ウィンドウを閉じる

SQLクエリの実行

SQLクエリは、データベースまたはODBCリソースから情報を抽出するために使用されています。eVisでは、これらのクエリからの出力は、QGISマップウィンドウに追加ベクター層です。SQLクエリインターフェイスを表示するには、 SQL Query]タブをクリックします。SQLコマンドは、このテキストウィンドウに入力できます。SQLコマンドに役立つチュートリアルがhttp://www.w3schools.com/sqlで入手可能です。たとえば、Excelファイルのワークシートからのすべてのデータを抽出するために、 `` SELECT * FROM [Sheet1の$] `` sheet1``は、ワークシートの名前がどこにあります ``

コマンドを実行するために [クエリの実行] ボタンをクリックします。クエリが成功した場合、 データベースファイルSelection ウィンドウが表示されます。 出力Console ウィンドウクエリが成功しなかった場合、エラーメッセージが表示されます。

データベースファイルSelection ウィンドウで、 新Layerの名前 テキストボックスにクエリの結果から作成されるレイヤーの名前を入力します。

Figure eVis 5:

../../../_images/evissql_query.png

eVis SQLクエリタブ

  1. SQLクエリテキストウィンドウ: SQLクエリをタイプするためのスクリーン

  2. クエリ実行: SQL クエリウィンドウ で入力したクエリを実行するためのボタン

  3. コンソールウィンドウ:処理に関連するメッセージが表示されたコンソールウィンドウ

  4. ヘルプ:オンラインヘルプを表示する

  5. OK: メインの データベース接続 ウィンドウを閉じる

X Coordinate selectStringY Coordinate selectString コンボボックスを使用して X (または経度)と Y (または緯度)を格納する座標データベースからフィールドを選択します。 [OK] ボタンをクリックすると、SQLクエリーから作成されたベクトルレイヤーがQGIS地図ウィンドウに表示されます。

将来の使用のために、このベクトルファイルを保存するには、QGISマップの凡例にレイヤー名を右クリックしてアクセスして、選択されたコマンド「...として保存」QGISを使用できる「として保存...」

ちなみに

Microsoft Excelワークシートからベクタレイヤを作成

Microsoft Excelワークシートからのベクトルレイヤーを作成するときは、その不要なゼロ(「0」)を参照してください可能性がある有効なデータの下に属性テーブルの行に挿入されています。 Backspace キーこれは、使用してExcelでこれらのセルの値を削除することによって引き起こされる可能性があります。この問題を解決するには、Excelファイルを開く必要が使用し、その後(ファイルに接続している場合は、ファイルを編集できるようにするために、QGISを閉じる必要があります)と [編集] - > DELETE へをファイルから空白行を削除します。この問題を回避するには、ファイルを保存する前に:menuselection:編集- > DELETE を単に使用してExcelワークシートで複数の行を削除できます。

定義済クエリの実行

事前に定義されたクエリを使用すると、ファイルにXML形式で保存され、以前に書かれたクエリを選択することができます。SQLコマンドに慣れていない場合、これは特に便利です。定義済みクエリインターフェイスを表示するには、 定義済みのQueries タブをクリックします。

事前に定義されたクエリのセットをロードするには、evisFile ファイルを開く アイコンをクリックしてください。SQLクエリを含むファイルを検索するために使用されている オープンFile ウィンドウ、これが開きます。クエリがロードされると、XMLファイルで定義されたそのタイトルは、ちょうど下にあるドロップダウンメニューに表示されます evisFile オープンFile アイコン。クエリの詳細については、ドロップダウンメニューの下のテキストウィンドウに表示されます。

クエリはクエリウィンドウにロードされていることを確認するために、 SQL Query タブドロップダウンメニューから実行し、次にをクリックするクエリを選択します。それは事前に定義されたクエリを実行しているか、データベースの切り替えが初めての場合は、データベースに接続することを確認する必要があります。

コマンドを実行するには、 SQL Query タブで [クエリの実行] ボタンをクリックします。クエリが成功した場合、 データベースファイルSelection ウィンドウが表示されます。 出力Console ウィンドウクエリが成功しなかった場合、エラーメッセージが表示されます。

Figure eVis 6:

../../../_images/evispredefined.png

*eVis*定義済クエリタブ

  1. ファイルを開く :事前に定義されたクエリを保持しているXMLファイルを検索するには、「ファイルを開く」ファイルブラウザを起動します。

  2. 定義済クエリ: 定義済クエリのXMLファイルによって定義されたクエリすべてのドロップダウンリスト

  3. クエリ説明: クエリの短い説明文。この説明は定義済クエリのXMLファイルに由来します。

  4. コンソールウィンドウ:処理に関連するメッセージが表示されたコンソールウィンドウ

  5. ヘルプ:オンラインヘルプを表示する

  6. OK: メインの “データベース接続”ウィンドウを閉じる

eVis定義済クエリのXMLフォーマット

eVisで読み込まれるXMLタグ

タグ

説明

query

クエリ文の始まりと終わりを定義します。

shortdescription A short description of the query that appears in the eVis drop-down menu.
description

定義済みクエリテキストウィンドウに表示されたクエリのより詳細な説明。

databasetype

データベース接続タブのデータベースタイプドロップダウンメニューで定義されたデータベースタイプ

databaseport

データベース接続タブのポートテキストボックスで定義されたポート

databasename

データベース接続タブのデータベース名テキストボックスに定義されたデータベース名

databaseusername

データベース接続タブのユーザ名テストボックスで定義されたデータベースのユーザ名

databasepassword

データベース接続タブのパスワードテキストボックスに定義されたデータベースパスワード

sqlstatement

SQLコマンド。

autoconnect

上記のタグが自動的にデータベース接続]タブでデータベース接続ルーチンを実行せずにデータベースに接続するために使用されるべきかどうかを指定するフラグ(「真」」または 『false』)。

3つのクエリを含む XML ファイルの完全なサンプルは下に表示されています.

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>