Outdated version of the documentation. Find the latest one here.

14.3. Lesson: Numériser les massifs forestiers

À moins que vous n’utilisiez votre carte géoréférencée comme une simple image d’arrière-plan, la prochaine étape logique est de numériser des éléments de la carte. Vous l’avez déjà fait dans les exercices sur la création de données vectorielles dans Lesson: Création d’un Nouveau Jeu de Données Vectorielles, lorsque vous avez numérisé les terrains scolaires. Dans cette leçon, vous allez numériser les bordures des massifs forestiers qui sont représentés sur la carte avec des lignes vertes, mais à la place d’utiliser une image aérienne, vous utiliserez votre carte géoréférencée.

Objectif de cette leçon : Apprendre une technique d’aide à la tâche de numérisation, en numérisant des massifs forestiers et en leur ajoutant finalement les données d’inventaire.

14.3.1. basic Follow Along: Extraction des bordures des massifs forestiers

Ouvrez dans QGIS votre projet map_digitizing.qgs, que vous aviez sauvegardé dans la leçon précédente.

Une fois que vous avez scanné et géoréférencé votre carte, vous pouvez directement commencer la numérisation en regardant l’image comme un guide. Cela sera probablement la façon avec laquelle vous procéderez si l’image que vous avez numérisé est, par exemple, une photographie aérienne.

Si vous utilisez une bonne carte pour réaliser la numérisation, comme c’est notre cas, il est probable que l’information soit clairement affichée sous forme de lignes avec des couleurs différentes pour chaque type d’élément. Ces couleurs peuvent être relativement faciles à extraire sous forme d’images individuelles en utilisant un logiciel de traitement d’image comme GIMP. Ces images séparées peuvent être utilisée pour faciliter la numérisation comme vous allez pouvoir le constater plus loin.

La première étape sera d’utiliser GIMP pour obtenir une image qui ne contienne que les massifs forestiers, c’est-à-dire toutes ces lignes verdâtres que vous pouvez voir sur la carte scannée d’origine :

  • Ouvrez GIMP (si vous ne l’avez pas déjà installé, téléchargez-le depuis internet ou demandez à votre professeur).

  • Ouvrez l’image originale de la carte, Fichier ‣ Ouvrir, rautjarvi_map.tif dans le répertoire exercise_data/forestry. Notez que les massifs forestiers sont représentés par des lignes vertes (avec le numéro du massif également en vert à l’intérieur de chaque polygone).

../../../_images/gimp_map.png

Vous pouvez maintenant sélectionner les pixels dans l’image qui coïncident avec les bordures des massifs forestiers (les pixels verdâtres):

  • Ouvrez l’outil Sélection ‣ Par couleur.

  • Avec l’outil activé, zoomez sur l’image (Ctrl + molette de la souris) afin qu’une ligne de massif forestier soit suffisamment proche pour différencier les pixels formant la ligne. Voyez l’image de gauche ci-dessous.

  • Cliquez et faites glisser le curseur de la souris au milieu de la ligne afin que l’outil collecte plusieurs valeurs de couleur de pixels.

  • Relâchez le clic de la souris et attendez quelques secondes. Les pixels aux couleurs récupérées par l’outil seront sélectionnés à travers toute l’image.

  • Dézoomez pour voir comment les pixels verdâtres ont été sélectionnés sur toute l’image.

  • Si vous n’êtes pas content du résultat, répétez l’opération de cliquer et glisser la souris.

  • Votre sélection de pixels devrait ressembler à ce qu’on voit dans l’image de droite ci-dessous.

../../../_images/green_px_selected.png

Une fois que vous en avez terminé avec la sélection, vous devez copier cette sélection comme nouvelle couche et ensuite la sauvegarder séparément comme fichier image :

  • Copiez (Ctr+C) les pixels sélectionnés.

  • Et collez directement les pixels (Ctr+V), GIMP affichera les pixels collés comme une nouvelle couche temporaire dans l’onglet Couches - Remplissage en tant que Sélection flottante (Couche collée).

  • Faites un clic-droit sur la couche temporaire et sélectionnez Vers une nouvelle couche.

  • Cliquez sur l’icône “oeil” à côté de la couche de l’image d’origine pour la désactiver, afin que seule la Couche collée soit visible :

../../../_images/saving_green_px.png
  • Finalement, sélectionnez Fichier ‣ Exporter..., mettez une image TIFF à Sélectionner le type de fichier (par extension), sélectionnez le dossier digitizing et nommez-la rautjarvi_map_green.tif. Sélectionnez pas de compression lorsqu’on vous le demande.

Vous pouvez faire le même processus avec d’autres éléments de l’image, par exemple extraire les lignes noires représentant les routes, ou les brunes qui représentent les lignes de contour du terrain. Mais pour nous, les massifs forestiers sont suffisants.

14.3.2. basic Try Yourself Géoréférencer l’image de pixels verts

Comme vous l’avez fait dans la leçon précédente, vous devez géoréférencer cette nouvelle image pour pouvoir l’utiliser avec le reste de vos données.

Notez que vous n’avez pas besoin de numériser plus les points de contrôle car cette image est en fait la même image que l’image d’origine de la carte, dans la mesure où l’outil Géoréférencer est concerné. Voici quelques choses que vous devriez vous rappelez :

  • Cette image est aussi, évidemment, dans le SCR KKJ / Finland zone 2.

  • Vous devriez utiliser les points de contrôle que vous avez sauvegardé, Fichier ‣ Charger des points de contrôle (GCP).

  • Souvenez-vous de modifier les Préférences de transformation.

  • Nommez le raster de sortie rautjarvi_green_georef.tif dans le dossier digitizing.

Vérifiez que le nouveau raster se superpose parfaitement avec la carte d’origine.

14.3.3. basic Follow Along: Création de points d’appui pour la numérisation

Si vous avez en-tête les outils de numérisation de QGIS, vous pouvez penser qu’il serait utile de s’accrocher à ces pixels verts lors de la numérisation. C’est précisément ce que nous allons faire en créant des points à partir de ces pixels pour les utiliser plus tard pour nous aider à suivre les bordures des forêts lors de la numérisation en utilisant les outils d’accrochage disponible dans QGIS.

  • Utilisez l’outil Raster ‣ Conversion ‣ Polygoniser (Raster à Vecteur) pour vectoriser vos lignes vertes en polygones. Si vous ne vous souvenez plus comment faire, vous pouvez le revoir dans Lesson: Conversion Raster vers Vecteur.

  • Sauvegardez en tant que rautjarvi_green_polygon.shp dans le dossier digitizing.

Zoomez et voyez à quoi ressemblent les polygones. Vous obtiendrez quelque chose comme ça :

../../../_images/green_polygons.png

La prochaine option pour extraire les points à partir des polygones est de récupérer leur centroïde:

  • Ouvrez Vecteur ‣ Outils géométriques ‣ Centroïdes de polygones.

  • Paramétrez la couche de polygone que vous venez de récupérer comme fichier d’entrée de l’outil.

  • Nommez la sortie green_centroids.shp dans le dossier the digitizing.

  • Cochez Ajouter le résultat au canevas.

  • Lancez l’outil pour calculer les centroïdes des polygones.

../../../_images/green_points.png

Vous pouvez maintenant enlever la couche rautjarvi_green_polygon de la Légende la carte.

Changez la symbologie de la couche des centroïdes comme suit :

  • Ouvrez les Propriétés de la couche pour green_centroids.

  • Rendez-vous à l’onglet Style.

  • Configurez l’Unité avec Unité de la carte.

  • Mettez la Taille à 1.

Il n’est pas nécessaire de différencier les points les uns des autres, vous avez seulement besoin de les avoir pour que les outils d’accrochage puissent les utiliser. Vous pouvez maintenant utiliser ces points pour suivre les lignes d’origine plus facilement que sans eux.

14.3.4. basic Follow Along: Numériser les massifs forestiers

Maintenant, vous êtes prêt à lancer le travail de numérisation. Créez un fichier vecteur du type polygone mais pour cet exercice, il existe déjà un fichier Shape sur les emprises d’intérêt. Il vous reste à terminer la numérisation de la moitié des forêts qui restent entre les routes principales (lignes roses larges) et le lac:

../../../_images/forest_stands_to_digitize.png
  • Rendez-vous au dossier digitizing en utilisant votre navigateur de gestion de fichier.

  • Faites glisser et déposez le fichier vecteur forest_stands.shp dans votre carte.

Changez la symbologie de la nouvelle couche afin qu’il soit plus facile de voir quel polygone a déjà été numérisé :

  • Le remplissage du polygone en vert.

  • Les bordures des polygones à 1 mm.

  • Et mettez la transparence à 50%.

Maintenant, si vous vous souvenez des modules passés, nous devons définir et activer les options d’accrochage :

  • Rendez-vous aux Préférences ‣ Options d’accrochage....

  • Activez l’accrochage pour les couches green_centroids et forest_stands.

  • Fixez leur Tolérance à 5 unités de carte.

  • Cochez la case Éviter les intersections pour la couche forest_stands.

  • Cochez Activer l’édition topologique.

  • Cliquez sur Appliquer.

../../../_images/snapping_settings_forest.png

Avec ces paramètres d’accrochage, lorsque vous numérisez et que vous vous approcher de l’un des points de la couche de centroïdes ou d’un segment de vos polygones déjà numérisés, une croix rose apparaît sur le point sur lequel la numérisation s’accrochera.

Finalement, désactivez la visibilité de toutes les couches sauf de forest_stands et rautjarvi_georef. Assurez-vous que l’image de la carte n’a plus de transparence.

Quelques choses importantes à noter avec que vous démarriez la numérisation :

  • N’essayez pas d’être trop précis avec la numérisation des bordures.

  • Si une bordure est une ligne droite, numérisez-la avec seulement deux noeuds. En général, la numérisation utilise aussi peu de noeuds que possible.

  • Zoomez pour fermer les plages seulement si vous pensez que vous devez être précis, par exemple, à un coin ou lorsque vous voulez connecter un polygone avec un autre polygone à un certain noeud.

  • Utilisez le bouton du milieu de la souris pour zoomer/dézoomer et vous déplacer lors de la numérisation.

  • Numérisez seulement un polygone à la fois.

  • Après avoir numérisé un polygone, écrivez l’id du massif forestier que vous pouvez voir sur la carte.

Vous pouvez maintenant commencer la numérisation :

  • Localisez le massif forestier numéro 357 dans la fenêtre de la carte.

  • Activez l’édition pour la couche forest_stands.shp.

  • Sélectionner l’outil Ajouter une entité.

  • Commencez la numérisation de la place 357 en connectant certains des points.

  • Notez que les croix roses indiquent l’accrochage.

../../../_images/dgitizing_357_1.png
  • Quand vous avez terminé, faites un clic-droit pour terminer la numérisation du polygone.

  • Entrez l’id de la plage forestière (dans ce cas 357).

  • Cliquez sur OK.

Si on ne vous a pas demandé l’id du polygone lorsque vous avez terminé sa numérisation, rendez-vous aux Paramètres ‣ Options ‣ Numérisation et assurez-vous que Supprimer les avertissements de formulaire d’attribut lors de la création d’entité n’est pas coché.

Votre polygone numérisé ressemblera à cela :

../../../_images/dgitizing_357_3.png

Pour le second polygone, récupérez l’ilot 358. Assurez-vous que l’option Éviter les intersections est cochée pour la couche forest_stands. Cette option permet aux polygones numérisés de ne pas se superposer du tout. Si vous numérisez au dessus d’un polygone déjà existant, le nouveau polygone sera coupé à la bordure des polygones déjà existants. Vous pouvez utiliser cette fonctionnalité pour obtenir une bordure commune.

  • Commencez à numériser le massif 358 à un des angles communs avec le massif 357.

  • Puis continuez normalement jusqu’à ce que vous arriviez à l’autre coin commun aux deux massifs.

  • Finalement, numérisez quelques points dans le polygone 357 en s’assurant que la bordure commune n’est pas intersectée. Observez l’image de gauche ci-dessous.

  • Faites un clic-droit pour terminer la modification du massif forestier 358.

  • Entrez 358 comme id.

  • Cliquez sur OK, votre nouveau polygone devrait montrer une bordure commune avec la plage 357, comme vous pouvez le voir sur l’image de droite.

../../../_images/dgitizing_358_5.png

La partie du polygone qui chevauchait le polygone existant a été automatiquement découpée et vous avez obtenu une bordure commune, comme on pouvait s’y attendre.

14.3.5. basic Try Yourself Finir la numérisation des massifs forestiers

Vous avez maintenant deux plages de forêts prêtes. Et une bonne idée de comment procéder. Continuez à numériser de vous-même jusqu’à ce que vous ayez numérisé toutes les plages de forêt qui sont limitées par la route principale et le lac.

Cela peut sembler être beaucoup de travail, mais vous serez bientôt habitué à la numérisation des massifs forestiers. Cela devrait vous prendre environ 15 minutes.

Lors de la numérisation, vous pourriez avoir besoin de modifier ou de supprimer des nœuds, de séparer ou de fusionner des polygones. Vous avez appris les outils nécessaires à cela dans Lesson: Topologie des données, c’est probablement un bon moment pour relire à nouveau ce chapitre.

Souvenez-vous qu’en ayant coché Activer l’édition topologique, cela vous permet de déplacer des noeuds communs à deux polygones afin que la bordure commune soit modifiée en même temps pour les deux polygones.

Votre résultat devra ressembler à cela :

../../../_images/stands_fully_digitized.png

14.3.6. basic Follow Along: Jointure des données du massif forestier

Il est possible que les données d’inventaire des forêts que vous avez pour votre carte soit aussi écrites sur papier. Dans ce cas, vous devrez tout d’abord écrire ces données dans un fichier texte ou un tableur. Pour cet exercice, les informations de l’inventaire de 1994 (le même inventaire que la carte) sont prêtes dans un fichier texte séparé par des virgule (fichier csv).

Ouvrez le fichier rautjarvi_1994.csv depuis le répertoire exercise_data\forestry dans un éditeur de texte et notez que le fichier de données d’inventaire possède un attribut nommé ID qui contient les numéros des massifs de forêts. Ces numéros sont les mêmes que les ids des massifs de forêts que vous avez entrés pour vos polygones et peuvent être utilisés pour lier les données du fichier texte au fichier vectoriel. Vous pouvez voir les métadonnées pour ces données d’inventaire dans le fichier rautjarvi_1994_legend.txt dans le même dossier.

  • Ouvrez le .csv dans QGIS avec l’outil Couche ‣ Ajouter une couche de texte délimité.... Dans la boîte de dialogue, faites la configuration comme suit :

../../../_images/inventory_csv_import.png

Pour ajouter les données depuis un fichier .csv :

  • Ouvrez les Propriétés de la couche pour la couche forest_stands.

  • Rendez-vous à l’onglet Jointure.

  • Cliquez sur le signe plus en bas de la boîte de dialogue.

  • Sélectionnez rautjarvi_1994.csv pour la Couche de jointure et ID pour le champ Jointure.

  • Assurez-vous que le champ Cible est aussi mis sur id.

  • Cliquez sur OK deux fois.

Les données du fichier texte devraient être maintenant liées à votre fichier vectoriel. Pour voir ce qu’il s’est passé, ouvrez la table attributaire pour la couche forest_stands. Vous pouvez voir que tous les attributs du fichier de données d’inventaire sont maintenant liées à votre couche vectorielle numérisée.

14.3.7. basic Try Yourself Changement du nom des attributs et ajout de l’aire et du périmètre

Les données du fichier .csv sont juste liées à votre fichier vectoriel. Pour rendre ce lien permanent, afin que les données soient effectivement enregistrées dans le fichier vectoriel, vous devez sauvegarder la couche forest_stands comme un nouveau fichier vectoriel. Fermez la table attributaire et faites un clic droit sur la couche forest_stands pour la sauvegarder en tant que forest_stands_1994.shp.

Ouvrez votre nouveau forest_stands_1994.shp dans votre carte si vous ne l’avez pas encore ajouté. Puis, ouvrez la table attributaire. Vous remarquerez que le noms des colonnes que vous venez d’ajouter ne sont pas très utiles. Pour résoudre ceci :

  • Ajoutez l’extension Table Manager comme vous l’avez fait avec d’autres extensions précédemment.

  • Assurez-vous que l’extension est activée.

  • Dans la Légende de la carte, sélectionnez la couche forest_stands_1994.shp.

  • Puis, rendez-vous à Vecteur ‣ Table Manager ‣ Gestionnaire de table.

  • Utilisez la boîte de dialogue pour modifier les noms des colonnes correspondants à ceux du fichier .csv.

../../../_images/forestry_table_manager.png
  • Cliquez sur Sauvegarder.

  • Sélectionnez Oui pour garder le style de la couche.

  • Fermez la boîte de dialogue Table Manager.

Pour terminer sur l’information relative à ces lots forestiers, vous pourriez calculer la surface et le périmètre des lots. Vous avez calculé les surfaces des polygones dans Lesson: Exercice Supplémentaire. Retournez consulter cette leçon si vous en avez besoin et calculer les surfaces des lots forestiers, nommez le nouvel attribut Area et assurez-vous que les valeurs soient calculées en hectares.

Maintenant votre couche forest_stands_1994.shp est prête et contient toute l’information disponible.

Sauvegardez votre projet pour garder la présentation de la carte actuelle au cas où vous auriez besoin d’y revenir plus tard.

14.3.8. In Conclusion

Cela a pris plusieurs clics de souris mais vous avez désormais vos anciennes données d’inventaire dans un format numérique et prêtes à être utilisées dans QGIS.

14.3.9. What’s Next?

Vous pouvez lancer d’autres analyses sur votre nouveau jeu de données mais il est plus intéressant de les faire sur un jeu de données plus récentes. Le sujet de la prochaine leçon concerne la création des massifs forestiers en utilisant les dernières photos aériennes et l’ajout d’information plus précises à votre jeu de données.