Outdated version of the documentation. Find the latest one here.

Ondersteunde Formaten

QGIS gebruikt standaard de OGR functie-bibliotheek om vectorgegevens te kunnen lezen van, en te schrijven naar ESRI Shapefiles, MapInfo en Microstation bestandsformaten; PostGIS, SpatiaLite, MSSQL Spatial en Oracle Spatial databases en vele andere formaten. De vector gegevens kunnen ook geladen worden vanuit gecomprimeerde zip en gzip-archiefbestanden waarbij gegevens dan alleen gelezen kunnen worden in QGIS. Op het moment van schrijven van dit document worden, 69 vector formaten ondersteund door de OGR functiebibliotheek (zie OGR-SOFTWARE-SUITE Literature and Web References). De volledige lijst is beschikbaar op http://www.gdal.org/ogr/ogr_formats.html.

Notitie

Niet alle genoemde formaten zullen zomaar werken in QGIS voor verschillende redenen. Sommige formaten vereisen de aanwezigheid van externe commerciële funktiebibliotheken. Of een formaat wordt niet ondersteund door GDAL/OGR functiebibliotheek die is opgebouwd in voor het gebruikte besturingssysteem. Alleen die formaten die goed zijn getest zullen verschijnen in de lijst van bestandtypen wanneer men een vectorbestand in QGIS wilt inlezen. Overige niet geteste formaten kunnen worden geladen door *.* te selecteren.

Het werken met GRASS vector gegevens is beschreven in GRASS GIS Integration.

Dit deel beschrijft hoe je kunt werken met enkele veelvoorkomende vectorformaten: ESRI shapefiles, PostGIS lagen, Spatialite lagen, OpenStreetMap vector enz.. Veel van de beschikbare gebruikerfuncties in QGIS werken precies hetzelfde voor ondersteunde vectorformaten. Dit is een uitgangspunt geweest bij het ontwerp van QGIS en betreft o.a. de volgende functies, het identificeren, het selecteren, het toevoegen van labels en het werken met attributen.

ESRI Shapefiles

Het standaard vector bestandsformaat dat gebruikt wordt in QGIS is de ESRI Shapefile. De ondersteuning hiervoor wordt mogelijk gemaakt door de OGR Simple Feature Library ( http://www.gdal.org/ogr/ ).

Een shapefile bestaat uit meerdere bestanden. De volgende drie zijn noodzakelijk:

  1. .shp bestand die de geometrieën van de objecten bevat.

  2. .dbf bestand die de attribuutwaarden bevat in dBase formaat.

  3. .shx het index bestand.

Shapefiles kunnen ook een bestand bevatten met de bestandsextensie .prj , het projectiebestand die informatie over het gebruikte coördinatensysteem bevat. Alhoewel een projectie bestand erg handig is, is het niet noodzakelijk. Een shapefile dataset kan daarnaast nog meer bestanden bevatten. Voor verdere details, bekijk de ESRI technisch specificaties op http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

Het laden van een Shapefile

Om een shapefile te laden, open QGIS en klik op het icoontje |mActionOgrLayer| Vectorlaag Toevoegen in de werkbalk of gebruik de snelkoppeling Ctrl+Shift+V. Dit zal een nieuw scherm openen (zie figure_vector_1).

Figure Vector 1:

../../../_images/addvectorlayerdialog.png

Dialoog Vectorlaag Toevoegen nix

Uit de beschikbare opties selecteer het keuzerondje radiobuttonon Bestand. Klik vervolgens op de knop [Bladeren]. Dit zal een standaard bestandskeuze menu openen (zie figure_vector_2) waarmee je kunt bladeren naar de gewenste shapefile of een andere door QGIS ondersteund vectorformaat. De keuzelijst Bestandstypen selectstring geeft de mogelijkheid om te filteren op door OGR ondersteunde bestandsformaten.

Je kunt ook, indien gewenst de karakterset codering, oftewel de encoding meegeven voor de te openen shapefile, (CP1252 is de latijnse karakterset veelal gebruikt in westerse talen).

Figure Vector 2:

../../../_images/shapefileopendialog.png

Dialoog openen van een door OGR ondersteunde Vectorlaag nix

Selecteer een shapefile uit de lijst en selecteer de knop [Open] zodat deze geladen wordt in QGIS. Figure_vector_3 toont QGIS na het laden van de shapefile alaska.shp.

Figure Vector 3:

../../../_images/shapefileloaded.png

QGIS met de geopende shapefile van Alaska nix

Tip

Kleuren van kaartlagen

Wanneer je een kaartlaag toevoegt, zullen de objecten getoond worden in een willekeurige kleur. Wanneer je meer dan één kaartlaag toevoegd, zal elke kaartlaag een andere kleur krijgen.

Eenmaal geladen, kun je kaartlaag bestuderen met de kaart navigatie functies. Om de symbologie van een kaartlaag te wijzigen, open het scherm: guilabel:Laag Eigenschappen door te dubbelklikken op de naam van de kaartlaag in de legenda, of door de laag te selecteren en met de rechtermuis het snelmenu op te roepen en daarin te kiezen voor Eigenschappen. Zie ook Stijl Menu voor meer informatie over het toekennen van symbologie aan Vector kaartlagen.

Tip

Het laden van kaartlagen en projecten van exerne drives onder OS X

Onder OS X, worden de extern toegevoegde USB-sticks en externe harde schijven niet getoond onder Bestand ‣ Open Project zoals men zou verwachten. Er wordt gewerkt aan een oplossing die beter aansluit op de OSX-standaard open/opslaan menu om dit te verhelpen. Je kunt echter, als tijdelijke oplossing, ‘/Volumes’ invullen bij Bestandsnaam en op return drukken. Vervolgens kun je nu ook de externe gekoppelde geheugeneenheden, zoals USB sticks, benaderen.

Verbeteren van de performance voor Shapefiles

Om de performance van het werken met shapefiles te verbeteren, kun je een spatiale index maken. Een spatiale index zal er voor zorgen dat het kaartbeeld veel sneller getekend wordt zodat je ook sneller kunt in- en uitzoomen of het beeld kunt verschuiven. Spatiale indexen gebruikt door QGIS hebben de bestandsnaamextensie .qix.

Gebruik volgende stappen om een index te maken:

  • Laad een shapefile door het icoon mActionAddOgrLayer Vectorlaag Toevoegen in de werkbalk te selecteren of gebruik de snelkoppeling Ctrl+Shift+V.

  • Open het menu Laag Eigenschappen door in de legenda te dubbelklikken op de naam van de shapefile of na selectie in de legenda, met de rechtermuisknop het snelmenu te openen en hierin Eigenschappen te kiezen.

  • In het tabblad Algemeen selecteer de knop [Ruimtelijke index maken].

Problemen bij het laden van een shape .prj bestand

Wanneer je een shapefile laad met een .prj bestand en QGIS is niet in staat om het Coördinate referentie systeem van dat bestand te lezen, dan kun je zelf handmatig de goede CRS projectie zetten binnen het tabblad Algemeen van het scherm Laag Eigenschappen voor die laag. Dit is nodig omdat het gegeven definies in het .prj bestanden vaak niet alle benodigde projectie parameters bevatten, die gebruikt worden in QGIS en gegeven zijn in de lijst van de CRS dialoog.

Om die reden wordt er bij het aanmaken van een nieuwe shapefile met QGIS, twee verschillende projectie bestanden aangemaakt. Een .prj bestand met een kleiner aantal projectie parameters, compatibel met ESRI software, en een .qpj bestand, die een uitgebreidere set van parameters bevat van de gebruikte CRS. Wanneer QGIS een .qpj bestand aantreft, zal deze gebruikt worden in plaats van het .prj bestand.

Het laden van MapInfo gegevens

mActionAddOgrLayer Om MapInfo gegevens te laden, selecteer het icoon mActionAddOgrLayer Vectorlaag Toevoegen in de werkbalk of gebruik snelkoppeling Ctrl+Shift+V om het menu vectorlaag toevoegen te openen. Wijzig het bestandstype filter naar Bestandstype MapInfo Bestand [OGR] en selecteer het MapInfo bestand die je wilt laden.

Het laden van ArcInfo Binary Coverage

mActionAddOgrLayer Om een ArcInfo Binary Coverage te laden, druk op het icoontje mActionAddOgrLayer Vectorlaag Toevoegen in de werkbalk of gebruik snelkoppeling Ctrl+Shift+V om het menu Vectorlaag toevoegen te openen. Selecteer nu eerst de status van keuzerondje radiobuttonon Map. Wijzig vervolgens in de keuzelijst Type Arc/Info Binary Coverage selectstring. Navigeer vervolgens naar de folder die de Arc/Info Coverage bestanden bevat en selecteer deze.

Op de zelfde wijze kun je ook de vector bestanden in het UK National Transfer formaat laden, die eveneens zijn opgeslagen in een folder als bestanden in het TIGER formaat van het US Census Bureau.

Het laden van OpenStreetMap vectorgegevens

De Openstreetmap import functie is een standaard onderdeel van QGIS.

  • Om met de OSM server verbinding te maken en gegevens te downloaden, open het menu Vector ‣ Openstreetmap ‣ Download data.

  • Het menu Vector ‣ Openstreetmap ‣ Importeer topology van XML zal je .osm bestand omzetten naar een spatialite database en daarmee verbinding maken.

  • Het menu Vector ‣ Openstreetmap ‣ Exporteer topologie naar Spatialite geeft de mogelijkheid om de database connectie te openen, wat voor type data je wilt (punten, lijnen of polygonen) en kies de tags om te importeren. Dit zal een spatialite geometrie laag aanmaken die je kunt toevoegen aan je project door te klikken op het werkbalk icoon mActionAddSpatiaLiteLayer SpatiaLite laag Toevoegen of Kaartlagen ‣ SpatiaLite laag toevoegen..., zie ook SpatiaLite Kaartlagen.

PostGIS kaartlagen

PostGIS kaartlagen zijn opgeslagen in een PostgreSQL database. Het voordeel van PostGIS zijn de spatiale indexering, filters en de uitgebreidere bevraagmogelijkheden waarin PostGIS voorziet. Wanneer men gebruik maakt van PostGIS, werken vector functies zoals het selecteren en het identificeren van objecten meer accuraat dan met OGR lagen in QGIS.

Een Connectie maken met PostGIS

mActionAddPostgisLayer De eerste keer wanneer je een PostGIS database wilt openen, moet er eerst een connectie met de PostgreSQL database gemaakt worden die de spatiale gegevens bevat. Begin met het selecteren van het icoontje mActionAddPostgisLayer PostGIS-laag Toevoegen in de werkbalk, of selecteer de menuoptie mActionAddPostgisLayer PostGIS-laag Toevoegen... van het menu Kaartlagen of gebruik de snelkoppeling Ctrl+Shift+D. Het menu PostGIS Tabel(len) Toevoegen zal vervolgens geopend worden. Dit menu kun je ook openen vanuit het menu Vectorlaag Toevoegen waarbij je de status van het keuzerondje radiobuttonon Database.aanzet. Druk eerst op de knop [Nieuw] om toegang te krijgen tot de connectie manager, vervolgens opent het menu Nieuwe PostGIS-verbinding aanmaken. De verplichte velden voor het opzetten van een verbinding zijn:

  • Naam: Een naam voor deze verbinding. Kan gelijk zijn aan de Database

  • Service: Service parameter die gebruikt kan worden als alternatief voor Host/Poort (en eventueel ook Database). Dit kan gedefinieerd worden in de pg_service.conf

  • Host: Naam van de database host. De naam van de host moet dezelfde zijn als waarmee je deze kunt vinden via een telnet verbinding of hoe je deze kunt pingen. Wanneer de database op dezelfde computer staat als QGIS, gebruik hier dan ‘localhost’.

  • Poort: Poort nummer waar de PostgreSQL database naar luistert. De standaardpoort is 5432.

  • Database: Naam van de database.

  • SSL mode: De instelling van het opzetten van een beveiligde SSL verbinding met de server. De performance van het opbouwen van kaarten in QGIS is overigens veel beter door SSL uit te schakelen. Dit zijn de opties:

    • uitschakelen: alleen verbinden zonder SSL versleuteling

    • toestaan: probeer een verbinding zonder SSL versleuteling, als dat mislukt probeer dan met SSL

    • voorkeur (=standaard): probeer een verbinding met SSL versleuteling, als dat mislukt probeer dan een verbinding zonder SSL;

    • vereist: alleen verbinden met SSL versleuteling.

  • Gebruikersnaam: Gebruikersnaam om toegang te krijgen tot de database.

  • Wachtwoord: Wachtwoord die hoort bij Gebruikersnaam om toegang te krijgen tot de database.

Optioneel kunnen de volgende aanvinkvakjes worden aangevinkt:

  • checkbox Gebruikersnaam Opslaan

  • checkbox Wachtwoord Opslaan

  • checkbox Alleen in de geometrie-kolommen kijken

  • checkbox Niet het type geometrie bepalen voor onbeperkte kolommen (GEOMETRY)

  • checkbox Alleen in het ‘publieke’-schema kijken

  • checkbox Ook tabellen zonder geometrie tonen

  • checkbox Gebruik ’estimated table statistics’

Wanneer alle veldparameters en opties zijn gezet, kun je de connectie testen met de knop [Test Verbinding].

Tip

QGIS Gebruikersinstellingen en beveiliging

Afhankelijk van je besturingssysteem kan de opslag van wachtwoorden in de instellingen voor QGIS een beveiligingsrisico vormen. De opslag van gebruikersinstellingen voor QGIS hangt af van je besturingssysteem:

  • nix, voor linux worden de instellingen opgeslagen in de thuismap .qgis2/.

  • win, voor windows worden de instellingen opgeslagen in de registry.

Laden van een PostGIS kaartlaag

mActionAddPostgisLayer Na het aanmaken van een verbinding met één of meerdere PostgreSQL databases, kun je een kaartlaag laden vanuit de PostgreSQL database. Uiteraard moet deze wel eerst kaartgegevens bevatten. Zie Het importeren van gegevens in PostgreSQL voor een uitleg hoe je gegevens in een PostGis database kunt inlezen.

Doe de volgende stappen, om een kaartlaag te laden vanuit PostGIS:

  • Wanneer het venster PostGIS Tabel(len) toevoegen nog niet geopend is, selecteer in de werkbalk de knop mActionAddPostgisLayer PostGIS-laag Toevoegen... in het menu Layer of via de de snelkoppeling Ctrl+Shift+D.

  • Kies een aangemaakte verbinding vanuit de keuzelijst en druk op [Verbinden].

  • Vink aan of ontvink het keuzevakje checkbox Ook tabellen zonder geometrie tonen

  • Optioneel kun je het keuzevakje checkbox Zoek opties aanvinken om een selectie te maken van objecten die geladen dienen te worden of gebruik de knop [Query maken] om het venster te openen waarmee je een Query kunt opbouwen.

  • Vind de laag/lagen die je wilt laden uit de lijst van beschikbare tabellen met gegevens.

  • Selecteer deze door er op te klikken. Je kunt meerdere lagen selecteren door de Shift toets in te drukken tijdens het klikken. Zie Zoekopdrachtbouwer voor meer informatie over het gebruik van de PostgreSQL Query Builder hoe je een query kunt maken voor een gegevenslaag.

  • Klik op de knop [Toevoegen] om de laag toe te voegen aan de legenda en het kaartbeeld.

Tip

PostGIS Lagen

Normaal gesproken bevat een PostGIS laag een geometrieveld. Maar vanaf versie 0.9.0 is het ook mogelijk om in QGIS PostGIS lagen zonder geometrieveld te laden. Daarnaast is het ook mogelijke om gedefinieerde SQL Views te laden. Dit biedt krachtige mogelijkheden om gegevens visueel weer te geven. Zie de PostgreSQL handleiding voor informatie over het aanmaken van SQL Views.

Enkele details over PostgreSQL layers

Dit deel bevat enkele details over hoe QGIS toegang heeft tot PostgreSQL lagen. Meestal geeft QGIS een lijst van database tabellen die geladen kunnen worden en laad deze wanneer je deze selecteert. Maar wanneer je problemen hebt om een PostgreSQL tabel te laden in QGIS, kan de onderstaand informatie helpen om de meldingen van QGIS te begrijpen zodat je een aanwijzing hebt wat je moet veranderen aan de PostgreSQL tabel of aan de View definitie zodat QGIS deze alsnog kan laden.

QGIS vereist dat PostgreSQL tabellen een uniek sleutelveld bevatten voor de te laden laag. In QGIS, moet deze tabel van het type int4 zijn, een integer (geheel getal) met een grootte van 4 bytes. Als een alternatief kan het veld ctid gebruikt worden als sleutelveld. Wanneer in een tabel 1 van deze velden ontbreekt zal in plaats daarvan het veld oid worden gebruikt. De performance zal verbeteren door een index te definiëren op het sleutelveld. (opm. Sleutelvelden krijgen automatisch een index in PostgreSQL).

Wanneer de PostgreSQL laag een view betreft, bestaan dezelfde vereisten, maar views hebben geen sleutelvelden of velden met regels die ervoor zorgen dat deze uniek zijn. Er moet eerst een sleutelveld (van het type integer) in de QGIS dialoog gedefinieerd zijn voordat de view geladen kan worden. Wanneer er niet een daarvoor geschikte kolom bestaat in de view zal de laag niet geladen worden in QGIS. Wanneer dat gebeurd kun je dat oplossen door de view te veranderen zodat deze een kolom bevat van het type integer en die ook kan fungeren als sleutelveld (bij voorkeur geïndexeerd).

Het aanvinkvak Select at id van QGIS is standaard geactiveerd. Met deze opties worden de id’s opgehaald zonder attributen wat in de meeste gevallen sneller is. Deze optie uitschakelen heeft zin wanneer er ‘dure’ views worden gebruikt.

Het importeren van gegevens in PostgreSQL

Gegevens kunnen op een aantal verschillende manieren geïmporteerd worden in PostgreSQL gebruik makende van de SPIT plugin of met opdrachtregel programma’s shp2pgsql of ogr2ogr.

DB Manager

QGIS heeft standaard ook de icon_dbmanager DB Manager plugin. Deze kan gebruikt worden om meerdere shapefiles en andere dataformaten te laden en ondersteund ook schemas. Zie DB Manager Plugin voor meer informatie.

shp2pgsql

PostGIS heeft een stuk gereedschap genaamd shp2pgsql dat gebruikt kan worden om shapefiles te laden in een PostGIS database. Om bijvoorbeeld een shapefile met de naam lakes.shp te laden in een PostgreSQL database genaamd gis_data, gebruik de volgende opdracht:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

Dit maakt een nieuwe tabel aan genaamd lakes_new in de database gis_data. De nieuwe tabel zal een spatiale referentie ID (SRID) bevatten van 2964. Zie Werken met Projecties voor meer informatie over Spatiale Referentie Systemen en projecties.

Tip

Exporteren van gegevens uit PostGIS

Net zoals de functie shp2pgsql is er ook een functie waarmee je PostGIS tabellen kunt exporteren naar shape: pgsql2shp. Deze functies vormen een standaard onderdeel van een PostGIS distributie.

ogr2ogr

Naast shp2pgsql en DB Manager is er nog een manier om geografische gegevens in PostGIS in te lezen: ogr2ogr. Dit is een onderdeel van de GDAL.

Geef de volgende opdracht om een shapefile te importeren in PostGIS:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres \
password=topsecret" alaska.shp

Dit zal de shapefile alaska.shp importeren in de PostGIS-database postgis als gebruiker postgres met het wachtwoord topsecret op host server myhost.de.

Opm. OGR (GDAL) moet gebouwd zijn met ondersteuning voor PostgreSQL om te kunnen werken met PostGIS. Je kunt dit controleren m.b.v. volgende opdracht

ogrinfo --formats | grep -i post

Wanneer je PostgreSQL’s COPY -opdracht wilt gebruiken in plaats van de standaard INSERT INTO opdracht kun je dat doen door de volgende omgevingsvariabele in te stellen (tenminste voor nix en osx):

export PG_USE_COPY=YES

ogr2ogr maakt geen spatiale index aan in tegenstelling tot shp2pgsl die dat wel doet. Deze moet nadien, als extra handeling, alsnog handmatig worden aangemaakt met de normale SQL-opdracht CREATE INDEX (zoals beschreven in de volgende paragraaf Verbeteren van de Performance).

Verbeteren van de Performance

Het opvragen van gegevens uit een PostgreSQL database kan vertragend werken, zeker over een netwerk. Je kunt het tekenen echter een stuk sneller maken door er voor te zorgen dat er een PostGIS spatial index is aangemaakt voor elke laag uit de PostgreSQL database. PostGIS ondersteund het aanmaken van een zogenaamde GiST (Generalized Search Tree) index zodat de spatiale zoekopdrachten een stuk sneller uitgevoerd worden.

De opdracht voor het aanmaken van een GiST index is:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Voor grote tabellen kan het aanmaken van een index veel tijd kosten. Wanneer de index is aangemaakt dient deze gevolgd te worden door de opdracht VACUUM ANALYZE. Zie de PostGIS documentatie (POSTGIS-PROJECT Literature and Web References) voor meer informatie.

Hier volgt een voorbeeld hoe je een GiST index kunt aanmaken:

[email protected]:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

Vector kaartggegevens die de 180° lengtegraad overschrijden

Veel GIS pakketten zullen verkeerd omgaan met het aanmaken van vector kaarten, met een geografisch referentie systeem (lengte-/breedtegraden), wanneer deze de 180 lengtegraad lijn overschrijden. Wanneer ze zo’n kaart openen in QGIS, zullen we zien dat twee plaatsen die dicht bij elkaar liggen, ver uit elkaar getoond worden. In Figure_vector_4 ligt, het kleine puntje helemaal aan de linkerkant van het kaartbeeld (de Chatham Islands), in werkelijkheid aan de rechterkant van de Nieuw Zeeland’s hoofdeilanden.

Figure Vector 4:

../../../_images/vectorNotWrapping.png

Vector kaartggegevens die de 180° lengtegraad overschrijden nix

Dit probleem kan men oplossen door de lengtegraden te transformeren gebruik makende van PostGIS, en de ST_Shift_Longitude functie (zie http://postgis.refractions.net/documentation/manual-1.4/ST_Shift_Longitude.html). De transform functie leest elke coördinaat van de geometrie van elk object en wanneer de lengtegraad < 0° telt deze er 360° bij op. Het resultaat zal een 0° - 360° versie zijn van de gegevens die afgedrukt worden op een 180° gecentreerde kaart.

Figure Vector 5:

../../../_images/vectorWrapping.png

Het overschrijden van de 180° lengtegraad met het toepassen van de ST_Shift_Longitude functie

Gebruik

  • Importeer gegevens in PostGIS (Het importeren van gegevens in PostgreSQL) bijvoorbeeld door gebruik te maken van de DB Manager plugin.

  • Geef de volgende opdracht op de SQL opdrachtregel van PostGIS (dit is een voorbeeld waar “TABEL” de echte naam is van je PostGIS tabel)

    gis_data=# update TABLE set the_geom=ST_shift_longitude(the_geom);

  • Wanneer alles goed ging, zou je nu een bevestiging moeten ontvangen van het aantal objecten die bijgewerkt zijn. Daarna kan deze tabel geladen worden en zie je het verschil (Figure_vector_5)

SpatiaLite Kaartlagen

mActionAddSpatiaLiteLayer Wanneer je gegevens van een SpatiaLite database wilt laden, selecteer het icoontje mActionAddSpatiaLiteLayer SpatiaLite-laag Toevoegen op de werkbalk of door de menu-optie mActionAddSpatiaLiteLayer SpatiaLite-laag Toevoegen... te selecteren onder het hoofdmenu Kaartlagen of via de sneltoets Ctrl+Shift+L. Een menu zal openen waarin je een nieuwe verbinding met een Spatialite database kunt aanmaken of een bestaande verbinding die bekend is bij QGIS kunt kiezen in een keuzelijst. Om een nieuwe connectie aan te maken selecteer de knop [Nieuw], vervolgens kun je via een bestandsverkenner de SpatiaLite database vinden, wat vaak een bestand is die meestal de bestandsextensie :file`.sqlite` heeft.

Wanneer je een vectorlaag wilt opslaan in SpatiaLite formaat kun je dit doen door een vectorlaag in de legenda te selecteren en dan met de rechtermuis het snelmenu te openen en daarin Opslaan als te selecteren. Geef een naam voor de aan te maken database, geef ‘Spatialite’ als formaat en de CRS (Coordinaten Referentie Systeem). Je kunt ook ‘SQLite’ als formaat selecteren en de volgende opdracht in het veld OGR data source creation option SPATIALITE=YES meegeven. OGR weet dan dat deze een SpatiaLite database moet aanmaken. Zie ook http://www.gdal.org/ogr/drv_sqlite.html.

QGIS ondersteund ook het bewerken van Views die gewijzigd kunnen worden in SpatiaLite.

Het maken van een nieuwe SpatiaLite kaartlaag

Wanneer je een nieuwe SpatiaLite laag wilt aanmaken, ga naar Het aanmaken van een nieuwe Spatialite Laag.

Tip

SpatiaLite data management Plugins

Voor het beheren van SpatiaLite gegevens kun je een aantal Python plugins gebruiken: QSpatiaLite, SpatiaLite Manager of DB Manager (standaardplugin, aanbevolen). Deze kunnen gedownload en geïnstalleerd worden met de Plugin Installer.

MSSQL Spatial kaartlagen

mActionAddMssqlLayer QGIS ondersteund standaard ook MS SQL 2008. De mActionAddMssqlLayer MSSQL Spatial-laag toevoegen is beschikbaar in de werkbalk en ook beschikbaar in de MS SQL onderdeel van de QBrowser-boom waarbij je gegevens eenvoudig met ‘drag and drop’ kunt importeren.

ORACLE Spatial kaartlagen

mActionAddOracleLayer QGIS ondersteund standaard ook Oracle Locator/Spatial. De mActionAddOracleLayer Oracle Spatial-laag toevoegen is beschikbaar in de werkbalk en ook beschikbaar in het Oracle onderdeel van de QBrowser-boom waarbij je gegevens eenvoudig met ‘drag and drop’ kunt importeren.

Een Connectie maken met PostGIS

mActionAddOracleLayer De eerste keer wanneer je een Oracle Spatial database wilt openen, moet er eerst een connectie met de database gemaakt worden die de spatiale gegevens bevat. Begin met het selecteren van het icoontje mActionAddOracleLayer Oracle Spatial laag Toevoegen in de werkbalk, of selecteer de menuoptie mActionAddOracleLayer Oracle Spatial laag Toevoegen... van het menu Kaartlagen of gebruik de snelkoppeling Ctrl+Shift+O. Druk in het menu dat verschijnt op de knop [Nieuw] om toegang te krijgen tot de connectie manager, vervolgens opent het menu Nieuwe Oracle Spatial verbinding aanmaken. De verplichte velden voor het opzetten van een verbinding zijn:

  • Naam: Een naam voor deze verbinding. Kan gelijk zijn aan de Database

  • Database SID of SERVICE_NAME van de Oracle instantie.

  • Host: Naam van de database host. De naam van de host moet dezelfde zijn als waarmee je deze kunt vinden via een telnet verbinding of hoe je deze kunt pingen. Wanneer de database op dezelfde computer staat als QGIS, gebruik hier dan ‘localhost’.

  • Poort: Poort nummer waar de PostgreSQL database naar luistert. De standaardpoort is 1521.

  • Gebruikersnaam: Gebruikersnaam om toegang te krijgen tot de database.

  • Wachtwoord: Wachtwoord die hoort bij Gebruikersnaam om toegang te krijgen tot de database.

Optioneel kunnen de volgende aanvinkvakjes worden aangevinkt:

  • checkbox Opslaan Gebruikersnaam Geef aan of de gebruikersnaam van de database-connectie moet worden opgeslagen.

  • checkbox Opslaan Wachtwoord Geef aan of het wachtwoord van de database-connectie moet worden opgeslagen. Wachtwoorden worden opgeslagen als leesbare tekst in de systeemconfiguratie en in de projectbestanden van QGIS!

  • checkbox Kijk alleen in de metadata tabel. Dit beperkt de tabellen tot die aanwezig in de view all_sdo_geom_metadata. Dit kan het tonen van tabellen voor selectie aanzienlijk versnellen.

  • checkbox Kijk alleen in de gebruikerstabellen. Beperk de zoekopdracht tot alleen die spatiale tabellen waar de gebruiker eigenaar van is.

  • checkbox Ook tabellen zonder geometrie tonen Geeft aan dat ook tabellen zonder geometrie standaard in de lijst getoond worden.

  • checkbox Gebruik geschatte tabelstatistieken voor de laag metadata Wanneer een laag wordt aangemaakt wordt er ook verschillende metadata aangemaakt voor de Oracle tabel. Deze bevat informatie als bijhouding van het aantal regels, het geometrie type en de extent van alle geometrieën in de tabel. Het bijhouden van deze metadata is tijdrovend wanneer de tabellen veel records bevatten. Door deze optie te activeren, wordt het verzamelen van de metadata als volgt sneller bepaald: Het aantal regels word bepaald vanuit all_tables.num_rows. De extent van elke tabel wordt altijd bepaald met de functie SDO_TUNE.EXTENTS_OF zelfs wanneer er een filter wordt gebruikt. Het bepalen van de geometrie type van de tabel, worden de eerste 100 regels van de tabel gelezen die geometrie bevatten.

  • checkbox Alleen bestaande geometrie typen Toon alleen bestaande geometrie types en biedt niet aan om andere toe te voegen.

Wanneer alle veldparameters en opties zijn gezet, kun je de connectie testen met de knop [Test Verbinding].

Tip

QGIS Gebruikersinstellingen en beveiliging

Afhankelijk van je besturingssysteem kan de opslag van wachtwoorden in de instellingen voor QGIS een beveiligingsrisico vormen. Wachtwoorden worden opgeslagen als leesbare tekst in de systeem configuratie en in de projectbestanden! De opslag van gebruikersinstellingen voor QGIS hangt af van je besturingssysteem:

  • nix, de instellingen worden opgeslagen in de thuismap in .config/QGIS/QGIS2.conf.

  • win, voor windows worden de instellingen opgeslagen in de registry.

Het laden van Oracle Spatial gegevens

mActionAddOracleLayer Na het aanmaken van een verbinding met één of meerdere Oracle databases, kun je een kaartlaag laden vanuit de Oracle database. Uiteraard moet deze wel eerst kaartgegevens bevatten.

Doe de volgende stappen, om een spatiale tabel te laden vanuit Oracle Spatial:

  • Wanneer het venster Oracle Spatial Tabel(len) toevoegen nog niet open is, selecteer in de werkbalk de knop mActionAddOracleLayer Oracle Spatial laag Toevoegen.

  • Kies een aangemaakte verbinding vanuit de keuzelijst en druk op [Verbinden].

  • Vink aan of ontvink het keuzevakje checkbox Ook tabellen zonder geometrie tonen

  • Optioneel kun je het keuzevakje checkbox Zoek opties aanvinken om een selectie te maken van objecten die geladen dienen te worden of gebruik de knop [Query maken] om het venster te openen waarmee je een Query kunt opbouwen.

  • Vind de laag/lagen die je wilt laden uit de lijst van beschikbare tabellen met gegevens.

  • Selecteer deze door er op te klikken. Je kunt meerdere lagen selecteren door de Shift toets in te drukken tijdens het klikken. Zie Zoekopdrachtbouwer voor meer informatie over het gebruik van de Oracle Query Builder hoe je een query kunt maken voor een gegevenslaag.

  • Klik op de knop [Toevoegen] om de laag toe te voegen aan de legenda en het kaartbeeld.

Tip

Oracle Spatial Kaartlagen

Normaal gesproken wordt een spatiale laag in ORACLE gedefinieerd in de tabel USER_SDO_METADATA.