Outdated version of the documentation. Find the latest one here.

eVis Plugin

The Biodiversity Informatics Facility at the American Museum of Natural History’s (AMNH) Center for Biodiversity and Conservation (CBC) (this section is derived from Horning, N., K. Koy, P. Ersts. 2009. eVis (v1.1.0) User’s Guide. American Museum of Natural History, Center for Biodiversity and Conservation. Available from http://biodiversityinformatics.amnh.org/, and released under the GNU FDL.) has developed the Event Visualization Tool (eVis), another software tool to add to the suite of conservation monitoring and decision support tools for guiding protected area and landscape planning. This plugin enables users to easily link geocoded (i.e., referenced with latitude and longitude or X and Y coordinates) photographs, and other supporting documents, to vector data in QGIS.

eVis is now automatically installed and enabled in new versions of QGIS, and as with all plugins, it can be disabled and enabled using the Plugin Manager (See Plugins verwalten).

Es besteht aus drei Modulen: der eVis-Datenbankverbindung, dem eVis-Ereignis-ID-Werkzeug und dem eVis-Ereignisbrowser. Diese Werkzeuge arbeiten zusammen, damit das Darstellen von georeferenzierten Fotos und anderen Dokumenten, die mit Vektorobjekten, Datenbanken oder Tabellen verlinkt sind, funktioniert.

Ereignisbrowser

The Event Browser module provides the functionality to display geocoded photographs that are linked to vector features displayed in the QGIS map window. Point data, for example, can be from a vector file that can be input using QGIS or it can be from the result of a database query. The vector feature must have attribute information associated with it to describe the location and name of the file containing the photograph and, optionally, the compass direction the camera was pointed when the image was acquired. Your vector layer must be loaded into QGIS before running the Event Browser.

Den eVis-Ereignisbrowser starten

Um den Ereignisbrowser zu starten, klicken Sie entweder auf das event_browser eVis Event Browser Icon oder auf Datenbank ‣ eVis ‣ eVis Ereignisbrowser. Dies öffnet den Ereignisbrowser Dialog.

The Event Browser window has three tabs displayed at the top of the window. The Display tab is used to view the photograph and its associated attribute data. The Options tab provides a number of settings that can be adjusted to control the behavior of the eVis plugin. Lastly, the Configure External Applications tab is used to maintain a table of file extensions and their associated application to allow eVis to display documents other than images.

Der Anzeigen-Reiter

To see the Display window click on the Display tab in the Event Browser window. The Display window is used to view geocoded photographs and their associated attribute data.

Figure eVis 1:

../../../_images/evisdisplay.png

The eVis display window

  1. Anzeigefenster: Ein Fenster, in dem das Foto erscheint.

  2. Hineinzoomen: Zoomen, um Details zu sehen. Wenn das gesamte Bild nicht im Anzeigefenster dargestellt werden kann, erscheinen Scrollbars auf der linken und unteren Seite des Fensters, um das Foto verschieben zu können.

  3. Herauszoomen: Aus dem Bild herauszoomen, um einen Überblick zu haben.

  4. Zur vollen Ausdehnung zoomen: Zeigt die volle Ausdehnung des Fotos an.

  5. Attributfenster: Alle Attribute des Vektorpunktes, der mit dem Foto verlinkt ist werden hier angezeigt. Wenn der Datentyp, auf den verwiesen wird kein Foto ist, sondern ein anderer Datentyp, der im Reiter Externe Applikationen konfigurieren definiert ist, dann öffnet sich die Anwendung mit dem speziellen Datentyp, indem Sie auf das Feld mit dem Pfad doppelkicken. Die Anwendung wird dann gestartet und Sie können den Inhalt anschauen oder anhören. Wenn die Datenendung erkannt wird, wird sie automatisch in grün angezeigt.

  6. Navigation: Verwenden Sie den ‘Vorheriges’ und ‘Nächstes’ Knopf, um weitere Objekte zu laden, falls vorhanden und selektiert.

Der Optionen-Reiter

Figure eVis 2:

../../../_images/evisoptions.png

The eVis Options window

  1. Dateipfad: Eine Dropdown-Liste, um das Attributfeld zu definieren, welches den Verzeichnispfad oder die URL für die Fotos oder anderen Dokumente enthält. Wenn es ein relativer Pfad ist, dann wählen Sie das Kontrollkästchen checkbox Pfad ist relaitiv, links neben dem Dropdown-Menü. Der Grundpfad für den relativen Pfad kann in dem Grundpfad eingegeben werden. Informationen über die verschiedenen Optionen zur Angabe des Speicherortes der Datei werden weiter unten beschrieben.

  2. Compass bearing: A dropdown list to specify the attribute field that contains the compass bearing associated with the photograph being displayed. If compass bearing information is available it is necessary to click the checkbox below the dropdown menu title.
  3. Compass offset: Compass offsets can be used to compensate for declination (adjust bearings collected using magnetic bearings to true north bearings). Click the radiobuttonon Manual radiobutton to enter the offset in the text box or click the radiobuttonon From Attribute radiobutton to select the attribute field containing the offsets. For both of these options east declinations should be entered using positive values and west declinations should use negative values.
  4. Relativer Pfad: Der Grundpfad, auf den sich die relativen Pfade der Fotos und Dokumente beziehen wie in Abbildung Figure_eVis_2 (A) und wird angehängt.

  5. Gesamten Pfad ersetzen: Wenn dieses Kontrollkästchen aktiviert ist, wird nur der Dateiname an den Grundpfad angehängt, der als Attributspalte im Bereich Dateipfad definiert wurde.

  6. Bildpfad auf alle Dokumente anwenden: Wenn dieses Kontrollkästchen aktiviert ist, wird derselbe Grundpfad, der für Fotos verwendet wird, auch auf alle anderen Dokumente (Filme, Texte, usw.) verwendet. Ansonsten werden die definierten Pfadangaben nur für die Fotos verwendet. Alle anderen Dokumente ignorieren den Grundpfad.

  7. Remember settings: If the checkbox is checked the values for the associated parameters will be saved for the next session when the window is closed or when the [Save] button below is pressed.
  8. Zurücksetzen: Setzt die Werte der jeweiligen Zeile auf die Standardwerte zurück.

  9. Restore defaults: This will reset all of the fields to their default settings. It has the same effect as clicking all of the [Reset] buttons.
  10. Speichern: Dieser Knopf speichert alle Einstellungen, ohne den Dialog zu schließen.

Der Externe Applikationen konfigurieren Reiter

Figure eVis 3:

../../../_images/evisexternal.png

The eVis External Applications window

  1. Datei Referenztabelle: Eine Tabelle mit den Datentypen, die mit eVis geöffnet werden können. Jeder Datentyp benötigt eine Dateiendung, und den Pfad zu einer Anwendung, die den entsprechenden Datentyp anzeigen oder ausführen kann. Dies schließt neben Fotos u.a. auch Textdokumente, Filme oder Hörspiele mit ein.

  2. Neuen Dateityp hinzufügen: Füge einen neuen Dateityp mit einer einzigartigen Dateiendung hinzu, sowie einen Pfad zu der Applikation, mit der dieser Datentyp geöffnet werden kann.

  3. Aktuelle Zeile löschen: Löschen Sie den ausgewählten Dateityp aus der Referenztabelle.

Den Ort und Namen eines Fotos festlegen

Der Ort und Name eines Fotos kann über einen absoluten oder relativen Pfad festgelegt werden. Wenn das Foto auf einem Webserver liegt, kann auch eine URL verwendet werden. Beispiele für die verschiedenen Varianten finden Sie in Tabelle evis_examples.

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  http://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:http://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

Den Ort und Namen anderer Dokumente und Dateien festlegen

Belege wie Text-Dokumente, Videos und Sound-Clips können ebenfalls angezeigt oder abgespielt werden. Dazu ist es notwendig, einen Eintrag in der Referenztabelle zu erstellen, über den die Quelle dann geöffnet werden kann. Außerdem ist es notwendig, den Pfad oder eine URL in die Attributtabelle des Vektorlayers für das entsprechende Objekt einzutragen. Eine weitere Regel, die für URLs verwendet werden kann, die keine Dateiendung für das Dokument enthalten, das Sie öffnen möchten, besteht darin, die Dateierweiterung vor der URL anzugeben. Das Format ist dann — Dateiendung:URL. Vor die URL wird die Dateiendung mit einem Doppelpunkt geschrieben. Dies ist besonders nützlich für den Zugriff auf Dokumente in Wikis und anderen Webseiten, die eine Datenbank verwenden, um die Webseiten zu verwalten (siehe Tabelle evis_examples).

Using the Event Browser

Wenn Sie den Ereignisbrowser starten, öffnet sich ein Foto und wird im Display angezeigt, wenn in der Attributtabelle auf das entsprechende Foto verwiesen wird, und wenn der Speicherort der Datei im Reiter Optionen richtig eingestellt ist. Wenn Sie ein Foto erwarten, es aber nicht angezeigt wird, kontrollieren Sie die Parameter nochmals.

Wenn auf ein Dokument (oder ein Bild, das nicht über eine eVis bekannte Dateierweiterung verfügt) in der Attributtabelle verwiesen wird, wird das Feld mit dem Dateipfad grün hervorgehoben dargestellt, wenn die Dateierweiterung sich in der definierten Referenztabelle im Reiter Externe Applikationen konfigurieren befindet. Um das Dokument zu öffnen, doppelklicken Sie auf die grün markierte Zeile im Attribut Informationsfenster. Wenn auf ein Objekt in der Attributtabelle verwiesen wird und der Dateipfad nicht grün markiert ist, dann müssen Sie einen Eintrag für die Dateierweiterung entsprechend ergänzen. Wenn der Dateipfad grün markiert ist, sich aber nicht bei einem Doppelklick öffnet, müssen Sie die Parameter im Reiter Optionen einstellen, damit die Datei von eVis gefunden und dargestellt werden kann.

If no compass bearing is provided in the Options window a red asterisk will be displayed on top of the vector feature that is associated with the photograph being displayed. If a compass bearing is provided then an arrow will appear pointing in the direction indicated by the value in the compass bearing display field in the Event Browser window. The arrow will be centered over the point that is associated with the photograph or other document.

To close the Event Browser window click on the [Close] button from the Display window.

Ereignis-ID-Werkzeug

The ‘Event ID’ module allows you to display a photograph by clicking on a feature displayed in the QGIS map window. The vector feature must have attribute information associated with it to describe the location and name of the file containing the photograph and optionally the compass direction the camera was pointed when the image was acquired. This layer must be loaded into QGIS before running the ‘Event ID’ tool.

Starten des Ereignis-ID-Werkzeugs

To launch the ‘Event ID’ module either click on the event_id Event ID icon or click on Database ‣ eVis ‣ Event ID Tool. This will cause the cursor to change to an arrow with an ‘i’ on top of it signifying that the ID tool is active.

To view the photographs linked to vector features in the active vector layer displayed in the QGIS map window, move the Event ID cursor over the feature and then click the mouse. After clicking on the feature, the Event Browser window is opened and the photographs on or near the clicked locality are available for display in the browser. If more than one photograph is available, you can cycle through the different features using the [Previous] and [Next] buttons. The other controls are described in the ref:evis_browser section of this guide.

Datenbankverbindung

Der Dialog Datenbankverbindung ermöglicht es, sich mit einer Datenbank oder anderen ODBC Quelle, z.B. Excel-Tabellen zu verbinden.

eVis can directly connect to four types of databases:PostgreSQL, MySQL, SQLite, and can also read from ODBC connections (e.g.MS Access). When reading from an ODBC database (such as an Excel spreadsheet) it is necessary to configure your ODBC driver for the operating system you are using.

Starten des Dialogs Datenbankverbindung

To launch the ‘Database Connection’ module either click on the appropriate icon evis_connect eVis Database Connection or click on Database ‣ eVis ‣ Database Connection. This will launch the Database Connection window. The window has three tabs: Predefined Queries, Database Connection, and SQL Query. The Output Console window at the bottom of the window displays the status of actions initiated by the different sections of this module.

Verbinden mit einer Datenbank

Drücken Sie auf den Reiter Datenbankverbindung und definieren Sie dann im Dropdown-Menü den Datenbanktyp, mit dem Sie sich verbinden wollen. Wenn ein Passwort oder Benutzername erforderlich ist, können diese Informationen in den Feldern Benutzername und Passwort eingegeben werden.

Enter the database host in the Database Host textbox. This option is not available if you selected ‘MS Access’ as the database type. If the database resides on your desktop you should enter “localhost”.

Enter the name of the database in the Database Name textbox. If you selected ‘ODBC’ as the database type, you need to enter the data source name.

Nachdem Sie alle Parameter angegeben haben, klicken Sie auf den [Verbinden] Knopf. Wenn die Verbindung erfolgreich ist, wird dies im Ausgabefenster angezeigt. Im anderen Fall müssen Sie die Parameter nochmal überprüfen, die Sie eingegeben haben.

Figure eVis 4:

../../../_images/evisdatabase.png

The eVis Database connection window

  1. Datenbanktyp: Eine Dropdown-Liste, um den zu verwendenen Datenbanktyp festzulegen.

  2. Datenbank-Host: Der Name des Datenbank-Hosts.

  3. Port: Die Portnummer, wenn MYSQL oder PostgreSQL benutzt wird.

  4. Datenbankname: Der Name der Datenbank.

  5. Verbinden: Ein Knopf, um sich mit der definierten Datenbank zu verbinden.

  6. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  7. Benutzername: Benutzername, um sich mit einer passwortgeschützten Datenbank zu verbinden.

  8. Passwort: Passwort, wenn die Datenbank passwortgeschützt ist.

  9. Vordefinierte Abfragen: Reiter, um den Dialog ‘Vordefinierte Abfragen’ zu öffnen.

  10. Datenbankverbindung: Reiter, um den Dialog ‘Datenbankverbindung’ zu öffnen.

  11. SQL-Abfrage: Reiter, um den Dialog ‘SQL-Abfrage’ zu öffnen.

  12. Hilfe: Zeigt die Online-Hilfe an.

  13. OK: Schließen des Dialogs ‘Datenbankverbindung’.

SQL-Abfrage durchführen

SQL queries are used to extract information from a database or ODBC resource. In eVis the output from these queries is a vector layer added to the QGIS map window. Click on the SQL Query tab to display the SQL query interface. SQL commands can be entered in this text window. A helpful tutorial on SQL commands is available at http://www.w3schools.com/sql. For example, to extract all of the data from a worksheet in an Excel file, select * from [sheet1$] where sheet1 is the name of the worksheet.

Klicken Sie dann auf die Knopf [Abfrage ausführen], um den Befehl auszuführen. Wenn die Abfrage erfolgreich ist, wird ein Auswahlfenster angezeigt. Wenn die Abfrage nicht erfolgreich ist, erscheint eine Fehlermeldung in der Ausgabekonsole.

Im Datenbank Dateiauswahl Fenster geben Sie den Namen des Layers an, der aus dem Ergebnis der Abfrage erstellt werden soll.

Figure eVis 5:

../../../_images/evissql_query.png

The eVis SQL query tab

  1. SQL-Abfrage: Ein Fenster zur Eingabe von SQL-Abfragen.

  2. Abfrage ausführen: Knopf, um die SQL-Abfrage auszuführen.

  3. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  4. Hilfe: Zeigt die Online-Hilfe an.

  5. OK: Schließt das Fenster Datenbankverbindung.

Use the X Coordinate selectstring and Y Coordinate selectstring comboboxes to select the field from the database that store the X (or longitude) and Y (or latitude) coordinates. Clicking on the [OK] button causes the vector layer created from the SQL query to be displayed in the QGIS map window.

To save this vector file for future use, you can use the QGIS ‘Save as...’ command that is accessed by right clicking on the layer name in the QGIS map legend and then selecting ‘Save as...’

Tipp

Einen Vektorlayer von einem Microsoft Excel Arbeitsblatt erstellen

When creating a vector layer from a Microsoft Excel Worksheet you might see that unwanted zeros (“0”) have been inserted in the attribute table rows beneath valid data.This can be caused by deleting the values for these cells in Excel using the Backspace key. To correct this problem you need to open the Excel file (you’ll need to close QGIS if there if you are connected to the file to allow you to edit the file) and then use Edit ‣ Delete to remove the blank rows from the file. To avoid this problem you can simply delete several rows in the Excel Worksheet using Edit ‣ Delete before saving the file.

Vordefinierte Abfragen starten

Über den Reiter Vordefinierte Abfragen können Sie zuvor schriftlich erstellte SQL-Abfragen, die als Datei im XML-Format gespeichert werden, wieder aufrufen. Dies ist besonders hilfreich, wenn Sie nicht vertraut sind mit SQL-Befehlen. Klicken Sie auf den Reiter Vordefinierte Abfragen, um die vordefinierte Abfrage-Schnittstelle zu öffnen.

Um eine Reihe von vordefinierten Abfragen zu laden, klicken Sie auf das evis_file Datei öffnen Icon. Dann können Sie die Datei mit den abgespeicherten SQL-Befehlen auswählen und laden. Danach erscheinen die einzelnen Abfragen im Dropdown-Menü. Eine Beschreibung der SQL-Abfrage wird jeweils im Textfenster unterhalb des Dropdown-Menüs angezeigt.

Wählen Sie nun eine Abfrage, die Sie aus dem Dropdown-Menü ausführen möchten und klicken Sie auf den Reiter SQL-Abfrage, um die Abfrage anzuschauen. Wenn Sie eine vordefinierten Abfrage das erste Mal starten, müssen Sie sich erst vergewissern, dass die Datenbankverbindung steht.

Klicken Sie auf den Knopf [Abfrage ausführen] im Reiter SQL-Abfrage. Wenn die Abfrage erfolgreich ist, wird ein Auswahlfenster angezeigt. Wenn die Abfrage nicht erfolgreich ist, erscheint eine Fehlermeldung in der Ausgabekonsole.

Figure eVis 6:

../../../_images/evispredefined.png

The eVis Predefined queries tab

  1. Open File: Launches the “Open File” file browser to search for the XML file holding the predefined queries.
  2. Vordefinierte Abfragen: Eine Dropdown-Liste mit allen Abfragen der bereits erstellten XML-Datei.

  3. Abfragebeschreibung: Eine Beschreibung der Abfrage. Diese Beschreibung ist in der XML-Datei enthalten.

  4. Ausgabekonsole: Hier werden Informationen zu den Prozessen angezeigt.

  5. Hilfe: Zeigt die Online-Hilfe an.

  6. OK: Schließt das Fenster ‘Datenbankverbindung’.

XML-Format für vordefinierte Abfragen in eVis

Die von eVis gelesenen XML-Tags

Tag

Beschreibung

query

Definiert den Anfang und das Ende einer Abfrage.

shortdescription

Eine kurze Beschreibung der Abfrage, die im eVis Dropdown-Menü erscheint.

description

Eine detailiertere Beschreibung der Abfrage, die in der eVis Abfragebeschreibung angezeigt wird.

databasetype

Der Datebanktyp, wie er im Dropdown-Menü Datenbanktyp festgelegt wurde.

databaseport

Der definierte Port, über den die Verbindung mit der Datenbank stattfindet.

databasename

Der definierte Datenbankname aus dem Reiter Datenbankverbindung.

databaseusername

Der definierte Benutzername aus dem Reiter Datenbankverbindung.

databasepassword

Das definierte Passwort aus dem Reiter Datenbankverbindung.

sqlstatement

Die SQL-Abfrage.

autoconnect

Eine Option (‘true’ oder ‘false’), die festlegt, ob automatisch mit der Datenbank verbunden werden soll, ohne die Routine aus dem Reiter Datenbankverbindung zu durchlaufen.

Ein Beispiel einer XML-Datei mit drei Abfragen ist unten dargestellt:

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>