Outdated version of the documentation. Find the latest one here.

Элементы

В этом разделе описывается набор стандартных стилистических элементов, принятых в документе. В данном руководстве пользователя используются следующие элементы:

Элементы интерфейса пользователя

Элементы интерфейса пользователя используются для имитации внешнего вида интерфейса пользователя. Задача элементов — дать наглядное представление, так, чтобы пользователь мог посмотреть на интерфейс и найти то, что описано в инструкции руководства.

  • Пункты меню: Слой ‣ Добавить растровый слой или Вид ‣ Панели инструментов ‣ Оцифровка

  • Инструмент: mActionAddRasterLayer Добавить растровый слой

  • Кнопка : [По умолчанию]

  • Заголовок диалогового окна: Свойства слоя

  • Вкладка: Общие

  • Флажок: checkbox Отрисовка

  • Переключатель: radiobuttonon Postgis SRID radiobuttonoff EPSG ID

  • Выбрать число: selectnumber

  • Выбрать строку: selectstring

  • Выбрать файл: browsebutton

  • Выбрать цвет: selectcolor

  • Ползунок: slider

  • Ввод текста: inputtext

Затенение указывает на интерактивный компонент графического интерфейса.

Текстовые элементы или клавиатурные сокращения

Руководство также включает в себя стили, связанные с текстом, клавиатурными сокращениями и примерами кода для обозначения различных сущностей, таких, как классы или методы. Они не обязательно соответствуют каким-либо элементам интерфейса.

  • Гиперссылки: http://qgis.org

  • Комбинации клавиш: нажать Ctrl+B означает нажать и удерживать клавишу Ctrl, а затем нажать клавишу B.

  • Название файла: lakes.shp

  • Название класса: NewLayer

  • Метод: classFactory

  • Имя сервера: myhost.de

  • Текст, вводимый пользователем: qgis --help

Примеры кода отображаются с помощью шрифта фиксированной ширины

PROJCS["NAD_1927_Albers",
  GEOGCS["GCS_North_American_1927",

Инструкции, специфичные для конкретных платформ

Последовательности команд интерфейса пользователя и краткие описания могут быть представлены в виде строки: Нажмите nix win Файл osx QGIS ‣ Выход, чтобы закрыть QGIS.

Это означает, что на платформах Linux, Unix и Windows сначала нужно выбрать пункт меню «Файл», а затем в выпадающем меню щелкнуть «Выход», в то время как в Mac OSX сначала нужно выбрать меню QGIS, а затем в выпадающем меню выбрать «Выход». Если нужно большее количество текста, оно может быть представлено списком:

  • nix сделать это;

  • win сделать то;

  • osx сделать что-то еще.

или в виде абзацев.

nix osx Сделать это, и это, и это. И так далее, и тому подобное.

win Сделать то. И еще то и то. И так далее, и тому подобное.

Снимки экрана, которые встречаются в руководстве пользователя, были созданы на разных платформах; платформа обозначается специальной иконкой в конце подписи к рисунку.