Outdated version of the documentation. Find the latest one here.

オープンストリートマップ

近年, オープンストリートマップ(OpenStreetMap: OSM)プロジェクトが人気を集めています. 多くの国では, 自由に利用できる地図データが無いからです. OSMプロジェクトの目的は, GPSデータ, 航空写真, そして編集者自身が持つ知識を利用して, 自由に編集可能な世界地図を作成することです. これをサポートするために, QGISではOSMデータと連携するプラグインを提供しています.

QGISのコアプラグインであるOSMプラグインは, OSMデータを扱うための基本機能を提供します. 具体的には, データの読み込み, インポート, 保存, ダウンロード, 編集, OSMサーバへのアップロードです. 実装においては, 既存のOSMエディタを参考にしました. 既存OSMエディタの機能を取り入れることで, 最も良い結果がもたらされると考えました.

次のセクションは, OSMプロジェクトの理念に関する概要紹介です.

いくつかの段落は, OpenStreetMapのWEBサイト http://www.openstreetmap.org からコピーしたものです.

オープンストリートマップ(OSM)プロジェクト

オープンストリートマップは, 自由に編集可能な世界地図を作るプロジェクトです. 地図は, ポータブルGPSデバイス, 航空写真などの著作権フリーのソース, もしくは単純に編集者自身の地域に関する知識から作成されます. このプロジェクトがスタートしたのは, 一般的な地図のほとんどが利用にあたって法的もしくは技術的な制約があり, 創造的利用, 生産的利用や予想外の利用が制限されているためです. OSMの描画イメージとベクタデータセットはいずれも, Creative Commons Attribution ShareAlike 2.0 ライセンスのもとダウンロードできます.

Figure OpenStreetMap 1:

../../../_images/osmweb.png

OpenStreetMap data in the web

オープンストリートマップは, Wikipediaのようなサイトに触発されました. 地図の表示 (図_OpenStreetMap_1 参照) では「編集」タブが特徴的で, リビジョンの履歴が全て保持されています. 登録ユーザはGPSトラックログをアップロードでき, 編集ツールを使ってベクタデータの編集を行うことができます.

OSMデータの大本は, APIによってサーバに保存できるオブジェクトクラスです. サポートされるデータは, ノード, ウェイ, **リレーション**の3種類です.

  • **ノード(node)**は, 緯度/経度の座標です. 他の地物をつくるためのブロックであったり, 地物そのもの (Points Of Interest: POI) であったりします. タグは必要に応じて付けられます.

  • **ウェイ(way)**は, 2個以上のノードの組合わせで, 道路をはじめとした線形の地物を表現します. 同じノードを複数のウェイに用いることができます.

  • **リレーション(relation)**は, ロールと結びついたゼロまたはそれ以上のプリミティブのグループです. オブジェクト間の関係を定義する場合に指定します. 抽象オブジェクトを作る場合もあります.

一般的な地図にあるさまざまな地物(POI, 道路, 鉄道, バス停など) は, これらのプリミティブによって定義されます. 地図の地物はOSMコミュニティの中では周知のもので, キーと値を利用したタグとして保存されます. OSMは通常, XML形式で配布されます. XML ペイロードはOSMサーバーとの通信にも利用されています.

QGIS-OSMの接続

このセクションの最初のパートでは, OSMプリミティブがQGISのベクタレイヤでどのように表示されるかを説明します. 上記のように, OSMデータはノード, ウェイ, リレーションで構成されています. QGISでは, ポイントレイヤ, ラインレイヤ, ポリゴンレイヤの3種類の異なるレイヤタイプで表示されます. これらのレイヤはどれも必要ですし, さらに別のレイヤが加わることもありません.

  • **ポイント(Point)レイヤ**は, 単独のノードタイプの地物を表示します. ウェイに属していないノードはすべてポイントレイヤに属することになります.

  • **ライン(Line)レイヤ**は, 閉じていないウェイタイプのOSM地物を表示します. 閉じていないとは, ウェイの始点と終点が異なるノードであるということです.

  • **ポリゴン(Polygon)レイヤ**は, ラインレイヤに含まれないすべてのウェイを表示します.

上記の3つに加え、オープンストリートマップはもう1つのプリミティブを持っています。これをリレーションと呼びます。リレーションを示すためのベクタレイヤーは意図的には用意されていません。リレーションは任意の数のデータ・プリミティブを接続するために定義されます。ポイント、ライン、ポリゴンが地図上で特定された後、プラグインは、すべてのリレーションのリストを表示します。

これは、OSMのデータと標準的なQGISの編集ツールとの関係をデザインすることを試みていました。どのような地物タイプであるかにかかわらず、これらのツールは一度に1つのベクタレイヤーを編集します。これは、OSMデータがプラグインを通してQGISにロードされる場合、(理論的には)個別にこれらのツールを使って、ポイントレイヤー、ラインレイヤー、ポリゴンレイヤーを編集できることを意味します。

ラインレイヤーは、ウェイトノードという異なる2つのタイプのOSMフィーチャで構成されています。OSMフォーマットでは、ウェイはノードで構成されます。もしあなたがラインの形状を変えるためにラインレイヤーの編集を開始するなら、あなたのアクションはOSMのウェイだけでなく、その一部であるOSMのノードだけにも影響します。

QGIS標準の編集ツールは、OSMのプロバイダー、およびどのラインがどのように変更されたかを見分けることはできません。これは、どのラインが新しいジオメトリかということを見分けるだけで、OSMデータベースに対する変更を正しく伝えるには十分ではありません。ラインレイヤーはラインメンバーの識別子を知りません。同様の問題は、あなたがポリゴンレイヤーを編集しようとする際にも発生します。

この理由として、OSMプラグインはOSMデータを編集するための、それ自身のツールが必要です。それを使用すると、OSMレイヤは正しく変更されます。編集ツールのプラグインは、ポイント、ライン、ポリゴン、そしてリレーションの作図や削除、移動をするためのツールで構成されます。

ノート

OSMプラグインと標準の編集ツールをリンクするには、QGISコアコードの変更が必要であろう。

インストール

OpenStreetMapプラグインはQGIS内部のコアプラグインです。ref:`load_core_plugin`のセクションで記載されている通り、その ‘OpenStreetMap’プラグインは 、プラグインマネージャで選択出来ます。

基本的なユーザインタフェース

The first time the OSM plugin is started (and after the first data are loaded), several new OSM plugin icons appear in the QGIS toolbar menu together with new dock windows as shown in figure_OpenStreetMap_2.

Figure OpenStreetMap 2:

../../../_images/osm_widgets.png

OSM plugin user interface

OSMフィーチャーウィジェット

OSMフィーチャーウィジェットはOSMの地物を識別するのに役立ちます。誰によっていつ地物が変更されたかの情報だけでなく、フィーチャータイプや識別子の基礎情報を表示します。OSMフィーチャーウィジェットは、すべての編集ツールを(それの上の部分で)用意されています。これらのツールの詳細については、以下のセクションで見つけることができます。ウィジェットは最初は無効になっています。OSMデータのロードに成功した後、ウィジェットは有効になります。

OSM Undo/Redo ウィジェット

このUndo/Redoウィジェットは編集行為を元に戻す処理と繰り返す処理を行うために使われます。これは典型的なUndoとRedoのボタンのみで構成されているのではなく、行った編集処理の簡潔な説明もリスト表示します。OSM Undo/Redo ウィジェットは初期設定では非表示ですが、OSMフィーチャーウィジェットボタンを使うことで表示できます。

ツールバーのメニューアイコン

osm_load :sup:`Load OSM from file`は特定のOpenStreetMap XMLからデータをロードするために使われます。

osm_featureManager Show/Hide OSM Feature Manager はOSMフィーチャーウィジェットの表示・非表示を切り替えるために使用されます。OSMフィーチャーウィジェットはOSMの地物の特定やOSMのデータ編集を補助するためのパネルです。

osm_download Download OSM data はOpenStreetMapサーバーよりデータをダウンロードする際に使用されます。

osm_upload :sup:`Upload OSM data`は(現状のデータでの)変更をアップロードする際に使用されます。

osm_import Import data from a layer はベクタレイヤーからデータをインポートする際に使用されます。少なくとも1つのベクタレイヤーがロードされ、現状のOSMデータが選択されます。

osm_save Save OSM to file はOSMデータをXMLファイルに戻してから保存する際に使用されます。

すべてのウィジェット、ボタン、ダイアログの詳細については、これらの機能(編集、識別など)に応じて、このプラグインの適切なセクションで見つけることができます。

OSMデータの読み込み

OSMプラグインの開始後にされるべき最初のアクションとしては、OSMファイルからデータを開くことです。OSMデータはShapeファイルとしてインポートされるか、OpenStreetMapサーバーから直接ダウンロードします。ここでは、前者の方法に焦点を当てます。

To load data from a file use the osm_load Load OSM from file icon. If there is no such button, maybe someone disabled OpenStreetMap toolbar in your QGIS installation. You can enable it again selecting Settings ‣ Toolbars ‣ OpenStreetMap.

Figure OpenStreetMap 3:

../../../_images/osmloaddialog.png

Load OSM data dialog

その要素の目的について説明します。

OpenStreetMap file to load: Click on the browsebutton button to select the file:.osm file you want to load data from.

Add columns for tags: このオプションはOSMとQGISデータの接続を決定します。OSMデータの書く要素はいくつかのタグ(キーと値の組み合わせ)を持っていて、地物の属性を定義しています。QGISベクターレイヤーの各地物もまた、その属性(キーと値)を持っています。このオプションで、QGISの地物の詳細情報をいつ表示し、OSMオブジェクトのどの属性を表示するかを定義することができます。

Replace current data: このオプションのチェックは、新しいデータと、ユーザが作業した現状のデータを置き換えるかを意味します。現状データのレイヤーは削除され、新しいデータがロードされます。最初にOSMデータをロードする際は置き換え対象がないため、このオプションはアクティブではありません。

Use custom renderer: This option determines how many details of the map will be used. There are three pre-defined OSM styles for map displaying. Use ‘Small scale’ if you want to view OSM data at low level, to see all details and to edit something. If not you can use ‘Medium scale’ or ‘Large scale’. QGIS 1.8.0 doesn’t support changing the renderer style dynamically.

データを読み込むには**[OK]**をクリックします。初めてOSMファイルがロードされる場合は、プラグインは初めてデータベースを解析するに違いありません。これには数秒か数分かかると思いますが、それはロードするデータ量に依ります。

OSMデータの表示

OSMデータをロードした後、適切なツールを使ってマップの地物を特定することができます。OSMフィーチャーウィジェットの左上にある|osm_identify| Identify feature ボタンを使用します。このツールを使うと、すべてのマップオブジェクトを簡単に調べることができます。マウスカーソルをオブジェクト上に配置すると、OSMフィーチャーウィジェットで直接、そのオブジェクトすべての情報を表示できます。マップ上には動的なラバーバンドが表示されるため、ユーザは、どの地物が現在識別されているかを決定することができます。

ウィジェットのguilabel:`Properties`タブでは、地物のタグすべてが含まれています。guilabel:`Relation`タブでは特定の地物を接続するリレーションのリストが表示されます。

そのプロパティとリレーションを読み込むためにしばらくの間機能を停止するには、同時にマウスカーソルを移動して、地物上で左クリックします。特定プロセスは、次に左クリックするまでの間停止します。

左クリックが行われた時、その地点に複数のちぶつがある場合がある。これは特に、交差点をクリックした 場合やマップを十分にズームしないで行った場合に起こる。この状況では1つの地物のみが識別される(ラバーバンドが付けられる)。しかし、プラグインはそれらすべてを記憶している。その後(一時停止モード)は、右クリックで、識別された地物を循環閲覧できる。

基礎的なOSMデータの編集

‘Basic data’ in this context means non-relational OSM features - nodes and ways. If you prefer to examine how to perform relational editing, skip this section and move on to the next one.

基礎データの編集はOSMプラグインの重要な部分です。プロパティや、いかなる基礎の地物の位置や形状を変更することができます。地物の削除または追加ができます。ノードとウェイに対するすべての変更内容は、Undo/Redoによって記憶され、すべての変更はOpenStreetMapサーバにすぐにアップロードされます。

地物のタグの変更

OSM地物のプロパティ/タグの変更はテーブルの地物タグで直接行うことができます。基本的な地物のタグテーブルはOSMフィーチャーウィジェットで見つけることができます。最初に地物を特定することを忘れないでください。

Figure OpenStreetMap 4:

../../../_images/osm_changefeaturetag.png

Changing an OSM feature tag

If you want to change a tag value, just double-click in the appropriate row of column ‘Value’ and type, or select a new value. If you want to remove a tag, click in the relevant row, then use the button osm_removeTag Remove selected tags on the right bottom under the table.

新しいタグを追加するには、 ‘<next tag value>’と書かれたテーブルの最終行にキーと値をタイプします。存在しているタグのペアのキーを編集できないことに注意してください。便利なことに、すべての既存のタグキーと典型的な値のコンボボックスがあります。

点の作図

ポイントを作図するには、OSMフィーチャーウィジェット上にある|osm_createPoint| :sup:`点の作成`ボタンを使用します。いくつかのポイントを作図するには、そのボタンをクリックし、マップ上のクリックを開始します。いくつかの地図の地物にマウスカーソルを配置すると、その地物が直ちにマーク/識別されます。ラインまたはポリゴンがマークされ地図上をクリックすると、そのラインまたはポリゴンに、それらの新規メンバーとして、直接的に新しいポイントが作成されます。このような場合、OSMプラグインは、次のメッセージを表示します:

Figure OpenStreetMap 5:

../../../_images/osm_pointcreation.png

OSM point creation message

ラインまたはポリゴンをヒットするためにユーザーを助ける仕組みはスナップと呼ばれ、デフォルトで有効となってます。ラインの非常に近く(ただしライン上ではない)に点を作成したい場合は、最初に kbd:`Ctrl`キーを押すことでスナップを無効にしなければいけません。

ラインの作図

ラインを作図するには、OSMフィーチャーウィジェットの osm_createLine :sup:`線の作成`ボタンを使用します。ラインを作成するためそのボタンをクリックし、マップ上の左クリックを開始します。それぞれの左クリックは新しいラインの頂点として記憶されています。初めて右クリックするとラインの作図が終了します。新しいラインは直ちにマップ上に表示されます。

ノート

A Line with less than two members cannot be created. In such case the operation is ignored.

スナップは地図上のすべての頂点-ポイントベクターレイヤ由来のポイントとすべてのラインおよびポリゴンのメンバーに対して実行されます。スナップは、kbd:`Ctrl`キーを押すことで無効にすることができます。

ポリゴンの作図

ポリゴンを作成するには 、OSMフィーチャーウィジェット上の|osm_createPolygon| Create polygon`ボタンを使用します。ポリゴンを作成するためにこのボタンをボタンをクリックし、マップ上で左クリックを開始します。それぞれの左クリックが、新しいポリゴンのメンバーとなる頂点として記憶されます。初めて右クリックするとポリゴンの作図が終了します。新しいポリゴンは直ちにマップ上に表示されます。3つ未満のメンバーで構成されたポリゴンを作成することはできません。そのような場合、操作が無視されます。スナップはマップ上の頂点すべて-点(ポイントベクターレイヤ由来)やすべてのラインおよびラインのメンバーに対して行われます。スナップはkbd:`Ctrl キーを押すことで無効にできます。

マップ上の地物の移動

もし(種類に関係なく)地物を異動したい場合は、OSM地物ウィジェットメニューの|osm_move| Move feature ボタンを使用してください。それからマップ(あなたがそれを繰り返し行うとき、地物が動的に特定される)を表示することができ、移動したい地物をクリックすることができます。適切な地物が特定されるまで、右クリックを繰り返してください。選択が完了しカーソルを移動すると、何を移動するかを変更することはできません。移動を確認するには、マウスの左ボタンをクリックしてください。移動をキャンセルするには、別のマウスボタンをクリックします。

別の地物に接続している地物を移動する場合、これらの接続が損傷することはありません。他の地物は、移動した地物の新しい位置に適応するのみです。

スナップはこの操作においてもサポートされています。これは以下を意味します。

  • 単体のポイント(ライン/ポリゴンの一部でないもの)を移動する場合、マップのセグメントと頂点すべてに対するスナップが行われる。

  • ライン/ポリゴンのメンバーであるポイントを移動する場合、ポイントの親の頂点は除くすべてのマップセグメントと頂点に対してスナップが行われる。

  • ライン/ポリゴンを移動する場合、すべてのマップの頂点に対してスナップが行われます。OSMプラグインは、移動したライン/ポリゴンの持つカーソルに近接した3つの頂点に対してのみスナップを試みる点にご注意ください。そうでないと動作が非常に遅くなります。操作中にkbd:Ctrl キーを押すことでスナップを無効にすることができます。

マップの地物の移動

地物を削除したい場合は、まずそれを特定する必要があります。特定した地物を削除するには OSM地物ウィジェットの|osm_removeFeat| :sup:`この地物の削除`ボタンを使用します。ライン/ポリゴンを削除すると、それ自身のメンバーであって、他のライン/ポリゴンに属していないポイントもすべて削除されます。

ライン/ポリゴンのメンバーであるポイントを削除すると、ポイントが削除され、親であるライン/ポリゴンの形状は変更されます。新しい親の形状は、古いものよりも頂点が少なくなっています。

もし親地物が3つの頂点を持つポリゴンであれば、その新しい形状は、2つの頂点しか持ちません。2つの頂点しか持たないポリゴンは存在し得ないため前述のとおり、その地物タイプは自動的にラインに変更されます。

もし親地物が2つの頂点を持つラインであれば、新しい形状は1つの頂点しか持ちません。1つのみの頂点で構成されたラインは存在し得ないため、地物タイプが自動的にポイントに変更されます。

リレーションの編集

OSMリレーションが存在するおかげで、グループにOSMの地物を結合し、それらに共通のプロパティを付与することができます。そのような方法で、地域の境界(ウェイやポイントのグループとして)、バスルート等など、私たちは任意のマップオブジェクトをモデル化することができます。リレーションの各メンバーはそれ特有のロールを持ちます。我々のプラグインでは、OSMリレーションに取ってかなり良いサポートがあります。それらをどのように分析し、作成し、更新または削除するか見てみましょう。

リレーションの分析

もしリレーションの属性を参照したいなら、メンバーの1つを特定しましょう。それから、OSM地物ウィジェットのguilabel:`リレーション`タブを表示します。 タブの上部で、特定された地物を含むすべてのリレーションがリスト表示されます。分析したい1つを選択すると、その情報が下に表示されます。1つ目のテーブルは’リレーションタグ’と呼ばれ、選択したリレーションの属性を見つけることができます。1つのメンバーをクリックすると、プラグインは、地図上にラバーバンドを作成します。

リレーションの作成

リレーションの作成方法は2つあります:

  1. OSM地物ウィジェットの|osm_createRelation|:sup:`リレーションの作成`ボタンを使用することができます。

  2. OSM地物ウィジェットのguilabel:`リレーション`タブにある|osm_addRelation|:sup:`リレーションの追加`ボタンを使用することで、リレーションを作成することができます。

どちらの場合も、ダイアログが表示されます。第二のケースでは、現在特定された地物が自動的に最初のリレーションメンバーと見なされ、ダイアログでは少々事前入力がなされます。リレーションを作成する際、そのタイプを選択してください。定義済のリレーションの種類または独自のタイプを記載することができます。それからリレーションタグを埋めたりメンバーを選択します。

すでにリレーションのタイプを選択した場合は、 osm_generateTags タグの作成`ボタンを使用してください。それにより、リレーションのタイプにとって典型的なタグを生成できます。それから、キーに値を入力することが期待されます。リレーションメンバーの選択はメンバー識別子やタイプ、ロールを書くことか、|osm_identify| :sup:`地図上でメンバーの選択 ツールを使用してマップ場をクリックすることにより可能です。

タイプ、タグ、メンバーを選択したら、ダイアログの内容を確定できるようになります。その場合、プラグインは新しいリレーションを作成します。

リレーションの変更

既存のリレーションを辺既往するには、まずそれを選択します(上記のref:`examining_relation`のセクションに記載されたステップにしたがってください)。その後|osm_editRelation| :sup:`リレーションの編集`ボタンをクリックします。 それは、OSM地物ウィジェット上にあります。ダイアログが表示されると、 ‘リレーションの作成’とほぼ同様でしょう。そのダイアログでは、与えられたリレーションの情報があらかじめ入力されています。あなたはリレーション、メンバーとそのタイプのタグを変更できます。ダイアログの内容を確定すると、変更内容がコミットされます。

OSMデータのダウンロード

To download data from OpenStreetMap server click on the osm_download Download OSM data button. If there is no such button, the OSM toolbar may be disabled in your QGIS instalation. You can enable it again at Settings ‣ Toolbars ‣ OpenStreetMap . After clicking the button a dialog occurs and provides following functionalities:

Figure OpenStreetMap 6:

../../../_images/osm_downloaddialog.png

OSM download dialog

範囲:緯度と経度度の間隔からデータをダウンロードする領域を指定します。OpenStreetMapのサーバー上でダウンロード可能なデータ量の制限があるため、間隔を広げすぎてはいけません。領域の仕様におけるより詳細な情報は、右側の|osm_questionMark| :sup:`ヘルプ`ボタンをクリックした後に表示されます。

ダウンロード先:ここでは、データが格納されるファイルのパスを記述することが期待されています。あなたのディスクの構造を思い出せない場合は、パニックにならないでください。参照ボタン| browsebutton|があなたを助けるでしょう。

ダウンロード後に自動的にデータを開く:ダウンロードプロセス後にデータのロード処理をを行うかどうかを決定します。データをロードしたくない場合は、 osm_load :sup:`Load OSM from file`ボタンを使用して、後からロードします。

カレントデータの置き換え:このオプションは|radiobuttonon| :guilabel:`ダウンロード後自動的にデータを開く`にチェックが入っている場合のみ有効です。 このオプションにチェックを入れるとダウンロードデータが、現在作業しているデータと置き換えられます。現在のデータのレイヤは削除され、新しいものがロードされます。QGISを起動して初めてOSMデータをダウンロードする場合、置き換え対象がないため、このオプションは非アクティブです。

Use custom renderer: This option is active only if the radiobuttonon Open data automatically after download checkbox is checked. It determines how many details will be in the map. There are three predefined OSM styles for map displaying. Use ‘Small scale’ if you want to view OSM data at low level, to see all details and to edit something. If not you can use ‘Medium scale’ or ‘Large scale’. QGIS 1.8.0 does not support changing the renderer style dynamically.

ダウンロード処理を開始するには **[Download]**ボタンをクリックします。

プログレスダイアログが、すでにダウンロードされたデータがどれくらいあるかを継続的に知らせます。ダウンロードプロセス中にエラーが発生した場合、ダイアログが原因を知らせます。アクションが正常に終了すると、プログレスダイアログとダウンロードダイアログの両方が閉じられます。

OSMデータのアップロード

Note that the upload is always done on current OSM data. Before opening the OSM Upload dialog, please be sure that you really have the right active layer with OSM data.

To upload current data to the OSM server click on the osm_upload Upload OSM data button. If there is no such button, OSM toolbar in your QGIS installation is disabled. You can enable it again in Settings ‣ Toolbars ‣ OpenStreetMap . After clicking the [Upload] button a new dialog will appear.

Figure OpenStreetMap 7:

../../../_images/osm_uploaddialog.png

OSM upload dialog

正しいデータをアップロードする場合は、ダイアログの上部でチェックすることができます。現在のデータベースの短い名前があります。テーブルでは、どのくらいの変更がアップロードされるかの情報を見つけます。統計情報は、各地物の種類ごとに個別に表示されます。

‘あなたの変更についてのコメント’ボックスには、アップロード操作の意味について簡単な情報を書き込むことができます。ちょっと手短に言えば、データに何の変更を行ったかを書くか、ボックスを空にしておいてください。サーバがあなたを認証できるように’OSM アカウント’の列を埋めてください。もしOSMサーバーにアカウントを持っていない場合、 http://www.openstreetmap.org で作成するのには最高の時です。最終的に**[アップロード]**を使用してアップロード操作を開始します。

OSMデータの保存

To save data from a current map extent to an XML file click on the osm_save Save OSM to file button. If there is no such button, the OSM toolbar in your QuantumGIS installation is probably disabled. You can enable it again in Settings ‣ Toolbars ‣ OpenStreetMap. After clicking on the button a new dialog appears.

Figure OpenStreetMap 8:

../../../_images/osm_savedialog.png

OSM saving dialog

XMLファイルとファイル自体に保存したい地物を選択します。 **[OK]**ボタンを使用して操作を開始します。そのプロセスで、カレントのマップ領域で表現されたOSMデータをXMLファイルとして作成します。出力ファイルのOSMバージョンは0.6です。OSMデータの要素(<node>, <way>, <relation>)は、その変更セットとuidの情報を含みません。この情報はまだ必須のものではなく、OSM XMLバージョン0.6のDTDを参照してください。出力ファイルではOSMの要素が順序付けされていません。

現在の範囲外のデータも保存されていることに注意してください。それらのほんの一部が現在の範囲に表示されている場合でも、それら全体のポリゴンや線が出力ファイルに保存されます。保存されたライン/ポリゴンとそのメンバーであるノードすべても同様に保存されます。

OSMデータのインポート

To import OSM data from an opened non-OSM vector layer follow this instructions. Choose current OSM data by clicking on one of their layers. Click on the osm_import Import data from a layer button. If there is no such button, someone has probably disabled the OpenStreetMap toolbar in your QGIS installation. You can enable it again in Settings ‣ Toolbars ‣ OpenStreetMap.

そのボタンをクリック後に、以下のメッセージが表示されるでしょう:

Figure OpenStreetMap 9:

../../../_images/osm_importdialog.png

OSM import message dialog

In such case there is no vector layer currently loaded. The import must be done from a loaded layer - please load a vector layer from which you want to import data. After a layer is opened, your second try should give you a better result (don’t forget to mark the current OSM layer again):

Figure OpenStreetMap 10:

../../../_images/osm_importtoosmdialog.png

Import data to OSM dialog

OSMデータのインポート処理を開始するにはサブミットダイアログを使用します。あなたが何かをインポートしたいかわからない場合、それを拒否します。