Outdated version of the documentation. Find the latest one here.

OpenStreetMap

Il progetto OpenStreetMap (OSM) si sta ampiamente diffondendo, sopratutto in quei paesi dove non si hanno a disposizione dati geografici liberi. L’obiettivo di OSM è la creazione di una mappa aggiornabile e libera del mondo a partire da dati GPS, foto aeree e conoscenza locale. Per supportare tale obiettivo, QGIS mette a disposizione un plugin che permette di lavorare con i dati OSM.

Il plugin offre le principali funzionalità per la manipolazione dei dati OSM; download/upload dei dati, salvataggio, modifica. Nell’implementare il plugin, il team di sviluppo ha preso ispirazione dagli editor di dati OSM esistenti, nell’obiettivo di combinare le loro funzionalità in un unico prodotto.

La sezione seguente, fornisce una breve introduzione ai principi del progetto OSM.

Parti del paragrafo che segue sono riprese dal sito web di OpenStreetMap: http://www.openstreetmap.org <http://www.openstreetmap.org>.

Il progetto OpenStreetMap

L’obiettivo di OSM è la creazione di una mappa aggiornabile e libera del mondo a partire da dati GPS, foto aeree e conoscenza locale. Il progetto è stato iniziato perché molti dati geografici hanno restrizioni legali e tecniche, che impediscono il loro utilizzo in maniera creativa e produttiva. I dati di OSM e le immagini da esse derivate sono, invece, disponibili sotto la licenza Creative Commons Attribution ShareAlike 2.0.

Figure OpenStreetMap 1:

../../../_images/osmweb.png

OpenStreetMap data in the web

OpenStreetMap si è ispirato a progetti tipo Wikipedia: la mappa di OSM (Figura Figure_OpenStreetMap_1 ) mostra una ben visibile scheda Edit e viene mantenuto lo storico di tutte le modifiche effettuate. Gli utenti registrati possono caricare track GPS ed editare dati vettoriali utilizzando gli editor disponibili.

La ’primitiva dati’ di OSM è una classe oggetto che può essere memorizzata via API nel server. I tre tipi di dati supportati sono: Node (nodo), Way (via) e Relation (relazione).

  • Un nodo è una coppia latitudine/longitudine di coordinate: è il punto di partenza per la costruzione di tutti gli altri elementi ed è un elemento esso stesso (POI - Point of Interest).

  • Una via è un elenco di almeno due nodi che descrivono un elemento lineare, es. una strada. I nodi possono essere parte di più ’vie’.

  • Una relazione è un gruppo di zero o più primitive con ruoli associati. È usata per specificare il rapporto tra oggetti e per modellare un oggetto astratto.

Queste primitive sono usate per definire diversi elementi logici di una mappa (’Point Of Interest’, ’Street’, ’Tram Line’, ’Bus Stop’ etc.). Gli elementi di mappa sono ben noti nella comunità OSM e sono memorizzati tramite etichette basate su una chiave ed un valore. I dati OSM sono solitamente distribuiti in formato XML, che è usato anche per la comunizazione con i server OSM.

QGIS - Connessione a OSM

La prima parte di questa sezione descrive come le primitive OSM sono visualizzate QGIS. Come precedentemente descritto, i dati OSM consistono di ’node’, ’way’ e ’relation’. In QGIS le tre primitive vengono visualizzate con differenti tipi di layer: punti, linee, poligoni. Non è possibile rimuovere uno di questi layer e lavorare con i rimanenti.

  • Un layer di punti visualizza i soli elementi di tipo ’node’ che non sono parte di ’way’.

  • Un layer di linee visualizza gli elementi di tipo ’way’ non chiusi (a formare poligoni): nessuna delle ’way’ inizia e finisce nello stesso ’node’.

  • Un layer di poligoni visualizza tutte le ’way’ non incluse nel layer di linee, cioè le linee chiuse.

In aggiunta alle tre primitive OSM appena descLe Relation non sono visualizzate come layer vettoriale in quanto servono a definire le connessioni tra le altre primitive dati: dopo che un punto/linea/poligono è individuato sulla mappa, il plugin mostra un elenco delle relazioni di cui l’elemento è parte.

Ha richiesto un notevole impegno tentare di collegare i dati OSM con gli strumenti di modifica standard di QGIS. Tali strumenti sono fatti per modificare un singolo layer alla volta, a prescindere dal tipo di elemento: ciò significa che se i dati OSM venissero caricati in QGIS tramite il plugin, sarebbe teoricamente possibile modificare i layer di punti, di linee, di poligoni separatamente con gli strumenti standard.

Un layer di linee consiste di due diversi tipi di elementi OSM, ’node’ e ’way’. Nel formato OSM, una ’way’ è composta di ’node’; se si modifica un layer di linee, ad esempio cambiando la forma di qualche elemento, tale azione influenza anche i ’node’ che sono parte dello stesso.

Gli strumenti di modifica standard di QGIS non sono in grado di gestire tale tipo di relazioni e inviare correttamente le modifiche alla banca dati OSM. Il layer di linee non tiene traccia di quali ’node’ sono parte di quale ’way’: lo stesso problema si ha con i layer di poligoni.

Per tale ragione, il plugin OSM necessita dei propri strumenti di modifica, tramite i quali le modifiche ai layer OSM vengono gestiti correttamente. Gli strumenti di modifica del plugin permettono di creare/muovere/eliminare punti, linee, poligoni, relazioni.

Nota

Nota: Per creare una connessione tra il plugin OSM e gli strumenti di modifica standard di QGIS, sarebbero necessarie modifiche a livello di codice.

Installazione

Il plugin OpenStreetMap è un plugin core di QGIS. Se il supporto a python è abilitato, il plugin può essere attivato nel gestore di plugin, come descritto nella Sezione Abilitare un Plugin Core.

Interfaccia utente di base

In seguito all’attivazione del plugin OSM, ed al caricamento di alcuni dati, nel menu delle barra degli strumenti di QGIS appaiono diverse icone OSM, insieme alla nuova componente grafica mostrata in Figura figure_OpenStreetMap_2.

Figure OpenStreetMap 2:

../../../_images/osm_widgets.png

OSM plugin user interface

Pannello Elemento OSM

Il pannello Elemento OSM consente di identificare gli elementi OSM, fornendo informazioni sul tipo di elemento, sul suo identificatore, su chi l’ha modificato e quando: in esso sono, inoltre, presenti tutti gli strumenti di modifica, di seguito descritti. Il pannello è inizialmente disabilitato: viene abilitato al caricamento di dati OSM.

Pannello Storico modifiche OSM

Il pannello ’Storico modifiche OSM’ permette di annullare/ripristinare le modifiche più recenti. Oltre ai pulsanti classici di annulla/ripristina, mostra una lista con una breve descrizione delle operazioni di modifica più recenti. Il pannello, inizialmente nascosto, può essere attivato con l’apposito pulsante del pannello Elemento OSM.

Icone nel menu della barra degli strumenti

osm_load Load OSM from file permette di caricare dati da file OSM in XML.

osm_featureManager Show/Hide OSM Feature Manager permette di visualizzare/nascondere l’Elemento OSM. L’ Elemento OSM è un pannello che aiuta ad identificare e modificare gli elementi OSM.

osm_download Download OSM data per scaricare dati dai server di OpenStreetMap.

osm_upload Upload OSM data permette di salvare le modifiche ai dati correnti.

osm_import Import data from a layer permette di importare dati da layer vettoriali: è necessario caricare almeno un layer vettoriale e selezionare alcuni dati OSM.

osm_save Save OSM to file permette di salvare dati OSM in un file XML.

Informazioni più dettagliate sui vari elementi, comandi e maschere di dialogo, possono essere rinvenute nelle relative sezioni di questo capitolo, in relazione alla loro funzione (modifica, identificazione, ecc..).

Caricare dati OSM

La prima azione dopo aver lanciato il plugin consiste nell’aprire alcuni dati da un file OSM: i dati OSM possono essere importati come shapefile o scaricati dai server di OSM. Qui di seguito ci si riferisce alla prima modalità.

Per caricare dati da un file utilizzare l’icona osm_load Load OSM from file: se l’icona non è visualizzata, il plugin potrebbe essere stato disabilitato durante l’installazione di QGIS. Abilitarlo da Visualizza‣ Barre degli strumenti ‣ OpenStreetMap.

Figure OpenStreetMap 3:

../../../_images/osmloaddialog.png

Load OSM data dialog

La funzione dei suoi elementi è spiegata di seguito.

File OpenStreetMap da caricare:Cliccare sul pulsante browsebutton per selezionare il file .`.osm` da cui si vogliono caricare i dati.

Aggiungi colonne per i tag: permette di creare una connessione tra OSM e QGIS. Ogni elemento OSM ha alcune etichette (coppia chiave-valore) che ne definiscono le proprietà: anche ogni elemento di un layer vettoriale di QGIS ha i propri attributi (chiave-valore). Con questa opzione è possibile definire quali proprietà degli oggetti OSM devono essere visibili quando si visualizzano le informazioni dell’elemento QGIS.

Sostituisci i dati in uso: attivando l’opzione, i nuovi dati sostituiscono quelli su cui l’utente stava precedentemente lavorando. Se si sta caricando dati OSM per la prima volta, l’opzione non è attiva.

Usa un visualizzatore personalizzato: consente di determinare quanti dettagli della mappa visualizzare (si può scegliere tra Small scale, Medium scale, Large scale). Usare Small scale per visualizzare il massimo dei dettagli e compiere delle modifiche ai dati. QGIS 1.8.0 non supporta il cambiamento dinamico del visualizzatore.

Cliccare su [OK] per caricare i dati: l’operazione potrebbe richiedere alcuni minuti nel caso il file fosse caricato per la prima volta.

Visualizzare dati OSM

Una volta caricati i dati è possibile ottenere informazioni sui vari elementi tramite l’icona osm_identify Informazioni elemento nel pannello Elemento OSM. In questo modo è possibile esplorare facilmente tutte gli oggetti sulla mappa. Posizionando il cursore del mouse su un elemento di interesse, le informazioni relative vengono mostrate nel pannello suddetto: nella vista mappa l’elemento risulta evidenziato. Un collegamento dinamico sulla mappa consente inoltre all’utente di identificare facilmente l’ elemento correntemente selezionato.

La scheda Proprietà del pannello Elemento OSM contiene tutte le etichette dell’elemento: la scheda Relazioni mostra, invece, tutte le relazioni connesse all’elemento in questione.

Si noti che allontanando il cursore del mouse dall’elemento di interesse, le relative informazioni scompaiono: cliccando con il tasto sinistro del mouse sull’elemento, invece, le informazioni restano visibili sino ad un successivo click.

Spesso nel punto in cui si clicca potrebbero essere presenti più elementi, specialmente nel caso di incroci di strade. In questa situazione, anche se sono mostrate le informazioni di un solo elemento (marcato dal collegamento dinamico), il plugin mantiene in memoria le informazioni di tutti: E’ quindi possibile (sempre in modalità “pausa”) scorrere le informazioni degli altri elementi con cliccando con il tasto-destro e selezionando i successivi.

Modificare dati OSM

Si intendano per “dati di base” gli elementi OSM ’node’ e ’way’ non relazionali. Per le modifiche di elementi relazionali fare riferimento alla sezione dedicata.

La modifica dei dati di base è una delle caratteristiche sostanziali del plugin OSM. È possibile rimuovere/aggiungere elementi di base, modificarne le proprietà, la posizione, la forma. Tutti i cambiamenti sono elencati nel pannello ’Storico modifiche OSM’ e possono essere facilmente caricati sui server di OSM.

Cambiare l’etichetta di un elemento

Il cambiamento dell’etichetta di un elemento OSM viene fatto direttamente nella tabella delle etichette: tale tabella si trova nel pannello Elemento OSM, ma per visualizzarla bisogna preventivamente usare lo strumento osm_identify Informazioni elemento. Ricordarsi di selezionare preventivamente l’elemento.

Figure OpenStreetMap 4:

../../../_images/osm_changefeaturetag.png

Changing an OSM feature tag

Per cambiare il valore di un’etichetta, fare doppio-click in una casella della colonna ’Value’ ed inserire, o selezionare, il nuovo valore. Per rimuovere un’etichetta selezionarne la riga e cliccare su osm_removeTag Remove selected tags in fondo alla tabella sulla destra.

Per inserire una nuova etichetta, inserire chiave e valore nell’ultima riga della tabella, dove appare la scritta ‘<next tag value>’: non è possibile cambiare la chiave di un coppia ’key/value’ esistente. Una serie di menu a tendina permettono di selezionare tra i valori tipici di una specifica chiave.

Creare punti

Per creare un nuovo punto, cliccare su osm_createPoint Crea punto, quindi sulla mappa. Se il cursore del mouse passa sopra qualche elemento della mappa, l’elemento viene evidenziato e le sue informazioni appaiono nel pannello Elemento OSM; se si clicca sulla mappa quando una linea o un poligono sono evidenziati, il nuovo punto viene creato direttamente su questi elementi e sarà, quindi, parte di essi (è attiva una funzionalità di snap). Non si può creare un punto su un punto esistente: il plugin mostrerà il seguente messaggio:

Figure OpenStreetMap 5:

../../../_images/osm_pointcreation.png

OSM point creation message

Il meccanismo che aiuta l’utente a selezionare una linea o un poligono si chiama “snap”. Se si intende creare un punto molto vicino ad un elemento esistente, ma non su di esso, bisogna disabilitare la funzionalità di snap: tenere premuto Ctrl prima di cliccare sulla mappa.

Creare linee

Per creare una nuova linea, cliccare su osm_createLine Crea linea, quindi sulla mappa. Ogni click con tasto sinistro crea un vertice della nuova linea: per terminare la creazione di una linea basta cliccare con il tasto destro.

Nota

Nota: Non è possibile creare una linea con meno di due vertici: in tal caso l’operazione viene ignorata. Se si clicca con il tasto destro del mouse dopo un solo click con il tasto sinistro, nessuna linea viene creata.

Lo snap è attivo su ogni vertice della mappa - punti del layer di punti e tutte le componenti delle linee e dei poligoni. Per disattivare lo snap tenere premuto Ctrl prima di cliccare sulla mappa.

Creare poligoni

Per creare un nuovo poligono, cliccare su|osm_createPolygon| Create polygon, quindi sulla mappa. Ogni click con tasto sinistro sarà un vertice del nuovo poligono: per terminare la creazione di una linea basta cliccare con il tasto destro. Non possono essere creati poligoni con meno di tre vertici. Lo snap è attivo su ogni vertice della mappa - punti (su un layer di punti) e su tutte le componenti delle linee e dei poligoni. Per disattivare lo snap tenere premuto Ctrl prima di cliccare sulla mappa.

Spostare un elemento

Per spostare un elemento cliccare su osm_move Muovi elemento: posizionarsi nella mappa, portare il cursore del mouse sull’elemento che si intende spostare, cliccare con il tasto sinistro, portare l’elemento nella nuova posizione e cliccare di nuovo con il tasto sinistro. Nel caso si fosse selezionato l’elemento sbagliato, non effettuare il secondo click con il tasto sinistro: cliccando con il tasto destro, l’elemento sarà automaticamente riportato nella sua posizione originale.

Se si sposta una elemento connesso con altri elementi, le loro relazioni non saranno modificate: gli altri elementi si autoadatteranno alla nuova posizione dell’elemento cui sono relazionati.

Anche per questa operazione è disponibile la funzionalità di snap:

  • – quando si muove un punto singolo (cioè che non è parte di una linea/poligono), lo snap è attivo su tutti i vertici ed i segmenti in mappa.

  • – quando si muove un punto che è parte di una linea/poligono, lo snap è attivo su tutti i vertici ed i segmenti in mappa, tranne i vertici degli elementi di cui il punto fa parte.

  • – quando si muove una linea/poligono, lo snap è attivo su tutti i vertici in mappa. Si noti che il plugin cerca di basare lo snap sui 3 vertici della linea/poligono da spostare più vicini al cursore del mouse, altrimenti l’operazione sarebbe estremamente lenta. Per disattivare lo snap tenere premuto Ctrl prima di cliccare sulla mappa.

Eliminare un elemento

Per eliminare un elemento selezionarlo con Informazioni elemento e cliccare su Rimuovi elemento . Rimuovendo una linea/poligono, vengono rimossi anche tutti i punti che ne fanno parte (ma che non fanno parte di altre linee/poligoni).

Quando si rimuove un punto che fa parte di una linea/poligono, il punto è rimosso e la forma degli elementi cui apparteneva si modifica: la nuova geometria avrà meno vertici della precedente.

Se il punto da eliminare fa parte di un poligono con soli tre vertici, la nuova geometria del poligono avrà due vertici; ma siccome non possono esistere poligoni con due vertici, il tipo di elemento viene modificato automaticamente convertito in linea.

Se il punto faceva parte di una linea con due vertici, la nuova geometria della linea avrà un solo punto. E siccome non possono esistere linee di un solo punto, il tipo di elemento viene modificato in punto.

Modificare le relazioni

Le relazioni permettono di organizzare più elementi in gruppi ed assegnare loro proprietà comuni, in modo da poter modellare qualsiasi oggetto di mappa: es. confini di una regione come gruppo di ’way’ (linee) e ’node’ (punti), percorsi di un bus, etc. Ogni membro di una relazione ha un suo ruolo specifico. Il plugin di QGIS offre un buon supporto alle relazioni OSM. Di seguito viene riportato come esaminare, creare, aggiornare o rimuovere una relazione.

Esaminare una relazione

Per esaminare una relazione, selezionare prima un suo membro, quindi aprire la scheda Relazioni del pannello Elemento OSM, dove saranno elencate tutte le relazioni di cui l’elemento è parte. Selezionare una di esse per avere il dettaglio delle informazioni. Nella prima tabella, ’Tag relazione’, sono visualizzate le proprietà della relazione selezionata. Nella tabella ’Membri della relazione’ sono elencati i membri della relazione, cioè tutti gli elementi connessi dalla relazione selezionata. Cliccando su uno dei membri, lo stesso viene evidenziato in mappa.

Creare una relazione

Vi sono due modalità con cui è possibile creare una relazione:

  1. Usare il pulsante osm_createRelationCrea relazione del pannello Elemento OSM.

  2. Usare il pulsante Aggiungi relazione nella scheda osm_addRelationRelazioni del pannello Elemento OSM.

In entrambi i casi apparirà una finestra di dialogo. Nel secondo caso, l’elemento selezionato è automaticamente considerato il primo membro della relazione ed il dialogo è precompilato in minima parte. Selezionare un tipo di relazione, tra quelle predefinite e disponibili nel menu a tendina, o crearne una nuova, quindi inserire le etichette della relazione e selezionare i suoi membri.

Una volta selezionato un tipo di relazione, cliccare su osm_generateTags Genera i tags: nel riquadro ’Proprietà’ saranno elencate le etichette tipiche per il tipo di relazione. Inserire i valori nella colonna ’Value’ Per inserire i membri della relazione è possibile scrivere direttamente i loro identificatori, tipi e ruoli oppure usare il pulsante osm_identify Scegli un membro sulla mappa. Cliccare su Crea per terminare l’operazione.

Solo una volta scelto il tipo, etichetta e membro, la finestra di dialogo può ricevere conferma. Il plugin creerà quindi una nuova relazione.

Modificare una relazione

Per modificare una relazione esistente, selezionarla innanzitutto come visto nella precedente sezione ’Esaminare una relazione’, quindi cliccare su osm_editRelation Modifica relazione. Nella finestra di dialogo Edit OSM relation è possibile modificare le etichette, i membri o il tipo di relazione: cliccare su Save per salvare i cambiamenti.

Scaricare dati OSM

Per scaricare dati dal server di OpenStreetMap cliccare su osm_downloadDownload OSM data. Qualora il pulsante non fosse disponibile nell’interfaccia di QGIS, la barra degli strumenti OpenStreetMap potrebbe essere stata disattivata durante l’installazione di QGIS. Per attivarla cliccare su: menuselection:Visualizza –> Barre degli Strumenti –>OpenStreetMap . Apparirà quindi la finestra di dialogo Download dati OSM per fornire le seguenti funzionalità:

Figure OpenStreetMap 6:

../../../_images/osm_downloaddialog.png

OSM download dialog

Estensione: permette di impostare l’area da scaricare, indicando le coordinate i gradi di latitudine e longitudine. Prestare attenzione a non indicare un’area troppo vasta: il server di OpenStreetMap ha delle restrizioni sulla quantità di dati scaricabili. Ulteriori informazioni sull’estensione dei dati sono disponibili cliccando su osm_questionMark ?.

Download in: il percorso alla cartella in cui salvare i dati. Niente panico nel caso in cui non ci si ricordi la struttura dell’.hard disk.il bottone di navigazione browsebutton è pronto per aiutarvi.

Apri i dati automaticamente una volta scaricati: permette di definire se caricare i dati non appena scaricati. Se non si desidera caricare subito i dati disattivare l’opzione: i dati potranno essere caricati in un secondo momento cliccando su osm_load Load OSM from file.

Sostituisci i dati in uso: l’opzione è disponibile solo se lo è anche radiobuttonon Apri i dati automaticamente una volta scaricati. Attivando l’opzione, i dati scaricati andranno a sostituire quelli presenti nella vista mappa di QGIS: i layer presenti nella vista mappa saranno rimossi e sostituiti dai nuovi. Quando si avvia QGIS e si scaricano dati OSM per la prima volta, l’opzione non è attiva, in quanto non c’è nulla da sostituire.

Usa un visualizzatore personalizzato:l’opzione è attiva solo se lo è anche radiobuttonon Apri i dati automaticamente una volta scaricati. Determinare quanti dettagli della mappa visualizzare (scelta tra Small scale, Medium scale, Large scale). Usare Small scale per visualizzare il massimo dei dettagli e compiere delle operazioni di modifica. QGIS 1.8.0 non supporta il cambiamento dinamico dello stile del visualizzatore.

Cliccare su [Download] per avviare il processo di download dei dati.

Una finestra di dialogo mostra la percentuale di download. Qualora ci fossero errori, un’ulteriore finestra mostra il tipo di errore occorso. A completamento del download, le varie finestre di chiudono automaticamente.

Caricare i dati sul server OSM

Il caricamento dei dati sul server OSM riguarda i dati visualizzati nella vista mappa di QGIS: prima di caricare i dati assicurarsi che nella vista mappa siano visualizzati i dati corretti.

Per caricare i dati sul server OSM, cliccare su osm_uploadUpload OSM data. Qualora il pulsante non fosse disponibile nell’interfaccia di QGIS, la barra degli strumenti OpenStreetMap potrebbe essere disattivata: per attivarla cliccare su Visualizza ‣ Barre degli Strumenti ‣ OpenStreetMap. Verrà aperta la finestra di dialogo [Invia dati a OSM].

Figure OpenStreetMap 7:

../../../_images/osm_uploaddialog.png

OSM upload dialog

In alto nella finestra è possibile verificare la correttezza dei dati che si sta caricando. Nella tabella vengono elencati i cambiamenti che si stanno apportando, mentre sono riportate separatamente delle statistiche per ogni tipo di elemento.

In ’Commenti alle tue modifiche’ è possibile inserire delle informazioni aggiuntive: elencare brevemente le modifiche apportate. Compilare i campi ’Account OSM’ per l’autenticazione sul server: per creare un account OSM visitare la pagina web http://www.openstreetmap.org <http://www.openstreetmap.org>. Infine, cliccare [Upload] per avviare il processo di invio dei dati.

Salvare i dati OSM

Per salvare dati in un file XML, cliccare su osm_saveSave OSM to file. Qualora il pulsante non fosse disponibile nell’interfaccia di QGIS, la barra degli strumenti OpenStreetMap potrebbe essere disattivata: per attivarla cliccare su Visualizza ‣ Barre degli Strumenti ‣ OpenStreetMap. Verrà aperta la finestra di dialogo [Salva OSM].

Figure OpenStreetMap 8:

../../../_images/osm_savedialog.png

OSM saving dialog

Selezionare gli elementi da salvare come file XML, ed il file stesso cui salvarli, dopodichè cliccare su [Ok] per avviare il processo. La versione OSM del file XML è la 0.6: gli elementi non vengono ordinati.

Si noti che verranno salvati i soli dati non solo dalla vista mappa. Linee e poligoni sono salvati interamente, anche se sono visualizzati solo in parte: per ogni linea/poligono anche tutti i suoi vertici sono salvati.

Importare dati in OSM

Per importare dati in OSM da un layer vettoriale non-OSM seguire le seguenti istruzioni: selezionare i dati OSM, cliccando su uno dei layer, e cliccare su osm_importImport data from a layer. Qualora il pulsante non fosse disponibile nell’interfaccia di QGIS, la barra degli strumenti OpenStreetMap potrebbe essere disattivata: Per attivarla cliccare su Visualizza ‣ Barre degli Strumenti ‣ OpenStreetMap.

Potrebbe apparire la seguente finestra di dialogo:

Figure OpenStreetMap 9:

../../../_images/osm_importdialog.png

OSM import message dialog

In questo caso la finestra informa che non sono attualmente disponibili in QGIS layer vettoriali da cui importare dati. L’importazione può infatti avvenire solamente da layer caricati. Caricare quindi un layer vettoriale e riprovare (ricordandosi di selezionare il layer OSM in legenda):

Figure OpenStreetMap 10:

../../../_images/osm_importtoosmdialog.png

Import data to OSM dialog

Cliccare su [OK] per avviare il processo o su [Cancel] per annullare.