Outdated version of the documentation. Find the latest one here.

Unterstützte Datenformate

QGIS benutzt die OGR-Bibliothek, um Vektorformate zu lesen und zu schreiben wie etwa ESRI Shape, MapInfo und Microstation Datenformate; PostGIS, SpatiaLite, Oracle Spatial Datenbanken und viele mehr (GRASS Vektor und PostgreSQL Support wird duch native Datenprovider Plugins bereitgestellt). Die Vektordaten können auch im Lesemodus aus zip- und gzip-Archiven ins QGIS geladen werden. Zum Zeitpunkt der Erstellung dieses Dokumentes werden 69 Vektorformate von der OGR-Bibliothek unterstützt (siehe OGR-SOFTWARE-SUITE Literatur und Internetreferenzen). Die vollständige Liste ist auf http://gdal.org/ogr/ogr_formats.html zu finden.

Bemerkung

Einige der aufgelisteten Formate können auf ihrem Rechner aus unterschiedlichen Gründen nicht unterstützt werden. Einige brauchen z.B. kommerzielle Bibliotheken oder die GDAL Installation auf Ihrem Rechner wurde ohne die Unterstützung für das entsprechende Format erstellt. Nur Formate, die getestet wurden, können ausgewählt werden, wenn Sie eine Vektordatei in QGIS laden. Alle anderen werden angezeigt, wenn Sie *.* auswählen.

Das Arbeiten mit GRASS GIS Vektorlayern wird in Kapitel GRASS GIS Integration beschrieben.

In diesem Abschnitt wird beispielhaft beschrieben, wie man mit ESRI Shapes, PostGIS- und SpatiaLite-Layern arbeitet. Viele Funktionen in QGIS sind unabhängig vom verwendeten Datenformat und verhalten sich daher identisch. Dies ist gewollt und bezieht sich u.a. auf Abfrage, Selektion, Beschriftung und Attributfunktionen.

ESRI Shapes

ESRI Shape ist das Standard Vektorformat in QGIS und wird durch die OGR Simple Feature Library (http://www.gdal.org/ogr/ ) bereitgestellt.

Ein Shape besteht derzeit aus mehreren Dateien. Die folgenden drei sind erforderlich:

  1. .shp Datei (enthält die Geometrien).

  2. .dbf-Datei (enthält die Attribute im dBase-Format).

  3. .shx (enthält den räumlichen Index).

Darüber hinaus kann eine Datei mit .prj Endung existieren. Diese enthält die Projektionsinformationen des Shapes. Während es sehr nützlich ist eine Projektionsdatei zu verwenden ist dies nicht zwingend erforderlich. Ein Shape-Datensatz kann zusätzliche Dateien enthalten. Details dazu finden sich in der technischen Spezifikation von ESRI unter http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

Shape Layer laden

mActionAddNonDbLayer Um ein Shape zu laden starten sie QGIS und klicken sie auf mActionAddNonDbLayer Vektorlayer hinzufügen in der Werkzeugleiste oder die Taste Ctrl+Shift+V. Dies öffnet ein neues Fenster (siehe figure_vector_1).

Figure Vector 1:

../../../_images/addvectorlayerdialog.png

Add Vector Layer Dialog nix

Wählen Sie aus den möglichen Quelltypen radiobuttonon Datei und klicken Sie auf den Knopf [Durchsuchen]. Dadurch erscheint ein weiterer Dialog zum Öffnen (siehe figure_vector_2) mit dem Sie im Dateisystem navigieren können und Sie ein Shape oder eine andere unterstützte Datenquelle laden können. Die Auswahlbox Filter selectstring ermöglicht es Ihnen einige OGR untersützte Dateiformate vorzuwählen.

Außerdem kann auch der Kodierungstyp für das Shape eingestellt werden, falls dies notwendig ist.

Figure Vector 2:

../../../_images/shapefileopendialog.png

Open an OGR Supported Vector Layer Dialog nix

Durch Auswahl eines Shapes und Anklicken des Knopfes [Öffnen] wird die Datei in QGIS geladen. In Abbildung Figure_vector_3 sehen Sie das Ergebnis, nachdem die Beispieldatei alaska.shp ins QGIS geladen wurde.

Figure Vector 3:

../../../_images/shapefileloaded.png

QGIS with Shapefile of Alaska loaded nix

Tipp

Farben von Vektorlayern

Wenn Sie einen neuen Vektorlayer in QGIS laden, werden Farben zufällig zugewiesen. Wenn Sie mehrere neue Vektorlayer laden, werden jeweils unterschiedliche Farben zugewiesen.

Nach dem Laden können Sie mit den Navigationstools aus der Werkzeugleiste beliebig zoomen. Um den Stil eines Layers zu verändern öffnen Sie den Layereigenschaften Dialog in dem Sie auf den Layernamen doppelklicken oder indem Sie einen Rechtsklick auf den Namen in der Legende machen und Eigenschaften im Popupmenu wählen. Vergleichen Sie Abschnitt Stil für weitere Informationen zum Editieren der Eigenschaften von Vektorlayern.

Tipp

Layer und Projekte von externen Datenträgern laden unter OS X

Unter OS X werden externe Datenträger unter Datei ‣ Öffne Projekt nicht gemeinsam mit den internen Festplatten angezeigt. Dies soll zukünftig behoben werden. Solange können Sie ‘/Volumes’ in das Eingabefenster ‘Dateiname’ eintragen und Return drücken. Danach können Sie auch zu den externen Datenträgern bzw. Rechnern in einem Netzwerk browsen.

Darstellungsgeschwindigkeit optimieren

Um die Darstellungsgeschwindigkeit zu optimieren, kann ein räumlicher Index erstellt werden. Ein räumlicher Index erhöht die Geschwindigkeit beim Zoomen und Verschieben. Räumliche Indizes haben in QGIS die Endung .qix.

Benutzen Sie folgende Schritte zum Erstellen eines räumlichen Index:

  • Laden Sie ein Shape.

  • Öffnen Sie den Eigenschaften-Dialog des Vektorlayers, indem Sie auf den Namen des Layers in der Legende doppelklicken oder mit der rechten Maustaste Eigenschaften auswählen.

  • In dem Reiter Allgemein klicken Sie auf den [Räumlichen Index erstellen] Knopf.

Problem beim Laden eines Shapes mit .prj Datei

Wenn Sie ein Shape mit .prj-Datei laden und QGIS ist nicht in der Lage, die Projektionsinformationen korrekt auszulesen, ist es notwendig das Koordinatenbezugsystem (KBS) manuell im Allgemein Reiter des Layereigenschaften Dialog anzugeben.Hintergrund ist, dass .prj Dateien oftmals nich die vollständigen Projektionsparameter enthalten, so wie QGIS sie benötigt und auch im KBS Dialog anzeigt.

Aus diesem Grund, wenn Sie ein neues Shapefile mit QGIS erstellen, werden derzeit zwei unterschiedliche Projektionsdateien angelegt. Eine .prj Datei, mit den unvollständigen Projektionsparametern, wie sie z.B. von ESRI Software gelesen und erstellt wird, und eine .qpj Datei, in der die vollständigen Projektionsparameter anthalten sind. Wenn Sie dann ein Shape in QGIS laden, und QGIS findet eine .qpj Datei, dann wird diese anstelle der .prj Datei benutzt.

MapInfo Layer laden

Um eine MapInfo Datei zu laden, klicken Sie auf das Icon mActionAddNonDbLayer Vektorlayer hinzufügen in der Werkzeugleiste oder drücken Sie die Taste Strg-Shift-V. Definieren Sie unter Filter: Mapinfo File [OGR] und wählen die gewünschte Datei aus.

ArcInfo Binary Coverage laden

Um ein ArcInfo Coverage zu laden, klicken Sie auf das Icon mActionAddNonDbLayer Vektorlayer hinzufügen in der Werkzeugleiste oder drücken Sie die Taste Strg+Shift+V. Wählen Sie aus den möglichen Quelltypen radiobuttonon Verzeichnis, wählen Sie ArcInfo Binary Coverage selectstring. Wählen Sie nun den Ordner mit den ArcInfo Binary Coverage Dateien aus.

Auf die gleiche Art und Weise können auch andere Verzeichnis-basierte Vektorlayer geladen werden, wie etwa das U.K. National Transfer Format oder das raw TIGER Format des U.S. Census Bureau.

PostGIS Layer laden

PostGIS-Ebenen sind in einer PostgreSQL Datenbank gespeichert. Der Vorteil von PostGIS liegt in der Fähigkeitkeit, räumliche Indizes, Filterungen und Abfragen bereitszustellen. Vektorfunktionen wie Selektieren und Abfragen funktionieren besser als bei Ebenen, die durch die OGR-Bibliothek geladen wurden.

Erstellen einer PostGIS Anbindung

mActionAddLayer Beim ersten Einbinden einer PostGIS-Datenbank muss eine Anbindung erstellt und gespeichert werden. Klicken Sie dazu auf das Icon mActionAddLayer PostGIS-Layer hinzufügen in der Werkzeugleiste oder aus dem Menü Layer oder indem Sie Ctrl+Shift+D drücken. Sie können auch den Vektorlayer hinzufügen Dialog öffnen und radiobuttonon Datenbank wählen. Der PostGIS-Layer hinzufügen Dialog wird angezeigt. Um eine neue Anbindung zu erstellen, klicken Sie auf den Knopf [Neu] und der Neue PostGIS-Verbindung erzeugen Dialog erscheint. Die für eine Verbindung erforderlichen Parameter sind:

  • Name:Ein Name für die Verbindung. Kann derselbe wie für die Datenbank sein

  • Dienst: Service Parameter, der anstelle von Host / Port und potenziell auch Datenbank verwendet werden kann. Kann unter pg_service.conf definiert werden

  • Host: Name des Datenbank-Hosts. Dies muss einauflösbarer Name für den HOST sein, genau wie beim Benutzen von telnet oder ping Wenn die Datenbank auf demselben Computer ist wie QGIS, tragen Sie hier einfach ‘localhost’ ein.

  • Port: Port Nummer der Datenbank auf dem Server. Standard ist 5432.

  • Datenbank: Name der Datenbank.

  • SSL Modus: Wie die SSL-Verbindung mit dem Server festgelegt wird. Beachten Sie dass es zu erheblichen Beschleunigungen im Darstellen von PostGIS Layern kommt wenn man SSL im Verbindungseditor abschaltet. Die Optionen sind:

    • abschalten: Versuche nur eine Nicht-SSL-Verbindung

    • erlauben: Versuche eine Nicht-SSL-Verbindung. Wenn das nicht klappt, versuche eine SSL-Verbindung

    • bevorzugen (the default): Versuche eine SSL-Verbindung. Wenn das nicht klappt, versuche eine Nicht-SSL-Verbindung;

    • verlangen: Versuche nur eine SSL-Verbindung.

  • Benutzername: Benutzername, um sich bei der Datenbank anzumelden.

  • Passwort: Passwort das zusammen mit Benutzername verwendet wird um sich bei der Datenbank anzumelden.

Optional können noch die folgenden Kontrollkästchen aktiviert werden:

  • checkbox Benutzernamen speichern

  • checkbox Passwort speichern

  • checkbox Nur in geometry_columns nachschauen

  • checkbox Nur im ‘public’ Schema nachschauen

  • checkbox Auch geometrielose Tabellen anzeigen

  • checkbox Gechätzte Tabellenmetadaten nutzen

Wenn alle Parameter eingetragen sind, kann die Verbindung getestet werden, indem Sie auf den Knopf [Verbindung testen] drücken.

Tipp

QGIS Benutzereinstellungen und Sicherheit

Je nach Arbeitsumgebung birgt das Speichern von Passwörtern in Ihren QGIS-Einstellungen Risiken in sich. Ihre Einstellungen für QGIS werden basierend auf ihrem Betriebssystem gespeichert:

  • nix, die Einstellungen werden in Ihrem Homeverzeichnis in .qgis/ gespeichert.

  • win, die Einstellungen werden in der Registry gespeichert.

Laden eines Layers aus der PostGIS Datenbank

mActionAddLayer Nachdem Sie eine oder mehrere Verbindungen definiert und gespeichert haben, können Sie einzelne Ebenen aus PostGIS laden. Natürlich brauchen Sie dazu Daten in PostgreSQL/PostGIS. Eine Beschreibung zum Import von Daten nach PostgreSQL/PostGIS lesen Sie in Abschnitt Layer nach PostgreSQL/PostGIS importieren.

Um eine Ebene aus PostGIS zu laden, führen Sie folgende Schritte durch:

  • Wenn der PostGIS-Layer hinzufügen-Dialog noch nicht geöffnet ist, klicken Sie auf den Knopf mActionAddLayer PostGIS-Layer hinzufügen in der Werkzeugleiste.

  • Wählen Sie eine Verbindung aus dem Drop-Down Menü und klicken auf [Verbinden].

  • Wählen Sie checkbox Auch geometrielose Tabellen anzeigen an oder ab

  • Optional aktivieren Sie den Bereich checkbox Suchoptionen, um eine Auswahl anzuzeigender Objekte zu treffen oder verwenden Sie den [Abfrage erstellen] Knopf um den Abfrageerstellung-Dialog zu starten.

  • Suchen Sie einen Layer den Sie laden möchten.

  • Wählen Sie den Layer durch doppelklicken aus. Sie können mehrere Ebenen auswählen, indem Sie die Umschalt-Taste beim Auswählen gedrückt halten. Siehe Abschnitt Abfrageeditor über das Benutzen des PostgreSQL Query Builder um den Layer genauer zu definieren.

  • Klicken Sie auf den Knopf [Hinzufügen] um den Layer zu laden.

Tipp

PostGIS-Layer

Normalwerweise ist ein PostGIS-Layer über einen Eintrag in der geometry_columns Tabelle definiert. Seit Version 0.9.0 ist QGIS in der Lage, Layer zu laden, die keinen Eintrag in der geometry_columns Tabelle besitzen. Dies bezieht sich auf Tabellen und Views. Um einen ‘spatial view’ zu definieren, brauchen Sie ein kraftvolles System, um die Daten zu visualisieren. Beziehen Sie sich auf das PostgreSQL Handbuch, um weitere Informationen über die Erstellung von Views zu erhalten.

Einige Details zu PostGIS-Layern

Dieser Abschnitt enthält einige Details, wie QGIS auf PostgreSQL zugreift. Meistens soll QGIS eine Liste mit ein paar Datenbanktabellen bereitstellen, die bei Bedarf geladen werden können. Wenn Sie Probleme mit dem Laden von Layern aus PostgreSQL haben, können die nun folgenden Informationen vielleicht eine Hilfe sein, die Fehlermeldungen von QGIS besser zu verstehen und eine Lösung zu finden, die PostgreSQL Tabellen- oder Viewdefinition anzupassen, und somit den Layer laden zu können.

QGIS braucht eine Spalte in der PostgreSQL Tabelle, die als eindeutiger Schlüssel für den Layer genutzt werden kann. Für Tabellen bedeutet dies, dass die Tabelle normalerweise einen Primärschlüssel braucht oder eine Spalte mit eindeutiger Zuordnung. Für QGIS muss diese Spalte außerdem vom Typ int4 sein (Integer mit 4 Bytes). Als Alternative kann auch die Spalte ctid als Primärschlüssel-Spalte verwendet werden. Wenn eine Tabelle diese Voraussetzungen nicht erfüllt, wird die oid-Spalte genutzt. Die Performanz steigt, wenn für die Spalte ein Index erstellt wurde (für Primärschlüssel wird in PostgreSQL automatisch ein Index erstellt).

Wenn der PostGIS-Layer ein View ist, gelten dieselben Anforderungen, aber Views besitzen keinen Primärschlüssel oder Spalten mit eindeutiger Zuordnung. In diesem Fall wird QGIS versuchen, eine passende Spalte zu finden, die aus der Tabellenspalte erstellt wurde. Dies geschieht, indem die View Definition SQL-basiert durchsucht wird. Aber es gibt auch einige Aspekte der SQL, die von QGIS ignoriert werden. Dies beinhaltet zum Beispiel die Verwendung von Tabellen Aliases und Spalten, die durch SQL Funktionen generiert wurden.

Wenn so eine Primärschlüssel Spalte nicht existiert, wird die Ebene nicht geladen. In diesem Fall ist eine Lösung, den View anzupassen, damit er eine entsprechende Spalte vom Typ int4 enthält, entweder mit einem Primärschlüssel oder eindeutiger Zuordnung und bevorzugt natürlich mit Index.

Layer nach PostgreSQL/PostGIS importieren

Layer können auf unterschiedliche Art nach PostGIS importiert werden. Verwenden Sie dazu das SPIT Plugin oder Kommandozeilentools wie shp2pgsql oder ogr2ogr.

SPIT Plugin

QGIS bietet ein Plugin mit dem Namen spiticon SPIT (Shapefile to PostGIS ImportTool). SPIT kann dazu benutzt werden, gleichzeitig mehrere Shapes zu laden und bietet dabei auch Support für Schemas. Siehe Abschnitt SPIT Plugin für weitere Informationen.

shp2pgsql

PostGIS enthält ein Werkzeug names shp2pqsql das dazu verwendet werden kann Shapes in eine PostGIS-fähige Datenbank zu importieren. Um ein Shape mit dem Namen alaska.shp in eine PostgreSQL/PostGIS Datenbank die gis_data heißt zu importieren, wird folgendes Kommando benutzt:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

Dieser Befehl erzeugt eine neue Tabelle mit dem Namen lakes_new in der PostgreSQL/PostGIS Datenbank gis_data. Die neue Ebene wird die ID 2964 als ‘spatial reference identifier’ (SRID) tragen. Weitere Informationen zu räumlichen Referenzsystemen finden Sie in Abschnitt Arbeiten mit Projektionen.

Tipp

Layer aus PostGIS exportieren

Neben dem Importwerkzeug shp2pgsql gibt es auch ein Werkzeug um PostGIS-Datensätze als Shapes zu exportieren:pgsql2shp. Diees wird mit der PostGIS-Distribution geliefert.

ogr2ogr

Abgesehen von shp2pgsql und SPIT gibt es noch ein weiteres Tool, um Daten nach PostGIS zu importieren: ogr2ogr. Dieses Tool ist Teil der GDAL-Installation.

Um ein Shape nach PostGIS zu importieren, kann folgendes Kommando verwendet werden:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres \
password=topsecret" alaska.shp

Damit wird das Shape alaska.shp vom Benutzer postgres mit dem Passwort topsecret in die PostGIS Datenbank postgis auf dem Server myhost.de importiert.

Wichtig ist, dass GDAL mit PostgreSQL-Support kompiliert sein muss, damit der Import nach PostGIS möglich ist. Dies kann mit folgendem Kommando getestet werden:

ogrinfo --formats | grep -i post

Wenn Sie das PostgreSQL’s Kommando COPY anstatt der Standardmethode INSERT INTO verwenden möchten, müssen Sie vorher die folgende Variable exportieren (verifiziert unter nix und osx):

export PG_USE_COPY=YES

Der Befehl ogr2ogr erstellt im Gegensatz zu shp2pgsl keinen räumlichen Index. In diesem Fall müssen Sie ihn nachträglich manuell erstellen mit dem SQL-Kommando CREATE INDEX. Die Schritte werden im folgenden Kapitel Geschwindigkeit optimieren näher beschrieben.

Geschwindigkeit optimieren

Der Datentransfer von einer PostgreSQL/PostGIS Datenbank kann langsam sein, besonders über ein Netzwerk. Die Geschwindigkeit kann optimiert werden, indem für alle Ebenen in PostgreSQL ein PostGIS räumlicher Index erstellt wird. PostGIS unterstützt das Erstellen eines GiST (Generalized Search Tree) Index, um den Zugriff auf die Ebenen zu beschleunigen (die GiST Index Informationen wurden aus der PostGIS Dokumentation übernommen unter: http://postgis.refractions.net).

Dies ist die Syntax für das Erstellen eines GiST-Index:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Bedenken Sie, dass das Erstellen eines Index bei großen Datenmengen zeitaufwendig ist. Nachdem der Index erstellt ist, sollte ein ‘VACUUM ANALYZE’ durchgeführt werden (vgl. PostGIS Dokumentation Literatur und Internetreferenzen).

Im Folgenden sehen Sie ein Beispiel, um einen GiST-Index zu erstellen:

[email protected]:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

Vektorlayer, die den Längengrad 180° überschreiten

Viele GIS Applikationen stellen einen Vektorlayer, der über den Längengrad 180 hinausgeht nicht zusammenhängend dar. So wird in QGIS der Layer geteilt und man sieht im Kartenfenster zwei, weit voneinander entfernte Teile, die eigentlich zusammen gehören. In Abbildung Figure_vector_4 sollte z.B. der kleine Punkt in der linken Ecke des Kartenfensters (Chatham Inseln) rechts neben Neuseeland angezeigt werden.

Figure Vector 4:

../../../_images/vectorNotWrapping.png

Map in lat/lon crossing the 180° longitude line nix

Eine Möglichkeit, dies zu umgehen, bietet PostGIS und die Funktion ST_Umschalt_Longitude (http://postgis.refractions.net/documentation/manual-1.4/ST_Umschalt_Longitude.html). Die Funktion liest alle Objekte der Karte ein und wenn der Längengrad <0° ist, werden 360° hinzugezählt. Das Ergebnis ist eine 0-360° Karte, die als Mittelpunkt den Längengrad 180° verwendet.

Figure Vector 5:

../../../_images/vectorWrapping.png

Crossing 180° longitude applying the ST_Shift_Longitude function nix

Beispielanwendung

  • Importieren Sie Daten in PostGIS (Layer nach PostgreSQL/PostGIS importieren) in dem Sie z.B. das PostGIS Manager Plugin oder das SPIT Plugin benutzen

  • Öffnen Sie das PostGIS Kommandozeilenfenster und geben Sie folgendes Kommando ein. In diesem Beispiel steht der Name “TABELLE” für den tatsächlichen Namen der PostGIS Tabelle

    gis_data=# update TABELLE set the_geom=ST_shift_longitude(the_geom);

  • Wenn alles geklappt hat, sehen Sie eine Bestätigung mit den Objekten, die verändert wurden. Danach können Sie den PostGIS Layer in QGIS als eine zusammenhängende Karte laden (siehe Abbildung Figure_vector_5 )

SpatiaLite Layer laden

mActionAddSpatiaLiteLayer Wenn Sie das erste Mal einen Layer aus einer Spatialite Datenbank laden möchten, klicken Sie auf das Icon mActionAddSpatiaLiteLayer SpatiaLite Layer hinzufügen in der Werkzeugleiste oder indem Sie mActionAddSpatiaLiteLayer SpatiaLite Layer hinzufügen ... im Menü Layer auswählen oder indem Sie die Taste Strg+Shift+L drücken. Dies öffnet einen Dialog, über den Sie entweder eine Verbindung zu einer bereits in QGIS definierten SpatiaLite Datenbank auswählen oder eine neue Verbindung erstellen können. Um eine neue Verbindung zu erstellen, klicken Sie auf den Knopf [Neu] und verwenden dann den Dateibrowser, um eine entsprechende SpatiaLite Datenbank auszuwählen. Dabei handelt es sich um eine Datei mit der Endung .sqlite.

Wenn Sie einen Vektorlayer im SpatiaLite Format abspeichern wollen, wählen Sie den Layer in der Legende aus, benutzen Sie das Kontextmenü der rechten Maustaste und klicken Sie auf Speichern als. Geben Sie den Namen der Ausgabe an, wählen Sie sqlite als Format aus und das KBS. Danach fügen Sie noch SPATIALITE=YES in das Fenster ‘Datenquelle’. Damit sagen Sie OGR, dass eine SpatiaLite Datenbank erstellt werden soll. Siehe http://www.gdal.org/ogr/drv_sqlite.html.

QGIS unterstützt auch editierbare Views in SpatiaLite.

Einen neuen SpatiaLite Layer erzeugen

Wenn Sie einen neuen SpatiaLite Layer erzeugen wollen, finden Sie in Kapitel Einen neuen SpatiaLite Layer erstellen eine Anleitung.

Tipp

SpatiaLite Datenmanagement Plugin

Für das Managen von SpatiaLite Daten können Sie mehrere Python Plugins verwenden: QSpatiaLite, SpatiaLite Manager oder DB Manager. Sie können mit dem Python Plugin Installer gedownloaded und installiert werden.

Räumliche MSSQL-Layer

QGIS bietet auch native MS SQL 2008 Unterstützung. Der mActionAddMssqlLayer SpatiaLite Layer hinzufügen ist ein neuer Button in der Werkzeugleiste oder über den MS SQL-Knoten im QGIS Browser Baum, der Drag und Drop-Unterstützung bietet, zugänglich.