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rnaBA 1

MNpeambyna

This is the user guide for the geographical information system (GIS) software QGIS. QGIS is subject to the GNU
General Public License. More information is available on the QGIS homepage, https://www.qgis.org.

The contents of this document have been written and verified to the best of the knowledge of the authors and editors.
Nevertheless, mistakes are possible.

Therefore, the authors, editors and publishers do not take any responsibility or liability for errors in this document
and their possible consequences. We encourage you to report possible mistakes.

This document has been typeset with reStructuredText. It is available as reST source code on github, and online
as HTML and PDF via https://www.qgis.org/en/docs/. Translated versions of this document can be browsed and
downloaded via the documentation area of the QGIS project as well.

For more information about contributing to this document and about translation, please visit https://qgis.org/en/site/
getinvolved/index.html.

CCBUIKH B 5TOM JAOKYMEHTE

This document contains internal and external links. Clicking on an internal link moves within the document, while
clicking on an external link opens an internet address.

Documentation Authors and Editors

The list of the persons who have contributed with writing, reviewing and translating the following documentation
is available at Contributors.

Copyright (c) 2004 - 2020 QGIS Development Team
Internet: https://www.qgis.org
JInneHs3us 3Toro J10KyMeHTa

Pasperniaercst KonupoBath, paclipoCTpaHATh W/WIA U3MEHSATh ITOT JOKYMEHT B COOTBETCTBUM ¢ yciaoBusmMu GNU
Free Documentation License, Bepcuu 1.3 wmm 6onee mosaned, omyomikoBanHon Free Software Foundation; 6e3
KaKUX-TMO00 HEM3MEHSIeMbIX Pa3JieioB, TEKCTa, MOMEIIAeMOro Ha MePBOi CTpaHuIe O0NOKKHU, U €3 TeKCTa, IoMe-
IAEMOr'0 Ha TocieiHel crpanune 0610xkku. Konus tekcra nuiieH3un npejacrasieHa B Paznene Appendix B: GNU
Free Documentation License.
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QGIS Desktop 3.34 User Guide

1.1 What is new in QGIS 3.34

This release of QGIS includes hundreds of bug fixes and many new features and enhancements, compared to QGIS
3.28. For a list of new features, visit the visual changelogs at https://qgis.org/en/site/forusers/visualchangelogs.html.

We recommend that you use this version over previous releases.
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FMABA 2

[Npenwncnosne

Jo6po moskanoBaTh B yAUBHUTEIbHBINA MUp reorpadudeckux nagopmanmonnsix cucreM (I'MC)!

QGIS is an Open Source Geographic Information System. The project was born in May 2002 and was established as
a project on SourceForge in June the same year. We have worked hard to make GIS software (which is traditionally
expensive proprietary software) available to anyone with access to a personal computer.

QQGIS currently runs on most Unix platforms, Windows, and macOS. QGIS is developed using the Qt toolkit
(https://www.qt.io) and C++. This means that QGIS feels snappy and has a pleasing, easy-to-use graphical user
interface (GUI). There are also independently created applications that allow you to take QGIS into the field. These
applications can run on Android and iOS.

QGIS aims to be a user-friendly GIS, providing common functions and features. The initial goal of the project
was to provide a GIS data viewer. QGIS has reached the point in its evolution where it is being used for daily GIS
data-viewing needs, for data capture, for advanced GIS analysis, and for presentations in the form of sophisticated
maps, atlases and reports. QGIS supports a wealth of raster and vector data formats, with new format support easily
added using the plugin architecture.

QQIS is released under the GNU General Public License (GPL). Developing QGIS under this license means that
you can inspect and modify the source code, and guarantees that you, our happy user, will always have access to a
GIS program that is free of cost and can be freely modified. You should have received a full copy of the license
with your copy of QGIS, and you can also find it in Appendix Appendix A: GNU General Public License.

Coset: AKTyaJbHasi BepcHsl JOKYMEHTAIIN

The latest version of this document can always be found in the documentation area of the QGIS website at https:
/Iwww.qgis.org/en/docs/.
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OneMeHTbl

This section describes the uniform styles that will be used throughout this manual.

3.1

AnemeHTbl MHTEepdrenca nonb3oBaTens

The GUI convention styles are intended to mimic the appearance of the GUI In general, a style will reflect the
non-hover appearance, so a user can visually scan the GUI to find something that looks like the instruction in the
manual.

¢ Ilynktsl MeH10: Caoti » Jlobasume pacmposbiii caoti i Buo w [aneau uncmpymenmog » Ouugposka

3aTeHeHHe yKa3blBaeT HAa MHTEPAKTHBHBIN KOMITOHEHT rpaduueckoro nHTepderica.

Tool: FD Add a Raster Layer
Button : Save as Default

3aroJIoBOK JIHUaJioroBoro okHa: Ceoticmea caost

Bknanka: Oougue

DaxoK: A Ompucoska

Radio Button: '® ' Postgis SRID ' EPSG ID
Select a number: 190 <

Select a string: Ll
Browse for a file: ...

S -

—

Select a color:
[TonzyHok:

Input Text: Display name lakes.shp|
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3.2 TekcTOoBble aN1eMeHTbl UNU KNlaBUaTypHble COKpaLleHUsd

This manual also includes styles related to text, keyboard commands and coding to indicate different entities, such
as classes or methods. These styles do not correspond to the actual appearance of any text or coding within QGIS.

* Hyperlinks: https://qgis.org

» Keystroke Combinations: Press Ct r 1+B, meaning press and hold the Ctrl key and then press the B key.
* Haszpanwe caiina: lakes.shp

» HasBanue kiacca: NewLayer

e Meron: classFactory

* Wwms cepepa: myhost.de

¢ TexkcT, BBOMUMEIH MONIb30BaTENEM: dgis ——help

Lines of code are indicated by a fixed-width font:

PROJCS["NAD_1927_Albers",
GEOGCS["GCS_North_ American_1927",

3.3 MHcTpyKuum, cneunduryHbie N KOHKPETHbIX nnatcopm

GUI sequences and small amounts of text may be formatted inline: Click (‘} £7 File X QGIS » Quit to close QGIS.
This indicates that on Linux, Unix and Windows platforms, you should click the File menu first, then Quit, while
on macOS platforms, you should click the QGIS menu first, then Quit.

Larger amounts of text may be formatted as a list:
« B Do this
+ £7 Do that
. X Or do that
or as paragraphs:
‘f:\ X Do this and this and this. Then do this and this and this, and this and this and this, and this and this and this.
£7 Do that. Then do that and that and that, and that and that and that, and that and that and that, and that and that.

Screenshots that appear throughout the user guide have been created on different platforms.

8 MaBa 3. OneMeHTbI
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Bo3amoxHoCTH

QGIS offers a wealth of GIS functions, provided by core features and plugins. The locator bar makes it easy to
search for functions, datasets and more.

A short summary of six general categories of features and plugins is presented below, followed by first insights into
the integrated Python console.

4.1

MpocMoTp mMaHHbIX

You can view combinations of vector and raster data (in 2D or 3D) in different formats and projections without
conversion to an internal or common format. Supported formats include:

Spatially-enabled tables and views using PostGIS, Spatialite and MS SQL Spatial, Oracle Spatial, vector
formats supported by the installed OGR library, including GeoPackage, ESRI Shapefile, MapInfo, SDTS,
GML and many more. See section Paboma ¢ 8ekmopHuiMiu OGHHBIMU.

Raster and imagery formats supported by the installed GDAL (Geospatial Data Abstraction Library) library,
such as GeoTIFF, ERDAS IMG, Arclnfo ASCII GRID, JPEG, PNG and many more. See section Padoma c¢
pacmposbimu OaHHbIMU.

Mesh data (TINs and regular grids are supported). See Working with Mesh Data.
Vector tiles

GRASS raster and vector data from GRASS databases (location/mapset). See section Humezpauyusi ¢ GRASS
GIS.

Online spatial data served as OGC Web Services, including WMS, WMTS, WCS, WES, and WFS-T. See
section Working with OGC / ISO protocols.

The QGIS authentication infrastructure helps you manage user/password, certificates and keys for web
services and other resources.

Spreadsheets (ODS / XLSX)

Temporal data are supported.
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4.2

MUccnepoBaHue gaHHbIX U co3aaHue KapT

You can compose maps and interactively explore spatial data with a friendly GUI. The many helpful tools available
in the GUI include:

4.3

QGIS browser

[lepenpoenipoBaHue «Ha JIETY»

2D and 3D map rendering

DB Manager

Print layout

Report

MaHeJ b 0030pa

MIPOCTPAHCTBEHHBIE 3aKJIAAKN

MHCTPYMEHTHI aHHOTALIUMIA
orpeJeseHne/BHIO0OpKa 0OBEKTOB
PpeIaKkTHpOBaHME/IPOCMOTP/TIONCK aTpuOyTOB
Data-defined feature labeling

Data-defined vector and raster symbology tools
Atlas map composition with graticule layers
North arrow, scale bar and copyright label for maps

Support for saving and restoring projects

YnpaBneHue paHHbIMU: cOo3paHue, pedakTUpoBaHUe M 3KcC-
nopt

You can create, edit, manage and export vector and raster layers in several formats. QGIS offers the following:

Vector digitizing tools
Ability to create and edit multiple file formats and GRASS vector layers
Georeferencer tool to geocode vectors and images

GPS tools to import and export GPX format, and convert other GPS formats to GPX or down/upload directly
to a GPS unit (on Linux, usb: has been added to list of GPS devices)

Support for visualizing and editing OpenStreetMap data

Ability to create spatial database tables from files with the DB Manager plugin
yJIy4IlieHHAast TO/IIePXKKa MPOCTPAHCTBEHHbIX 0a3 TAHHbBIX

Tools for managing vector attribute tables

Option to save screenshots as georeferenced images

DXF-Export tool with enhanced capabilities to export styles and plugins to perform CAD-like functions

10
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4.4 Analyze data

You can perform spatial data analysis on spatial databases and other OGR-supported formats. QGIS currently offers
vector analysis, raster analysis, sampling, geoprocessing, geometry and database management tools. You can also
use the integrated GRASS tools, which include the complete GRASS functionality of more than 400 modules
(see section Humezpauusi c GRASS GIS). Or, you can work with the Processing plugin, which provides a powerful
geospatial analysis framework to call native and third-party algorithms from QGIS, such as GDAL, SAGA, GRASS,
OTB, R, and more (see section Bsedenue). All analysis functions are run in the background, allowing you to continue
your work before the processing has finished.

The graphical modeller allows you to combine / chain functions into a complete workflow in an intuitive graphical
environment.

4.5 My6nukaumns kapt B cetn UHTEepHeT

QGIS can be used as a WMS, WMTS, WMS-C, WFS, OAPIF and WFS-T client (see section Working with OGC
/ ISO protocols), and QGIS Server (see QGIS-Server-manual) allows you to publish your data through the WMS,
WCS, WES and OAPIF protocols on the Internet using a webserver.

4.6 Extend QGIS functionality through plugins

QGIS can be adapted to your special needs with the extensible plugin architecture and libraries that can be used to
create plugins. You can even create new applications with C++ or Python!

4.6.1 OcHOBHble MOAoYNN

Core plugins include:
1. DB Manager (exchange, edit and view layers and tables from/to databases; execute SQL queries)
2. Geometry Checker (check geometries for errors)
3. Georeferencer GDAL (add projection information to rasters using GDAL)
4. GPS Tools (load and import GPS data)
5. GRASS (integrate GRASS GIS)
6

. MetaSearch Catalogue Client (interacting with metadata catalog services supporting the OGC Catalog Service
for the Web (CSW) standard)

~

Offline Editing (allow offline editing and synchronizing with databases)
8. Processing (the spatial data processing framework for QGIS)

9. Topology Checker (find topological errors in vector layers)

4.4. Analyze data 11
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4.6.2 BHewHue moaynu Python

QGIS offers a growing number of external Python plugins that are provided by the community. These plugins
reside in the official Plugins Repository and can be easily installed using the Python Plugin Installer. See Section
The Plugins Dialog.

4.7 KoHconb Python

For scripting, it is possible to take advantage of an integrated Python console, which can be opened with: Plugins
» Python Console. The console opens as a non-modal utility window. For interaction with the QGIS environment,
there is the ggis.utils. iface variable, which is an instance of QgisInterface. This interface provides
access to the map canvas, menus, toolbars and other parts of the QGIS application. You can create a script, then
drag and drop it into the QGIS window and it will be executed automatically.

For further information about working with the Python console and programming QGIS plugins and applications,
please refer to Korcoae QGIS Python and PyQGIS-Developer-Cookbook.

4.8 Known Issues

4.8.1 Number of open files limitation

If you are opening a large QGIS project and you are sure that all layers are valid, but some layers are flagged as
bad, you are probably faced with this issue. Linux (and other OSs, likewise) has a limit of opened files by process.
Resource limits are per-process and inherited. The ulimit command, which is a shell built-in, changes the limits
only for the current shell process; the new limit will be inherited by any child processes.

You can see all current ulimit info by typing:

[$ ulimit -as

You can see the current allowed number of opened files per process with the following command on a console:

[$ ulimit -Sn

To change the limits for an existing session, you may be able to use something like:

$ ulimit -Sn #number_of_allowed_open_files
$ ulimit -Sn
$ qgis

Alternatively, you can use the newer prlimit utility. More info: https://manpages.ubuntu.com/manpages/latest/
manl/prlimit.1.html

To fix it forever

On most Linux systems, resource limits are set on login by the pam_1imits module according to the settings
contained in /etc/security/limits.conf or /etc/security/limits.d/*.conf. You should be
able to edit those files if you have root privilege (also via sudo), but you will need to log in again before any changes
take effect.

More info:

https://www.cyberciti.biz/fag/linux-increase-the-maximum-number-of-open-files/  https://linuxaria.com/article/
open-files-in-linux

12 MmaBa 4. Bo3aMoXxHoOCTHK
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[NepBble warn

This chapter provides a quick overview of installing QGIS, downloading QGIS sample data, and running a first
simple session visualizing raster and vector data.

5.1 Installing QGIS

QGIS project provides different ways to install QGIS depending on your platform.

5.1.1 Installing from binaries

Standard installers are available for £7 MS Windows and )( macOS. Binary packages (rpm and deb) or software

repositories are provided for many flavors of GNU/Linux @'.

For more information and instructions for your operating system check https://download.qgis.org.

5.1.2 Installing from source

If you need to build QGIS from source, please refer to the installation instructions. They are distributed with the
QGIS source code in a file called INSTALL. You can also find them online at https://github.com/qgis/QGIS/blob/
release-3_34/INSTALL.md.

If you want to build a particular release and not the version in development, you should replace master with the
release branch (commonly in the release—-X_Y form) in the above-mentioned link (installation instructions may
differ).

13
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5.1.3 Installing on external media

It is possible to install QGIS (with all plugins and settings) on a flash drive. This is achieved by defining a —profiles-
path option that overrides the default user profile path and forces QSettings to use this directory, too. See section
System Settings for additional information.

5.1.4 Downloading sample data

This user guide contains examples based on the QGIS sample dataset (also called the Alaska dataset).
Download the sample data from https://github.com/qgis/QGIS-Sample-Data/archive/master.zip and unzip the
archive on any convenient location on your system.

The Alaska dataset includes all GIS data that are used for the examples and screenshots in this user guide; it also
includes a small GRASS database. The projection for the QGIS sample datasets is Alaska Albers Equal Area with
units feet. The EPSG code is 2964.

PROJCS ["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]7,
TOWGS84[-3,142,183,0,0,0,01,

AUTHORITY ["EPSG", "6267"11,
PRIMEM|["Greenwich", O,

AUTHORITY ["EPSG","8901"]1],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]7,

AUTHORITY ["EPSG","4267"11,
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER ["standard_parallel_1",55],
PARAMETER|["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

If you intend to use QGIS as a graphical front end for GRASS, you can find a selection of sample locations (e.g.,
Spearfish or South Dakota) at the official GRASS GIS website, https://grass.osgeo.org/download/data/.

5.2 Starting and stopping QGIS

QGIS can be started like any other application on your computer. This means that you can launch QGIS by:

* using A the Applications menu, £7 the Start menu, or X the Dock
* double clicking the icon in your Applications folder or desktop shortcut

* double clicking an existing QGIS project file (with . ggz or . ggs extension). Note that this will also open
the project.

* typing ggis in a command prompt (assuming that QGIS is added to your PATH or you are in its installation
folder)

To stop QGIS, use:
o (:\ £7 the menu option Project » Exit QGIS or use the shortcut Ctr1+Q

. X QGIS » Quit QGIS, or use the shortcut Cmd+Q

* or use the red cross at the top-right corner of the main interface of the application.

14 asa 5. MepB.ble Wwarun



https://github.com/qgis/QGIS-Sample-Data/archive/master.zip
https://grass.osgeo.org/download/data/

QGIS Desktop 3.34 User Guide

5.3 Sample Session: Loading raster and vector layers

Now that you have QGIS installed and a sample dataset available, we will demonstrate a first sample session. In this
example, we will visualize a raster and a vector layer. We will use:

 the landcover raster layer (qgis_sample_data/raster/landcover.img)
* and the 1akes vector layer (qgis_sample_data/gml/lakes.gml)
Where qgis_sample_data represents the path to the unzipped dataset.
1. Start QGIS as seen in Starting and stopping QGIS.

2. The data we will be working with are in Albers Equal Area,so let’s set the project’s CRS accordingly:

1. Click the ‘% Select projection bytton in the bottom right of QGIS interface. The project properties dialog
opens with the CRS tab active.

2. Type™ 2964 in the CL Filter text area.

3. Select the row with NAD27 / Alaska Albers CRS name.

Project Properties — CRS

Project Coordinate Reference System (CRS)
\

% General No CRS (or unknown/non-Earth projection)
m Metadata iy @ 2964 =
Recently Used Coordinate Reference Systems
E View Settings - .
Coordinate Reference System Authority ID
MNAD27 / Alaska Albers EPSG:2964
Transformations
" Styles ] »
Predefined Coordinate Reference Systems Hide deprecated CRSs
Data Sources
Coordinate Reference System Authority ID
Relations ~ [ Projected Coordinate Systems
: ~ Albers Equal Area
Variables NAD27 / Alaska Albers EPSG:2964
Macros
QGIS Server
a Temporal ] )
BB rercain NAD27 / Alaska Albers =
Properties
* Linits: feet

# Static (relies on a datum which is plate-fixed)
* Method: Albers Equal Area

WKT
PROJCRS["MNADZ2T7 / Alaska Albers", - .
BASEGEOGCRS[ "NAD27", o L -
DATUM[ "North American Datum 1927, I P

ELLIPSOID["Clarke 1866",
6378206.4,294.978698213898,
LENGTHUNIT[ "metre”,1]1],

8 Aide | v 0k |\/ﬁppliquer © Annuler

Puc. 5.1: Select the Coordinate Reference System of data

4. Knuknaute OK.

5.3. Sample Session: Loading raster and vector layers 15
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IIpumeuanne: You can ignore/close for now the «ballpark transform» message that could display.

3. Load the files in QGIS:

1. Click on the Q Open Data Source Manager oo The Data Source Manager should open in Browser mode.

2. Browse to the folder qgis_sample_data/raster/

[ |
3. Select the ERDAS IMG file w  landcover. img and double-click it. The landcover layer is added in the

background while the Data Source Manager window remains open.

Data Source Manager | Browser N =) &
lf Browser Browser
: R = O ]
Vector r [ issue-action =
Rt » 3 MapsPrllnter
v [ OsGeoLive-doc
Mesh » [0 pyagis
» [ QaGIs
° Point Cloud » [ QGIS-Documentation
v [ QGIs-Training-Data
Delimited Text » [ QGIS-Website

T3 qgis_sample_data

GeoPackage » [ climate

» [T csv
GPS * 5 gml

- ~ & lakes.gml

SpatiaLite b 9 lakes

» [0 gps
PostgreSQL » [ grassdata

» [ projects
MS SQL Server « [ raster

** SR_50M_alaska_nad.tif
» [ shapefiles
» [ screenshots

"y WFS/OGC API - Features » [1 sphinx_rtd_theme
» [ worktrees

m Virtual Layer

\ﬁ!‘_ WMS/WMTS

_:e: Wes » [* Project Home
_—+ L ] .
v Spatial Bookmarks
XYz v [a] Home
* p—
(11} ' D f
2i% Vector Tile @ GeoPackage
. / spatialLite
4 ArcGIS REST Server & PostgresQL
I Ms sQL Server
§ CeoNode v B WMS/WMTS
y » BH vector Tiles
Metadata Search - 55 XYZ Tiles -

Puc. 5.2: Adding data to a new project in QGIS

4. To load the lakes data, browse to the folder ggis_sample_data/gml/, and drag and drop the @
lakes.gml file over QGIS main dialog. (Or just double-click as mentioned above.)

5. The Select Items to Add dialog opens, scanning the file. This is due to . gm1l file format being able to
store more than one layer at a time.
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Select Items to Add | lakes X

/media/delazj/TRAVAIL/dev/github/qqgis sample data/gml/lakes.gml
Search...

Item Description

™ |akes PolygonZ (15)

Select All | | Deselect All
b Options

Qcancel |@Add Layers

Puc. 5.3: Select layers within a file

6. In our case there is a single C lakes layer. Select it and press Add Layers.
7. The layer is added to the Layers panel

4. Close the Data Source Manager window

In the Layers panel, you can notice that the lakes layer displays ' Layer has no coordinate reference sysem set pex fo it, Let's
adjust that.

1. Click the ? icon. The Coordinate Reference System Selector dialog opens.

2. As done earlier, find and select the NAD27 / Alaska Albers CRS entry.

3. Kiuknute OK.
You now have the two layers available in your project in some random colours. Let’s do some customization on the
lakes layer.

1. Select the }-ﬁ ZoomIn 0] on the Navigation toolbar

2. Zoom to an area with some lakes

3. Double-click the 1akes layer in the map legend to open the Properties dialog

4. To change the lakes color:

1. Click on the (\( Symbology tab

2. Select blue as fill color.

5.3. Sample Session: Loading raster and vector layers 17
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= .
fZ ' Information

2 source

Q{ Symbology

€= Labels

€O Masks
Ny 3D View
. Diagrams
B rields
E Attributes Form

Joins

ﬁ Auxiliary Storage
@ Actions
. Display

Rendering

L Temporal

Layer Properties — lakes — Symbology

®

| 2 single symbol

[ simple Fill

T | = |

Color | |E|
Opacity 1000% |- €
Unit | Millimeters - |
| @ Favorites a |~ | 8
Default 3
[
gradient plasma gray 3 fill hashed black / hashed black', hashed black X =

b Layer Rendering

_[@elp |[ sty

Puc. 5.4: Selecting Lakes color

3. Press OK. Lakes are now displayed in blue in the map canvas.

5. To display the name of the lakes:

1. Reopen the 1akes layer Properties dialog

2. Click on the Labels tab

3. Select Single labels in the drop-down menu to enable labeling.

4. From the Label with list, choose the NAME S field.

|save Ssymbol... | | Advanced - |

 ©@apply || @cancel || QoK |

18
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Layer Properties — lakes — Labels %
= Single Labels - ||
2) information ~ value | < NAMES (e
v Text Sample
32 source -
%’ symbology Lorem Ipsum
{abs Labels -
Lorem Ipsum | [1:1000000 ~ | |&; |~ v
€D Masks
ERCT -
< -
Wy 3D View "% Formatting Font  Ubuntu &
DI & Buffer
lagrams sbe Mask Style  Regular - €
B Fies @ Background u&ise e e
J Shadow =
B8 Attributes Form # Callouts Size  10.0000 e
Joins #* Placement Points K=s
_/ Rendering
&) Auxiliary storage color | (NN - <.
- Opaci _11100.0 % -
{;@ Actions pacity A=
Allow HTML formatting
- Display
) 2. Favorites -] &
4’ Rendering -
Default
G' Temporal
VELEDIES A3 Aa

(sl -

=._.l Elevation

Save Settings...

_| @Help Style -~ @~2pply | ©cancel

m Metadata

Puc. 5.5: Showing Lakes names

5. Press Apply. Names will now load over the boundaries.
6. You can improve readability of the labels by adding a white buffer around them:

1. Click the Buffer tab in the list on the left

Check A Draw text buffer
Choose 3 as buffer size
Knukuure [Tpumenuts Apply.

Check if the result looks good, and update the value if needed.

AN

Finally click OK to close the Layer Properties dialog and apply the changes.

5.3. Sample Session: Loading raster and vector layers 19
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(2 Layer Properties — lakes — Labels X
ST | =r=yyeoes =
& rrormatio = b =
1 Information %‘ue abc NAMES =
a w Text Sample
AN Source
Lorem Ipsum
{abe| Labels =
Lorem Ipsum Fa - 'h = .
D Masks wbe Text Buffer
\‘i 3D View %% Formatting V| Draw textbuffer (=]
Sy Size 3.0000 -
1 Diagrams abel Mask - >
. @ Background Millmeters = EL
E Fields
\;ﬂ Shadow Color c
E Attributes Form ° Callouts =5
% Color buffer's fill
4% Placement
Joins _,“ Rendering Opacity _11100.0 % - EL
G" Augxiliary Storage e a — - EL
(@ Actions Blend mode | Normal - {EL
- Display Draw effects
/’
& Rendering
c‘ Temporal
Variables
=I Elevation
E Metadata
ﬁ Dependencies
n - Sl | oK Cancel Apply Help
T —

Puc. 5.6: Showing Buffers around Labels

Let’s now add some decorations in order to shape the map and export it out of QGIS:
1. Select View » Decorations » Scale Bar menu

. In the dialog that opens, check i Enable Scale Bar option

. Customize the options of the dialog as you want

Press Apply

ISR

Likewise, from the decorations menu, add more items (north arrow, copyright...) to the map canvas with
custom properties.

6. Click Project » Import/Export » % Export Map to Image...
7. Press Save in the opened dialog

8. Select a file location, a format and confirm by pressing Save again.

=]
9. Press Project » Save... to store your changes as a . qgz project file.
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Skilak Lake -
g

mena Lake

Puc. 5.7: Showing Exported Map with Decorations

That’s it! You can see how easy it is to visualize raster and vector layers in QGIS, configure them and generate your
map in an image format you can use in other softwares. Let’s move on to learn more about the available functionality,
features and settings, and how to use them.

IIpumeuanne: To continue learning QGIS through step-by-step exercises, follow the Training manual.

5.3. Sample Session: Loading raster and vector layers 21
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Working with Project Files

6.1 Introducing QGIS projects

The state of your QGIS session is called a project. QGIS works on one project at a time. A setting can be project-
specific or an application-wide default for new projects (see section /lapamempst). QGIS can save the state of your

workspace into a QGIS project file using the menu options Project » =1 Save or Project » 1214 Save As....

IIpumeuanue: If the project has been modified the * symbol will appear in the title bar and QGIS will, by default,

ask you if you would like to save the changes. This behavior is controlled by the oA Prompt to save project and data
source changes when required setting under Settings » Options » General.

You can load existing projects into QGIS from the Browser panel or by through Project » Open..., Project »
New from template or Project » Open Recent ».

At startup, a list of Project Templates and Recent Projects are displayed, including screenshots, names and file paths
(for up to ten projects). The Recent Projects list is handy to access recently used projects. Double-click an entry
to open the project or project template. Right-click an entry to Pin to List, Open Directory... or Remove from List.
You can also add a layer to create a new project automatically. The lists will then disappear, giving way to the map
canvas.

If you want to clear your session and start fresh, go to Project » D New. This will prompt you to save the existing
project if changes have been made since it was opened or last saved.

When you open a fresh project, the title bar will show Untitled Project until you save it.
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Untitled Project - QGIS
JGIE4d Edit View Layer Settings Plugins Vector Raster Database Web Mesh Processing Help

B New ) Ctrl+N jiJ @) je =W LN~ | 5 »

New from Template 4

Open... ctrl+o =% @ P> VAR? A

Open From 3 0 N .

Open Recent 4

Close
[ save Ctrl+s Processing Toolbox (=]E3]
[3 save As... ctrl+Shift+s wae OF 2,

Save To 4 Q. Search...

Revert... (Y Recently used =

Properties... Ctrl+Shift+P (@ Database

I _cila kanle

3
» (@ Cartography
3
1Y

Snapping Options...
Import/Export b Results Viewer (=]ES]
5y New Print Layout... Ctrl+P
| New Report...
% Layout Manager...
Layouts »
Exit QGIS Ctrl+Q

"4

Q. Type to locate (Ctrl+K) i -0887,0074 B : 11921941 = | & r|100% =R 2|V Render ¢ gpscizze @

Puc. 6.1: Starting a new project in QGIS

The information saved in a project file includes:
* Layers added
* Which layers can be queried
¢ Layer properties, including symbolization and styles
* Layer notes
e 2D and 3D map views
* Projection for each map view
¢ Last viewed extent for each map
* Print layouts
* Print layout elements with settings
¢ Print layout atlas settings
* Digitizing settings
* Table Relations
* Project Macros
¢ Project default styles

¢ Plugins settings

QGIS Server settings from the OWS settings tab in the Project properties
* Queries stored in the DB Manager

The project file is saved in XML format (see QGS/OGZ - The QGIS Project File Format). This means that it is
possible to edit the file outside of QGIS if you know what you are doing. The project file format has been updated
several times. Project files from older QGIS versions may not work properly any more.
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IIpumeuanne: By default, QGIS will warn you of version differences. This behavior is controlled in the General

tab of Settings » Options (IZ Warn when opening a project file saved with an older version of QGIS).

Whenever you save a . ggs project file in QGIS, a backup of the file is created in the same directory as the project
file, with the extension . ggs~.

The extension for QGIS projects is . ggs but when saving from QGIS, the default is to save using a compressed
format with the . ggz extension. The . ggs file is embedded in the . ggz file (a zip archive), together with its
associated SQLite database (. qgd) for auxiliary data. You can get to these files by unzipping the . ggz file.

IIpumeuanne: The Auxiliary Storage Properties mechanism makes a zipped project particularly useful, since it
embeds auxiliary data.

Projects can also be saved/loaded to/from a PostgreSQL, GeoPackage or Oracle database using the following Project
menu items:

¢ Project » Open from
* Project » Save to

Both menu items have a sub-menu with a list of extra project storage implementations (PostgreSQL, GeoPackage
and Oracle). Clicking the action will open a dialog to pick a GeoPackage connection and project, a PostgreSQL
connection, schema and project or Oracle connection, owner and project.

Projects stored in GeoPackage, PostgreSQL or Oracle can also be loaded through the QGIS browser panel, either
by double-clicking them or by dragging them to the map canvas.

6.2 Handling broken file paths

When opening a project, QGIS may fail to reach some data sources due to unavailable service/database, or to a
renamed or moved file. QGIS then opens the Handle Unavailable Layers dialog, referencing the unfound layers.
You can:

¢ Double-click in the Datasource field, adjust the path of each layer and click Apply changes;
* Select a row, press Browse to indicate the correct location and click Apply changes;

¢ Press Auto-Find to browse the folders and try to automatically fix all or selected broken path(s). Be aware
that the browsing may take some time. Then click Apply changes.

* Ignore the message and open your project with the broken path(s) by clicking Keep Unavailable Layers.

Your layer is then displayed in the Layers panel, but without any data until you fix the path using the £\
Unavailable layer! joon pext to it in the Layers panel, or Repair Data Source... in the layer contextual menu.

With the Repair Data Source... tool, once a layer path has been fixed, QGIS scans through all other broken
paths and tries to auto-fix those that have the same broken file path.
o W Remove Unavailable Layers from the project.

Launching QGIS from command line using the --skipbadlayers option can help you skip the Handle Unavailable
Layers dialog at startup.
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6.3 Generating output

There are several ways to generate output from your QGIS session. We have already discussed saving as a project
file in Introducing QGIS projects. Other ways to produce output files are:

¢ Creating images: Project » Import/Export » =) Export Map to Image... outputs the map canvas rendering

to an image format (PNG, JPG, TIFF...) at custom scale, resolution and size. Including georeference

information in the exported image is possible, simply enable g Append georeference information (embedded
or via world file). See Exporting the map view for more details.

Exporting to PDF files: Project » Import/Export » Export Map to PDF... outputs the map canvas rendering to
PDF at custom scale, resolution, and with some advanced settings (simplification, georeferencing, ...). See
Exporting the map view for more details.

Exporting to DXEF files: Project » Import/Export » Export Project to DXF... opens a dialog where you can
define the ,,Symbology mode®, the ,,Symbology scale* and vector layers you want to export to DXF. Through
the ,,Symbology mode®, symbols from the original QGIS Symbology can be exported with high fidelity (see
section Creating new DXF files).

Designing maps: Project » h New Print Layout... opens a dialog where you can layout and print the current
map canvas (see section Laying out the maps).
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QGIS GUI

The QGIS graphical user interface (GUI) is shown in the figure below (the numbers 1 through 5 in yellow circles
indicate important elements of the QGIS GUI, and are discussed below).

documentation3.qgs - QGIS
Project Edit View Layer Settings Plugins Vector Raster _Databi1 leb Mesh Processing Help
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Browser Processing Toolbox
LIEEREXS %408 9 A
& v - Favorites = Q search...

» [¥ Project Home R tly d
V; » " spatial Bookmarks gc:::o“gr:::;
.’}_3 b [&) Home 3 @ Database

r [/ @ File tools
ﬁ @ GeoPackage @ Graphics
2 / SpatiaLite @ Interpolation
I ) @ postcis @ Layer tools

: MSSQL - @ Network analysis
R— (1 Raster analysis

@ Raster terrain analysis
(@ Raster tools

@ vector analysis é)
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Q@ Vector general
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& scripts

« @ e T &R L

[ regions
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Q Type to locate (Ctrl+k) 5 ' Coordinate | 176.2207,67.2258 | ¥ scale| 114739258 | = | Magnifier | 100% 4] Rotation |00° || 1w Render & epsc2ses @

Puc. 7.1: QGIS GUI with Alaska sample data

Ipumeuanne: BuemrHuil Buj1 371eMeHTOB uHTEpdeiica (3aroJ0BKM OKOH U T.I1.) MOXKET OTJIMYATHCS, B 3aBUCHCMOCTH
OT OIMEPAIMOHHON CUCTEMbI 1 MEHEKEPa OKOH.

The main QGIS GUI (Puc. 7.1) consists of five components / component types:
1. Menu Bar
2. Toolbars
3. Panels
4. Map View
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5. Status Bar

Scroll down for detailed explanations of these.

7.1 TnaBHOe MeHIo

The Menu bar provides access to QGIS functions using standard hierarchical menus. The Menus, their options,
associated icons and keyboard shortcuts are described below. The keyboard shortcuts can be reconfigured (Settings
» Keyboard Shortcuts).

Most menu options have a corresponding tool and vice-versa. However, the Menus are not organized exactly like
the toolbars. The locations of menu options in the toolbars are indicated below in the table. Plugins may add new
options to Menus. For more information about tools and toolbars, see [larneau uncmpymenmoas.

IIpumeuanne: QGIS is a cross-platform application. Tools are generally available on all platforms, but they may
be placed in different menus, depending on the operating systems. The lists below show the most common locations,
including known variations.

7.1.1 MpoekTr

The Project menu provides access and exit points for project files. It provides tools to:

* Create a New project file from scratch or use another project file as a template (see Project files options for
template configuration)

e Open... a project from a file, a GeoPackage, PostgreSQL or Oracle database
* Close a project or revert it to its last saved state

e Save a project in . ggs or .ggz file format, either as a file or within a GeoPackage, PostgreSQL or Oracle
database

» Export the map canvas to different formats or use a print layout for more complex output

 Set project properties and snapping options for geometry editing.
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Ta6muna 7.1: The Project menu items

[MyHKT MeHIo KombuHauus kna- [Ma- Cnpaska
BULL Henb

NH-

CTpy-

MEHTOB
D New Ctrl+N Ilpoexkm  Introducing QGIS projects
Cozoambe u3 wabnrona » Introducing QGIS projects
= Open... Ctrl+0 Ilpoexm  Introducing QGIS projects
Open from » Introducing QGIS projects
» GeoPackage... Introducing QGIS projects
» PostgreSQL... Introducing QGIS projects
» Oracle... Introducing QGIS projects
Open Recent » Alt+J+R Introducing QGIS projects
Close Introducing QGIS projects
=]
Save Ctrl+s Ilpoexm  Introducing QGIS projects
=
Save As... Ctrl+Shift+S Ilpoexm  Introducing QGIS projects
Save to » Introducing QGIS projects
» Templates... Introducing QGIS projects
» GeoPackage... Introducing QGIS projects
» PostgreSQOL... Introducing QGIS projects
Revert...
[ 3
¥ Properties... Ctrl+Shift+P Ceoiicmea npoekma
Snapping Options... Snapping and Digitizing Options
Import/Export »
> ﬁlﬂ Export Map to Image... Exporting the map view
- % Export Map to PDF... Exporting the map view
» Export Project to DXF... Creating new DXF files
» Import Layers from DWG/DXF... Importing a DXF or DWG file
"L New Print Layout... Ctrl+P Ilpoexm  Laying out the maps
|D New Report... Creating a Report
’T\q Layout Manager... Ilpoexm  Laying out the maps
Layouts » Laying out the maps
Models » The model designer
@Exit OGIS Ctrl+Q

Under X macOS, the Exit QGIS command corresponds to QGIS » Quit QGIS (Cmd+0Q).

7.1.2 lpaBka

The Edit menu provides most of the native tools needed to edit layer attributes or geometry. To enable Edit menu

options you need to switch to editing mode by clicking on §/ Toggle editing (see Peoaxmuposarue for details).

7.1. TnhaBHOe MeHI0
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Tabmuma 7.2: The Edit menu items

[MyHKT MeHIO KombuHaums MaHenb Cnpaska
KnaswLw VHCTPY-
MEHTOB
@ Undo Ctrl+z Ouugpposka  Ommernumse u Beprymeo
@ Redo Ctrl+Shift+Z Ouyugpoeka Ommenumo u Beprymuo
=,
“S Cut Features Ctrl+X Ouugppoexa  Beipezamy, Konuposams
U 6CMasumv 00veKNblL
Copy Features Ctrl+C Ouugppoexa  Beipezamy, konuposamo
U 6cmasumv 00veKNblL
-
Paste Features Ctrl+v Ouugppoeka  Beipezamp, Konuposams
U 6cmasums 00veKNblL
Paste Features as » Working with the
Attribute Table
» New Vector Layer... Working with the
Attribute Table
» Temporary Scratch Layer... Ctrl+Alt+V Working with the
Attribute Table
@ Delete Selected Ouugppoeka  Yoanenue 8bl0eneHHBIX
00BeKmMog
Buviopame » Selecting features
» 33 Select Fi eature(s) Selection Selecting features
=
» %% Select Features by Polygon Selection Selecting features
» A2 Select Features by Freehand Selection Selecting features
B
» "% Select Features by Radius Selection Selecting features
» ‘= Select Features by Value... F3 Selection Selecting features
> € Select Features by Expression... Ctrl+F3 Selection Selecting features
» & Deselect Features from All Layers Ctrl+Alt+A Selection Selecting features
» (@ Deselect Features from the Current Active Ctrl+Shift+A Selection Selecting features
Layer
» Reselect Features Selecting features
> Select All Features Ctrl+A Selection Selecting features
> —l Invert Feature Selection Selection Selecting features
=3 Add Record Ctrl+. Oyugbposka
oo
® €1 Add Point Feature Ctrl+. Ouucpposka  Jlobasnerue 006ekmos
“L2 Add Line Feature Ctrl+. Ouugpposxa  [obasnenue o6veknmos
Add Polygon Feature Ctrl+. Oyugbposxa  /lobasneriue 006eKmos
s £3 Add Circular String Shape Circular string by radius
Digitizing
& £3 Add Circular String by Radius Shape Circular string by radius
Digitizing
Add Circle » Shape Draw Circles
Digitizing
continues on next page
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Tabnuua 7.2 - NpoLOMXEHNE C NpeablayLlWei cTpaHnubI

[TyHKT MeHI0 KombuHaums MaHenb Cnpaska
KnasuLw VHCTPY-

MEHTOB

> Add Circle from 2 Points Shape Draw Circles
Digitizing

- Add Circle from 3 Points Shape Draw Circles
Digitizing

~

» L1 Add Circle from 3 Tangents Shape Draw Circles

Digitizing
—

» "3 Add Circle from 2 Tangents and a Point Shape Draw Circles
Digitizing

» 23 Add Circle by a Center Point and Another Shape Draw Circles

Point Digitizing

Add Rectangle » Shape Draw Rectangles
Digitizing

> g Add Rectangle from Extent Shape Draw Rectangles
Digitizing

- L Add Rectangle from Center and a Point Shape Draw Rectangles
Digitizing

- Add Rectangle from 3 Points (Distance Shape Draw Rectangles

from 2nd and 3rd point) Digitizing

- g Add Rectangle from 3 Points (Distance Shape Draw Rectangles

from projected point on segment pl and p2) Digitizing

Add Regular Polygon » Shape Draw Regular Polygons
Digitizing

» L0 Add Regular Polygon from Center and a Shape Draw Regular Polygons

Point Digitizing

» L0 Add Regular Polygon from Center and a Shape Draw Regular Polygons

Corner Digitizing

> Add Regular Polygon from 2 Points Shape Draw Regular Polygons
Digitizing

Add Ellipse » Shape Draw Ellipses
Digitizing

= “1 Add Ellipse from Center and 2 Points Shape Draw Ellipses
Digitizing

> Add Ellipse from Center and a Point Shape Draw Ellipses
Digitizing

» . Add Ellipse from Extent Shape Draw Ellipses
Digitizing

> “01Add Ellipse from Foci Shape Draw Ellipses
Digitizing

Add Annotation »

T .
> Text Annotation

Hnempymenmol — anmno-
mayuu

Annotations ~ Uncmpymenmot — anHo-
mavuu

continues on next page

7.1. TnhaBHOe MeHI0
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Tabnuua 7.2 - NpoLOMXEHNE C NpeablayLlWei cTpaHnubI

[TyHKT MeHI0 KombuHaums MaHenb Cnpaska
KnasuLw VHCTPY-
MEHTOB
» . Form Annotation Annotations ~ MHcmpymernmsl — aHHO-
mayuu
B0
» .~ HTML Annotation Annotations ~ UHcmpymernmsl — aHHO-
mayuy
> SVG Annotation Annotations ~ UHcmpymernmsl — aHHO-
mayuu
Edit Attributes »
- y Modify Attributes of Selected Features Oyugbposka  Editing attribute values
» = Merge Attributes of Selected Features Advanced Obvedurumo ampu-
Digitizing oymuol BbIOPAHHBIX
00BeKmMOo8
Edit Geometry »-
> % Move Feature(s) Advanced Move Feature(s)
Digitizing
=
- CES Copy and Move Feature(s) Advanced Move Feature(s)
Digitizing
- C& Rotate Feature(s) Advanced [oseprymo o6vexm
Digitizing
> % Scale Feature(s) Advanced Scale Feature
Digitizing
> % Simplify Feature Advanced Ynpocmumu o6vexm
Digitizing
(@)
> Add Ring Advanced Jlobasume Konvyo
Digitizing
> %U Add Part Advanced Jobasumo uacmo
Digitizing
> Fill Ring Advanced Fill Ring
Digitizing
(@)
» & Delete Ring Advanced Yoanumu konvyo
Digitizing
» & Delete Part Advanced Yoarume uacme
Digitizing
> {.P Reshape Features Advanced Koppexmuposames  06%-
Digitizing eKmol
> G) Offset Curve Advanced Tapannenvras kpusas
Digitizing
ade
» o% Split Features Advanced Pazoume ob6wexmoi
Digitizing
a :
» &% Split Parts Advanced Split parts
Digitizing

continues on next page
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Tabnuua 7.2 - NpoLOMXEHNE C NpeablayLlWei cTpaHnubI

[TyHKT MeHI0 KombuHaums MaHenb Cnpaska
KnasuLw VHCTPY-
MEHTOB
> C?j Merge Selected Features Advanced O6Bedunums — 6b10parH-
Digitizing Hble 00BeKMbl
» I % Vertex Tool (All Layers) Oyugbposka  Vertex tool
- /E(z Vertex Tool (Current Layer) Ouyugbposxa  Vertex tool
» & Reverse Line Advanced Reverse Line
Digitizing
|
» 'L Trim/extend Feature Advanced Trim/Extend Feature
Digitizing
e o
Rotate Point Symbols Advanced [loseprymo 3Hauku
Digitizing
A
7" Offset Point Symbols Advanced Offset Point Symbols
Digitizing

Tools that depend on the selected layer geometry type i.e. point, polyline or polygon, are activated accordingly:

Tabnuna 7.3: The «Move feature» geometry based icons

[MyHKT MEHIO Touka MonunnHus MonuroH
g q
Move Feature(s) ‘D = %
) V- (|
Copy and Move Feature(s) = o= CEE
7.1.3 Bug

The map is rendered in map views. You can interact with these views using the View tools. For example, you can:
¢ Create new 2D or 3D map views next to the main map canvas
e Zoom or pan to any place
* Query the attributes or geometry of the displayed features
¢ Enhance the map view with preview modes, annotations or decorations
¢ Access any panel or toolbar
The menu also allows you to reorganize the QGIS interface itself using actions like:
* Toggle Full Screen Mode: covers the whole screen while hiding the title bar

¢ Toggle Panel Visibility: shows or hides enabled panels - useful when digitizing features (for maximum canvas
visibility) as well as for (projected/recorded) presentations using QGIS main canvas

* Toggle Map Only: hides panels, toolbars, menus and status bar and only shows the map canvas. Combined
with the full screen option, it makes your screen display only the map
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Tabmuma 7.4: The View menu items

[MyHKT MEHIO KombuHaumst «kna- [MaHenb Cnpaska
BULL VHCTPY-
MEHTOB
New Map View Ctrl+M Map 2D Map View
Navigation
3D Map Views » 3D Map View
> New 3D Map View Ctrl+Alt+M Map 3D Map View
Navigation
» Manage 3D Map Views 3D Map View
@ Pan Map Map Exploring the map view
Navigation
£
¥+ Pan Map to Selection Map Exploring the map view
Navigation
4;-!." Zoom In Ctrl+Alt++ Map Exploring the map view
Navigation
&~ Zoom Out Ctrl+Alt+- Map Exploring the map view
Navigation
Q% Identify Features Ctrl+Shift+I Ampuoy- Identifying Features
Mol
Hzmepumpo » Ampuby- H3zmepenus
Mol
[ —
» ™ Measure Line Ctrl+Shift+M Ampuby-  Hzmepenus
Mol
» M Measure Area Ctrl+Shift+J Ampuby- H3zmepenus
mol
> T/ Measure Bearing Ampuby- H3zmepenus
Mot
F. &
» ™ Measure Angle Ampuby- H3zmepenus
mol
z Statistical Summary Ampuby- Statistical Summary
Mol Panel
F Elevation Profile Elevation Profile View
;: Zoom Full Ctrl+Shift+F Map Exploring the map view
Navigation
..F'\I
&~ Zoom To Selection Ctrl+Jd Map Exploring the map view
Navigation
r"\l
9 ~ Zoom To Layer(s) Map Exploring the map view
Navigation
__
1:1)
y’" Zoom To Native Resolution (100%) Map Exploring the map view
Navigation
# Zoom Last Map Exploring the map view
Navigation
2 Zoom Next Map Exploring the map view
Navigation
Ogpopmnenue » Alt+V+D Decorating the map

continues on next page
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Tabnuua 7.4 - NpoLONXeEHNE C NpeablayLlWei cTpaHnLbI

[MyHKT MEHIO KombuHaumst «kna- [MaHenb Cnpaska
BULL VHCTPY-
MEHTOB
> E Grid... Cemka
» & Scale Bar-... Macwmabnas aunelixa
» L Image... Image Decoration
> ﬁb North Arrow... Ykazamenw «cesep-roe»
> -rD Title Label... Title Label
» & Copyright Label... Copyright Label
» L3 Layout Extents... Layout Extents
Preview mode »
» Normal
» Simulate Monochrome
» Simulate Achromatopsia Color Blindness
(Grayscale)
» Simulate Protanopia Color Blindness (No
Red)
» Simulate Deuteranopia Color Blindness (No
Green)
» Simulate Tritanopia Color Blindness (No
Blue)
& Show Map Tips Ampuoy- Display Properties
mol
W New Spatial Bookmark... Ctrl+B Map Bookmarking extents on
Navigation  the map
Show Spatial Bookmarks Ctrl+Shift+B Map Bookmarking extents on
Navigation  the map
Show Spatial Bookmark Manager Bookmarking extents on
the map
|
B/ Refresh F5 Map
Navigation
Layer Visibility » Layers Panel
- Show All Layers Ctrl+Shift+U Layers Panel
» = Hide All Layers Ctrl+Shift+H Layers Panel
» 1 Show Selected Layers Layers Panel
» “=7| Hide Selected Layers Layers Panel
- b’“ Toggle Selected Layers Layers Panel
» Toggle Selected Layers Independently Layers Panel
-~ Hide Deselected Layers Layers Panel
Tlanenu » Panels and Toolbars
Taneau uncmpymenmog » Panels and Toolbars
Toggle Full Screen Mode F11
Toggle Panel Visibility Ctrl+Tab
Toggle Map Only Ctrl+Shift+Tab

Under Linux KDE, Panels », Toolbars » and Toggle Full Screen Mode are in the Settings menu.

7.1. TnhaBHOe MeHI0
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7.1.4 Cnon

The Layer menu provides a large set of tools to create new data sources, add them to a project or save modifications
to them. Using the same data sources, you can also:

* Duplicate a layer to generate a copy where you can modify the name, style (symbology, labels, ...), joins, ...
The copy uses the same data source as the original.

e Copy and Paste layers or groups from one project to another as a new instance whose properties can be
modified independently. As for Duplicate, the layers are still based on the same data source.

* or Embed Layers and Groups... from another project, as read-only copies which you cannot modify (see
Embedding layers from external projects)

The Layer menu also contains tools to configure, copy or paste layer properties (style, scale, CRS...).

Ta6muma 7.5: The Layer menu items

[MyHKT MEHIO KombuHauus MaHenb uHctpy- ChpaBka
Knasul MEHTOB

‘5 Data Source Manager Ctrl+L Data Source  Opening Data
Manager

Create Layer » Creating new vector layers

> @ New GeoPackage Layer... Ctrl+Shift+N Data Source  Creating a new GeoPackage
Manager layer

> ‘v"’ New Shapefile Layer... Data Source  Creating a new Shapefile
Manager layer

> ﬁ New SpatiaLite Layer... Data Source  Creating a new SpatiaLite
Manager layer

> I:'Iﬁ New Temporary Scratch Layer... Data Source  Creating a new Temporary
Manager Scratch Layer

> E] New Mesh Layer... Data Source  Creating a new Mesh layer
Manager

> E:I New GPX Layer... Data Source  Creating a new GPX layer
Manager

> @ New Virtual Layer... Data Source  Creating virtual layers
Manager

Add Layer » Opening Data

> <\fl.ilﬁ Add Vector Layer...... Ctrl+Shift+V Manage Layers Loading a layer from a file

- 'C! Add Raster Layer... Ctrl+Shift+R Manage Layers Loading a layer from a file

- % Add Mesh Layer... Manage Layers Loading a mesh layer

> ’D Add Delimited Text Layer... Ctrl+Shift+T Manage Layers Importing a delimited text

file

> 'D Add PostGIS Layer... Ctrl+Shift+D Manage Layers Database related tools

- ﬁé Add SpatiaLite Layer... Ctrl+Shift+L Manage Layers SpatiaLite Layers

> R Add MS SQL Server Layer... Manage Layers Database related tools

> q}l Add Oracle Spatial Layer... Manage Layers Database related tools

W ,
» % Add SAP HANA Spatial Layer... Manage Layers Database related tools
- Iga Add/Edit Virtual Layer... Manage Layers Creating virtual layers

continues on next page

36

Masa 7. QGIS GUI



QGIS Desktop 3.34 User Guide

Tabnuua 7.5 - NpoLonNXeHNe C Npeablaywei cTpaHnLbl

[MyHKT MEHIO KoMmbuHauus MaHenb uHctpy- CnpaBska
Knasuil MEHTOB
> Add WMS/WMTS Layer... Ctrl+Shift+W Manage Layers 3aepyska WMS/WMTS-
cnoés
mam
» ""0 Add XYZ Layer... Using XYZ Tile services
> % Add WCS Layer... Manage Layers Kauenm WCS
> ‘J“‘\‘-'El Add WFS / OGC API - Features Manage Layers Kauenm WES u WES-T
Layer...
fu )
» S0 Add ArcGIS REST Server Manage Layers Using ArcGIS REST Servers
Layer...
> @J Add Vector Tile Layer... Using Vector Tiles services
o
> ,ﬁ Add Point Cloud Layer... Working with Point Clouds
> EE Add GPX Layer... Introducing GNSS/GPS Data
Embed Layers and Groups... Embedding layers  from
external projects
Add from Layer Definition File... Layer definition file
Georeferencer... Georeferencer
E Copy Style Save and Share Layer
Properties
% Paste Style Save and Share Layer
Properties
E Copy Layer
Paste Layer/Group
Open Attribute Table F6 Ampubymuol Working with the Attribute
Table
Filter Attribute Table » Working with the Attribute
Table
> ifl Open Attribute Table (Selected Shift+F6 Ampubymuol Working with the Attribute
Features) Table
> Open Attribute Table (Visible Ctrl+F6 Ampubymul Working with the Attribute
Features) Table
> Open Attribute Table (Edited and Ampubymul Working with the Attribute
New Features) Table
4 Toggle Editing Oyugpposka Peoaxmuposariue cyue-
CIMBYIOULe20 CAOS.
=1 Save Layer Edits Ouyugpposra Coxpanenue ompedakmupo-
BAHHDIX CN0€8
;&' Current Edits » Ouyugbposra Coxpanenue ompedakmupo-
BAHHBIX CN0€8
» Save for Selected Layer(s) Ouyugpposra Coxpanernue ompedakmupo-
BAHHBIX CN0E8
» Rollback for Selected Layer(s) Ouyugpposka Coxpanenue ompedakmupo-
BAHHDIX CN0€8
» Cancel for Selected Layer(s) Ouyugpposra Coxpanenue ompedaKmupo-

BUHHBIX Cr0€eB8

continues on next page
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Tabnuua 7.5 - NpoLonNXeHNe C Npeablaywei cTpaHnLbl

[MyHKT MEHIO KoMmbuHauus MaHenb uHctpy- CnpaBska
Knasuil MEHTOB
» Save for all Layers Oyugpposra Coxparernue ompedakmupo-
BAHHBIX CA0EB
» Rollback for all Layers Ouugpposxa Coxpanenue ompedakmupo-
BAHHDIX CN0E8
» Cancel for all Layers Ouugpposra Coxpanernue ompedaKmupo-
BAHHBIX CN0€8
Save As... Creating new layers from an
existing layer
Save As Layer Definition File... Layer definition file
ﬂ Remove Layer/Group Ctrl+D
LL—‘ Duplicate Layer(s)
Set Scale Visibility of Layer(s) Visibility Scale Selector
Set CRS of Layer(s) Ctrl+Shift+C Layer Coordinate Reference
Systems
Set Project CRS from Layer Project Coordinate
Reference Systems
Layer Properties...
* vector
* raster
* mesh
* point cloud
* vector tiles
Filter... Ctrl+F Query Builder
kel Labeling Labels Properties
& Show in Overview Overview Panel
Y9 Show All in Overview Overview Panel
oo
Hide All from Overview Overview Panel

7.1.5 YcTaHOBKM

Ta6suna 7.6: The Settings menu items

MyHKT MeHIo Cnpaska

User Profiles »

> default

» Open Active Profile Folder
» New Profile...

[ T4
Ba Style Manager...
Y

)

=i Custom Projections...
0
OC1 Keyboard Shortcuts. ..

[ .
@ Interface Customization...
RN Options...

Working with User Profiles
Working with User Profiles
Working with User Profiles
Working with User Profiles

The Style Manager

Tlonavzosamenvckue cucmembl IC()OP()L{HClm

Keyboard shortcuts

Hacmporixa unmepgetica
Ilapamempot

Under Linux KDE, you’ll find more tools in the Settings menu such as Panels », Toolbars » and Toggle Full

Screen Mode.
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7.1.6 Moaynu

Tabmmna 7.7: The Plugins menu items

[MyHKT MeHI0 KombrHaumsi Maneno  wH- CnpaBka

KnaBull CTPYMEHTOB
% Manage and Install Plugins... The Plugins Dialog
«a Python Console Ctrl+Alt+P Plugins Konconv QGIS Python

When starting QGIS for the first time not all core plugins are loaded.

7.1.7 BekTop

This is what the Vector menu looks like if all core plugins are enabled.

Taommna 7.8: The Vector menu items

MyHKT MeHIo KombuHaums [a- Cnpaska
Knasul Henb

NH-

CTpy-

MEHTOB
Q Check Geometries... Geometry Checker Plugin
:ﬁ Topology Checker Vector Topology Checker Plugin
Geoprocessing Tools » Alt+0+G
- ? Buffer... Buffer
> @ Clip... Clip
> i Convex Hull... Convex hull
> p Difference... Difference
> ' Dissolve... Dissolve
> @ Intersection... Intersection
> @ Symmetrical Difference... Symmetrical dif ference
> ' Union... Union
> ' Eliminate Selected Polygons... Eliminate selected polygons
Geometry Tools » Alt+O+E
> f:'c_:j Centroids. .. Centroids
> I?E?%‘ Collect Geometries. .. Collect geometries
> QHQO Extract Vertices... Extract vertices
> (@:J Multipart to Singleparts... Multipart to singleparts
- G} Polygons to Lines... Polygons to lines
- g Simplify... Simplify
> v Check Validity. .. Check validity
> ‘ Delaunay Triangulation... Delaunay triangulation

continues on next page
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Tabnuua 7.8 - NpoLoNXeEHNE C NpeablayLWei cTpaHnLbI

[TyHKT MeHIO KombuHaums  [la- Cnpagka
KnaBul Henb

NH-

CTpYy-

MEHTOB
> CE%E Densify by Count... Densify by count
» T Add Geometry Attributes. .. Add geometry attributes
> 6) Lines to Polygons... Lines to polygons
> - Voronoi Polygons... Voronoi polygons
Analysis Tools » Alt+0+A
> 361 Line Intersection. .. Line intersections

®3
= €4 Mean Coordinate(s)... Mean coordinate(s)
> Z Basic Statistics for Fields... Basic statistics for fields
> (%:@ Count Points in Polygon... Count points in polygon
> E Distance Matrix... Distance matrix
==
» = List Unique Values... List unique values
[+]

- & Nearest Neighbour Analysis... Nearest neighbour analysis
> % Sum Line Lengths... Sum line lengths
Data Management Tools » Alt+0+D
> @ Merge Vector Layers... Merge vector layers
- %’E Reproject Layer... Reproject layer
> %’} Create Spatial Index... Create spatial index
> %} Join Attributes by Location... Join attributes by location
> [”D Split Vector Layer... Split vector layer
Research Tools » Alt+0+R

> H Create Grid...
> E Extract Layer Extent...
> Random Points in Extent...

o
> Eﬁi Random Points in Polygons...
» - ." Random Points on Lines...

» ¥ Select by Location...

> = Select Within Distance...

- Random Points in Layer Bounds...

> Random Points Inside Polygons. ..

» © Random Selection...

»  ? Random Selection Within Subsets...

- Regular Points...

Create grid

Extract layer extent

Random points in extent
Random points in polygons
Random points on lines

Select by location

Select within distance

Random points in layer bounds
Random points inside polygons
Random selection

Random selection within subsets

Regular points

By default, QGIS adds Processing algorithms to the Vector menu, grouped by sub-menus. This provides shortcuts
for many common vector-based GIS tasks from different providers. If not all these sub-menus are available, enable
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the Processing plugin in Plugins » Manage and Install Plugins....

Note that the list of algorithms and their menu can be modified/extended with any Processing algorithms (read
Configuring the Processing Framework) or some external plugins.

7.1.8 Pactp

This is what the Raster menu looks like if all core plugins are enabled.

Ta6muna 7.9: The Raster menu items

[MyHKT MeHIO KomburHa- Ma- Cnpaska
LUna Knasuil Hellb
NH-
CTpy-
MEH-
TOB
Raster calculator... Raster Calculator
Align Rasters. .. Align rasters
Analysis »
-
>~ AL Aspect... Aspect
-
= GOl Fill nodata... Fill NoData
- la Grid (Moving Average)... Grid (Moving average)

- h; Grid (Data Metrics)...

> la Grid (Inverse Distance to a Power)...

> h; Grid (Nearest Neighbor)...

|
> l#I Near Black...
-
» Gl Hillshade...
n
» . Proximity (Raster Distance)...
-
- GOAL Roughness. ..
g
» M Sieve. ..

-
>~ GOAL Slope...

-

> GOAL Topographic Position Index (TPI)...
-

- GOAL Terrain Ruggedness Index (TRI)...

Projections »

» il Assign Projection...
e
5] . .

» & Extract Projection...

> ?(i Warp (Reproject)...
Miscellaneous »

i
> Build Virtual Raster...
> h_!‘ Raster Information...
o
> mim Merge...

» "W Build Overviews (Pyramids)...

Grid (Data metrics)
Grid (Inverse distance to a power)

Grid (IDW with
searching)

nearest neighbor

Near black

Hillshade

Proximity (raster distance)
Roughness

Sieve

Yraon

Topographic Position Index (TPI)
Terrain Ruggedness Index (TRI)

Assign projection
Extract projection

Warp (reproject)

Build virtual raster
Raster information
Merge

Build overviews (pyramids)

continues on next page
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Tabnuua 7.9 - NpoLoNXeEHNE C NpeablayWei cTpaHnLbI

[MyHKT MEHIO KomburHa- Ma- Cnpaska
LA KnasuLl Henb

NH-

CTpy-

MEH-

TOB
> Tile Index... Tile index
Extraction »
> = Clip Raster by Extent... Clip raster by extent
> o Clip Raster by Mask Layer... Clip raster by mask layer
= (7 Contour... Contour
Conversion »

o

» - PCTto RGB... PCT 6 RGB
» S Polygonize (Raster to Vector)... Cozoanue noauzonos (pacmp 6 6eKmop)
> \> Rasterize (Vector to Raster)... Rasterize (vector to raster)
» -*. RGB 10 PCT... RGB to PCT
> % Translate (Convert Format)... Translate (convert format)

By default, QGIS adds Processing algorithms to the Raster menu, grouped by sub-menus. This provides a shortcut
for many common raster-based GIS tasks from different providers. If not all these sub-menus are available, enable
the Processing plugin in Plugins » Manage and Install Plugins....

Note that the list of algorithms and their menu can be modified/extended with any Processing algorithms (read
Configuring the Processing Framework) or some external plugins.

7.1.9 Database

This is what the Database menu looks like if all the core plugins are enabled. If no database plugins are enabled,
there will be no Database menu.

Ta6muma 7.10: The Database menu items

[TyHKT MeHI0 KombvHaumsi [MaHenb uH- Cnpaeka

KnasuLw CTPYMEHTOB
Offline editing... Alt+D + O Offline Editing Plugin
> W Convert to Offline Project... Database Offline Editing Plugin
>~ E?? Synchronize Database Offline Editing Plugin
g DB Manager... Database DB Manager Plugin

When starting QGIS for the first time not all core plugins are loaded.
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7.1.10 Web

This is what the Web menu looks like if all the core plugins are enabled. If no web plugins are enabled, there will
be no Web menu.

Tabmwmma 7.11: The Web menu items

[MyHKT MeHI0 KombvHaumsi [aHenb uH- CnpaBka
Knasww CTPYMEHTOB
MetaSearch » Alt+W+ M MetaSearch Catalog Client
=
)
- @ Metasearch Web MetaSearch Catalog Client
» Help MetaSearch Catalog Client

When starting QGIS for the first time not all core plugins are loaded.

7.1.11 Mesh

The Mesh menu provides tools needed to manipulate mesh layers. Third-party plugins can add items to this menu.

Taoyuna 7.12: The Mesh menu items

MyHKT MeHIo KombuHaumsi TMarenb wH- Cnpaeka
KnaBuLL CTPYMEHTOB
% Mesh Calculator... Mesh Calculator
1 Kz
3" Reindex Faces and Vertices Reindexing meshes

7.1.12 AHanus

Ta6mma 7.13: The Processing menu items

[MyHKT MEHIO KombrHaumsi kna- [Ma- Cnpagka
BULL Henb

NH-
CTpy-
MEHTOB

“* Toolbox Ctrl+Alt+T The Toolbox

## Model Designer... Ctrl+Alt+G The model designer

) History... Ctrl+Alt+H Kypnan

Results Viewer Ctrl+Alt+R Hacmpoiika cmopoHHUX NpUAO#CeHULE
" Edit Features In-Place The Processing in-place layer modifier

When starting QGIS for the first time not all core plugins are loaded.
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7.1.13 Cnpaska

Tat6sumna 7.14: The Help menu items

[MyHKT MeHI0 KombvHaumsi [MaHenb uH- Cnpaeka
KnaBuL CTPYMEHTOB

I:| Help Contents F1l Cnpaska

API Documentation

Plugins »

Report an Issue
Need commercial support?

@ QGIS Home Page Ctrl+H
V" Check QGIS Version

N About
@ OGIS Sustaining Members

7.1.14 QGIS

This menu is only available under X macOS and contains some OS related commands.

Tabmuna 7.15: The QGIS menu items

MyHkT MeHi0  KomBuHaums knaemi

Preferences

About QGIS

Hide QGIS

Show All

Hide Others

Quit QGIS Cmd+Q

Preferences corresponds to Settings » Options, About QGIS corresponds to Help » About and Quit QGIS corresponds
to Project » Exit QGIS for other platforms.
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7.2 Panels and Toolbars

From the View menu (or Settings), you can switch QGIS widgets (Panels ») and toolbars (Toolbars ») on and
off. To (de)activate any of them, right-click the menu bar or toolbar and choose the item you want. Panels and
toolbars can be moved and placed wherever you like within the QGIS interface. The list can also be extended with
the activation of Core or external plugins.

7.2.1 MaHenu NHCTPYMEHTOB

The toolbars provide access to most of the functions in the menus, plus additional tools for interacting with the map.
Each toolbar item has pop-up help available. Hover your mouse over the item and a short description of the tool’s
purpose will be displayed.

Available toolbars are:

Tabuma 7.16: QGIS Toolbars

Toolbar name

Main Reference for tools

Advanced Digitizing
Annotations
Ampubymuol

Data Source Manager
Database
Oyugbposera

GPS

GRASS

Cnpaska

Label

Manage Layers
Map Navigation
Mesh Digitizing
Plugins

Ipoexm

Processing Algorithms
Raster

Selection

Shape digitizing
Snapping

Vector

Web

Jonoanumenvhole gpyrkuun ouupbposKu

Hnempymenmol annomauuu

Working with the Attribute Table, OcHogHbie uHcmpymermol
Managing Data Source

DB Manager Plugin

Peoaxmuposanue cyuecmsyrouezo caos

GPS-caedicerue

Humezpayusi c GRASS GIS

The Label Toolbar

Opening Data

Exploring the map view

Editing a mesh layer

Mooyau

Working with Project Files, Laying out the maps, The Style Library
Configuring the Processing Framework

Mooyau

Selecting features

Shape digitizing

Setting the snapping tolerance and search radius
Mooyau

Mooyau, MetaSearch Catalog Client

IIpumeuanne: Third-party plugins can extend the default toolbar with their own tools or provide their own toolbar.

CoBet: BoccranoB/ieHne nanejeil HHCTPyMEeHTOB

If you have accidentally hidden a toolbar, you can get it back using View » Toolbars » (or Settings » Toolbars
»). If, for some reason, a toolbar (or any other widget) totally disappears from the interface, you'll find tips to get
it back at restoring initial GUI.
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7.2.2 Panels

QGIS provides many panels. Panels are special widgets that you can interact with (selecting options, checking boxes,
filling values...) to perform more complex tasks.

Below is a list of the default panels provided by QGIS:

Tabmauma 7.17: QGIS Panels

Panel name KombuHaums knasuw  Cnpaeka

Advanced Digitizing Ctrl+4 The Advanced Digitizing panel
Browser Ctrl+2 The Browser Panel

Browser (2) The Browser Panel
Debugging/Development Tools F12 Debugging/Development Tools Panel
Elevation Profile

Geometry Validation Digitizing Properties

GPS Information Ctrl+0 GPS-caediceriue

GRASS Tools Humeepayusi ¢ GRASS GIS
Layer Order Ctrl+9 Layer Order Panel

Layer Styling Ctrl+3 Layer Styling Panel

Layers Ctrl+l Layers Panel

Log Messages Log Messages Panel

Overview Ctrl+8 Overview Panel

Processing Toolbox The Toolbox

Results Viewer The Toolbox

Snapping and Digitizing Options Setting the snapping tolerance and search radius
Spatial Bookmark Manager Ctrl+7 Bookmarking extents on the map
Statistics Ctrl+6 Statistical Summary Panel
Temporal Controller The temporal controller panel
Tile Scale Mozauku

Undo/Redo Ctrl+5 Undo/Redo Panel

Vertex Editor The Vertex Editor Panel

7.3 Ctpoka cocTosiHUSA

The status bar provides you with general information about the map view and processed or available actions, and
offers you tools to manage the map view.

7.3.1 MNMaHenb nokatopa
On the left side of the status bar, the locator bar, a quick search widget, helps you find and run any feature or options
in QGIS:

1. Click in the text widget to activate the locator search bar or press Ct r1+K.

2. Type a text associated with the item you are looking for (name, tag, keyword, ...). By default, results are
returned for the enabled locator filters, but you can limit the search to a certain scope by prefixing your text
with the locator filters prefix, ie. typing 1 cad will return only the layers whose name contains cad.

The filter can also be selected with a double-click in the menu that shows when accessing the locator widget.

3. Click on a result to execute the corresponding action, depending on the type of item.

Cosert: Limit the lookup to particular field(s) of the active layer

By default, a search with the «active layer features» filter (£) runs through the whole attribute table of the layer.
You can limit the search to a particular field using the @ prefix. E.g., f @name sal or @name sal returns only
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the features whose «name» attribute contains ,,sal. Text autocompletion is active when writing and the suggestion
can be applied using Tab key.

A more advanced control on the queried fields is possible from the layer Fields tab. Read Fields Properties for details.

Searching is handled using threads, so that results always become available as quickly as possible, even if slow search
filters are installed. They also appear as soon as they are encountered by a filter, which means that e.g. a file search
filter will show results one by one as the file tree is scanned. This ensures that the Ul is always responsive, even if
a very slow search filter is present (e.g. one which uses an online service).

IIpumeuanne: The Nominatim locator tool may behave differently (no autocompletion search, delay of fetching
results, ...) with respect to the OpenStreetMap Nominatim usage policy.

Cogset: Quick access to the locator’s configurations

Click on the icon inside the locator widget on the status bar to display the list of filters you can use and a
Configure entry that opens the Locator tab of the Settings » Options... menu.

7.3.2 Reporting actions

In the area next to the locator bar, a summary of actions you've carried out will be shown when needed (such as
selecting features in a layer, removing layer, pan distance and direction) or a long description of the tool you are
hovering over (not available for all tools).

In case of lengthy operations, such as gathering of statistics in raster layers, executing Processing algorithms or
rendering several layers in the map view, a progress bar is displayed in the status bar.

7.3.3 Control the map canvas

The % Coordinate option shows the current position of the mouse, following it while moving across the map view.
You can set the units (and precision) in the Project » Properties... » General tab. Click on the small button at the

left of the textbox to toggle between the Coordinate option and the @ Extents option that displays the coordinates
of the current bottom-left and top-right corners of the map view in map units.

Next to the coordinate display you will find the Scale display. It shows the scale of the map view. There is a scale
selector, which allows you to choose between predefined and custom scales.

On the right side of the scale display, press the ﬂ button to lock the scale to use the magnifier to zoom in or out.
The magnifier allows you to zoom in to a map without altering the map scale, making it easier to tweak the positions
of labels and symbols accurately. The magnification level is expressed as a percentage. If the Magnifier has a level
of 100%, then the current map is not magnified, i.e. is rendered at accurate scale relative to the monitor’s resolution
(DPI). A default magnification value can be defined within Settings » Options » Rendering » Rendering Behavior,
which is very useful for high-resolution screens to enlarge small symbols. In addition, a setting in Settings » Options
» Canvas & Legend » DPI controls whether QGIS respects each monitor’s physical DPI or uses the overall system
logical DPI.

To the right of the magnifier tool you can define a current clockwise rotation for your map view in degrees.

On the right side of the status bar, the Cif Render checkbox can be used to temporarily suspend the map view
rendering (see section Controlling map rendering).

To the right of the oA Render function, you find the & EPSG:code button showing the current project CRS.

Clicking on this opens the Project Properties dialog and lets you reproject the map view or adjust any other project
property.
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Coser: Calculating the Correct Scale of Your Map Canvas

When you start QGIS, the default CRSisWGS 84 (EPSG 4326) and units are degrees. This means that QGIS will
interpret any coordinate in your layer as specified in degrees. To get correct scale values, you can either manually

change this setting in the General tab under Project » Properties... (e.g. to meters), or you can use the 2 BPSGreode

icon seen above. In the latter case, the units are set to what the project projection specifies (e.g., tunits=us—ft).

Note that CRS choice on startup can be set in Settings » Options » CRS Handling.

7.3.4 Messaging

The Q Messages hytton next to it opens the Log Messages Panel which has information on underlying processes
(QGIS startup, plugins loading, processing tools...)
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The Browser panel

* Resources that can be opened /run from the Browser
* Browser panel top-level entries

— Favorites

1] POCMPAHCINBEHHblE 3AKJ/1A OKU

Project Home

Drives and file system

Database entries

Tiles and Web Services

* Resources

The QGIS Browser panel is a great tool for browsing, searching, inspecting, copying and loading QGIS resources.
Only resources that QGIS knows how to handle are shown in the browser.

Using the Browser panel you can locate, inspect and add data, as described in The Browser Panel. In addition, the
Browser panel supports drag and drop of many QGIS resources, such as project files, Python scripts, Processing
scripts and Processing models.

Python scripts, Processing scripts and Processing models can also be opened for editing in an external editor and
the graphical modeller.

You can drag and drop layers from the Layers panel to the Browser panel, for instance into a GeoPackage or a
PostGIS database.
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Browser (] (%]
& T O
Favorites

U Spatial Bookmarks
¢ Home
Y
] /Volumes
& GeoPackage
/£ SpatialLite
@ PostGIS
i SAP HANA
P> MSsQL
@ Oracle
WMS/WMTS
BH Vector Tiles
p === XYZ Tiles

v v v v

& WFS [ OGC API - Features
OWS

& ArcGIS REST Servers

s GeoNode

Puc. 8.1: The Browser panel

The browser panel (Puc. 8.1) is organised as an expandable hierarchy with some fixed top-level entries that organise
the resources handled by the browser. Node entries are expanded by clicking on 4 to the left of the entry name.

. - - T Coltapse Al -
A branch is collapsed by clickingon . The P button collapses all top-level entries.

In Settings » Interface Customization it is possible to disable resources. If you, for instance, would not like to show
Python scripts in the browser, you can uncheck the Browser » py entry, and if you want to get rid of your home
folder in the browser, you can uncheck the Browser » special:Home entry.

A filter (? Filter Browsery can be used for searching based on entry names (both leaf entries and node entries in the
hierarchy). Using the %, Options pull-down menu next to the filter text field, you can
* toggle Case Sensitive search
e set the Filter pattern syntax to one of
— Normal

— Wildcard(s)
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— Regular Expressions

The Properties widget, showing useful information about some entries / resources, can be enabled / disabled using

the @ Enable/disable properties widget bytton, When enabled, it opens at the bottom of the browser panel, as shown in Puc.
8.2.

Browser = (e
LT *[0
v @ GeoPackage 1=

» = testgeopackage.gpkg
* & training_data.gpkg
-~ buildings
V" roads
-~ schools
» = vector_analysis.gpkg
» /#° spatiaLite

v @ PostGls B
. . .\
Metadata | Preview  Attributes
Information from provider |
Name restaurants
Path /home/tveite/Downloads/QGIS/QGIS-Training-
Data-release 3.10/exercise data/
training data.gpkg
Source /home/tveite/Downloads/QGIS/0OGIS-Training- >

Puc. 8.2: The properties widget

A second browser panel can be opened by activating the Browser (2) panel in View » Panels. Having two browser

panels can be useful when copying layers between resources that are locationed deep down in different branches of
the browser hierarchy.
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8.1 Resources that can be opened / run from the Browser

A lot can be accomplished in the Browser panel
¢ Add vector, raster and mesh layers to your map by double-clicking, dragging onto the map canvas or clicking
the q Add Selected Layers bytton (after selecting layers)
* Run Python scripts (including Processing algorithms) by double-clicking or dragging onto the map canvas
* Run models by double-clicking or dragging onto the map canvas
* Extract Symbols... from QGIS Project files using the context menu

¢ Open files with their default applications (Open <file type> Externally... in the context menu). Examples:
HTML files, spreadsheets, images, PDFs, text files, ...

* Copy entries
* Rename and delete (multiple) layers (context menu: Manage »)
* Open a file explorer window and directly select the file Show in Files

Resource specific actions are listed for the different resource groups sorted under the top-level entries listed below.

8.2 Browser panel top-level entries

8.2.1 Favorites

Often used file system locations can be tagged as favorites. The ones you have tagged will appear here.

In addition to the operations described under Home, the context menu allows you to Rename Favorite... and Remove
Favorite.

8.2.2 pocTpaHCTBEHHbIE 3aKnaaKu

This is where you will find your spatial bookmarks, organised into Project Bookmarks and User Bookmarks.

From the top level context menu, you can create a bookmark (New Spatial Bookmark...), Show the Spatial Bookmark
Manager, Import Spatial Bookmarks... and Export Spatial Bookmarks....

For bookmark group entries you can Export Spatial Bookmarks..., create a bookmark (New Spatial Bookmark...),
Rename Bookmark Group, and Delete Bookmark Group.

For bookmark entries you can Zoom to Bookmark, Edit Spatial Bookmark... and Delete Spatial Bookmark

8.2.3 Project Home

Available once the project file has been saved, the Project home entry is a folder containing data and other contents
(scripts, models, text, ...) that may be used within the current project. Displayed in the Browser panel, it allows you
to quickly access data and other files of the project.

It defaults to the project file folder but can be changed through the Project » Properties... » General » Project
home option, or by right-clicking on the Project Home item of the Browser panel and selecting Set project home....
Customizing that folder is especially useful in contexts where QGIS projects are not stored in the root folder of an
organisational ,,project®, along with datasets.
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8.2.4 Drives and file system

The next items of the Browser panel depend on the OS in use and concern the top level entries of its file system.
They are mainly:

e The Home folder, pointing to the current user home folder

¢ on Unix-based machines, the root / folder

* the connected drives, either local or network. Depending on the OS, they are directly listed (eg, C:\,D:\)
or through the /Volumes entry.

From the contextual menu of each of these folders or drives, you can:
* refresh the contents
* create a New » subitem that is a Directory, GeoPackage or ESRI Shapefile format dataset
¢ hide the directory (Hide from Browser)
* Set color: customize the folder icon color, aiding in rapid browser navigation of complex folder structures

* enable Scanning:

& Monitor for changes: allows to manually control whether a particular directory should be monitored
and automatically updated. This setting applies to the selected directory and all subdirectories. This
means that you can manually opt-in to monitoring of network drives if you know there’s no issue, or
manually opt-out of monitoring of large directories which you don’t want monitored for other reasons.
By default, remote or network drives are not automatically monitored.

- Fast scan this directory
* open the directory in your file manager (Open Directory...)
 open the directory in a terminal window (Open in Terminal...)

* inspect the Properties... or the parent Directory Properties...

8.2.5 Database entries

Depending on your OS and installed drivers, you might have access to different database types to use in QGIS.
Below are listed the different entries of contextual menu at each level of the dataset tree.

Level Context Type of database

menu B 1
® ﬁ (@ i SAP jj’b MS DOracle
GeoPackage SpatiaLite  PostGIS HANA SQL
") Server

Top menu  Create oA 4 . o o of

a New
Connection...
to an
existing
database

Create o o

Database...

Save o o T

Connections.
details to a
file

continues on next page
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Tabnuua 8.1 - NpoLoNXeHNE C NpeablayWei cTpaHnLbI

Connection
/ Database

Schema

Table /
Layer

Load
Connections.

Refresh a
connection
Edit
Connection...
settings

Remove
Connection

Delete
<database_n

Compact
Database
(VACUUM)

Create
a New
Schema...

Create
a New
Table...

Execute
SOL...
query
Refresh a
schema

Schema
Operations
» Rename
Schema...

Schema
Operations
> Delete
Schema...

Create
a New
Table...

Execute
SOL...
query
Table
Operations

» Rename
Table...

Table
Operations
» Truncate
Table...

Execute
SOL...

query

i A
i A
o

o 4

& A

& A

.
A

.
i

C

<

continues on next page
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Tabnuua 8.1 - NpoLoNXeHNE C NpeablayWei cTpaHnLbI

Export
Layer »
To file...

Manage »
Rename
Layer
<layer_name

Manage

» Delete
Layer
<layer_name

Manage
» Delete
Selected

Layers

Manage »
Add Layer
to Project

Manage

> Add
Selected
Layers to
Project
Open
Layer
Properties...
dialog
Open File
Properties...
dialog

Fields Add New
Field...

Field Set Alias...

Set
Comment...

Delete
Field...

o

#

L

1 S8 8

C

o

g

C

C

g

C

! The different entries may also be available for some GDAL supported vector file formats such as ESRI File Geodatabase, FlatGeobuf,

GeoParquet, NetCDF, ... when compatible.

8.2. Browser panel top-level entries
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8.2.6 Tiles and Web Services

Level

Context menu

Type of services

HH

Vector
WMTS Tiles

@

WMS /

XYZ
Tiles

-

@ wrs / @ G
WCS OGC APl - ArcGIS Scene
Features REST

Servers

Top
menu

Connec

Table

Layer

Create a New
Connection. ..

Create a New Generic
Connection. ..

Create a New ArcGIS
Vector Tile Service
Connection. ..

Save Connections. ..
details to a file

Load Connections...
Refresh connection

Edit... connection
settings

Delete connection

View Service Info in
Web browser

Export Layer w» To
File...

Add layer to Project
Open Layer
properties... dialog

View Service Info in
Web browser

.

S8 §

L

L

] 8

] § § K

®

i

S8 §

L

L

4

S8 K
S8 K

i

LY

o &
L

i

o o

] & § 8

S8 § 8§ S8 §
L

8.3 Resources

* Project files. The context menu for QGIS project files allows you to:

— open it (Open Project)

— extract symbols (Extract Symbols...) - opens the style manager that allows you to export symbols to an
XML file, add symbols to the default style or export as PNG or SVG.

— inspect properties (File Properties...)

You can expand the project file to see its layers. The context menu of a layer offers the same actions as
elsewhere in the browser.

¢ QGIS Layer Definition files (QLR). The following actions are available from the context menu:

— export it (Export Layer » To file)
— add it to the project (Add Layer to Project)

— inspect properties (Layer Properties...)
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* Processing models (.model3). The following actions are available from the context menu:
— Run Model...)
— Edit Model...)
¢ QGIS print composer templates (QPT). The following action is available from the context menu:
— (New Layout from Template)
* Python scripts (.py). The following actions are available from the context menu:
— (Run script...)
— (Open in External Editor)

* Recognized raster formats. The following actions are available from the context menu:

delete it (Delete File <dataset name>)

export it (Export Layer » To file)

add it to the project (Add Layer to Project)

inspect properties (Layer Properties..., File Properties...)
For some formats you can also Open <file type> Externally...

* Recognized vector formats. The following actions are available from the context menu:

delete it (Delete File <dataset name>)

export it (Export Layer w» To file)

add it to the project (Add Layer to Project)

inspect properties (Layer Properties..., File Properties...)

For some formats you can also Open <file type> Externally...

8.3. Resources
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QGIS Configuration

QQIS is highly configurable. Through the Setfings menu, it provides different tools to:

e/
o B a Style Manager...: create and manage symbols, styles and color ramps.

Priin
=

. Custom Projections...: create your own coordinate reference systems.

O
o [T Keyboard Shortcuts...: define your own set of keyboard shortcuts. Also, they can be overridden during
each QGIS session by the project properties (accessible under Project menu).
. o Interface Customization...: configure the application interface, hiding dialogs or tools you may not need.

o Options...: set global options to apply in different areas of the software. These preferences are saved in the
active User profile settings and applied by default whenever you open a new project with this profile.

9.1 MapameTpbl

“ Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings » X
Options. You can modify the options according to your needs. Some of the changes may require a restart of QGIS
before they will be effective.

The tabs where you can customize your options are described below.

IIpumeuanue: Plugins can embed their settings within the Options dialog

While only Core settings are presented below, note that this list can be extended by installed plugins implementing
their own options into the standard Options dialog. This avoids each plugin having their own config dialog with
extra menu items just for them...
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9.1.1 General Settings

Options — General x

w v Override System Locale

>
A General User interface translation == American English -

% System
CRS and Transforms

Locale (numbers, date and currency formats) v

Data Sources Show group (thousand) separator
¢ Rendering Note: Enabling / changing override on locale requires an application restart
Canvas & Legend Detected active locale on your system: fr_FR
Map Tools Sample date: 16 oct. 2022 money: 1000.00 int: 1000 float: 1000.00
3D
2 Colors w Application
Fonts Style (QGIS restart required) Fusion -
s Ul theme (QGIS restart required) default -
Variables .
Authentication Icon size 2
= Network Font ® Qt default Size |11 @ 2
GPS Timeout for timed messages or dialogs 55 :

Locator Hide splash screen at startup

Acceleration

IDE
% Processing v Check QGIS version at startup

v Show QGIS news feed on welcome page

Ak Advanced Use native color chooser dialogs

¥ Project Files

Open project on launch | Welcome Page ~

Create new project from default project

Set Current Project as Default | Reset Default
Template folder ®
v Prompt to save project and data source changes when required
¥ Prompt for confirmation when a layer is to be removed
v Warn when opening a project file saved with an older version of QGIS
Enable macros Ask v
Default paths | Relative ~
Default project file format ‘' QGZ Archive file format, embeds auxiliary data

QGS Project saved in a clear text, does not embed auxiliary data

@ Help O cancel

Puc. 9.1: General Settings

Override System Locale

By default, QGIS relies on your Operating System configuration to set language and manipulate numerical values.
Enabling this group allows you to customize the behavior.

* Select from User interface translation the language to apply to the GUI

¢ Select in Locale (number, date and currency formats) the system on which date and numeric values should be
input and rendered

. & Show group (thousand) separator
A summary of the selected settings and how they would be interpreted is displayed at the bottom of the frame.
IIpuioxenne

* Select the Style (QGIS restart required) ie, the widgets look and placement in dialogs. Possible values depend
on your Operating System.

* Define the Ul theme (QGIS restart required) 'I\ . It can be ,,default”, ,,Night Mapping®, or ,,Blend of Gray*

¢ Define the Icon size 'I\
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Define the Font and its Size. The font can be - ® Ot default or a user-defined one

Change the Timeout for timed messages or dialogs
Hide splash screen at startup

o Show QGIS news feed on welcome page: displays a curated QGIS news feed on the welcome page, giving
you a direct way to be aware of project news (user/developer meetings date and summary, community surveys,
releases announcements, various tips...)

o Check QGIS version at startup to keep you informed if a newer version is released

Use native color chooser dialogs (see Color Selector)

®ajiabl IPOEKTOB

Open project on launch

»Welcome Page“ (default): can display the «News» feed, the project template(s) and the most recent
projects (with thumbnails) of the user profile. No project is opened by default.

- ,New": opens a new project, based on the default template
— ,.Most recent”: reopens the last saved project

— and ,,Specific*: opens a particular project. Use the ... button to define the project to use by default.

o Create new project from default project. Y ou have the possibility to press on Set current project as default or
on Reset default. You can browse through your files and define a directory where you find your user-defined

project templates. This will be added to Project » New From Template. If you first activate o Create new
project from default project and then save a project in the project templates folder.

o Prompt to save project and data source changes when required to avoid losing changes you made.
o Prompt for confirmation when a layer is to be removed

oA Warn when opening a project file saved with an older version of QGIS. You can always open projects
created with older version of QGIS but once the project is saved, trying to open with older release may fail

because of features not available in that version.
Enable macros —'*! . This option was created to handle macros that are written to perform an action
on project events. You can choose between ,Never”, ,Ask“, ,For this session only“ and ,,Always (not

recommended)*.

Default paths: defines whether paths to files and layers used in new projects are stored as ,,Absolute” or
»Relative” to the project file. This setting can be overwritten at the project level.

Default project file format
-\ OGZ Archive file format, embeds auxiliary data (see auxiliary data)

— 4 OGS Project saved in a clear text, does not embed auxiliary data: the auxiliary data is stored in a
separate . ggd file along with the project file.
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9.1.2 System Settings

SVG paths

Add or Remove Path(s) to search for Scalable Vector Graphic (SVG) symbols. These SVG files are then available to

symbolize or label the features or decorate your map composition.

Also read Remote or embedded file selector for different ways to refer to svg files in a QGIS path.

Moayan
Add or Remove Path(s) to search for additional C++ plugin libraries.

Documentation paths

Add or Remove Documentation Path(s) to use for QGIS help. By default, a link to the official online User Manual
corresponding to the version being used is added. You can however add other links and prioritize them from top to
bottom: each time you click on a Help button in a dialog, the topmost link is checked and if no corresponding page

is found, the next one is tried, and so on.

IIpumeuanne: Documentation is versioned and translated only for QGIS Long Term Releases (LTR), meaning that
if you are running a regular release (eg, QGIS 3.0), the help button will by default open the next LTR manual page
(ie. 3.4 LTR), which may contain description of features in newer releases (3.2 and 3.4). If no LTR documentation
is available then the festing doc, with features from newer and development versions, is used.

Settings

It helps you Reset user interface to default settings (restart required) if you made any customization.

IlepemeHHbIEe cpeabl

Options — System

P SVG Paths

> Pluin Paths

% System » Documentation Paths

CRS and Transforms v Settings
B Data Sources

« Rendering Reset user interface to default settings (restart required)
& Canvas & Legend
B Map Tools

W 3D

v Environment

¥ Use custom variables (restart required - include separators)
A colors Variable

QGIS_LOG_FILE /userfqgis_log

Apply

Fonts
M Layouts
Variables

Overwrite
IF Undefined
Unset

& Authentication Prepend
Append

Skip

== Network
GPs
Locator

Acceleration Variable -

Value

w Current environment variables (read-only - bold indicates modified at startup)

Value

ADG_MENU_PREFEX
XDG_RUNTIME_DIR
XDG_SESSION_CLASS
XDG_SESSION_DESKTOP
XDG_SESSION_TYPE
XMODIFIERS

IDE

#* Processing
A Advanced

@Help

gnome-
Jrun/fuser/1000

user

ubuntu

X11

@im=ibus =

Show only QGIS-specific variables

Oconcel

Puc. 9.2: System environment variables
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System environment variables can be viewed, and many configured, in the Environment group. This is useful for
platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. It’s also
useful for setting and viewing environment variables for the external tool sets controlled by the Processing toolbox
(e.g., SAGA, GRASS), and for turning on debugging output for specific sections of the source code.

Check . Use custom variables (restart required - include separators) and you can '31'}] Add gpd = Remove

environment variables. For each new item, you can configure a Variable name, its Value and the Apply method
to use, among which:

e Overwrite: replace any preexisting value of the variable

 If undefined: use this value for the variable if not already defined at a higher level (e.g. OS or application
levels)

» Unset: remove the variable from the environment (the Value parameter is not used)
* Prepend: prepend the value to the preexisting value of the variable

* Append: append the value to the preexisting value of the variable

* Skip: the item is kept in the list for future reference but unused

Already defined environment variables are displayed in Current environment variables, and it’s possible to filter

them by activating oA Show only QGIS-specific variables.

9.1.3 User Profiles Settings

IIpumeuanue: For more information on how to manage user profiles, please read the dedicated section at Working
with User Profiles.

9.1.4 CRS and Transforms Settings

IIpumeuanue: For more information on how QGIS handles layer projection, please read the dedicated section at
Paboma ¢ npoeKuuUAmMU.
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CRS Handling

In the % CRS Handling tab you can configure which CRS will be used for a new project or layer.

*. General
% System

CRS and Transforms
“# CRs Handling

# Coordinate Transforms

& User Defined CRS
Data Sources

¢ Rendering
Canvas & Legend
Map Tools
3D
Colors
Fonts

M Layouts
Variables

& Authentication

== Network

GPs
Locator
Acceleration

IDE

% Processing

A Advanced

CRS for Projects

Options — CRS Handling

¥ CRS for Projects

When a new project is created
@' Use CRS from first layer added

Use adefault CRS EPSG:4326 - WGS 84

w CRS for Layers

Default CRS for layers EPSG:4326 - WGS 84

When a new layer is created, or when a layer is loaded that has no CRS
@ Leave as an unknown CRS (take no action)

Prompt for CRS

Use project CRS

Use default layer CRS

¥ Accuracy Warnings

Only show CRS accuracy warnings for inaccuracies which exceed | Always show

Show CRS accuracy warnings for layers in project legend

Planimetric measurements

@Help

Puc. 9.3: CRS Settings

There is an option to automatically set new project’s CRS:

Ocmnce

« '®Use CRS from first layer added: the CRS of the project will be set to the CRS of the first layer loaded

into it

e ./ Use adefault CRS: a preselected CRS is applied by default to any new project and is left unchanged when
adding layers to the project.

The choice will be saved for use in subsequent QGIS sessions. The Coordinate Reference System of the project can
still be overridden from the Project » Properties... » CRS tab.

CRS for Layers

Default CRS for layers: select a default CRS to use when you create a layer

You can also define the action to take when a new layer is created, or when a layer without a CRS is loaded.

o '@ [ eave as unknown CRS (take no action)

e i Prompt for CRS

e . Use project CRS

e i Use default layer CRS

64

nasa 9. QGIS Configuration



QGIS Desktop 3.34 User Guide

Accuracy Warnings

Only show CRS accuracy warnings for inaccuracies which exceed a given distance: occurs when you are explicitly
creating or modifying a dataset and select a CRS based on a datum ensemble with lower accuracy. The default is to
Always show the warning if any inaccuracy. Requires a QGIS version using at least PROJ 8.0.

! Show CRS accuracy warning for layers in project legend: If checked, any layer with a CRS with accuracy issues
(i.e. adynamic crs with no coordinate epoch available, or a CRS based on a datum ensemble with inherent inaccuracy

—
exceeding the user-set limit) will have the ™ warning icon in the Layers panel reflecting that it is a low-accuracy
layer.

This is designed for use in engineering, BIM, asset management, and other fields where inaccuracies of
meter/submeter level are potentially very dangerous or expensive!

! Planimetric measurements: sets the default for the planimetric measurements property for newly created projects.
Coordinate Transforms

The @ Coordinate Transforms tab helps you set coordinate transformations and operations to apply when loading
a layer to a project or reprojecting a layer.

Options — Coordinate Transforms x

| Default Datum Transformations

*. General V| Ask For datum transformation if several are available
% System

T m— Enter default datum transformations which will be used in any newly created project

€ CRs Handling &=
# Coordinate Transforms Source CRS Destination CRS Operation Allow Fallback Transforms

& User Defined CRS EPSG:2964 EPSG:4326 +proj=pipeline +step +proj=unitconvert +xy_in=us-ft +xy_out=m ... v
B Data Sources
4" Rendering
Canvas & Legend
B Map Tools
W 3D
M colors
Fonts
M Layouts
Variables
@ Authentication
== Network
GPS
Locator
Acceleration
IDE

% Processing

A Advanced

@Help O cancel

Puc. 9.4: Transformations settings

Default Datum Transformations
Here you can control whether reprojecting layers to another CRS should be:
* automatically processed using QGIS default transformations settings;

* and/or more controlled by you with custom preferences such as:

- Ask for datum transformation if several are available

— a predefined list of datum transformations to apply by default. See Datum Transformations for more
details.

You can I:II-:III-:| Add =1 Remove vf Edit transformations, which will be used in any newly created project.
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User Defined CRS

The ‘% User Defined CRS tab helps you to define a custom CRS which must conform to a WKT or Proj string
format.

Options — User Defined CRS x

| You can define your own custom Coordinate Reference System (CRS) here. The definition must conform to a WKT or Proj string
Format For specifying a CRS.

“ General

N Name Parameters. &
%% System Alaska PROJCRS["NAD27 / Alaska Albers" BASEGEOGCRS["NAD27", DATUM["North American Datum 1927" ELLIPS... -
CRS and Transforms
€ CRS Handling
£ Coordinate Transforms
4 User Defined CRS
B Data Sources
4 Rendering
Canvas & Legend
B Map Tools Name Alaska
-
&30 v Definition
A Colors
Fonts Format WKT (Recommended) >
B Layouts PROJCRS["NAD27 [ Alaska Albers”, =@ || validate
Variables BASEGEOGCRS["NAD27",
- . DATUM["North American Datum 1927",
& Authentication ELLIPSOID["Clarke 1866",6378206.4,294.978698213898,
== Network LENGTHUNIT["metre”,1]]],
Parameters PRIMEM["Greenwich",0,
GPS ANGLEUNIT["degree”,0.0174532925199433]],
Locater ID["EPSG",4267]],

Acceleration CONVERSION["Alaska Albers",
METHOD["Albers Equal Area”,
IDE ID["EPSG",9822]], a

¥ Processing

; ¥ Test
A Advanced

Use the text boxes below ko test the CRS definition you are creating. Enter a coordinate where both the lat/long and the
transformed result are known (For example by reading off a map). Then press the calculate button to see if the CRS definition
you are creating is accurate.

Geographic / WGS84 Destination CRS

Calculate

@Help Ocancel

Puc. 9.5: User Defined CRS

= - =
Set a Name and use Addnew CRS Tf you want to delete an existing one you can use Remove CRS

Definition
» Format
— WKT (Recommended)
— Proj String (Legacy - Not Recommended)

¢ Parameters

- Copy parameters from an existing CRS.
— Validate tests if your expression is correct.
Test

Here you can test your created CRS definition by Latitude and Longitude. Use a known coordinate to control if
your definition is accurate.
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9.1.5 Data Sources settings

Options — Data Sources x

v Feature Attributes and Table

. General Open attribute table as docked window
% System ’
o Copy features as Plain Text, WKT Geometry -
CRS and Transforms
= Data Sources Attribute table behavior Show All Features v
« Rendering Default view Remember Last View -
Canvas & Legend Attribute table row cache 10000 =
B Map Tools .
Representation for NULL values NULL
& 3D
3 Colors ¥ Data Source Handling
Fonts
Scan for valid items in the browser dock Check Extension v
M Layouts
Variables Scan for contents of compressed files (.zip) in browser dock Basic Scan -
& Authentication Prompt For sublayers when opening Always -

== Network
GPs
Locator v Localized Data Paths

v Automatically refresh directories in browser dock when their contents change

Acceleration

- Localized data paths for basemaps, logos, etc. {in order of preference) | |=| A ¥

% Processing
A Advanced

v Hidden Browser Paths

Paths hidden from browser panel =
[{media/delazj/cAsA/mysecretfolder

OHelp © cancel

Puc. 9.6: Data Sources settings

Taéumna arpudyToB

. & Open attribute table as docked window

* Copy features as ,,Plain text, no geometry“, ,,Plain text, WKT geometry®, or ,,GeoJSON* when pasting features
in other applications.

« Attribute table behavior ") : set filter on the attribute table at the opening. There are three possibilities:
»Show all features®, ,,Show selected features* and ,,.Show features visible on map*.

* Default view: define the view mode of the attribute table at every opening. It can be ,,Remember last view",
,»Table view" or ,,Form view*.

« Attribute table row cache % !, This row cache makes it possible to save the last loaded N attribute rows
so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute
table.

* Representation for NULL values. Here, you can define a value for data fields containing a NULL value.

Coset: Improve opening of big data attribute table

‘When working with layers with big amount of records, opening the attribute table may be slow as the dialog request
all the rows in the layer. Setting the Attribute table behavior to Show features visible on map will make QGIS
request only the features in the current map canvas when opening the table, allowing a quick data loading.

Note that data in this attribute table instance will be always tied to the canvas extent it was opened with, meaning
that selecting Show All Features within such a table will not display new features. You can however update the set
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of displayed features by changing the canvas extent and selecting Show Features Visible On Map option in the
attribute table.

HcTouHNMKH JaHHBIX

e Scan for valid items in the browser dock ' Ad . You can choose between ,,Check extension® and ,,Check file

contents”.

e Scan for contents of compressed files (.zip) in browser dock "% defines how detailed is the widget
information at the bottom of the Browser panel when querying such files. ,,No*, ,,Basic scan“ and ,,Full scan“
are possible options.

e Prompt for sublayers when opening. Some rasters support sublayers — they are called subdatasets in GDAL.
An example is netCDF files — if there are many netCDF variables, GDAL sees every variable as a subdataset.
The option allows you to control how to deal with sublayers when a file with sublayers is opened. You have
the following choices:

— ‘Always’: Always ask (if there are existing sublayers)
— ‘If needed’: Ask if layer has no bands, but has sublayers
— ‘Never’: Never prompt, will not load anything

— ‘Load all’: Never prompt, but load all sublayers

. & Automatically refresh directories in browser dock when their contents change: Allows you to manually opt-
out of monitoring directories in the Browser panel by default (eg, to avoid potential slow down due to network
latency).

Localized data paths

It is possible to use localized paths for any kind of file based data source. They are a list of paths which
are used to abstract the data source location. For instance, if C:\my_maps is listed in the localized paths,
a layer having C:\my_maps\my_country\ortho.tif as data source will be saved in the project using
localized:my_country\ortho.tif.

The paths are listed by order of preference, in other words QGIS will first look for the file in the first path, then in
the second one, etc.

Hidden browser paths

This widget lists all the folders you chose to hide from the Browser panel. Removing a folder from the list will make
it available in the Browser panel.

GDAL Settings

GDAL is a data exchange library for geospatial data that supports a large number of vector and raster formats. It
provides drivers to read and (often) write data in these formats. The GDAL tab exposes the drivers for raster and
vector formats with their capabilities.

GDAL raster and vector drivers

The Raster Drivers and Vector Drivers tabs allow you to define which GDAL driver is enabled to read and/or write
files, as in some cases more than one GDAL driver is available.
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Options — GDAL x

Raster Drivers | Vector Drivers

%, General

Raster Driver Options
& System

CRS and Transforms GTiff ~ | Edit Create Options Edit Pyramids Options

B Data Sources
Raster Drivers

% GDAL
¢ Rendering In some cases more than one GDAL driver can be used to load the same raster format. Use the list below to
. specify which to use.
Canvas & Legend
Map Tools Name Extension Flags  Description =
v! AAIGrid asc wy Arc/Info ASCII Grid
3D v! ACE2 ace2 rov ACE2
1 colors v| ADRG gen rw+v  ARC Digitized Raster Graphics
v AIG rov Arc/Info Binary Grid
Fonts v AIrSAR rov AIrSAR Polarimetric Image
Layouts v| ARG wv Azavea Raster Grid format
- v| BAG bag rw+v  Bathymetry Attributed Grid
Variables v| BIGGIF gif rov Graphics Interchange Format (.gif)
B ALthentication V| BLX blx rwv Magellan topo (.blx)
v! BMP bmp rw+v  MSWindows Device Independent Bitmap
=% Network v| BSB rov Maptech BSB Nautical Charts
GPS v BT bt rw+v VTP .bt (Binary Terrain) 1.3 Format
p——— ¥| BYN rw+v  Natural Resources Canada's Geoid
v! CAD dwg rov AutoCAD Driver
Acceleration v! CALS wv CALS (Type 1)
IDE v/ CEOS rov CEOS Image
: ¥| COASP hdr ro DRDC COASP SAR Processor Raster
¥ Processing v/ COG wy Cloud optimized GeoTIFF generator
A Advanced v! COSAR rov COSAR Anr)otated Binary Matrix (TerraSAR-X) =

@Help ©cancel

Puc. 9.7: GDAL Settings - Raster drivers

Coset: Double-click a raster driver that allows read and write access (rw+ (v) ) opens the Edit Create options
dialog for customization.

Raster driver options
This frame provides ways to customize the behavior of raster drivers that support read and write access:

* Edit create options: allows you to edit or add different profiles of file transformation, i.e. a set of predefined
combinations of parameters (type and level of compression, blocks size, overview, colorimetry, alpha...) to
use when outputting raster files. The parameters depend on the driver.
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» # Create Option... GTiff Driver

Profile | High Compression -
o New = Remove # Reset
Mame Value
1|COMPRESS DEFLATE
2| PREDICTOR 2
3| ZLEVEL 9
gdr || = || Validate Help
v OK | & Cancel

Puc. 9.8: Sample of create options profile (for GeoTiff)

The upper part of the dialog lists the current profile(s) and allows you to add new ones or remove any of them.
You can also reset the profile to its default parameters if you have changed them. Some drivers (eg, GeoTiff)
have some sample of profiles you can work with.

At the bottom of the dialog:
— The ':II-I-II:I button lets you add rows to fill with the parameter name and value

— The ™ button deletes the selected parameter

Click the Validate button to check that the creation options entered for the given format are valid

Use the Help button to find the parameters to use, or refer to the GDAL raster drivers documentation.

 Edit Pyramids Options
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Create Options - pyramids

Overview format | External (GTiff .ovr) - |
Resampling method |Average - |
Levels 2 4 8 16 32 64

Custom levels | |

Create Options

Profile | High Compression - |

|CDMF"HESS_D‘U’E RVIEW=DEFLATE PREDICTOR_OVERVIEW=2 ZLEVEL=9 |

v OK || & Cancel |

Puc. 9.9: Sample of pyramids profile

9.1.6 Rendering Settings

The 5 Rendering tab provides settings for controlling layers rendering in the map canvas.
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Options — Rendering

[a v Rendering Behavior
* General v| By default new layers added to the map should be displayed
& System . . -
9 oY Maximum cores to use for map rendering 1 a5
CRS and Transforms
B Data Sources Map update interval 250 ms v
¥ Rendering Magpnification level 100% -

Canvas & Legend
B Map Tools
W 3D v Make lines appear less jagged at the expense of some drawing performance

v Rendering Quality

M colors
Fonts
@ Layouts
Variables
@ Authentication
== Network
GPS
Locator
Acceleration
IDE

% Processing

i Advanced

@Help ©cancel

Puc. 9.10: Rendering settings

Rendering Behavior

. & By default new layers added to the map should be displayed: unchecking this option can be handy when
loading multiple layers to avoid each new layer being rendered in the canvas and slow down the process

¢ Set the Maximum cores to use for map rendering

* The map canvas renders in the background onto a separate image and at each Map update interval (defaults
to 250 ms), the content from this (off-screen) image will be taken to update the visible screen representation.
However, if rendering finishes faster than this duration, it will be shown instantaneously.

* Magnification level (see the magnifier)
Rendering Quality

® i Pucosamw cznadicerinvie aunuu (CHMDfC(Zem CKOpoCnib OmpucosKku )
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Vector rendering settings

The .~ Vector tab contains specific settings for rendering vector layers.

Options — Vector D
| vV Enable Feature simplification by default For newly added layers

*. General Note: Feature simplification may speed up rendering but can result in rendering inconsistencies

% system Simplification threshold (higher values result in more simplification) 1,00 <| pixels

CRS and Transforms TR . :

Simplification algorithm Distance v
B Data Sources
- EErierhe Simplify on provider side if possible

2 Vector Maximum scale at which the layer should be simplified (1:1 always simplifies) | 1:1 -

= Raster
B Canvas & Legend ¥ Curve Segmentation
& Map Tools Segmentation tolerance 1,00 -
W 3D

M colors

Tolerance type Maximum Angle v

Fonts
[ Layouts
VELED]E
& Authentication
== Network
GPS
Locator
Acceleration
IDE

#* Processing

i advanced

@Help ©cancel

Puc. 9.11: Vector rendering settings

. & Enable Feature Simplification by Default for Newly Added Layers: you simplify features® geometry (fewer
nodes) and as a result, they display more quickly. Be aware that this can cause rendering inconsistencies.
Available settings are:

Simplification threshold (higher values result in more simplification)

Simplification algorithm: This option performs a local «on-the-fly» simplification on feature’s and speeds
up geometry rendering. It doesn’t change the geometry fetched from the data providers. This is important
when you have expressions that use the feature geometry (e.g. calculation of area) - it ensures that
these calculations are done on the original geometry, not on the simplified one. For this purpose, QGIS
provides three algorithms: ,Distance” (default), ,,SnapToGrid* and ,,Visvalingam®.

U Simplify on provider side if possible: the geometries are simplified by the provider (PostGIS,
Oracle...) and unlike the local-side simplification, geometry-based calculations may be affected

Maximum scale at which the layer should be simplified (1:1 always simplifies)

IIpumeuanne: Besides the global setting, feature simplification can be set for any specific layer from its
Layer properties » Rendering menu.

* Curve Segmentation

— Segmentation tolerance: this setting controls the way circular arcs are rendered. The smaller maximum
angle (between the two consecutive vertices and the curve center, in degrees) or maximum difference
(distance between the segment of the two vertices and the curve line, in map units), the more straight
line segments will be used during rendering.
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— Tolerance type: it can be Maximum angle or Maximum dif ference between approximation and curve.
Raster rendering settings

The :'- Raster tab contains specific settings for rendering raster layers.

Options — Raster X

| v Bands and Resampling

“ General RGB band selection Red band 1 :| Greenband |2 2| Blue band 3 =
% System

Zoomed in resampling | Nearest Neighbour v
CRS and Transforms

W Data Sources Zoomed out resampling | Nearest Neighbour x
« Rendering oversampling 2,00 =
= Vector Early resampling
¥ Raster
& Canvas & Legend Contrast Enhancement
B Map Tools Algorithm Limits (minimum/maximum)
-,
R single band gray Stretch to MinMax * | | Minimum / Maximum v
M colors
- Multi band color (byte / band) No Stretch * | | Minimum / Maximum v
onts
M Layouts Multi band color (> byte / band) | Stretch to MinMax | | Cumulative Pixel Count Cut v
VELED]E . . . = -
Cumulative pixel count cut limits | 2,0 -~ -/98,0 =

& Authentication
) Standard deviation multiplier 2,00 =
== Network
GPS
Locator
Acceleration

IDE

% Processing
i advanced

@Help ©cancel

Puc. 9.12: Raster rendering settings

Under Bands and Resampling:
e With RGB band selection, you can define the number for the Red, Green and Blue band.

* The Zoomed in resampling and the Zoomed out resampling methods can be defined. For Zoomed in resampling
you can choose between three resampling methods: ,,Nearest neighbour®, , Bilinear (2x2 kernel)* and ,,Cubic
(4x4 kernel)“. For Zoomed out resampling you can choose between ,,Nearest Neighbour* and ,,Average“. You
can also set the Oversampling value (between 0.0 and 99.99 - a large value means more work for QGIS - the
default value is 2.0).

. & Early resampling: allows to calculate the raster rendering at the provider level where the resolution of
the source is known, and ensures a better zoom in rendering with QGIS custom styling. Really convenient
for tile rasters loaded using an interpretation method. The option can also be set at the layer level (Symbology
properties)

Contrast Enhancement options can be applied to Single band gray, Multi band color (byte/band) or Multi band color
(>byte/band). For each, you can set:

« the Algorithm to use, whose values can be ,,No stretch®, ,,Stretch to MinMax*, ,,Stretch and Clip to MinMax*
or ,,Clip to MinMax*

e the Limits (minimum/maximum) to apply, with values such as ,Cumulative pixel count cut®,
L~2Minimum/Maximum®, ,Mean +/- standard deviation®.

The Contrast Enhancement options also include:
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o [ PpaHuywvl cpesa ¢ HaAaKoONnJAeHUuem
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9.1.7 Canvas and Legend Settings

Options — Canvas & Legend

w Default Map Appearance (overridden by project properties)
S Selection celor ~| Background color v
& System
User Profiles w Layer Legend
CRS and Transforms
Double-click action in legend Open layer properties v
@ Data Sources
« Rendering Behavior used when adding new layers Above currently selected layer =
&% Canvas & Legend Show feature count for newly added layers
Map Tools Display classification attribute in layer titles
BBz o WMS getLegendGraphic resolution 0 dpi .
;olor-_: Minimum legend symbol size 0,10 mm =
Fonts Maximum legend symbol size 20,00 mm =
Layouts i
¥ Map Tips
Variables
m Authentication Delay (in milliseconds) 850 ms -
= MNetwork
cps v DPI
Locator Respect screen DPI
Acceleration
IDE
i% Processing
A\ Advanced
H Aide « Ok | © Annuler

Puc. 9.13: Canvas & Legend settings

These properties let you set:
¢ the Default map appearance (overridden by project properties): the Selection color and Background color.
¢ Layer legend interaction:

— Double click action in legend: whether a double-click on a layer should either Open layer properties
(default), Open attribute table or Open layer styling dock.

— Behavior used when adding new layers: determines where layers are placed in the Layers panel when
loaded into QGIS. It can be:

x Above currently selected layer
« Always on top of the layer tree

« Optimal index within current layer tree group: Unlike the other options that sort the new layers among
them and place them as a stack at the desired location, this option extents the sorting logic to the
whole layer tree (or the active group) and inserts new layers in an «optimal» fashion by insuring that
point layers sit on top of point layers, followed by line layers on top of lines, followed by polygon
layers, etc.
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Show feature count for newly added layers: displays in the Layers panel the number of features next
to the layer name. Feature count of classes, if any, is as well displayed. You can right-click on a layer
to turn on/off its feature count.

Display classification attribute names in the Layers panel, e.g. when applying a categorized or rule-
based renderer (see Symbology Properties for more information).

the WMS getLegendGraphic Resolution
— Minimum and Maximum legend symbol size to control symbol size display in the Layers panel

¢ the Delay in milliseconds of layers map tips display

¢ Whether QGIS should g Respect screen DPI: If enabled, QGIS will attempt to display the canvas with
physically accurate scale on screen, depending on the monitor’s physical DPI. Symbology with specified
display size will also be rendered accurately, e.g. a 10mm symbol will show as 10mm on screen. However,
label font sizes on canvas may differ from those in QGIS“ UI or other applications. If this setting is turned
off, QGIS will use the operating system’s logical DPI, which will be consistent with other applications on the
system. However, canvas scale and symbology size may be physically inaccurate on screen. In particular, on
high-dpi screens, symbology is likely to appear too small.

For best experience, it is recommended to enable o Respect screen DPI, especially when using multiple or

different monitors and preparing visually high-quality maps. Disabling Cig Respect screen DPI will generate
output that may be more suitable for mapping intended for on-screen use only, especially where font sizes
should match other applications.

IIpumeuanne: Rendering in layouts is not affected by the Respect screen DPI setting; it always respects the
specified DPI for the target output device. Also note that this setting uses the physical screen DPI as reported
by the operating system, which may not be accurate for all displays.
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9.1.8 Map tools Settings

(&) Options — Map Toeols

S Handling

ordinate Transforms

Data Sources

@ GDAL

" Rendering

30
Colors

Fonts

m Authentication
Network

Locator

Acceleration

Code Editor

1"Identifv

Search radius for identifying features and displaying map tips | 2,00 mm =

Highlight color — ¥| Buffer | 0,50 mm
w Measure Tool
Rubberband color — =
Decimal places 3 =
Keep base unit L
Preferred distance units Meters
Preferred area units Square Meters
Preferred angle units Degrees
w Measure Tool Copy Settings
Indude header v
Always use decimal point |V
Separator ) Comma (®) Semicolon
) Tab () Colon
Space | ) Other
w Coordinate and Bearing Display
Default coordinate format for new projects
Default bearing format for new projects
w Zooming
Zoom factaor 200%
Reverse wheel zoom
w Predefined Scales
1:1000000
1:500000
1:250000
1:100000
1:50000
1:25000
1:10000
1:5000
1:2500
1:1000

Customize...

Customize...

*

= | Minimum width | 1,00 mm =

-

-

-

>

=

®
| OK Cancel Help

Puc. 9.14: Map tools settings

This tab offers some options regarding the behavior of the Identify tool.

e Search radius for identifying features and displaying map tips is a tolerance distance within which the identify
tool will depict results as long as you click within this tolerance.

* Highlight color allows you to choose with which color features being identified should be highlighted.

* Buffer determines a buffer distance to be rendered from the outline of the identify highlight.

* Minimum width determines how thick should the outline of a highlighted object be.

HNHcTpymMeHT u3MepeHnuii

* VYcraHoBuTh Lleem aunuu A1 THCTPYMEHTOB U3MEPEHUI
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* YCTaHOBWTD YUCTIO Jlecsimuutbix 3HAKO8

. & Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)

e Preferred distance units: options are ,Meters“, ,Kilometers“, ,Feet“, ,,Yards“, ,,Miles®, , Nautical Miles“,
»Centimeters®, ,,Millimeters®, ,,Inches”, ,,Degrees“ or ,,Map Units“

* Preferred area units: options are ,,Square meters®, ,Square kilometers®, ,Square feet, ,Square yards®, ,Square
miles®, ,,Hectares®, ,Acres®, ,Square nautical miles®, ,,Square centimeters®, ,,Square millimeters®, ,Square
inches®, ,,Square degrees” or ,,Map Units*

* Preferred angle units: options are ,,Degrees“, ,,Radians®, ,,Gon/gradians®, ,,Minutes of arc*, ,,Seconds of arc®,
,»Lurns/revolutions®, milliradians (SI definition) or mil (NATO/military definition)

Some of these options can be overridden at the project level.

Measure Tool Copy Settings

— .
These settings allow you to control the behavior of the Copy button in the T Measure Line \indow. You can choose
to oA Include header to keep columns names, and you can also select Separator of your choice. You can also choose

A Always use decimal point to keep your coordinates copied to the clipboard with a dot as a decimal separator,
even if your language settings in QGIS options are set up to use a comma. In this case, if you don’t have the Always
use decimal point option checked, you will be unable to select comma as a field separator.

Coordinate and Bearing Display
This section provides ways to Configure:
e Default coordinate formc_zt for new projects, as displayed in the Coordinates box on QGIS status bar and in the
Derived section of the '}C’\% Identify features 460]’ results
* Default bearing format for new projects, as displayed in the status bar for the map canvas panning direction
and by the T/n Measure bearing ¢o]
These options can be overridden at the project level.
IIpokpyTka u MacmTabupoBaHne

* Define a Zoom factor for zoom tools or wheel mouse

. & Reverse wheel zoom allows you to adjust mouse wheel scrolling direction.
MacmraOHblil psag
Here, you find a list of predefined scales to display by default in the scale-related drop-down widgets, such as the

status bar Scale, the visibility scales selector or secondary 2D map view settings,... With the I:II-:III-:| and = buttons
you can add or remove your personal scales. You can also import or export scales from/to a . XML file. Note that
you still have the possibility to remove your changes and reset to the predefined list.

From the project properties dialog, you can also set your own list of scales, overriding this global one in the widgets.
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Digitizing settings

Options — Digitizing x
[a I Feature Creation

. General Suppress attribute form pop-up after feature creation

% System

Reuse last entered attribute values
CRS and Transforms

B Data sources Validate geometries QGIS v
" Rendering Default Z value 10,000 =
® Canvas & Legend Default M value 5,000 -
Map Tools
* Digitizing » Rubberband
3D ¥ Snapping
Colors
Enable snapping by default
Fonts
Layouts Default snapping type No Snapping v
Variables Default snapping tolerance 12,00000 2| pixels v
& Authentication search radius For vertex edits 10,00000 2| | pixels -
== Network . L i -
- Display main dialog as (restart required) Dialog -
Locator Snapping marker color I -
Acceleration Show snapping tooltips
212 Enable snapping on invisible Features (not shown on the map canvas)
% Processing
A& advanced ¥ Vertex Markers
v! Show markers only for selected features
Marker style Cross v
Marker size (in millimeter) 2,00 =
b Curve Offset Tool
¥ Tracing
Convert tracing to curve (this Feature is experimental)
Angle tolerance when tracing curves 0,0000010000 =

Distance tolerance when tracing curves 0,0000010000

@Help ©cancel

Puc. 9.15: Digitizing settings

This tab helps you configure general settings when editing vector layer (attributes and geometry).

Co3aanue 00bEKTOB

. & Suppress attribute form pop-up after feature creation: this choice can be overridden in each layer properties
dialog.

. & Reuse last entered attribute values: remember the last used value of every attribute and use it as default
for the next feature being digitized. Works per layer. This behavior can also be controled on a per-field basis
(see Configure the field behavior).

 Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering.
This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is
possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry
validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Note that depending on the selection, reports of geometry errors may differ (see T'ypes of error messages and
their meanings)

* Default Z value to use when creating new 3D features.
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Pe3unoBas HUTH
¢ Define Rubberband Line width, Line color and Fill color.
* Don't update rubberband during vertex editing.

IIpuamnanne
. & Enable snapping by default activates snapping when a project is opened

* Define Default snap mode ' Ad (, Vertex*®, ,,Segment*, ,,Centroid®, ,,Middle of segments®, ,,Line endpoints*,
»Area®)

L4 yCTaHOBI/ITb Hopoz NPUAUNAHUSA NO YMOAUAHUIO B €INHULIaX KaprI HNJIN ITUKCEIIAX
o Vi Pad 2 0 1.00
CTAaHOBUTH ra UYC NOUCKA 015 pedaKmuposaHust 6EpULUH (B [S1051501700020,8 KapTLI nin HI/IKCCJ]SIX)

* Display main dialog as (restart required): set whether the Advanced Snapping dialog should be shown as
»Dialog® or ,,Dock®.

* Snapping marker color

. & Show snapping tooltips such as name of the layer whose feature you are about to snap. Helpful when
multiple features overlap.

. & Enable snapping on invisible features (not shown on the map canvas)

Mapkepn! BepIInH
. & Toxazvisamv Mapkepvl MOALKO 015l 8bIOPAHHBIX 00BEKIMOB

¢ Define vertex Marker style ' A (,Cross® (default), ,,Semi transparent circle” or ,,None*)
¢ Define vertex Marker size (in millimeter)
ITapanneabHble KPpUBbIE
The next 3 options refer to the G) Offset Curve to0] in JJonoanumenvrvle pyrnxuuu ouyugbposku. Through the various
settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.
* Join style: ,Round®, ,,Mitre“ or ,,.Bevel“
* Quadrant segments
* Miter limit

Tracing

By activating the oA Convert tracing to curve you can create curve segments while digitizing. Keep in mind that
your data provider must support this feature.

80 Maea 9. QGIS Configuration



QGIS Desktop 3.34 User Guide

9.1.9 Elevation settings

Options — Elevation

Profile Chart Appearance

Background color -

User Profiles

CRS and Transforms

B Data Sources

¥ Rendering
Canvas & Legend
Map Tools

Elevation

Puc. 9.16: Elevation settings

In Elevation menu, you can set a specific color to use as the Background color for elevation profiles. This
can make the chart more readable for certain datasets, e.g. point clouds with RGB coloring, where the default
background color is too similar to point colors to be easily discernable. If unchanged, the elevation profiles will
continue to display using the standard system background color.

9.1.10 3D settings

Options — 3D
Default Camera Settings

. General Projection type Perspective Projection -
1 System ) ) o

Field of View 45° =

User Profiles

P T B —— Navigation mode Terrain Based -
@ Data Sources Movement speed 5,00 -
# Rendering Invert vertical axis Only When Dragging -
B8 Canvas & Legend
BR Map Tools Graphics Memory
il io -
<! Elevation Allowed memory per map layer 500 MB =
™ colors

Puc. 9.17: 3D settings

The @ 3D menu helps you configure some default settings to use for any 3D Map view. These can refer to:
* Default Camera Settings:
— Projection type: allowing to view the 3D scene in a:

» Perspective projection (default): Parallel lines appear to meet in the distance. Objects appear to
shrink the farther they are from the camera.

+ or an Orthogonal projection: Parallel lines appear parallel. Objects appear the same size regardless
of distance.
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Camera’s Field of view: only relevant in perspective projection, specifies the current vertical field of
view in degrees and determines how much of the scene is visible to the camera. Default value is 45°.

Navigation mode: provides different means to interact with the 3D scene. Available modes are:

+ Terrain based: the camera follows around a fixed position on the surface of the terrain as the scene
is navigated.

« Walk mode (first person)
Depending on the selected mode, navigation commands differ.
— Movement speed

Invert vertical axis: Controls whether vertical axis movements should be inverted from their normal
behaviour. Only affects movement in the Walk mode. It can be set to:

x Never

+ Only when dragging: causes the vertical motion to inverted only when performing a click-and-drag
camera rotation

+ and Always: causes the motions to be inverted when both click-and-dragging and when the camera
movement is locked to the cursor (via a ~ key press)

e Under Graphics memory, the Allowed memory per layer option lets you set the GPU memory limit
configuration on each layer. This is useful for users utilizing large 3D scenes which exhaust the available GPU
memory resources. When a limit is hit, a warning is also displayed, which should assist in troubleshooting
large scenes.

9.1.11 Colors settings

Options — Colors X
Q v Color Schemes
\ General Mew layer colors v §
% System
- Color Label | (¢
CRS and Transforms
B Data Sources #d5cf3c =
«" Rendering #729b6F &
Canvas & Legend 5
B® Map Tools #f3a6b2
e
> =0 #8d5a99 a8
& Colors
Fonts #eg8718d
@ Layouts affoe17
Variables
& Authentication #b7484b
b #e77148
GPS
Locator #987db7
Acceleration
#becf50
IDE
% Processing #e17da2
& Advanced
#e5b636
f#e23835 4

@ Help @ cancel

Puc. 9.18: Colors settings
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This menu allows you to create or update palettes of colors used throughout the application in the color selector
widget. You can choose from:

* Recent colors showing recently used colors

e Standard colors, the default palette of colors

* Project colors, a set of colors specific to the current project (see Styles Properties for more details)
* New layer colors, a set of colors to use by default when new layers are added to QGIS

* or custom palette(s) you can create or import using the ... button next to the palette combobox.

By default, Recent colors, Standard colors and Project colors palettes can not be removed and are set to appear in
the color button drop-down. Custom palettes can also be added to this widget thanks to the Show in Color Buttons
option.

For any of the palettes, you can manage the list of colors using the set of tools next to the frame, ie:
. '31':'-!] Add or = Remove color
. Copy or Paste color

. [ Import or Export the set of colors from/to . gp1 file.

Double-click a color in the list to tweak or replace it in the Color Selector dialog. You can also rename it by double-
clicking in the Label column.

9.1.12 Fonts Settings

Options — Fonts x
| Font Replacements
*. General References to fonts present in this replacement list will automatically be replaced with the matching replacement font & [=
% System Family
CRS and Transforms Font Family Replacement Family
B Data Sources 1 Arfal Helvetica
«  Rendering
B Canvas & Legend
B Map Tools
3 3D
M colors
Aa Fonts
@ Layouts
variables User Fonts
& Authentication v Automatically download missing, freely-licensed fFonts —
=% Network File Font Families =
< &R 1 fhome/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/Opensans-Bold.ttF Open Sans
Locator
L 2 fhome/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/OpenSans-Bolditalic.ttf Open Sans
Acceleration
IDE 3 /home/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/OpenSans_Condensed-Bold.ttf Open Sans Condensed
# Processing 4 fhome/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/Opensans_Condensed-Bolditalic.ttf  Open Sans Condensed
A Advanced 5 /home/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/OpenSans_Condensed-ExtraBold.ttf  Open Sans Condensed
6 /home/delazj/.local/share/QGIS/QGIS3/profiles/default/fonts/OpenSans_Condensed-... Open Sans Condensed
@ Help @ cancel

Puc. 9.19: Fonts settings

The Fonts tab provides support to manage fonts used across the projects:

* Font Replacements: gives ability to populate a list of automatic font replacements to apply when loading
projects or styles, allowing better support for projects and styles to be used across different operating systems
(e.g. replace «Arial» with «Helvetica»).
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* User Fonts: Allows you to place TTF or OTF fonts in the font s sub-folder of the user profile. These fonts
can be automatically loaded at QGIS startup time. This provides a way to use fonts without requiring them to
be installed on an operating system level, which is often blocked in enterprise environments. The panel lists
all installed user fonts and allows you to manage (i.e. remove) previously installed user fonts.

It is also possible to i Automatically download missing, freely-licensed fonts: E.g. if you open a project or
style, or try to load a vector tile layer that references fonts that aren’t currently available, then a hard-coded list
of freely licensed fonts to download via URL is consulted to determine whether it’s possible to automatically
download the font to the user profile font directory (with notification of the font license).

9.1.13 Layouts settings

Composition defaults

«. General

3% System

CRS and Transforms
i Data Sources

«" Rendering

B Canvas & Legend
B® Map Tools

W 3D

M cColors

Fonts

. Layouts
Variables
& Authentication
=% Network
GPS
Locator
Acceleration
IDE

#* Processing
A Advanced

lw Layout Defaults

Default Font

v Grid Appearance

Options — Layouts X

Abyssinica SIL v

Grid style Dots * | Grid color v
v Grid and Guide Defaults

Grid spacing 10,00 mm < | Grid offset x: 0,00 y: 0,00

Snap tolerance 5px =
v Layout Paths

Path(s) to search for extra print templates o | (=

@ Help

Ococe

Puc. 9.20: Layouts settings

You can define the Default font used within the print layout.

Grid appearance

¢ Define the Grid style (,,Solid", ,,Dots”, ,,Crosses*)

¢ Define the Grid color

Grid and guide defaults

 Define the Grid spacing
¢ Define the Grid offset for X and Y

* Define the Snap tolerance
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Layout Paths

* Define Path(s) to search for extra print templates: a list of folders with custom layout templates to use while
creating new one.

9.1.14 Variables settings
The Variables tab lists all the variables available at the global-level.

It also allows the user to manage global-level variables. Click the EI-IE-:I button to add a new custom global-level
variable. Likewise, select a custom global-level variable from the list and click the = button to remove it.

More information about variables in the Storing values in Variables section.

Options — Variables X
Q Expression Variables

R Variable Value

2% System w Global
CRS and Transforms qgis_locale ‘en’

B Data Sources qgis_os_name linux’

« Rendering qgis_platform ‘desktop’
Canvas & Legend qgf.s_rel'ease_na_me :Mas.!:er

qgis_shert_version 3.27

¥ Map Tools qgis_version '3.27.0-Master’
% 3D qgis_version_no 32700

3 Colors user_account_name  ‘delazj’

Fonks user_full name ‘Delaz)’

work_department 'Map Laboratory'

™ Layouts
£ WVariables
& Authentication
=% Network
GPS
Locator
Acceleration
IDE

¥ Processing
A Advanced

g | (=

@ Help @ cancel

Puc. 9.21: Variables settings

9.1.15 Authentication settings

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Authentication
System for more details.

To manage authentications, you can use the list of tools next to the frame, ie:

. L-'::I':] Add new authentication configuration
o ==I Remove selected authentication configuration

. % Edit selected authentication configuration
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Options — Authentication x
Configurations

*, General Name

2/r5q9376  postgis-docker APIHeader
B Data Sources F

@ System

CRS and Transforms

+ Rendering
Canvas & Legend
B® Map Tools

W 3D

4 colors
@ Layouts

VERELIES
% Authentication
== Network
GPS
Locator
Acceleration
IDE
% Processing
A Advanced
Management

“slnstalled Plugins “eManage Certificates Utilities~

Note: Editing writes directly to authentication database

©Help @cancel

Puc. 9.22: Authentication settings

9.1.16 Network settings

Oomue
* VYcranoButs Tatimaym ons cemegolx 3anpocos (mc). 3HadeHue no ymordasuio — 60000
e Define Default expiration period for WMS Capabilities (hours) - default is 24
* Define Default expiration period for WMS-C/WMTS tiles (hours) - default is 24
* Define Max retry in case of tile or feature request errors

¢ Define User-Agent

86 nasa 9. QGIS Configuration



QGIS Desktop 3.34 User Guide

Options — Network X
Q General =
Y (€ Timeout for network requests (ms) 60000 =
% System faul L i bilities (h A
CRS and Transforms Default expiration period for WMS capabilities (hours) |24 -
B Data Sources Default expiration period for WMS-C/WMTS tiles (hours) | 24 -
¥ Rendering Max retry in case of tile or feature request errors 3 =
4 Canvas & Legend -
User-Agent Mozilla/5.0
Map Tools
3D Cache Settings
Colors
Fonts Content | Authentication
Layouts Directory |/home/delazj/.cache/QGIS/QGIS3
Variables . . ==
. Size [KiB] 51200 =k
Authentication
=% Network
GPS w V| Use Proxy For Web Access
sty Proxy type HttpProxy * | Default uses system's proxy
Acceleration
Host |192.168.1.3
IDE
#% Processing Port 8080
i Advanced Authentication
Configurations | Basic
Choose or create an authentication configuration
No Authentication ~ )
Configurations store encrypted credentials in the QGIS authentication database.
No proxy for (URLs starting with) & | (=

www.proprietary-gis.com

@ Help ©cancel

Puc. 9.23: Network and proxy settings

ITapameTpbl K3MIMPOBaHUS

Defines the Directory and a Size for the cache. Also offers tools to automatically clear the connection authentication
cache on SSL errors (recommended).

Proxy for web access
. & Use proxy for web access

* Set the Proxy type ol according to your needs and define ,,Host* and ,,Port“. Available proxy types are:

Default Proxy: Proxy is determined based on system’s proxy

Socks5 Proxy: O6umii mpokeu [yist modoro Buna csisu. [lognepxusatorcs TCP, UDP, npussizka k nopry
(BXOSIIIHE COeVHEHNYSI) ¥ aBTOPH3AIIUs

HitpProxy: peanuzoBad c ucroib3oBaareM koMaHapl «CONNECT», mogiep:kuBaeT TOJIBKO UCXOSIIIe
TCP coenuHeHus ; NOAAEPKUBAET ABTOPU3ALIUIO

HipCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP
requests.

FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests.

Credentials of proxy are set using the authentication widget.
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Excluding some URLSs can be added to the text box below the proxy settings (see Puc. 9.23). No proxy will be used
if the target url starts with one of the string listed in this text box.

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying
QT library documentation at https://doc.qt.io/archives/qt-5.9/qnetworkproxy.html#ProxyType-enum

Coget: HcnoJib30BaHHE NPOKCU-CEPBEPOB

Using proxies can sometimes be tricky. It is useful to proceed by ,,trial and error” with the above proxy types, to

check if they succeed in your case.

9.1.17 GPS settings

o

The *= GPS dialog helps you configure GPS devices connections and properties in QGIS. It also provides settings

for GPS tracking and data digitizing.

[a v GPS Connection
. General ® Autodetect
% system Serial device
CRS and Transforms
@ Data Sources gpsd
" Rendering Host
Canvas & Legend Port | 2947
B Map Tools Bevie
W 3D
@ colors ¥ Filtering
Fonts Acquisition interval (seconds)

@ Layouts
Variables

Distance threshold (meters)

@ Authentication ¥ Geometry Options
== Network
* aps

Store in M values

Locator ¥ GPS Location Marker
Acceleration

IDE

) GPS location marker
% Processing

A Advanced

» GPS Bearing
b GPS Track

¥ Timestamp Properties

Format Local Time

V| Leap seconds |18

@Help

You can specify:

v Map Centering and Rotation

Automatic map rotation frequency

Options — GPS

Do not Store M Values

v Rotate location marker to match GPS bearing

Threshold for automatic map centering | 50% of map extent

On GPS signal

Puc. 9.24: GPS settings

[

-

Ocnc
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* GPS Connection: provides different means to connect the device to QGIS

_ e Autodetect

— . Serial device (reload required if a new GPS Device is connected)

— . gpsd (selecting the Host and Port your GPS is connected to, and providing a Device name)
In case of connection problems, you can try to switch from one to another.

* Filtering: You can set an Acquisition interval (seconds) and/or a Distance threshold (meters) parameters to keep
the cursor still active when the receiver is in static conditions.

e Under Geometry Options, the Store in M values option allows to create geometries with M values from
the inbuilt GPS logging tools. This applies to both features digitized from GPS logs and from the Log o
Geopackage/SpatiaLite functionality. .. Options include storing timestamps (as ms since epoch), ground speed,
altitudes, bearings, and accuracy components as m values.

e GPS Location Marker

— Configure a symbol for the GPS location marker, indicating the current GPS position

= Rotate location marker to match GPS bearing: whether the marker symbol should be rotated to match
the GPS direction

* GPS Bearing:

— configure a Bearing line style using QGIS line symbol properties

— set whether to ! Calculate Bearings from travel direction: If checked, the bearing reported by the GPS
device will be ignored and the bearing will instead be calculated by the angle between the previous two
GPS locations.

* GPS Track: set symbol to use for the Track line style

* Map Centering and Rotation: defines when the map canvas is updated according to the user displacement on
the field:

— Threshold for automatic map centering: defines the minimal offset of the GPS position from the map
canvas center to trigger an automatic map recentering if enabled.

— Automatic map rotation frequency: defines how often the map rotation to match the GPS bearing could
happen; it can be on a custom duration or On GPS signal.

o Timestamp Properties to configure how time values are displayed and stored in the data. Parameters include
the Format which can be:

— Local time

- UTC

— UTC with offset, to account for daylight savings offsets or other complex time zone issues
— aspecific Time zone

Moreover, Leap seconds correction can be applied, by adding the seconds to GPS timestamp.
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GPSBabel

GPSBabel converts waypoints, tracks, and routes between popular GPS receivers such as Garmin or Magellan and
mapping programs like Google Earth or Basecamp. Literally hundreds of GPS receivers and programs are supported.
QGIS relies on GPSBabel to interact with these devices and manipulate their data.

For details on how-to, please refer to Loading to or from a device.

9.1.18 Locator settings

Q The Locator tab lets you configure the Locator bar, a quick search widget available on the status bar to help
you perform searches in the application. It provides some default filters (with prefix) to use:

Locator Filters

Options — Locator

% General Filter Prefix Enabled Default Configuration
% system Project Layers l v v
CRS and Transforms profect L " l . >
roject Layouts
i Data Sources - 3 -
+ Rendering Actions v
Canvas & Legend Active Layer Features f v
& Map Tools .
P Features in All Layers af v
W 3D
M colors Calculator = v
Fonts Spatial Bookmarks b v v
W Layouts Settings set v v
Variables .
- . Go to Coordinate go v v
@ Authentication
e Nebwark Nominatim Geocoder > v
GPS Processing Algorithms a v v
2. Locator .
Edit Selected Features ef v v

Acceleration
IDE
3% Processing
A Advanced

@ Help O cancel

Puc. 9.25: Locator settings

 Project Layers (1): finds and selects a layer in the Layers panel.

* Project Layouts (p1): finds and opens a print layout.

* Actions (.): finds and executes a QGIS action; actions can be any tool or menu in QGIS, opening a panel...

* Active Layer Features (£): searches for matching attributes in any field from the current active layer and
z00ms to the selected feature. Press * to configure the maximum number of results.

* Features in All Layers (af): searches for matching attributes in the display name of each searchable layers

‘?
and zooms to the selected feature. Press “*" to configure the maximum number of results and the maximum
number of results per layer.

* Calculator (=): allows evaluation of any QGIS expression and, if valid, gives an option to copy the result to
the clipboard.
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* Spatial Bookmarks (b): finds and zooms to the bookmark extent.
* Settings (set): browses and opens project and application-wide properties dialogs.

* Go to Coordinate (go): pans the map canvas to a location defined by a comma or space separated pair of x
and y coordinates or a formatted URL (e.g., OpenStreetMap, Leaflet, OpenLayer, Google Maps, ...). The
coordinate is expected in WGS 84 (epsg: 432 6) and/or map canvas CRS.

* Nominatim Geocoder (>): geocodes using the Nominatim geocoding service of the OpenStreetMap
Foundation.

* Processing Algorithms (a): searches and opens a Processing algorithm dialog.

o Edit Selected Features (e f): gives quick access and runs a compatible modify-in-place Processing algorithm
on the active layer.

In the dialog, you can:
* customize the filter Prefix, i.e. the keyword to use to trigger the filter

¢ set whether the filter is Enabled: the filter can be used in the searches and a shortcut is available in the locator
bar menu

* set whether the filter is Default: a search not using a filter returns results from only the default filters
categories.

» Some filters provide a way to configure the number of results in a search.

The set of default locator filters can be extended by plugins, eg for OSM nominatim searches, direct database
searching, layer catalog searches, ...

9.1.19 Acceleration settings

OpenCL acceleration settings.

Options — Acceleration x

| Some of the internal C++ processing core algorithms and renderers can take advantage of an OpenCL compatible
device to increase the performances.

“. General QGIS OpenCL support is highly experimental and can crash QGIS because of bugs in the underlying libraries,
% System enable at your own risk!
CRS and Transforms V| Enable OpenCL acceleration
@ Data Sources The following OpenCL devices were Found on this system (changing the default device requires QGIS to be restarted).
« Rendering NVIDIA GeForce GTX 1050 Ti -
B Canvas & Legend Type: GPU
B Map Tools Name: NVIDIA GeForce GTX 1050 Ti

Vendor: NVIDIA Corporation
Profile: FULL_PROFILE

4 colors Version: OpenCL 3.0 CUDA
Image support: True

Max image2d width: 16384

W Layouts Max image2d height: 32768

Max mem alloc size: 1059078144

i 3D

Fonts

Variables
@& Authentication
== Network
GPS

Locator

™ Acceleration
IDE

% Processing
A& advanced

@Help ©cancel

Puc. 9.26: Acceleration settings
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Depending on your hardware and software, you may have to install additional libraries to enable OpenCL
acceleration.

9.1.20 IDE settings

Code Editor settings

In the Code Editor tab, you can control the appearance and behaviour of code editor widgets (Python interactive
console and editor, expression widget and function editor, ...).

Options — Code Editor X
Q Preview
“. General 1 =def simple function(x,y,z): =
% System gcgll_s Expression i =
CRS and Transforms HTML 2
B Data Sources Css G return-[1,-1.2, -"val", -'a-string’', -{'a': -True, -'b": -
: ) JavaScript B
« Rendering
. 7 @my decorator
Canvas & Legend 8 —def somefunc(paraml: -str="", -param2=0):
B Map Tools 9
~ 10 = if-paraml.= param2: # interesting
R 11 print{'Gre\'ater'.lower())
4 colors 12 return-(param2---paraml-+-1-+.8b181) -or -None
Fonts =
14 =class-SomeClass: b
M Layouts « C
R override Code Editor Font =
@ Authentication
== Network
GPS
Colors
Locator
Acceleration Color scheme Default
IDE Default @ - Background ~ Cursor I
= Code Editor d .
Function N -| Keywor S - class name O
¢ Python Console W
% Processing Operator N |- Quoted operator N - Number I
I

A Advanced \dentifier I -| Quoted identifier N - Decorator
L] - : »

@Help ©cancel

Puc. 9.27: Code Editor settings

At the top of the dialog, a widget provides a live preview of the current settings, in various coding languages (Python,
QGIS expression, HTML, SQL, JavaScript). A convenient way to adjust settings.

* Check ] Override Code Editor Font to modify the default Font family and Size.
¢ Under the Colors group, you can:

— select a Color scheme: predefined settings are Default, Solarized Dark and Solarized
Light. A Custom scheme is triggered as soon as you modify a color and can be reset with selecting
a predefined scheme.

— change the color of each element in code writing, such as the colors to use for comments, quotes,
functions, background, ...
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Python Console settings

The F:- Python Console settings help you manage and control the behavior of the Python editors (interactive console,
code editor, project macros, custom expressions, ...). It can also be accessed using the &, Options... hyytton from:

e the Python console toolbar
* the contextual menu of the Python console widget

¢ and the contextual menu of the code editor.

Options — Python Console

w V| Autocompletion

General Autocompletion threshold 2 = | characters

From document ® From API files From doc and APIs
User Profiles

CRS and Transforms ¥ Typing

Data Sources

“ Rendering

1 Canvas & Legend

Automatic parentheses insertion
V| Automatically surround selection when typing quotes or brackets

Automatic insertion of the 'import’ string on *from xxx'

Map Tools
Elevation v Formatting
3D Reformat on save
Colors | Sortimports
Fonts Maximum line length | 80 =
Layouts Formatter autopepd -
. _ =
Rareties Autopeps level 1 -

m Authentication

= Metwork w Run and Debug

Enable Object Inspector (switching between tabs may be slow)

Locator Auto-save script before running

Acceleration
b APIs

& code Editor GitHub Access Token

#_ Python Console

_ACCESS_TOKEN= Generate
%% Processing
A Advanced B Aide + 0Ok | © Annuler

Puc. 9.28: Python Console settings

You can specify:

o J Autocompletion: Enables code completion. You can get autocompletion from the current document, the
installed API files or both.

— Autocompletion threshold: Sets the threshold for displaying the autocompletion list (in characters)

 under Typing

- Automatic parentheses insertion: When no text is selected, if an opening character (parentheses,
quotes, brackets, ...) is entered, inserts the matching closing character just after the cursor. Note that
this behavior is disabled if the current cursor is inside a string or comment.

- Automatically surround selection when typing quotes or brackets: When an opening character is
entered, the selected text is enclosed in the opening/closing pair. Selection remains the same, so it is
possible to quote a selected word and enclose it in parentheses just by typing " then (.
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Special case for multiline selection with quotes and double quotes: selection is enclosed in triple
single/double quotes.

- Automatic insertion of the jimport” string on ,from xxx*“: Enables insertion of ,,import“ when
specifying imports

¢ under Formatting, you can add automated tools to reformat the code you are writing:

Reformat on save: formatting is applied just before saving the script

A Sort imports: sorts ,import” statements using the isort library

Maximum line length: controls how the formatter will wrap the lines, and controls the editor ruler

Formatter - supported tools are autopep8 and black, with dedicated option:

* Autopep8 level - more details at autopep8 advanced usage

# Normalize quotes: replaces all single quotes with double quotes if possible

e under Run and Debug
- Enable Object Inspector (switching between tabs may be slow)

- Auto-save script before running: Saves the script automatically when executed. This action will store
a temporary file (in the temporary system directory) that will be deleted automatically after running.

For APIs you can specify:

o sing preloade s file: You can choose 1f you would like to use the preloade 1les. If this 1s not

BU' loaded APIs file: Y h if y 1d lik he preloaded API files. If this i
checked you can add API files and you can also choose if you would like to use prepared API files (see next
option).

. Using prepared APIs file: If checked, the chosen * . pap file will be used for code completion. To generate
aprepared API file you have to load at least one * . ap1 file and then compile it by clicking the Compile APIs...
button.

Under GitHub access token, you can generate a personal token allowing you to share code snippets from within the
Python code editor. More details on GitHub authentication
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9.1.21 Processing settings

The
Processing framework. More information at QGIS processing framework.

Processing tab provides you with general settings of tools and data providers that are used in the QGIS

Options — Processing X
[a ] Setting Value
Neeneral - 4 General
3 System Default output raster layer extension tif
CRS and Transforms ¥# Default output vector layer extension gpkg
B Data Sources Invalid Features filtering Stop algorithm execution when a geometry is invalid
« Rendering ¥ Keep dialog open after running an algorithm v
2 Canvas & Legend # Max Threads 8
Map Tools Output folder /home/delazj/ local/share/QGIS/QGIS3/profiles/defaul...
3D Override temporary output folder path
Colors ¥ Post-execution script
IR 4% Pre-execution script
SSYORE Prefer output filename for layer names v
Eamatics Results group name
Authentication % show algorithms with known issues
# Network 4% show layer CRS definition in selection boxes v
o5 Show tooltip when there are disabled providers v

Locator
4 style for line layers

Acceleration
IDE
# Processing

Style For point layers

4% style for polygon layers

A Advanced style for raster layers
4t warn before executing if parameter CRS's do not match v
b = Menus Reset to defaults
» #: Models
» % Providers
» @ scripts

@Help

Puc. 9.29: Processing settings

Ocmcs
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9.1.22 Advanced settings

*. General

% System
CRS and Transforms
B Data Sources

« Rendering

Canvas & Legend

B Map Tools
& 3D
3 Colors
Fonts
M Layouts
Variables
& Authentication
== Network
GPs
Locator
Acceleration
IDE
% Processing
Ay Advanced

| Advanced Settings Editor

Options — Advanced

Setting Type
» 3 Projections
~ 5 pythonPlugins
GdalTools bool
MetasSearch bool
db_manager bool
grassprovider bool
processing bool
sagaprovider bool
» 3 QgsCollapsibleGroupBox
» 3 QgsVariableEditor
» 5 QgsVariableEditorTree
» 5 Raster
» [ statisticalsummaryDock
» S5l
» 5 windows
- 5 app
» 5 LayoutDesigner
» 5 windows
» 5 gps
» 9 map3d
» 3 plugin_installer
» 5 plugin_repositories
» 5 projections
askToSaveMemaoryLayers bool
maxRecentProjects int
minTaskLengthForSystemMNotification int
showPanDistancelnStatusBar bool
~ 5 browser
expandedPaths QstringList
hiddenPaths Qstring
propertieswidgetEnabled bool
propertieswidgetHeight float
» 5 browser2
» 5 cache
+ 5 colors
@Help

Value Description

true
true
true
true
true
true

true
20

5
true

Favorites: xyz:

//media/delazj/CASA/mysecret...
false

Oconce

[e]

Puc. 9.30: Advanced settings

All the settings related to QGIS (UI, tools, data providers, Processing configurations, default values and paths,
plugins options, expressions, geometry checks...) are saved in a QGIS/QGIS3.ini file under the active user
profile directory. Configurations can be shared by copying this file to other installations.

From within QGIS, the Advanced tab offers a way to manage these settings through the Advanced Settings Editor.
After you promise to be careful, the widget is populated with a tree of all the existing settings, and you can edit
their value. Right-click over a setting or a group and you can delete it (to add a setting or group, you have to edit
the QGIS3.ini file). Changes are automatically saved in the QGIS3. ini file.

IIpenynpexxaenue: Avoid using the Advanced tab settings blindly

Be careful while modifying items in this dialog given that changes are automatically applied. Doing changes
without knowledge can break your QGIS installation in various ways.
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9.2 Working with User Profiles

9.2.1 The concept
The Settings » User Profiles menu provides functions to set and access user profiles. A user profile is a unified
application configuration that allows to store in a single folder:

« all the global settings, including locale, projections, authentication settings, color palettes, shortcuts. ..

* GUI configurations and customization

» grid files and other proj helper files installed for datum transformation

* installed plugins and their configurations

* project templates and history of saved project with their image preview

* processing settings, logs, scripts, models.

By default, a QGIS installation contains a single user profile named default. But you can create as many user
profiles as you want:

1. Click the New profile... entry.

2. You'll be prompted to provide a profile name, creating a folder of the same name under ~/
<UserProfiles>/ where:

+ ~ represents the HOME directory, which on £7 Windows is usually something like C:\Users\
<username>.

e and <UserProfiles> represents the main profiles folder, i.e.:

- (:\ .local/share/QGIS/QGIS3/profiles/

- &7 3AppData%\Roaming\QGIS\QGIS3\profiles\

- x Library/Application Support/QGIS/QGIS3/profiles/
The user profile folder can be opened from within QGIS using the Open Active Profile Folder.
3. A new instance of QGIS is started, using a clean configuration. You can then set your custom configurations.

If you have more than one profile in your QGIS installation, the name of the active profile is shown in the application
title bar between square brackets.

As each user profile contains isolated settings, plugins and history they can be great for different workflows, demos,
users of the same machine, or testing settings, etc. And you can switch from one to the other by selecting them in
the Settings » User Profiles menu. You can also run QGIS with a specific user profile from the command line.

Coser: Run QGIS under a new user profile to check for bug persistence

When you encounter weird behavior with some functions in QGIS, create a new user profile and run the commands
again. Sometimes, bugs are related to some leftovers in the current user profile and creating a new one may fix them
as it restarts QGIS with the new (clean) profile.
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9.2.2 Setting user profile

By default, QGIS opens a new session with the profile of the last closed session. This, among other settings, can be

customized in Settings » X Options » -’- User Profiles tab:

Options — User Profiles

Q Startup Profile
4 General Use last closed profile

% System

Always use profile default
8 User Profiles

. ®) Choose profile at start up

CRS and Transforms

& Data s These settings do not apply if a profile was explicitly selected with the --profile command line argument
ata Sources

" Rendering Profile Display
} Canvas & Legend Default icon size 64 ~
Map Tools
k) Active Profile (default) icon . =
1 Colors
Fonts
Layouts
Variables
= Authentication

= Network

Acceleration

IDE

% Processing

A Advanced

& Aide v Ok |®ﬁnnuler

Puc. 9.31: User profiles settings

* Startup profile: indicates the user profile to use when starting a QGIS session. It can be:
— Use last closed profile
— aspecific user profile to select from Always use profile drop-down menu

— Choose profile at start up: Opens the User Profile Selector dialog listing available user profiles. Double-
click an entry or select a profile and press OK to use that user profile for the starting session. It is also

possible to Ell'l}:l Add new profile to the list: a profile is created from scratch and automatically run with
the opening session.

» Under Profile display, you can set:
— The size of icons to use when selecting a profile from the User Profile Selector dialog.

— A specific icon to display next to the current profile in the Settings » User profiles menu or the User

| _
Profile Selector dialog. Press M Resetprofileicon o remove custom modifications.
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9.3

CBowncTBa npoekTa

In the properties window for the project under Project » Project Properties, you can set project-specific options.
The project-specific options overwrite their equivalent in the Options dialog described above.

9.3.1 General Properties

N,
In the #% General tab, the General settings let you:

see the location of the project file

set the folder for the project home (available in the Project home item of the Browser panel). The path can
be relative to the folder of the project file (type it in) or absolute. The project home can be used for storing
data and other content that is useful for the project. Convenient when dataset and project files are not stored
at the same place. If not filled, the Project home defaults to the project file folder.

give a title to the project beside the project file path
choose the color to use for features when they are selected
choose the background color: the color to use for the map canvas

set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file
location. You may prefer relative path when both layers and project files can be moved or shared or if the
project is accessed from computers on different platforms.

choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to
performance degradation.

Remember attribute tables windows and docks between sessions: If checked for a project, then any opened
attribute tables will be saved into the project and immediately restored when loading that project. This can
improve workflows when you constructed a project with a particular set of attribute table configurations for
your requirements, and re-setting up these attribute tables is a hassle.

Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying
projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

the Ellipsoid, on which distance and area calculations are entirely based; it can be:
— None/Planimetric: returned values are in this case cartesian measurements. This option can be set as
default for new projects from the Settings » X Options » {‘ﬁ} CRS Handling menu
— a Custom one: you'll need to set values of the semi-major and semi-minor axes.

— or an existing one from a predefined list (Clarke 1866, Clarke 1880 IGN, New International 1967, WGS
84...).

the Units for distance measurements for length and perimeter, and the Units for area measurements. These
settings which default to their corresponding global options override them in the current project. They are
used in:

Attribute table field update bar

Field calculator calculations

Identif’y tool derived length, perimeter and area values

measure dialog

scale bar decoration

The Coordinate and Bearing display allows you to customize the display of:

the coordinates shown in the Coordinates box on QGIS status bar and in the Derived section of the QT%
Identify features tool’s results
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* the bearing value displayed in the status bar for the map canvas panning direction and by the T/ Measure bearing

tool.
Available parameters are:
* Display coordinates using either:
— Map Units, based on the project CRS

— Map Geographic (degrees): based on the project CRS if it is of geographic type, otherwise
uses its associated geographic CRS. This is helpful e.g. for non-earth celestial bodies.

— or Custom Projection Units: allows to rely on any CRS you desire for coordinates display
¢ In the Coordinate CRS option, you can view or define the CRS to use depending on your display mode.

» Coordinate format: you can configure it as Decimal Degrees, Degrees, Minutes or Degrees,
Minutes, Seconds, and whether it should display:

- Show directional suffix
- Show leading zeros for minutes and seconds
- Show leading zeros for degrees

- Show trailing zeros

* Coordinate precision: the number of decimal places can be automatic (derived from the type of CRS) or set
manually

» Coordinate order: you can opt to display the coordinates in the native order of the CRS (Default) or
switch it to either Easting, Northing (Longitude, Latitude) orNorthing, Easting
(Latitude, Longitude) order

* Bearing format possible values are 0 to 180°, with E/W suffix,-180 to +180°or0 to
360°. The number of Decimal places as well as whether to Show trailing zeros can be set.
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Project Properties — General

Q w General Settings

Project file I5-Documentation/qgis-projects/user_manual/introduction_ggis_gui_map_legend.qgs

Metadata Project home

P Project title GUI & Map Legend
View Settings

Selection color = Background color -

Save paths Relative -
Transformations
Awvoid artifacts when project is rendered as map tiles (degrades performance)

” Styles ) ) :
* Remember attribute tables windows and docks between sessions

Data Sources
w Measurements

Relations

Ellipsoid . .
. . None / Planimetric v
o _ (for distance and area calculations)
Variables
Semi-major Semi-minor

Macros

Units for distance measurement Meters -
QGIS Server )

Units for area measurement Square Meters v

{ Temporal
¥ Coordinate and Bearing Display
B2 Terrain

Display coordinates using | Custom Projection Units (degrees) -

Coordinate CRS EPSG:4326 - WGS 84 = —:'5

Coordinate format Customize...

Coordinate precision (®) Automatic () Manual | | decimal places

Coordinate order Default hd

Bearing format Customize...

Generate Project Translation File

Source language == American English - Generate TS File

H Aide | + Ok | -+ Appliquer | | © Annuler

Puc. 9.32: General tab of the Project Properties dialog

9.3.2 Metadata Properties

The :? Metadata tab allows detailed metadata to be defined, including (among the others): author, creation date,
language, abstracts, categories, keywords, contact details, links, history. There is also a validation functionality that
checks if specific fields were filled, anyway this is not enforced. See vector layer metadata properties for some
details.
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9.3.3 View Settings

Project Properties — View Settings x

v V| Project Predefined Scales

¢ General 1:100000 e
1:50000
1 1:25000 =
Metadata 15000
%% view Settings
8

% CRS
% Transformations

% Default Styles
. Y w V| Set Project Full Extent (current: map view)

B8 DataSources
=]

North 4366425.0709
& Relations West -1740916.7749 East |-624380.3165
VELGEDIES South |3575912.2232

{;Q Macros Calculate from Layer - Map Canvas Extent

©Help Q~apply || Ocancel

Puc. 9.33: View Settings tab of the Project Properties dialog

The 5% View Settings tab provides means to control the project map canvas. You can:

* set Project predefined scales: the list of scales to display in scale-related drop-down widgets, such as the status
bar Scale, the visibility scales selector or secondary 2D map view settings,... in replacement of the global
predefined scales.

* Set Project full Extent: this extent will be used instead of the extent of all layers when zooming to full map

extent (;:). It’s useful when a project contains web layers/national layers/global layers yet the actual area of
interest for the project is a smaller geographic area. The project full extent coordinates can be set with the
extent selector widget.

9.3.4 CRS Properties

IIpumeuanue: For more information on how QGIS handles project projection, please read the dedicated section
at Paboma ¢ npoexuusamu.

The % CRS tab helps you set the coordinate reference system to use in this project. It can be:

. & No CRS (or unknown/non-Earth projection): layers are drawn based on their raw coordinates

e or an existing coordinate reference system that can be geographic, projected or user-defined. Layers added to
the project are translated on-the-fly to this CRS in order to overlay them regardless their original CRS.
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9.3.5 Transformations Properties

The @ Transformations tab helps you control the layers reprojection settings by configuring the datum
transformation preferences to apply in the current project. As usual, these override any corresponding global
settings. See Datum Transformations for more details.

9.3.6 Styles Properties

Under & Styles tab, you can configure symbols and colors inherent to the project, allowing to safely share the
project among different machines.

The Default Symbols group lets you control how new layers will be drawn in the project when they do not have an
existing . gml style defined. You can set Marker, Line, Fill to apply depending on the layer geometry type as well as
default Color Ramp and Text Format (e.g. when enabling labeling). Any of these items can be reset using the Clear
entry from the corresponding drop-down widget.

In the Options group, you can:

* Apply a default Opacity to new layers

. & Assign random colors to symbols, modifying the symbols fill colors, hence avoiding same rendering for

all layers.
Project Properties — Styles X
[a | v Default Symbols
\‘-...__ General
~ ° Marker . -
a Metadata
View Settings " Line —_— =
&5 CRrs & Fill =
2 Transformations [EECEReSGLECIEN -
d" Styles sbc Text Format |Configure Text Format... -
E Data Sources w Options
EE Relations Opacity ~11100,0 % =
N v| Assign random colors to symbols
v
{;@ Macros Project Colors
=_1'-= QGIS Server Color Label &
. metalRed =
a- Temporal
- . water A
&8 Terrain =
. grass
=)
w Style Databases
o
=

@Help @Apply || @cancel

Puc. 9.34: Styles tab
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There is also an additional section where you can define specific colors for the running project. Like the global
colors, you can:

. Ifl-l:l-l:| Add or = Remove color

-
. Copy or Paste color

-
. Import or =1 Export the set of colors from/to . gp1 file.

Double-click a color in the list to tweak or replace it in the Color Selector dialog. You can also rename it by double-
clicking in the Label column.

These colors are identified as Project colors and listed as part of color widgets.

Coset: Use project colors to quickly assign and update color widgets

Project colors can be refered to using their label and the color widgets they are used in are bound to them. This
means that instead of repeatedly setting the same color for many properties and, to avoid a cumbersome update you
can:

1. Define the color as a project color
2. Click the data defined override widget next to the color property you want to set

3. Hover over the Color menu and select the project color. The property is then assigned the expression
project_color ('color_label') and the color widget reflects that color.

4. Repeat steps 2 and 3 as much as needed

5. Update the project color once and the change is reflected EVERYWHERE it’s in use.

9.3.7 Data Sources Properties

In the Data Sources tab, you can:
 Transaction mode, defines how edits are sent to the data provider:

— Local Edit Buffer: edits are buffered locally and sent to the provider when toggling layer editing mode
or clicking Save edits.

— Automatic Transaction Groups: on supported datasources (postgres and geopackage databases) the edit
state of all tables that originate from the same database are synchronized and executed in a server side
transaction. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the
database which gets committed when toggling layer editing mode or clicking Save edits.

— Buffered Transaction Groups: all editable layers, disregarding from which provider, are toggled
synchronously and all edits are saved in a local edit buffer. Saving changes is executed within a single
transaction on all layers (per provider).

Note that you can change this option only if no layer is being edited in the project.

. Evaluate default values on provider side: When adding new features in a PostgreSQL table, fields with
default value constraint are evaluated and populated at the form opening, and not at the commit moment.
This means that instead of an expression like nextval ('serial'), the field in the Add Feature form
will display expected value (e.g., 25).

. Remember editable layer status between sessions: makes sure that all layers that are editable in a project
will be remembered as such when saving the project, as well as making sure that those layers are immediately
made editable whenever the project is restored.

* Configure the Layers Capabilities, i.e.:
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— Set (or disable) which layers are identifiable, i.e. will respond to the identify tool. By default,
layers are set queryable.

— Set whether a layer should appear as read-only, meaning that it can not be edited by the user,
regardless of the data provider’s capabilities. Although this is a weak protection, it remains a quick
and handy configuration to avoid end-users modifying data when working with file-based layers.

— Define which layers are searchable, i.e. could be queried using the locator widget. By default, layers
are set searchable.

— Define which layers are defined as required. Checked layers in this list are protected from
inadvertent removal from the project.

— Define which layers are private,i.e. hidden from the Layers panel. This is meant for accessory layers
(basemap, join, lookups for value-relations, most probably aspatial layers, ...) that you still need in a
project but you don’t want them to pollute the legend tree and other layer selection tools. If set visible,

they are still displayed in the map canvas and rendered in the print layout legend. Use the ? Filter
legend » Show private layers option in the Layers panel top toolbar to temporarily turned them on for
any interaction.

The Layers Capabilities table provides some convenient tools to:

— Select multiple cells and press Toggle Selection to have them change their checkbox state;

- Show spatial layers only, filtering out non-spatial layers from the layers list;

- Filter layers... and quickly find a particular layer to configure.

¢ Under the Advanced Settings group, you can select Trust project when data source has no metadata: To
speed up project loading by skipping data checks. Useful in QGIS Server context or in projects with huge
database views/materialized views. The extent of layers will be read from the QGIS project file (instead of
data sources) and when using the PostgreSQL provider the primary key unicity will not be checked for views
and materialized views.
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Project Properties — Data Sources X

Q, Editing Behavior

. General Transaction mode | Local Edit Buffer v
E Metadata Evaluate default values on provider side

Remember editable layer status between sessions

View Settings

. v Layer Capabilities
€5 CRs yertap

g

P . Layer Identifiable Read-only Searchable  Required Private
W Transformations - @ Boundaries Group
regions v v v v
-~
& Default Styles alaska 7
> [l
-~ Data Sources - Walfer Group
rivers v v
EE Relations Majrivers v v
lakes v v
Variables M swamp v v
* [ group1
{G Macros * popp v
- @ airports v v v
—T- QGIS Server @ storagep v v

4 »
ﬁ- Temporal

Show spatial layersonly | @
B8 Terrain

Advanced Settings

Trust project when data source has no metadata

@Help @apply || Ocancel

Puc. 9.35: Data Sources tab

9.3.8 Relations Properties

The = Relations tab is used to define relations between layers. The relations can be of one to one, many to many
or polymorphic type. They are defined in the project properties dialog. Once relations exist for a layer, a new user
interface element in the form view (e.g. when identifying a feature and opening its form) will list the related entities.
This provides a powerful way to express e.g. the inspection history on a length of pipeline or road segment. You
can find out more about relations support in section Setting relations between multiple layers.

Project Properties | Relations x

Name ~ Referenced Layer Referenced Field Referencing Layer Referencing Field Id Strength

\'-.__ General 1|airport_regions regions ID airports fk_region airport_region_fk Association

! Metadata
& crs
% Default styles

: Data Sources

“I= Relations
Variables

{G Macros s Add Relation | | s Discover Relations

B8 qaisserver [T </ Apply || % cancel

Puc. 9.36: Relations tab
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9.3.9 Variables Properties

The € Variables tab lists all the variables available at the project’s level (which includes all global variables).
Besides, it also allows the user to manage project-level variables. Click the Ifl-l-ll:| button to add a new custom project-

level variable. Likewise, select a custom project-level variable from the list and click the = button to remove it.
More information on variables usage in the General Tools Storing values in Variables section.

9.3.10 Macros Properties

i0
The ﬁ:) Macros tab is used to edit Python macros for projects. Currently, only three macros are available:
openProject (), saveProject () and closeProject ().

Project Properties | Macros

Q v| Python macros

\.__.__ Tl 1 —def openProject():
2 msgbar = -iface.messageBar()
a‘ Metadata 3 - msgbar.pushMessage( 'WARNING', 'project-contains-sensitive-data’,
4 QgsMessageBar.WARNING, 10) -
5|
6 —def . saveProject():
% Derault Styles E pass
8
[, 7] Identify Layers 9 —def . closeProject(}):
" 10 pass
EE Data Sources 11
!E Relations
Variables
Macros
[~ QGIS Server
4 4

@Help </ Apply || % cancel

Puc. 9.37: Macro settings

9.3. CsowncTBa npoekra 107



QGIS Desktop 3.34 User Guide

9.3.11 QGIS Server Properties

The 52| QGIS Server tab allows you to configure your project in order to publish it online. Here you can define
information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions. More information
available in section Creatingwmsfromproject and subsequent.

Project Properties — QGIS Server X
Services Capabilities | WMS = WMTS = WFS/OAPIF =~ WCS 3
\'--..__ General v |v| Enable Service Capabilities
Metadata These parameters are used to generate the GetCapabilities document and shall be
) . chosen carefully to avoid interoperability and security issues.
View Settings
RS Short name A name used to identify the root layer. The short name is a text ...
Title The title should be brief yet descriptive enough to identify this ...
e Transformations :
Organization The name of the service provider.
=/
o bEEnEEmE online resource  |The web site URL of the service provider. =l
B8 Data Sources Person The contact person name for the service.
EE Relations Position -
Variables E-Mail The conkact person e-mail for the service.
@ Phone The contact person phone for the service.
s Macros
=
=% QGIs Server
ﬁ- Temporal
Abstract
Fees Conditions Unknown -
Access constraints None hé
Keyword list List of keywords separated by comma to help catalog searching.
Tesk Configuration
Launch
©Help @apply || @cancel

Puc. 9.38: QGIS Server settings
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9.3.12 Temporal Properties

The Temporal tab is used to set the temporal range of your project, either by using manual Start date and End
date inputs or by calculating it from the current project temporal layers. The project time range can then be used in

the Temporal controller panel to manage the map canvas femporal navigation.

Project Properties — Temporal

Temporal Options

%, General

.
m Transformations

%" Default Styles

E Data Sources

EE Relations

Variables

{;@ Macros

QGIS Server

Temporal

9.3.13 Terrain Properties

—

Start date | MULL

MULL
Calculate From Layers

@apply || @cancel Qok

Puc. 9.39: Project Temporal tab

The “— Terrain tab helps you configure default settings for the terrain and elevation. When any new 3d map is
created in the project, the map will default to using the same terrain settings as are defined for the project. The

project elevation settings will also be respected by the elevation profile tool.
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Project Properties — Terrain

w Terrain
\‘....____ General Type DEM (Raster Layer) =
! Metadata DEM layer -
View settings Vertical scale 1,00 =
Offset 0,00 =

CRS ‘ =
w V| Global Map Shading

Apply shading on the canvas following elevation of point cloud layers, mesh layers and raster layers if they
represent elevation surface.

ﬁ Data Sources Method to combine Highest Elevation -
EE Relations w V| Eye-Dome Lighting
Variables Strength 1000 v
Distance 0,50 <! | Millimeters -
{.@ Macros
. QGIS Server v V| Hillshading
a, Temporal Z Factor 1,000000 =
Multidirectional
/7] Terrain
_ Azimuth | 315,0° -
Sensors
Altitude | 45,0° - |
LJ
1Bl Aide v 0Ok + Appliquer || @ Annuler

Puc. 9.40: Project Terrain tab

¢ Terrain and elevation options are available for:

— Flat terrain with Terrain height setting

— DEM (Raster Layer): with setting for defining the Raster layer, a Vertical scale factor to apply to band
values and a vertical Offset

— Mesh: with setting for defining the Mesh layer, a Vertical scale factor to apply to vertices Z value and a
vertical Offset

These settings can be overwritten from the 3D map configuration dialog.

e With ] Global map shading settings, you apply a global shading effect to the map, based on the elevation
of all the active layers that have elevation properties enabled, including:

— raster layers
— mesh layers

— point cloud layers

Method to combine: the elevation value at any particular position for all the relevant layers are combined, and
the considered elevation is chosen depending on one of these methods:

— Highest elevation value

— Based on layer’s order: the elevation on the topmost layer in the layer tree is considered.

Supported shading options are:

- Eye-dome lighting: applies shading effects to the map canvas for a better depth rendering. Following
parameters can be controlled:

« Strength: increases the contrast, allowing for better depth perception
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« Distance: represents the distance of the used pixels off the center pixel and has the effect of making
edges thicker.

-0 Hillshading, shaping some reliefs on the map using shading (levels of gray):

« Z Factor: Scaling factor for the elevation value
« ! Mulridirectional: Specify if multidirectional hillshading is to be used

+ Azimuth: The azimuth of the light source

« Alfitude: The elevation angle of the light source

IIpumeuanne: A shortcut to Global map shading properties is available through the Layer Styling panel.

9.3.14 Sensors Properties

() . . . . . .
The (@) Sensors tab is used to configure sensors and toggle their connection status. When active, sensors will
passively collect data in the background and make available their latest data to expressions and python scripts.

Project Properties — Sensors = (=
Sensors
. Name Last Value
“ Metadata heat sensor Disconnected |
radiation sensor Disconnected

View Settings

& s

e

% Transformations

T styles

E Data Sources

=. Relations
Variables

{;‘G Macros

—T, QGIS Server

9 Temporal

B8 Terrain

((®) sensors

When connected, a sensor will passively capture data in the background. The latest captured data
can be accessed within expressions using the sensor_data('sensor name') function.

@ Help @rpply | Qcancel

Puc. 9.41: Project Sensors tab

To add a new sensor, click on the EI-IE-J button. A settings sub-panel will open and allow you to configure:
* the Sensor name: used to retrieve sensor values in expressions and python scripts;

e the Sensor type: TCP, UDP, serial port, etc.; and
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* additional type-specific details (e.g. host name and port)

Project Properties — Sensors N (=
Sensors
2 General 4| sensor Settings
" Sensor name
I Metadata -
radiation sensor

View Settings Sensor type
:.i_é.‘-. CRS i) TCP socket sensor v
&% Transformations Host name (a domain string or IP address)
.g,.; Styles 127.0.0.1

Port
E Data Sources

| 1234 :

=. Relations

Variables
{;@ Macros
—T- QGIS Server

0 Temporal

B2 Terrain

((®) sensors

@ Help @rpply | @cancel

Puc. 9.42: Sensor Settings sub-panel

Once a sensor is configured, you can use the b Start hutton to connect the sensor. Once active, the last collected
data will be displayed in the sensors table’s Last value column.

9.4 HacTtpouka nHtepcenca

The Customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very
useful if you want to provide your end-users with a ,light* version of QGIS, containing only the icons, menus or
panels they need.

IIpumeuanne: Before your changes are applied, you need to restart QGIS.
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NBEHAF

v| Enable customization

< label a
Object name Label =
* V| Menus
¥ V! mLayerMenu Layer
v “ mActionLabeling Labeling
* | mViewMenu View
* | menuDecorations Decorations
¥| = mActionDecorationCopyright Copyright Label...
v| T mActionDecorationTitle Title Label...
* |v| mToolbarMenu Toolbars

¥ mActionToggleLabelToolBar Label Toolbar
¥ V! StatusBar
¥ mRotationLabel
* V| Toolbars

* | mLabelToolBar Label Toolbar
¥\ “ mActionChangelLabelProperties Change Label
V| %, mActionDiagramProperties Diagram Options
v “ mActionLabeling Labeling
v| “5 mActionMovelabel Move Label and Diagram
v *“ mActionPinLabels Pin/Unpin Labels and Diagrams
v| “2 mActionRotateLabel Rotate Label
v| % mActionShowHideLabels show/Hide Labels and Diagrams
v *“3 mActionShowPinnedLabels Highlight Pinned Labels and Diagrams
v “ mActionshowUnplacedLabels  Show Unplaced Labels

* V| Widgets
w | NMincahantk b
@Help & Reset « Apply || % cancel « OK

Puc. 9.43: The Customization dialog

Ticking the o Enable customization checkbox is the first step on the way to QGIS customization. This enables the
toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:
¢ a Menu or some of its sub-menus from the /" 1asroe menio
¢ a whole Panel (see Panels and Toolbars)
« the Status bar described in Cmpoxa cocmosinus or some of its items
¢ a Toolbar: the whole bar or some of its icons

* or any widget from any dialog in QGIS: label, button, combobox...

= o]
With h Switch to catching widgets in main application "y can click on an item in QGIS interface that you want to be hidden
and QGIS automatically unchecks the corresponding entry in the Customization dialog. You can also use the Search
box to find items by their name or label.
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Once you setup your configuration, click Apply or OK to validate your changes. This configuration becomes the
one used by default by QGIS at the next startup.

=] )
The modifications can also be saved in a .ini file using Save ToFile bytton. This is a handy way to share a

common QGIS interface among multiple users. Just click on LoadfromFile from the destination computer in
order to import the . ini file. You can also run command line tools and save various setups for different use cases
as well.

Coget: Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

* unchecking ™ Enable customization option in the Customization dialog or click the % Cheek All pygion
e pressing the Reset button in the Settings frame under Settings » Options menu, System tab
¢ launching QGIS at a command prompt with the following command line gqgis —--nocustomization

 setting to false the value of Ul » Customization » Enabled variable under Settings » Options menu,
Advanced tab (see the warning).

In most cases, you need to restart QGIS in order to have the change applied.

9.5 Keyboard shortcuts

QGIS provides default keyboard shortcuts for many features. You can find them in section /asHoe metrro.

0
Additionally, the menu option Settings » L1 Keyboard Shortcuts... allows you to change the default keyboard
shortcuts and add new ones to QGIS features.
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Keyboard Shortcuts X

Action ¥ Shortcuk =
| Mew Ctrl+M
Mew 30 Map View Ctri+alt+m

A~ Mew Annotation Layer
| Mew Blank Project

fﬁf" Mew GeoPackage Layer... Ctrl+Shift+M
£ New GPX Layer...
Mew Map View Ctri+m
E¥ New Mesh Layer...
* Mew Print Layouk... Ctrl+P
Mew Report...
%" MNew Shapefile Layer...
I Mew Spatial Bookmark... Ctrl+8

ﬂ Mew Spatialite Layer...

i Mew Temporary Scrabch Layer...

MNew Vector Layer...

W New Virtual Layer...

Mormal '

Change Set default (Mone)

Load... Save... @Help | aglnse

Puc. 9.44: Define shortcut options

Configuration is very simple. Use the search box at the top of the dialog to find a particular action, select it from
the list and click on :

¢ Change and press the new combination you want to assign as new shortcut
* Set None to clear any assigned shortcut
e or Set Default to backup the shortcut to its original and default value.

Proceed as above for any other tools you wish to customize. Once you have finished your configuration, simply
Close the dialog to have your changes applied. You can also Save the changes either as an . XML file with only
the User Shortcuts or with all Shortcuts or as an . PDF file with all Shortcuts and Load them into another QGIS
installation.

9.6 Running QGIS with advanced settings

9.6.1 Command line and environment variables

We've seen that launching QGIS is done as for any application on your OS. QGIS provides command line options for
more advanced use cases (in some cases you can use an environment variable instead of the command line option).
To get a list of the options, enter gqgis —-help on the command line, which returns:

QGIS is a user friendly Open Source Geographic Information System.
Usage: /usr/bin/qgis.bin [OPTION] [FILE]
(continues on next page)
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(IPOJIOJIKEHHE C MTPEbIAYLIEH CTPaHULIBI)

OPTION:

[-v, ——-version] display version information and exit

[-s, ——snapshot filename] emit snapshot of loaded datasets to given file

[-w, ——width width] width of snapshot to emit

[-h, ——height height] height of snapshot to emit

[-1, ——lang language] use language for interface text (changes.
—existing override)

[-p, ——project projectfile] load the given QGIS project

[-e, ——extent xmin,ymin,xmax, ymax] set initial map extent

[-n, ——nologo] hide splash screen

[-V, ——noversioncheck] don't check for new version of QGIS at startup

[-P, ——noplugins] don't restore plugins on startup

[-B, ——skipbadlayers] don't prompt for missing layers

[-C, ——nocustomization] don't apply GUI customization

[-z, ——customizationfile path] use the given ini file as GUI.
—customization

[-g, ——globalsettingsfile path] use the given ini file as Global.
—Settings (defaults)

[-a, ——authdbdirectory path] use the given directory for authentication.
—database

[-f, ——code path] run the given python file on load

[-d, ——defaultui] start by resetting user ui settings to default

[-—hide-browser] hide the browser widget

[-—dxf-export filename.dxf] emit dxf output of loaded datasets to.
—given file

[-—dxf-extent xmin,ymin,xmax,ymax] set extent to export to dxf

[-—dxf-symbology-mode none|symbollayer|feature] symbology mode for dxf..
—output

[-—dxf-scale—-denom scale] scale for dxf output

[-—dxf-encoding encoding] encoding to use for dxf output

[-—dxf-map-theme maptheme] map theme to use for dxf output

[-—take-screenshots output_path] take screen shots for the user.
—documentation

[-—screenshots-categories categories] specify the categories of..
—screenshot to be used (see QgsAppScreenShots::Categories) .

[-——profile name] load a named profile from the user's profiles.
—folder.

[-S, ——profiles-path path] path to store user profile folders. Will.
—create profiles inside a {path}\profiles folder

[-—version-migration] force the settings migration from older version if._
—found

[-—openclprogramfolder] path to the folder containing the sources.
—for OpenCL programs.

[——help] this text

[==1 treat all following arguments as FILEs

FILE:

Files specified on the command line can include rasters,
vectors, and QGIS project files (.ggs and .ggz):
1. Rasters - supported formats include GeoTiff, DEM
and others supported by GDAL
2. Vectors - supported formats include ESRI Shapefiles
and others supported by OGR and PostgreSQL layers using
the PostGIS extension

Coser: Example Using command line arguments

You can start QGIS by specifying one or more data files on the command line. For example, assuming you are in the
ggis_sample_data directory, you could start QGIS with a vector layer and a raster file set to load on startup
using the following command: ggis ./raster/landcover.img ./gml/lakes.gml
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——version

This option returns QGIS version information.

——snapshot

This option allows you to create a snapshot in PNG format from the current view. This comes in handy when you
have many projects and want to generate snapshots from your data, or when you need to create snapshots of the
same project with updated data.

Currently, it generates a PNG file with 800x600 pixels. The size can be adjusted using the ——width and
—-—height arguments. The filename can be added after ——snapshot. For example:

[qgis ——snapshot my_image.png —-width 1000 —--height 600 —--project my_project.qgs }

——width

This option returns the width of the snapshot to be emitted (used with ——snapshot).

—-height

This option returns the height of the snapshot to be emitted (used with ——snapshot).

—-lang

Based on your locale, QGIS selects the correct localization. If you would like to change your language, you can
specify a language code. For example, qgis —-lang it starts QGIS in Italian localization.

——project

Starting QGIS with an existing project file is also possible. Just add the command line option ——project followed
by your project name and QGIS will open with all layers in the given file loaded.

——extent

To start with a specific map extent use this option. You need to add the bounding box of your extent in the following
order separated by a comma:

[ffextent xmin, ymin, xmax, ymax }

This option probably makes more sense when paired with the ——project option to open a specific project at the
desired extent.

—-nologo

This option hides the splash screen when you start QGIS.
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——noversioncheck

Skip searching for a new version of QGIS at startup.

——noplugins

If you have trouble at start-up with plugins, you can avoid loading them at start-up with this option. They will still
be available from the Plugins Manager afterwards.

——nocustomization

Using this option, any existing GUI customization will not be applied at startup. This means that any hidden buttons,
menu items, toolbars, and so on, will show up on QGIS start up. This is not a permanent change. The customization
will be applied again if QGIS is launched without this option.

This option is useful for temporarily allowing access to tools that have been removed by customization.

—-skipbadlayers

Using this option, you can avoid QGIS prompting the Handle Unavailable Layers dialog at startup. The project file
is loaded, with missing layers kept as unavailable. More details on the topic at Handling broken file paths.

——customizationfile

Using this option, you can define a Ul customization file, that will be used at startup.

——globalsettingsfile

The equivalent environment variable is QGIS_GLOBAL_SETTINGS_FILE.

Using this option, you can specify the path for a Global Settings file (. ini), also known as the Default Settings.
The settings in the specified file replace the original inline default ones, but the user profiles” settings will be set on
top of those.

QGIS looks for the default global settings file in the following order and only the first found file will be used:
* path specified by the commandline parameter
¢ path defined by the environment variable

* the AppDatal.ocation folder, where persistent application data can be stored; it is managed by the user or
system administrator and is not touched by installer and does not require any additional setup like passing
commandline parameters or settings environment variable. Depending on the OS, it is:

) SHOME/ .local/share/QGIS/QGIS3/

- £7 c:\Users\<username>\%AppData%\Roaming\QOGIS\QGIS3\

- X SHOME/Library/Application Support/QGIS/QGIS3/

e the installation directory, ie. your_QGIS_package_path/resources/
ggis_global_settings.ini.

Presently, there’s no way to specify a file to write settings to; therefore, you can create a copy of an original settings
file, rename, and adapt it.

Setting the qgis_global_setting.ini file path to a network shared folder, allows a system administrator
to change global settings and defaults in several machines by only editing one file.
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——authdbdirectory

This option is similar to ——globalsettingsfile, butdefines the path to the directory where the authentication
database will be stored and loaded.

——code

This option can be used to run a given python file directly after QGIS has started.

For example, when you have a python file named 1oad_alaska.py with following content:

from ggis.utils import iface

raster_file = "/home/gisadmin/Documents/ggis_sample_data/raster/landcover.img"
layer_name = "Alaska"

iface.addRasterLayer (raster_file, layer_name)

Assuming you are in the directory where the file 1oad_alaska.py islocated, you can start QGIS, load the raster
file landcover. img and give the layer the name ,,Alaska“ using the following command:

[qgis ——code load_alaska.py

——defaultui

On load, permanently resets the user interface (UI) to the default settings. This option will restore the panels and
toolbars visibility, position, and size. Unless it’s changed again, the default UI settings will be used in the following
sessions.

Notice that this option doesn’t have any effect on GUI customization. Items hidden by GUI customization (e.g. the
status bar) will remain hidden even using the -——defaultui option. See also the ——nocustomization option.

——hide-browser

On load, hides the Browser panel from the user interface. The panel can be enabled by right-clicking a space in the
toolbars or using the View » Panels (Settings » Panels in Linux KDE).

Unless it’s enabled again, the Browser panel will remain hidden in the following sessions.

——dxf—*

These options can be used to export a QGIS project into a DXF file. Several options are available:
* —dxf-export: the DXF filename into which to export the layers;
e —dxf-extent: the extent of the final DXF file;

o —dxf-symbology-mode: several values can be used here: none (no symbology), symbollayer (Symbol
layer symbology), feature (feature symbology);

* —dxf-scale-denom: the scale denominator of the symbology;
e —dxf-encoding: the file encoding;

* —dxf-map-theme: choose a map theme from the layer tree configuration.
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——take—-screenshots

Takes screenshots for the user documentation. Can be used together with ——screenshots—-categories
to filter which categories/sections of the documentation screenshots should be created (see
QgsAppScreenShots::Categories).

—-profile

Loads QGIS using a specific profile from the user’s profile folder. This option takes precedence over user profile
startup setting.

—-profiles-path
With this option, you can choose a path to load and save the profiles (user settings). It creates profiles inside a
{path}\profiles folder, which includes settings, installed plugins, processing models and scripts, and so on.

This option allows you to, for instance, carry all your plugins and settings in a flash drive, or, for example, share the
settings between different computers using a file sharing service.

The equivalent environment variable is QGIS_CUSTOM_CONFIG_PATH.

—--—version—-migration

If settings from an older version are found (e.g., the . ggis2 folder from QGIS 2.18), this option will import them
into the default QGIS profile.

——openclprogramfolder
Using this option, you can specify an alternative path for your OpenCL programs. This is useful for developers
while testing new versions of the programs without needing to replace the existing ones.

The equivalent environment variable is QGIS_OPENCL_PROGRAM_FOLDER.

9.6.2 Deploying QGIS within an organization

If you need to deploy QGIS within an organization with a custom configuration file, first you need to
copy/paste the content of the default settings file located in your_QGIS_package_path/resources/
ggis_global_settings.ini. This file already contains some default sections identified by a block starting
with []. We recommend that you keep these defaults values and add your own sections at the bottom of the file. If
a section is duplicated in the file, QGIS will take the last one from top to bottom.

You can change allowVersionCheck=false to disable the QGIS version check.

If you do not want to display the migration window after a fresh install, you need the following section:

[migration]
fileVersion=2
settings=true

If you want to add a custom variable in the global scope:

[variables]
organisation="Your organization"
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A lot of settings can be set using the . INT file such as WMS/WMTS, PostGIS connections, proxy settings, maptips,
default values for algorithms parameters... For example, if you want to configure organization wide default values
for some algorithms it would be handy if you could configure it in the prepared ini-file for all users. If the users
then open the toolbox to execute an algorithm, the default values will be there. To set the default value e.g. for
GRID_SIZE parameter for the native:intersection algorithm, you could write the following into the .
INT file:

[Processing]
DefaultGuiParam\native%3Aintersection\GRID_SIZE=0.01

Not all settings can be prepared from QGIS GUI, but to discover the possibilities of the settings . INT file, we
suggest that you set the config you would like in QGIS Desktop and then search for it in your . INT file located in
your profile using a text editor.

Finally, you need to set the environment variable QGIS_GLOBAL_SETTINGS_FILE to the path of your
customized file.

In addition, you can also deploy files such as Python macros, color palettes, layout templates, project templates. ..
either in the QGIS system directory or in the QGIS user profile.

¢ Layout templates must be deployed in the composer_templates directory.
* Project templates must be deployed in the project_templates directory.

* Custom Python macros must be deployed in the python directory.
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A Coordinate Reference System, or CRS, is a method of associating numerical coordinates with a position on the
surface of the Earth. QGIS has support for approximately 7,000 standard CRSs, each with different use cases, pros
and cons! Choosing an appropriate reference system for your QGIS projects and data can be a complex task, but
fortunately QGIS helps guide you through this choice, and makes working with different CRSs as transparent and
accurate as possible.

10.1 O630p NoaonepXKu NpoeKunn

QGIS has support for approximately 7,000 known CRSs. These standard CRSs are based on those defined by the
European Petroleum Search Group (EPSG) and the Institut Geographique National de France (IGNF), and are
made available in QGIS through the underlying «Proj» projection library. Commonly, these standard projections
are identified through use of an authority:code combination, where the authority is an organisation name such as
«EPSG» or «IGNF», and the code is a unique number associated with a specific CRS. For instance, the common
WGS 84 latitude/longitude CRS is known by the identifier EPSG: 4326, and the web mapping standard CRS is
EPSG:3857.

Custom, user-created CRSs are stored in a user CRS database. See section /loab3osamensckue cucmemsl KOOPOUHAm
for information on managing your custom coordinate reference systems.

10.2 Layer Coordinate Reference Systems

In order to correctly project data into a specific target CRS, either your data must contain information about its
coordinate reference system or you will need to manually assign the correct CRS to the layer. For PostGIS layers,
QGIS uses the spatial reference identifier that was specified when that PostGIS layer was created. For data supported
by GDAL, QGIS relies on the presence of a recognized means of specifying the CRS. For instance, for the Shapefile
format this is a file containing an ESRI Well-Known Text (WKT) representation of the layer’s CRS. This projection
file has the same base name as the . shp file and a . prj extension. For example, alaska.shp would have a
corresponding projection file named alaska.prj.

Whenever a layer is loaded into QGIS, QGIS attempts to automatically determine the correct CRS for that layer.
In some cases this is not possible, e.g. when a layer has been provided without retaining this information. You can
configure QGIS behavior whenever it cannot automatically determine the correct CRS for a layer:

1. Open Settings » AN Options... » CRS
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Options — CRS Handling %
v CRs for Projects
*. General when a new project is created
% System ® Use CRS from first layer added

CRS and Transforms

Use adefault CRS EPSG:4326 - WGS 84 =

&

“ CRs Handling

& Coordinate TransForms w CRS for Layers
& User Defined CRS

Default CRS fFor layers EPSG:4326 - WGS 84 -
B Data Sources

@

. When a new layer is created, or when a layer is loaded that has no CRS
« Rendering

. -
Canvas & Legend Leave as an unknown CRS (take no action)

B Map Tools Prompt for CRS
W 3D Use project CRS

| i Use default layer CRS
Fonts
M Layouts ¥ Accuracy Warnings

variables only show CRS accuracy warnings for inaccuracies which exceed | Always show

& Authentication . . .
Show CRS accuracy warnings for layers in project legend
== Network

GPs

Locator

Planimetric measurements

Acceleration
IDE

% Processing
A Advanced

@Help © cancel

Puc. 10.1: The CRS tab in the QGIS Options Dialog

2. Under the CRS for layers group, set the action to do when a new layer is created, or when a layer is loaded
that has no CRS. One of:

« '@ Leave as unknown CRS (take no action): there will be no prompt to select a CRS when a layer
without CRS is loaded, defering CRS choice to a later time. Convenient when loading a lot of layers

at once. Such layers will be identifiable in the Layers panel by the ? icon next to them. They’ll also
be un-referenced, with coordinates from the layer treated as purely numerical, non-earth values, i.e. the
same behavior as all layers get when a project is set to have no CRS.

e s Prompt for CRS: it will prompt you to manually select the CRS. Selecting the correct choice is
crucial, as a wrong choice will place your layer in the wrong position on the Earth’s surface! Sometimes,
accompanying metadata will describe the correct CRS for a layer, in other cases you will need to contact
the original author of the data to determine the correct CRS to use.

e . Use project CRS

o L Use default layer CRS, as set in the Default CRS for layers combobox above.

Coget: To assign the same CRS to multiple layers that have no crs or have a wrong one in one operation:
1. Select the layers in the Layers panel

2. Press Ctr1+Shift+C. You could also right-click over one of the selected layers or go to Layer » Set CRS
of layer(s)

3. Find and select the right CRS to use

4. And press OK. You can confirm that it has been set correctly in the Source tab of the layers* properties dialog.
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Note that changing the CRS in this setting does not alter the underlying data source in any way, rather it just changes
how QGIS interprets the raw coordinates from the layer in the current QGIS project.

10.3 Project Coordinate Reference Systems

Every project in QGIS also has an associated Coordinate Reference System. The project CRS determines how data
is projected from its underlying raw coordinates to the flat map rendered within your QGIS map canvas.

QGIS supports «on the fly» CRS transformation for both raster and vector data. This means that regardless of
the underlying CRS of particular map layers in your project, they will always be automatically transformed into
the common CRS defined for your project. Behind the scenes, QGIS transparently reprojects all layers contained
within your project into the project’s CRS, so that they will all be rendered in the correct position with respect to
each other!

It is important to make an appropriate choice of CRS for your QGIS projects. Choosing an inappropriate CRS can
cause your maps to look distorted, and poorly reflect the real-world relative sizes and positions of features. Usually,
while working in smaller geographic areas, there will be a number of standard CRSs used within a particular country
or administrative area. It's important to research which CRSs are appropriate or standard choices for the area you
are mapping, and ensure that your QGIS project follows these standards.

By default, QGIS starts each new project using a global default projection. This default CRS is EPSG: 4326 (also
known as «WGS 84»), and it is a global latitude/longitude based reference system. This default CRS can be changed
via the CRS for New Projects setting in the CRS tab under Settings » RN Options... (see Puc. 10.1). There is an option
to automatically set the project’s CRS to match the CRS of the first layer loaded into a new project, or alternatively
you can select a different default CRS to use for all newly created projects. This choice will be saved for use in
subsequent QGIS sessions.

The project CRS can also be set through the CRS tab of the Project » Properties... dialog. It will also be shown in
the lower-right of the QGIS status bar.

() Project Properties — CRS X
” ] Project Coordinate Reference System {(CRS)

\.. Mo CRS {or unknown/nan-Earth projection)

%, General

Filter

' Metadata

Recently Used Coordinate Reference Systems

View Setings Coordinate Reference System Authority ID
WGES 84 EPSG:4325
WGES 84 Pseudo-Mercator EPSG:3857 [x]
e WGES 84/ UTM zone 335 EPSG:32733
ﬁ;. Transformations
NAD27 { Alaska Albers EPSG:2954 <]
"“"/ Styles US Mational Atlas Equal Area EPSG:2163
i Data Sources Predefined Coordinate Reference Systems Hide deprecated CRSs
B Relations Coordinate Reference System Authority ID ~
B WGS 72 EP5G:4985
Variables WGS 72BE EP5Gi4324
WGS 72BE EPS5G:4987
@ . WGS 84 EPSG:4326 =
o acros
- q 3
QGIS Server WGS 84 -

Properties

* Geographic (uses latitude and
. _ longitude for coordinates) | . -
Terrain * Dynamic (relies on a datum which is - O P -

¢ Sensors -
| Ok | Cancel Apply Help

Puc. 10.2: Project Properties Dialog
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Available options are:

No CRS (or unknown/non-Earth projection): Checking this setting will disable ALL projection handling
within the QGIS project, causing all layers and map coordinates to be treated as simple 2D Cartesian
coordinates, with no relation to positions on the Earth’s surface. It can be used to guess a layer CRS (based on
its raw coordinates or when using QGIS for non earth uses like role-playing game maps, building mapping or
microscopic stuff. In this case:

— No reprojection is done while rendering the layers: features are just drawn using their raw coordinates.
— The ellipsoid is locked out and forced to None/Planimetric.

— The distance and area units, and the coordinate display are locked out and forced to «unknown units»;
all measurements are done in unknown map units, and no conversion is possible.

or an existing coordinate reference system that can be geographic, projected or user-defined. A preview of
the CRS extent on earth is displayed to help you select the appropriate one. Layers added to the project are
translated on-the-fly to this CRS in order to overlay them regardless of their original CRS. Use of units and
ellipsoid setting are available and make sense and you can perform calculations accordingly.

Whenever you select a new CRS for your QGIS project, the measurement units will automatically be changed in
the General tab of the Project properties dialog (Project » Properties...) to match the selected CRS. For instance,
some CRSs define their coordinates in feet instead of meters, so setting your QGIS project to one of these CRSs
will also set your project to measure using feet by default.

Cosert: Setting the project CRS from a layer

You can assign a CRS to the project using a layer CRS:

1. In the Layers panel, right-click on the layer you want to pick the CRS

2. Select Set project CRS from Layer.

The project’s CRS is redefined using the layer's CRS. Map canvas extent, coordinates display are updated
accordingly and all the layers in the project are on-the-fly translated to the new project CRS.
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10.4 Coordinate Reference System Selector

L QGIS3 X

Predefined CRS =

Filter

Recently Used Coordinate Reference Systems

Coordinate Reference System Authority ID o
WGES 84 EP5G:4326
WGS 84 | Pseudo-Mercator EPSG:3857
WGS 84/ UTM zone 335 EPSG: 32733
MADZ27 [ Alaska Albers EPSG: 2964
US Mational Atlas Equal Area EPSG: 2163 -
Predefined Coordinate Reference Systems Hide deprecated CRSs
Coordinate Reference System Authority ID 5
Voirol 1879 (Paris) EPSG:4321
WG5S 66 EPSG:4750
WGES 66 EPSG:4891 —
] e et b
WaS 84 -

Properties

* Geographic (uses latitude and
longitude for coordinates)

& Pismmrmie feclinn am o dod e kick

0K Cancel Help

Puc. 10.3: CRS Selector

This dialog helps you assign a Coordinate Reference System to a project or a layer, provided a set of projection
databases. Items in the dialog are:

« Filter: If you know the EPSG code, the identifier, or the name for a Coordinate Reference System, you can
use the search feature to find it. Enter the EPSG code, the identifier or the name.

* Recently used coordinate reference systems: If you have certain CRSs that you frequently use in your

everyday GIS work, these will be displayed in this list. Click on one of these items to select the associated
CRS.

* Coordinate reference systems of the world: This is a list of all CRSs supported by QGIS, including
Geographic, Projected and Custom coordinate reference systems. To define a CRS, select it from the list
by expanding the appropriate node and selecting the CRS. The active CRS is preselected.

* PROJ text: This is the CRS string used by the PROJ projection engine. This text is read-only and provided
for informational purposes.

If you want to remove a recently used CRS from the list that can be done in several ways:

o Press ' Removefromrecendyused CRS hytton on the right side.

e Press Del after selecting CRS that you want to remove.

» Right-click on used CRS and choose Remove selected CRS from recently used CRS to remove selected
%
CRS or Clear all recently used CRS to remove all used CRS.

The CRS selector also shows a rough preview of the geographic area for which a selected CRS is valid for use.
Many CRSs are designed only for use in small geographic areas, and you should not use these outside of the area
they were designed for. The preview map shades an approximate area of use whenever a CRS is selected from the
list. In addition, this preview map also shows an indicator of the current main canvas map extent.
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10.5 lNonb3oBaTenbckne CUCTEMbl KoopauHaT

If QGIS does not provide the coordinate reference system you need, you can define a custom CRS. To define a

i)
CRS, select 3 Custom CRS... from the Settings menu. Custom CRSs are stored in your QGIS user database. In
addition to your custom CRSs, this database also contains your spatial bookmarks and other custom data.

Defining a custom CRS in QGIS requires a good understanding of the PROJ projection library. To begin, refer to
«Cartographic Projection Procedures for the UNIX Environment - A User’s Manual» by Gerald I. Evenden, U.S.
Geological Survey Open-File Report 90-284, 1990 (available at https://pubs.usgs.gov/of/1990/0f90-284/0fr90-284.
pdf).

This manual describes the use of proj and related command line utilities. The cartographic parameters used with
proj are described in the user manual and are the same as those used by QGIS.

B ananoroBom okHe OnpedeneHue noab308amenbckoll CUcmembl KOopouHam TpedyeTcst BCEro JBa rnapameTpa JUls
onpeneNneHust COOCTBEHHOM IPOEKLMH:

1. A descriptive name
2. The cartographic parameters in PROJ or WKT format

To create a new CRS:

1. Click the I:II-I:I-I:I Addnew CRS bytton

2. Enter a descriptive name

3. Select the format: it can be Proj String or WKT
4. Add the CRS Parameters.

IIpumeuanne: Prefer storing the CRS definition in WKT format

Although both Proj String and WKT formats are supported, it’s highly recommended to store projection
definitions in the WKT format. Therefore, if the available definition is in the proj format, select that format,
enter the parameters and then switch to WKT format. QGIS will convert the definition to the WKT format
that you can later save.

5. Click Validate to test whether the CRS definition is an acceptable projection definition.
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Options — User Defined CRS x

You can define your own custom Coordinate Reference System (CRS) here. The definition must

conform to a WKT or Proj string format for specifying a CRS.
«. General
Name Parameters

o
i system WGS 85 UTM 29N PROJCRS["unknown".BASEGEOGCRS["unk..._ e

CRS and Transforms
€ CRS Handling
i Coordinate Transforms
% User Defined CRS
i@ Data Sources
@ GDAL
« Rendering

B Canvas & Legend

Name WG5S 85 UTM 29N

E® Map Tools
w Definition

W 3D
M colors Format WKT (Recommended) -
B Digitizing PROJCRS["unknown”, . Validate
@ Layouts BASEGEOGCRS["unknown",

. DATUM["World Geodetic System 1984",

BUSDES ELLIPSOID["WGS 84",6378137,298.257223563,

& Authentication LENGTHUNIT["metre",1]],
= Network Parameters ID["EPSG"6326]
- PRIMEM["Greenwich™,0,
GPS ANGLEUNIT["degree",0.0174532925199433]],

= cpsBabel ID["EPSG"8901]]]

CONWERSION["UTM zone 29N",

Locator METHOD["Transverse Mercator™ -

Acceleration
IDE v Test

E Code Editor Use the kext boxes below to test the CRS definition you are creating. Enter a coordinate

& Python Console where both the lat/long and the transformed result are known (for example by reading off a

- map). Then press the calculate button to see if the CRS definition you are creating is accurate.
g . . L
* Processing Geographic / WGS84 Destination CRS

& Advanced Latitude I:
Longitude

Calculate

©Help Ocancel QoK

Puc. 10.4: Custom CRS Dialog

You can test your CRS parameters to see if they give sane results. To do this, enter known WGS 84 latitude and
longitude values in North and East fields, respectively. Click on Calculate, and compare the results with the known
values in your coordinate reference system.

10.5.1 Integrate an NTv2-transformation in QGIS

To integrate an NTv2 transformation file in QGIS you need one more step:

1. Place the NTv2 file (.gsb) in the CRS/Proj folder that QGIS uses (e.g. C: \OSGeo4W64\share\pro7 for
windows users)

2. Add nadgrids (+nadgrids=nameofthefile.gsb) tothe Proj definition in the Parameters field of the
Custom Coordinate Reference System Definition (Settings » Custom Projections...).

Puc. 10.5: Setting an NTv2 transformation
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10.6 Datum Transformations

In QGIS, ,on-the-fly* CRS transformation is enabled by default, meaning that whenever you use layers with
different coordinate systems QGIS transparently reprojects them to the project CRS. For some CRS, there are
a number of possible transforms available to reproject to the project’s CRS!

By default, QGIS will attempt to use the most accurate transformation available. However, in some cases this may not
be possible, e.g. whenever additional support files are required to use a transformation. Whenever a more accurate
transformation is available, but is not currently usable, QGIS will show an informative warning message advising
you of the more accurate transformation and how to enable it on your system. Usually, this requires download of
an external package of transformation support files, and extracting these to the proj folder under your QGIS user
profile folder.

If desired, QGIS can also prompt you whenever multiple possible transformations can be made between two CRSs,
and allow you to make an informed selection of which is the most appropriate transformation to use for your data.

This customization is done in the Settings » N Options » Transformations tab menu under the Default datum
transformations group:

* using oA Ask for datum transformation if several are available: when more than one appropriate datum
transformation exist for a source/destination CRS combination, a dialog will automatically be opened
prompting users to choose which of these datum transformations to use for the project. If the Make default
checkbox is ticked when selecting a transformation from this dialog, then the choice is remembered and
automatically applied to any newly created QGIS projects.

* or defining a list of appropriate datum transformations to use as defaults when loading a layer to a project or

reprojecting a layer.

Use the Ifl-l:l-l:| button to open the Select Datum Transformations dialog. Then:

T Select CRS

1. Choose the Source CRS of the layer, using the drop-down menu or the widget.

2. Provide the Destination CRS in the same way.

3. A list of available transformations from source to destination will be shown in the table. Clicking
a row shows details on the settings applied and the corresponding accuracy and area of use of the
transformation.
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Select Datum Transformations x

Multiple operations are possible for converting coordinates between these two Coordinate Reference
Systems. Please select the appropriate conversion operation, given the desired area of use, origins of your data, and
any other constraints which may alter the "fit for purpose" for particular transformation operations.

Source CRS EPSG:2964 - NAD27 / Alaska Albers v ||

Destination CRS | EPSG:4326 - WGS 84 - | | &
Transformation Accuracy (meters) Area of Use

1 5 USA - Alaska, USA - Alaska including EEZ

2|Inverse of Alaska Albers + NAD27 to WGS 84 (7) 12 USA - Alaska, USA - Alaska mainland

3

4|Inverse of Alaska Albers + NAD27 to WGS 84 (3) 20 USA - Alaska, Canada - NAD27

5/Inverse of Alaska Albers + NAD27 to WGS 84 (13) 8 USA - Alaska, Canada - NWT:; Nunavut; Saskatchewan

6/Inverse of Alaska Albers + NAD27 to WGS 84 (14) 10 USA - Alaska, Canada - Yukon

7|Inverse of Alaska Albers + NAD27 to WGS 84 (10) 13 USA - Alaska, Canada - Alberta and British Columbia

8|Inverse of Alaska Albers + NAD27 to WGS 84 (21) 15 USA - Alaska, USA - Alaska - Aleutian Islands east of 180°E

9/Inverse of Alaska Albers + NAD27 to WGS 84 (22) 18 USA - Alaska, USA - Alaska - Aleutian Islands west of 180°W

Inverse of Alaska Albers + NAD27 to WGS 84 (85)

Scope: Accuracy at 67% confidence level is 0.15m onshore, 5m nearshore and undetermined
farther offshore.

Area of use: USA - Alaska, USA - Alaska including EEZ
Identifiers: INVERSE(EPSG):15020, DERIVED_FROM(EPSG):15864

+proj=pipeline +step +proj=unitconvert +xy in=us-ft +xy out=m +step +inv
+proj=aea +lat 0=50 +lon 0=-154 +lat 1=55 +lat 2=65 +x 0=0 +y 0=0
+ellps=clrk66 +step +proj=hgridshift +grids=alaska +step +proj=unitconvert
+Xy_in=rad +xy out=deg

Show superseded transforms V| Allow Fallback transforms if preferred operation fails

@Help Ocancel Qok

Puc. 10.6: Selecting a preferred default datum transformation

In some cases a transformation may not be available for use on your system. In this case, the
transformation will still be shown (greyed) in this list but can not be picked until you install the
required package of transformation support. Usually, a button is provided to download and install the
corresponding grid, which is then stored under the proj folder in the active user profile directory.

4. Find your preferred transformation and select it

5. Set whether you i Allow fallback transforms if preferred operation fails
6. Kimknaure Ha kHONKY OK.

A row is added to the table under Default Datum Transformations with information about the Source
CRS, the Destination CRS, the Operation applied for the transformation and whether Allow fallback
Transforms is enabled.

From now, QGIS automatically uses the selected datum transformations for further transformation between

these two CRSs until you remove it (E') from the list or change the entry ( & ) in the list.
Datum transformations set in the Settings » RN Options » Transformations tab will be inherited by all new QGIS
projects created on the system. Additionally, a particular project may have its own specific set of transformations
specified via the CRS tab of the Project properties dialog (Project » Properties...). These settings apply to the current
project only.
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Visualizing Maps

Creating maps is one of the «business ends» of QGIS. Map views are canvases to visualize spatial layers loaded in
the project, with the various rendering settings applied to them. They can be of 2D or 3D type or plotted along a
profile line, show different scale or extent, or display a different set of the loaded layers thanks to map themes.

11.1 2D Map View

The 2D map view (also called Map canvas) is the central place where maps are displayed. QGIS opens by default
with a single map view (called main map), showing layers in 2D, and tightly bound to the Layers panel. That
window reflects the rendering (symbology, labeling, visibilities...) you applied to the loaded layers.

Project Edit View Layer Settings Plugins Vector Raster _Databi1

documentation3.qgs - QGIS
leb Mesh Processing Help

DEBRRH O#2LRPPR. i\,-'ﬂzzl;@e Q¢ -0-5-0,F
/ “q= wgaes A
Browser Processing Toelbox
LIEERETS 2 DR DS
& v - Favorites [ Q search...
» [¥ Project Home R tly d
V; » [ spatial Bookmarks gc:ff;g,:::;
» [6) Home @ Database
/ =y 3 @ File tools
ﬁ @ GeoPackage @ Graphics
2 / SpatiaLite @ Interpolation
@ postais @ Layer tools
: MSSQL < @ Network analysis
— (1 Raster analysis

« @ e T &R L

[ regions
» v/ I¥ landcover
» [ & sR_som_alaska_nad

)

@ Raster terrain analysis
(@ Raster tools

@ Vector analysis 3
@ Vector creation

Q@ Vector general

@ Vector geometry
@ vector overlay

@ Vector selection

@ vector table

# climb

# GDAL

& GRASS

*: Models

& scripts

Layer Styling ‘ Processing Toolbox

Q Type to locate (Ctrl+k)

‘:\ Rotation |00°

|2] I/ Render @ psc:2sea @

5 ' Coordinate | 176.2207,67.2258 | % S(ile‘l:‘!n?:ﬂlﬁﬁ ‘-‘ @ Magnifier | 100%

Puc. 11.1: QGIS GUI
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11.1.1 Exploring the map view

When you add a layer (see e.g. Opening Data), QGIS automatically looks for its CRS. If a different CRS is set by
default for the project (see Project Coordinate Reference Systems) then the layer extent is «on-the-fly» translated to
that CRS, and the map view is zoomed to that extent if you start with a blank QGIS project. If there are already
layers in the project, no map canvas resize is performed, so only features falling within the current map canvas

extent will be visible.

Click on the map view and you should be able to interact with it, panning or zooming to different areas of the map.
Dedicated tools are provided in the Navigation Toolbar and in the View menu, with handful shortcuts from the
keyboard or the mouse buttons.

Tab6muna 11.1: Map canvas navigation tools

WHCTpyMeHT

Vcnonb3oBaHue

@ Pan Map

[
J—'.'—/ Zoom In

P

&',f',' Zoom Out

A
¢‘0¢‘ Pan Map to Selection

Ty
()‘ /' Zoom To Selection

L}- .,:' Zoom To Layer(s)

1
&', }ﬂ Zoom Full
P

Jl'ij Zoom Last

e

fl"lj Zoom Next

i)

Zoom to Native Resolution

Mouse wheel

* Single left click: the map is centered on the clicked point, at the same scale
e Hold down the left mouse button and drag the map canvas.

» Single left click: the map is centered on the clicked point, while the scale gets
doubled

* Drag a rectangle on the map canvas with the left mouse button to zoom in to an
area.

« Hold the ALt key to switch to the #— 200mOut (0]

« Single left click: the map is centered on the clicked point, while the scale gets
halved
 Drag a rectangle on the map canvas with the left mouse button to zoom out from
an area. )
)

« Hold the A1t key to switch to the & ZeomIn go0].

Pan the map to the selected features of all the selected layers in the Layers panel.

Zoom to the selected features of all the selected layers in the Layers panel.
Also available in the layer contextual menu

Zoom to the extent of all the selected layers in the Layers panel.
Also available in the layer contextual menu

Zoom to the extent of all the layers in the project or to the project full extent.
Zoom the map to the previous extent in history.
Zoom the map to the next extent in history.

Zoom the map to a level where one pixel of the active raster layer covers one screen
pixel.
Also available in the layer contextual menu

e Pan map: Hold and drag the mouse wheel.

e Zoom: Roll the mouse wheel to zoom in or zoom out. With Ctr1 key pressed
while rolling the mouse wheel results in a finer zoom.

* Press the back or forward button to browse the map canvas zoom history.

continues on next page
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Tabnuua 11.1 - npooonxeHue ¢ Npeablaywel CTpaHnLbl

UHcTpyMeHT Wcnonb3oBaHue
Keyboard

* Pan map: Hold down the Space key and move the mouse. Press the arrow keys
to pan up, down, left and right.

e Zoom in: Press PgUp or Ctrl++

e Zoom out: Press PgDown or Ctr1+-—

e Zoom to area: When certain map tools are active (Identify, Measure...), hold down
Shift and drag a rectangle on the map to zoom to that area. Not compatible with
active selection or edit tools.

Right-click over the map and you should be able to Copy coordinates of the clicked point in the map CRS, in
WGS84 or in a custom CRS. The copied information can then be pasted in an expression, a script, text editor or
spreadsheet...

11.1.2 Controlling map rendering
By default, QGIS renders all visible layers whenever the map canvas is refreshed. The events that trigger a refresh
of the map canvas include:
« changing the visibility of a layer
* modifying symbology of a visible layer
* adding a layer
* panning or zooming
¢ resizing the QGIS window
QGIS allows you to control the rendering process in a number of ways.
e at the global level
* per layer, using e.g. the scale dependent rendering
* or with dedicated tools in the GUIL

To stop the map drawing, press the Esc key. This will halt the refresh of the map canvas and leave the map partially
drawn. It may however take a bit of time after pressing Esc for the map drawing to halt.

To suspend rendering, click the g Render checkbox in the bottom-right corner of the status bar. When oA Render
is unchecked, QGIS does not redraw the canvas in response to any of the usual triggers mentioned earlier. Examples
of when you might want to suspend rendering include:

¢ adding many layers and symbolizing them prior to drawing
* adding one or more large layers and setting scale dependency before drawing
* adding one or more large layers and zooming to a specific view before drawing

* any combination of the above

Bxmogyenne Cl)ﬂa)KKa Ig Ompucoeica AKTUBHUPYET OTPUCOBKY U HEMEJICHHO OOHOBJISIET COACPIKUMOC KAPTHI.
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11.1.3 Time-based control on the map canvas
QGIS can handle temporal control on loaded layers, i.e. modify the map canvas rendering based on a time variation.
To achieve this, you need:

1. Layers that have dynamic temporal properties set. QGIS supports temporal control for different data
providers, with custom settings. It’s mainly about setting the time range in which the layer would display:

* raster layers: controls whether to display or not the layer.

o WMTS layers: controls whether the data should be rendered based on a static time range or following a
dynamic temporal range

e vector layers: features are filtered based on time values associated to their attributes
e mesh layers: displays dynamically the active dataset groups values
When dynamic temporal options are enabled for a layer, an @ icon is displayed next to the layer in the

Layers panel to remind you that the layer is temporally controlled. Click the icon to update the temporal
settings.

2. Enable the temporal navigation of the map canvas using the Temporal controller panel. The panel is activated:

* using the @ Temporal controller panel joon Jocated in the Map Navigation toolbar

e or from the View » Panels » Temporal controller panel menu
The temporal controller panel

The Temporal controller panel has the following modes:

Temporal Controller B
X | (® current frame: 2021-11-02 18:00:00 < £ < 2021-12-02 18:00:00

o L TS BN | I i Loop

-

Animation range  2020-11-02 18:00:00 || to |2021-11-03 18:00:00 |+| &2 ~ Step| 1.000 % || months -3
Puc. 11.2: Temporal Controller Panel in navigation mode

. Turn off temporal navigation. 4]] the temporal settings are disabled and visible layers are rendered as usual

P
. '»SJ' Fixed range temporal navigation. 5 time range is set and only layers (or features) whose temporal range overlaps
with this range are displayed on the map.

P

. '»E} Animated temporal navigation. 5 time range is set, split into steps, and only layers (or features) whose temporal
range overlaps with each frame are displayed on the map

. Settings o1 general control of the animation

— Frames rate: number of steps that are shown per second

— ! Cumulative range: all animation frames will have the same start date-time but different end dates and
times. This is useful if you wish to accumulate data in your temporal visualization instead of showing a
‘moving time window’ across your data.
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Animating a temporal navigation

An animation is based on a varying set of visible layers at particular times within a time range. To create a temporal
animation:

1.

2.

Fay
Toggle on the () Animated temporal navigation - displaying the animation player widget

~

Enter the Time range to consider. Using the M= button, this can be defined as:
e Set to full range of all the time enabled layers
e Set to preset project range as defined in the project properties

e Set to single layer’s range taken from a time-enabled layer

. Fill in the time Step to split the time range. Different units are supported, from seconds to centuries. A

source timestamps option is also available as step: when selected, this causes the temporal navigation
to step between all available time ranges from layers in the project. It’s useful when a project contains layers
with non-contiguous available times, such as a WMS-T service which provides images that are available at
irregular dates. This option will allow you to only step between time ranges where the next available image is
shown.

Click the > button to preview the animation. QGIS will generate scenes using the layers rendering at the
set times. Layers display depends on whether they overlap any individual time frame.

The animation can also be previewed by moving the time slider. Checking the Loop checkbox will

>

repeatedly run the animation while clicking
is available.

stops a running animation. A full set of video player buttons

Horizontal scrolling using the mouse wheel (where supported) with the cursor on the map canvas will also
allow you to navigate, or “scrub”, the temporal navigation slider backwards and forwards.

=] A
Click the Export animation ty1tton if you want to generate a series of images representing the scene. They can
be later combined in a video editor software:
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Export Map Animation X

Template AirportConstruction_####.png

Qutput directory 'dev/github/QGIS-Documentation/qgis-projects/user_manual
Map Settings

v Extent (current: user defined)
North | 7809746.2379

West -7282764.4251 East |5063131.2528
South |1363824.5915

Calculate from Layer - Map Canvas Extent Draw on Canvas

Output width | 1400 px =
-

Output height | 730 px ] T

v| Draw active decorations: none

Temporal Settings
Range 1950-01-01 00:00:00 |=| ko |2020-12-3123:00:00 |7 &2
step (Frame length) | 5.000 ~| years -

@ Help Ocancel Llsave

Puc. 11.3: Exporting map canvas animation scenes to images

» The filename Template: the #### are replaced with frame sequence number
* The Output directory
¢ Under Map settings, you can:
— redefine the spatial extent to use
— control the Resolution of the image (Output width and Output height)
— Draw active decorations: whether active decorations should be kept in the output
e Under Temporal settings, you can redefine:
— the time Range for the animation

— the Step (frame length) in the unit of your choice

11.1.4 Bookmarking extents on the map

Spatial Bookmarks allow you to «bookmark» a geographic location and return to it later. By default, bookmarks are
saved in the user’s profile (as User Bookmarks), meaning that they are available from any project the user opens.
They can also be saved for a single project (named Project Bookmarks) and stored within the project file, which can
be helpful if the project is to be shared with other users.
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Co3paHue 3aKknagku

s co3manus 3aKJIagKu:

1. Zoom and pan to the area of interest.

0
2. Select the menu option View » W New Spatial Bookmark..., press Ctr1+B or right-click the Spatial
Bookmarks entry in the Browser panel and select New Spatial Bookmark. The Bookmark Editor dialog opens.

(! Bookmark Editor e

Name University of Cape Town|
Group -
w Extent (current: map view)
Morth |6246505,5908
West |809449.5311 East |83083%.7307

South |6227355.0908

Calculate from Layer - | | LayoutMap ~ Bookmark ~
Map Canvas Extent Draw on Canvas
Rotation | 130.0 % =
CRS EPS5G:32733 - WG5S 84 / UTM zone 335 v ||
Savedin | Project Bookmarks A
Save Cancel Help

Puc. 11.4: The Bookmark Editor Dialog

Enter a descriptive name for the bookmark

Enter or select a group name in which to store related bookmarks

Select the extent of the area you wish to save, using the extent selector widget
Change the map Rotation

Indicate the CRS to use for the extent

® N AW

Select whether the bookmark will be Saved in User Bookmarks or Project Bookmarks (by default, this drop-
down list is set to User Bookmarks)

9. Press Save to add the bookmark to the list

HOMHI/ITC, YTO MOXHO UMETh MHOXECTBO 3aKJIaJOK C OAMHAKOBBIMU HA3BAHUAMMU.
Pa6oTta c 3aknapgkamu

To use and manage bookmarks, you can either use the Spatial Bookmarks panel or Browser.

0
Select View » Show Spatial Bookmark Manager or press Ctr1+7 to open the Spatial Bookmarks Manager

]
panel. Select View » Show Bookmarks or Ctr1+Shift+B to show the Spatial Bookmarks entry in the
Browser panel.

You can perform the following tasks:
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Ta6muma 11.2: Managing bookmark actions

Task Spatial Bookmark Manager Browser
Zoom to a Double-click on it, or select the bookmark  Double-click on it, drag and drop it to the
U‘\I o AT
Bookmark L 2 Zoom 1o bookmark ~Map canvas, or right-click the bookmark
and select Zoom to Bookmark.

button.

Delete a Select the bookmark and click the [ Right-click the bookmark and select Delete

bookmark Delete bookmark button. Confirm your Spatial Bookmark. Confirm your choice.
choice.

Export Click the C%) Import/Export Bookmarks  Select one or more folders (user or project)

l))((l)\(/)llimarks to button and select mbm Export. All the or subfolders (groups), then right-click and
bookmarks (user or project) are saved inan  select m=a Export Spatial Bookmarks.... The
xml file. selected bookmark subset is saved.

Import Click the c%) Import/Export Bookmarks Right-click the Spatial Bookmarks entry

bookmarks from
XML

Edit bookmark

button and select m=a Import. All
bookmarks in the XML file are imported
as user bookmarks.

You can change a bookmark by changing
the values in the table. You can edit the
name, the group, the extent and if it is
stored in the project or not.

or one of its folders (user or project) or
subfolders (groups) to determine where

!

to import the bookmarks, then select m=a
Import Spatial Bookmarks. If performed
on the Spatial Bookmarks entry, the
bookmarks are added to User Bookmarks.
Right-click the desired bookmark and
select Edit Spatial Bookmark.... The
Bookmark Editor will open, allowing you
to redefine every aspect of the bookmark
as if you were creating it for the first time.
You can also drag and drop the bookmark
between folders (user and project) and
subfolders (groups).

You can manage bookmark actions by right-click on the desired bookmark in the Spatial Bookmarks Manager. You
can also zoom to bookmarks by typing the bookmark name in the locator.

11.1.5 Decorating the map

Decorations include Grid, Title Label, Copyright Label, Image, North Arrow, Scale Bar and Layout Extents. They
are used to ,,decorate” the map by adding cartographic elements.
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Cetka

E Grid allows you to add a coordinate grid and coordinate annotations to the map canvas.

1. Select menu option View » Decorations » Grid... to open the dialog.

Grid Properties (]

v Enable Grid

Grid type Line -
Linesymbol (- ======s=2ssccnccnnccnncnnns -
X 5000
Interval
¥ 5000
X 0
Offset
Y 0

Update Interval / Offset from

Canvas Extents Active Raster Layer
v Draw Annotation

Annotation direction | Horizontal and Vertical -

Annotation font Font M

L

Distance to map frame | 1,00

Coordinate precision |0
@Help </ Apply | % cancel </ OK

Puc. 11.5: The Grid Dialog

2. Tick g Enable grid and set grid definitions according to the layers loaded in the map canvas:
» The Grid type: it can be Line or Marker
e The associated Line symbol or marker symbol used to represent the grid marks
» The Interval X and Interval Y between the grid marks, in map units

* An Offset X and Offset Y distance of the grid marks from the bottom left corner of the map canvas, in
map units

» The interval and offset parameters can be set based on the:
— Canvas Extents: generates a grid with an interval that is approximatively 1/5 of the canvas width

— Active Raster Layer resolution

3. Tick Cif Draw annotations to display the coordinates of the grid marks and set:
» The Annotation direction, ie how the labels would be placed relative to their grid line. It can be:
— Horizontal or Vertical for all the labels
— Horizontal and Vertical, ie each label is parallel to the grid mark it refers to

— Boundary direction, ie each label follows the canvas boundary, and is perpendicular to the grid mark
it refers to

* The Annotation font (text formatting, buffer, shadow...) using the font selector widget
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» The Distance to map frame, margin between annotations and map canvas limits. Convenient when
exporting the map canvas eg to an image format or PDF, and avoid annotations to be on the «paper»
limits.

* The Coordinate precision

4. Click Apply to verify that it looks as expected or OK if you’re satisfied.
Title Label

-rﬂ Title Label allows you to decorate your map with a Title.
To add a Title Label decoration:

1. Select menu option View » Decorations w Title Label... to open the dialog.

Title Label Decoration -

v Enable Title Label

Title label text

Airports in Alaska

Insert an Expression...

Font Font -
Background bar color | (R [~

Placement Top Center -
Margin from edge Horizontal |0 =) vertical | 2 < | Millimeters ~

@Help </ Apply || % cancel </ OK

Puc. 11.6: The Title Decoration Dialog

2. Make sure ® Enable Title Label is checked

3. Enter the title text you want to place on the map. You can make it dynamic using the Insert or Edit an
Expression... button.

4. Choose the Font for the label using the font selector widget with full access to QGIS zext formatting options.
Quickly set the font color and opacity by clicking the black arrow to the right of the font combo box.

5. Select the color to apply to the title’s Background bar color.

6. Choose the Placement of the label in the canvas: options are Top left, Top Center (default), Top Right, Bottom
left, Bottom Center and Bottom Right.

7. Refine the placement of the item by setting a horizontal and/or vertical Margin from Edge. These values can
be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

8. Click Apply to verify that it looks as expected or OK if you’re satisfied.
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Copyright Label

& Copyright Label can be used to decorate your map with a Copyright label.
To add this decoration:
1. Select menu option View » Decorations » Copyright Label... to open the dialog.

Copyright Label Decoration [

v Enable Copyright Label

Copyright label text
© Organisation 2018

Insert an Expression...

Font Font -

Placement Bottom right -
Margin from edge Horizontal |0 ~| Vertical 0 < Millimeter ~
@Help «/Apply | % Cancel «/ OK

Puc. 11.7: The Copyright Decoration Dialog

2. Make sure o Enable Copyright Label is checked

3. Enter the copyright text you want to place on the map. You can make it dynamic using the Insert or Edit an
Expression... button.

4. Choose the Font for the label using the font selector widget with full access to QGIS fext formatting options.
Quickly set the font color and opacity by clicking the black arrow to the right of the font combo box.

5. Choose the Placement of the label in the canvas: options are Top left, Top Center, Top Right, Bottom left,
Bottom Center, and Bottom Right (default for Copyright decoration)

6. Refine the placement of the item by setting a horizontal and/or vertical Margin from Edge. These values can
be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

7. Click Apply to verify that it looks as expected or OK if you’re satisfied.
Image Decoration

“*0 Image allows you to add an image (logo, legend, ..) on the map canvas.
To add an image:

1. Select menu option View » Decorations » Image... to open the dialog.
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=
-

v Enable Image
Image path
Colar
’. Size
Placement

Margin from edge

@Help

Image Decoration + X
fimages/icons/qgis-icon-minimal-black.svg &

Al | N ~| sroke | -
16.00 mm € |
Top Left -
Horizontal | 20 & |5 Vertical | 20 = | Pixels -

« Apply ® Cancel o OK

Puc. 11.8: The Image Decoration Dialog

2. Make sure g Enable Image is checked

3. Select a bitmap (e.g. png or jpg) or SVG image using the ... B"*® button

4. If you have chosen a parameter enabled SVG then you can also set a Fill or Stroke (outline) color. For bitmap
images, the color settings are disabled.

5. Set a Size of the image in mm. The width of selected image is used to resize it to given Size.

6. Choose where you want to place the image on the map canvas with the Placement combo box. The default

position is Top Left.

7. Set the Horizontal and Vertical Margin from (Canvas) Edge. These values can be set in Millimeters, Pixels
or as a Percentage of the width or height of the map canvas.

8. Click Apply to verify that it looks as expected and OK if you're satisfied.

Ykasartenb «ceBep-tor»

A] North Arrow allows you to add a north arrow on the map canvas.

To add a north arrow:

1. Select menu option View » Decorations » North Arrow... to open the dialog.
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North Arrow Decoration £

v| Enable north arrow

Color Fill B - Outline -

Size 16.00 mm =

I Custom SVG
-*- Angle v| Automatic
Placement Horizontal | 0 < | Vertical |0 S| |Millimeter -

Margin from edge Bottom left -

Help Apply Cancel oK

Puc. 11.9: The North Arrow Dialog

Make sure Cf Enable north arrow is checked
Optionally change the color and size, or choose a custom SVG
Optionally change the angle or choose Automatic to let QGIS determine the direction

Optionally choose the placement from the Placement combo box

A

Optionally refine the placement of the arrow by setting a horizontal and/or vertical Margin from (Canvas)
Edge. These values can be in Millimeters or Pixels or set as a Percentage of the width or height of the map
canvas.

7. Click Apply to verify that it looks as expected and OK if you're satisfied.
MacwtabHas nuHeika

“& Scale Bar adds a simple scale bar to the map canvas. You can control the style and placement, as well as the
labelling of the bar. The scale bar respects the active project’s distance unit as defined in Project properties » General
» Units for distance measurement.

Il moGaBieHUsT MAaCIITAOHOM JTMHEWKU:

1. Select menu option View » Decorations w Scale Bar... to open the dialog
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Scale Bar Decoration (%

v| Enable Scale Bar

Scale bar style Tick Down -
Color of bar Fill B - Outline -
Font of bar Font v
Size of bar 30 -

¥ Automatically snap to round number on resize

Placement Top left -
Margin from edge Horizontal |0 % Wertical |0 = | Millimeter -
©@Help « Apply | % cancel

Puc. 11.10: The Scale Bar Dialog

2. Make sure o Enable scale bar is checked

3. Choose a style from the Scale bar style 1% combo box

N -

4. Select the Color of bar by choosing a fill color (default: black) and an outline color
(default: white). The scale bar fill and outline can be made opaque by clicking on the down arrow to the right
of the color input.

5. Select the font for the scale bar from the Font of bar 1% combo box

6. Set the Size of bar in the active unit
7. Optionally check o Automatically snap to round number on resize to display easy-to-read values

8. Choose the placement from the Placement 1% combo box

9. You can refine the placement of the item by setting a horizontal and/or vertical Margin from (Canvas) Edge.
These values can be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

10. Click Apply to verify that it looks as expected or OK if you're satisfied.
Layout Extents

|B Layout Extents adds the extents of map item(s) in print layout(s) to the canvas. When enabled, the extents of all
map items within all print layouts are shown using a lightly dotted border labeled with the name of the print layout
and map item. You can control the style and labeling of the displayed layout extents. This decoration is useful when
you are tweaking the positioning of map elements such as labels, and need to know the actual visible region of print
layouts.
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Sights: Map;

Sights: Map.1

" Tivoli: Map 1

Puc. 11.11: Example of layout extents displayed in a QGIS project with two print layouts. The print layout named
»Sights“ contains two map items, while the other print layout contains one map item.

To add layout extent(s):

1. Select View » Decorations » Layout Extents to open the dialog

Layout Extents Properties .

v Show layout extents

symbol . w
v Label extents Fant v
Help Apply Cancel OK

Puc. 11.12: The Layout Extents Dialog

2. Make sure . Show layout extents is checked.
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3. Optionally change the symbol and labeling of the extents.
4. Click Apply to verify that it looks as expected and OK if you're satisfied.

Cogset: Decorations Settings

When you save a QGIS project file, any changes you have made to Grid, North Arrow, Scale Bar, Copyright and
Layout Extents will be saved in the project and restored the next time you load the project.

11.1.6 UHCTpYyMeHTbl aHHOTaUuun

Annotations are another type of elements added onto the map canvas to provide additional information that can not
be depicted by the rendered layers. Unlike labels that rely on attribute values stored in vector layers, annotations are
independent details, stored within the project file itself.

Two families of annotations are available in QGIS:

» Feature annotations: they are actual georeferenced features of text, marker, line or polygon type stored
within a special layer type called «annotation layer». They are tied to a particular geographic location, meaning
that moving your map, changing the scale or changing projection won’t cause your annotations to jump around
the map. Rather, they’ll be locked in place to the location you’ve drawn them.

« Balloon annotations: these are individuals annotations of text, form or image type placed inside a bubble.
They can be associated to any layer for their visibility, are drawn on top of the map canvas. The size is
dependent from the map canvas scale, and its position can be anchored.

Coget: Layout the map with annotations
You can print or export annotations with your map to various formats using:
* map canvas export tools available in the Project menu

e print layout,in which case you need to check Draw map canvas items in the corresponding map item properties

The Annotations Toolbar provides a set of tools to create and interact with both families of annotations.

148 Mnaea 11. Visualizing Maps



QGIS Desktop 3.34 User Guide

Taomuna 11.3: The Annotations Toolbar actions

Wuctpyment
A5

Main Annotation Layer Properties

g
:-L\QH Modify Annotations
Iz

Create Polygon Annotation

New Annotation Layer

{_ o Create Line Annotation

|

Create Marker Annotation

uTD

Create Text Annotation at Point
]
]

Create Text Annotation along Line
1| Text Annotation
L .
HTML Annotation
SVG Annotation

Form Annotation

HUcnons3oBanue Scope
Create a new layer to store annotations Feature
Control settings of the Main Annotation Layer annotations

Select, move, resize and modify symbology properties of
annotations

Create an annotation as a polygon feature

Create an annotation as a polyline feature

Create an annotation as a point feature

Create an annotation as a text label

Create an annotation as a curved text along a linestring

Select and create a text formatted annotation Balloon

. . o, annotations
Select and create annotation with an HTML file’s content
Select and create annotation showing an SVG file

Select and create annotation showing attributes of a vector layer in
a custom form file

Feature Annotations

Feature annotations are stored in annotation layers. Unlike conventional layers, an annotation layer is available
only in the current project and can contain features of different types (text, marker, line, polygon). The layer has
no attributes and no symbology associated, but instead each feature can be symbolized on an item-by-item basis,
through Layer Styling panel.

Two types of annotation layer are available in QGIS:

* A common Annotation Layer: you can create one using the

=ad
A= New Annotation Layer

tool. It is listed in the Layers

panel, allowing you to control its features* visibility, move it to show above or below particular layers in your
map, like any common layer. Double-click the layer and you can access its properties.

e The Main Annotation Layer: By default, this is where annotations are stored when no annotation layer is
available in the project or is selected at creation time. This layer is always drawn on the very top of your
map and you won’t see it listed in the Layers panel alongside the other layers in your project, meaning that its
features are always visible. The Main Annotation Layer Properties entry on the Annotations toolbar helps you
open its properties dialog.
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Layer Properties

The properties dialog of an annotation layer provides the following tabs:

* Information: a read-only dialog representing an interesting place to quickly grab summarized information and
metadata on the current layer. This may include the layer extent, count of items per annotation type and total
count, CRS details, ...

* Source: defines general settings for the annotation layer. You can:

— Set a Layer name that will be used to identify the layer in the project (in the Layers Panel, with
expressions, ...)

— Display the layer’s Assigned Coordinate Reference System (CRS): you can change the layer’s CRS,

iy
%
=

selecting a recently used one in the drop-down list or clicking on =3 St RS bytton (see Coordinate
Reference System Selector). Use this process only if the CRS applied to the layer is a wrong one or if
none was applied.

¢ Rendering:
— You can set the Maximum (inclusive) and Minimum (exclusive) scale, defining a range of scale in which

features will be visible. Out of this range, they are hidden. The LER Set to current canvas scale by tton helps you
use the current map canvas scale as boundary of the range visibility. See Visibility Scale Selector for more
information.

— Opacity: You can make the underlying layer in the map canvas visible with this tool. Use the slider to
adapt the visibility of your vector layer to your needs. You can also make a precise definition of the
percentage of visibility in the menu beside the slider.

— Blending mode at the Layer level: You can achieve special rendering effects with these tools that you
may previously only know from graphics programs. The pixels of your overlaying and underlying layers
are mixed through the settings described in Blending Modes.

— Apply paint effects on all the layer features with the Draw Effects button.

Some of these options are accessible from the feature annotation Symbology properties.

Interacting with features

The Feature annotations have dedicated tools for creation depending on their type:

° I:é Create Polygon Annotation

° { +] Create Line Annotation

. & Create Marker Annotation

. "-‘TU Create Text Annotation at Point
225 Create Text A ion along Li

o =gy Create Text Annotation along Line

All the usual QGIS shortcuts for creating features apply when creating annotation items. A line or polygon annotation
is drawn by left-clicking once for each vertex, with a final right mouse click to complete the shape. Snapping can
be enabled while you draw, you can use the Advanced Digitizing Tools to precisely place vertices, and even switch
the drawing tools to the streaming mode for completely free-form shapes.

Unlike common layers, an annotation layer does not need to be active before you select its features. Simply grab
a

the Bl Modify Annotations 5] and you will be able to interact with any feature annotation:

¢ Selection: left-click on the annotation. By default, annotations are rendered in the order of creation, meaning
that recent annotations will be placed on top of older. You may need to play with the Z-index property of
features in order to select ones they would sit above.
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Moving: Left click on a selected annotation item to start moving it. A right-click or pressing Esc key cancels
the move, while a second left click will confirm the move. The displacement can also be controlled pressing
the cursor keys:

— Shift+key for big movement
— Alt+keyfor 1 px movement

Geometry modification: for line or polygon annotations, left-click on a vertex of the geometry, move and
click again. Double-click a segment to add a new vertex.

Delete: Pressing the Del or Backspace key while an annotation is selected will delete that annotation

Change feature symbology

Feature symbology

A selected annotation will display its Symbology properties in the Layer styling panel. You can:

Modify the appearance using full capabilities of:
— the symbol properties for polygon, polyline and marker annotations

— the text format properties for text-based annotations. A text area allows you to construct the string to
display using QGIS expression functions. It is also possible to set the Alignment for text annotation at
point (left, center or right of the text point).

For text annotation at point, also configure whether it should Ignore map rotation or Rotate with map. In both
cases, a custom Angle can be set for the feature orientation.

For text annotation along a line, configure an Offset from line in the unit of your choice

Configure a ' Reference scale: indicates the map scale at which symbol or text sizes which uses paper-based
units (such as millimeters or points) relate to. The sizes will be scaled accordingly whenever the map is viewed
at a different scale. For instance, a line feature wide of 2mm at 1:2000 Reference scale will be rendered using
4mm when the map is viewed at 1:1000.

Set a Z-index: a feature with a higher index is placed on top of features with lower index. A convenient setting
for both feature display and selection.

Modify some of the Layer rendering settings

Balloon annotations

You can add balloon annotations through Edit » Add Annotation » menu or from the Annotations Toolbar:

T |
Text Annotation £ cystom formatted text

<

> .
HTML Annotation ¢, place the content of an html file

SVG Annottion t, add an SVG symbol

Form Annotation. sefy] to display attributes of a vector layer in a customized ui file (see Puc. 11.13). This
is similar to the custom attribute forms, but displayed in an annotation item. Also see this video https://www.
youtube.com/watch?v=0pDBuSbQ02o0&feature=youtu.be&t=2m25s from Tim Sutton for more information.
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Annotation Text X
| [ubuntu e e [ 1 oo
v| Fixed map position
Linked layer | v

Map marker L v

Frame style | EE———— |~

w Contents Margins

Top  [EWmm @ )
Left | 0.00mm 2]
Right | 0.00 mm ]
Bottom | 0.00 mm |3|

V| Live update
| @Help | | Delete H ok ]

Puc. 11.13: Examples of balloon annotations

To add a balloon annotation, select the corresponding tool and click on the map canvas. An empty balloon is added.
Double-click on it and a dialog opens with various options. This dialog is almost the same for all the annotation

types:

At the top, a file selector to fill with the path to an html, svg or ui file depending on the type of annotation.
For text annotation, you can enter your message in a text box and set its rendering with the normal font tools.

o Fixed map position: when unchecked, the balloon placement is based on a screen position (instead of the
map), meaning that it’s always shown regardless the map canvas extent.

Linked layer: associates the annotation with a map layer, making it visible only when that layer is visible.

Map marker: using QGIS symbols, sets the symbol to display at the balloon anchor position (shown only when
Fixed map position is checked).

Frame style: sets the frame background color, transparency, stroke color or width of the balloon using QGIS
symbols.

Contents margins: sets interior margins of the annotation frame.

o Live update allows you to live preview your changes.
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Annotation Text 0

Ubuntu * |11 |% B I N -

QGIS rocks]

¥ Fixed map position

Linked layer -
Map marker L -
Frame style [ | [

v Contents Margins

Top 0,00 mm :
Left 0,00 mm -
Right | 0,00 mm -
Bottom | 0,00 mm -
@Help « Apply Delete | ¥ Cancel «/ OK

Puc. 11.14: A ballon annotation text dialog

When a balloon annotation tool is active, you can also:
* Select an annotation
* Resize an annotation
* Move an annotation by map position (by dragging the map marker) or by moving only the balloon.

* Delete an annotation: select it and either press the Del or Backspace button, or double-click it and press
the Delete button in the properties dialog.

 Right-click and in the contextual menu:
_B Copy coordinate of the annotation’s map marker in various CRS
- ¢ Edit properties of the annotation. Same as double-clicking the annotation.

e
— [ Delete the annotation
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11.1.7 UamepeHus

NMpumeHeHne
QGIS provides four means of measuring geometries:

—
* interactive measurement tools ™™

Field Calculator

* measuring in the
¢ derived measurements in the Identifying Features tool
* the vector analysis tool: Vector » Geometry Tools » Export/Add Geometry Columns

Measuring works within projected coordinate systems (e.g., UTM) and unprojected data. The first three measuring
tools behave equally to global project settings:

¢ Unlike most other GIS, the default measurement metric is ellipsoidal, using the ellipsoid defined in Project
» Properties... » General. This is true both when geographic and projected coordinate systems are defined
for the project.

* If you want to calculate the projected/planimetric area or distance using cartesian maths, the measurement
ellipsoid has to be set to «None/Planimetric» (Project » Properties... » General). However, with a geographic
(ie unprojected) CRS defined for the data and project, area and distance measurement will be ellipsoidal.

However, neither the identify tool nor the field calculator will transform your data to the project CRS before
measuring. If you want to achieve this, you have to use the vector analysis tool: Vector » Geometry Tools » Add
Geometry Attributes.... Here, measurement is planimetric, unless you choose the ellipsoidal measurement.

Measure length, areas, bearings and angles interactively

| )
Click the ™ jcon in the Attribute toolbar to begin measurements. The down arrow near the icon switches between
—_ L 2 -4
™ length, ™M™ area, T/ bearing or ™™ angle. The default unit used in the dialog is the one set in Project »

Properties... » General menu.

For the Measure Line and the Measure Area the measurements can be done in '®' Cartesian or ' ® Ellipsoidal
measure.

IIpumeuanne: Configuring the measure tool

While measuring length or area, clicking the Configuration button at the bottom of the widget opens the Settings »
Options » Map Tools menu, where you can select the rubberband color, the precision of the measurements and the
unit behavior. You can also choose your preferred measurement or angle units, but keep in mind that those values
are overridden in the current project by the selection made in the Project » Properties... » General menu, and by
the selection made in the measurement widget.

All measuring modules use the snapping settings from the digitizing module (see section Setting the snapping tolerance
and search radius). So, if you want to measure exactly along a line feature, or around a polygon feature, first set its
layer snapping tolerance. Now, when using the measuring tools, each mouse click (within the tolerance setting) will
snap to that layer.

The [T Measure Line measures distances between given points. The tool then allows you to click points on the map.
Each segment length, as well as the total, shows up in the measure window. In the measure window, you will see
coordinates for all your points and distances. Keep in mind that the first row will contain only coordinates, as it
represents your starting point. Now it is possible to copy all your line measurements at once to the clipboard using
the Copy button. Clicking the Configuration button you will access to Measure Tool Copy Settings where you can set
up copy options. To stop measuring, click the right mouse button.
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Note that you can use the drop-down list near the total to change the measurement units interactively while working
with the measure tool. This unit is retained for the widget until a new project is created or another project is opened.

The Info section in the dialog explains how calculations are made according to the CRS settings available.

Measure n
X y Segments [meters]
815.714,009 6.237.042,126
815.692,501 6.235.084,910 1.955,714
813.993,379 6.234.267,610 1.883,920
811.455,450 6.235.966,733 3.051,735
Total 6.891,369 m | | meters -
Cartesian ®) Elipsoidal
w Info

The calculations are based on:
* Project ellipsoidal calculation is selected.

*The coordinates are transformed to the chosen ellipsoid (WG5S 84 (EPSG: 7030)),
and the distance is calculated in meters,

| MNew | Configuration Copy Close Help

Puc. 11.15: Measure Distance

g Measure Area: A reag can also be measured. In the measure window, the accumulated area size appears. Right-click
to stop drawing. The Info section is also available as well as the ability to switch between different area units.

Total 64,662 m? |  square mekers -
® Cartesian Ellipsoidal
¥ Info

The calculations are based on:

* Cartesian calculation selected, so area is calculated using
Cartesian calculations.

@Help MNew Configuration # Close

Puc. 11.16: Measure Area

T/ Measure Bearing: 'y oy can also measure bearings. The cursor becomes cross-shaped. Click to draw the first point
of the bearing, then move the cursor to draw the second point. The measurement is displayed in a pop-up dialog.

Bearing x

42 486506°E

| agluse |

Puc. 11.17: Measure Bearing

11.1. 2D Map View 155



QGIS Desktop 3.34 User Guide

-4 . .
i Measure Angle: 'y oy can also measure angles. The cursor becomes cross-shaped. Click to draw the first segment of
the angle you wish to measure, then move the cursor to draw the desired angle. The measurement is displayed in a

[s3814° |

|  Close

pop-up dialog.

Puc. 11.18: Measure Angle

11.1.8 Setting additional map views

It is also possible to open additional map views whose content could diverge from the Layers panel current state.

To add a new map view, go to View » |—|?.J New Map View. A new floating widget, mimicking the main map view’s
rendering, is added to QGIS. You can add as many map views as you need. They can be kept floating, placed side

by side or stacked on top of each other.

Alaska - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh Progessing Help
= v es @ O D D Q) ~ (€ = - B i -
DEBRREH U APLAPPL L QLR @ H-a-GEE# T =T
REGEViAWMEB / =4 e GPgRGgH A
Layers © Layer Styling ®
BT &H-RAL ORI SLOPE alaska -
~ Iv/ @ Boundaries Group & | = single symbol
v regions
M alaska 1 INORTHWEST ARCTIC &
~ v/ @l water Group simple fill
rivers
v majrivers
NOME
lakes FAIRBANKS NORTH.STAR
W swamp S
~ VI @ groupt
R YUKON-KOYUKUK SOUTHEAST FAIRBANKS, . G
; DENALI Unit | Millimeters
& airports
o storagep WADE HAMPTON| Opacity 1000% -
Color M
MATANUSKA-SUSITNA /27D 7. CORDOVA
T ANCHORAGES
Gedl. SKAGWAY.YAKUTAT-ANG 14 /RiES
&4 A . Favorites « &
SR PUUNEAY,
ORI Pens AL ENA1 REHINSULA e c
- 7
L - /
- ALELTIANSWEST. - iniec 7
Airports @ only Alaska view =[]
B S e radient ray3fil hashed black
HPpP = HOD Y isma o !
a 4 YUKON-KOYUKUK
N
WADE HAMPTON NIAK MATANUSKA-SUS
¢ AN
PARREVOHN LRRS hashedblack\  hashedblackX  outline blue
o g™ &
e goce,
° °*
L] &
besod
DILLINGHAM =
LAKE AND PENINSULA oubinered__outline xnattem.
! =
B ¢ Save Symbol... | Advanced
€316 MOUNTAIN AFS
i gy b Layer Rendering
Layers | Browser Map 1 | Airports oo v Live update | «/ Apply
Coordinate | -123.1091,66.4951 | ¥ Scale 1:10000000 |~ | @ Magnifier|100% </ Rotation |0.0° <|lv/Render @ EPsc:2964 @

Puc. 11.19: Multiple map views with different settings

At the top of an additional map canvas, there’s a toolbar with the following capabilities:

B )
° ;} Zoom Full’ g / Zoom to Selection and ;  Zoom to Layer(s) to navigate within the view
o @, SetViewTheme v select the map theme to display in the map view. If set to (none), the view will follow
the Layers panel changes.

o %, Viewsettings 1 configure the map view:

-\@ Synchronize view center with main map: syncs the center of the map views without changing the scale.
This allows you to have an overview style or magnified map which follows the main canvas center.
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— . Synchronize view fo selection: same as zoom to selection

Scale

Rotation

Magnification

Synchronize scale with the main map scale. A Scale factor can then be applied, allowing you to have
a view which is e.g. always 2x the scale of the main canvas.

i Show annotations

A Show cursor position

Show main canvas extent

A Show labels: allows to hide labels regardless they are set in the displayed layers“ properties
Change map CRS...

Rename view...

11.1.9 Exporting the map view

Maps you make can be layout and exported to various formats using the advanced capabilities of the print layout or
report. It’s also possible to directly export the current rendering, without a layout. This quick «screenshot» of the
map view has some convenient features.

To export the map canvas with the current rendering:
1. Go to Project » Import/Export

2. Depending on your output format, select either
= Export Map to Image...

e or °'L' Export Map to PDF...

The two tools provide you with a common set of options. In the dialog that opens:
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Save Map as Image [~

w Extent (current: user defined)
North |3382891.8955
West -455697.9058 East 494822.9275

South |2642440.5067

Calculate from Layer ~ Map Canvas Extent Draw on Canvas
Scale 1:1000000 - | B
Resolution 96 dpi -
Output width | 1095 px =
-
Output height | 853 px =] i

v Draw active decorations: north arrow, scale bar
v/ Draw annotations

v Append georeference information (embedded or via world File)
@Help Copy to Clipboard # Ccancel Zlsave

Puc. 11.20: The Save Map as Image dialog

. Choose the Extent to export: it can be the current view extent (the default), the extent of a layer or a custom

extent drawn over the map canvas. Coordinates of the selected area are displayed and manually editable.

Enter the Scale of the map or select it from the predefined scales: changing the scale will resize the extent to
export (from the center).

Set the Resolution of the output

Control the Output width and Output height in pixels of the image: based by default on the current resolution
and extent, they can be customized and will resize the map extent (from the center). The size ratio can be
locked, which may be particularly convenient when drawing the extent on the canvas.

E Draw active decorations: in use decorations (scale bar, title, grid, north arrow...) are exported with the
map

o Draw annotations to export any annotation

. i Append georeference information (embedded or via world file): depending on the output format, a world

file of the same name (with extension PNGW for PNG images, JPGW for JPG, ...) is saved in the same folder
as your image. The PDF format embeds the information in the PDF file.

When exporting to PDF, more options are available in the Save map as PDF... dialog:
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Save Map as PDF .

v Extent (current: map view)
North |9307279.3573
West -2897581.0567 East |4322720.1924

South |3682697.6536

Calculate from Layer ~ Map Canvas Extent Draw on Canvas
Scale 1:7596153 - | B
Resolution 96 dpi -
Output width | 1095 px =
-
Output height | 853 px =] i

v Draw active decorations: none
v/ Draw annotations
v Append georeference information (embedded or via world File)

¥| Export RDF metadata (title, author, etc.)

v Advanced Settings

Rasterize map
| simplify geometries to reduce output file size

Text export | Always Export Text as Paths (Recommended) -

@Help *® Cancel Usave
Puc. 11.21: The Save Map as PDF dialog

. & Export RDF metadata of the document such as the title, author, date, description...

e ! Create Geospatial PDF (GeoPDF): Generate a georeferenced PDF file. You can:
— Choose the GeoPDF Format

- Include vector feature information in the GeoPDF file: will include all the geometry and attribute
information from features visible within the map in the output GeoPDF file.

IIpumeuanue: A GeoPDF file can also be used as a data source. For more on GeoPDF support in
QQGIS, see https://morth-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

* Rasterize map

. & Simplify geometries to reduce output file size: Geometries will be simplified while exporting the
map by removing vertices that are not discernibly different at the export resolution (e.g. if the export
resolution is 300 dpi, vertices that are less than 1/600 inch apart will be removed). This can
reduce the size and complexity of the export file (very large files can fail to load in other applications).

* Set the Text export: controls whether text labels are exported as proper text objects (Always export texts
as text objects) or as paths only (Always export texts as paths). If they are exported as text objects then
they can be edited in external applications (e.g. Inkscape) as normal text. BUT the side effect is that
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the rendering quality is decreased, AND there are issues with rendering when certain text settings like
buffers are in place. That’s why exporting as paths is recommended.

9. Click Save to select file location, name and format.

When exporting to image, it’s also possible to Copy to clipboard the expected result of the above settings and
paste the map in another application such as LibreOffice, GIMP...

11.2 3D Map View

3D visualization support is offered through the 3D map view. You can create, manage and open 3D map views via
View » 3D Map Views » menu:

1. By clicking on ‘Ei New 3D Map View you can create a new 3D map view. A floating and dockable QGIS
panel will appear (see The 3D Map View dialog). It has the same extent and view as the 2D main map canvas
and provides a set of navigation tools to turn the view into 3D.

2. By clicking on Manage 3D Map Views you get in the 3D Map Views Manager. Here you get the ability to
open, duplicate, remove and rename 3D map views.

3. If you created one or more 3D map views, you see them listed in 3D Map Views. You can turn them on and
off by clicking on. They will be saved by saving the project, even if they are turned off.

3D Map 1 [=]ES]

onO@=Fne v

N "—

Keyframe |Ss

Interpolatlnn | Othuad - |

|L| i D Loop

Puc. 11.22: The 3D Map View dialog

The following tools are provided at the top of the 3D map view panel:

. @ Camera Control: mgves the view, keeping the same angle and direction of the camera
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U
o P ZoomFull: regizeq the view to the whole layers® extent, or the reference extent if set

AN e
o | Toggle On-Screen Notification. shqws/hides the navigation widget (that is meant to ease controlling of the map
view)

. QX Identify: returns information on the clicked point of the terrain or the clicked 3D feature(s) — More details
at Identifying Features

| ] .
o [ Measurement Line: meaqures the horizontal distance between points

. b Animations: shows/hides the animation player widget

o B saveastmage.... exports the current view to an image file format

. @ Export 3D Scene: exports the current view as a 3D scene (. ob7 file), allowing post-processing in applications
like Blender... The terrain and vector features are exported as 3D objects. The export settings, overriding the
layers properties or map view configuration, include:

— Scene name and destination Folder

Terrain resolution

Terrain texture resolution

Model scale

_ & Smooth edges
= Export normals
_ & Export textures
o &, SetView Theme: Allows you to select the set of layers to display in the map view from predefined map themes.

e The “* OPtons menu provides shortcuts to:

— Add visual effects to the 3D rendering, such as showing shadows, eye dome lighting or ambient occlusion

Synchronize the views (2D map view follows 3D camera and/or 3D camera follows 2D Map view)

Show visible camera area in 2D map view

— "% Configure the 31y map view sertings.

. Dock 3D Map View: qwitch from docked widget to top level window

11.2.1 Scene Configuration

The 3D map view opens with some default settings you can customize. To do so, expand the &, Options meny at the
top of the 3D canvas panel and press the “* Configure button to open the 3D configuration window.

In the 3D Configuration window there are various options to fine-tune the 3D scene:
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General

3D Configuration

v Extent (current: map view)

£7] Terrain

Lights
’ Shadow West |67731,9797 East |90227,5999
& Camera & Skybox
& Advanced

Morth |84197,1418

South 64694 8347
Calculate from | Layer ~||Layout Map - || Bookmark -
Map Canvas Extent Draw on Canvas

Show in 2D map view

i Aide | v Ok |Jgppliquer @ Annuler

Puc. 11.23: The 3D Map General Configuration dialog

»
Under the #% General tab, you can:

» Limit the 3D scene’s contents to a 2D map extent, using the spatial extent selector: terrain and features
are clipped at the specified extent and only the parts falling within the extent are loaded in the scene.
Elevation range of the terrain, mesh and pointcloud layers is also taken into account so that the camera is not
positioned below the scene’s contents, particularly when using the terrain’s vertical scale setting to exaggerate
the elevation differences.

The set extent is also used as reference extent when pressing the ;: Zoom full hyytton in 3D map view.

* Press o Show in 2D map view to display in the main map canvas a rubberband corresponding to the current
extent of the 3D scene.
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Terrain

3D Configuration

A General v| Terrain
@ rerrain [N VO —— .
T yp ( yer)
@ shadow Elevation =" dtm -
= Camera & Skybox "
_'.-' 2 Vertical scale 1,00 -
&y Advanced
Tile resolution 16 px =
skirt height 10,0 map units -
Offset 0,00 =

Terrain Shading

i aide Ok « Appliquer | | ® Annuler

Puc. 11.24: The 3D Map Terrain Configuration dialog

e Terrain: Before diving into the details, it is worth noting that the terrain in a 3D view is represented by a
hierarchy of terrain tiles and as the camera moves closer to the terrain, existing tiles that do not have sufficient
details are replaced by smaller tiles with more details. Each tile has mesh geometry derived from the elevation
raster layer and texture from 2D map layers.

— The elevation terrain T'ype can be:
« a Flat terrain
» aloaded DEM (Raster Layer)

+ an Online service, loading elevation tiles produced by Mapzen tools — more details at https://registry.
opendata.aws/terrain-tiles/

+ a loaded Mesh dataset

— Elevation: Raster or mesh layer to be used for generation of the terrain. The raster layer must contain a
band that represents elevation. For a mesh layer, the Z values of the vertices are used.

— Vertical scale: Scale factor for vertical axis. Increasing the scale will exaggerate the height of the
landforms.

— Tile resolution: How many samples from the terrain raster layer to use for each tile. A value of 16px
means that the geometry of each tile will consist of 16x16 elevation samples. Higher numbers create
more detailed terrain tiles at the expense of increased rendering complexity.

— Skirt height: Sometimes it is possible to see small cracks between tiles of the terrain. Raising this value
will add vertical walls («skirts») around terrain tiles to hide the cracks.

— Offset: moves the terrain up or down, e.g. to adjust its elevation with respect to the ground level of other
objects in the scene.

This can be useful when there is a discrepancy between the height of the terrain and the height of layers
in your scene (e.g. point clouds which use a relative vertical height only). In this case adjusting the terrain
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elevation manually to coincide with the elevation of objects in your scene can improve the navigation
experience.

* When a mesh layer is used as terrain, you can configure the Triangles settings (wireframe display, smooth
triangles, level of detail) and the Rendering colors settings (as a uniform color or color ramp based). More
details in the Mesh layer 3D properties section.

.U Terrain shading: Allows you to choose how the terrain should be rendered:
— Shading disabled - terrain color is determined only from map texture

— Shading enabled - terrain color is determined using Phong’s shading model, taking into account map
texture, the terrain normal vector, scene light(s) and the terrain material’s Ambient and Specular colors
and Shininess

Lights

From the Lights tab, press the I:II-:ILI:I menu to add

* up to eight Point lights: emits light in all directions, like a sphere of light filling an area. Objects closer to the
light will be brighter, and objects further away will be darker. A point light has a set position (X, Y and Z), a
Color, an Intensity and an Attenuation

e up to four Directional lights: mimics the lighting that you would get from a giant flash light very far away
from your objects, always centered and that never dies off (e.g. the sun). It emits parallel light rays in a single
direction but the light reaches out into infinity. A directional light can be rotated given an Azimuth, have an
Altitude, a Color and an Intensity.

3D Configuration

A General Lights
£7] Terrain
® ghs , Pointlight 1 =
@ shadow - Point light 2 =
i Camera & Skybox b Directional light 1
"% Advanced ) o
Light Direction
W '-_I_- _-" ri
.'_‘I;”/ \;;'_'.-
Azimuth | 130,76° |3 —| |— Altitude | 65,29°
o F O
oA
’TTT
X -0.32 Y -0.91 z -0.27
Color =
Intensity | 1,00 -
i Aide « Ok + Appliquer | | @ Annuler

Puc. 11.25: The 3D Map Lights Configuration dialog
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Shadow

Check ' Show shadows to display shadows within your scene, given:
* a Directional light

* a Shadow rendering maximum distance: to avoid rendering shadow of too distant objects, particularly when
the camera looks up along the horizon

e a Shadow bias: to avoid self-shadowing effects that could make some areas darker than others, due to
differences between map sizes. The lower the better

* a Shadow map resolution: to make shadows look sharper. It may result in less performance if the resolution
parameter is too high.

Camera & Skybox

In this tab, you can control different parameters like camera, 3D axis, navigation synchronization and skybox.

3D Configuration

A General Camera
£7] Terrain . - et

Lights Projection type Perspective Projection =
@ shadow Field of View 450 =

D camera & Skybox . .
MNavigation mode Terrain Based -

& Advanced
Movement speed 5,00 a |,

v| Show 3D Axis
Axis type Coordinate Reference System -
Horizontal position | Right

Vertical position Top -

Navigation Synchronization

2D map view follows 3D camera
V| 3D camera follows 2D map view

Show visible camera area in 2D map view

V| Show Skybox

Skybox type Panoramic Texture v
Panoramic texture file |£9241f40611e462aa13366442e77f0chb5(1)JPG & || ... |~
i Aide « Ok + Appliquer | | ® Annuler

Puc. 11.26: The 3D Map Camera Configuration dialog

e The Camera parameter group overrides some default camera settings made in the Settings » Options » 3D
dialog.

« Check | Show 3D Axis to enable 3D axis tool. This parameter group allows to set the axis type and its
position.

— With the Coordinate Reference System type an orthogonal axis will be represented.
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— With the Cube type, a 3D cube will be represented. The cube faces can be used to change the camera
view: for example, click on the north face to set the camera to see from the north.

Coget: Right-click the 3D axis to quickly set its position and type, and the camera view.

Puc. 11.27: The 3D Axis context menu

e The Navigation Synchronization parameter group adds options to synchronize 2D view with 3D camera

position or 3D camera position with 2D view or bi directional synchronization. The last option displays the
extent visible from the 3D camera over the 2D map view.

¢ Check "' Show skybox to enable skybox rendering in the scene. The skybox type can be:

— Panoramic texture, with a single file providing sight on 360°
— Distinct faces, with a texture file for each of the six sides of a box containing the scene

Texture image files of the skybox can be files on the disk, remote URLs or embedded in the project (imore
details).

Advanced

Map tile resolution: Width and height of the 2D map images used as textures for the terrain tiles. 256px means
that each tile will be rendered into an image of 256x256 pixels. Higher numbers create more detailed terrain
tiles at the expense of increased rendering complexity.

Max. screen error: Determines the threshold for swapping terrain tiles with more detailed ones (and vice versa)
- i.e. how soon the 3D view will use higher quality tiles. Lower numbers mean more details in the scene at the
expense of increased rendering complexity.

Max. ground error: The resolution of the terrain tiles at which dividing tiles into more detailed ones will stop
(splitting them would not introduce any extra detail anyway). This value limits the depth of the hierarchy of
tiles: lower values make the hierarchy deep, increasing rendering complexity.

Zoom levels: Shows the number of zoom levels (depends on the map tile resolution and max. ground error).
Show labels: Toggles map labels on/off

Show map tile info: Include border and tile numbers for the terrain tiles (useful for troubleshooting terrain
issues)

Show bounding boxes: Show 3D bounding boxes of the terrain tiles (useful for troubleshooting terrain
issues)

Show camera’s view center
Show camera’s rotation center

Show light sources: shows a sphere at light source origins, allowing easier repositioning and placement of
light sources relative to the scene contents

Show frames per second (FPS)

Show debug overlay: visual overlay which displays some useful debugging and profiling information. This
allows in particular to quickly see the frame graph and the scene graph.
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« ! Show Eye Dome Lighting (EDL): a post processing effect which enhances depth perception. Each pixel’s
depth (distance off the camera) is compared to its neighboring pixels* depth and gets highlighted according to
that depth difference, making the edges stand out. Affects the whole scene and can be combined with Screen
Space Ambient Occlusion. Following parameters can be controlled:

— Lighting strength: increases the contrast, allowing for better depth perception

— Lighting distance: represents the distance of the used pixels off the center pixel and has the effect of
making edges thicker.

e Add screen-space ) Ambient Occlusion (SSAO): a post processing effect which also enhances depth
perception by applying a darker shading to areas which are less exposed to ambient lighting. Affects the
whole scene and can be combined with Eye dome Lighting. Following parameters can be controlled:

— Radius: how far we will reach to calculate ambient occlusion

— Intensity: how strong the effect should be (higher values make things darker)

— Occlusion threshold: how many neighboring points need to be occluded for the effect to appear (lower
values than 50% will make the output darker, but possibly providing greater range of occlusion)

Puc. 11.28: Rendering Point clouds in 3D map using Eye Dome Lighting (EDL) and/or Screen-Space Ambient

Occlusion (SSAO)
From top, left to right: No effect — SSAO only — EDL only — SSAO and EDL

.U Debug Shadow Map: renders the scene as a red-black image from the point of view of the light used for
shadows (for troubleshooting). The widget is set with a proportional Size to the 3D map view’s, and docked
in a Corner.

.U Debug Depth Map: renders the scene’s depth map as an image with nearer pixels being darker (for
troubleshooting). The widget is set with a proportional Size to the 3D map view’s, and docked in a Corner.
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11.2.2 Navigation options

To explore the map view in 3D:

Tilt the terrain (rotating it around a horizontal axis that goes through the center of the window)

L. -
Press the = Tiltup gpd W& Tiltdown 444]g

Press Shift and use the up/down keys

Drag the mouse forward/backward with the middle mouse button pressed

Press Shift and drag the mouse forward/backward with the left mouse button pressed

Rotate the terrain (around a vertical axis that goes through the center of the window)

Turn the compass of the navigation widget to the watching direction

Press Shift and use the left/right keys

Drag the mouse right/left with the middle mouse button pressed

Press Shift and drag the mouse right/left with the left mouse button pressed

Change the camera position (and the view center), moving it around in a horizontal plan

— Drag the mouse with the left mouse button pressed, and the {Ij Camera control {14100 enabled

— Press the directional arrows of the navigation widget

— Use the up/down/left/right keys to move the camera forward, backward, right and left, respectively
Change the camera altitude: press the Page Up/Page Down keys
Change the camera orientation (the camera is kept at its position but the view center point moves)

— Press Ctrl and use the arrow keys to turn the camera up, down, left and right

— Press Ctrl and drag the mouse with the left mouse button pressed

Zoom in and out

— Press the corresponding A zomn g S Zoom 0wt (o015 of the navigation widget
— Scroll the mouse wheel (keep Ct r1 pressed results in finer zooms)

— Drag the mouse with the right mouse button pressed to zoom in (drag down) and out (drag up)

5y
To reset the camera view, click the &## Zeom Full hytton on the top of the 3D canvas panel.

11.2.3 Creating an animation

An animation is based on a set of keyframes - camera positions at particular times. To create an animation:

1.

2.

Toggle on the P Animations 1,0 displaying the animation player widget

Click the EI-IE-J Add keyframe byytton and enter a Keyframe time in seconds. The Keyframe combo box now displays
the time set.

Using the navigation tools, move the camera to the position to associate with the current keyframe time.
Repeat the previous steps to add as many keyframes (with time and position) as necessary.

Click the ™ button to preview the animation. QGIS will generate scenes using the camera positions/rotations
at set times, and interpolating them in between these keyframes. Various Interpolation modes for animations

are available (eg, linear, inQuad, outQuad, inCirc... — more details at https://doc.qt.io/qt-5/qeasingcurve.
html#EasingFunction- typedef).
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The animation can also be previewed by moving the time slider. Keeping the Loop box checked will repeatedly

run the animation while clicking > stops a running animation.

=] N
Click Export animation frames , oeperate a series of images representing the scene. Other than the filename Template
and the Output directory, you can set the number of Frames per second, the Output width and Output height.

11.2.4 3D vector layers

A vector layer with elevation values can be shown in the 3D map view by checking Enable 3D Renderer in the 3D
View section of the vector layer properties. A number of options are available for controlling the rendering of the
3D vector layer.

11.3 Elevation Profile View

The Elevation Profile panel is a plotting tool for side view, for visualizing elevation data along a line. It supports
vector, raster, mesh and point cloud layers. Data can be of 2D or 3D type.

"

To add an elevation profile view, go to View » “~ Elevation Profile menu. You can add as many profile views as
you want, and they can be docked, piled on top of each other, or floating.

Elevation Profile ®)

ElviMd4dr%(80p 000k XNE
v| % Pointclod coastal area 15 53.970763
M contour lines sea
— 2.5
m 10
0.5m S ey -:
= [v| [7] contour lines land S I L . S
—25m B RESE
<= 0.5m o st

v| — DEM coastal area

5 -
-10 /

0 20 40 60 80 100 120 140 160 180 200 220 240 260 280 300 320 340 360

Puc. 11.29: Elevation Profile dialog embedded below main map canvas
Figure shows a coastline with a town behind a sea-dike. A larger tolerance applied to the elevation profile line returns more
point cloud features.
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11.3.1 The interface

At the top of the Elevation Profile panel, a toolbar provides you with the following tools:

Ta6mmna 11.4: Elevation Profile View toolbar

Tool Shorcut Description
QJ Add Layers hold Allows you to add new layers to a plot.
Ctrl
while
drag-
and-
drop
@ Show Layer Tree Shows or hides a list of project layers to configure rendering in the profile
view.
Capture Curve Draws interactively a line over the map canvas to represent the profile curve.
W& Picks an existing line feature on the map canvas and generate a profile curve
Capture Curve From Feature along that line.
{ Nudge Left Ctrl+Al Allows you to slowly move the capture line across the map to the left (e.g. to
find the optimal profile line based on the elevation).
D> Nudge Right Ctrl+Al Allows you to slowly move the capture line across the map to the right (e.g. to
find the optimal profile line based on the elevation).
3
W Clear Removes the profile line and any plot displayed in the Elevation Profile view
Ay 1dentify Features Identifies features in the plot canvas via either a single click, or click-and-drag
rectangle. Results are shown in the standard Identify Results dock.
m
U Han Space  Click and drag to pan the plot canvas. Can also be done with the middle mouse
button.
(] ; . . . . . .
# Zoom X Axis Zooms in/out along the horizontal axis, keeping the vertical ratio
)
A T Ctrl+Sy Click or click-and-drag a rectangle over the plot to zoom in. Press A1t and

B
6,} E Zoom Full

@ Enable Snapping

[—] R
[ Measure Distances
1'}1 = Export As PDF

i Export As

% Export As Image

=]
Export Results

“, Options

> Lock
distance/elevation
scales

» Distance units

» Tolerance

click to instead zoom out.
Zooms the Elevation Profile view to the extent of the capture line

Allows to snap to the edge or vertex of the plot features in the profile view.
Convenient for accurate retrieval of coordinates or distance measurements.

Measures horizontal and vertical distances
Exports plots to PDF (as high quality vector objects)
Exports plots to several image formats

Exports plots as 3D features, 2D Profile and Distance/Elevation Table. (The
results can be saved as DXF files, CSV files or any of the standard writable
vector spatial formats)

Provides access to configuration settings of the profile elevation line.

Ensures that the horizontal and vertical scales are always kept equal (so that
e.g. a 45° slope will appear as a 45° slope in the profile view).

Allows to render distances in the profile chart with units other than the map
canvas units.

Sets how far from the actual profile line a point can reside within to be
included in the results. Uses the map units and is ignored by other layer or
geometry types.

continues on next page
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Tabnuua 11.4 - npooonxeHue ¢ Npeablaywel CTpaHnLbl

Tool Shorcut Description
Switch between docked and floating status of the view

Dock Elevation Profile View

In the bottom left, a copy of the Layers panel can be displayed pushing the '@~ Show Layer Tree button. This is
however an independent widget, with its own set of visible layers, in a custom stack order. It allows you to control
layers rendering and behavior within the plot canvas:

* Tick the box next to the layer name to set whether it should be rendered in the plot canvas
* Drag-and-drop layers up or down to change the order of the layers

* style rendering of layers in the profile view: double-click a layer or right-click and select Properties... to open
the layer’s Elevation properties tab for configuration. A summary of elevation settings is displayed as tooltip
when hovering over the layer.

On the right of the layer tree, the plot canvas is the main place you can preview the elevation profile of the enabled
layers. It is based on a graduated grid in which the horizontal axis displays the length of the profile line and the
vertical axis displays the Z elevation of the observed features. It also allows a set of interactions such as zooming,
panning, measuring, identifying features, ... using the tools at the top.

11.3.2 Creating an elevation profile
To create a profile view, you can:

1. Go to View » af Elevation Profile menu. The Elevation profile panel opens.

2. Create the profile line along which the terrain and the features will be rendered. Select a drawing tool:

L
o

. Capture Curve. ¢lick Jeft over the main map canvas to add vertices and click right to finalize a line that
will be used as profile line

o or iz CapwreCurve From Feawre. click g Jine feature on the map canvas to select it as the profile line. If
multiple features are present at the clicked point then a popup menu will appear allowing you to select
among them.

All the line digitizing capabilities such as the snapping options, tracing, digitizing technigues or the advanced
digitizing panel are available for use.

The plot canvas may start rendering some features.
3. The next step is to configure the elevation properties of the layers you want to visualize.

1. Push on the '@~ ShowLayerTree 1o to display the list of layers. By default, not all the layers of the
project are loaded and referenced in the profile tool; e.g., raster layers which are not marked as having

elevation data in their properties are ignored. Clicking the Q Addlayers bytton will show a filtered list
of possible layers which can be added to the plot, but which currently aren’t in the plot. Applying the
dialog with selected layers will automatically mark them as having elevation data and immediately add
them to the plot.

Coget: Holding Ctrl key, it is possible to drag and drop additional layers from the main layer tree to
one in the elevation profile tool.

2. Toggle visibility of the layers you are interested in. These are the only ones rendered in the profile view
and selected layers can be different from the main Layers panel’s.
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3. Double-click a layer name or right-click and select Properties. The Elevation properties tab of the layer
opens. This is the place you configure how each feature or terrain should render on the profile view.
Available properties depend on the layer type:

* Raster Elevation Properties

» Vector Elevation Properties

* Point Cloud Elevation Properties
* Mesh Elevation Properties

The profile view starts rendering terrain or features of active layers crossing the given profile curve, as
soon as they have elevation properties configured.

4. Under “* Options drop-down menu, you can set the Tolerance value. This value is used to create a flat buffer
around the elevation profile line, visible in the main map canvas. Any visible point feature overlapping that
buffer will be captured in the plot canvas.

11.3.3 Interacting with the profile Views

When an elevation profile line is created, the plot canvas zooms to its full extent. On the X-axis you can see the
length of the profile and, on the Y-axis the height range between minimum and maximum height captured, both in
map units.

When you move the mouse pointer in the elevation profile view, you will see two crossing dot lines:
* the vertical line shows the height information
* the horizontal line shows the distance from the beginning of the elevation profile Line

When you move the mouse pointer in the elevation profile canvas, you can also see a black dot move along the
elevation profile line on the main map canvas. At the middle of the profile line, an arrow indicates its direction.

As for the main map canvas, QGIS provides means to navigate on the plot canvas:

L1}
. ‘J\U Pan i used to move the elevation profile extent in any direction you want. Holding Space key while
moving the mouse also shifts the plot canvas extent.

o H Zoom X AXis g yysed to zoom in along the horizontal axis, keeping the ratio of the vertical axis (the elevation)

the same. Left click to stretch out the plot along the X axis, with the clicked point at the center of the axis,

or drag a rectangle to stretch out the plot along the X axis to the rectangle width. Hold A1t while using #*=
Zoom X Axis o 700m out along that axis.

o 2 Zoom s ysed to zoom in on a certain point (using left click), or to a certain extent (dragging a rectangle
on the area). Hold A1t while using &~ 2°°™ to instead zoom out. In combination with the Ct r1 key you can
zoom in or out more smoothly.

wy

o P8 Zcom Full i the default zoom level used at the beginning and shows the full extent of the profile line, with

all returned features. Use it to reset the zoom level.

It is also possible to interact with the elements displayed in the plot canvas:

¢ Press @ Enable snapping bytton to accurately catch points, vertices or edges of the features, for an accurate
measurement or coordinates report.

. QR Identify Features j5 ysed to identify features of the visible layers in the layer tree. You can drag a rectangle
across several features in the profile view to query all of them. When compatible with the format (e.g. vector,
point cloud), these features will be highlighted in the main map canvas.

|| .
o [ Measurement Distances. ¢ick or select two points in the plot canvas to report the horizontal Distance, the
Elevation and the Total distance between them, in map units.
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o NudgeLeft g P Nudgeright 56 ysed to shift the position of the elevation profile line in the map canvas to
its left or right. The plot canvas will be redrawn, showing features and terrain overlapping the profile line
buffer. The line is moved sideways using the Tolerance value in “% ©Pi™ menu.

Ipenynpexaenne: Closing an elevation profile view or the project currently removes the view from the
project.

For more details, give a look to QGIS elevation profile/cross section tool — a deep dive!, a presentation done by
Nyall Dawson.
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OCHOBHbIE VHCTPYMEHTHI

12.1 KoHTeKkcTHas cnpaBka

Whenever you need help on a specific topic, you can access the corresponding page in the current User Manual via
the Help button available in most dialogs — please note that third-party plugins can point to dedicated web pages.

12.2 Panels

By default, QGIS provides many panels to work with. Some of these panels are described below while others may
be found in different parts of the document. A complete list of default panels provided by QGIS is available via the
View » Panels » menu and mentioned at Panels.

12.2.1 Layers Panel
The Layers panel (also called the map legend) lists all the layers in the project and helps you manage their
visibility and shape the map. You can show or hide the panel by pressing Ct r1+1.
QGIS provides a variety of ways to add layers to a project:
* using the Add button from the dedicated data provider tab in the Data source manager dialog

e from QGIS Browser panel or DB Manager: double-click, drag-and-drop files and layers onto QGIS or use the
contextual menu

e drag-and-drop files from the Operating System files explorer onto QGIS
In all these scenarios, you can open one or many layers at a time. New layers are added to the Layers panel:
1. if dropped over the Layers panel, at the exact location they are released
2. in the other cases, at a location that respects the global behavior used when adding new layers setting

3. and in case of multiple layers, they are sorted in a way that increases the chance of their stacking being logical
and features being visible as most as possible, using the following logic (top to bottom):

* vector point layers

* vector line layers
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* vector polygon layers
* point cloud layers

* mesh layers

* raster layers

At the top of the Layers panel, a toolbar allows you to:

o &F open he layer styling dock (F7), toggle the Layer Styling panel on and off.

U

o [Logy Addnew group: seo Interact with groups and layers

o @, Manage Map Themes. ooniro] visibility of layers and arrange them in different map themes.

. ? filter layers in the legend tree:

— Filter Legend by Map Content: only the layers that are set visible and whose features intersect the current
map canvas have their style rendered in the layers panel. Otherwise, a generic NULL symbol is applied
to the layer. Based on the layer symbology, this is a convenient way to identify which kind of features
from which layers cover your area of interest.

— Show Private Layers: a convenient shortcut to display and interact with private layers in the Layers panel
without modifying the project settings.

. afd Filter Legend by Expression. 4 hply an expression to remove styles from the selected layer tree that have no feature

satisfying the condition. This can be used to highlight features that are within a given area/feature of another
layer. From the drop-down list, you can edit and clear the expression currently applied.
. _" Expand All (5 _f Collapse All Javers and groups in the layers panel.

o 4 Remove LayersGroup currently selected.

Layers @
| @ ® T &~ L

Puc. 12.1: Layer Toolbar in Layers Panel

IIpumeuanne: Tools to manage the layers panel are also available for map and legend items in print layouts

Configuring map themes

The @~ Manage Map Themes jron_down button provides access to convenient shortcuts to manipulate visibility of the
layers in the Layers panel:

. Show All Layers

"= Hide All Layers

. @ Show Selected Layers

. Hide Selected Layers

. :-b;' Toggle Selected Layers: changes the visibility of the first selected layer in the panel, and applies that state
to the other selected layers. Also accesible through Space shortcut.

 Toggle Selected Layers Independently: changes the visibility status of each selected layer
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. A Hide Deselected Layers

Beyond the simple control of layer visibility, the @~ Manage Map Themes pyeny allows you to configure Map Themes
in the legend and switch from one map theme to another. A map theme is a snapshot of the current map legend
that records:

« the layers set as visible in the Layers panel
* and for each visible layer:
— the reference to the style applied to the layer

— the visible classes of the style, ie the layer checked node items in the Layers panel. This applies to
symbologies other than the single symbol rendering

— the collapsed/expanded state of the layer node(s) and the group(s) it’s placed inside
To create a map theme:
1. Check a layer you want to show
2. Configure the layer properties (symbology, diagram, labels...) as usual

3. Expand the Style » menu at the bottom and click on Add... to store the settings as a new style embedded in
the project

IIpumeuanue: A map theme does not remember the current details of the properties: only a reference to the
style name is saved, so whenever you apply modifications to the layer while this style is enabled (eg change
the symbology rendering), the map theme is updated with new information.

4. Repeat the previous steps as necessary for the other layers
5. If applicable, expand or collapse groups or visible layer nodes in the Layers panel
6. Click on the @~ Manage Map Themes byyton on top of the panel, and Add Theme...
7. Enter the map theme’s name and click OK
The new theme is listed in the lower part of the ®~ drop-down menu.

You can create as many map themes as you need: whenever the current combination in the map legend (visible
layers, their active style, the map legend nodes) does not match any existing map theme contents as defined above,
click on Add Theme... to create a new map theme, or use Replace Theme » to update a map theme. You can rename
the active map theme with Rename Current Theme... or use the Remove Current Theme button to delete it.

Map themes are helpful to switch quickly between different preconfigured combinations: select a map theme in the
list to restore its combination. All configured themes are also accessible in the print layout, allowing you to create
different map items based on specific themes and independent of the current main canvas rendering (see Map item
layers).

Overview of the context menu of the Layers panel

At the bottom of the toolbar, the main component of the Layers panel is the frame listing all the layers added to the
project, optionally organized in groups. A layer with a checked box next to it displays its contents overlapping the
map canvas extent, unless a scale-based visibility is set. A layer can be selected and dragged up or down in the legend
to change the Z-ordering. Z-ordering means that layers listed nearer the top of the legend are drawn over layers
listed lower down in the legend. Also a layer or a group of layers can be dragged across several QGIS instances.

IIpumeuanne: The Z-ordering behavior can be overridden by the Layer Order panel.

Depending on the item selected in the panel, a right-click shows a dedicated set of options presented below.
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Ta6muma 12.1: Contextual menus from Layers panel items

Option

Group Vector Layer

Raster Layer

Mesh Layer

Point Cloud Layer 3D La:

IT._\‘l

..Lf" Zoom to Layer(s)/Group
.T.--\'I

«.Lf = Zoom to Selection

& Show in Overview
Show Feature Count
abe] Show Label
Copy Layer/Group
Rename Layer/Group
gﬁl Zoom to Native Resolution (100%)
Stretch Using Current Extent

E Update SOL Layer...
EH Edit Virtual Layer...
L@: Add Group

L_‘ Duplicate Layer

ﬂ Remove Layer/Group...
Move Out of Group

Move to Top

Move to Bottom

Check and all its Parents
Group Selected

Open Attribute Table

ur Toggle Editing

;& Current Edits »

Filter...

Change Data Source...

Repair Data Source...

Actions on selections » (in edit mode)
» Duplicate Feature

» Duplicate Feature and Digitize
Set Layer Scale Visibility...
Zoom to Visible Scale

Layer CRS »

» Set Project CRS from Layer
» Set to.. (recent CRSs)

» Set Layer CRS...

Set Group CRS...

Set Group WMS Data...

ol Mutually Exclusive Group

C

L

L

e

LU

8§

NS Q8§

oA

L

L L L

] HEEK

o

o

L

s |8

L

C

L S K L

L

C

8

S K

continues on next pe
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Tabnuua 12.1 - npoLonxeHue ¢ Npeablaywelt CTpaHnLbl

Option Group Vector Layer Raster Layer Mesh Layer Point Cloud Layer 3D La:

Check and all its children (Ctri-click) i
Uncheck and all its children (Ctrl-click) i
Make Permanent

Export » g

L
L
L

» Save As...

» Save Features As...

» Save Selected Features As...

» Save As Layer Definition File... i
» Save As QGIS Layer Style File...

Styles »

» Copy Style

» Paste Style Cif
> Add...

L
SRS
SRS N
Y S8 K

» Rename Current...
» Edit symbol...

» Copy Symbol

» Paste Symbol
Add Layer Notes...
Edit Layer Notes...

L

Remove Layer Notes

NS EEEEHE g8

L
L
g8

Properties...

For GRASS vector layers, ¢ Toggle editing jg ot available. See section Ouudbposka u npaska eexmopiix caoée GRASS
for information on editing GRASS vector layers.

Interact with groups and layers
Layers in the legend window can be organized into groups. There are different ways to do this:

1. Press the L@ icon to add a new group. Type in a name for the group and press Enter. Now click on an
existing layer and drag it onto the group.

2. Select more than one layer, then press the L@ icon. The selected layers are automatically inserted into the
new group.

3. Select some layers, right-click in the legend window and choose Group Selected. The selected layers will
automatically be placed in a new group.

To move a layer out of a group, drag it out, or right-click on it and choose Move Out of Group: the layer is moved
from the group and placed above it. Groups can also be nested inside other groups. If a layer is placed in a nested
group, Move Out of Group will move the layer out of all nested groups.

To move a group or layer to the top of the layer panel, either drag it to the top, or choose Move to Top. If you use
this option on a layer nested in a group, the layer is moved to the top in its current group. The Move to Bottom option
follows the same logic to move layers and groups down.

The checkbox for a group will show or hide the checked layers in the group with one click. With Ctr1 pressed,
the checkbox will also turn on or off all the layers in the group and its sub-groups.
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Ctrl-click on a checked / unchecked layer will uncheck / check the layer and all its parents.

Enabling the Mutually Exclusive Group option means you can make a group have only one layer visible at the
same time. Whenever a layer within the group is set visible the others will be toggled not visible.

It is possible to select more than one layer or group at the same time by holding down the Ct r1 key while clicking
additional layers. You can then move all selected layers to a new group at the same time.

You may also delete more than one layer or group at once by selecting several items with the Ctr1 key and then
pressing Ct r1+D: all selected layers or groups will be removed from the layers list.

More information on layers and groups using indicator icon

In some circumstances, formatting or icons next to the layer or group in the Layers panel change to give more
information about the layer/group. These elements are:

¥ to indicate that the layer is in edit mode and you can modify the data
;‘? to indicate that the layer being edited has some unsaved changes

T to indicate a filter applied to the layer. Hover over the icon to see the filter expression and double-click
to update the query

 to identify layers that are required in the project, hence non removable

@D to identify an embedded group or layer and the path to their original project file

o identify a layer whose data source was not available at the project file opening (see Handling broken file

paths). Click the icon to update the source path or select Repair Data Source... entry from the layer contextual
menu.

ﬂ:::] to remind you that the layer is a temporary scratch layer and its content will be discarded when you close
this project. To avoid data loss and make the layer permanent, click the icon to store the layer in any of the
GDAL vector formats supported by QGIS.

I to identify a layer used in offline editing mode.

?

£ toidentify a layer that has no/unknown CRS

—
= for layers with coordinates stored in a coordinate reference system which is inherently low accuracy
(requires the corresponding setting to be enabled)

@ to identify a temporal layer controlled by canvas animation

LE;I to identify a layer that has nofes associated

A grayed name, when the map canvas current scale is outside the layer’s visibility scale range (as set in its
Rendering properties). Select the contextual menu Zoom to Visible Scale option to zoom the map to the layer’s
nearest visibility scale bound.
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Control layers rendering through grouping

Groups are a means of structuring layers within a tree in the project but they can also impact how their component
layers are rendered, namely as a single flattened object during map renders.

The option for such a rendering is available within the Layer Styling panel whenever a group is selected. Under the

Symbology tab, check . Render Layers as a Group to enable a set of options to control the appearance of the
child layers as a whole, instead of individual layers:

* Opacity: Features from child layers which are obscured by other child layers remain obscured, and the opacity
applies to the «whole of group» only.

Puc. 12.2: Setting opacity on layers vs on a group
The image on the left shows two layers being rendered at 50% opacity (underlying features are visible, but semi-masked by the
50% red feature on top). The second image shows the result of setting the opacity on the group (parts of the blue underlying
child layer is completely obscured by the red layer on top and then the result is rendered at 50% opacity).

* Blend modes: Just like opacity, setting a blend mode (like multiply, overlay, ...) for an entire group results
first in flattening features of child layers, with upper ones obscuring lower. The rendering is then obtained
by blending the flat group and the layers sitting below the group.

— When the child layers have blend modes assigned, it is applied before flattening but the scope is restricted
to only affecting other child layers from that group, and not other layers sitting below the whole group.

— Some more blending modes options are available for child layers in groups, in their Symbology tab which
perform «clipping» style operations on other child layers during the render. You can e.g. clip the render
of one layer’s content by the content in a second «mask» layer.

* Layer effects: applies effects only to the flattened render of the child layers; So e.g. a drop shadow effect
applied to the group would not be visible for obscured child layers.

When a group is set to Render layers as a group, then only the group will be shown in the Layer Order panel list.
Group children will not be visible in this order list, as their ordering is determined by the placement of the group
layer.

Editing layer style

From the Layers panel, you have shortcuts to change the layer rendering quickly and easily.
Right-click on a layer and select Styles » in the list in order to:

* see the styles currently available for the layer. If you defined many styles for the layer, you can switch from
one to another and your layer rendering will automatically be updated on the map canvas.

* copy part or all of the current style, and when applicable, paste a copied style from another layer
* Rename current... style
* Add a new style (which is actually a copy of the current one)

* or Remove current style (only when multiple styles are available).
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Coget: Quickly share a layer style

From the context menu, copy the style of a layer and paste it to a group or a selection of layers: the style is
applied to all the layers that are of the same type (vector, raster, mesh, point cloud, ...) as the original layer
and, for vector layers, have the same geometry type (point, line or polygon).

When using a symbology based on features classification (e.g. categorized, graduated or rule-based for vector layers,
or classification for point clouds), right-clicking a class entry in the Layers panels makes it possible to edit the
visibility of the classes (and their features) and avoid (un)checking them one by one:

. JP* Toggle Items

& Show All Items

.~ Hide All Items

With vector layer, the contextual menu of a class leaf entry also gives access to:
. Select features: selects in the layer all the features matching that class

. Show in attribute table: opens an attribute table filtered to only the features matching that class

* update the symbol color using a Color Wheel. For convenience, the recently used colors are also available at
the bottom of the color wheel.

o Edit Symbol...: opens the Symbol Selector dialog to change feature symbol (symbol, size, color...).
e Copy Symbol
* Paste Symbol

Coget: Double-clicking a class leaf entry also opens the Symbol Selector dialog.

12.2.2 Layer Styling Panel

The Layer Styling panel (also enabled with Ctr1+3) is a shortcut to some of the functionalities of the Layer
Properties dialog. It provides a quick and easy way to define the rendering and the behavior of a layer, and to
visualize its effects without having to open the layer properties dialog.

In addition to avoiding the blocking (or «modal») layer properties dialog, the layer styling panel also avoids
cluttering the screen with dialogs, and contains most style functions (color selector, effects properties, rule edit,
label substitution...): e.g., clicking color buttons inside the layer style panel causes the color selector dialog to be
opened inside the layer style panel itself rather than as a separate dialog.

From a drop-down list of current layers in the layer panel, select an item and:

* Depending on the active item, set:

_&f

e r . . .
- ‘Q‘( Symbology, - Transparency, and =2 Histogram properties for raster layer. These options are
the same as in the Cgoiicmea pacmpa.

- ‘Q"/ Symbology, ‘2k=| Labels, " Mask and @ 3D View properties for vector layer. These options are
the same as in the Csoricmea eexmoprozo caos and can be extended by custom properties introduced by
third-party plugins.

Symbology for groups (see Control layers rendering through grouping)
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- (\\7{ Symbology and @ 3D View properties for mesh layer. These options are the same as in the Mesh
Dataset Properties.

- (\{ Symbology, @ 3D View and | Elevation properties for point cloud layer. These options are the
same as in the Point Clouds Properties.
* Enable and configure global map shading properties

[
¢ Manage the associated style(s) in the “1 Style Manager (more details at Managing Custom Styles).

s Seethe @ History of changes you applied to the layer style in the current project: you can therefore cancel
or restore to any state by selecting it in the list and clicking Apply.

Another powerful feature of this panel is the i Live update checkbox. Tick it to render your changes immediately
on the map canvas: you no longer need to click the Apply button.
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Layer Styling £
"/ rivers - |
& ' = single symbol - |
e &3
— Simple line
Unit Millimeters v

Gpacity —:l | 100,0 %

Color | (NN ~

width | 0,26000 =y =

| <. Topology -

topo foot topo hydrology  topo main road

-

|:| ES 'Save Symbol... | |Advanced |

P Layer Rendering
|E| |E| v| Live update | «/Apply |
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12.2.3 Layer Order Panel

By default, layers shown on the QGIS map canvas are drawn following their order in the Layers panel: the higher a
layer is in the panel, the higher (hence, more visible) it’'ll be in the map view.

You can define a drawing order for the layers independent of the order in the layers panel with the Layer Order

panel enabled in View » Panels » menu or with Ct r1+9. Check g Control rendering order underneath the list of
layers and reorganize the layers in the panel as you want. This order becomes the one applied to the map canvas. For
example, in Puc. 12.4, you can see that the airports features are displayed over the alaska polygon despite
those layers“ respective placement in the Layers panel.

Unchecking A Control rendering order will revert to default behavior.

Layers Panel 5] . .
-
& [l ® T f [ S ) - * NOME .
L ]
— N e L] F 4
v [ [ Boundaries Group ‘. .e 5
_ i .
lE]' regions ‘Q . . F
& alaska ." s o .
— s -
v @ [ water Group . é '}
- rivers a :
p o WADE HAMPTQN .
majrivers ® '
— ! o % . ] o
&= lakes ] . R .
~ |l swamp ':.'. s -
v @ @ groupt . e B
& - popp e O
[& airports -
Layers Panel | Browser Panel A . . .
-~ .. BETHEL
Layer Order Panel 5] e - .
- A . « @ i e * . 'Q l'
& airports . . .
& popp "t
-
_ L
storagep - L L
"~ rivers k2 %
. -
p— -
& regions !
& lakes e -
.
I .

& control rendering order

Puc. 12.4: Define a layer order independent of the legend

12.2.4 Overview Panel

The Overview panel (Ct r1+8) displays a map with a full extent view of some of the layers. The Overview map is
filled with layers using the Show in Overview option from the Layer menu or in the layer contextual menu. Within
the view, a red rectangle shows the current map canvas extent, helping you quickly to determine which area of the
whole map you are currently viewing. If you click-and-drag the red rectangle in the overview frame, the main map
view extent will update accordingly.

Note that labels are not rendered to the map overview even if the layers used in the map overview have been set up
for labeling.
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12.2.5 Log Messages Panel

When loading or processing some operations, you can track and follow messages that appear in different tabs using

the Q Log Messages Panel. It can be activated using the most right icon in the bottom status bar.

12.2.6 Undo/Redo Panel

For each layer being edited, the Undo/Redo (Ct r1+5) panel shows the list of actions carried out, allowing you
quickly to undo a set of actions by selecting the action listed above. More details at Undo and Redo edits.

12.2.7 Statistical Summary Panel

The Statistics panel (Ct r 1+ 6) provides summarized information on any vector layer. This panel allows you to select:

* the vector layer to compute the statistics on: it can be selected from the top drop-down menu, or synced with
the active layer in the Layers panel using the Follow selected layer checkbox at the bottom of the statistics
drop-down list

* the field or € expression to use: for each layer, the last entry is remembered and automatically computed
upon layer reselection.

* the statistics to return using the drop-down button at the bottom-right of the dialog. Depending on the field’s
(or expression’s values) type, available statistics are:

Ta6mumna 12.2: Statistics available for each field type

Statistics cTpoka (string) Integer Float [Hara

Count/Cuutatb o o I

Count Distinct Value i

Count Missing value oA
Sum/Cymma

Mean/Cpeanee 3HaueHue

£ RE8

Standard Deviation

Standard Deviation on Sample
Minimal value

Maximal value
Range//lnanazon

Minority

Majority

Variety

First Quartile

Third Quartile

Inter Quartile Range

e Q8
LR
L

Minimum Length

Maximum Length

L

Mean Length

The statistical summary can be:
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» returned for the whole layer or g Selected features only
. B copied to the clipboard and pasted as a table in another application

~ .
e recalculated using the " button when the underlying data source changes (eg, new or removed
features/fields, attribute modification)

| Statistics (=]ES)
airports b
1.2 ELEV || &
Statistic Value Count
sum 22758 V| sum
Mean 299,447 v Mean
Minimum 9 Median
St dev (po
Maximum 1569 (Pop)
st dev (sample)
Range 1560 v/ Minimum
Minority 24 V| Maximum
Majority 18 v/ Range
Variety 57 V| Minority
v| Majori
Q1 45 J_ &
v Variety
Q3 369 v Q1
IQR 324 v/ Q3
Missing (null) values 0 v/ IQR
v| Missing (null) values

Follow Selected Layer

Selected fFeaturesonly = &2

Puc. 12.5: Show statistics on a field

12.2.8 Debugging/Development Tools Panel

The Debugging/Development Tools panel (F12) provides a unified place for handling and debugging actions within
QGIS. Available tools are organized under following tabs:

a2
* =8 Network Logger
. i Query Logger

. @ Profiler - under this tab you can choose one out of these categories:
— Startup helps you diagnose (and fix) occasional long startup times of QGIS.

— Project Load allows you to get a breakdown of the various stages of project load, in order to identify
the causes of slow project load times.

— Map Render tool allows you to identify pain points in your map rendering and track down exactly which
layers are causing long map redraws.

IIpumeuanne: Plugin authors can extend the panel with custom tabs for debugging and developping their own
plugins. This is done using registerDevToolWidgetFactory method.
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Network Logger

=
The ®® Network Logger tab helps you record and display network requests, along with a whole load of useful details
like request and reply status, header, errors, SSL configuration errors, timeouts, cache status, etc.

From its top toolbar, you can:

@ Record Log: which will start or stop the logging.
I crear Log: will clear the log history.

=]
Save Log...: will first show a big warning that the log is sensitive and should be treated as confidential
and then allow you to save the log.

Press the ™ Settings drop-down menu to select whether to Show Successful Requests, Show Timeouts and Show
Replies Served from Cache.

3] Disable cache: will disable the cache so that every request has to be performed.

)
o " Filter requests based on URL string subsets or request status

By right clicking on a request you can:

* Open URL which will open the URL in your default browser.
* Copy URL

e Copy As cURL to use it in the terminal.

* Copy as JSON: copies the tree values as a json string to the clipboard, for easy pasting in bug reports or for

remote assistance.

Debugging/Development Tools

® @ B *. [ Disable cache

Q, Filter requests

{ - M Requests

Operation
Thread
Initiator

ID

Cache (control)
Cache (save)

- Headers

referer
Accept
User-Agent

- Reply

Status
Cache (result)

- Headers

Connection

Content-Length

Server
Strict-Transport-Security
Expect-CT

ETag

Cache-Control

Expires
Access-Control-Allow-0Origin
X-TileRender

Content-Type
Accept-Ranges

Date

Via

Age

X-Served-By

X-Cache

X-Cache-Hits

X-Timer

alt-svc

@

- Reguest
: GET
: Bx00007f3b94200290
: QgsWmsTiledImageDownloadHandler
¢ src/providers/wms/qgswmsprovider.cpp:4598 (QgsWmsTiledImageDownloadHandler)
: Load from cache if available, otherwise load from network
: Can store result in cache

; *‘,“*
: Mozilla/5.0 QGIS/32700/Ubuntu 22.04.1 LTS

1 200
: Read from network

: keep-alive
1 4263
: Apache/2.4.54 (Ubuntu)
: max-age=31536000; includeSubDomains; preload
: max-age=0
: "d145f22d7382781d7bf996d3701ce2a?"
: max-age=102574, stale-while-revalidate=604800, stale-if-error=604800
: Fri, 30 Sep 2022 11:35:49 GMT
=

. ysera.openstreetmap.org

: image/png

: bytes

¢ Sun, 02 Oct 2022 06:31:55 GMT
: 1.1 varnish

1 39135

: cache-cdg20776-CDG

¢ HIT

I
: §1664692315.075885,VS0,VEL
1 h3=":443";ma=86400,h3-29=":443"; ma=86400,h3-27=":443" ;ma=86400

+ 42 GET https://tile.openstreetmap.org}ﬁ/lS}l@.png
+ 43 GET https://tile.openstreetmap.org/6/15/11.png =

Puc. 12.6: Network Logger output for GET Request
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Query Logger

The ﬁ Query Logger is the place to log the SQL commands sent by the data provider and the connections API to the
backend database, together with their execution time as measured by QGIS (i.e. in the client that sent the commands).
This can be useful when investigating performances of a particular layer during debugging or development of a QGIS
algorithm or plugin.

From its top toolbar, you can:
. @ Record Log: which will start or stop the logging.
« I clear Log: will clear the log history.

=]
. Save Log...: will first show a big warning that the log is sensitive and should be treated as confidential
and then allow you to save the log.
'@
e = Filter queries based on the query string subsets or details such as provider type, start time, initiator, ...
Right-click on a reported query, and you can:
¢ Copy SOL command called by QGIS on the database

* Copy as JSON': copies the tree values as a json string to the clipboard, for easy pasting in bug reports or for
remote assistance.

Debugging/Development Tools @
=T MO RN

ﬁ Q Filter queries

[ M Requests
-~ 1 PRAGMA synchronous=0FF
Provider : spatialite
URI : dbname='/home/delazj/.local/share/QGIS/QGIS3/profiles/default/cache/wfsprovider..
Started at 1 2022-10-01T22:32:08.847
Initiator : QgsSpatialiteProvider
Total time (ms) [}

b
b
b
b

PRAGMA journal_mode=WAL

SELECT rowid FROM "features" WHERE @

SELECT "_ ogc_fid","_ ogc_fid","NA2DESC","NA3DESC"," qgis_gen_counter™,”_qgis_unique_id","_ qgis_hexwkb_geom".
SELECT " ogc fid"," ogc fid","NA2DESC","NA3DESC"," qgis gen counter™," ggis unique id"," qgis hexwkb geom".

NS SR VRN

SELECT ogc fid"," ggis unlque id", AsBinary(" spatialite geometry") FROM "features" WHERE " ggis unigque 1_
Provider : spatlallte

URI 1 /home/delazj/.local/share/QGIS/QGIS3/profiles/default/cache/wfsprovider/pid 177..
Started at 1 2022-10-01T22:32:10.077

Initiator : QgsSpatialiteFeaturelterator

Location ¢ src/providers/spatialite/qgsspatialitefeatureiterator.cpp:240 (QgsSpatialiteFea..
Total time (ms) [¢]

~ 7 SAVEPOINT "qgis_spatialite . 1nternal _savepoint_1"

Provider : spatialite

URI : dbname="/home/delazj/.local/share/QGIS/QGIS3/profiles/default/cache/wfsprovider..
Started at 1 2022-10-01T22:32:10.078

Initiator : QosSpatialiteProvider

Location ¢ src/providers/spatialite/qgsspatialiteprovider.cpp:4155 (addFeatures)

Total time (ms) [¢]
+ 8 RELEASE SAVEPOINT “"qgis_ spatlallte internal_savepoint_1" =

Puc. 12.7: Query Logger output

Profiler

The @ Profiler tab allows to get load times for every single operation involved in actions requested by the user.
Depending on the context, these operations can be settings reading, menu, map canvas or 3D views creation,
resolving map layers reference, bookmark or layout loading, ... This helps identify causes of slow load times.

Default supported actions can be selected from the Categories drop-down menu:
e QGIS Startup

* Project Load
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Debugging/Development Tools B®
Category| Startup v
Task ~ Time (seconds) =

Populate saved styles 0
Plugin manager 0,033
Plugin installer 0,756
New project 0,078
Message bar 0
Loading Python support 1,611
Load user fonts 0
~ Load plugins 11,446
» sagaprovider 0,726
» processing 1,22
~ grassprovider 8,663
» Import GRASS Provider 5,556
Grass Provider 3,088
db_manager 0,009
MetaSearch 0,673
~ Load default style database 0,11
+ Load text Formats 0,035
r Load symbols 0,058
» Load legend patch shapes 0,005
» Load label settings 0,002
» Load color ramps 0,004
Load 3D symbols shapes 0
Load color schemes 0,001
Load bookmarks 0 ¥

Puc. 12.8: Profiler for QGIS Startup

12.3 Embedding layers from external projects

Sometimes, you'd like to keep some layers in different projects, but with the same style. You can either create a
default style for these layers or embed them from another project to save time and effort.

Embed layers and groups from an existing project has some advantages over styling:
 All types of layers (vector or raster, local or online...) can be added

* Fetching groups and layers, you can keep the same tree structure of the «background» layers in your different
projects

¢ While the embedded layers are editable, you can’t change their properties such as symbology, labels, forms,
default values and actions, ensuring consistency across projects

* Modify the items in the original project and changes are propagated to all the other projects
If you want to embed content from other project files into your project, select Layer » Embed Layers and Groups:

1. Click the ... button to look for a project: you can see the content of the project (see Puc. 12.9)
2. Hold down Ctrl (or X Cmd) and click on the layers and groups you wish to retrieve
3. Kimuknute OK.

The selected layers and groups are embedded in the Layers panel and displayed on the map canvas. An icon is
added next to their name for recognition and hovering over displays a tooltip with the original project file path.
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o Select layers and groups to embed

Project file [qgis_sample_datafprcjectsfrelations.qgsl]

airports
regions

Cancel || OK

Puc. 12.9: Select layers and groups to embed

Like any other layer, an embedded layer can be removed from the project by right-clicking on the layer and clicking

|1 Remove

Coset: Change rendering of an embedded layer

It’s not possible to change the rendering of an embedded layer, unless you make the changes in the original project
file. However, right-clicking on a layer and selecting Duplicate creates a layer which is fully-featured and not
dependent on the original project. You can then safely remove the linked layer.

12.4 Interacting with features

12.4.1 Selecting features

QGIS provides several tools to select features on the map canvas. Selection tools are available in the Edit » Select
menu or in the Selection Toolbar.

IMpumeuanue: Selection tools work with the currently active layer.

Selecting manually on the map canvas

To select one or more features with the mouse, you can use one of the following tools:
° ;:;I,v% Select Features by area or single click
. EEV[% Select Features by Polygon
. E‘%& Select Features by Freehand

° @% Select Features by Radius

IMpumeuanune: Other than EE{% Select Features by Polygon these manual selection tools allow you to select feature(s) on
the map canvas with a single click.

Ipumeuanne: Use the E‘% Select Features by Polygon 160] to use an existing polygon feature (from any layer) to select
overlapping features in the active layer. Right-click in the polygon and choose it from the context menu that shows a
list of all the polygons that contain the clicked point. All the overlapping features from the active layer are selected.
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Coser: Use the Edit » Select » Reselect Features tool to redo your latest selection. Very useful when you have
painstakingly made a selection, and then click somewhere else accidentally and clear your selection.

While using the E53 Select Feature(s) tool, holding Shift or Ctrl toggles whether a feature is selected (ie either
adds to the current selection or remove from it).

For the other tools, different behaviors can be performed by holding down:
* Shift: add features to the current selection
* Ctrl:substract features from the current selection
e Ctrl+shift:intersect with current selection, ie only keep overlapping features from the current selection

e Alt: select features that are totally within the selection shape. Combined with Shift or Ctrl keys, you
can add or substract features to/from the current selection.

Automatic selection

The other selection tools, most of them available from the Artribute table, perform a selection based on a feature’s
attribute or its selection state (note that attribute table and map canvas show the same information, so if you select
one feature in the attribute table, it will be selected on the map canvas too):

. Select By Expression.... select features using expression dialog

. Select Features By Value... or press F 3

o {] Deselect Feawres from All Layers or hregs Ctr1+Alt +A to deselect all selected features in all layers

. = Deselect Features from the Current Active Layer or press Ctr 1+Shift+A
. Select All Features or pregs Ctr1+A to select all features in the current layer
o [ vert Feature setecion to invert the selection in the current layer

o @ Selectby Location ¢ gelect the features based on their spatial relationship with other features (in the same or
another layer - see Select by location)

o [E] setect within distance to select features wherever they are within the specified maximum distance from
referenced features - see Select within distance)

For example, if you want to find regions that are boroughs from regions. shp of the QGIS sample data, you
can:

1. Use the &7 Select features using an Expression icon

Expand the Fields and Values group

Double-click the field that you want to query («TYPE_2»)
Click All Unigue in the panel that shows up on the right

A

From the list, double-click ,,Borough®. In the Expression editor field, write the following query:

["TYPE_Z " = 'Borough'

6. Click Select Features

From the expression builder dialog, you can also use Function list » Recent (Selection) to make a selection that you
have used before. The dialog remembers the last 20 expressions used. See Expressions for more information and
examples.
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Coser: Save your selection into a new file

Users can save selected features into a New Temporary Scratch Layer or a New Vector Layer using Edit » Copy
Features and Edit » Paste Features as in the desired format.

Select Features By Value

This selection tool opens the layer’s feature form allowing the user to choose which value to look for for each field,
whether the search should be case-sensitive, and the operation that should be used. The tool has also autocompletes,
automatically filling the search box with existing values.

Select Features by Value

fid Exclude field_
id Exclude field_
flc_region Exclude field,
elev 100 Equal to (=),
name Case sensitive | Exclude field_
use |M| Case sensitive | Contains,
Jr.{;iilr;u;cal':!}irlitarwcwilian R‘\
Reset form Flash features | Zoom to features Select features |~ Close

Puc. 12.10: Filter/Select features using form dialog

Alongside each field, there is a drop-down list with options to control the search behaviour:
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Ta6muma 12.3: Query operators per data type

Field search option ctpoka (string) Numeric [Hara

Exclude Field from the search .
Equal to (=) i
Not equal to (#) o
Greater than (>)

Less than (<)

Greater than or equal to (>)

Less than or equal to (<)

Between (inclusive)

L
SRS

Not between (inclusive)
Contains
Does not contain

Is missing (null)

 ®
|

Is not missing (not null)
Starts with
Ends with

L

For string comparisons, it is also possible to use the Cf Case sensitive option.
After setting all search options, click Select features to select the matching features. The drop-down options are:
o Select features
* Add to current selection
* Remove from current selection
e Filter current selection
You can also clear all search options using the Reset form button.
Once the conditions are set, you can also either:
» Zoom to features on the map canvas without the need of a preselection

e Flash features, highlighting the matching features. This is a handy way to identify a feature without selection
or using the Identify tool. Note that the flash does not alter the map canvas extent and would be visible only
if the feature is within the bounds of the current map canvas.

12.4.2 |dentifying Features

The Q?% Identify Features 0] allows you to interact with the map canvas and get information on features or pixels in
a pop-up window. It can be used to query most of the layer types supported by QGIS (vector, raster, mesh, point
cloud, wms, wfs, ...). To identify an element, use either:

e View » Identify Features

e Ctrl+Shift+I (orX Cmd+Shift+1),

. Qf\% Identify Features 1y,tton on the Aftributes toolbar
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Then click on a feature or pixel of the active layer. The identified item gets highlighted in the map canvas while the
Identify Results dialog opens with detailed information on it. The dialog also shows a set of buttons for advanced

configuration.

The Identify Results dialog

|dentify Results

Feature

* regions

* (Derived)

(clicked coordinate X)
(clicked coordinate Y)
Area (Cartesian)

Area (Ellipsoidal — EPSG:7008)
Closest X

Closest Y

Closest vertex X
Closest vertex Y
Closest vertex number
Feature ID

Part number

Parts

Perimeter (Cartesian)

Perimeter (Ellipsoidal — EPSG7008)

Vertices

* (Actions)

ID

NAME_2
TYPE_2

* airport_relation [1]

* NAME
* (Actions)

ID
fk_region
ELEV
NAME
USE

Mode | Current Layer

View | Tree

From bottom to top:

* The View controls the general aspect of the dialog and the formatting of the results; it can be set as:

Value

Aleutians East

-1838412
2001782
192708709904,198
17903107685,030 m®
- 1846463
2007783
-1846542

2007831

1462

0

213

213

14963241,526
4560628,650 m
31277

View feature form

Set as Atlas Feature for clip_test
1

Aleutians East

Borough

COLD BAY

View feature form
63

Aleutians East
87,000

COLD BAY
Civilian/Public

Help

Puc. 12.11: Identify Results dialog

— Tree: this is the default view, and returns the results in a tree-structure
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— Table: available only for raster-based layers, it allows to display the results as a table whose columns
are Layer, FID, Attribute and Value

— or Graph: available only for raster-based layers

¢ The Mode helps you select the layers from which results could be returned. These layers should be set visible,
displaying data in the map canvas, and set identifiable from the Project properties » Data Sources » Layers
capabilities. Available modes are:

Current layer: only the layer(s) selected in the Layers panel return results. If a group is selected, then
results are picked from its leaf layers.

Top down, stop at first: results are from the layer of the top most feature or pixel under the mouse.

Top down: results are from the layers with feature or pixel under the mouse.

Layer selection: opens a contextual menu where the user selects the layer to identify features from. If
only a single feature is under the mouse, then the results are automatically displayed.

¢ In the upper part of the Identify Results dialog, a frame shows the information returned by features as a table,
a graph or a tree, depending on the selected view. When in a tree view, you have a handful of tools above the
results:

— =5 OpenForm f the current feature

_ _‘]L Expand tree
_ ii Collapse tree

- $ Expand New Results by Default 1, define whether the next identified feature’s information should be
collapsed or expanded

17 Clear Results
1]

_ Copy the identified feature to clipboard’ suitable for pasting ina spreadsheet.

— U= Printselected HTML response. 5 gext_based formatting of the results to print on paper or save as a . PDF
file

— the interactive identifying tools: a drop-down menu with tools for selecting on the map canvas features
or pixels to identify

— Under "~ Mdentify Settings vy can activate whether to:

. & Auto open form for single feature results: If checked, each time a single feature is identified, a
form opens showing its attributes. This is a handy way to quickly edit a feature’s attributes.

* Hide derived attributes from results to only show fields actually defined in the layer

* Hide NULL values from results

- EHSIP to access the current documentation
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Using the Identify Features tool

In its default display (View: Tree), the Identify Results panel offers several tools to interact with the layers to query.
A smart combination of these tools with the farget layers selector may greatly improve identification operations:
. % Identify Feature(s) 1y gingle click or click-and-drag
— single click or click-and-drag: overlaying features in the target layers are returned

— right-click: overlaying features from target layers are listed in the contextual menu, grouped by layers.
You can then choose to:

» display the result for a specific feature,
« display the result for all the features of a specific layer,
+ for vector layers, it is also possible to open its attribute table filtered to the returned features

x or show all of the returned features.

. a@ Identify Features on Mouse over; mgye gver the map canvas and hovered items in the target layers get highlighted
and returned in the results panel.

T
Cl .
. q\:‘\ Identify Features by Polygon: retyrns items overlapping a drawn or selected polygon.

— Draw a polygon (left click to add point, right click to close the polygon) and all the overlaying features
from target layers are highlighted and returned in the results panel.

— Right-click and you get the list of all visible polygon features in the project under the click. Pick an
entry and QGIS will return all the features from the target layers that overlap the selected polygon.
. % Identify Features by Freehand . reyyrng jtems overlapping a polygon drawn by freehand. Draw a polygon (left-click
to start, move the pointer to shape the area and right-click to close the polygon). All the overlaying features
from target layers are highlighted and returned in the results panel.

. % Identify Features by Radius petyrng jtems overlapping a drawn circle. Draw a cercle (left-click to indicate the
center point, move the pointer to shape the area or enter the radius in the pop-up text box and left-click or
press Enter to validate the circle). All the overlaying features from target layers are highlighted and returned
in the results panel.

Cogert: Filter the layers to query with the Identify Features tool
Under Project » Properties... » Data Sources » Layer Capabilities, uncheck the Identifiable column next to a layer

to avoid it being queried when using the Q% Identify Feawres t60] This is a handy way to return features from only
layers that are of interest to you.

Feature information

When you identify a data in the map canvas, the Identify Results dialog will list information about the items clicked
(or hovered over, depending on the tool in use). The default view is a tree view in which the first item is the name
of the layer and its children are its identified feature(s). Each feature is described by the name of a field along with
its value. This field is the one set in Layer Properties » Display. All the other information about the feature follows.

The feature information displayed by the identify tool will depend on the type of layer you have selected, whether
it is a vector layer (including vector tiles or point cloud data) or raster layer. If your layer is raster, clicking on a
location on the map canvas with identify tool will highlight the identified raster pixel. The Identify Results dialog
can be customized to display custom fields, but by default it will display the following information:

 The feature display name;
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* Actions: Actions can be added to the identify feature windows. The action is run by clicking on the action

label. By default, only one action is added, namely View feature form for editing. You can define
more actions in the layer’s properties dialog (see Actions Properties).

Derived: This information is calculated or derived from other information. It includes:
— general information about the feature’s geometry:

» depending on the geometry type, the cartesian measurements of length, perimeter or area in the
layer’s CRS units. For 3D line vectors the cartesian line length is available.

+ depending on the geometry type and if an ellipsoid is set in the project properties dialog for
Measurements, the ellipsoidal values of length, perimeter or area using the specified units

+ the count of geometry parts in the feature and the number of the part clicked
+ the count of vertices in the feature
— coordinate information, using the project properties Coordinates display settings:
» X and Y coordinate values of the point clicked
+ the number of the closest vertex to the point clicked
+ X and Y coordinate values of the closest vertex (and z/M if applicable)
+ if you click on a curved segment, the radius of that section is also displayed.
Data attributes: This is the list of attribute fields and values for the feature that has been clicked.
information about the related child feature if you defined a relation:

the name of the relation

the entry in reference field, e.g. the name of the related child feature

Actions: lists actions defined in the layer’s properties dialog (see Actions Properties) and the default
actionis View feature form.

Data attributes: This is the list of attributes fields and values of the related child feature.

IIpumeuanue: Links in the feature’s attributes are clickable from the Identify Results panel and will open in your
default web browser.

Results contextual menu

Other functions can be found in the context menu of the identified item. For example, from the context menu you

can:

View the feature form

VBeanuuth 10 00beKTa

Copy feature: Copy all feature geometry and attributes

Toggle feature selection: Add identified feature to selection

Copy attribute value: Copy only the value of the attribute that you click on

Copy feature attributes: Copy the attributes of the feature

Select features by attribute value: Select all features in the layer that match the selected attribute
Clear result: Remove results in the window

Clear highlights: Remove features highlighted on the map

Ilonceeruts BeE

TToaceeTuts BCE B ciioe
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 Activate layer: Choose a layer to be activated
» Layer properties: Open layer properties window
* Pa3BepHyTb BCE

¢ CBepHyTb BcE

12.5 Save and Share Layer Properties

12.5.1 Managing Custom Styles

When a vector layer is added to the map canvas, QGIS by default uses a random symbol/color to render its features.
However, you can set a default symbol in Project » Properties... » Default styles that will be applied to each newly
added layer according to its geometry type.

Most of the time, though, you’d rather have a custom and more complex style that can be applied automatically or
manually to the layers (with less effort). You can achieve this by using the Style menu at the bottom of the Layer
Properties dialog. This menu provides you with functions to create, load and manage styles.

A style stores any information set in the layer properties dialog to render or interact with the layer (including
symbology, labeling, fields and form definitions, actions, diagrams...) for vector layers, or the pixels (band or color
rendering, transparency, pyramids, histogram ...) for raster.

Layer Properties - regions | Diagrams B

No diagrams - ||®
fi InFormation Attributes
A8 source
% symbology ]
€3 Labels
- Save Layer Style £
‘ Diagrams
Y LRIl As QGIS QML style file k
N 3D View 2
File As SLD style file
E Fields
v "% Layer Configuration
Attributes
Form v & symbology
Joins v 6‘:" 3D Symbology
L Auxiliary V| @b Labels
<8 storage v f% Fields
{;‘G} Actions v Forms
® ol Categories | v/ /& Actions
isplay
v Map Tips
o .
& Rendering v W, Diagrams
Variables Load style... v Attribute Table Settings
~ R~ v &f Rendering
! Metadata save jfyle... . ‘% Costom p .
Save as Default ustom Froperties
ﬁ' Dependencies Restore Default V| "% Geometry Options

Legend

QGIS Server

“ Digitizing

By default, the style applied to a loaded layer is named default. Once you have got the ideal and appropriate

@Help Style -

Add...
Rename Current...

@Help

Puc. 12.12: Vector layer style combo box options

* Cancel

« Apply || % cancel « OK

rendering for your layer, you can save it by clicking the £ Style combo box and choosing:

¢ Rename Current: The active style is renamed and updated with the current options
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e Add: A new style is created using the current options. By default, it will be saved in the QGIS project file.
See below to save the style in another file or a database

* Remove: Delete unwanted style, in case you have more than one style defined for the layer.
At the bottom of the Style drop-down list, you can see the styles set for the layer with the active one checked.

Note that each time you validate the layer properties dialog, the active style is updated with the changes you’ve
made.

You can create as many styles as you wish for a layer but only one can be active at a time. In combination with Map
Themes, this offers a quick and powerful way to manage complex projects without the need to duplicate any layer
in the map legend.

IIpumeuanue: Given that whenever you apply modifications to the layer properties, changes are stored in the
active style, always ensure you are editing the right style to avoid mistakenly altering a style used in a map theme.

Cosert: Manage styles from layer context menu

Right-click on the layer in the Layers panel to copy, paste, add or rename layer styles.

12.5.2 Storing Styles in a File or a Database

While styles created from the Style combo box are by default saved inside the project and can be copied and pasted
from layer to layer in the project, it’s also possible to save them outside the project so that they can be loaded in
another project.

Save as text file

Clicking the - Style » Save Style, you can save the style as a:
¢ QGIS layer style file (. gml)
» SLD file (. s1d), only available for vector layers

Used on file-based format layers (. shp, .tab...), Save as Default generates a . qml file for the layer (with the
same name). SLDs can be exported from any type of renderer — single symbol, categorized, graduated or rule-based
— but when importing an SLD, either a single symbol or rule-based renderer is created. This means that categorized
or graduated styles are converted to rule-based. If you want to preserve those renderers, you have to use the QML
format. On the other hand, it can be very handy sometimes to have this easy way of converting styles to rule-based.

Save in database

Vector layer styles can also be stored in a database if the layer datasource is a database provider. Supported formats
are PostGIS, GeoPackage, SpatiaLite, MS SQL Server and Oracle. The layer style is saved inside a table (named
layer_styles) in the database. Click on Save Style... » Save in database then fill in the dialog to define a style
name, add a description, a . ui file if applicable and to check if the style should be the default style.

You can save several styles for a single table in the database. However, each table can have only one default style.
Default styles can be saved in the layer database or in ggis . db, a local SQLite database in the active user profile
directory.
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o Save style in database

Style Name |Alaska_regions

o Alaska regions boundaries with
Description || spels

Optionally pick an input Form Ffor attribute editing
(QT Designer Ul format), it will be stored in the
database

ul open...

[ Use as default style For this layer

Cancel | [ OK

Puc. 12.13: Save Style in database Dialog

Coget: Sharing style files between databases

You can only save your style in a database if the layer comes from such a database. You can’t mix databases (layer
in Oracle and style in MS SQL Server for instance). Use instead a plain text file if you want the style to be shared
among databases.

IIpumeuanue: You may encounter issues restoring the layer_styles table from a PostgreSQL database
backup. Follow QGIS layer_style table and database backup to fix that.

Load style

When loading a layer in QGIS, if a default style already exists for this layer, QGIS loads the layer with this style.
Also Style » Restore Default looks for and loads that file, replacing the layer’s current style.

Style » Load Style helps you apply any saved style to a layer. While text-file styles (. s1d or . gml) can be applied
to any layer whatever its format, loading styles stored in a database is only possible if the layer is from the same
database or the style is stored in the QGIS local database.

The Database Styles Manager dialog displays a list of styles related to the layer found in the database and all the
other styles saved in it, with name and description.

Coget: Quickly share a layer style within the project

You can also share layer styles within a project without importing a file or database style: right-click on the layer
in the Layers Panel and, from the Styles combo box , copy the style of a layer and paste it to a group or a selection
of layers: the style is applied to all the layers that are of the same type (vector vs raster) as the original layer and, in
the case of vector layers, have the same geometry type (point, line or polygon).

12.5. Save and Share Layer Properties 201



QGIS Desktop 3.34 User Guide

12.5.3 Layer definition file

Layer definitions can be saved asa Layer Definition File (.qglr) using Export » Save As Layer Definition
File... in the active layers“ context menu. A layer definition file (. glr) includes references to the data source of
the layers and their styles. . glr files are shown in the Browser Panel and can be used to add the layers (with the
saved style) to the Layers Panel. You can also drag and drop . glr files from the system file manager into the map
canvas.

12.6 Documenting your data

In addition to displaying and symbolizing the data in the layers, QGIS allows you to fill:

* metadata: information to help people find and understand the dataset, how they can access and use it... these
are properties of the datasource and can live out of the QGIS project.

* notes: instructions and comments regarding the layer in the current project

12.6.1 Metadata

In the layer properties dialog, the / Metadata tab provides you with options to create and edit a metadata report
on your layer.

Information to fill concern:
« the data Identification: basic attribution of the dataset (parent, identifier, title, abstract, language...);
* the Categories the data belongs to. Alongside the ISO categories, you can add custom ones;
* the Keywords to retrieve the data and associated concepts following a standard based vocabulary;
* the Access to the dataset (licenses, rights, fees, and constraints);
« the Extent of the dataset, either spatial one (CRS, map extent, altitudes) or temporal;
e the Contact of the owner(s) of the dataset;
* the Links to ancillary resources and related information;
* the History of the dataset.

A summary of the filled information is provided in the Validation tab and helps you identify potential issues related
to the form. You can then either fix them or ignore them.

Metadata are saved in the project file by default, the Metadata drop-down offers options for loading/saving metadata
from . gmd file and for loading/saving metadata in the «Default» location.

Metadata ~
Load Metadata from File...
Save Metadata to File...
Save to Default Location

Restore from Default Location

Puc. 12.14: Metadata load/save options

The «Default» location used by Save to Default Location and Restore from Default Location changes depending on
the underlying data source and on its configuration:

» For PostgreSQL data sources if the configuration option Allow saving/loading QGIS layer metadata in the
database is checked the metadata are stored inside a dedicated table in the database.
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* For GeoPackage data sources Save fo Default Location always saves the metadata in the internal metadata

tables of the GeoPackage.

When metadata are saved into the internal tables of PostgreSQL or GeoPackage they become available for

search and filtering in the browser and in the layer metadata search panel.

¢ For all other file based data sources Save fo Default Location saves the metadata in a . gmd file alongside the

file.

¢ In all other cases Save to Default Location saves the metadata in a local . sqlite database.

12.6.2 Layer notes

Layer notes allow you to document the layer within the current project. They can be place to store important

messages for users of the project like to do lists, instructions, warnings, ...

From the layer’s contextual menu in Layers panel, select Add layer notes... and fill the open dialog with necessary

texts.

Layer Notes — Lakes b3

Standard <~ | % 1M~ &t @ é = — > ~  Bullet List  OrderedList =¢ jE =z ‘@l %

Memo
Always check if a new version of the background image is available.

Client requests

* Client has asked to make "commercial" features in this layer redder. Only apply this change in the "structure" style.
* Remember to check the label placement before supply to client, particularly in layout.

Digitizing

* ND (07/23/21): I only managed to digitize the northern part of the layer this week. @EH when you pick up this project again, can you please finish

digitizing this layer?
. 8740 = FheEype”

tew: Fixed (MK - 07/19/21)

@ Help Ocancel || Zsave

Puc. 12.15: Adding notes to a layer

The Add layer notes dialog provides a html-based multiline text box with a complete set of tools for:

* text manipulation: cut, copy, paste, undo, redo

* characters formatting, applied to all or parts of the contents: font size and color, bold, italic, underline,

strikethrough, background color, URL highlighting
e paragraph structuring: bullet and numbered lists, indentation, predefined headings
« file insertion, even with drag-and-drop
* editing with HTML coding
From the ... drop-down at the far right of the toolbar, you can:
* Remove all formatting
e Remove character formatting

e Clear all content

In the Layers panel, a layer with a note is assigned the IE;] icon which, upon hover, displays the note. Click the icon

to edit the note. You can as well right-click the layer and Edit layer note... or Remove layer note.

12.6. Documenting your data
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IIpumeuanue: Notes are part of the layer style and can be saved in the .gml or .glr file. They can also be
transferred from one layer to another while copy-pasting the layer style.

12.7 Storing values in Variables

In QGIS, you can use variables to store useful recurrent values (e.g. the project’s title, or the user’s full name) that can
be used in expressions. Variables can be defined at the application’s global level, project level, layer level, processing
modeler level, layout level, and layout item’s level. Just like CSS cascading rules, variables can be overwritten - e.g.,
a project level variable will overwrite any application global level variables set with the same name. You can use
these variables to build text strings or other custom expressions using the @ character before the variable name. For
example in print layout creating a label with this content:

)

This map was made using QGIS [% @qggis_version $]. The project file for this
map is: [% @project_path %]

Will render the label like this:

This map was made using QGIS 3.4.4-Madeira. The project file for this map is:
/gis/qgis-user—-conference-2019.ggs

Besides the preset read-only variables, you can define your own custom variables for any of the levels mentioned
above. You can manage:

¢ global variables from the Settings » Options menu

e project variables from the Project Properties dialog (see Ceoiicmea npoexma)

* vector layer variables from the Layer Properties dialog (see Ceoiicmea sexmoprozo cnosi);
¢ modeler variables from the Model Designer dialog (see The model designer);

* layout variables from the Layout panel in the Print layout (see The Layout Panel);

* and layout item variables from the Item Properties panel in the Print layout (see Layout Items Common
Options).

To differentiate from editable variables, read-only variable names and values are displayed in italic. On the other
hand, higher level variables overwritten by lower level ones are strike through.
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Project Properties | Variables X

Expression Variables

\ General Variable value
Metadata v Global
qgis_locale 'en’
CRS ggis_os_name linux’
ggis_platform 'desktop’
"~ Default Styles qgis_release_name ‘Madeira’
Data Sources qgis_short_version '3.4'
qgis_version '3.4.3-Madeira’
Relations qgis_version_no 30403
user_account_name ‘tt'
& Vvariables user_full name 't
@ " employee_number '12345"
L SC108 work—department “Map-Ltaboratory’
QGIS Server Project
project_abstract "
project_author ‘tt'

project_basename
project_creation_date
project_crs
project_crs_definition
project_filename
project_folder
profect_home
project_identifier
project_keywords
project_path

project _title
work_department

@Help

<datetime: 2019-01-05 14:25:09>
'EPSG:4326'
‘+proj=longlat +datum=WGS84 +no_defs’

{}

"

‘My beautiful map’
'somwhere new I'm temporarily working at’'

o

# cancel

«/ Apply

Puc. 12.16: Variables editor at the project level

IIpumeuanne: You can read more about variables and find some examples in Nyall Dawson’s Exploring variables

in QGIS 2.12, part 1, part 2 and part 3 blog posts.

12.8 Authentication

QGIS has the facility to store/retrieve authentication credentials in a secure manner. Users can securely save
credentials into authentication configurations, which are stored in a portable database, can be applied to server or
database connections, and are safely referenced by their ID tokens in project or settings files. For more information

see Authentication System.

A master password needs to be set up when initializing the authentication system and its portable database.

12.8. Authentication
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12.9 Common widgets

In QGIS, there are some options you’ll often have to work with. For convenience, QGIS provides you with special
widgets that are presented below.

12.9.1 Color Selector

The color dialog

N -

The Select Color dialog will appear whenever you click the ————— icon to choose a color. The features
of this dialog depend on the state of the Use native color chooser dialogs parameter checkbox in Settings » Options...
» General. When checked, the color dialog used is the native one of the OS on which QGIS is running. Otherwise,
the QGIS custom color chooser is used.

The custom color chooser dialog has four different tabs which allow you to select colors by IEI Color ramp L

Color wheel Color swatches (- ﬁ’ Colorpicker With the first two tabs, you can browse to all possible color combinations
and apply your choice to the item.

Select color

| 248°

& o P

100%

69%

23

HTML notation |#1700af

Current

i Opacity S oo%

Old

Puc. 12.17: Color selector ramp tab

In the [mas| Colorswatches tahy vou can choose from a list of color palettes (see Colors settings for details). All but the

Recent colors palette can be modified with the kR Aad curentcotor and "= Remove selected color byytons at the bottom of
the frame.

The ... button next to the palette combo box also offers several options to:
* copy, paste, import or export colors
* create, import or remove color palettes

* add the custom palette to the color selector widget with the Show in Color Buttons item (see Puc. 12.19)
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Select Color -

*
¥ © ; H I 250 -
Recent colors e S 100% .

L
standard colors v I 5%

L

Project colors

L

r INEEE 3
New layer colors

« W 0 =
. #d7191c

I 7 -
. #cf3922 Opacity R 100% .

F— 5
HTML notation #1700af

Current > [ ]
old

@Help Reset % cancel  OK
Puc. 12.18: Color selector swatches tab

Another option is to use the ﬁf Color picker which allows you to sample a color from under your mouse cursor at any
part of the QGIS UI or even from another application: press the space bar while the tab is active, move the mouse
over the desired color and click on it or press the space bar again. You can also click the Sample Color button to
activate the picker.

Whatever method you use, the selected color is always described through color sliders for HSV (Hue, Saturation,
Value) and RGB (Red, Green, Blue) values. The color is also identifiable in HTML notation.

Modifying a color is as simple as clicking on the color wheel or ramp or on any of the color parameters sliders. You
can adjust such parameters with the spinbox beside or by scrolling the mouse wheel over the corresponding slider.
You can also type the color in HTML notation. Finally, there is an Opacity slider to set transparency level.

The dialog also provides a visual comparison between the Old color (applied to object) and the Current one (being

* Add color to swatch

selected). Using drag-and-drop or pressing the button, any of these colors can be saved in a slot

for easy access.

Coset: Quick color modification

Drag-and-drop a color selector widget onto another one to apply its color.
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The color drop-down shortcut

Click the drop-down arrow to the right of the —————"— “ color button to display a widget for quick color
selection. This shortcut provides access to:

a color wheel to pick a color from

an alpha slider to change color opacity

the color palettes previously set to Show in Color Buttons
copy the current color and paste it into another widget
pick a color from anywhere on your computer display
choose a color from the color selector dialog

drag-and-drop the color from one widget to another for quick modification

Cogert: Scroll the mouse wheel over a color selector widget to quickly modify the opacity of the associated color.

IIpumeuanue: When the color widget is set to a project color through the data-defined override properties, the
above functions for changing the color are unavailable. You'd first need to Unlink color or Clear the definition.

=

Copy Color

Paste Color
Pick Color

Choose Colar...

Puc. 12.19: Quick color selector menu
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The color ramp drop-down shortcut

Color ramps are a practical way to apply a set of colors to one or many features. Their creation is described

in the Setting a Color Ramp section. As for the colors, pressing the H color ramp button opens the
corresponding color ramp type dialog allowing you to change its properties.

(2} ColorBrewer Ramp ? x
Scheme name l Accent =
Colors 7 =

Preview

Cancel Help

Puc. 12.20: Customizing a colorbrewer ramp

The drop-down menu to the right of the button gives quick access to a wider set of color ramps and options:

Invert Color Ramp

Clear Current Ramp to unset any assigned color ramp to the widget (available only in some contexts)

— Random Colors: available only in some contexts (e.g., when a color ramp is being used for a layer
symbology), checking this entry creates and applies a color ramp with random colors. It also enables a Shuffle
random colors entry to regenerate a new random color ramp if the current one is not satisfactory.

a preview of the gradient or catalog: cpt-city color ramps flagged as Favorites in the Style
Manager dialog

All Color Ramps to access the compatible color ramps database

Create New Color Ramp... of any supported type that could be used in the current widget (note that this color
ramp will not be available elsewhere unless you save it in the library)

Edit Color Ramp..., the same as clicking the whole color ramp button

Save Color Ramp..., to save the current color ramp with its customizations in the style library
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- . -

Invert Color Ramp
Random Color Ramp
I Blues
B cividis
Il Greens
Hl Greys
P Magma
B Mako
I | rday
Il Reds
B Rocket
| | spectral
I Turbo
B viridis
All Color Ramps »
Create New Color Ramp...
Edit Color Ramp...

Save Color Ramp...

Puc. 12.21: Quick color ramp selection widget

12.9.2 Symbol Widget

The Symbol selector widget is a convenient shortcut when you want to set symbol properties of a feature. Clicking
the drop-down arrow shows the following symbol options, together with the features of the color drop-down widget:

* Configure Symbol...: the same as pressing the symbol selector widget. It opens a dialog to set the symbol
parameters.

¢ Copy Symbol from the current item
* Paste Symbol to the current item, speeding configuration

* Clear Current Symbol to unset any assigned symbol to the widget (available only in some contexts)

Coget: Scroll the mouse wheel over a marker or line symbol widget to quickly modify the size of the associated
symbol.

12.9.3 Remote or embedded file selector
Along with the file selector widget, the ... button will sometimes show a drop-down arrow. This is usually available
when using:
* an SVG file in a symbol or a label
* araster image to customize symbols, labels, textures or decorations
Pressing the arrow will provide you with a menu to:

¢ Select File..., to load the file from the file system. The file is identified through the file path and QGIS needs
to resolve the path in order to display the corresponding image

e From URL..., to load the file from a remote URL. As above, the image will only be loaded on successful
retrieval of the remote resource
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e Embed File..., to embed the file inside the current project, style database, or print layout template. The file
is then always rendered as part of the item. This is a convenient way to create self-contained projects with
custom symbols which can be easily shared amongst different users and installations of QGIS.

 Extract Embedded File..., to extract the embedded file from the widget and save it on disk.

12.9.4 Visibility Scale Selector

The visibility scale selector provides options to control the scales at which an element will be made visible in the
map canvas. Out of the specified range of scales, the elements are not displayed. It can be applied e.g. to layers,
labels or diagrams, from their Rendering properties tab.

1. Tick the oA Scale dependent visibility box

2. Fill the Minimum (exclusive) box with the most zoomed out desired scale, typing the value or selecting it from
the predefined scales

3. and/or fill the Maximum (inclusive) box with the most zoomed in desired scale
The IER Setto current canvas scale fy,tton next to the scale boxes sets the current map canvas scale as boundary of

the range visibility. Press the arrow next to the button to access scales from layouts“ maps and reuse them to
fill the box.

v V| Scale Dependent Visibility

Minimum (exclusive) Maximum (inclusive)
4= 1:1000001 - | %~/ f®|1:250000 - | &

Puc. 12.22: Visibility scale selector widget

12.9.5 Spatial Extent Selector

The Extent selector widget is a convenient shortcut when you want to select a spatial extent to assign to a layer or to
limit the actions to run on. Depending on the context, it offers selection between:

* Current Layer Extent: e.g. when exporting a layer

* Calculate from Layer »: uses extent of a layer loaded in the current project
» Use current Map Canvas Extent

* Draw on Canvas: a rectangle whose coordinates are then used

* Calculate from Bookmark: uses extent of a saved bookmark

* Calculate from Layout Map: uses extent of a layout map

¢ Enter or edit the coordinates as xmin, xmax, ymin, ymax
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v Vv Extent (current: layer)

North |7805331,2231
West -7115212,9838 East 4895579,8115

South [1368239,6063

Calculate from  Layer - | Layout Map - Bookmark -

Current Layer Extent Map Canvas Extent

12.9.6 Font Selector

Puc. 12.23: Extent selector widget

The Font selector widget is a convenient shortcut when you want to set font properties for textual information
(feature labels, decoration labels, map legend text, ...). Clicking the drop-down arrow shows some or all of the

following options:

10.0000 =
Recent Fonts ’
Configure Format...

Copy Format

A3 Paste Format

V o

| N ETE N
Copy Color

W Paste Color

Puc. 12.24: Font selector drop-down menu

¢ Clear Current Text Format to unset any assigned text format to the widget (available only in some contexts)

e Font Size in the associated unit

* Recent Fonts » menu with the active font checked (at the top)

* Configure Format...: same as pressing the font selector widget. It opens the Text format dialog, providing
advanced formatting options such as color, opacity, orientation, HTML notation, buffer, background, shadow,
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Copy Format of the text
Paste Format to the text, speeding configuration

the color widget for quick color setting

Coget: Scroll the mouse wheel over a font selector widget to quickly modify the font size of the associated text.

12.9.7 Unit Selector

Size properties of the items (labels, symbols, layout elements, ...) in QGIS are not necessarily bound to either the
project units or the units of a particular layer. For a large set of properties, the Unit selector drop-down menu allows
you to tweak their values according to the rendering you want (based on screen resolution, paper size, or the terrain).
Available units are:

Millimeters
Points
Pixels
Inches

Percentage: allows you to set some properties as a percent of another one. For example, this is useful for
creation of text formats where the components (buffer size, shadow radius...) nicely scale as the text size is
changed, instead of having constant buffer/shadow sizes. So you don’t need to adjust those sizes, when the
text size changes.

Meters at Scale: This allows you to always set the size in meters, regardless of what the underlying map
units are (e.g. they can be in inches, feet, geographic degrees, ...). The size in meters is calculated based on
the current project ellipsoid setting and a projection of the distances in meters at the center of the current
map extent. For maps in a projected coordinate system this is calculated using projected units. For maps
in a geographic (latitude/longitude) based system the size is approximated by calculating meter sizes using
ellipsoidal calculations for the vertical scale of the map.

and Map Units: The size is scaled according to the map view scale. Because this can lead to too big or too
small values, use the “ button next to the entry to constrain the size to a range of values based on:

— The Minimum scale and the Maximum scale: The value is scaled based on the map view scale until you
reach any of these scale limits. Out of the range of scale, the value at the nearest scale limit is kept.

— and/or The Minimum size and the Maximum size in mm: The value is scaled based on the map view scale
until it reaches any of these limits; Then the limit size is kept.

Adjust Scaling Range (]

Scale Range

Scale only within the Following map unit scale range

v Minimum scale | 1:50000 -
v Maximum scale |1:1000 -
Size Range

Scale only within the Following size range

| Minimum size | 1,20 mm :
¥ Maximum size | 5,00 mm -
@Help % Cancel

Puc. 12.25: Adjust scaling range dialog
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12.9.8 Number Formatting

Numeric formatters allow formatting of numeric values for display, using a variety of different formatting
techniques (for instance scientific notation, currency values, percentage values, etc). One use of this is to set text in
a layout scale bar or fixed table.

4| Number Format

Category Number -

4Pk

Round to 4
e Decimal places
Significant figures
¥| Show thousands separator
Show plus sign
Show trailing zeros
Thousands separator

Decimal separator

Sample
1234.56789123456 = 1 234.5679 D‘\

Puc. 12.26: Formatting numeric value

Different categories of formats are supported. For most of them, you can set part or all of the following numeric
options:

. & Show thousands separator
. Show plus sign

. Show trailing zeros
But they can also have their custom settings. Provided categories are:

* General, the default category: has no setting and displays values as set in the parent widget properties or using
the global settings.

e Number
— The value can be Round to a self defined number of Decimal places or their Significant figures
— customize the Thousands separator and Decimal separator

* Bearing for a text representation of a direction/bearing using:

— Format: possible ranges of valuesare 0 to 180°, with E/W suffix,-180 to +180° and
0 to 360°

— number of Decimal places
* Currency for a text representation of a currency value.
— Prefix
— Suffix
— number of Decimal places

* Fraction for a vulgar fractional representation of a decimal value (e.g. //2 instead of 0.5)

- Use unicode super/subscript to show. For example 2 instead of 1/2
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- Use dedicated Unicode characters
— customize the Thousands separator

Percentage - appends % to the values, with setting of’:
— number of Decimal places

— Scaling to indicate whether the actual values already represent percentages (then they will be kept as is)
or fractions (then they are converted)

Scientific notation in the form 2 . 56e+03. The number of Decimal places can be set.

A live preview of the settings is displayed under the Sample section.

12.9.9 Blending Modes

QGIS offers different options for special rendering effects with these tools that you may previously only know from
graphics programs. Blending modes can be applied on layers and features, and also on print layout items:

Normal: This is the standard blend mode, which uses the alpha channel of the top pixel to blend with the pixel
beneath it. The colors aren’t mixed.

Lighten: This selects the maximum of each component from the foreground and background pixels. Be aware
that the results tend to be jagged and harsh.

Screen: Light pixels from the source are painted over the destination, while dark pixels are not. This mode is
most useful for mixing the texture of one item with another item (such as using a hillshade to texture another
layer).

Dodge: Brighten and saturate underlying pixels based on the lightness of the top pixel. Brighter top pixels
cause the saturation and brightness of the underlying pixels to increase. This works best if the top pixels
aren’t too bright. Otherwise the effect is too extreme.

Addition: Adds pixel values of one item to the other. In case of values above the maximum value (in the case
of RGB), white is displayed. This mode is suitable for highlighting features.

Darken: Retains the lowest values of each component of the foreground and background pixels. Like lighten,
the results tend to be jagged and harsh.

Multiply: Pixel values of the top item are multiplied with the corresponding values for the bottom item. The
results are darker.

Burn: Darker colors in the top item cause the underlying items to darken. Burn can be used to tweak and
colorize underlying layers.

Overlay: Combines multiply and screen blending modes. Light parts become lighter and dark parts become
darker.

Soft light: Very similar to overlay, but instead of using multiply/screen it uses color burn/dodge. This is
supposed to emulate shining a soft light onto an image.

Hard light: Hard light is also very similar to the overlay mode. It’s supposed to emulate projecting a very
intense light onto an image.

Difference: Subtracts the top pixel from the bottom pixel, or the other way around, in order always to get a
positive value. Blending with black produces no change, as the difference with all colors is zero.

Subtract: Subtracts pixel values of one item from the other. In the case of negative values, black is displayed.
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Puc. 12.27: Examples of blend modes applied to a green feature over an orange

From top to bottom, left to right: Normal — Lighten, Screen, Dodge, Addition — Difference, Subtract — Darken, Multiply, Burn

— Overlay, Soft light, Hard light

When a layer is part of a group that renders layers as a group, additional blending modes are available for the
rendering. They provide methods to clip the render of one layer’s content by the content in a second «mask» layer.

Masked By Below: The output is the top pixel, where the opacity is reduced by that of the bottom pixel.
Mask Below: The output is the bottom pixel, where the opacity is reduced by that of the top pixel.

Inverse Masked By Below: The output is the top pixel, where the opacity is reduced by the inverse of the
bottom pixel.

Inverse Mask Below: The output is the bottom pixel, where the opacity is reduced by the inverse of the top
pixel.

Paint Inside Below: The top pixel is blended on top of the bottom pixel, with the opacity of the top pixel
reduced by the opacity of the bottom pixel.

Paint Below Inside: The bottom pixel is blended on top of the top pixel, with the opacity of the bottom pixel
reduced by the opacity of the top pixel.
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Puc. 12.28: Examples of blend clipping mode applied to top green layer in a group
A: Mask Below B: Masked By Below C: Paint Below Inside D: Inverse Mask Below E: Inverse Masked By Below F: Paint
Inside Below

12.9.10 Data defined override setup

Next to many options in the vector layer properties dialog or settings in the print layout, you will find a €

Data defined override

icon. Using expressions based on layer attributes or item settings, prebuilt or custom functions and

variables, this tool allows you to set dynamic values for parameters. When enabled, the value returned by this widget
is applied to the parameter regardless of its normal value (checkbox, textbox, slider...).

The data defined override widget

Clicking the €)' Dua defined override ji.on shows the following entries:

Description... that indicates if the option is enabled, which input is expected, the valid input type and the
current definition. Hovering over the widget also pops up this information.

Store data in the project: a button allowing the property to be stored using the Auxiliary Storage Properties
mechanism.

Field type: an entry to select from the layer’s fields that match the valid input type.

Color: when the widget is linked to a color property, this menu gives access to the colors defined as part of
the current project’s colors scheme.

Variable: a menu to access the available user-defined variables

Edit... button to create or edit the expression to apply, using the Expression String Builder dialog. To help you
correctly fill in the expression, a reminder of the expected output’s format is provided in the dialog.

Paste and Copy buttons.
Clear button to remove the setup.

For numeric and color properties, Assistant... to rescale how the feature data is applied to the property (more
details below)

Cosert: Use right-click to (de)activate the data override
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When the data-defined override option is set up correctly the icon is yellow \= or QE. If it is broken, the icon is

red @ or .

You can enable or disable a configured =/ Dua-defined override button by simply clicking the widget with the right
mouse button.

Using the data-defined assistant interface

When the € padetined overrde button is associated with a size, a rotation, an opacity or a color property, it has an

Assistant... option that helps you change how the data is applied to the parameter for each feature. The assistant
p psy g pp p

allows you to:

¢ Define the Input data, ie:
— Source: the attribute to represent, using a field or an € expression

|
— the range of values to represent: you can manually enter the values or use the fs Feich value range from layer
button to fill these fields automatically with the minimum and maximum values returned by the Source
expression applied to your data

. Apply transform curve: by default, output values (see below for setting) are applied to input features
following a linear scale. You can override this logic: enable the transform option, click on the graphic to add
break point(s) and drag the point(s) to apply a custom distribution.

¢ Define the Output values: the options vary according to the parameter to define. You can globally set:

for a color setting, the color ramp to apply to values and the single color to use for NULL values

for the others, the minimum and maximum values to apply to the selected property as well as the
size/angle/opacity value for ignored or NULL source features

for size properties, the Scale method of representation which can be Flannery, Exponential, Surface,
Radius or Linear

the Exponent to use for data scaling when the Scale method is of exponential type or when tweaking the
opacity

When compatible with the property, a live-update preview is displayed in the right-hand side of the dialog to help
you control the value scaling.
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@ @ Symbol size

Input QO 200
Source 123 passengers £ O i
£ O e
Values from 9.000000 N _
o O 800
to 2000.000000 f
() 1000
»  Apply transform curve O 1200
,_/‘0
-
g o Q 1400
| L O 1600
= 1800
Output onoo
Size from 1.000000 .
to 10.000000

Scale method  Flannery
Exponent
Size when NULL 0.000000

@Help ® Cancel |</OK|
Puc. 12.29: Scaling feature size based on passengers field’s value

The values presented in the varying size assistant above will set the size ,,Data-defined override* with:

[coalesce(scale_exp("passenqers", 9, 2000, 1, 10, 0.57), 0) }
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Level up with Expressions

13.1 Expressions

Based on layer data and prebuilt or user defined functions, Expressions offer a powerful way to manipulate attribute
value, geometry and variables in order to dynamically change the geometry style, the content or position of the label,
the value for diagram, the height of a layout item, select some features, create virtual field, ...

IIpumeuanue: A list of the default functions and variables for writing expressions can be found at List of functions,
with detailed information and examples.

13.1.1 The Expression string builder

Main dialog to build expressions, the Expression string builder is available from many parts in QGIS and, can
particularly be accessed when:

¢ clicking the 8 button;
e selecting features with the & setect By Expression.... o]
* editing attributes with e.g. the Field caleulator ¢, 5]
+ manipulating symbology, label or layout item parameters with the €l Data defined override 5] (see Data defined
override setup);
* building a geometry generator symbol layer;
¢ doing some geoprocessing.
The Expression builder dialog offers access to the:

¢ Expression tab which, thanks to a list of predefined functions, helps to write and check the expression to use;

 Function Editor tab which helps to extend the list of functions by creating custom ones.
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The Interface

The

Expression tab provides the main interface to write expressions using functions, layer fields and values. It

contains the following widgets:

Q;H

pression String Builder %

Expression Function Editor

=) Lol Q Searct

Featu

Preview: ‘BETHEL is a Census Area)
W' Copy Expression Value

group field

Aggregates ble-click to add field name to expression
Arrays
Color
Conditionals
Conversions
Date and Time Loading field values from WFS layers isn't

Fields and Values supported, e the layer is actually inserted, ie
when building queries.

on field name to open context menu
sample value loading options.

MNotes

{v v v v~

NULL
1231p
abe NAME_2
abc TYPE 2
* Files and Paths Values  ( Sea
v Fuzzy Matching
b ey All Unique 10 Samples
r Geometry Aleutians East =
» Map Layers Aleutians West
» Maps Anchorage
+ Math Bethel
» Operators Bristol Bay
* Rasters Denali
FoE Al * Record and Attributes Dillingham
- P SIS + String Fairbanks North Star
» Variables

Haines =

oK Cancel Help
Puc. 13.1: The Expression tab

¢ An expression editor area for typing or pasting expressions. Autocompletion is available to speed expression
writing:

— Corresponding variables, function names and field names to the input text are shown below: use the Up
and Down arrows to browse the items and press Tab to insert in the expression or simply click on the
wished item.

— Function parameters are shown while filling them.
QGIS also checks the expression rightness and highlights all the errors using:
— Underline: for unknown functions, wrong or invalid arguments;

— Marker: for every other error (eg, missing parenthesis, unexpected character) at a single location.

Coset: Document your expression with comments

When using complex expression, it is good practice to add text either as a multiline comment or inline
comments to help you remember.

/%
Labels each region with its highest (in altitude) airport (s)
and altitude, eg 'AMBLER : 264m' for the 'Northwest Artic' region
#/
with_variable (
'airport_alti', -- stores the highest altitude of the region
aggregate (
'airports',

'max',

"ELEV", —-- the field containing the altitude

—-— and limit the airports to the region they are within
filter := within( $geometry, geometry( @parent ) )

)y

(continues on next page)
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(IPOJIOJIKEHHE C MTPEbIAYLIEH CTPaHULIBI)
aggregate ( —— finds airports at the same altitude in the region
'airports',
'concatenate’,

"NAME",
filter := within( $geometry, geometry( @parent ) )
and "ELEV" = @airport_alti
)
[l ' « ' || Qairport_alti || 'm'
—-— using || allows regions without airports to be skipped

* Above the expression editor, a set of tools helps you:
_ D Clear the expression editor

— Create and manage user expressions
* Under the expression editor, you find:
— A set of basic operators to help you build the expression
— An indication of the expected format of output when you are data-defining feature properties

— A live Output preview of the expression (up to 60 characters), evaluated on the first feature of the Layer
by default. To view output preview text exceeding 60 characters, you can hover your cursor over the
text to display a tooltip pop-up containing the entire output preview. To copy the output preview text

onto your clipboard, right-click on the output preview text and select Copy Expression Value.

You can browse and evaluate other features of the layer using the Feature combobox (the values are
taken from the display name property of the layer).

In case of error, it indicates it and you can access the details with the provided hyperlink.

¢ A function selector displays the list of functions, variables, fields... organized in groups. A search box is
available to filter the list and quickly find a particular function or field. Double-clicking an item adds it to
the expression editor.

* A help panel displays help for each selected item in the function selector.

CoBer: Press Ctr1+C1lick when hovering a function name in an expression to automatically display its
help in the dialog.

A field’s values widget shown when a field is selected in the function selector helps to fetch features attributes:
— Look for a particular field value
— Display the list of All Unique or 10 Samples values. Also available from right-click.

When the field is mapped with another layer or a set of values, i.e. if the field widget is of
RelationReference, ValueRelation or ValueMap type, it’s possible to list all the values of the mapped

field (from the referenced layer, table or list). Moreover, you can filter this list to Cif Only show values
in use in the current field.

Double-clicking a field value in the widget adds it to the expression editor.

Coset: The right panel, showing functions help or field values, can be collapsed (invisible) in the dialog.
Press the Show Values or Show Help button to get it back.
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Writing an expression

QGIS expressions are used to select features or set values. Writing an expression in QGIS follows some rules:

1.

The dialog defines the context: if you are used to SQL, you probably know queries of the type select features
from layer where condition or update layer set field = new_value where condition. A QGIS expression also
needs all these information but the tool you use to open the expression builder dialog provides parts of them.
For example, giving a layer (buildings) with a field (height):

e pressing the & )setec by expression 0] means that you want to «select features from buildings». The
condition is the only information you need to provide in the expression text widget, e.g. type
"height" > 20 to select buildings that are higher than 20.

 with this selection made, pressing the Field caleulator bytton and choosing «height» as Update existing
field, you already provide the command «update buildings set height = ??? where height > 20». The only
remaining bits you have to provide in this case is the new value, e.g. just enter 50 in the expression
editor textbox to set the height of the previously selected buildings.

. Pay attention to quotes: single quotes return a literal, so a text placed between single quotes ('145") is

interpreted as a string. Double quotes will give you the value of that text so use them for fields ("myfield").
Fields can also be used without quotes (myfield). No quotes for numbers (3.16).

IIpumeuanne: Functions normally take as argument a string for field name. Do:

attribute ( @atlas_feature, 'height' ) —-—- returns the value stored in the
—"height" attribute of the current atlas feature

And not:
attribute ( @atlas_feature, "height" ) —-- fetches the value of the attribute.
—named "height" (e.g. 100), and use that value as a field

—— from which to return the atlas.
—feature value. Probably wrong as a field named "100" may not exist.

Coset: Use named parameters to ease expression reading

Some functions require many parameters to be set. The expression engine supports the use of named parameters.
This means that instead of writing the cryptic expression clamp ( 1, 2, 9),youcanuse clamp( min:=1,
value:=2, max:=9). This also allows arguments to be switched, e.g. clamp ( value:=2, max:=9,
min:=1). Using named parameters helps clarify what the arguments for an expression function refer to, which is
helpful when you are trying to interpret an expression later!

Some use cases of expressions

¢ From the Field Calculator, calculate a «pop_density» field using the existing «total_pop» and «area_km2»

fields:

["totalfpop" / "area_km2"

 Label or categorize features based on their area:

[CASE WHEN S$area > 10 000 THEN 'Larger' ELSE 'Smaller' END

» Update the field «density_level» with categories according to the «pop_density» values:
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CASE WHEN "pop_density" < 50 THEN 'Low population density'

WHEN "pop_density" >= 50 and "pop_density" < 150 THEN 'Medium population.
—density'

WHEN "pop_density" >= 150 THEN 'High population density'
END

* Apply a categorized style to all the features according to whether their average house price is smaller or higher
than 10000€ per square metre:

["price_mZ" > 10000 }

e Using the «Select By Expression...» tool, select all the features representing areas of “High population
density” and whose average house price is higher than 10000€ per square metre:

["densityflevel" = 'High population density' and "price_m2" > 10000 }

The previous expression could also be used to define which features to label or show on the map.

* Create a different symbol (type) for the layer, using the geometry generator:

[point_on_surface( Sgeometry ) J

* Given a point feature, generate a closed line (using make_1ine) around its geometry:

s 2}

make_line (
—-— using an array of points placed around the original
array_foreach (
—— list of angles for placing the projected points (every 90°)
array:=generate_series( 0, 360, 90 ),
—— translate the point 20 units in the given direction (angle)
expression:=project ( Sgeometry, distance:=20, azimuth:=radians( @element ).

* In a print layout label, display the name of the «airports» features that are within the layout «Map 1» item:

with_variable( 'extent',
map_get ( item_variables( 'Map 1' ), 'map_extent' ),
aggregate ( 'airports', 'concatenate', "NAME",

intersects( $geometry, @extent ), ' ,'

Saving Expressions

Using the Add current expression to user expressions hytton above the expression editor frame, you can save important
expressions you want to have quick access to. These are available from the User expressions group in the middle
panel. They are saved under the user profile (<userprofile>/QGIS/QGIS3.ini file) and available in all
expression dialogs inside all projects of the current user profile.

A set of tools available above the expression editor frame helps you manage the user expressions:

Addth t expression to us ssions Lo :

o ] © current expression fo user expressions: store the expression in the user profile. A label and a help text can be
added for easy identification.

o | i Editselected expression from user expresslons, as well as their help and label

-
. n]] Remove selected expression from user expressions
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. i- Import user expressions from 3 . §son file into the active user profile folder

o e BXPOTtUSCT eXpreSsions 5 5 5 5o file; all the user expressions in the user profile 0GIS3 . ini file are shared

13.1.2 Function Editor

With the Function Editor tab, you are able to write your own functions in Python language. This provides a handy
and comfortable way to address particular needs that would not be covered by the predefined functions.

airports — Select by Expression .

Expression | Function Editor

from-qgis.core -import -*
from-qgis.gui import -*

B default

1

2

3

4 @qgsfunction(args='auto', -group='Custom')

5 —def-my sum(valuel, -value2, -feature, parent):
[

7

8

9

10
11
12
13
14 return-valuel -+ -value2
4 3
» Save and Load Functions
o | | = b Help
@Help Zoom to Features | | & Select Features |» Close

Puc. 13.2: The Function Editor tab

To create a new function:

1. Press the o New it button.
2. Enter a name to use in the form that pops up and press OK.

A new item of the name you provide is added in the left panel of the Function Editor tab; this is a Python . py
file based on QGIS template file and stored in the /python/expressions folder under the active user
profile directory.

3. Theright panel displays the content of the file: a python script template. Update the code and its help according
to your needs.

4. Press the > Save and Load Functions button. The function you wrote is added to the functions tree in the
Expression tab, by default under the Custom group.

5. Enjoy your new function.

6. If the function requires improvements, enable the Function Editor tab, do the changes and press again the >
Save and Load Functions button to make them available in the file, hence in any expression tab.

Custom Python functions are stored under the user profile directory, meaning that at each QGIS startup, it will
auto load all the functions defined with the current user profile. Be aware that new functions are only saved in the
/python/expressions folder and not in the project file. If you share a project that uses one of your custom
functions you will need to also share the . py file in the /python/expressions folder.

To delete a custom function:
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1. Enable the Function Editor tab

2. Select the function in the list

3. Press the — Remove sclected function The fyunction is removed from the list and the corresponding . py file deleted
from the user profile folder.

Example

Here’s a short example on how to create your own my_ sum function that will operate with two values.

from ggis.core import *
from ggis.gui import *

@ggsfunction (args='auto', group='Custom')
def my_sum(valuel, value2, feature, parent):
Calculates the sum of the two parameters valuel and valuel.
<h2>Example usage:</h2>
<ul>
<li>my_sum(5, 8) —-> 13</1i>
<li>my_sum("fieldl", "field2") -> 42</1i>
</ul>

mn

return valuel + value2

The @ggsfunction decorator accepts the following arguments:

e args: the number of arguments. When using the args='auto' argument the number of function
arguments required will be calculated by the number of arguments the function has been defined with in
Python (minus 2 - feature, and parent). With args = -1, any number of arguments are accepted.

* The group argument indicates the group in which the function should be listed in the Expression dialog.
e usesgeometry=True if the expression requires access to the features geometry. By default False.

* handlesnull=True if the expression has custom handling for NULL values. If False (default), the
result will always be NULL as soon as any parameter is NULL.

e referenced_columns=[1list]:Anarray of attribute names that are required to the function. Defaults
to [QgsFeatureRequest .ALL_ATTRIBUTES].

The function itself allows following arguments:
¢ any number and type of parameters you want to pass to your function, set before the following arguments.
e feature: the current feature
e parent:the OgsExpression object

e context: If there is an argument called context found at the last position, this variable will contain
a QgsExpressionContext object, that gives access to various additional information like expression
variables. E.g. context.variable( 'layer_id' )

The previous example function can then be used in expressions:
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airports — Select by Expression A

Expression | Function Editor

a8 L)L Q Search... my_sum function
my_sum{ . ) = 1lee » Aggregates -
: '2;2};5 Calculates the sum of the two parameters
v Conditionals valuel and value2.
» Conversions Example usage:
a * my_sum(5, 8) -> 13
» Date and Time * my_sum("field1", "field2") -> 42
} Fields and Values
E] w0z =2 0ull el N » Files and Paths
» Fuzzy Makching
Feature | BIG LAKE ~|| 4[| » General
. » Geometry
Preview: 1 » e -
@Help Zoom to Features | | &1 Select Features |~ Close

Puc. 13.3: Custom Function added to the Expression tab

Further information about creating Python code can be found in the PyQGIS-Developer-Cookbook.

13.2 List of functions

The functions, operators and variables available in QGIS are listed below, grouped by categories.

13.2.1 Aggregates Functions

This group contains functions which aggregate values over layers and fields.

aggregate

Returns an aggregate value calculated using features from another layer.
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Syntax aggregate(layer, aggregate, expression, [filter], [concatenator="“], [order_by])
[] marks optional arguments
Arguments * layer - a string, representing either a layer name or layer ID
* aggregate - a string corresponding to the aggregate to calculate. Valid options are:

— count
— count_distinct
— count_missing
— min
— max
— sum
— mean
— median
— stdev
— stdevsample
— range
— minority
— majority
— ql: first quartile
— q3: third quartile
— iqr: inter quartile range
— min_length: minimum string length
— max_length: maximum string length
— concatenate: join strings with a concatenator
— concatenate_unique: join unique strings with a concatenator
— collect: create an aggregated multipart geometry
— array_agg: create an array of aggregated values

 expression - sub expression or field name to aggregate

« filter - optional filter expression to limit the features used for calculating the aggregate.
Fields and geometry are from the features on the joined layer. The source feature can be
accessed with the variable @parent.

e concatenator - optional string to use to join values for ,concatenate and
,concatenate_unique* aggregates

* order_by - optional filter expression to order the features used for calculating the
aggregate. Fields and geometry are from the features on the joined layer. By default,
the features will be returned in an unspecified order.

Examples , ,

* aggregate(layer:='rail_ stations', aggregate:='sum',
expression:="passengers") — sum of all values from the passengers
field in the rail_stations layer

e aggregate ('rail_stations', 'sum', "passengers"/7) — calculates a
daily average of «passengers» by dividing the «passengers» field by 7 before summing
the values

* aggregate (layer:="'rail_stations', aggregate:='sum',
expression:="passengers",filter:="class">3) — sums up all
values from the «passengers» field from features where the «class» attribute is greater
than 3 only

* aggregate (layer:='rail_stations', aggregate:='concatenate',
expression:="name", concatenator:=',') — comma separated list of
the name field for all features in the rail_stations layer

* aggregate (layer:='countries', aggregate:='max',
expression:="code", filter:=intersects ( @geometry,
geometry (@parent) ) ) — The country code of an intersecting country
on the layer ,,countries*

* aggregate (layer:="'rail_stations', aggregate:='sum',
expression:="passengers",filter:=contains (
@atlas_geometry, Qgeometry ) ) — sum of all values from the passengers
field in the rail_stations within the current atlas feature

e aggregate(layer:="'rail stations', aggregate:='collect',
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array_agg

Returns an array of aggregated values from a field or expression.

Syntax array_agg(expression, [group_by], [filter], [order_by])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate

 group_by - optional expression to use to group aggregate calculations

« filter - optional expression to use to filter features used to calculate aggregate

* order_by - optional expression to use to order features used to calculate aggregate. By
default, the features will be returned in an unspecified order.

Examples :
e array_agg ("name", group_by:="state") — list of name values, grouped by

state field

collect

Returns the multipart geometry of aggregated geometries from an expression

Syntax collect(expression, [group_by], [filter])
[] marks optional arguments
Arguments . .
* expression - geometry expression to aggregate
* group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples . .
e collect ( @geometry ) — multipart geometry of aggregated geometries
e collect ( centroid(Q@Rgeometry), group_by:="region", filter:=
"use" = 'civilian' ) — aggregated centroids of the civilian features based on
their region value
concatenate

Returns all aggregated strings from a field or expression joined by a delimiter.

Syntax concatenate(expression, [group_by], [filter], [concatenator], [order_by])
[] marks optional arguments

Arguments . :
=  expression - sub expression of field to aggregate

¢ group_by - optional expression to use to group aggregate calculations

« filter - optional expression to use to filter features used to calculate aggregate

* concatenator - optional string to use to join values. Empty by default.

 order_by - optional expression to use to order features used to calculate aggregate. By
default, the features will be returned in an unspecified order.

Examples ° n n =N " P |
concatenate ("town_name", group_by: state", concatenator: o

') — comma separated list of town_names, grouped by state field
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concatenate_unique

Returns all unique strings from a field or expression joined by a delimiter.

Syntax concatenate_unique(expression, [group_by], [filter], [concatenator], [order_by])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate

 group_by - optional expression to use to group aggregate calculations

« filter - optional expression to use to filter features used to calculate aggregate

* concatenator - optional string to use to join values. Empty by default.

¢ order_by - optional expression to use to order features used to calculate aggregate. By
default, the features will be returned in an unspecified order.

Examples :
* concatenate_unique ("town_name", group_by:="state",

concatenator:="', ') — comma separated list of unique town_names, grouped by
state field

count

Returns the count of matching features.

Syntax count(expression, [group_by], [filter])
[] marks optional arguments
Arguments . . .
* expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

e count ("stations",group_by:="state") — count of stations, grouped by
state field

count_distinct

Returns the count of distinct values.

Syntax count_distinct(expression, [group_by], [filter])
[] marks optional arguments
A t
MRS  expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

e count_distinct ("stations",group_by:="state") — count of distinct
stations values, grouped by state field
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count_missing

Returns the count of missing (NULL) values.

Syntax count_missing(expression, [group_by], [filter])
[] marks optional arguments
Arguments . .
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples , ) , L.
e count_missing("stations",group_by:="state") — count of missing
(NULL) station values, grouped by state field
iqr

Returns the calculated inter quartile range from a field or expression.

Syntax igr(expression, [group_by], [filter])
[] marks optional arguments
Arguments . . 5
 expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples ) , . .
e igr ("population",group_by:="state") — inter quartile range of
population value, grouped by state field
majority

Returns the aggregate majority of values (most commonly occurring value) from a field or expression.

Syntax majority(expression, [group_by], [filter])
[] marks optional arguments
Arguments
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

* majority ("class",group_by:="state") — most commonly occurring class
value, grouped by state field
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max_length

Returns the maximum length of strings from a field or expression.

Syntax max_length(expression, [group_by], [filter])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate

 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate

Examples .
* max_length ("town_name", group_by:="state") — maximum length of

town_name, grouped by state field
maximum

Returns the aggregate maximum value from a field or expression.

Syntax maximum(expression, [group_by], [filter])
[] marks optional arguments
Arguments . . 5
 expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples , ) . .
e maximum ("population", group_by:="state") — maximum population
value, grouped by state field
mean

Returns the aggregate mean value from a field or expression.

Syntax mean(expression, [group_by], [filter])
[] marks optional arguments
Arguments
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples ) .
* mean ("population", group_by:="state") — mean population value,
grouped by state field
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median

Returns the aggregate median value from a field or expression.

Syntax median(expression, [group_by], [filter])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate

 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate

Examples ) ) . .
e median ("population", group_by:="state") — median population value,

grouped by state field
min_length

Returns the minimum length of strings from a field or expression.

Syntax min_length(expression, [group_by], [filter])
[] marks optional arguments
Arguments . . 5
 expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples , .
e min_length ("town_name",group_by:="state") — minimum length of
town_name, grouped by state field
minimum

Returns the aggregate minimum value from a field or expression.

Syntax minimum(expression, [group_by], [filter])
[] marks optional arguments
Arguments
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

e minimum ("population", group_by:="state") — minimum population
value, grouped by state field
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minority

Returns the aggregate minority of values (least occurring value) from a field or expression.

Syntax minority(expression, [group_by], [filter])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate

 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate

Examples ) ) .
e minority ("class",group_by:="state") — least occurring class value,

grouped by state field
q1

Returns the calculated first quartile from a field or expression.

Syntax ql(expression, [group_by], [filter])
[] marks optional arguments

Arguments . . 5
 expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples , . . .
* gl ("population",group_by:="state") — first quartile of population value,
grouped by state field
q3

Returns the calculated third quartile from a field or expression.

Syntax q3(expression, [group_by], [filter])
[] marks optional arguments
A t
e  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

* g3 ("population", group_by:="state") — third quartile of population value,
grouped by state field
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range

Returns the aggregate range of values (maximum - minimum) from a field or expression.

Syntax range(expression, [group_by], [filter])
[] marks optional arguments

Arguments . .
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples

e range ("population",group_by:="state") — range of population values,
grouped by state field

relation_aggregate

Returns an aggregate value calculated using all matching child features from a layer relation.
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Syntax relation_aggregate(relation, aggregate, expression, [concatenator="“], [order_by])
[] marks optional arguments
Arguments . . . .
* relation - a string, representing a relation ID
* aggregate - a string corresponding to the aggregate to calculate. Valid options are:
— count
— count_distinct
— count_missing
— min
— max
— sum
— mean
— median
— stdev
— stdevsample
— range
— minority
— majority
— ql: first quartile
— q3: third quartile
— iqr: inter quartile range
— min_length: minimum string length
— max_length: maximum string length
— concatenate: join strings with a concatenator
— concatenate_unique: join unique strings with a concatenator
— collect: create an aggregated multipart geometry
— array_agg: create an array of aggregated values
¢ expression - sub expression or field name to aggregate
* concatenator - optional string to use to join values for ,,concatenate® aggregate
 order_by - optional expression to order the features used for calculating the aggregate.
Fields and geometry are from the features on the joined layer. By default, the features
will be returned in an unspecified order.
Examples

* relation_aggregate (relation:="'my_relation',
aggregate:="'mean', expression:="passengers") — mean value of
all matching child features using the ,,my_relation® relation

e relation_aggregate ('my_relation', 'sum', "passengers"/7) —
sum of the passengers field divided by 7 for all matching child features using the
»my_relation” relation

* relation_aggregate ('my_relation', 'concatenate’, "towns",
concatenator:="', ') — comma separated list of the towns field for all matching
child features using the ,,my_relation” relation

e relation_aggregate ('my_relation', "array_agg', "id") — arrayof
the id field from all matching child features using the ,,my_relation® relation

Further reading: Setting relations between multiple layers
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stdev

Returns the aggregate standard deviation value from a field or expression.

Syntax stdev(expression, [group_by], [filter])
[] marks optional arguments
Arguments
.  expression - sub expression of field to aggregate
 group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples ) ..
e stdev ("population",group_by:="state") — standard deviation of
population value, grouped by state field
sum

Returns the aggregate summed value from a field or expression.

Syntax sum(expression, [group_by], [filter])
[] marks optional arguments
Arguments . . 5
 expression - sub expression of field to aggregate
» group_by - optional expression to use to group aggregate calculations
« filter - optional expression to use to filter features used to calculate aggregate
Examples , .
e sum("population", group_by:="state") — summed population value,
grouped by state field

13.2.2 Array Functions
This group contains functions to create and manipulate arrays (also known as list data structures). The order of

values within the array matters, unlike the ,map“data structure, where the order of key-value pairs is irrelevant and
values are identified by their keys.

array

Returns an array containing all the values passed as parameter.

Syntax array(valuel, value2, ...)

Arguments
¢ value - a value

E 1
xamples e array(2,10) —»[2,10]

e array(2,10) [0] =2
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array_all

Returns TRUE if an array contains all the values of a given array.

Syntax array_all(array_a, array_b)

Argumen
IS e array_a - an array

e array_b - the array of values to search

Examples

e array_all (array(1,2,3),array(2,3)) —» TRUE
e array_all (array(1,2,3),array(1,2,4)) —» FALSE

array_append

Returns an array with the given value added at the end.

Syntax array_append(array, value)

Argumen
gu & e array - an array

¢ value - the value to add

Examples

e array_append (array(1,2,3),4) —»[1,2,3,4]

array_cat

Returns an array containing all the given arrays concatenated.

Syntax array_cat(arrayl, array?2, ...)

Arguments
g e array - an array

Examples

e array_cat (array(1,2),array(2,3)) —»[1,2,2,3]

array_contains

Returns TRUE if an array contains the given value.

Syntax array_contains(array, value)

Arguments
g e array - an array

¢ value - the value to search

Examples

* array_contains (array(1,2,3),2) - TRUE
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array_count

Counts the number of occurrences of a given value in an array.

Syntax array_count(array, value)

Argumen
IS e array - an array

¢ value - the value to count

Examples
e array_count (array('a', 'b', 'c', 'b'), 'b') 52

array_distinct

Returns an array containing distinct values of the given array.

Syntax array_distinct(array)

Arguments
g e array - an array

Examples
p e array_distinct (array(1,2,3,2,1)) »[1,2,3]

array_filter

Returns an array with only the items for which the expression evaluates to true.

Syntax array_filter(array, expression, [limit=0])
[] marks optional arguments
AU e array - an array
* expression - an expression to evaluate on each item. The variable @element will be
replaced by the current value.
¢ limit - maximum number of elements to be returned. Use O to return all values.
Examples .
e array_filter (array(1,2,3),Qelement < 3) »[1,2]
e array_filter (array(1,2,3),Qelement < 3, 1) > [1]
array_find

Returns the lowest index (O for the first one) of a value within an array. Returns -1 if the value is not found.

Syntax array_find(array, value)

Arguments
g e array - an array

¢ value - the value to search

Examples ,
e array_find(array('a', 'b', 'c'), 'b') —>1
e array_find(array('a', 'b', 'c', 'b'), 'b') —>1
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array_first

Returns the first value of an array.

Syntax array_first(array)

Argumen
ERE e array - an array

Examples «

e array_first (array('a','b','c')) —,a

array_foreach

Returns an array with the given expression evaluated on each item.

Syntax array_foreach(array, expression)

Arguments
g e array - an array

e expression - an expression to evaluate on each item. The variable @element will be
replaced by the current value.

Examples v e
e array_foreach (array('a','b', 'c'),upper (Qelement)) —[,A" B
2C¢1
e array_foreach (array(1,2,3),Qelement + 10) —[11,12,13]
array_get

Returns the Nth value (0 for the first one) or the last -Nth value (-1 for the last one) of an array.

Syntax array_get(array, pos)

Argumen
FIIIE e array - an array

* pos - the index to get (0 based)

Examples “«
e array_get (array('a', 'b','c"'),1) —.,b

e array_get (array('a', 'b','c'),-1) —,c“

IMoackaska: You can also use the index operator ([]) to get a value from an array.
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array_insert

Returns an array with the given value added at the given position.

Syntax array_insert(array, pos, value)

Argumen
IS e array - an array

* pos - the position where to add (0 based)
* value - the value to add

E 1
xampres e array_insert (array(1,2,3),1,100) —[1,100,2,3 ]

array_intersect

Returns TRUE if at least one element of arrayl exists in array?2.

Syntax array_intersect(arrayl, array2)

Arguments
e arrayl - an array

e array2 - another array

Examples
P e array_intersect (array(1,2,3,4),array(4,0,2,5)) - TRUE

array_last

Returns the last value of an array.

Syntax array_last(array)

Arguments
g e array - an array

Examples
* array_last (array('a','b','c')) —,C

array_length

Returns the number of elements of an array.

Syntax array_length(array)

Arguments
g e array - an array

Examples
e array_length (array(1,2,3)) —3
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array_majority

Returns the most common values in an array.

Syntax array_majority(array, [option="all“])
[] marks optional arguments
Arguments * array - an array
¢ option=*“all* - a string specifying the return values handling. Valid options are:
— all: Default, all most common values are returned in an array.
— any: Returns one of the most common values.
— median: Returns the median of the most common values. Non arithmetic values are
ignored.
— real_majority: Returns the value which occurs more than half the size of the array.
Examples .
e array_majority(array(0,1,42,42,43), 'all') —»[42]
e array_majority(array(0,1,42,42,43,1), 'all') —[42,1]
e array_majority(array(0,1,42,42,43,1), 'any') — 1lor42
e array_majority(array(0,1,1,2,2), 'median') — 1.5
* array_majority (array(0,1,42,42,43), 'real_majority') —
NULL
* array_majority (array(0,1,42,42,43,42), 'real_majority') —
NULL
e array_majority(array(0,1,42,42,43,42,42), 'real_majority"')
—42
array_max

Returns the maximum value of an array.

Syntax array_max(array)

Arguments
g e array - an array

Examples
e array_max (array(0,42,4,2)) —»42

array_mean

Returns the mean of arithmetic values in an array. Non numeric values in the array are ignored.

Syntax array_mean(array)

Arguments
g e array - an array

Examples
e array_mean (array(0,1,7,66.6,135.4)) —»42

e array_mean (array(0,84,'a','b','c")) —»42
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array_median

Returns the median of arithmetic values in an array. Non arithmetic values in the array are ignored.

Syntax array_median(array)
Arguments e array - an array
Examples .
e array_median (array (0,1,42,42,43)) > 42
e array_median (array(0,1,2,42,'a','b')) > 1.5
array_min

Returns the minimum value of an array.

Syntax array_min(array)

Arguments
g e array - an array

Examples .
e array_min (array (43,42,54)) —»42

array_minority

Returns the less common values in an array.

Syntax array_minority(array, [option="all“])
[] marks optional arguments
AU e array - an array
* option=*“all* - a string specifying the return values handling. Valid options are:

— all: Default, all less common values are returned in an array.

— any: Returns one of the less common values.

— median: Returns the median of the less common values. Non arithmetic values are

ignored.

— real_minority: Returns values which occur less than half the size of the array.

Examples

e array_minority(array(0,42,42), 'all') —»[0]

e array_minority(array(0,1,42,42), 'all') —»[0,1]

e array_minority(array(0,1,42,42,43,1), 'any') —»0or43

e array_minority(array(1,2,3,3), 'median') — 1.5

e array_minority(array(0,1,42,42,43), 'real_minority') —[42,

43,0, 1]

e array_minority (array (0,1,42,42,43,42), 'real_minority') — [
42,43,0,1 ]

e array_minority (array(0,1,42,42,43,42,42), 'real minority')
—[43,0,1]
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array_prepend

Returns an array with the given value added at the beginning.

Syntax array_prepend(array, value)

Argumen
IS e array - an array

 value - the value to add

E 1
xampres e array_prepend (array(1,2,3),0) =[0,1,2,3]

array_prioritize

Returns an array sorted using the ordering specified in another array. Values which are present in the first array but
are missing from the second array will be added to the end of the result.

Syntax array_prioritize(array, array_prioritize)

Arguments
g e array - an array

* array_prioritize - an array with values ordered by priority

E 1
xampiles * array_prioritize(array(l, 8, 2, 5), array(5, 4, 2, 1, 3,

8)) —=1[5,2,1,8]
* array_prioritize (array(5, 4, 2, 1, 3, 8), array(l, 8, o,
5)) —>[1,8,5,4,2,3]

array_remove_all

Returns an array with all the entries of the given value removed.

Syntax array_remove_all(array, value)

Arguments
g e array - an array

¢ value - the values to remove

Examples o«
e array_remove_all (array('a','b','c','b"),'b") = [,a% ,c“]

array_remove_at

Returns an array with the item at the given index removed. Supports positive (0 for the first element) and negative
(the last -Nth value, -1 for the last element) index.
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Syntax array_remove_at(array, pos)

Arguments

array - an array

* pos - the position to remove (0 based)

Examples

array_remove_at (array (1, 2, 3), 1) —[1,3]
array_remove_at (array (1, 2, 3), -1) —[1,2]

array_replace

Returns an array with the supplied value, array, or map of values replaced.

Value & array variant

Returns an array with the supplied value or array of values replaced by another value or an array of values.

Syntax array_replace(array, before, after)

Arguments

Examples

array - the input array
before - the value or array of values to replace
after - the value or array of values to use as a replacement

array_replace(array ('QGIS', 'SHOULD', '"ROCK"'), 'SHOULD',
'DOES') — [,,QGISY, ,DOES*, ,ROCK* ]

array_replace (array(3,2,1),array(1,2,3),array(7,8,9)) —»[9,
8,71

array_replace (array ('Q','G','I','S'"),array('Q','S"),'-") —
Ler™s oG5 6% o |

Map variant

Returns an array with the supplied map keys replaced by their paired values.

Syntax array_replace(array, map)

Arguments

Examples

array - the input array
map - the map containing keys and values

array_replace (array ('APP', 'SHOULD ', 'ROCK"'") ,map ("'APP',
'QGIS', 'SHOULD', 'DOES'")) — [,QGIS*, ,DOES*, ,ROCK* ]

array_reverse

Returns the given array with array values in reversed order.

Syntax array_reverse(array)

Arguments

Examples

array - an array

e array_reverse (array(2,4,0,10)) —»[10,0,4,2]
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array_slice

Returns a portion of the array. The slice is defined by the start_pos and end_pos arguments.

Syntax array_slice(array, start_pos, end_pos)

Argumen
IS e array - an array

* start_pos - the index of the start position of the slice (0 based). The start_pos index is
included in the slice. If you use a negative start_pos, the index is counted from the end
of the list (-1 based).

* end_pos - the index of the end position of the slice (0 based). The end_pos index is
included in the slice. If you use a negative end_pos, the index is counted from the end of
the list (-1 based).

Examples e array_slice (array(1,2,3,4,5),0,3) =[1,2,3,4]

e array_slice(array(1,2,3,4,5),0,-1) =»[1,2,3,4,5]

e array_slice(array(1,2,3,4,5),-5,-1) —»[1,2,3,4,5]

e array_slice(array(1,2,3,4,5),0,0) =»[1]

e array_slice(array(1,2,3,4,5),-2,-1) - [4,5]

e array_slice(array(1,2,3,4,5),-1,-1) =»[5]

e array_slice(array ('Dufour', 'Valmiera', 'Chugiak’',
'Brighton'),1,2) — [, Valmiera®, ,,Chugiak® ]

e array_slice(array ('Dufour', 'Valmiera', 'Chugiak’',
'Brighton'),-2,-1) — [ ,,Chugiak®, ,Brighton“ ]

array_sort

Returns the provided array with its elements sorted.

Syntax array_sort(array, [ascending=true])
[] marks optional arguments
Arguments e array - an array
 ascending - set this parameter to false to sort the array in descending order
Examples
p e array_sort (array(3,2,1)) —»[1,2,3]
array_sum

Returns the sum of arithmetic values in an array. Non numeric values in the array are ignored.

Syntax array_sum(array)

Arguments
g e array - an array

E 1
Xamples * array_sum(array(0,1,39.4,1.6,"'a")) —»42.0
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array_to_string

Concatenates array elements into a string separated by a delimiter and using optional string for empty values.

Syntax array_to_string(array, [delimiter=",“], [empty_value="“])
[] marks optional arguments

Arguments .

e array - the input array

* delimiter - the string delimiter used to separate concatenated array elements

* empty_value - the optional string to use as replacement for empty (zero length) matches
Examples

e array_to_string(array('1','2','3")) —,1,2,3¢
e array_to_string(array(1,2,3),'-") —,1-2-3%
e array_to_string(array('1','','3"),',','0") —»,1,0,3¢

generate_series

Creates an array containing a sequence of numbers.

Syntax generate_series(start, stop, [step=1])
[] marks optional arguments
Arguments
2 * start - first value of the sequence
* stop - value that ends the sequence once reached
* step - value used as the increment between values
Examples
p * generate_series(1,5) —»[1,2,3,4,5]
e generate_series (5,1,-1) —»[5,4,3,2,1]

geometries_to_array

Splits a geometry into simpler geometries in an array.

Syntax geometries_to_array(geometry)

Arguments .
* geometry - the input geometry

Examples . ;
* geometries_to_array (geom_from wkt ('GeometryCollection

(Polygon ((5 8, 4 1, 3 2, 5 8)),LineString (3 2, 4
2))')) — an array of a polygon and a line geometries

e geom_to_wkt (geometries_to_array (geom_from_wkt ('GeometryCollection

(Polygon ((58, 41, 32, 58)),LineString (3 2, 4 2)) ")) [0])
— ,Polygon ((5§ 8,4 1,32,5 8))“

* geometries_to_array(geom_from wkt ("MULTIPOLYGON(((5 5,0 O,
0 10,5 5)), ((5 5,10 10,10 0,5 5))"')) — an array of two polygon
geometries
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regexp_matches

Returns an array of all strings captured by capturing groups, in the order the groups themselves appear in the supplied
regular expression against a string.

Syntax regexp_matches(string, regex, [empty_value="“])
[] marks optional arguments
Arguments . . . .
* string - the string to capture groups from against the regular expression
* regex - the regular expression used to capture groups
» empty_value - the optional string to use as replacement for empty (zero length) matches
Examples

* regexp_matches ('QGIS=>rocks', ' (.*)=>(.*)") — [,QGIS*, ,rocks“ ]
* regexp_matches ('key=>"',"'(.*)=>(.*)"', 'empty value') — [ .key“
»~empty value® |

string_to_array

Splits string into an array using supplied delimiter and optional string for empty values.

Syntax string_to_array(string, [delimiter=",“], [empty_value="“])
[] marks optional arguments
Arguments . . .
* string - the input string
¢ delimiter - the string delimiter used to split the input string
¢ empty_value - the optional string to use as replacement for empty (zero length) matches
Examples

* string_to_array('1,2,3',"',") - [,1%,2%,3“]
e string_to_array('1,,3',',','0") = [,1%,0% ,3“]

13.2.3 Color Functions

This group contains functions for manipulating colors.

color_cmyk

Returns a string representation of a color based on its cyan, magenta, yellow and black components

Syntax color_cmyk(cyan, magenta, yellow, black)

Arguments .
= * cyan - cyan component of the color, as a percentage integer value from 0 to 100

* magenta - magenta component of the color, as a percentage integer value from 0 to 100
* yellow - yellow component of the color, as a percentage integer value from 0 to 100
¢ black - black component of the color, as a percentage integer value from O to 100

Examples “
e color_cmyk (100,50,0,10) —,0,115,230
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color_cmyka

Returns a string representation of a color based on its cyan, magenta, yellow, black and alpha (transparency)
components

Syntax color_cmyka(cyan, magenta, yellow, black, alpha)

Arguments .
S * cyan - cyan component of the color, as a percentage integer value from 0 to 100

* magenta - magenta component of the color, as a percentage integer value from 0 to 100
* yellow - yellow component of the color, as a percentage integer value from 0 to 100

* black - black component of the color, as a percentage integer value from O to 100

« alpha - alpha component as an integer value from 0 (completely transparent) to 255

(opaque).

E It
xamples  color_cmyka (100,50,0,10,200) —,0,115,230,200%

color_grayscale_average

Applies a grayscale filter and returns a string representation from a provided color.

Syntax color_grayscale_average(color)

Arguments .
¢ color - a color string

E 1
xampies * color_grayscale_average ('255,100,50"') — ,135,135,135,255“

color_hsl

Returns a string representation of a color based on its hue, saturation, and lightness attributes.

Syntax color_hsl(hue, saturation, lightness)

A t
rguments * hue - hue of the color, as an integer value from 0 to 360

* saturation - saturation percentage of the color as an integer value from 0 to 100
* lightness - lightness percentage of the color as an integer value from O to 100

E 1
xamples e color_hsl (100,50,70) —,166,217,140¢

color_hsla

Returns a string representation of a color based on its hue, saturation, lightness and alpha (transparency) attributes
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Syntax color_hsla(hue, saturation, lightness, alpha)

A t
S * hue - hue of the color, as an integer value from 0 to 360

* saturation - saturation percentage of the color as an integer value from 0 to 100
* lightness - lightness percentage of the color as an integer value from O to 100
* alpha - alpha component as an integer value from 0 (completely transparent) to 255

(opaque).

E I
Xampies e color_hsla(100,50,70,200) — ,166,217,140,200*

color_hsv

Returns a string representation of a color based on its hue, saturation, and value attributes.

Syntax color_hsv(hue, saturation, value)

A t
reuments * hue - hue of the color, as an integer value from 0 to 360

* saturation - saturation percentage of the color as an integer value from 0 to 100
* value - value percentage of the color as an integer from 0 to 100

E 1
xamples « color_hsv(40,100,100) —,255,170,0¢

color_hsva

Returns a string representation of a color based on its hue, saturation, value and alpha (transparency) attributes.

Syntax color_hsva(hue, saturation, value, alpha)

A t
Teuments * hue - hue of the color, as an integer value from 0 to 360

* saturation - saturation percentage of the color as an integer value from 0 to 100
« value - value percentage of the color as an integer from 0 to 100
* alpha - alpha component as an integer value from 0 (completely transparent) to 255

(opaque)

Exampl,
xampres * color_hsva (40,100,100,200) —,255,170,0,200°

color_mix_rgb

Returns a string representing a color mixing the red, green, blue, and alpha values of two provided colors based on
a given ratio.
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Syntax color_mix_rgb(colorl, color2, ratio)

Arguments .
. ¢ colorl - a color string

* color2 - a color string
* ratio - a ratio

Exampl
Xampies * color_mix_rgb('0,0,0','255,255,255",0.5) —,127,127,127,255

color_part

Returns a specific component from a color string, e.g., the red component or alpha component.

Syntax color_part(color, component)

Arguments .
* color - a color string

¢ component - a string corresponding to the color component to return. Valid options are:
— red: RGB red component (0-255)
— green: RGB green component (0-255)
— blue: RGB blue component (0-255)
— alpha: alpha (transparency) value (0-255)
— hue: HSV hue (0-360)
— saturation: HSV saturation (0-100)
— value: HSV value (0-100)
— hsl_hue: HSL hue (0-360)
— hsl_saturation: HSL saturation (0-100)
— lightness: HSL lightness (0-100)
— cyan: CMYK cyan component (0-100)
— magenta: CMYK magenta component (0-100)
— yellow: CMYK yellow component (0-100)
— black: CMYK black component (0-100)

Examples
e color_part ('200,10,30"', "green') — 10

color_rgb

Returns a string representation of a color based on its red, green, and blue components.

Syntax color_rgb(red, green, blue)

Arguments .
* red - red component as an integer value from 0 to 255

e green - green component as an integer value from 0 to 255
¢ blue - blue component as an integer value from 0 to 255

Exampl
Rathpies e color_rgb (255,127, 0) —,255,127,04
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color_rgba

Returns a string representation of a color based on its red, green, blue, and alpha (transparency) components.

Syntax color_rgba(red, green, blue, alpha)

Arguments .
2 ¢ red - red component as an integer value from 0 to 255

e green - green component as an integer value from 0 to 255

¢ blue - blue component as an integer value from 0 to 255

« alpha - alpha component as an integer value from 0 (completely transparent) to 255
(opaque).

E 1
Xampies s color_rgba(255,127,0,200) —,255,127,0,200¢

create_ramp

Returns a gradient ramp from a map of color strings and steps.

Syntax create_ramp(map, [discrete=false])
[] marks optional arguments
Arguments .
e map - a map of color strings and steps
* discrete - set this parameter to true to create a discrete color ramp
Examples
* ramp_color (create_ramp (map(0,'0,0,0',1,'255,0,0")),1) —
»255,0,0,255¢
darker

Returns a darker (or lighter) color string

Syntax darker(color, factor)

Arguments .
* color - a color string

« factor - an integer corresponding to the darkening factor:
— if the factor is greater than 100, this function returns a darker color (e.g., setting
factor to 200 returns a color that is half the brightness);
— if the factor is less than 100, the return color is lighter, but using the lighter()
function for this purpose is recommended;
— if the factor is O or negative, the return value is unspecified.

E 1
Xampies » darker('200,10,30', 200) —,100,5,15,255%

Further reading: lighter
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lighter

Returns a lighter (or darker) color string

Syntax lighter(color, factor)

Arguments .
¢ color - a color string

« factor - an integer corresponding to the lightening factor:
— if the factor is greater than 100, this function returns a lighter color (e.g., setting
factor to 150 returns a color that is 50% brighter);
— if the factor is less than 100, the return color is darker, but using the darker()
function for this purpose is recommended;
— if the factor is O or negative, the return value is unspecified.

Exampl
xampres e lighter ('200,10,30', 200) — ,255,158,168,255

Further reading: darker

project_color

Returns a color from the project’s color scheme.

Syntax project_color(name)

Arguments
* name - a color name

E 1
Xampies e project_color ('Logo color') — ,20,140,50“

Further reading: setting project colors

ramp_color

Returns a string representing a color from a color ramp.
Saved ramp variant

Returns a string representing a color from a saved ramp

Syntax ramp_color(ramp_name, value)

Arguments .
. * ramp_name - the name of the color ramp as a string, for example ,,Spectral

* value - the position on the ramp to select the color from as a real number between 0 and
1

E 1
xamples e ramp_color ('Spectral',0.3) —,253,190,115,255¢

IIpumeuanne: The color ramps available vary between QGIS installations. This function may not give the expected
results if you move your QGIS project between installations.

Expression-created ramp variant
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Returns a string representing a color from an expression-created ramp

Syntax ramp_color(ramp, value)

Arguments
e ramp - the color ramp

* value - the position on the ramp to select the color from as a real number between 0 and
1

E 1
xamples * ramp_color (create_ramp (map(0,'0,0,0',1,'255,0,0")),1) -

,»255,0,0,255¢

Further reading: Setting a Color Ramp, The color ramp drop-down shortcut

set_color_part

Sets a specific color component for a color string, e.g., the red component or alpha component.

Syntax set_color_part(color, component, value)

Arguments .
* color - a color string

¢ component - a string corresponding to the color component to set. Valid options are:
— red: RGB red component (0-255)
— green: RGB green component (0-255)
— blue: RGB blue component (0-255)
— alpha: alpha (transparency) value (0-255)
— hue: HSV hue (0-360)
— saturation: HSV saturation (0-100)
— value: HSV value (0-100)
— hsl_hue: HSL hue (0-360)
— hsl_saturation: HSL saturation (0-100)
— lightness: HSL lightness (0-100)
— cyan: CMYK cyan component (0-100)
— magenta: CMYK magenta component (0-100)
— yellow: CMYK yellow component (0-100)
— black: CMYK black component (0-100)
* value - new value for color component, respecting the ranges listed above

E 1
Xamples e set_color_part ('200,10,30"', 'green', 50) — ”200,50,30,255‘4
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13.2.4 Conditional Functions

This group contains functions to handle conditional checks in expressions.

CASE

CASE is used to evaluate a series of conditions and return a result for the first condition met. The conditions are
evaluated sequentially, and if a condition is true, the evaluation stops, and the corresponding result is returned. If
none of the conditions are true, the value in the ELSE clause is returned. Furthermore, if no ELSE clause is set and
none of the conditions are met, NULL is returned.

CASE

WHEN condition THEN result
[...n]

[ ELSE result ]

END

[ ] marks optional components

Arguments . .. .
* WHEN condition - A condition expression to evaluate

e THEN result - If condition evaluates to True then result is evaluated and returned.
¢ ELSE result - If none of the above conditions evaluated to True then result is evaluated
and returned.

Examples . «
e CASE WHEN "name" IS NULL THEN 'None' END — Returns the string ,,None

if the «name» field is NULL

e CASE WHEN $area > 10000 THEN 'Big property' WHEN $area > 5000
THEN 'Medium property' ELSE 'Small property' END — Returns the
string ,,Big property” if the area is bigger than 10000, ,,Medium property” if the area is
between 5000 and 10000, and ,,Small property* for others

coalesce

Returns the first non-NULL value from the expression list.

This function can take any number of arguments.

Syntax coalesce(expressionl, expression2, ...)

Arguments . . .
 expression - any valid expression or value, regardless of type.

Examples
e coalesce (NULL, 2) —2

(
e coalesce (NULL, 2, 3) —»2
e coalesce (7, NULL, 3*2) —»7
e coalesce ("fieldA", "fallbackField", 'ERROR') — value of fieldA if it
is non-NULL else the value of «fallbackField» or the string ,,ERROR* if both are NULL
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if

Tests a condition and returns a different result depending on the conditional check.

Syntax if(condition, result_when_true, result_when_false)

Arguments .. - .
¢ condition - the condition which should be checked

e result_when_true - the result which will be returned when the condition is true or
another value that does not convert to false.

e result_when_false - the result which will be returned when the condition is false or
another value that converts to false like 0 or ,,“. NULL will also be converted to false.

Examples )
e if( 1+1=2, 'Yes', 'No' ) —,Yes“
e if( 1+1=3, 'Yes', 'No' ) —,No“
e if( 5 >3, 1, 0) —>1
e if( '', "It is true (not empty)', 'It is false (empty)' ) —
»lt is false (empty)*
e if( ' ', "It is true (not empty)', 'It is false (empty)' )
— It is true (not empty)*
e if( 0, 'One', 'Zero' ) — ,Zero“
e if( 10, 'One', 'Zero' ) — ,One“
nullif

Returns a NULL value if valuel equals value2; otherwise it returns valuel. This can be used to conditionally
substitute values with NULL.

Syntax nullif(valuel, value2)

A t
Teuments ¢ valuel - The value that should either be used or substituted with NULL.

* value2 - The control value that will trigger the NULL substitution.

E It
xamples e nullif (' (none)', ' (none)') — NULL

e nullif ("text', ' (none)') — ,text”
e nullif ("name", '') — NULL, if name is an empty string (or already NULL), the
name in any other case.

regexp_match

Return the first matching position matching a regular expression within an unicode string, or O if the substring is
not found.

Syntax regexp_match(input_string, regex)

Arguments . . . . .
* input_string - the string to test against the regular expression

* regex - The regular expression to test against. Backslash characters must be double
escaped (e.g., «\\s» to match a white space character or «\\b» to match a word boundary).

Examples
e regexp_match ('QGIS ROCKS', "\\sROCKS') — 5

e regexp_match ('Budacd', 'udac\\b') —?2
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try

Tries an expression and returns its value if error-free. If the expression returns an error, an alternative value will be
returned when provided otherwise the function will return NULL.

Syntax try(expression, [alternative])
[] marks optional arguments
Arguments . .
S ¢ expression - the expression which should be run
* alternative - the result which will be returned if the expression returns an error.
Examples

e try( to_int( '"1' ), 0 ) —>1
e try( to_int( 'a' ), 0 ) —0
e try( to_date( 'invalid_date' ) ) —» NULL

13.2.5 Conversions Functions

This group contains functions to convert one data type to another (e.g., string from/to integer, binary from/to string,
string to date, ...).

from_base64

Decodes a string in the Base64 encoding into a binary value.

Syntax from_base64(string)

Arguments .
5 * string - the string to decode

Examples
P e from_base64 ('UUdJUw==") — ,,QGIS“
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hash

Creates a hash from a string with a given method. One byte (8 bits) is represented with two hex ,,“digits

1713

, SO ,,md4*“

(16 bytes) produces a 16 * 2 = 32 character long hex string and ,.keccak_512% (64 bytes) produces a 64 * 2 = 128
character long hex string.

Syntax hash(string, method)

Arguments

Examples

string - the string to hash

method - The hash method among ,,md4“, ,md5%, ,shal®, ,sha224“,  sha384“, ,sha512%,
»sha3_224“  sha3_256“, ,sha3_384“ ,sha3_512“  keccak_224“  keccak_256%,
keccak_384*, keccak_512%

hash
hash
hash
hash
hash

('"QGIS', 'md4') — ,c0fc71c241cdebb6e888cbacOe2b68eb™
('"OGIS', 'md5') — ,57470aaa9e22adaefac7f5f342f1c6da“
('QGIS', 'shal') —,f87cfb2b74cdd5867db913237024¢7001e62b114“
("QGIS', 'sha224') —,4093a619ada631c770f44bc643ead18fb393b93d6abaf1861fcfece0”
('"OGIS', 'sha256') —,eb045cba7a797aaa06ac58830846e40c8e8c780bc0676d3393605fae50
hash ('QGIS', 'sha384') —,91cl1de038cc3d09fdd512e99f9dd9922efadc39ed21d3922e69a4305¢c!
hash ('QGIS', 'sha512') —,c2c092f2ab743bf8edbeb6d028a745f30fc720408465ed369421f0ade2(
hash ('QGIS', 'sha3_224"') —,467f49a5039e7280d5d42fd433e80d203439e338ecaabd701f0d6c17¢
hash ('QGIS', 'sha3_256"') —,540f7354b6b8a6e735f2845250f15f4f3badf666c55574d9¢9354575
hash ('QGIS', 'sha3_384"') —,96052dale77679¢9a65f60d7¢ad961b287977823144786386eb4364
hash ('QGIS', 'sha3_512"') —,900d079dc69761dal13980253aa8ac0414a8bd6d09879a916228f87
hash ('QGIS', 'keccak_224"') —,5b0cebacef8b0al21d4acdf3eaa8503c799ad4e26a3392d1fb2014
hash ('QGIS', 'keccak_256") —,991¢c520aa6815392de24087f61b2ae0fd56abbfeeed4a8ca019¢10]
hash ('QGIS', 'keccak_384"') — ,c57a3aed9d856fa04eS5eeee9b62b6e027cca81bas574116d3cclfOc

md>5

Creates a md5 hash from a string.

Syntax md5(string)

Arguments

Examples

string - the string to hash

md5 ('QGIS') — ,,57470aaa9e22adaefac7f5f342f1c6da‘“

sha256

Creates a sha256 hash from a string.

Syntax sha256(string)

Arguments

Examples

string - the string to hash

sha256 ('QGIS') — ,eb045cba7a797aaa06ac58830846e40c8e8c780bc0676d3393605fae50c05309
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to_base64

Encodes a binary value into a string, using the Base64 encoding.

Syntax to_base64(value)

Arguments

Examples

value - the binary value to encode

to_base64 ('QGIS') — ,,UUdIUw=="

to_date

Converts a string into

a date object. An optional format string can be provided to parse the string; see

QDate::fromString or the documentation of the format_date function for additional documentation on the format.
By default the current QGIS user locale is used.

Syntax to_date(string, [format], [language])
[] marks optional arguments
Arguments ) . .
e string - string representing a date value
» format - format used to convert the string into a date
 language - language (lowercase, two- or three-letter, ISO 639 language code) used to
convert the string into a date. By default the current QGIS user locale is used.
Examples
e to_date ('2012-05-04") — 2012-05-04
e to_date ('June 29, 2019', 'MMMM d, yyyy') — 2019-06-29, if the current
locale uses the name ,,June® for the sixth month, otherwise an error occurs
e to_date('29 juin, 2019','d MMMM, yyyy','fr') — 2019-06-29
to_datetime

Converts a string into

a datetime object. An optional format string can be provided to parse the string;

see QDate:fromString, QTime::fromString or the documentation of the format_date function for additional
documentation on the format. By default the current QGIS user locale is used.

Syntax to_datetime(string, [format], [language])
[] marks optional arguments

Arguments

Examples

string - string representing a datetime value

format - format used to convert the string into a datetime

language - language (lowercase, two- or three-letter, ISO 639 language code) used to
convert the string into a datetime. By default the current QGIS user locale is used.

to_datetime ('2012-05-04 12:50:00") — 2012-05-04T12:50:00
to_datetime ('June 29, 2019 @ 12:34','MMMM d, yyyy @ HH:mm')
— 2019-06-29T12:34, if the current locale uses the name ,,JJune“ for the sixth month,
otherwise an error occurs

to_datetime ('29 juin, 2019 @ 12:34','d MMMM, yyyy @ HH:mm',
"fr') — 2019-06-29T12:34
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to_decimal

Converts a degree, minute, second coordinate to its decimal equivalent.

Syntax to_decimal(value)

Arguments . .
£ * value - A degree, minute, second string.

E 1
xamples e to_decimal ('6°21\"'16.445") — 6.3545680555

to_dm

Converts a coordinate to degree, minute.

Syntax to_dm(coordinate, axis, precision, [formatting=])
[] marks optional arguments

Arguments . . .
 coordinate - A latitude or longitude value.

* axis - The axis of the coordinate. Either ,.x* or ,,y*.

* precision - Number of decimals.

o formatting - Designates the formatting type. Acceptable values are NULL (default),
waligned® or ,,suffix®.

Examples
e to_dm(6.1545681, 'x', 3) —6°9.274'

e to_dm(6.1545681, 'y', 4, 'aligned') — 6°09.2741'N
e to_dm(6.1545681, 'y', 4, 'suffix') — 6°9.2741'N

to_dms

Converts a coordinate to degree, minute, second.

Syntax to_dms(coordinate, axis, precision, [formatting=])
[] marks optional arguments

Arguments * coordinate - A latitude or longitude value.
* axis - The axis of the coordinate. Either ,,x“ or ,,y*.
* precision - Number of decimals.
 formatting - Designates the formatting type. Acceptable values are NULL (default),
»aligned” or ,,suffix®.
Examples

e to_dms (6.1545681, 'x', 3) — 6°9'16.445"
e to_dms (6.1545681, 'y', 4, 'aligned') — 6°09'16.4452"N
e to_dms (6.1545681, 'y', 4, 'suffix') — 6°9'16.4452"N
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to_int

Converts a string to integer number. Nothing is returned if a value cannot be converted to integer (e.g ,,123asd” is
invalid).

Syntax to_int(string)

Arguments . . .
e string - string to convert to integer number

Exampl
HAmMPIEs e to_int ('123') — 123

to_interval

Converts a string to an interval type. Can be used to take days, hours, month, etc of a date.

Syntax to_interval(string)
A t
s * string - a string representing an interval. Allowable formats include {n} days {n} hours
{n} months.
Examples ) .
e to_interval ('l day 2 hours') — interval: 1.08333 days
e to_interval( '0.5 hours' ) — interval: 30 minutes
* to_datetime ('2012-05-05 12:00:00') - to_interval('l day 2
hours') — 2012-05-04T10:00:00
to_real

Converts a string to a real number. Nothing is returned if a value cannot be converted to real (e.g ,,123.56asd” is
invalid). Numbers are rounded after saving changes if the precision is smaller than the result of the conversion.

Syntax to_real(string)

Arguments . .
e string - string to convert to real number

E 1
xampres e to_real('123.45") —» 123.45

to_string

Converts a number to string.

Syntax to_string(number)

Arguments .
4 * number - Integer or real value. The number to convert to string.

E 1
Xamples * to_string(123) — ,123%
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to_time

Converts a string into a time object. An optional format string can be provided to parse the string; see
QTime::fromString for additional documentation on the format.

Syntax to_time(string, [format], [language])
[] marks optional arguments

Arguments ] . . .
* string - string representing a time value
» format - format used to convert the string into a time
 language - language (lowercase, two- or three-letter, ISO 639 language code) used to
convert the string into a time
Examples

e to_time('12:30:01") — 12:30:01
e to_time('12:34"', "HH:mm"') — 12:34:00
e to_time('12:34"', '"HH:mm"', "fr"') — 12:34:00

13.2.6 Custom Functions

This group contains functions created by the user. See Function Editor for more details.

13.2.7 Date and Time Functions

This group contains functions for handling date and time data. This group shares several functions with the
Conversions Functions (to_date, to_time, to_datetime, to_interval) and String Functions (format_date) groups.

IIpumeuanne: Storing date, datetime and intervals on fields

The ability to store date, time and datetime values directly on fields depends on the data source’s provider (e.g.,
Shapefile accepts date format, but not datetime or time format). The following are some suggestions to overcome
this limitation:

* date, datetime and time can be converted and stored in text type fields using the format_date() function.

* Intervals can be stored in integer or decimal type fields after using one of the date extraction functions (e.g.,
day() to get the interval expressed in days)

age

Returns the difference between two dates or datetimes.

The difference is returned as an Interval and needs to be used with one of the following functions in order to
extract useful information:

* year

e month
* week

e day

* hour

* minute

e second
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Syntax age(datetimel, datetime2)

Arguments . . .
= ¢ datetimel - a string, date or datetime representing the later date

 datetime2 - a string, date or datetime representing the earlier date

Examples
e day (age ('2012-05-12"','2012-05-02")) — 10

* hour (age ('2012-05-12"', '2012-05-02")) — 240

datetime_from_epoch

Returns a datetime whose date and time are the number of milliseconds, msecs, that have passed since 1970-01-
01T00:00:00.000, Coordinated Universal Time (Qt.UTC), and converted to Qt.LocalTime.

Syntax datetime_from_epoch(int)

Arguments . .
e int - number (milliseconds)

Exampl
Xampies * datetime_from_epoch (1483225200000) — 2017-01-01T00:00:00

day

Extracts the day from a date, or the number of days from an interval.
Date variant

Extracts the day from a date or datetime.

Syntax day(date)

Arguments .
& ¢ date - a date or datetime value

E 1
xampies e day ('2012-05-12") — 12

Interval variant

Calculates the length in days of an interval.

Syntax day(interval)

Arguments . .
* interval - interval value to return number of days from

Examples ,
e day (to_interval ('3 days')) —3

e day (to_interval ('3 weeks 2 days')) —23
e day (age ('2012-01-01"','2010-01-01")) — 730

264 Maea 13. Level up with Expressions



QGIS Desktop 3.34 User Guide

day_of_week

Returns the day of the week for a specified date or datetime. The returned value ranges from 0 to 6, where 0

corresponds to a Sunday and 6 to a Saturday.

Syntax day_of_week(date)

Arguments .
& ¢ date - date or datetime value

Examples
e day_of_week (to_date ('2015-09-21")) — 1

epoch

Returns the interval in milliseconds between the unix epoch and a given date value.

Syntax epoch(date)

Arguments .
£ ¢ date - a date or datetime value

Exampl
xamples * epoch (to_date ('2017-01-01")) — 1483203600000

format_date

Formats a date type or string into a custom string format. Uses Qt date/time format strings. See QDateTime::toString.
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Syntax format_date(datetime, format, [language])
[] marks optional arguments
Arguments * datetime - date, time or datetime value
 format - String template used to format the string.
Expression Output
d the day as number without a leading zero (1 to 31)
dd the day as number with a leading zero (01 to 31)
ddd the abbreviated localized day name (e.g. ,Mon“ to ,,Sun®)
dddd the long localized day name (e.g. ,,Monday“ to ,,Sunday*)
M the month as number without a leading zero (1-12)
MM the month as number with a leading zero (01-12)
MMM the abbreviated localized month name (e.g. ,,Jan* to ,,Dec)
MMMM the long localized month name (e.g. ,,January“ to ,,December®)
vy the year as two digit number (00-99)
yyyy the year as four digit number
These expressions may be used for the time part of the format string:
Expression Output
h the hour without a leading zero (0 to 23 or 1 to 12 if AM/PM display)
hh the hour with a leading zero (00 to 23 or 01 to 12 if AM/PM display)
H the hour without a leading zero (0 to 23, even with AM/PM display)
HH the hour with a leading zero (00 to 23, even with AM/PM display)
m the minute without a leading zero (0 to 59)
mm the minute with a leading zero (00 to 59)
S the second without a leading zero (0 to 59)
ss the second with a leading zero (00 to 59)
z the milliseconds without trailing zeroes (0 to 999)
777 the milliseconds with trailing zeroes (000 to 999)
AP or A interpret as an AM/PM time. AP must be either ,,AM* or ,,PM*.
apora Interpret as an AM/PM time. ap must be either ,,am® or ,,pm*.
 language - language (lowercase, two- or three-letter, ISO 639 language code) used to
format the date into a custom string. By default the current QGIS user locale is used.
Examples
e format_date ('2012-05-15", 'dd.MM.yyyy') — ,15.05.2012¢
e format_date ('2012-05-15"','d MMMM yyyy', 'fr') — ,15 mai 2012
e format_date ('2012-05-15", 'dddd"') — , Tuesday®, if the current locale is an
English variant
e format_date ('2012-05-15 13:54:20', 'dd.MM.yy") — ,15.05.12¢
e format_date('13:54:20', '"hh:mm AP') —,01:54 PM“
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hour
Extracts the hour part from a datetime or time, or the number of hours from an interval.

Time variant

Extracts the hour part from a time or datetime.

Syntax hour(datetime)

Arguments . . .
¢ datetime - a time or datetime value

Examples )
e hour ( to_datetime ('2012-07-22 13:24:57'") ) —> 13

Interval variant

Calculates the length in hours of an interval.

Syntax hour(interval)
Arguments .
£ e interval - interval value to return number of hours from
Examples ,
e hour (to_interval ('3 hours')) —3

* hour (age ('2012-07-22T13:00:00"', '2012-07-22T10:00:00")) — 3

e hour (age ('2012-01-01"','2010-01-01")) — 17520

make_date

Creates a date value from year, month and day numbers.

Syntax make_date(year, month, day)

Arguments . . .. .
5 * year - Year number. Years 1 to 99 are interpreted as is. Year O is invalid.

* month - Month number, where 1=January
¢ day - Day number, beginning with 1 for the first day in the month

E It
Xamples e make_date (2020, 5, 4) — date value 2020-05-04

make_datetime

Creates a datetime value from year, month, day, hour, minute and second numbers.
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Syntax make_datetime(year, month, day, hour, minute, second)

Arguments . . . .
4 * year - Year number. Years 1 to 99 are interpreted as is. Year O is invalid.

e month - Month number, where 1=January

¢ day - Day number, beginning with 1 for the first day in the month
¢ hour - Hour number

¢ minute - Minutes

¢ second - Seconds (fractional values include milliseconds)

Examples
p e make_datetime (2020,5,4,13,45,30.5) — datetime value 2020-05-04

13:45:30.500

make_interval

Creates an interval value from year, month, weeks, days, hours, minute and seconds values.

Syntax make_interval([years=0], [months=0], [weeks=0], [days=0], [hours=0], [minutes=0],
[seconds=0])
[] marks optional arguments

Arguments
* years - Number of years (assumes a 365.25 day year length).
* months - Number of months (assumes a 30 day month length)
¢ weeks - Number of weeks
¢ days - Number of days
¢ hours - Number of hours
¢ minutes - Number of minutes
¢ seconds - Number of seconds
Examples : .
e make interval (hours:=3) — interval: 3 hours
* make_interval (days:=2, hours:=3) — interval: 2.125 days
e make_interval (minutes:=0.5, seconds:=5) — interval: 35 seconds
make_time

Creates a time value from hour, minute and second numbers.

Syntax make_time(hour, minute, second)

Arguments
g ¢ hour - Hour number

¢ minute - Minutes
e second - Seconds (fractional values include milliseconds)

EXampl
xamples e make_time (13,45, 30.5) — time value 13:45:30.500
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minute

Extracts the minutes part from a datetime or time, or the number of minutes from an interval.
Time variant

Extracts the minutes part from a time or datetime.

Syntax minute(datetime)

Arguments . . .
¢ datetime - a time or datetime value

Examples i i
e minute ( to_datetime ('2012-07-22 13:24:57") ) —»24

Interval variant

Calculates the length in minutes of an interval.

Syntax minute(interval)

Arguments . . .
e interval - interval value to return number of minutes from

Examples , . .
e minute (to_interval ('3 minutes')) —3
* minute (age ('2012-07-22T00:20:00"', '2012-07-22T00:00:00")) —
20
e minute (age ('2012-01-01",'2010-01-01")) — 1051200
month

Extracts the month part from a date, or the number of months from an interval.
Date variant

Extracts the month part from a date or datetime.

Syntax month(date)

Arguments .
& ¢ date - a date or datetime value

E 1
xamples e month ('2012-05-12") — 05

Interval variant

Calculates the length in months of an interval.

Syntax month(interval)

Arguments . .
£  interval - interval value to return number of months from

Examples .
e month (to_interval ('3 months')) —3

e month (age ('2012-01-01", '2010-01-01")) — 4.03333
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now

Returns the current date and time. The function is static and will return consistent results while evaluating. The time
returned is the time when the expression is prepared.

Syntax now()

sl
xamples e now () — 2012-07-22T13:24:57

second

Extracts the seconds part from a datetime or time, or the number of seconds from an interval.
Time variant

Extracts the seconds part from a time or datetime.

Syntax second(datetime)

Arguments . . .
¢ datetime - a time or datetime value

Examples ,
e second( to_datetime('2012-07-22 13:24:57') ) =57

Interval variant

Calculates the length in seconds of an interval.

Syntax second(interval)

Arguments . .
« interval - interval value to return number of seconds from

Examples i i
e second(to_interval ('3 minutes')) — 180
* second(age('2012-07-22T00:20:00"', '2012-07-22T00:00:00") ) —
1200
e second(age ('2012-01-01",'2010-01-01")) — 63072000
to_date

Converts a string into a date object. An optional format string can be provided to parse the string; see
QDate::fromString or the documentation of the format_date function for additional documentation on the format.
By default the current QGIS user locale is used.
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Syntax to_date(string, [format], [language])
[] marks optional arguments
Arguments . . .
e string - string representing a date value
 format - format used to convert the string into a date
 language - language (lowercase, two- or three-letter, ISO 639 language code) used to
convert the string into a date. By default the current QGIS user locale is used.
Examples
e to_date ('2012-05-04") — 2012-05-04
e to_date ('June 29, 2019', 'MMMM d, yyyy') — 2019-06-29, if the current
locale uses the name ,,June® for the sixth month, otherwise an error occurs
e to_date('29 juin, 2019','d MMMM, yyyy','fr') — 2019-06-29
to_datetime

Converts a string into

a datetime object. An optional format string can be provided to parse the string;

see QDate:fromString, QTime::fromString or the documentation of the format_date function for additional
documentation on the format. By default the current QGIS user locale is used.

Syntax to_datetime(string, [format], [language])
[] marks optional arguments
Arguments . . . .
* string - string representing a datetime value
e format - format used to convert the string into a datetime
 language - language (lowercase, two- or three-letter, ISO 639 language code) used to
convert the string into a datetime. By default the current QGIS user locale is used.
Examples ,
e to_datetime ('2012-05-04 12:50:00") — 2012-05-04T12:50:00
e to_datetime ('June 29, 2019 @ 12:34','MMMM d, yyyy @ HH:mm')
— 2019-06-29T12:34, if the current locale uses the name ,,June“ for the sixth month,
otherwise an error occurs
* to_datetime('29 juin, 2019 @ 12:34','d MMMM, yyyy @ HH:mm',
"fr') — 2019-06-29T12:34
to_interval

Converts a string to an interval type. Can be used to take days, hours, month, etc of a date.

Syntax to_interval(string)

Arguments

Examples

string - a string representing an interval. Allowable formats include {n} days {n} hours
{n} months.

to_interval ('l day 2 hours') — interval: 1.08333 days

to_interval( '0.5 hours' ) — interval: 30 minutes

to_datetime ('2012-05-05 12:00:00') - to_interval('l day 2
hours') — 2012-05-04T10:00:00
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to_time

Converts a string into a time object. An optional format string can be provided to parse the string; see

QTime::fromString for additional documentation on the format.

Syntax to_time(string, [format], [language])
[] marks optional arguments

Arguments . . . .
* string - string representing a time value

» format - format used to convert the string into a time

* language - language (lowercase, two- or three-letter, ISO 639 language code) used to

convert the string into a time

Exampl
xamples * to_time('12:30:01") — 12:30:01

e to_time('12:34"', "HH:mm"') — 12:34:00
e to_time('12:34"', '"HH:mm"', "fr"') — 12:34:00

week

Extracts the week number from a date, or the number of weeks from an interval.
Date variant

Extracts the week number from a date or datetime.

Syntax week(date)

Arguments .
£ ¢ date - a date or datetime value

E 1
xampres e week ('2012-05-12") > 19

Interval variant

Calculates the length in weeks of an interval.

Syntax week(interval)

Arguments . .
 interval - interval value to return number of months from

Examples .
e week (to_interval ('3 weeks')) —»3

e week (age ('2012-01-01"', '2010-01-01")) — 104.285
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year

Extracts the year part from a date, or the number of years from an interval.
Date variant

Extracts the year part from a date or datetime.

Syntax year(date)

Arguments .
£ ¢ date - a date or datetime value

E 1
xampies e year ('2012-05-12") — 2012

Interval variant

Calculates the length in years of an interval.

Syntax year(interval)

Arguments . .
* interval - interval value to return number of years from

Examples ,
* year (to_interval ('3 years')) —3

e year (age ('2012-01-01"','2010-01-01")) — 1.9986

Some examples:
Besides these functions, subtracting dates, datetimes or times using the — (minus) operator will return an interval.

Adding or subtracting an interval to dates, datetimes or times, using the + (plus) and — (minus) operators, will return
a datetime.

¢ Get the number of days until QGIS 3.0 release:

to_date ('2017-09-29'") - to_date (now())
—— Returns <interval: 203 days>

¢ The same with time:

to_datetime ('2017-09-29 12:00:00") — now()
Returns <interval: 202.49 days>

* Get the datetime of 100 days from now:

now() + to_interval('100 days')
—— Returns <datetime: 2017-06-18 01:00:00>
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13.2.8 Fields and Values

Contains a list of fields from the active layer, and special values. Fields list includes the ones stored in the dataset,
virtual and auxiliary ones as well as from joins.

Double-click a field name to have it added to your expression. You can also type the field name (preferably inside
double quotes) or its alias.

To retrieve fields values to use in an expression, select the appropriate field and, in the shown widget, choose
between 10 Samples and All Unique. Requested values are then displayed and you can use the Search box at the top
of the list to filter the result. Sample values can also be accessed via right-clicking on a field.

To add a value to the expression you are writing, double-click on it in the list. If the value is of a string type, it
should be simple quoted, otherwise no quote is needed.

NULL

Equates to a NULL value.
Syntax NULL
Examples

e NULL — a NULL value

IIpumeuyanne: To test for NULL use an IS NULL or IS NOT NULL expression.

13.2.9 Files and Paths Functions

This group contains functions which manipulate file and path names.

base_file_name

Returns the base name of the file without the directory or file suffix.

Syntax base_file_name(path)

A t
R  path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples i ) )
e base_file_name ('/home/ggis/data/country_boundaries.shp') —

»country_boundaries
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exif

Retrieves exif tag values from an image file.

Syntax exif(path, [tag])
[] marks optional arguments

A t
R ¢ path - An image file path or a map layer value. If a map layer value is specified then the
file source of the layer will be used.
* tag - The tag to return. If empty, a map with all exif tag values will be returned.
Examples , , . . .
e exif ('/my/photo.jpg', '"Exif.Image.Orientation') —0
file_exists

Returns TRUE if a file path exists.

Syntax file_exists(path)

A t
gt * path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples , , . ]
e file_exists ('/home/ggis/data/country_boundaries.shp') —

TRUE

file_name

Returns the name of a file (including the file extension), excluding the directory.

Syntax file_name(path)

A t
IR e path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples ) ) )
e file_name ('/home/ggis/data/country_boundaries.shp') —

»country_boundaries.shp*

file_path

Returns the directory component of a file path. This does not include the file name.

Syntax file_path(path)

A t
HgREE » path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples ) , )
e file_path('/home/ggis/data/country_boundaries.shp') —

»/home/qgis/data‘“

13.2. List of functions 275



QGIS Desktop 3.34 User Guide

file_size

Returns the size (in bytes) of a file.

Syntax file_size(path)

Arguments . . . .
* path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples i ) ) i )
e file_size('/home/ggis/data/country_boundaries.geojson') —

5674

file_suffix

Returns the file suffix (extension) from a file path.

Syntax file_suffix(path)

Arguments . . . .
e path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples . . q :
e file_suffix('/home/ggis/data/country_boundaries.shp') —

,,Shp“

is_directory

Returns TRUE if a path corresponds to a directory.

Syntax is_directory(path)

Arguments . . . .
e path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples , . ) ]
e is_directory ('/home/ggis/data/country_boundaries.shp') —
FALSE
e is_directory ('/home/qgis/data/"') — TRUE
is_file

Returns TRUE if a path corresponds to a file.

Syntax is_file(path)

Arguments . . . .
» path - a file path or a map layer value. If a map layer value is specified then the file

source of the layer will be used.

Examples , . . .
e is_file('/home/ggis/data/country_boundaries.shp') — TRUE

e is_file('/home/ggis/data/') — FALSE
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13.2.10 Form Functions

This group contains functions that operate exclusively under the attribute form context. For example, in field's
widgets settings.

current_parent_value

Only usable in an embedded form context, this function returns the current, unsaved value of a field in the parent
form currently being edited. This will differ from the parent feature’s actual attribute values for features which
are currently being edited or have not yet been added to a parent layer. When used in a value-relation widget filter
expression, this function should be wrapped into a ,,coalesce()“ that can retrieve the actual parent feature from the
layer when the form is not used in an embedded context.

Syntax current_parent_value(field_name)

Arguments . . .
* field_name - a field name in the current parent form

Examples .
P e current_parent_value( 'FIELD_NAME' ) — The current value of a field

»FIELD_NAME" in the parent form.

current_value

Returns the current, unsaved value of a field in the form or table row currently being edited. This will differ from
the feature’s actual attribute values for features which are currently being edited or have not yet been added to a
layer.

Syntax current_value(field_name)

Arguments . . .
¢ field_name - a field name in the current form or table row

Examples .
P e current_value ( '"FIELD NAME' ) — The current value of field

-FIELD_NAME".

13.2.11 Fuzzy Matching Functions

This group contains functions for fuzzy comparisons between values.

hamming_distance

Returns the Hamming distance between two strings. This equates to the number of characters at corresponding
positions within the input strings where the characters are different. The input strings must be the same length, and
the comparison is case-sensitive.
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Syntax hamming_distance(stringl, string2)

Arguments ] .
* stringl - a string

* string2 - a string

Examples i )
* hamming_distance('abc', 'xec') —
* hamming_distance ('abc', '"ABc') —
e hamming_distance (upper ('abc') ,upper ('ABC')) -0
* hamming_distance ('abc', "abcd') — NULL
levenshtein

Returns the Levenshtein edit distance between two strings. This equates to the minimum number of character edits
(insertions, deletions or substitutions) required to change one string to another.

The Levenshtein distance is a measure of the similarity between two strings. Smaller distances mean the strings are
more similar, and larger distances indicate more different strings. The distance is case sensitive.

Syntax levenshtein(string1, string2)

Arguments . .
* stringl - a string

e string2 - a string

Examples , . .
e Jevenshtein('kittens', 'mitten') —2

e levenshtein ('Kitten', 'kitten') —» 1
e levenshtein (upper ('Kitten') ,upper ('kitten')) —0

longest_common_substring

Returns the longest common substring between two strings. This substring is the longest string that is a substring of
the two input strings. For example, the longest common substring of «kxABABC» and «<BABCA» is «<BABC». The
substring is case sensitive.

Syntax longest_common_substring(string1, string2)

Arguments . .
* stringl - a string

e string2 - a string

Examples
P e longest_common_substring ('ABABC', 'BABCA') — ,,BABC*

* longest_common_substring ('abcDeF"', 'abcdef') — ,abc
* longest_common_substring (upper ('abcDeF '), upper ('abcdex'))
— ,,ABCDE*
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soundex

Returns the Soundex representation of a string. Soundex is a phonetic matching algorithm, so strings with similar
sounds should be represented by the same Soundex code.

Syntax soundex(string)

Arguments ] .
 string - a string

E 1
xampres e soundex ('robert') —,R163“

e soundex ('rupert') — ,R163“
e soundex ('rubin') — ,R150

13.2.12 General Functions

This group contains general assorted functions.

env

Gets an environment variable and returns its content as a string. If the variable is not found, NULL will be returned.
This is handy to inject system specific configuration like drive letters or path prefixes. Definition of environment
variables depends on the operating system, please check with your system administrator or the operating system
documentation how this can be set.

Syntax env(name)

Arguments . . . .
£ ¢ name - The name of the environment variable which should be retrieved.

Examples
P e env( 'LANG' ) — ,en US.UTF-8*
e env( 'MY OWN_PREFIX VAR' ) —,Z:*
e env( 'I_DO_NOT_EXIST' ) — NULL
eval

Evaluates an expression which is passed in a string. Useful to expand dynamic parameters passed as context variables
or fields.

Syntax eval(expression)

Arguments ] . .
* expression - an expression string

Examples .
p e eval ('"\'nice\'') — ,nice”

e eval (Rexpression_var) — [whatever the result of evaluating @expression_var
might be...]
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eval_template

Evaluates a template which is passed in a string. Useful to expand dynamic parameters passed as context variables
or fields.

Syntax eval_template(template)

Arguments .
e template - a template string

E I
xampies * eval_template ('QGIS [% upper (\'rocks\') %]') — QGIS ROCKS

is_layer_visible

Returns TRUE if a specified layer is visible.

Syntax is_layer_visible(layer)

Arguments . . :
. * layer - a string, representing either a layer name or layer ID

Examples
P e is_layer_visible ('baseraster') —» TRUE

mime_type

Returns the mime type of the binary data.

Syntax mime_type(bytes)

A t
rguments * bytes - the binary data

Examples )
* mime_type ('<html><body></body></html>"') — text/html
* mime_type (from base64 ('RO1IGOD1hAQABAAAAACHSBAEKAAEALAAAAAABAAEAAATIAOW==
— image/gif
var

Returns the value stored within a specified variable.

Syntax var(name)

Arguments .
e name - a variable name

Examples
P e var ('qggis_version') —,2.12

Further reading: List of default variables
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with_variable

This function sets a variable for any expression code that will be provided as 3rd argument. This is only useful for
complicated expressions, where the same calculated value needs to be used in different places.

Syntax with_variable(name, value, expression)

Arguments .
£ ¢ name - the name of the variable to set

* value - the value to set
* expression - the expression for which the variable will be available

Examples
p e with_variable('my_sum', 1 + 2 + 3, @my_sum * 2 + @my_sum *

5) - 42

13.2.13 Geometry Functions

This group contains functions that operate on geometry objects (e.g. buffer, transform, $area).

affine_transform

Returns the geometry after an affine transformation. Calculations are in the Spatial 