Atualização

Formatos de dados suportados

QGIS usa a biblioteca OGR para ler e escrever formatos de dados vetoriais, incluindo arquivos de formato ESRI, MapInfo e formatos de arquivo MicroStation, AutoCAD DXF, PostGIS, SpatiaLite, Oracle Spatial e bancos de dados MSSQL espaciais, e muitos mais. Vetor grama e suporte ao PostgreSQL é fornecido pela nativas | qg | provedores de plugins. Dados vetoriais também podem ser carregados no modo de leitura de arquivos ZIP e GZIP em QGIS. A partir da data deste documento, 69 formatos vetoriais são suportados pela biblioteca OGR (ver OGR-SOFTWARE-SUITE em: ref: literature_and_web). A lista completa está disponível em http://www.gdal.org/ogr/ogr_formats.html.

Nota

Nem todos os formatos mencionados podem trabalhar no QGIS por várias razões. Por exemplo, alguns exigem bibliotecas comerciais externas, ou a instalação de seu sistema operacional GDAL/OGR pode não ter sido construída para suportar o formato que você deseja usar. Apenas os formatos que foram bem testados irão aparecer na lista de tipos de arquivos ao carregar um raster no QGIS. Outros formatos não testados podem ser carregados selecionando *.*.

Procedimentos com dados vetoriais GRASS são descritos na Seção Integração com SIG GRASS.

Esta seção descreve como trabalhar com vários formatos comuns: arquivos ESRI, camadas PostGIS, camadas SpatiaLite, vetores OpenStreetMap e dados Comma Separated (CSV). Muitos dos recursos disponíveis no | QG | independentemente da fonte de dados vetoriais você pode trabalhar sozinho e isso inclui identificar, selecionar, rotular e atribuir funções.

Shapefiles ESRI

O formato de arquivo vetorial padrão usado pelo QGIS é o Shapefile ESRI. O suporte é fornecido pela OGR Simple Feature Library ( http://www.gdal.org/ogr/ ).

Um shapefile consiste na verdade de um conjunto de vários arquivos. Os três seguintes são necessários:

  1. .shp arquivo que contém as formas vetoriais.

  2. .dbf arquivo que contém os atributos no formato dBase..

  3. .shx arquivos index.

Shapefiles também podem incluir um arquivo com a extensão .prj que contém as informações de projeção. Embora seja muito útil um arquivo de projeção, não é obrigatória. Um conjunto de dados shapefile pode conter arquivos adicionais. Para mais detalhes veja a especificação técnica ESRI em: http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

Carregando um Shapefile

Para carregar um arquivo comece o | QG | e clique em mActionAddOgrLayer: Adicionar um Vetor ou simplesmente pressione as teclas ‘Ctrl + Shift + V’. Isso fará com que você crie uma nova janela (ver figura_vetor_1).

Figure Vector 1:

../../../_images/addvectorlayerdialog.png

Diálogo Adicionando Camada Vetorial nix

Entre as opções disponíveis verificar radiobuttonon: guilabel: Arquivo. Clique no [Browse]. Isso fará com que um diálogo de arquivo padrão aberto (ver figure_vector_2), que permite que você navegue no sistema de arquivos e carregue um shapefile ou outra fonte de dados suportados. A caixa de seleção: guilabel: ‘Filtro’ selectstring permite você pré-selecionar alguns formatos de arquivos OGR suportados.

Você também pode selecionar a codificação para o shapefile, se desejar.

Figure Vector 2:

../../../_images/shapefileopendialog.png

Diálogo abrir Camada Vetorial OGR Suportada nix

Ao selecinar um shapefile a partir da lista e clicando em [Abrir] o QGIS o carregará. A Figure_vector_3 exibe o QGIS depois de carregar o arquivo alaska.shp.

Figure Vector 3:

../../../_images/shapefileloaded.png

QGIS com Shapefile do Alaska carregado nix

Dica

Cores das camadas

Quando você adiciona uma camada ao mapa, é atribuída uma cor aleatória. Na adição de mais de uma camada de uma vez, são atribuídas cores diferentes para cada camada.

Uma vez carregado, você pode aplicar zoom em todo o shapefile usando as ferramentas de navegação do mapa. Para alterar o estilo de uma camada, abra a caixa de diálogo Propriedades da Camada clicando duas vezes no nome da camada ou clicando com o botão direito do mouse sobre o nome na legenda e escolha Propriedades a partir do menu context. Consulte a Seção vector_style_tab para mais informações sobre a definição da simbologia das camadas vetoriais.

Dica

Carregando camadas e armazenando projetos em unidades externas no OS X

No OS X, unidades portáteis que são armazenadas além do disco rígido principal não aparecem no File ‣Open Project `como esperado. Para resolver isso estamos trabalhando em uma forma mais nativa do OS X com caixa de diálogo abrir/salvar. Como alternativa, você pode digitar ‘/Volumes’ no campo Nome do arquivo e pressione :kbd:`Voltar. Depois, você pode navegar para unidades externas ou armazenadas em rede.

Melhorando o desempenho de Shapefiles

Para melhorar o desempenho do desenho de um shapefile, você pode criar um índice espacial. Um índice espacial irá melhorar a velocidade do zoom e visão panorâmica. Os índices espaciais utilizados pelo QGIS estão na extensão .qix.

Siga estes passos para criar o índice:

  • Carregue um shapefile clicando no | mActionAddOgrLayer |: sup: Add Vector Layer ` barra de ferramentas ou pressionando camada: kbd: `Ctrl + Shift + V.

  • Abra a caixa de diálogo Propriedades da camada clicando duas vezes sobre o nome do shapefile na legenda ou com o botão direito do mouse e escolha Propriedades a partir do menu de contexto.

  • Na guia :guilabel:’Geral’, clique no botão [Criar índice espacial].

Problema ao carregar um arquivo shape .prj

Se você carregar um arquivo shapefile com o :aquivo:`.prj` e QGIS o sistema não é capaz de ler a referência de coordenadas a partir desse arquivo, você tem que definir a projeção adequada manualmente dentro guia :Guilabel:’Geral’ da caixa de diálogo Propriedades da camada. Isto é devido ao fato de que arquivos .prj muitas vezes não fornecem os parâmetros de projeção completos, conforme usado no QGIS e listados na guia CRS.

Por essa razão, se você criar um novo shapefile no QGIS, dois arquivos de projeção diferentes são criados. Um arquivo .prj com os parâmetros limitados de projeção, compatível com o software ESRI, e um arquivo .qpj, fornecendo os parâmetros completos dos CRS ​​usados. Se o QGIS encontra um arquivo .qpj, ele será usado em vez do arquivo prj.

Carregando uma camada MapInfo

mActionAddOgrLayer To load a MapInfo layer, click on the mActionAddOgrLayer Add Vector Layer toolbar button; or type Ctrl+Shift+V, change the file type filter Files of type selectstring: to ‘Mapinfo File [OGR] (*.mif *.tab *.MIF *.TAB)’ and select the MapInfo layer you want to load.

Carregando uma camada ArcInfo Binary

Para carregar um Arquivo/Informação clique no mActionAddOgrLayer: Adicionar Vetor no botão da barra de ferramentas ou pressione as teclas ‘Ctrl + Shift + V’ para abrir o guilabel: Adicionar uma informação ao Vetor. Selecione o botão do guilabel e o Diretório do guilabel. Altere o tipo de arquivo do guilabel de SelectString para Arquivo/Informação. Navegue até o diretório que contém o arquivo e selecione.

Da mesma forma, você pode carregar arquivos vetoriais baseados em um diretório no formato UK National Transfer, bem como os formatos TIGER do Census Bureau US.

Arquivos de texto delimitado

Dados em tabelas é um formato muito comum e amplamente utilizado devido à sua simplicidade e facilidade de acesso - os dados podem ser visualizados e editados até mesmo em um editor de texto simples. Um arquivo de texto delimitado é uma tabela de atributos com cada coluna separados por um caracter definido e cada linha separada por uma quebra de linha. A primeira linha geralmente contém os nomes das colunas. Um tipo comum de arquivo de texto delimitado é um arquivo CSV (Comma Separated Values​​), com cada coluna separado por uma vírgula.

Esses arquivos de dados também podem conter informações sobre a posição em duas formas principais:

  • Coordenadas de ponto separadas por colunas

  • Texto bem conhecido (WKT) representado por geometria

QGIS allows you to load a delimited text file as a layer or ordinal table. But first check that the file meets the following requirements:

  1. O arquivo deve ter uma linha de cabeçalho delimitada de nomes de campo. Esta deve ser a primeira linha do arquivo de texto.

  2. A linha de cabeçalho deve conter campo (s) com a definição da geometria. Estes campo (s) pode ter qualquer nome.

  3. As coordenadas X e Y (se a geometria for definida pelas coordenadas) deverá ser especificada como números. O sistema de coordenadas não é importante.

Como um exemplo de um arquivo de texto válido, nós importamos o arquivo de elevação de dados de pontos elevp.csv que vem com o conjunto de dados da amostra do QGIS (ver seção: ref: label_sampledata):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Alguns itens a serem observados sobre o arquivo de texto:

  1. O arquivo de texto exemplo usa ; (ponto e vírgula) como delimitador. Qualquer caractére pode ser usado para delimitar os campos.

  2. A primeira linha é a linha de cabeçalho. Ela contém os campos X, Y e ELEV.

  3. Sem aspas (") são usados ​​para delimitar os campos de texto.

  4. A coordenada X está contida no campo X.

  5. A coordenada Y está contida no campo Y.

Carregando um arquivo de texto delimitado

Clique no ícone da barra de ferramentas delimited_text Adicionar camada de texto Delimitado na barra de ferramentas Gerenciar camadas para abrir o diálogo Criar uma camada a partir de um arquivo de texto delimitado, como mostrado na figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Diálogo Texto Delimitado nix

Primeiro, selecione o arquivo a ser importado (por exemplo: arquivo ‘qgis_sample_data/csv/elevp.csv’) clicando no botão do [navegador]. Quando o arquivo for selecionado, | QG | tenta analisar o arquivo com o delimitador usado mais recentemente. Para ativar o | QG | para analisar corretamente o arquivo, é importante selecionar o delimitador correto. Você pode especificar um delimitador ativando pelo botão no guilabel, pelo delimitador personalizado ou pelo texto no guilabel: ‘Expressão’. Por exemplo, para alterar o delimitador de tabulação, use “t” (esta é uma expressão para o caracter de tabulação).

Uma vez que o arquivo é analisado, definir o guilabel, selecione o botão: ‘definição de geometria’. As coordenadas são o ponto ‘X’ e o campo ‘Y das listas suspensas. As coordenadas são definidas como graus/minutos/segundos, ative a caixa de seleção no guilabel ‘DMS’.

Por fim, digite um nome para a camada (por exemplo: arquivo ‘elevp’), como mostrado na figura_texto_1. Para adicionar a camada ao mapa, clique ** [OK] **. O arquivo de texto delimitado agora se comporta como qualquer outra camada de mapa em | QG |

Há também uma opção de ajuda que permite cortar espaços iniciais e finais dos campos no guilabel: ‘campos da guarnição’. Além disso, é possível no guilabel: descartar campos vazios. Se necessário, você pode forçar uma vírgula para ser o separador decimal ativando no guilabel: ‘separador decimal por vírgula’.

Se a informação espacial é representada por WKT, ative o botão no guilabel: na opção ‘Texto’ e selecione o campo com a definição WKT para ponto, linha ou polígono. Se o arquivo contém dados não-espaciais, ative o botão no guilabel: ‘Não’ e ele será carregado como uma tabela.

Adicionalmente, você pode ativar:

  • checkbox Utilize índice espacial para melhorar o desempenho de exibição e espacialmente a seleção das feições.

  • checkbox Utilize índice de subconjunto.

  • checkbox Assista arquivo para observar as alterações no arquivo por outros aplicativos enquanto o QGIS está sendo executado.

Dados OpenStreetMap

Nos últimos anos, o projeto OpenStreetMap ganhou popularidade porque, em muitos países há dados geográficos gratuitos, tais como mapas de estradas digitais estão disponíveis. O objetivo do projeto OSM é criar um mapa livre e editável do mundo a partir de dados de GPS, fotografia aérea ou conhecimento local. Para apoiar este objetivo, o QGIS fornece supporte para dados OSM.

Carregando vetores OpenStreetMap

QGIS integra importação OpenStreetMap como funcionalidade principal.

  • Para conectar-se aos dados do servidor OSM e de download, abra o menu: ‘Vetor -> OpenStreetMap -> Carregar dados’. Você pode pular esta etapa se você já obteve um arquivo XML usando .osm, JOSM, API ou qualquer outra fonte.

  • No menu ‘Vetor -> OpenStreetMap -> Importar topologia de um arquivo XML’ irá converter o seu: arquivo .osm em um banco de dados SpatiaLite e criar uma conexão de banco de dados correspondente.

  • O menu ‘Vetor -> OpenStreetMap -> Exportar topologia para SpatiaLite’ permite que você abra a conexão de banco de dados, selecione o tipo de dados que você quer (pontos, linhas ou polígonos) e escolher as tags para importação. Isso cria uma camada de geometria SpatiaLite que você pode adicionar ao seu projeto, clicando no mActionAddSpatiaLiteLayer ‘Adicionar SpatiaLite Layer’ na barra de ferramentas ou selecionando a | mActionAddSpatiaLiteLayer |: ‘Adicionar Camada SpatiaLite’ opção no menu Camada (ver seção:: ref: label SpatiaLite).

Camadas PostGIS

Camadas PostGIS são armazenados em um banco de dados PostgreSQL. As vantagens do PostGIS são a indexação espacial, filtragem e recursos de consulta. Usando o PostGIS, funções vetoriais, como selecionar e identificar permitem um trabalho com mais precisão do que com camadas OGR no QGIS.

Criando uma conexão armazenada

A primeira vez que você usar uma fonte de dados PostGIS, você deve criar uma conexão com o banco de dados PostgreSQL que contém os dados. Comece clicando no botão | mActionAddPostgisLayer |: sup: ‘Adicionar PostGIS’, selecionando a | mActionAddPostgisLayer |: ‘Adicionar Camada PostGIS’ ou digitando as teclas: ‘Ctrl + Shift + D’. Você também pode abrir a guilabel: ‘Adicionar Vetor’ e selecione o botão banco de dados. A guilabel ‘Adicionar Tabela PostGIS’ será exibida. Para acessar o gerenciador de conexão, clique no [novo] para exibir o guilabel: ‘Criar uma nova conexão PostGIS’. Os parâmetros necessários para uma conexão são:

  • Nome: Um nome para esta conexão. Pode ser o mesmo que o da base de dados.

  • Serviço: parâmetro de serviço a ser usado como alternativa ao nome do host/porta (e, potencialmente, banco de dados). Esta pode ser definida em: arquivo ‘pg_service.conf’.

  • Host: Nome do host no banco de dados. Este deve ser um nome de host usado para abrir uma conexão telnet ou ping. Se o banco de dados está no mesmo computador como | QG |, basta digitar ‘localhost’.

  • Porta: Número da porta do servidor de banco de dados PostgreSQL atende. A porta padrão é 5432.

  • Banco de dados: Nome do banco de dados.

  • Modo SSL: A conexão SSL será negociado com o servidor. Note-se que a velocidade no PostGIS por camada pode ser alcançada desativando o SSL na conexão. As seguintes opções estão disponíveis:

    • Desativar: tentar Apenas uma conexão SSL não criptografada.

    • Permitir: Tente uma conexão não-SSL. Se isso não funcionar, tente uma conexão SSL.

    • Prefira (o padrão): Tente uma conexão SSL. Se isso não funcionar, tente uma conexão não-SSL.

    • Exigir: Apenas tentar uma conexão SSL.

  • Nome do usuário: Nome do usuário usado para logar na base de dados.

  • Senha: Senha usada com Nome do Usuário para conectar ao banco de dados.

Opcionalmente, você pode ativar as seguintes caixas de seleção:

  • checkbox Salvar nome do usuário

  • checkbox Salvar Senha

  • checkbox Apenas olhar na tabela geometry_columns

  • checkbox: guilabel: Não resolve tipo de colunas sem restrições (geometria)

  • checkbox :guilabel:`Apenas olhar no esquema ‘público’

  • checkbox Também listar tabelas sem geometrias

  • checkbox Usar metadados atribuidos da tabela

Uma vez que todos os parâmetros e as opções estão configuradas, você pode testar a conexão clicando no botão [Testar Conexão].

Dica

QGIS Configurações do Usuário e Segurança

Depending on your computing environment, storing passwords in your QGIS settings may be a security risk. Your customized settings for QGIS are stored based on the operating system:

  • nix As configurações são armazenadas em seu diretório home em ~/.qgis2.

  • win As configurações são armazenadas no registro.

Carregando uma camada PostGIS

mActionAddLayer Uma vez que você tem uma ou mais conexões definidas, você pode carregar as camadas do banco de dados PostgreSQL. Claro que isso exige ter dados no PostgreSQL. Consulte a Secção Importação de dados no PostgreSQL para entender sobre a importação de dados para o banco de dados.

Para colocar uma camada no PostGIS, execute os seguintes passos:

  • Se o: guilabel: diálogo ‘Adicionar camadas PostGIS ` já não estiver aberto, selecionar o mActionAddPostgisLayer: menuselection:’ Adicionar PostGIS Camada ...` opção no: menuselection: Menu camada ou digitando: kbd: `Ctrl + Shift + D `abre o diálogo.

  • Escolha a conexão a partir da lista drop-down e clique em [Conectar].

  • Marque ou desmarque checkbox Listar tabelas sem geometrias

  • Opcionalmente, use no guilabel: ‘Opções de pesquisa’ para definir quais recursos carregar a partir da uma camada, ou usar o botão ** [Construtor de consultas] **.

  • Encontre a camada(s) que deseja adicionar na lista de camadas disponíveis.

  • Selecione-a clicando sobre ela. Você pode selecionar várias camadas pressionando a tecla Shift enquanto clica. Consulte a Seção Ferramenta de Consulta para obter informações sobre como usar o Query Builder PostgreSQL para melhor definição da camada.

  • Clique no botão [Add] para adicionar a camada ao mapa.

Dica

Camadas PostGIS

Normalmente uma camada PostGIS é definida por um caminho na tabela. A partir da versão 0.9.0 em diante, o QGIS permite carregar camadas que não têm um caminho na tabela geometry_columns. Isto inclui ambas as tabelas e exibições. A definição de uma visão espacial fornece um meio poderoso para visualizar seus dados. Consulte o manual do PostgreSQL para obter informações sobre a criação de pontos de vista diversos.

Alguns detalhes sobre as camadas PostgreSQL

Esta seção contém alguns detalhes sobre como o QGIS acessa camadas do PostgreSQL. Na maioria das vezes o QGIS simplesmente deve fornecer-lhe uma lista de tabelas do banco de dados que podem ser carregadas, e carregá-las mediante solicitação. No entanto, se você tiver problemas para carregar uma tabela do PostgreSQL no QGIS, as informações abaixo podem ajudá-lo a entender as mensagens do QGIS e dar-lhe orientações para alterar a tabela de PostgreSQL ou ver definições para permitir o QGIS carregá-la.

QGIS requer que as camadas PostgreSQL contenham uma coluna que pode ser usada como uma chave única para a camada. Para tabelas, isso geralmente significa que a tabela precisa de uma chave primária, ou uma coluna com uma restrição exclusiva sobre ela. No QGIS, esta coluna tem de ser do tipo int4 (um inteiro de 4 bytes). Alternativamente, a coluna ctid pode ser usada como chave primária. Se uma tabela não tem esses itens, a coluna oid será usado em seu lugar. O desempenho será melhorado se a coluna é indexada (note que as chaves primárias são automaticamente indexadas pelo PostgreSQL).

Se o banco de dados PostgreSQL é um ponto de referência, existe o mesmo requisito, mas não têm chaves ou colunas primárias com restrições exclusivas sobre eles. Você tem que definir um campo de chave primária (tem que ser inteiro) no | QG | antes de você carregar. Se uma coluna adequada não existe como requisito, | QG | não carregará. Se isso ocorrer, a solução é alterar o modo de exibição para ele incluir uma coluna adequada (um tipo inteiro com chave primária ou uma restrição exclusiva, de preferência indexado).

QGIS offers a checkbox Select at id that is activated by default. This option gets the ids without the attributes which is faster in most cases. It can make sense to disable this option when you use expensive views.

Importação de dados no PostgreSQL

Os dados podem ser importados para PostgreSQL/PostGIS utilizando várias ferramentas, incluindo o plugin SPIT e as ferramentas de linha de comando shp2pgsql e ogr2ogr.

Gerenciador BD

QGIS comes with a core plugin named icon_dbmanager DB Manager. It can be used to load shapefiles and other data formats, and it includes support for schemas. See section Complemento Gerenciador BD for more information.

shp2pgsql

PostGIS inclui um utilitário chamado shp2pgsql que pode ser usado para importar arquivos em um banco de dados habilitado para PostGIS. Por exemplo, para importar um arquivo denominado ‘lakes.shp’ em um banco de dados PostgreSQL chamado “gis_data”, use o seguinte comando:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

Isso cria uma nova camada chamada lakes_new no banco de dados gis_data. A nova camada terá um identificador de referência espacial (SRID) de 2964. Consulte a Seção Trabalhando com Projeções para mais informações sobre os sistemas de referência espacial e projeções.

Dica

Exportando conjuntos de dados do PostGIS

Assim como a ferramenta de importação shp2pgsql, há também uma ferramenta para exportar conjuntos de dados PostGIS como shapefiles: pgsql2shp. Este é enviado dentro de sua distribuição PostGIS.

ogr2ogr

Junto ao shp2pgsql e ao SPIT existe uma outra ferramenta para a insersão de dados geográficos no PostGIS: ogr2ogr. Esta é parte da instalação do GDAL.

Para importar um shapefile no PostGIS, faça o seguinte :

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres
password=topsecret" alaska.shp

Isto irá importar o shapefile alaska.shp para o banco de dados PostGIS postgis usando o usuário postgres com a senha topsecret no servidor myhost.de.

Note que o OGR deve ser construído com PostgreSQL para suportar PostGIS. Você pode ver isso digitando (in nix)

ogrinfo --formats | grep -i post

Se você preferir usar o PostgreSQL com o comando CÓPIA em vez do padrão INSERIR, você pode exportar a seguinte variável de ambiente (pelo menos disponível em | nix | e | OSX |):

export PG_USE_COPY=YES

ogr2ogr ** não cria índices espaciais como **shp2pgsl **. Você precisa criá-los manualmente, usando o comando SQL **CRIAR como um passo extra (como descrito na próxima seção: ref: ‘melhorando a performance do vetor’).

melhorando o Desempenho

Recuperando recursos a partir de um banco de dados PostgreSQL pode ser demorado, especialmente através da rede. Você pode melhorar o desempenho do desenho das camadas PostgreSQL, garantindo que o índice espacial PostGIS existe em cada camada do banco de dados. PostGIS suporta a criação de um índice GiST (Pesquisa em forma de Árvore) para acelerar as pesquisas espaciais dos dados (informações a partir da documentação disponível no PostGIS http://postgis.refractions.net).

A sintaxe para criar um índice GiST é:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Observe que para grandes tabelas, a criação do índice pode levar um longo tempo. Uma vez que o índice é criado, você deve realizar um VACUUM ANALYZE. Consulte a documentação do PostGIS (PostGIS-PROJECT Referências Bibliográficas e Web) para mais informações.

A seguir um exemplo de criação de um índice GiST:

[email protected]:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

Camadas vetoriais que ultrapassam 180° de longitude

Muitos pacotes de SIG não envolve mapas vetoriais com um sistema geográfico de referência (latitude/longitude) cruzando a linha de longitude de 180 graus (http://postgis.refractions.net/documentation/manual-2.0/ST_Shift_Longitude html). Como resultado, se abrirmos esse mapa em | QG |, vamos ver dois pontos, locais distintos, que deve aparecer perto um do outro. Na Figura_vetor_4, o ponto minúsculo no canto esquerdo da tela do mapa (Ilhas Chatham) deve estar dentro da grade, à direita das principais ilhas da Nova Zelândia.

Figure Vector 4:

../../../_images/vectorNotWrapping.png

Mapa em lat/long atravessando a linha de longitude de 180 |graus| nix

A solução alternativa é transformar os valores de longitude utilizando PostGIS e a função ** ST_Shift_Longitude**. Esta função lê cada ponto/vértice dos componentes com recursos de geometria, e se coordenar a longitude < 0 graus, se acrescenta 360 graus a ele. O resultado é 0 graus - 360 graus a serem plotados em um 180 graus em um mapa centralizado.

Figure Vector 5:

../../../_images/vectorWrapping.png

Cruzando 180 | graus | longitude aplicação da função ** ST_Shift_Longitude **

Uso

  • Importar dados para o PostGIS ( ref: ‘vetor_import_data_in_postgis’`), utilizando, por exemplo, o complemento Gerenciador de DB.

  • Use a interface do PostGIS para emitir o seguinte comando (neste exemplo, “tabela” é o nome real da tabela PostGIS): “gis_data = # update TABELA set the_geom = ST_Shift_Longitude (the_geom);”.

  • Se tudo correu bem, você deve receber uma confirmação sobre o número de recursos que foram atualizados. Então você vai ser capaz de carregar o mapa e veja a diferença (Figura_vetor_5).

Camadas SpatiaLite

A primeira vez que você carregar dados de um banco de dados SpatiaLite, comece clicando no | mActionAddSpatiaLiteLayer| arquivo: ‘Adicionar Camada SpatiaLite, ou selecionando a | mActionAddSpatiaLiteLayer|: ‘Adicionar Camada SpatiaLite’ ... opção do menu de seleção ou digitando as teclas: ‘Ctrl + Shift + L’. Isso abrirá uma janela que permitirá que você se conecte a um banco de dados SpatiaLite já conhecido por | QG |, que você pode escolher entre o menu flutuante, ou definir uma nova conexão com um novo banco de dados. Para definir uma nova conexão, clique em ** [Novo] ** e use o navegador para mostrar o banco de dados SpatiaLite, que é um arquivo com extensão ‘.sqlite’.

Se você quiser salvar uma camada do vetor para o formato SpatiaLite, você pode fazer isso com um clique direito na legenda. Em seguida, clique em ‘Salvar como...’, defina o nome do arquivo final, e selecione ‘SpatiaLite’ como formato e o CRS. Além disso, você pode selecionar ‘SQLite’ como formato e, em seguida, adicionar “SpatiaLite = SIM” no campo opção da fonte de dados OGR. Isto diz OGR para criar um banco de dados SpatiaLite. Veja também http://www.gdal.org/ogr/drv_sqlite.html.

QGIS também suporta visualizações editáveis ​​em SpatiaLite.

Criando uma nova camada SpatiaLite

Se você quiser criar uma nova camada SpatiaLite, consulte a seção Criando uma nova camada SpatialLite.

Dica

Gestão complementos de dados SpatiaLite

Para o gerenciamento de dados SpatiaLite, você também pode usar vários complementos em Python: QSpatiaLite, Gerenciamento SpatiaLite ou Gerenciamento de DB (plugin de núcleo, recomendado). Se necessário, eles podem ser baixados e instalados com o Plugin Installer.

Camadas Espaciais MSSQL

mActionAddMssqlLayer QGIS also provides native MS SQL 2008 support. The first time you load MSSQL Spatial data, begin by clicking on the mActionAddMssqlLayer Add MSSQL Spatial Layer toolbar button or by selecting the mActionAddMssqlLayer Add MSSQL Spatial Layer... option from the Layer menu, or by typing Ctrl+Shift+M.

Camadas Espaciais Oracle

As feições espaciais em usuários de próteses Oracle Epacial na gestão de dados geográficos e de localização em um tipo nativo dentro de um banco de dados Oracle. O QGIS agora tem suporte para essas camadas.

Criando uma conexão armazenada

A primeira vez que você usar uma fonte de dados Oracle Espacial, você deve criar uma conexão com o banco de dados que contém os dados. Comece clicando no | mActionAddOracleLayer |: arquivo: ‘Adicionar Oracle Espacial’, selecionando a | mActionAddOracleLayer |: ‘Adicionar Oracle Camada Espacial ... ‘ opção no menu ou digitando as teclas: ‘Ctrl + Shift + O’. Para acessar o gerenciador de conexão, clique em **[novo] ** para exibir o guilabel: ‘Criar uma nova conexão com Oracle Espacial’. Os parâmetros necessários para uma conexão são:

  • Nome: Um nome para esta conexão. Pode ser o mesmo que base de dados

  • Base de dados: SID ou SERVICE_NAME da instância Oracle.

  • Host: Nome do host no banco de dados. Este deve ser um nome de host usado para abrir uma conexão telnet ou ping. Se o banco de dados está no mesmo computador como | QG |, basta digitar ‘localhost’.

  • Port: Número da porta do servidor de banco de dados PostgreSQL. A porta padrão é 1521.

  • Usuário: Nome de usuário usado para acessar o banco de dados.

  • Senha: Senha usada com Nome do Usuário para conectar ao banco de dados.

Opcionalmente, você pode ativar caixas de seleção a seguir:

  • |caixa|: ‘Salvar Nome de Usuário’ Indica salvar o nome de usuário do banco de dados na configuração da conexão.

  • |caixa|: ‘Salvar senha’ Indica se é para salvar a senha do banco de dados nas configurações de conexão.

  • checkbox: guilabel: Olhe somente na tabela de metadados Restringe as tabelas exibidas para aqueles que estão na visão all_sdo_geom_metadata. Isso pode acelerar a exibição inicial de tabelas espaciais.

  • |caixa|: ‘Verificar apenas as tabelas do usuário’ Ao procurar tabelas espaciais, restringir a pesquisa para tabelas que são de propriedade do usuário.

  • checkbox :guilabel: Também lista tabelas sem geometria Indica que tabelas sem geometria também devem ser listados por padrão.

  • checkbox Use estimated table statistics for the layer metadata When the layer is set up, various metadata are required for the Oracle table. This includes information such as the table row count, geometry type and spatial extents of the data in the geometry column. If the table contains a large number of rows, determining this metadata can be time-consuming. By activating this option, the following fast table metadata operations are done: Row count is determined from all_tables.num_rows. Table extents are always determined with the SDO_TUNE.EXTENTS_OF function, even if a layer filter is applied. Table geometry is determined from the first 100 non-null geometry rows in the table.
  • checkbox: guilabel: Somente tipos de geometria existente listar apenas os tipos de geometria existentes e não oferecem para adicionar outros.

Uma vez que todos os parâmetros e as opções estão configuradas, você pode testar a conexão clicando no botão [Testar Conexão].

Dica

QGIS Configurações do Usuário e Segurança

Dependendo do seu ambiente de computacional, armazenamento de senhas nas suas configurações QGIS pode ser um risco de segurança. As senhas são salvas em texto claro na configuração do sistema e nos arquivos do projeto! Suas configurações personalizadas para o QGIS são armazenadas com base no sistema operacional:

  • nix The settings are stored in your home directory in .config/QGIS/QGIS2.conf.
  • win As configurações são armazenadas no registro.

Carregando uma camada Espacial Oracle

mActionAddOracleLayer Uma vez que você tem uma ou mais conexões definidas, você pode carregar camadas do banco de dados Oracle. Claro, isso exige ter dados em Oracle.

Para carregar uma camada Espacial Oracle, execute os seguintes passos:

  • Se a caixa de diálogo Oracle Espacial já estiver aberta clique em: ‘Adicionar’ arquivo: | mActionAddOracleLayer |.

  • Escolha a conexão a partir da lista drop-down e clique em [Conectar].

  • Marque ou desmarque checkbox Listar tabelas sem geometrias

  • Opcionalmente, use o guilabel: ‘Opções de pesquisa’ para definir quais recursos será carregado a partir da camada ou use o botão de ** [Consulta] **.

  • Encontre a camada(s) que deseja adicionar na lista de camadas disponíveis.

  • Selecione-o clicando sobre ele. Você pode selecionar várias camadas, mantendo pressionada a: tecla ‘Shift’ enquanto clica. Consulte a seção ref: ‘vetor_query_builder’ para obter informações sobre o uso de Oracle Consultas para definir a camada.

  • Clique no botão [Add] para adicionar a camada ao mapa.

Dica

Camadas Espacial Oracle

Normalmente, uma camada Espacial Oracle é definida por uma entrada na tabela USER_SDO_METADATA.