.

Editando

QGIS suporta vários recursos para tabelas e camadas vetoriais :índice:`Edição` OGR, SpatiaLite, PostGIS, Espacial MSSQL e Oracle.

Nota

O procedimento para editar camadas do GRASS é diferente - consulte a seção Digitalizando e editando uma camada vetorial GRASS para mais detalhes.

Dica

Edições Simultâneas

Esta versão do QGIS não controla se alguém mais está editando uma feição ao mesmo tempo que você. A última pessoa a salvar suas edições ganha.

Configurando a Tolerância de Atracção e Raio de Pesquisa

Antes de podermos editar os vértices, necessitamos de configurar a tolerância e o raio de pesquisa para um valor que nos permita uma edição ideal das geometrias da camada vetorial.

Tolerância de Atração

Tolerância de Atração é a distância que o QGIS usa para pesquisar por vértice mais próximo e / ou segmento que você está tentando conectar-se quando você define um novo vértice ou move um vértice existente. Se você não estiver dentro da tolerância de atração, o QGIS deixará o vértice onde você soltar o botão do mouse, em vez de agarrar-lo a um vértice e / ou segmento existente. A configuração da tolerância de atração afeta todas as ferramentas que trabalham com tolerância.

  1. A general, project-wide snapping tolerance can be defined by choosing Settings ‣ mActionOptions Options. On Mac, go to QIS ‣ mActionOptions Preferences.... On Linux: Edit ‣ mActionOptions Options. In the Digitizing tab, you can select between ‘to vertex’, ‘to segment’ or ‘to vertex and segment’ as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300 ft at a scale of 1:10000 should be a reasonable setting.
  2. Uma tolerância de encaixe com base em camadas pode ser escolhido pela escolha Definições‣ (or Arquivo‣) Opções de encaixe... para permitir e ajustar o modo de encaixe e tolerância em uma base de camada (ver figure_edit_1).

Note que estes encaixes com base em camadas substitui a opção de encaixe global na aba Digitalização. Então, se você precisa editar uma camada e encaixar seus vértices para outra camada, em seguida habilitando apenas encaixe na camada “encaixar para”, depois diminuir o encaixe global para um valor menor. Além disso, encaixar nunca ocorrerá para uma camada que não está marcada a opção encaixar, independentemente da tolerância de encaixe global. Então tenha certeza de marcar a caixa de seleção para estas camadas que você precisa encaixar.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edição das opções de atracção numa camada base nix

Raio de pesquisa

Pesquisa raio é a distância que p QGIS usa para buscar para o vértice mais próximo que você está tentando mover quando você clicar no mapa. Se você não estiver dentro do raio de busca, o QGIS não vai encontrar e selecionar nenhum vértice para edição, e vai aparecer um aviso irritante para o efeito. Acerte a tolerância e o raio de busca é definido em unidades do mapa ou pixels, para que você possa encontrar o que você precisa experimente definir direito para obtê-los. Se você especificar uma tolerância muito grande, QGIS pode agarrar o vértice errado, especialmente se você está lidando com um grande número de vértices nas proximidades. Defina o raio de busca muito pequeno, e não vai encontrar outro para confundir.

O raio de busca de edições de vértices em unidades da camada pode ser definido no guia Digitizando em :menuselection: ‘Configurações ->`|mActionOptions| :menuselection: opções. Este é o mesmo lugar onde você define o geral, projeto- atração tolerância.

Ampliando e Movendo

Antes de editar uma camada, deve fazer uma ampliação à zona da área de interesse. Isto evita que espere enquanto os marcadores dos vértices são renderizados em toda a camada.

Além de usar os ícones mActionPan mover mapa e mActionZoomIn aproximar / mActionZoomOut afastar na barra de ferramentas com o mause, a navegação pode também ser feita com a roda do mouse, espaço e as teclas de direção.

Ampliando e movendo com a roda do mouse

Enquanto a digitalização, você pode pressionar a roda do mouse para se deslocar dentro da janela principal, e você pode rolar a roda do mouse para ampliar e reduzir o mapa. Para zoom, coloque o cursor do mouse dentro da área do mapa e rodá-lo para a frente (longe de você) para aumentar o zoom; e para trás (na sua direção) para diminuir o zoom. A posição do cursor do mouse será o centro da área ampliada de interesse. Você pode personalizar o comportamento do zoom da roda do mouse usando o :guilabel: aba Ferramentas do Mapa sob o :menuselection: ‘Configurações ->` mActionOptions :menuselection: menu de opções.

Movendo a direção com as setas do teclado

Panorâmica no mapa durante a digitalização é possível com as teclas de seta. Coloque o cursor do mouse dentro da área do mapa, e clique na seta para a direita para se deslocar a leste, seta para a esquerda para mover oeste, seta para cima para deslocar para o norte, e para baixo chave de seta para se deslocar para o sul.

Você também pode usar a barra de espaço para fazer com que temporariamente os movimentos do mouse para percorrer o mapa. A: kbd: PgUp e: kbd:` chaves PgDown` do seu teclado fará a apresentação do mapa para ampliar ou reduzir, sem interromper a sessão de digitalização.

Edição Topológica

Além de opções de ajuste com base em camadas, você também pode definir funcionalidades topológicas no :guilabel: menu de opções Tirando ... diálogo no :menuselection: Configurações (Arquivo ou:: menuselection). Aqui, você pode definir |caixa| :guilabel: ‘Ativar edição` topológica, e / ou para as camadas de polígonos, você pode ativar a coluna |caixa| :guilabel: Evite Int., o que evita intersecção de novos polígonos.

Ativar edição topológica

A opção |caixa| :guilabel: ‘Ativar edição` topológica é para edição e manutenção de limites comuns em mosaicos poligonais. O QGIS ‘detecta’ uma fronteira compartilhada em um mosaico de polígonos, assim você só tem que mover o vértice uma vez, e o QGIS cuidará de atualizar o outro limite.

Evitar intersecções de novos polígonos

A segunda opção topológica na |caixa| :guilabel: Evite coluna Int., chamado :guilabel:` Evite interseções de novo polígonos`, evita sobreposições em mosaicos poligonais. É por digitalização mais rápida de polígonos adjacentes. Se você já tem um polígono, é possível com esta opção para digitalizar o segundo de tal forma que ambos se cruzam, e o QGIS corta então o segundo polígono da fronteira comum. A vantagem é que você não tem que digitalizar todos os vértices da fronteira comum.

Activar atracção nas intersecções

Outra opção é usar |caixa| :guilabel: Habilitar encaixe em intersecção. Ele permite que você encaixe em uma intersecção de camadas de fundo, mesmo se não há nenhum vértice na interseção.

Digitalizar uma camada existente

Por padrão, QGIS carrega camadas de leitura. Esta é uma salvaguarda para evitar que acidentalmente a edição de uma camada se houver um deslize do mouse. No entanto, você pode optar por editar qualquer camada, enquanto o provedor de dados suporta, e a fonte de dados subjacente é gravável (ou seja, seus arquivos não são somente leitura).

In general, tools for editing vector layers are divided into a digitizing and an advanced digitizing toolbar, described in section Digitalização Avançada. You can select and unselect both under Settings ‣ Toolbars ‣. Using the basic digitizing tools, you can perform the following functions:

Ícone

Finalidade

Ícone

Finalidade

mActionAllEdits

Edições actuais

mActionToggleEditing

Alternar edição

mActionCapturePoint

Adicionando Elementos: Capturar Ponto

mActionCaptureLine

Adicionando Elementos: Capturar Linha

mActionCapturePolygon

Adicionando Elementos: Capturar Polígono

mActionMoveFeature

Mover Elemento

mActionNodeTool

Ferramenta de Nós

mActionDeleteSelected

Apagar Selecionados

mActionEditCut

Cortar Elementos

mActionEditCopy

Copiar Elementos

mActionEditPaste

Colar Elementos

mActionSaveEdits

Salvar edições da camada

Edição da Tabela: Edição básica da camada vectorial pela barra de ferramentas

Todas as sessões de edição começa escolhendo o mActionToggleEditing :sup: opção edição alternância. Isto pode ser encontrado no menu de contexto depois botão direito sobre a entrada de legenda para uma determinada camada.

Alternativamente, você pode usar a opção :index: Alternar Edição | mActionToggleEditing |: sup:` botão edição` alternância na barra de ferramentas de digitalização para iniciar ou parar o modo de edição. Uma vez que a camada está em modo de edição, marcadores aparecerá nos vértices, e botões de ferramentas adicionais na barra de ferramentas de edição ficará disponível.

Dica

Salvar Regularmente

Lembre-se de mActionSaveEdits Salvar Edições da Camada regularmente. Isto irá também verificar que a sua fonte de dados aceita todas as alterações.

Adicionando Elementos

Pode usar os ícones mActionCapturePoint Adicionar Elemento, mActionCaptureLine Adicionar Elemento ou mActionCapturePolygon Adicionar Elemento da barra de ferramentas para por o cursor QGIS no modo de digitalização.

Para cada elemento, primeiro digitaliza a geometria, e de seguida introduz os atributos. Para digitalizar a geometria, clique com o botão direito do mouse na área do mapa para criar o primeiro ponto do seu novo elemento.

Para linhas e polígonos, mantenha o clique com o botão direito do mouse para cada ponto adicional que pretende capturar. Quando acabar de adicionar os pontos, clique com o direito do rato em qualquer sítio da área do mapa para confirmar a finalização da introdução da geometria desse elemento.

A janela de atributo aparecerá, permitindo que você insira as informações para a nova feição. Figure_edit_2 mostra definir atributos para um novo rio fictício no Alasca. No :guilabel: menu de Digitalização sob o :menuselection: ‘Configurações -> opções` menu, você também pode ativar | caixa |: guilabel:` Repressão atributos janelas pop-up após cada feição` criado e | caixa |: guilabel: `Reuse último entrou atributo Valor-.

Figure Edit 2:

../../../_images/editDigitizing.png

Introduza os Valores dos atributos na Janela após a digitalização do novo elemento vetorial nix

Com o ícone mActionMoveFeature :sup: Mover Feição (ões) na barra de ferramentas, você pode mover as feições existentes.

Dica

Tipos de Valores de Atributo

Para a edição, os tipos de atributos são validados durante a entrada. Devido a isso, não é possível inserir um número em uma coluna de texto na caixa de diálogo: guilabel: Digite Atributo Valor-ou vice-versa. Se você precisar fazer isso, você deve editar os atributos em uma segunda etapa dentro de: guilabel: `diálogo table atributo.

Edições Atuais

This new feature allows the digitization of multiple layers. Choose mActionFileSaveAs Save for Selected Layers to save all changes you made in multiple layers. You also have the opportunity to mActionRollbackEdits Rollback for Selected Layers, so that the digitization may be withdrawn for all selected layers. If you want to stop editing the selected layers, mActionCancelEdits Cancel for Selected Layer(s) is an easy way.

As mesmas funções estão disponíveis para a edição de todas as camadas do projeto.

Ferramenta de Nós

Para camadas baseadas em shapefile, bem como tabelas SpatialLite, PostgreSQL / PostGIS, MSSQL Spatial e Oracle Spatial, o mActionNodeTool :sup: Ferramenta de Nós fornece capacidades de manipulação de vértices de feições semelhantes aos programas de CAD. É possível simplesmente selecionar vários vértices de uma vez e para se mover, adicionar ou excluí-los por completo. A ferramenta nó também trabalha com ‘on the fly’ projeção ligado, e ele suporta a edição topológica de feições. Esta ferramenta é, ao contrário de outras ferramentas no QGIS, persistente, por isso, quando alguma operação for feito, a seleção permanece ativo por essa ferramenta de feição. Se a ferramenta de nós não é capaz de encontrar todas as feições, um aviso será exibido.

É importante definir a propriedade: menuselection: ‘Configurações –> |mActionOptions|: menuselection:`Opções –> Digitalização –> :guilabel:` Pesquisa Raio: `selectnumber para um número maior que zero (isto é, 10). Caso contrário, QGIS não será capaz de dizer qual vértice está sendo editado.

Dica

Marcadores de Vértice

A versão atual do QGIS suporta três tipos de marcadores de vértice: ‘círculo semi-transparente’, ‘Cruz’ e ‘Nenhum’. Para alterar o estilo de marcador, escolha mActionOptions :menuselection: opções do menu de :menuselection: Configurações, clique na guia :guilabel: Digitalização e selecione a entrada apropriada.

Operações Básicas

Comece por ativar a mActionNodeTool Ferramenta de Nós e selecione um elemento clicando em cima de um, As caixas vermelhos irão aparecer em cada vértice deste elemento.

  • Selecionando vértices: Você pode selecionar vértices, clicando sobre eles um de cada vez, clicando em uma borda para selecionar os vértices em ambas as extremidades, ou clicando e arrastando um retângulo em torno de alguns vértices. Quando um vértice é selecionado, sua cor muda para azul. Para adicionar mais vértices para a seleção atual, mantenha pressionada a :kbd: tecla Ctrl enquanto clica. Mantenha pressionado :kbd: Ctrl ou Shift ao clicar para alternar o estado de seleção de vértices (vértices que estão atualmente desmarcada serão selecionados como de costume, mas também vértices que já estão selecionados será desmarcada).

  • Adicionando vértices: Para adicionar um vértice, basta clicar duas vezes perto de uma borda e um novo vértice aparecerá na borda perto do cursor. Note-se que o vértice aparecerá na borda, não na posição do cursor; por conseguinte, deve ser transferida, se necessário.

  • Eliminar vértices: Depois de selecionar os vértices para eliminar, clique na tecla Delete. Note-se que não pode usar a mActionNodeTool Node Tool para eliminar um elemento completo; QGIS vais assegurar que mantém o número mínimo de vértices necessários para o tipo de elemento que está a trabalhar. Para eliminar um elemente completo, utilize a ferramenta mActionDeleteSelected Delete Selected.

  • Mover vértices: Selecione todos os vértices que pretende mover. Clique num vértice selecionado ou na extreminade e arraste na direção que pretende mover. Todos os vértices selecionados serão movidos em conjunto. Se a ferramenta snapping está ativa, toda a seleção pode saltar para o vértice ou linha mais próximos.

Cada alteração feita com a ferramenta de nó é armazenado como uma entrada separada no diálogo Desfazer. Lembre-se que todas as operações de suporte à edição topológica quando este for ligado. Projeção on-the-fly também é suportada, e a ferramenta de nó fornece dicas para identificar um vértice ao passar o ponteiro do mouse sobre ele.

Cortando, Copiando e Colando Elementos

Feições selecionadas podem ser recortadas, copiadas e coladas entre camadas do mesmo projeto do QGIS contanto que a camada de destino estejam selecionadas como mActionToggleEditing :sup: Alternar edição previamente.

As feições também podem ser coladas para aplicações externas como texto. Ou seja, as feições são representadas no formato CSV, com os dados de geometria que aparece no formato de texto bem delimitado OGC (WKT).

No entanto, nesta versão do QGIS, feições de texto de fora do QGIS não pode ser colado a uma camada dentro de QGIS. Em que a função copiar e colar vir a calhar? Bem, acontece que você pode editar mais de uma camada de cada vez e funcionalidades copiar / colar entre as camadas. Por que iríamos querer fazer isso? Diga o que precisamos fazer algum trabalho em uma nova camada, mas só precisa de um ou dois lagos, e não a 5000 em nosso camada big_lakes``. Podemos criar uma nova camada e use copiar / colar para plop os lagos necessários para ele.

Como exemplo, vamos copiar alguns lagos para uma nova camada:

  1. Carregue a camada que quer copiar a partir (camada de origem)

  2. Carregue ou crie a camada que quer copiar para (camada de destino)

  3. Começar a editar a camada de destino

  4. Ative a camada de origem clicando nela na legenda

  5. Use a ferramenta mActionSelect Selecione Elemento Único para selecionar os elemento(s) na camada fonte

  6. Clique na ferramenta mActionEditCopy Copiar Elementos

  7. Ative a camada de destino clicando na legenda

  8. Clique na ferramenta mActionEditPaste Colar Elementos

  9. Parar a edição e salvar as alterações

O que acontece se as camadas de origem e de destino têm esquemas diferentes (nomes de campo e tipos não são a mesma coisa)? QGIS preenche o que corresponde e ignora o resto. Se você não se importa com os atributos que está sendo copiado para a camada de destino, não importa como você projeta os campos e tipos de dados. Se você quer ter certeza de tudo - a feição e seus atributos - é copiada, verifique se o jogo esquemas.

Dica

Congruência dos Elementos Colados

Se as camadas de fonte e de destino usar a mesma projecção, em seguida, as feições coladas terão geometria idêntica à da camada de fonte. No entanto, se a camada de destino é uma projeção diferente, então QGIS não pode garantir a geometria é idêntica. Isto é simplesmente porque existem erros pequenos arredondamentos envolvidos na conversão entre projeções.

Apagando os Elementos Selecionados

Se quisermos apagar o polígono todo, podemos faze-lo seleccionando o polígono usando a ferramenta mActionSelect Selecionar Elemento Único. Pode selecionar múltiplos elementos para apagar. Uma vez feita a seleção do conjunto, use a ferramenta mActionDeleteSelected Apagar Selecionados para apagar os elementos.

A ferramenta mActionEditCut :sup: Cortar feições na barra de ferramentas de digitalização também pode ser usado para excluir recursos. Isso exclui efetivamente a feição, mas também coloca-lo em uma “área de transferência espacial”. Então, cortamos a feição para excluir. Poderíamos, então, usar a ferramenta mActionEditPaste :sup: Colar Feições para colocá-lo de volta, dando-nos a capacidade de desfazer de um nível. Recortar, copiar e colar o trabalho sobre as feições selecionadas no momento, o que significa que pode operar em mais de um de cada vez.

Salvando as Camadas Editadas

Quando uma camada está no modo de edição, as alterações permanecem na memória de QGIS. Portanto, eles não estão comprometidos / salvos imediatamente à fonte de dados ou disco. Se você quiser salvar as edições da camada atual, mas quero continuar editando sem sair do modo de edição, você pode clicar no botão mActionSaveEdits :sup: Salvar Camadas Editadas. Quando você ativar o modo de edição off com mActionToggleEditing :sup: editando Alternar (ou sair QGIS para que o assunto), você também perguntado se você deseja salvar as alterações ou descartá-las.

Se as alterações não podem ser salvas (por exemplo, disco cheio, ou os atributos têm valores que estão fora de alcance), o estado em memória do QGIS é preservado. Isso permite que você ajuste as suas edições e tente novamente.

Dica

Integridade dos dados

É sempre boa ideia fazer cópias de segurança da sua fonte de dados antes de começar a editar. Enquanto os autores do QGIS fizeram todo o esforço para preservar a integridade dos seus dados, nós não oferecemos garantia neste sentido.

Digitalização Avançada

Ícone

Finalidade

Ícone

Finalidade

mActionUndo

Retroceder

mActionRedo

Retomar

mActionRotateFeature

Rodar Elemento(s)

mActionSimplify

Simplificar elemento

mActionAddRing

Adicionar Anel

mActionAddPart

Adicionar Parte

mActionFillRing

Preenchimento Anel

mActionDeleteRing

Apagar Anel

mActionDeletePart

Apagar Parte

mActionReshape

Refazer elementos

mActionOffsetCurve

Curva de Afastamento

mActionSplitFeatures

Dividir Elementos

mActionSplitParts

Dividindo partes

mActionMergeFeatures

Juntar Elementos Selecionados

mActionMergeFeatureAttributes

Juntar Atributos dos Elementos Selecionados

mActionRotatePointSymbols

Rodar Símbolos de Pontos

Tabela de edição avançada: Barra de ferramentas de edição avançada de camadas vetoriais

Retroceder e Retomar

As ferramentas mActionUndo :sup: Desfazer e mActionRedo Refazer permitem desfazer ou refazer operações de edição de vetores. Há também uma tela acoplável, que mostra toda o histórico de todas operações desfazer / refazer (veja Figure_edit_3). Este elemento não é exibido por padrão; ele pode ser exibido com um clique direito na barra de ferramentas e ativando a opção Desfazer / Refazer. Desfazer / Refazer é no entanto ativo, mesmo que a tela não esteja sendo exibida.

Figure Edit 3:

../../../_images/redo_undo.png

Refazer e desfazer passos de digitalização nix

Quando Desfzer é atingido, o estado de todas as feições e atributos são revertidos para o estado antes da reversão da operação acontecer. Outras mudanças para além das operações normais de edição vetorial (por exemplo, alterações feitas por um complemento), podem ou não podem serem revertidas, dependendo de como as mudanças foram realizadas.

Para usar a tela histórico de desfazer / refazer, basta clicar para selecionar uma operação na lista de histórico. Todas as feições serão revertidas para o estado em que estavam depois da operação selecionada.

Rodar Elemento(s)

Use mActionRotateFeature Rotação de feição(s) para rodar uma ou várias feições selecionadas na tela do mapa. Você primeiro precisa selecionar as feições e, em seguida, pressione o ícone mActionRotateFeature Rotação de feição(s). O centro de gravidade da feição(s) aparece e será o ponto de ancoragem da rotação. Se você tiver selecionado várias feições, o ponto de ancoragem da rotação será o centro comum das feições. Pressione e arraste o botão esquerdo do mouse na direção desejada para girar as feições selecionadas.

Também é possível criar um ponto de ancoragem de rotação definido pelo usuário em torno do qual a feição selecionada irá rodar. Selecione as feições para girar e ativar a ferramenta mActionRotateFeature :sup: Rotação de feição(s). Pressione e segure o botão :kbd: Ctrl e mova o ponteiro do mouse (sem pressionar o botão do mouse) para o local onde deseja que a âncora de rotação seja movida. Solte o botão Ctrl no ponto de ancoragem de rotação desejada. Agora, pressione e arraste o botão esquerdo do mouse na direção desejada para girar a função selecionada (s).

Simplificar elemento

The mActionSimplify Simplify Feature tool allows you to reduce the number of vertices of a feature, as long as the geometry doesn’t change. First, select a feature. It will be highlighted by a red rubber band and a slider will appear. Moving the slider, the red rubber band will change its shape to show how the feature is being simplified. Click [OK] to store the new, simplified geometry. If a feature cannot be simplified (e.g. multi-polygons), a message will appear.

Adicionar Anel

Você pode criar :índice:`polígonos anéis` usando o ícone mActionAddRing Adicionar Anel na barra de ferramentas. Isto significa que no interior de uma área existente, é possível digitalizar outros polígonos que ocorrem como um “orifício”, de modo que apenas a zona entre as fronteiras dos polígonos exterior e interior continua sendo um anel poligonal.

Adicionar Parte

Você pode mActionAddPart adicionar parte no polígonos selecionado :índice:`multipolígono`. A nova parte do polígono deve ser digitadas fora do multi-polígono selecionado.

Preenchimento Anel

Você pode usar a função mActionFillRing Preenchimento Anel para adicionar um toque a um polígono e adicionar uma nova feição para a camada ao mesmo tempo. Assim, você não precisa usar primeiro o ícone mActionAddRing Adicionar Anel e então a função a mais mActionCapturePolygon Adicionar feição.

Apagar Anel

A ferramenta | mActionDeleteRing |: sup: Excluir Anel permite excluir polígonos anel dentro de uma área existente. Esta ferramenta só funciona com camadas de polígonos. Isso não muda nada quando ele é usado no anel externo do polígono. Esta ferramenta pode ser utilizada em polígonos e multi-funções poligonais. Antes de selecionar os vértices de um anel, ajuste a tolerância na edição do vértice.

Apagar Parte

A ferramenta | mActionDeletePart |: sup: Excluir Parte permite apagar partes de multifeições (por exemplo, para excluir os polígonos de uma feição de multi-polígono). Não vai apagar a última parte da feição; esta última parte vai ficar intocada. Esta ferramenta funciona com todas as geometrias multi-parte: ponto, linha e polígono. Antes de selecionar os vértices de um papel, ajustar a tolerância de edição do vértice.

Refazer elementos

Você pode alterar feições de linha e polígono usando o ícone | mActionReshape |: sup: Remodelar Feições na barra de ferramentas. Ele substitui a linha ou polígono parte da primeira para a última intersecção com a linha original. Com polígonos, às vezes isso pode levar a resultados indesejados. É útil principalmente para substituir partes menores de um polígono, não para grandes reparações, e a linha de remodelar não é permitido atravessar vários anéis de polígonos, pois isso geraria um polígono inválido.

Por exemplo, pode editar o limite de um polígono com esta ferramenta. Primeiro, clique na área interna do polígono junto do ponto onde pretende adicionar o novo vértice. Depois, atravesse o limite e adicione os vértices no exterior do polígono. Para finalizar, clique com o botão direito na área interna do polígono. A ferramenta vai adicionar um nó automaticamente no ponto onde a linha atravessa o limite. Também é possível remover parte da área do polígono, começa-se a nova linha no exterior do polígono, adicionam-se vértices no interior e termina-se a linha no exterior do polígono com um clique no botão direito.

Nota

A ferramenta de mudança de forma pode alterar a posição inicial de um anel ou de uma linha poligonal fechada. Assim, o ponto que está representada ‘duas vezes’ não será o mesmo mais. Isto pode não ser um problema para a maioria das aplicações, mas é algo a considerar.

Curvas de Afastamento

The mActionOffsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (in which case it creates copies of the lines / rings and adds them to the the edited layer). It is thus ideally suited for the creation of distance line layers. The displacement is shown at the bottom left of the taskbar. To create a shift of a line layer, you must first go into editing mode and then select the feature. You can make the mActionOffsetCurve Offset Curve tool active and drag the cross to the desired distance. Your changes may then be saved with the mActionSaveEditsSave Layer Edits tool.

Dividir Elementos

Pode dividir elementos usando o ícone mActionSplitFeatures Dividir Elementos da barra de ferramentas. Apenas desenhe uma linha ao longo do elemento que quer dividir.

Dividindo partes

No QGIS 2.0, é possível dividir as partes de uma feição de multi parte de modo a que o número de peças é aumentado. Basta desenhar uma linha em toda a parte que você quer dividir com o ícone mActionSplitParts Dividir Partes.

Juntar elementos selecionados

The mActionMergeFeatures Merge Selected Features tool allows you to merge features that have common boundaries and the same attributes.

Juntar os atributos dos elementos selecionados

A ferramenta mActionMergeFeatureAttributes :sup: Mesclar Atributos das Feições escolhidas permite :índice:`mesclar atributos de feições` com fronteiras comuns fundir e atributos sem a fusão de suas fronteiras. Primeiro, selecione várias feições ao mesmo tempo. Em seguida, pressione o botão mActionMergeFeatureAttributes | |: sup: `Mesclar Atributos de feições selecionadas`. Agora |qg| pede-lhe os atributos que devem ser aplicados a todos os objetos selecionados. Como resultado, todos os objetos selecionados têm as mesmas entradas de atributos.

Rodar Símbolos de Pontos

mActionRotatePointSymbols Rotate Point Symbols allows you to change the rotation of point symbols in the map canvas. You must first define a rotation column from the attribute table of the point layer in the Advanced menu of the Style menu of the Layer Properties. Also, you will need to go into the ‘SVG marker’ and choose Data defined properties .... Activate checkbox Angle and choose ‘rotation’ as field. Without these settings, the tool is inactive.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rodar Símbolos de Pontos nix

Para alterar a rotação, selecione um recurso ponto na tela do mapa e gire-o, segurando o botão esquerdo do mouse pressionado. A seta vermelha com o valor de rotação será visualizado (ver Figura_editada_4). Quando você soltar o botão esquerdo do mouse novamente, o valor será atualizado na tabela de atributos.

Nota

Se segurar a tecla Ctrl premido, a rotação irá ser feita em passos de 15 graus.

Criando novas camadas Vetoriais

QGIS allows you to create new shapefile layers, new SpatiaLite layers, and new GPX layers. Creation of a new GRASS layer is supported within the GRASS plugin. Please refer to section Criando uma nova camada vetorial GRASS for more information on creating GRASS vector layers.

Criando uma nova camada Shapefile

Para criar uma nova camada de forma para edição, escolha: seleção de menu: Novo -> | mActionNewVectorLayer |: seleção de menu Novo Shapefile Camada ... do: menu de seleção: menu de Camada. A: guilabel: diálogo Novo Vetor de Camada será exibido como mostrado na Figure_editada_5. Escolha o tipo de camada (ponto, linha ou polígono) e CRS (sistema de coordenadas de referência).

Note-se que o QGIS ainda não suporta a criação de feições 2.5D (ou seja, com características X, Y, Z).

Figure Edit 5:

../../../_images/editNewVector.png

Janela de criação de uma nova camada Shapefile nix

Para concluir a criação da nova camada arquivo shape, adicione os atributos desejados clicando no botão ** [Adicionar à lista de atributos] ** e especificar um nome e tipo para o atributo. A primeira coluna ‘código’ é adicionado como padrão, mas pode ser removido, se não quiser. Apenas: guilabel: Tipo: real | String |,: guilabel:` Tipo: inteiro’ | String |,: guilabel: Tipo: string | String | e: guilabel:` Tipo: data` | String | atributos são suportados. Além disso e de acordo com o tipo de atributo, você também pode definir a largura e a precisão da nova coluna de atributo. Quando estiver satisfeito com os atributos, clique ** [OK] ** e forneça um nome para o arquivo shape. | QG | irá adicionar automaticamente um: arquivo: .shp extensão para o nome que você especificar. Uma vez que a camada foi criado, ele será adicionado ao mapa, e você pode editá-lo da mesma forma como descrito na seção: ref: sec_edit_existing_layer acima.

Criando uma nova camada SpatialLite

Para criar uma nova camada SpatialLite para edição, escolha Novo ‣ mActionNewSpatiaLiteLayer Nova Camada SpatiaLite... do menu Camada. O diálogo Nova Camada SpatiaLite irá aparecer como é mostrado na Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Janela de criação de uma nova camada SpatialLite nix

A primeira etapa consiste em selecionar um banco de dados SpatiaLite existente ou criar uma nova base de dados SpatiaLite. Isso pode ser feito com o botão de navegação | browsebutton | à direita do campo de banco de dados. Em seguida, adicione um nome para a nova camada, definir o tipo de camada, e especificar o sistema de referência de coordenadas com ** [Especificar CRS] **. Se desejar, você pode selecionar | caixa |: guilabel: ‘Criar uma chave` primária auto incrementol.

Para definir uma tabela de atributos para a nova camada SpatiaLite, adicione os nomes das colunas de atributos que você deseja criar com o tipo de coluna correspondente e clique no botão ** [Adicionar à lista de atributos] **. Quando estiver satisfeito com os atributos, clique ** [OK] **. | QG | adiciona automaticamente a nova camada com a legenda, e você pode editá-lo da mesma forma como descrito na seção: ref: sec_edit_existing_layer acima.

O tratamento adicional das camadas SpatiaLite pode ser feito com o Gerenciador BD. Veja Complemento Gerenciador BD.

Criando uma nova camada GPX

Para criar um novo arquivo GPX, você precisa carregar o plugin GPS em primeiro lugar. : menu de seleção: Plugins -> | mActionShowPluginManager |: menu de seleção: ‘Gerenciador de Plugin ...` abre o Gerenciador de diálogo de Plugin. Ative a | caixa |: guilabel: ‘Ferramentas GPS’.

Quando este plugin é carregado, escolha: menu de seleção: Novo -> | icon_newgpx |: menu de seleção: ‘Criar nova camada GPX ... do: menu de seleção: menu de Camada`. No: guilabel: ‘Salvar como novo arquivo GPX`, você pode escolher onde deseja salvar a nova camada GPX.

Trabalhando com a Tabela de Atributos

O: índice: atributo da tabela exibe características de uma camada selecionada. Cada linha na tabela representa um recurso de mapa, e cada coluna contém uma determinada parte das informações sobre o recurso. Recursos na tabela pode ser pesquisado, selecionado, movido ou mesmo editadas.

Para abrir a tabela de atributos de uma camada do vetor, fazer a camada ativa, clicando sobre ela na área do mapa legenda. Então, a partir do principal: menu de seleção: menu de Camada, escolha | mActionOpenTable |: menu de seleção: ‘Abrir Tabela de Atributos`. Também é possível fazer um clique direto sobre a camada e escolha | mActionOpenTable |: menu de seleção: ‘Abrir Tabela de Atributos` a partir do menu suspenso, e clique no | mActionOpenTable |: guilabel: botão Abrir Tabela de Atributos na barra de ferramentas.

Isto irá abrir uma nova janela que exibe os atributos do recurso para a camada (figura_atributos_1). O número de recursos e o número de recursos selecionados são mostrados no título da tabela de atributos.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Tabela de Atributos para a camada regiões nix

Selecionando elementos na tabela de atributos

Cada linha selecionada na tabela de atributos representa os atributos de um determinado elemento da camada. Se o conjunto de elementos selecionados na janela principal é alterado, a seleção também é atualizada na tabela de atributos. Da mesma forma, se um conjunto de linhas selecionadas na tabela de atributos é modificada, o conjunto de elementos selecionado na janela principal será atualizado.

As linhas podem ser selecionadas ao clicar no número da linha, do lado esquerdo desta. Podem ser marcadas Linhas múltiplas manter a tecla Ctrl primida. Pode ser feita uma seleção contínua se manter primida a tecla Shift e clicar na entrada de várias linha, do lado esquerdo. Todas as linhas entre a posição atual do cursor e a linha clicada serão selecionados. Ao mover a posição do cursor na tabela de atributos, ao clicar um célula na tabela, não tem influência na seleção de linhas. Modificar a seleção na tela principal não altera a posição do cursor na tabela de atributos.

A tabela pode ser ordenada por qualquer coluna, clicando no cabeçalho da coluna. Uma pequena seta indica a forma de ordenação (apontar para baixo significa valores descendentes do topo da linha, apontar para cima significa valores descendentes do topo da linha).

Para uma simples busca por atributos em apenas uma coluna, escolha o: menu de seleção: filtrar Coluna -> a partir do menu no canto inferior esquerdo. Selecione o campo (coluna) em que a pesquisa deve ser realizada a partir do menu suspenso, e acertar o botão [Aplicar] . Então, apenas os recursos relacionados são mostrados na tabela de atributos.

Para fazer uma seleção, você tem que usar o | mIconExpressionSelect |: sup: SELECIONAR recursos usando o ícone Expressão` no topo da tabela de atributos. | mIconExpressionSelect |: sup: SELECIONAR recursos usando uma Expressão` permite definir um subconjunto de uma tabela usando um: guilabel: Lista de Funções como no | mActionCalculateField |: sup:` Campo Calculadora` (veja: ref: vetor_campo_calculadora). Os resultados da consulta podem ser salvos como uma nova camada vetorial. Por exemplo, se você quiser encontrar regiões que são bairros de: arquivo: regiões.shp do | QG | dados de exemplo, você tem que abrir o: guilabel:` Campos e Valor-menu e escolher o campo que você deseja consultar. Clique duas vezes no campo ‘TIPO_2’ e também ** [Carregar todos os valores únicos] **. A partir da lista, selecione e clique duas vezes em Cidade. No: guilabel: campo Expressão, a consulta a seguir será exibida

"TYPE_2"  =  'Borough'

Aqui você também pode usar o: menu de seleção: lista de Funções -> recente (Seleção) para fazer uma seleção que você usou antes. O construtor de expressão se lembra dos últimos 20 expressões usadas.

As linhas correspondentes serão selecionados, e o número total de linhas correspondentes será exibida na barra de título da tabela de atributos, bem como na barra de status da janela principal. Para pesquisas que apresentam características só selecionadas no mapa, use o Construtor de Consultas descrito na seção: ref: vetor_consultas_construtor.

Para mostrar apenas os registros selecionados, use Mostrar feições selecionadas a partir do menu na parte inferior esquerda.

Os outros botões na parte superior da janela de tabela de atributos fornecem as seguintes funcionalidades:

  • mActionToggleEditing Alternar o modo de edição para editar valores individuais e permitir funcionalidades descritas abaixo (também com Ctrl+E)

  • mActionSaveEdits Salvar Editados (também com Ctrl+S)

  • mActionUnselectAttributes Desselecionar todosl (também com Ctrl+U)

  • mActionSelectedToTop Mover seleção para o topo (também com Ctrl+T)

  • mActionInvertSelection Inverter seleção (também com Ctrl+R)

  • mActionCopySelected Copiar linhas selecionadas para área de transferência (também com Ctrl+C)

  • mActionZoomToSelected Zoom no mapa para linhas selecionadas (também com Ctrl+J)

  • PanToSelected Pan no mapa para linhas selecionadas (também com Ctrl+P)

  • mActionDeleteSelected Deletar feição selecionada (também com Ctrl+D)

  • mActionNewAttribute Nova Coluna para camadas PostGIS e para camadas OGR com versão GDAL >= 1.6 (também com Ctrl+W)

  • mActionDeleteAttribute Deletar Coluna para camadas PostGIS e para camadas OGR com versão >= 1.9 (também com Ctrl+L)

  • mActionCalculateField Abrir calculadora de campo (também com Ctrl+I)

Dica

Ignorar geometria WKT

Se você quiser usar dados de atributos em programas externos (como Excel), use o | mActionCopySelected |: sup: Copiar as linhas selecionadas para o botão clipe. Você pode copiar as informações sem geometrias vetoriais se você desativar: menu de seleção: `Configurações -> Opções -> Fontes de dados do menu | caixa |: guilabel: Copiar geometria na representação WKT de atributo tabela.

Salvar elementos selecionados como nova camada

The selected features can be saved as any OGR-supported vector format and also transformed into another coordinate reference system (CRS). Just open the right mouse menu of the layer and click on Save selection as ‣ to define the name of the output file, its format and CRS (see section Legenda do Mapa). It is also possible to specify OGR creation options within the dialog.

Colar dentro de nova camada

Recursos que estão na área de transferência pode ser colado em uma nova camada. Para fazer isso, primeiro faça uma camada editável. Selecione algumas características, copiá-los para a área de transferência e colá-los em uma nova camada usando: menu de seleção: Editar -> Colar Características e escolher: menu de seleção:` Nova Camada` no vetor ou: menu de seleção: Nova Camada na memória .

Isso se aplica a recursos selecionados e copiados dentro | QG | e também para recursos de outra fonte definida de acordo com o texto conhecido (WKT).

Trabalhando com tabelas de atributos não espaciais

QGIS allows you also to load non-spatial tables. This currently includes tables supported by OGR and delimited text, as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table, you will see it in the legend field. It can be opened with the mActionOpenTable Open Attribute Table tool and is then editable like any other layer attribute table.

Como exemplo, você pode usar colunas da tabelas não espaciais para definir valores de atributos, ou um intervalo de valores que são permitidos, para ser adicionado a uma camada de vetor específico durante a digitalização. Dê uma olhada mais de perto o widget de edição na seção: ref: vetor_atributos_menu para saber mais.

Criando uma ou mais relações

As relações são uma técnica frequentemente utilizada em bancos de dados. O conceito é, que as características (linhas) de diferentes camadas (tabelas) podem pertencer a um ao outro.

Como um exemplo, você tem uma camada com todas as regiões do Alasca (polígono), que fornece alguns atributos sobre o seu nome e tipo de região e um código único (que atua como chave primária).

Chaves Externas

Então você começa uma outra camada de ponto ou tabela com informações sobre aeroportos que estão localizados nas regiões e também querem manter o controle deles. Se você deseja adicioná-los à camada região, você precisa criar uma relação de um para muitos usando chaves estrangeiras, porque existem vários aeroportos na maioria das regiões.

Figure Relations 1:

../../../_images/relations1.png

Região Alaska com aeroportos nix

Além dos atributos já existentes na tabela de atributos de airport outro campo fk_region que atua como uma chave estrangeira (se você tiver um banco de dados, você provavelmente vai querer definir uma restrição sobre ele).

Este campo fk_região sempre conterá um codigo de uma região. Pode ser visto como um indicador para a região a que pertence. E você pode criar um formulário de edição personalizada para a edição e QGIS se preocupa com a configuração. Ele trabalha com diversos fornecedores (para que você também pode usá-lo com os arquivos de vários formatos e csv) e tudo o que você tem a fazer é as relações entre as tabelas QGIS.

Camadas

QGIS não faz diferença entre uma tabela e uma camada vetorial. Basicamente, uma camada de vetor é uma tabela com uma geometria. Então, pode adicionar sua tabela como uma camada vetorial. Para demostrar você pode carregar o arquivo shape “região” (com geometrias) e a tabela ‘aeroporto’ csv (sem geometrias) e uma chave estrangeira (fk_região) para a região da camada. Isto significa que cada aeroporto pertence a exatamente uma região, enquanto cada região pode ter qualquer número de aeroportos (a típica relação de um para muitos).

Definição (Gerenciador de relação)

A primeira coisa que vamos fazer é deixar QGIS saber sobre as relações entre a camada. Isso é feito em: menu de seleção: ‘Configurações -> : menu de seleção: Projeto Propriedades`. Abra o: guilabel: menu de Relações e clique em: guilabel:` Adicionar`.

  • nome vai ser utilizado como um título. Deve ser um texto legível, descrevendo, para que a relação é utilizada. Vamos apenas dizer chamada “Airports” neste caso.

  • camada de referência é o único com o campo de chave estrangeira sobre ele. No nosso caso, esta é a camada airports

  • campo referência dirá, quais os pontos de campo para a outra camada de modo que este será fk_region neste caso

  • camada referenciada é a única com a chave primária, apontada, então aqui está a camada de regiões

  • campo referenciado é a chave primária da camada referenciada por isso é ID

  • **código ** será usado para fins internos e tem de ser único. Você pode precisar dele para criar formulários personalizados uma vez que este é suportado. Se você deixá-lo vazio, será gerada para você, mas você pode atribuir um para obter que é mais fácil de manusear.

Figure Relations 2:

../../../_images/relations2.png

Gerenciador de relações nix

Formas

Agora que QGIS conhece a relação, ele vai ser usado para melhorar as formas que são gerados. Como nós não alteramos o método de formulário padrão (gerada automaticamente) ele vai apenas adicionar um novo widget em nosso formulário. Então, vamos selecionar a região de camada na legenda e use a ferramenta para identificar. Dependendo das configurações, o formulário pode ser aberto diretamente ou você terá que optar por abri-lo na janela de identificação no âmbito de ações.

Figure Relations 3:

../../../_images/relations3.png

Diálogo identificação regions com relação a airports nix

Como você pode ver, os aeroportos atribuídos a esta região em particular são todos mostrados em uma tabela. E há também alguns botões disponíveis. Vamos revê-los em breve

  • O botão | mActionToggleEditing | serve para alternar o modo de edição. Esteja ciente de que ele alterna o modo de edição da camada de aeroporto, apesar de estarmos na forma de uma característica da camada região. Mas o quadro está representando características da camada aeroporto.

  • O botão | mActionSignPlus | irá adicionar um novo recurso para a camada de aeroporto. E vai atribuir um novo aeroporto para a região atual por padrão.

  • O botão mActionRemove apagará o aeroporto selecionado permanentemente.

  • O símbolo | mActionLink | irá abrir uma nova janela onde você pode selecionar qualquer aeroporto existente, que será, então, atribuído à região atual. Isto pode ser útil se você criou o aeroporto na região errada por acidente.

  • O símbolo | mActionUnlink | desvincula o aeroporto selecionado da região atual, deixando-os não atribuído (a chave estrangeira é definida como NULO) de forma eficaz.

  • Os dois botões para a chave de visualização da tabela e formulário, onde o deixou-nos mais tarde, você vê todos os aeroportos no seu respectivo formulário.

Se você trabalha na tabela aeroporto, um novo tipo de widget está disponível que permite que você incorpore a forma característica da região referenciada na forma característica dos aeroportos. Ele pode ser usado quando você abre as propriedades da camada da tabela de aeroportos, mude para o: menu de seleção: menu de campos e mudar o tipo de widget do campo de chave estrangeira ‘fk_região’ a relação de referência.

Se você olhar para a caixa de diálogo agora, você vai ver, que a forma de a região estar inserida dentro do formulário aeroportos e até mesmo ter um caixa de combinações, que permite atribuir o atual aeroporto para outra região.

Figure Relations 4:

../../../_images/relations4.png

Diálogo identificação aeroportos com relação a regiões nix