` `

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Options, Project Properties and Customization.

Nota

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described below could be in the Project or the Settings menu.

Opções

options Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ options Options. You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

The tabs where you can customize your options are described below.

General Settings

Aplicação

  • Select the Style (QGIS restart required) selectString and choose between ‘Oxygen’, ‘Windows’, ‘Motif’, ‘CDE’, ‘Plastique’ and ‘Cleanlooks’.
  • Define the Icon theme selectString. It can be ‘default’ or ‘Night Mapping’.
  • Define the Icon size selectString.
  • Define the Font and its Size. The font can be radioButtonOn Qt default or a user-defined one.
  • Change the Timeout for timed messages or dialogs selectString.
  • checkbox Não exibir a janela inicial

  • checkbox Mostrar dicas ao iniciar

  • checkbox Check QGIS version at startup to keep you informed if a newer version is released
  • checkbox QGIS-estilo das caixas de grupo

  • checkbox Use native color chooser dialogs (see Color Selector)
  • checkbox Use live-updating color chooser dialogs (see Color Selector)
  • checkbox Canvas rotation support (restart required)

Arquivos de projeto

  • Open project on launch selectString (choose between ‘New’, ‘Most recent’, ‘Welcome Page’, and ‘Specific’). When choosing ‘Specific’ use the browseButton to define the project to use by default. The ‘Welcome Page’ displays a list of recent projects with screenshot.
  • checkbox Criar um novo projeto como projeto padrão. Tem a possibilidade de carregar em Usar projeto atual com padrão ou em Resetar padrão. Pode navegar através dos seus arquivos e definir um diretório onde encontra os modelos de projeto definidos pelo usuário. Isto será adicionado a Projeto ‣ Novo do modelo. Primeiro ative checkbox Criar novo projeto como projeto padrão e a seguir salve o projeto dentro da pasta de modelos de projeto.

  • checkbox Avisar para salvar projeto e alterações de fontes de dados quando necessário

  • checkbox Solicitar confirmação quando uma camada for ser removida

  • checkbox Avisar quando abrir um projeto salvado com uma versão antiga do |qg|

  • Enable macros selectString. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

System Settings

SVG paths

Add or Remove Path(s) to search for Scalable Vector Graphic (SVG) symbols. These SVG files are then available to symbolize features or decorate your map composition.

Diretórios dos complementos

Add or Remove Path(s) to search for additional C++ plugin libraries

QSettings

It helps you Reset user interface to default settings (restart required) if you made any customization.

Ambiente

Variáveis de ambiente do sistema podem ser vistas agora, e muitas configuradas, no grupo Environment (ver figure_environment_variables). Isto é útil para plataformas, tais como Mac, onde um aplicativo GUI não herda necessariamente o ambiente do utilizador da linha de comandos. Também é útil para configuração e visualização de variáveis de ambiente para os conjuntos de ferramentas externas controlados pela caixa de ferramentas de Processamento (p. ex., SAGA, GRASS), e para ativar a saída de depuração (“debugging”) para seções específicas do código-fonte.

  • checkbox Utilize variáveis ​​personalizadas (Reinício necessário - incluem separadores). Você pode [Adicionar] e [remover] variáveis. Variáveis ​​de ambiente já definidas são exibidos em variáveis de ambiente ​​atual, e é possível filtrá-las ativando checkbox Mostrar somente variáveis ​específicas-QGIS.

../../../_images/sys-env-options.png

System environment variables in QGIS

Data Sources Settings

Atributos dos elementos e tabela

  • checkbox Open attribute table in a dock window
  • Copy features as ‘Plain text, no geometry’, ‘Plain text, WKT geometry’, or ‘GeoJSON’ when pasting features in other applications.
  • Attribute table behavior selectString: set filter on the attribute table at the opening. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Default view: define the view mode of the attribute table at every opening. It can be ‘Remember last view’, ‘Table view’ or ‘Form view’.
  • Attribute table row cache selectNumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representação para valores NULL. Aqui, pode definir um valor para os campos de dados que contêm valores NULL.

Dica

Improve opening of big data attribute table

When working with layers with big amount of records, opening the attribute table may be slow as the dialog request all the rows in the layer. Setting the Attribute table behavior to Show features visible on map will make QGIS request only the features in the current map canvas when opening the table, allowing a quick data loading.

Note that data in this attribute table instance will be always tied to the canvas extent it was opened with, meaning that selecting Show All Features within such a table will not display new features. You can however update the set of displayed features by changing the canvas extent and selecting Show Features Visible On Map option in the attribute table.

Manipulação das fontes de dados

  • Scan for valid items in the browser dock selectString. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectString. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Solicitar subcamadas raster ao abrir. Alguns rasters suportam subcamadas — elas são chamadas de subdatasets no GDAL. Um exemplo são os arquivos netCDF — se há muitas variáveis ​​netCDF, GDAL verá cada variável como um subdataset. A opção permite que você controle como lidar com subcamadas quando um arquivo é aberto com subcamadas. Você tem as seguintes opções:

    • ‘Sempre’: Perguntar sempre (se existem subcamadas)

    • ‘Se necessário’: Perguntar se a camada não tem bandas, mas tem subcamadas

    • ‘Nunca’: Nunca pede, não irá carregar nada

    • ‘Carregar tudo’: Nunca pede, mas carrega todas as subcamadas

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Adicionar camadas PostGIS com duplo clique e seleciona no modo estendido

  • checkbox Adicione camadas Oracle com duplo clique e selecione em modo extendido

  • checkbox Execute expressions on server-side if possible

Hidden Browser Path

This widget lists all the folder you chose to hide from the Browser panel. Removing a folder from the list will make it available in the Browser panel.

Rendering Settings

../../../_images/rendering_menu.png

Rendering tab of Project Properties dialog

Rendering behavior

  • checkbox Por padrão novas camadas adicionadas ao mapa devem ser exibidas

  • checkbox Use tornar cache sempre que possível para acelerar redesenhos

  • checkbox Representação de camadas em paralelo utilizando muitos núcleos CPU

  • checkbox Máximo de núcleos para utilizar

  • Intervalo de atualização do mapa (por padrão 250 ms)

  • checkbox Enable feature simplification by default for newly added layers
  • Simplificação de limiar

  • Simplification algorithm: This option performs a local “on-the-fly” simplification on feature’s and speeds up geometry rendering. It doesn’t change the geometry fetched from the data providers. This is important when you have expressions that use the feature geometry (e.g. calculation of area) - it ensures that these calculations are done on the original geometry, not on the simplified one. For this purpose, QGIS provides three algorithms: ‘Distance’ (default), ‘SnapToGrid’ and ‘Visvalingam’.
  • checkbox Simplify on provider side if possible: the geometries are simplified by the provider (PostGIS, Oracle...) and unlike the local-side simplification, geometry-based calculations may be affected
  • Escala máxima a que a camada deve simplificar

  • doubleSpinBox Magnification level (see the magnifier)

Nota

Besides the global setting, feature simplification can be set for any specific layer from its Layer properties ‣ Rendering menu.

Qualidade de renderização

  • checkbox Faz com que as linhas apareçam menos irregulares, em detrimento de algum desempenho do desenho

Curve segmentation

  • Segmentation tolerance: this setting controls the way circular arcs are rendered. The smaller maximum angle (between the two consecutive vertices and the curve center, in degrees) or maximum difference (distance between the segment of the two vertices and the curve line, in map units), the more straight line segments will be used during rendering.

  • Tolerance type: it can be ‘Maximum angle’ or ‘Maximum distance’

    Matriciais

  • Com a Seleção de banda RGB pode definir o número para a banda Vermelha, Verde e Azul.

Melhora de contraste

  • Single band gray selectString. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectString. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Limites de contagem cumulativa de pixeis de corte

  • Multiplicador do desvio-padrão

Corrigindo Erros

  • checkbox Atualiza o mapa da tela

Colors Settings

Esse menu permite adicionar cores personalizadas que poderão ser encontradas em cada caixa de diálogo de renderização. É apresentado um conjunto de cores predefinidas na tab: você pode deletar ou editar todas. Mais ainda, você pode adicionar as cores que quiser e realizar algumas operações de copia e cola. Finalmente, você pode importar ou exportar o conjunto de cores como um arquivo gpl.

Canvas and Legend Settings

Aparência padrão do mapa (reescrita pelas propriedades do projeto)

  • Define a Cor da seleção e a Cor de fundo.

Legenda da camada

  • Double click action in legend selectString. You can either ‘Open layer properties’, ‘Open attribute table’ or ‘Open layer styling dock’ with the double click.
  • As seguintes Estilos de itens de legenda são possíveis:

    • checkbox Tornar maiúsculo os nomes da camada

    • checkbox Tornar negrito os nomes da camada

    • checkbox Tornar negrito os nomes dos grupos

    • checkbox Mostrar nomes de atributos de classificação

    • checkbox Criar ícones matriciais (pode ser lento)

    • you can also set the WMS getLegendGraphic Resolution

Map tools Settings

This tab offers some options regarding the behavior of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance distance within which the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified be highlighted.
  • Buffer determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width determines how thick should the outline of a highlighted object be.

Ferramenta de medida

  • Define Cor do elástico para as ferramentas de medida

  • Define Casas decimais

  • checkbox Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)
  • Preferred distance units radioButtonOn (‘Meters’, ‘Kilometers’, ‘Feet’, ‘Yards’, ‘Miles’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square kilometers’, ‘Square feet’, ‘Square yards’, ‘Square miles’, ‘Hectares’, ‘Acres’, ‘Square nautical miles’, ‘Square degrees” or ‘Map Units’)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’, ‘Seconds of arc’ or ‘Turns/revolutions’)

Movendo e ampliando

  • Define a Zoom factor for zoom tools or wheel mouse

Escalas pré-definidas

Here, you find a list of predefined scales. With the signPlus and signMinus buttons you can add or remove your personal scales. You can also import or export scales from/to a .XML file. Note that you still have the possibility to remove your changes and reset to the predefined list.

Composer Settings

Composição padrão

You can define the Default font used within the print composer.

Aparência do Gride

  • Define the Grid style selectString (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define a Cor da grade

Configurações de guia e grade

  • Define the Grid spacing selectNumber
  • Define the Grid offset selectNumber for x and y
  • Define the Snap tolerance selectNumber

Composer Paths

  • Define Path(s) to search for extra print templates: a list of folders with custom composer templates to use while creating new one.

Digitizing Settings

This tab helps you configure general settings when editing vector layer (attributes and geometry).

Criação de elementos

  • checkbox Suppress attribute form pop-up after feature creation
  • checkbox Reutilizar últimos valores de atributos inseridos

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Elástico

  • Define Rubberband Line width, Line color and Fill color
  • Don’t update rubberband during node editing

Ajuste

  • checkbox Abrir opções de atração na janela principal (necessário reiniciar o QGIS)

  • Define Default snap mode selectString (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Define Tolerância de atração pré-definida em unidades de mapa ou pixeis

  • Define o Raio de pesquisa para editar vértices em unidades de mapa ou pixeis

Marcadores de Vértices

  • checkbox Mostrar marcadores apenas para elementos selecionados

  • Define vertex Marker style selectString (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Definir o vértice Tamanho do Marcador

Ferramenta de curva de afastamento

The next 3 options refer to the offsetCurve Offset Curve tool in Digitalização Avançada. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Join style: ‘Round’, ‘Mitre’ or ‘Bevel’
  • Quadrante do Segmento

  • Limite quadrante

GDAL Settings

GDAL is a data exchange library for raster files. In this tab, you can Edit create options and Edit Pyramids Options of the raster formats. You can define which GDAL driver is to be used for a raster format, as in some cases more than one GDAL driver is available.

CRS Settings

SRC padrão para novos projetos

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • Selecione um SRC em Iniciar sempre um novo projeto com este SRC

SRC para novas camadas

Esta área permite que você defina a ação a ser tomada quando uma nova camada é criada, ou quando uma camada sem SRC é carregada.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Use default CRS

Transformação de datum padrão

  • checkbox Pergunte pela transformação do datum quando nenhum padrão for definido

  • With the ‘on-the-fly’ CRS transformation enabled and the above option checked, adding layers of different CRS opens the Select datum transformations dialog. This offers you to select the most appropriate transformation settings. Validating this dialog with the ‘Remember selection’ option checked populates the table under CRS ‣ Default datum transformations with information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’. From now, QGIS automatically uses the selected datum transformation for further transformation between these two CRSs until you signMinus remove it from the list.

    You can use the signPlus button to add a datum transformation if you know its parameters (source and destination ellipsoids and the numbers from the transformation table). You then need to manually enter each setting.

Nota

For more information on how QGIS handles layers projection, please read the dedicated section at Trabalhando com Projeções.

Locale Settings

  • checkbox Override system locale and Locale to use instead
  • Informação sobre a região do sistema ativo local

Authentication Settings

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Sistema de Autenticação for more details.

Network Tab

Geral

  • Define Pesquisa de endereço WMS, padrão como http://geopole.org/wms/search?search=\%1\&type=rss

  • Define Tempo esgotado para pedidos de rede (ms) - o padrão é 60000

  • Define Default expiration period for WMS Capabilities (hours) - default is 24
  • Define Período padrão de validade para a quadrícula WMSC/WMTS (horas) - o padrão é 24

  • Define Max retry in case of tile or feature request errors
  • Define Usuário-Agente

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Configurações de cache

Define a Pasta e Tamanho para o cache.

  • checkbox Usar proxy para acessar à web e define ‘Máquina’, ‘Porta’, ‘Usuário’, e ‘Palavra-chave’.

  • Set the Proxy type selectString according to your needs.
    • Default Proxy: Proxy é determinado baseando-se na definição do proxy da aplicação em uso

    • Socks5Proxy: Proxy genérico para qualquer tipo de ligação. Suporta TCP, UDP, unindo a uma porta (ligações de entrada) e autenticação.

    • HttpProxy: Implementado usando o comando “LIGAR” , apenas suporta ligações TCP de saída; suporta autenticação.

    • HttpCachingProxy: Implementado usando comandos HTTP normais, é útil apenas em pedidos no contexto do HTTP.

    • FtpCachingProxy: Implementado usando um proxy FTP, é útil no contexto de pedidos FTP.

Alguns URLs excluídos podem ser adicionados na caixa de texto debaixo das configurações de proxy (veja Figure_Network_Tab).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.qt.io/qt-4.8/qnetworkproxy.html#ProxyType-enum

Dica

Usando Proxies

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check if they succeed in your case.

Variables Settings

The Variables tab lists all the variables available at the global-level.

It also allows the user to manage global-level variables. Click the signPlus button to add a new custom global-level variable. Likewise, select a custom global-level variable from the list and click the signMinus button to remove it.

More information about variables in the Variables section.

Advanced Settings

Depending on your OS, all the settings related to QGIS (UI, tools, data providers, default values, plugins options...) are saved:

  • nix in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx in the properties list file: $HOME/Library/Preferences/org.qgis.qgis.plist
  • win in the registry under: HKEY\CURRENT_USER\Software\QGIS\qgis

The Advanced tab offers you in a single place, regardless your OS, means to manage these settings through the Advanced Settings Editor. After you promise to be careful, the widget is populated with a tree of all QGIS settings, which you can directly edit.

Aviso

Avoid using the Advanced tab settings blindly

Be careful while modifying items in this dialog given that changes are automatically applied. Doing changes without knowledge can break your QGIS installation in various ways.

Propriedades do Projeto

In the properties window for the project under Project ‣ Project Properties (or kde Settings ‣ Project Properties), you can set project-specific options.

The project-specific options overwrite their equivalent in the options described above.

  • In the General tab, the general settings let you:

    • give a title to the project beside the project file path
    • choose the color to use for features when they are selected
    • choose the background color: the color to use for the map canvas
    • set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file location. You may prefer relative path when both layers and project files can be moved or shared or if the project is accessed from computers on different platforms.
    • choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to performance degradation.

    Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

    • the ellipsoid to use: it can be an existing one, a custom one (you’ll need to set values of the semi-major and semi-minor axis) or None/Planimetric.
    • the units for distance measurements for length and perimeter and the units for area measurements. These settings, which default to the units set in QGIS options but then overrides it for the current project, are used in:
      • Attribute table field update bar
      • Field calculator calculations
      • Identify tool derived length, perimeter and area values
      • Default unit shown in measure dialog

    The Coordinate display allows you to choose and customize the format of units to use to display the mouse coordinate in the status bar and the derived coordinates shown via the identify tool.

    Finally, you can define a project scale list, which overrides the global predefined scales.

../../../_images/project_general.png

General tab of Project Properties dialog

  • The CRS tab enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS. For more information on projection’s handling in QGIS, please read Trabalhando com Projeções section.

  • With the Identify layers tab, you set (or disable) which layers will respond to the identify tool. By default, layers are set queryable.

    You can also set whether a layer should appear as read-only, meaning that it can not be edited by the user, regardless of the data provider’s capabilities. Although this is a weak protection, it remains a quick and handy configuration to avoid end-users modifying data when working with file-based layers.

  • The Default Styles tab lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colors assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.

  • The tab OWS Server allows you to configure your project in order to publish it online. Here you can define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions. More information available in section Prepare a project to serve and subsequent.

  • The Macros tab is used to edit Python macros for projects. Currently, only three macros are available: openProject(), saveProject() and closeProject().

../../../_images/macro.png

Macro settings in QGIS

  • The Relations tab is used to define 1:n relations. The relations are defined in the project properties dialog. Once relations exist for a layer, a new user interface element in the form view (e.g. when identifying a feature and opening its form) will list the related entities. This provides a powerful way to express e.g. the inspection history on a length of pipeline or road segment. You can find out more about 1:n relations support in Section Creating one or many to many relations.
  • In the Data Sources tab, you can:
    • checkbox Evaluate default values on provider side: When adding new features in a PostGreSQL table, fields with default value constraint are evaluated and populated at the form opening, and not at the commit moment. This means that instead of an expression like nextval('serial'), the field in the Add Feature form will display expected value (e.g., 25).
    • checkbox Automatically create transaction groups where possible: When this mode is turned on, all (postgres) layers from the same database are synchronised in their edit state, i.e. when one layer is put into edit state, all are, when one layer is committed or one layer is rolled back, so are the others. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the database which gets committed when the user clicks save layer. Note that you can (de)activate this option only if no layer is being edited in the project.
  • The Variables tab lists all the variables available at the project’s level (which includes all global variables). Besides, it also allows the user to manage project-level variables. Click the signPlus button to add a new custom project-level variable. Likewise, select a custom project-level variable from the list and click the signMinus button to remove it. More information on variables usage in the General Tools Variables section.

Personalização

The customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you want to provide your end-users with a ‘light’ version of QGIS, containing only the icons, menus or panels they need.

Nota

Before your changes are applied, you need to restart QGIS.

../../../_images/customization.png

The Customization dialog

Ticking the checkbox Enable customization checkbox is the first step on the way to QGIS customization. This enables the toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:

  • a Menu or some of its sub-menus from the Barra de Menu
  • a whole Panel (see Panels and Toolbars)
  • the Status bar described in Barra de Status or some of its items
  • a Toolbar: the whole bar or some of its icons
  • or any widget from any dialog in QGIS: label, button, combobox...

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog.

Once you setup your configuration, click [Apply] or [Ok] to validate your changes. This configuration becomes the one used by default by QGIS at the next startup.

The modifications can also be saved in a .ini file using fileSave Save To File button. This is a handy way to share a common QGIS interface among multiple users. Just click on fileOpen Load from File from the destination computer in order to import the .ini file. You can also run command line tools and save various setups for different use cases as well.

Dica

Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

  • unchecking checkbox Enable customization option in the Customization dialog or click the selectAllTree Check All button
  • pressing the [Reset] button in the QSettings frame under Settings ‣ Options menu, System tab
  • launching QGIS at a command prompt with the following command line qgis --nocustomization
  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab (see the warning).

In most cases, you need to restart QGIS in order to have the change applied.

Keyboard shortcuts

QGIS provides default keyboard shortcuts for many features. You can find them in section Barra de Menu. Additionally, the menu option Settings ‣ Configure Shortcuts... allows you to change the default keyboard shortcuts and add new keyboard shortcuts to QGIS features.

../../../_images/shortcuts.png

Define shortcut options

Configuration is very simple. Just select a feature from the list and click on :

  • [Change] and press the new combination you want to assign as new shortcut
  • [Set none] to clear any assigned shortcut
  • or [Set default] to backup the shortcut to its original and default value.

Proceed as above for any other tools you wish to customize. Once you have finished your configuration, simply [Close] the dialog to have your changes applied. You can also [Save] the changes as an .XML file and [Load] them into another QGIS installation.