7.2. Lesson: Análise Vetorial

Dados vetoriais também podem ser analisados para revelar como diferentes feições interagem entre si no espaço. Há diferentes análises disponíveis nas funções do SIG, então, nós não iremos cobrir todas elas. Ao invés disso, traremos uma questão e tentaremos solucioná-la usando ferramentas providas pelo QGIS.

O objetivo desta lição: Fazer uma pergunta e respondê-la usando ferramentas de análise.

7.2.1. basic O Processo SIG

Antes de começar, é importante conhecer de maneira geral os passos que devemos seguir para resolver qualquer problema em SIG. O que devemos fazer é o seguinte:

  1. Definir o Problema

  2. Coletar os Dados

  3. Analisar o Problema

  4. Demonstrar os Resultados

7.2.2. basic O problema

Comecemos o processo definindo o problema a ser solucionado. Por exemplo, você é um funcionário público e está procurando por propriedades residenciais em Swellendam por clientes que se encaixam nos seguintes critérios:

  1. É necessário estar em Swellendam.

  2. É preciso haver uma escola há uma distância razoável, na qual acessaremos dirigindo (digamos 1 Km)

  3. Deve ter um tamanho superior a 100 m quadrados.

  4. Próximo no máximo 50m de uma via principal.

  5. Um restaurante há no máximo 500m de distância.

7.2.3. basic Os Dados

Para responder a todas essas perguntas precisaremos dos seguintes dados:

  1. Os imóveis residenciais (edifícios) na área.

  2. As estradas dentro e ao redor da cidade.

  3. A localização das escolas e restaurantes.

  4. O tamanho dos edifícios.

Todos esses dados estão disponíveis no OSM e você perceberá que o conjunto de dados que você tem usado ao longo desse manual também pode ser usado nesta lição. Entretanto, para termos certeza que temos os dados completos, nós iremos dar o download novamente dos dados do OSM usando a ferramenta do QGIS para download de OSM.

Nota

Aunque hay coherencia en los campos de datos que encontramos en las descargas de OSM, pueden variar en su cobertura y detalle. Si ves, por ejemplo, que la región que has elegido no contiene información sobre restaurantes, quizás necesitas elegir otra región.

7.2.4. basic Follow Along: Comienzar un projecto

  • Comienza un nuevo proyecto QGIS.

  • Use a ferramenta de download de dados OpenStreetMap localizada no menu Vetor ‣ OpenStreetMap para fazer download dos dados da região que você escolheu.

  • Guarda los datos como osm_data.osm en tu carpeta exercise_data.

  • Note que o formato osm é dado do tipo vetorial. Adicione o dado como uma camada vetorial usando Camada ‣ Adicionar a camada vetorial..., busque o novo arquivo osm_data.osm que você acabou de baixar. Você pode precisar selecionar Mostrar todos os arquivos em formato de arquivo.

  • Selecciona osm_data.osm y haz clic en Abrir

  • En el cuadro de diálogo que aparece, selecciona todas las capas, excepto las capas other_relations y multilinestrings:

../../../_images/select_osm_layers.png

Esto hará que los datos OSM se importen en su mapa como capas separadas.

Los datos que acabas de descargar desde OSM se encuentran en un sistema de coordenadas, WGS84, que utiliza coordenadas de latitud y longitud, como ya vimos en la lección anterior. Asimismo, también aprendiste que para calcular distancias en metros, necesitamos trabajar con un sistema de coordenadas proyectado. Comienza por establecer el sistema de coordenadas de tu proyecto en un SRC adecuado para tus datos, en el caso de Swellendam, WGS 84 / UTM zone 34S:

  • Abre el cuadro de diálogo Propiedades del Proyecto, selecciona SRC y filtre la lista para encontrar WGS 84 / UTM zone 34S.

  • Haz clic en OK.

Ahora necesitamos extraer la información que necesitamos del conjunto de datos OSM. Es necesario finalizar con capas representando todas las casas, colegios, restaurantes y carreteras de la región. Esta información se encuentra dentro de la capa multipolygons y se puede extraer utilizando la información en su Tabla de Atributos. Empezaremos con la capa schools.

  • Haga clic con el botón derecho del ratón en la capa multipolygons en la Lista de Capas y abre la Propiedades de la Capa.

  • Ve al menú General.

  • Bajo Subconjunto de objetos espaciales haz clic en el botón [Constructor de consultas] para abrir el cuadro de diálogo Constructor de consultas.

  • Mira en la lista de Campos de la izquierda de este cuadro de diálogo hasta que veas el campo amenity.

  • Haz clic sobre él una vez.

  • Haz clic en el botón Todos que se encuentra bajo la lista Valores:

Ahora necesitamos comunicar a QGIS que solamente nos muestre aquellos polígonos donde el valor de amenity es igual a school.

  • Haga doble clic sobre la palabra servicios en la lista de Campos.

  • Veja o que acontece no campo Provider specific filter expression abaixo:

../../../_images/schools_query.png

La palabra "amenity" ha aparecido. Para crear el resto de la consulta:

  • Haz clic en el botón = (bajo Operadores).

  • Haz doble clic en el valor school en la lista de Valores.

  • Haz clic en Aceptar dos veces.

Isso irá filtrar os layers multipolygons OSMs para mostrar somente as escolas na sua região. Agora você pode:

  • Cambiar el nombre de la capa filtrada de OSM al de schools e importar de nuevo la capa multipolygons desde osm_data.osm, o

  • Duplicar la capa filtrada, renombrar la copia, borrar la Query Builder y crea tu nueva consulta en e l:guilabel:Constructor de consultas.

7.2.5. moderate Try Yourself Extraer de Capas Requeridas de OSM

Usando la técnica anterior, utiliza la herramienta Constructor de consultas para extraer los datos que quedan de OSM para crear las siguientes capas:

  • carreteras ( de la capa de OSM lines)

  • restaurantes (desde la capa multipolygons de OSM)

  • casas (desde la capa multipolygons de OSM)

Puede que quieras utilizar de nuevo la capa roads.shp que creaste en lecciones anteriores.

Comprueba tus resultados

  • Salve seu mapa em exercise_data, como analysis.qgs (esse mapa será usado em módulos futuros).

  • En el administrador de archivos de tu sistema operativo, crea una nueva carpeta en exercise_data y llamalá desarrollo_urbano. Aquí es donde guardarás los conjuntos de datos que resultarán de las funciones de análisis.

7.2.6. basic Try Yourself Encontrar carreteras importantes.

Algunas de las carreteras en los datos de OSM están listadas como unclassified, tracks, path y footway. Queremos eliminarlas de nuestro conjunto de datos de carreteras.

  • Abre el Constructor de Consultas para la capa roads, haz clic en Limpiear y crea la siguiente consulta:

    "highway" != 'NULL' AND "highway" != 'unclassified' AND "highway" != 'track' AND "highway" != 'path' AND "highway" != 'footway'

Puedes, o bien utilizar la estrategia utilizada anteriormente, haciendo doble clic en los valores y clic en los botones, o bien puedes copiar y pegar el comando que aparece arriba.

Esto debería reducir inmediatamente el número de carreteras en tu mapa:

../../../_images/correct_roads_filter.png

7.2.7. basic Try Yourself Convertir el SRC de una Capa

Como vamos a estar midiendo distancias entre nuestras capas, necesitamos cambiar el SRC de las capas. Para ello, necesitamos seleccionar las capas una por una, guardar la capa a un nuevo shapefile con nuestra nueva proyección y entonces añadir la nueva capa a nuestro mapa.

Nota

En este ejemplo, vamos a usar el SRC WGS 84 / UTM zone 34S, pero puedes utilizar un SRC UTM que sea más apropiado para tu región.

  • Haz clic derecho sobre la capa carreteras en el panel Capas.

  • Haz clic en Guardar como...

  • En el diálogo Guardar capa vectorial como..., elige las siguientes opciones y haz clic en Aceptar (asegurate de que seleccionas Añadir archivo guardado al mapa):

../../../_images/save_roads_34S.png

El nuevo shapefile se creará y la capa resultante es añadida a tu mapa.

Nota

Se você não ativou Enable ‘on the fly’ CRS transformation ou Automatically enable ‘on the fly’ reprojection if layers have different CRS (veja a lição anterior), é possível que você não veja os novos layers recém adicionados ao mapa. Nesse caso, você pode focar o mapa em qualquer layer clicando com o botão direito em qualquer layer e clicando em Zoom to layer extent ou simplesmente ative qualquer das opções ‘on the fly’ mencionadas.

  • Elimina la capa carreteras vieja.

Repite este proceso para cada capa, creando un nuevo shapefile y una nueva capa añadiendo el apendice “_34S” al nombre original y eliminando cada una de las capas viejas.

Una vez que hayas completado el proceso para cada capa, haz clic derecho sobre cualquiera de las capas y clic en Zum a la extensión de la capa para enfocar el mapa a la zona de interés.

Ahora que hemos convertido los datos OSM a una proyección UTM, podemos empezar nuestros cálculos.

7.2.8. basic Follow Along: Analizando el Problema: Distancias Desde Colegios y Carreteras.

QGIS te permite calcular distancias desde cualquier objeto vectorial.

  • Asegurate de que solamente las capas carreteras_34S y casas_34S son visibles, para simplificar el mapa mientras trabajas.

  • Click on the Vector ‣ Geoprocessing Tools ‣ Fixed distance buffer tool:

Esto te da un nuevo cuadro de diálogo.

  • Configúralo así:

../../../_images/vector_buffer_setup.png

The Distance is in meters because our input dataset is in a Projected Coordinate System that uses meter as its basic measurement unit. This is why we needed to use projected data.

  • Guarda la capa resultante en exercise_data/desarrollo_inmobiliario/ as carreteras_buffer_50m.shp.

  • Clic OK y el buffer se creará.

  • Cuando te pregunte si debe “añadir resultado al TDC”, clic Aceptar. (“TDC” significa “Tabla de Contenidos”, que es lo mismo que la Lista de capas).

  • Close the Fixed distance buffer dialog.

Ahora tu mapa se parece un poco a esto:

../../../_images/roads_buffer_result.png

Si tu nueva capa es la primera en la lista Capas, probablemente ocultará una gran parte de tu mapa, pero nos da todas las áreas que están a dentro de una distancia de 50m de una carretera en tu región.

Sin embargo, verás que hay zonas distintas dentro de nuestro buffer, correspondiendo a cada una de las carreteras. Para resolver este problema, elimina la capa y crea el buffer de nuevo utilizando las opciones mostradas aquí:

../../../_images/dissolve_buffer_setup.png
  • Note that we’re now checking the Dissolve result box.
  • Guarda el resultado con el mismo nombre que utilizaste antes (clic Si cuando te pida permiso para reemplazar el antiguo).

  • Click OK and close the Fixed distance buffer dialog again.

Una vez que le añadas la capa a Layers list, se verá esto:

../../../_images/dissolve_buffer_results.png

Ahora no hay subdivisiones innecesarias.

7.2.9. basic Try Yourself Distancia desde colegios.

  • Usa el mismo enfoque que anteriormente y crea un buffer para tus colegios.

Es necesario que sea 1 km en radios, y guardarlo en el directorio habitual como schools_buffer_1km.shp.

:ref:` Comprueba tus resultados <vector-analysis-basic-2>`

7.2.10. basic Follow Along: Areas que se solapan.

Ahora tenemos áreas donde la carretera está a 50 metros y en la que hay un colegio en un espacio de 1 km ( en línea recta, no por la carretera). Pero obviamente, sólo queremos aquellas áreas donde coincidan estos dos criterios Para lo cual, necesitaremos utilizar la herramienta Intersect tool. La puedes encontrar en Vector ‣ Geoprocessing Tools ‣ Intersect. Instalela de la siguiente manera:

../../../_images/school_roads_intersect.png

Las dos capas de entrada son los dos buffers; la ruta de guardado es la usual y el nombre del archivo es road_school_buffers_intersect.shp. Una vez hecho esto, haga clic en OK y añada la capa a Layers list cuando se le pida.

En la imagen inferior, las áreas en azul muestran donde ambos criterios de distancia coinciden

../../../_images/intersect_result.png

Usted puede borrar las dos capas buffer y solo mantener la que muestra la superposición, dado que eso era lo que queriamos conocer en primer lugar:

../../../_images/final_intersect_result.png

7.2.11. basic Follow Along: Seleccione las Construcciones

Ahora que usted conoce el área en que las construcciones se superponen. El proximo paso es seleccionar las construcciones en dicha área.

  • Seleccione en el menu Vector ‣ Research Tools ‣ Select by location. Un dialogo aparecerá.

  • Configúralo así:

../../../_images/location_select_dialog.png
  • Selecione OK, em seguida Close.

  • Probablemente encontrará que no mucho ha cambiado. De ser así, mueva la capa school_roads_intersect a la parte más baja de la lista de capas y luego haga un zoom in:

../../../_images/select_zoom_result.png

Los edificios destacados en amarillo son aquellos que cumplen nuestros criterios y están seleccionados, mientras que los edificios en verde son los que no. Podemos ahora guardar los edificios seleccionados como una nueva capa.

  • Haz clic derecho en la capa houses_34S de la Layers list.

  • Selecciona Guadar Selección como....

  • Configura el diálogo emergente así:

../../../_images/save_selection_as.png
  • El nombre del archivo es well_located_houses.shp.

  • Haz clic en OK.

Ahora tienes la selección como una capa separada y puedes quitar la capa houses_34S.

7.2.12. moderate Try Yourself Filtrado adicional de nuestros Edificios

Ahora tenemos una capa que nos muestra los edificios en un radio de 1km de una escuela y a menos de 50m de una carretera. Ahora tenemos que reducir la selección para que sólo nos muestre los edificios que están a menos de 500 metros de un restaurante.

Usando los procesos descritos anteriormente, crear una capa llamada houses_restaurants_500m aplicando filtros adicionales a la capa well_located_houses para mostrar sólo aquellos que están a menos de 500 metros de un restaurante.

:ref:` Comprueba tus resultados <vector-analysis-basic-3>`

7.2.13. basic Follow Along: Seleccione las Construcciones de Tamaño Adecuado

Para ver quais edifícios são do tamanho certo (mais de 100 metros quadrados), primeiro temos que calcular o tamanho dos mesmos.

  • Abra a tabela de atributos da camada houses_restaurants_500m.

  • Entra en el modo de edición y abre la calculadora de campos.

  • Configúralo así:

../../../_images/buildings_area_calculator.png
  • Si no puedes encontrar AREA en la lista, intenta crear un nuevo campo como hiciste en la lección previa de este módulo.

  • Haz clic en OK.

  • Desplázate a la derecha de la tabla de atributos; tu campo AREA contiene ahora el área en metros cuadrados de todos los edificios de la capa houses_restaurants_500m.

  • Haga clic en el botón del modo de edición de nuevo para finalizar la edición y guarde los cambios cuando se le pida.

  • Construya una consulta como hizo anteriormente en esta lección.

../../../_images/buildings_area_query.png
  • Haga clic en Aceptar. Tu mapa debería mostrar aquellos edificios que cumplen los criterios iniciales y aquellos de tamaño superior a 100 metros cuadrados.

7.2.14. basic Try Yourself

  • Guarda la solución como una nueva capa usando la estrategia que aprendiste anteriormente. El archivo debería ser guardado en el directorio usual con el nombre solution.shp.

7.2.15. In Conclusion

Usando la estrategia de resolución de problemas SIG junto con las herramientas de análisis vectorial de QGIS, has sido capaz de resolver un problema con múltiples criterios rápida y fácilmente.

7.2.16. What’s Next?

Na lição seguinte, veremos como calculcar a distância mais curta entre um ponto e outro da via.