15.2. Lesson: Georreferenciando un Mapa

Una tarea forestal común sería la acutalización de información de un área forestal. Es posible que la información anterior para esa área date de muchos años atrás y fuera tomada analógicamente (es decir, en papel) o puede que fuera digitalizada pero todo lo que queda sea la versión en papel del área inventariada.

Segúramente querrás utilizar esa información en tu SIG para, por ejemplo, comparar con los inventarios posteriores. Esto implica que necesitarás digitalizar la información a mano en tu software SIG. Pero antes de que puedas empezar a digitalizar, hay un importante primer paso para hacer, escanear y georreferenciar tu mapa de papel.

El objetivo de esta lección: Aprender a usar la herramienta de Georreferenciación en QGIS.

15.2.1. basic Escanear el mapa

La primera tarea que deberás hacer es escanear tu mapa, si el mapa es demasiado grande, puedes escanearlo en partes diferentes pero teniendo en cuenta que tendrás que repetir las tareas de preprocesado y georreferenciación para cada parte. Así que si es posible, escanea el mapa en el menor número de partes posible.

Si vas a utilizar diferentes mapas al proporcionado en este manual, utiliza tu propio escaner para escanear el mapa como un archivo de imagen, una resolución de 300 DPI funcionará. Si tu mapa tiene colores, escanea la imagen en color para luego utilizar esos colores para separar la información de tu mapa en diferentes capas (por ejemplo, masas forestales, curvas de nivel, calles...).

Para este ejercicio utilizarás un mapa previamente escaneado, puedes encontrarlo como rautjarvi_map.tif en la carpeta de datos exercise_data/forestry

15.2.2. basic Follow Along: Georreferenciar el mapa escaneado

Abre QGIS y ajusta el SRC del proyecto a ETRS89 / ETRS-TM35FIN en Project ‣ Project Properties ‣ CRS, que es el SRC de uso actual en Finlandia. Asegúrate de que Enable ‘on the fly’ CRS transformation está activado, ya que trabajaremos con datos antiguos que están en otro SRC.

../../../_images/f_1.png

Guarda el proyecto QGIS como map_digitizing.qgs.

Utilizarás los complementos de georreferenciación del QGIS, los complementos ya están instalados en QGIS. Activa los complementos utilizando el administrador de complementos como has hecho en módulos anteriores. El complemento se llama Georeferencer GDAL.

Para georeferenciar el mapa:

  • Abre la herramienta de georreferenciado, Raster ‣ Georeferencer ‣ Georeferencer.

  • Adicione o arquivo de imagem de mapa,: kbd: rautjarvi_map.tif, como a imagem para georeferenciamento, File ‣ Open raster.

  • Cuando se solicite encuentra y selecciona el SRC KKJ / Finland zone 2, es el SRC que fue utilizado en Finlandia en 1994 cuando el mapa fue creado.

  • Haz clic en OK.

Acontinuación deberás definir los ajustes de transformación para georreferenciar el mapa:

  • Abre Settings ‣ Transformation settings.

  • Haz clic en el icono junto a la caja Output raster, ve a la carpeta y crea la carpeta exercise_data\forestry\digitizing y nombra el archivo como rautjarvi_georef.tif.

  • Ajusta el resto de los parámetros como se muestra abajo.

../../../_images/Clipboard10.png
  • Haz clic en OK.

El mapa contiene muchas cruces que marcan las coordenadas en el mapa, las utilizaremos para georreferenciar esa imagen. Puedes utilizar las herramientas de zoom y planificación como normalmente usas para inspeccionar la imagen en la ventana del Georreferenciador.

  • Aumente o zoom para o canto inferior esquerdo do mapa e note que há uma cruz com um par de coordenadas, x e y, que como mencionado anteriormente está em :kbd: KKJ / Finland zone 2 CRS. Você vai usar esse ponto como o primeiro ponto de controle de solo para o georreferenciamento seu mapa.

  • Selecciona la herramienta Add point y haz clic en la intersección de la cruz (desplázate y haz zoom como necesites).

  • En el diálogo Enter map coordinates escribe las coordenadas que aparecen en el mapa (X: 2557000 e Y: 6786000).

  • Haz clic en OK.

La primera coordenada de la georreferenciación ya está lista.

Busca otras cruces en las líneas negras de la imagen, están separadas 1000 metros entre ellas en dirección Norte y Este. Deberías ser capaz de calcular las coordenadas de esos puntos en relación al primero.

Zoom menos na imagem e passe para a direita até encontrar outra forma de cruz, e estimar quantos quilômetros você se moveu. Tente obter pontos de controle no terreno o mais longe possível uns dos outros. Digitalize, pelo menos, mais três pontos de controle, da mesma forma que você fez o primeiro. Você deve acabar com algo semelhante a isto:

../../../_images/Clipboard09.png

Con los puntos de control ya digitalizados serás capaz de ver los errores de georreferenciación como una línea roja saliendose de los puntos. El error en píxels puede ser visto también en GCP table en las columnas dX[pixels] y dY[pixels]. El error en píxels no debería ser mayor de 10 píxels, si lo es deberías revisar los puntos que has digitalizado y las coordenadas que has introducido para encontrar dónde está el problema. Puedes utilizar la imagen anterior como guía.

Una vez que estés contento con tus puntos de control guárdalos, en el caso de que los necesites más tarde:

  • File ‣ Save GCP points as....
  • Na pasta exercise_data\forestry\digitizing, nome do arquivo rautjarvi_map.tif.points.

Finalmente, georreferencia tu mapa:

  • File ‣ Start georeferencing.
  • Observa que ya has nombrado tu archivo como rautjarvi_georef.tif cuando editaste los ajustes del Georreferenciador.

Ahora puedes ver el mapa en el proyecto QGIS como un ráster georreferenciado. Observa que el ráster parece estar ligeramente rotado, pero eso solo se debe a que los datos están en KKJ / Finland zone 2 y tu proyecto está en ETRS89 / ETRS-TM35FIN.

Para verificar se os seus dados estão devidamente georreferenciados você pode abrir a imagem aérea na pasta: kbd: exercise_data\forestry , com o nome: kbd:` rautjarvi_aerial.tif`. Seu mapa e esta imagem devem sobrepor muito bem. Defina a transparência mapa para 50% e compará-la com a imagem aérea.

../../../_images/Clipboard14.png

Guarda los cambios en tu proyecto QGIS, continuarás desde este punto en la siguiente lección.

15.2.3. In Conclusion

Como has visto, georreferenciar un mapa de papel es una operación relativamente sencilla.

15.2.4. What’s Next?

En la siguiente lección, digitalizarás las masas forestales en tu mapa como polígonos y les añadirás los datos de inventario.