9.4. Lesson: Ejercicio Suplementario

En esta lección, serás guiado a través de un análisis SIG completo en QGIS.

Nota

Lección desarrollada por Linfiniti y S Motala (Universidad Tecnológica de Península del Cabo)

9.4.1. Planteamiento del Problema

Eres el encargado de encontrar áreas en Península del Cabo que sean adecuadas para el hábitat de especies de plantas fynbos raras. La extensión de tu área de investigación en Península del Cabo es: Sur de Melkbosstrand, Oeste de Strand. Botánicos te han proporcionado las preferencias exhibidas por las especies en cuestion:

  • Crecen en pendientes orientadas al este.

  • Crecen en pendientes con gradiente entre 15 y 60%.

  • Crecen en áreas que tienen un total de precipitación anual de > 1200 mm.

  • Solo se encuentran a al menos 250 m de distancia de los asentamientos humanos.

  • El área de vegetación en la que ocurre debería ser de al menos 6000m2.

Como voluntario de Naturaleza del Cabo, has acordado buscar la planta en el terreno adecuado más cercano a tu casa. Utiliza tus habilidades SIG para determinar dónde deberías ir a ver.

9.4.2. Esquema de la Solución

In order to solve this problem, you will have to download data from https://www.dropbox.com/s/q5evvkizuunrcs0/more_analysis.zip?dl=0 and place it under exercise_data/more_analysis folder. You will use it to find the candidate area that is closest to your house. If you don’t live in Cape Town (where this problem is based) you can choose any house in the Cape Town region. The solution will involve:

  • análisis del MDE para encontrar las pendientes orientadas al este y las pendientes con el gradiente correcto;

  • análisis del ráster de precipitación para encontrar las áreas con cantidad de precipitación correcta;

  • análisis de las zonas de capa vectorial para encontrar áreas que tengan la distancia a enclaves humanos y sean del tamaño correctos.

9.4.3. Preparando el Mapa

  • Haz clic en el botón “estado SRC” en la esquina inferior derecha de la pantalla. En la pestaña SRC de la pestaña que aparece, verás la casilla Sistema de referencia de coordenadas del mundo.

  • En esta casilla, navega hasta Sistemas de coordenadas proyectadas ‣ Universal Transverse Mercator (UTM).

  • Selecciona la entrada WGS 84 / UTM zone 33S (con el código EPSG 32733).

  • Haz clic en Aceptar. El mapa está ahora en el Sistema de coordenadas de referencia UTM33S .

  • Guarda el mapa clicando en el botón de la barra de herramientas Guardar proyecto como, o utiliza el elemento del menú Proyecto ‣ Guardar como....

  • Guarda el mapa en un directorio llamado Rasterprac que deberías crear en algún lugar de tu ordenador. También guardarás cualquiera de las capas que crees en este directorio.

9.4.4. Cargar Datos dentro del Mapa

Para procesar los datos, necesitarás cargar las capas necesarias (nombres de calles, zonas, precipitación, MDE) en la vista del mapa.

9.4.4.1. Para vectoriales...

  • Haz clic en el botón Añadir Capa Vectorial, o utiliza el elemento del menú Capa ‣ Añadir Capa Vectorial...

  • En el cuadro de diálogo que aparece, asegúrate de que el botón radial Archivo está selecionado.

  • Haz clic en el botón Explorar.

  • En el cuadro de diálogo que aparece, abre el directorio exercise_data/more_analysis/streets.

  • Selecciona el archivo Street_Names_UTM33S.shp.

  • Haz clic en Abrir.

El cuadro de diálogo se cerrará y te mostrará el cuadro de diálogo original, con la ruta de archivo especificada en el campo de texto junto al botón Explorar. Esto te permite asegurarte de que está seleccionado el archivo correcto. También es posible introducir la ruta de archivo en este campo manualmente, si lo prefieres.

  • Haz clic en Abrir. La capa vectorial se cargará en tu mapa. Su color está asignado automáticamente. Será cambiado luego.

  • Renombra la capa como Streets.

  • Haz clic derecho en ella en la Lista de capas (por defecto, el panel a mano izquierda de la pantalla).

  • Haz clic en Cambiar nombre en el cuadro de diálogo que aparece y renómbralo pulsando la tecla Enter cuando acabes.

  • Repite el proceso de añadir datos vectoriales, pero esta vez selecciona el archivo Generalised_Zoning_Dissolve_UTM33S.shp del directorio Zoning.

  • Renómbralo como Zoning.

9.4.4.2. Para rásters...

  • Haz clic en el botón Añadir capa ráster, o utiliza el elemento del menú Capa ‣ Añadir capa ráster...

  • Navega hasta el archivo apropiado, selecciónalo y haz clic en Abrir.

  • Haz esto para cada uno de los dos archivos ráster. Los archivos que quieres son DEM/reproject/DEM y Rainfall/reprojected/rainfall.tif.

  • Renombra el ráster de precipitaciónes como Precipitación (con la letra inicial en mayúsculas). Al principio cuando los cargues, las imágenes serán rectángulos grises. No te preocupes, esto se cambiará luego.

  • Guarda el mapa.

Para ver correctamente qué está pasando, se necesita cambiar la simbología para las capas.

9.4.5. Cambio de simbología de capas vectoriales

  • En Lista de capas, haz clic derecho en la capa Streets.

  • Selecciona Propiedades del menú que aparece.

  • Selecciona la pestaña Estilo del cuadro de diálogo que aparece.

  • Clique no botão rotulado Mudar, com a mostrando quadra e cor atual da camada Estradas.

  • Selecciona un color nuevo en el cuadro de diálogo que aparece.

  • Haz clic en Aceptar.

  • Vuelve a hacer clic en Aceptar en el cuadro de diálogo Propiedades de la capa. Esto cambiará el color de la capa Streets.

  • Sigue un proceso similar para la capa Zoning y elige un color adecuado para ella.

9.4.6. Cambio de simbología de capas ráster

La simbología de capas ráster es algo diferente.

  • Abre el cuadro de diálogo Propiedades para el ráster Precipitación.

  • Cambia a la pestaña Estilo. Observarás que este cuadro de diálogo es muy diferente a la versión utilizada para capas vectoriales.

  • Asegúrate de que el botón Media +/- desviación estándar está seleccionado.

  • Cambia el valor en la casilla asociada a 2.00 (debería estar ajustada a 1.00 por defecto).

  • En el título Mejora de contraste, cambia el valor del menú desplegable a Estirar a MinMax.

  • Haz clic en Aceptar. El ráster “Precipitación”, si está visible, debería cambiar de colores, permitiendote ver diferentes valores de brillo para cada píxel.

  • Repite este proceso para el MDE, pero ajusta las desviaciones estándar utilizadas a 4.00.

9.4.7. Cambio de orden de capas

  • En Lista de capas, haz clic y arrastra las capas hacia arriba o abajo para cambiar el orden en el que aparecen en el mapa.

  • Nuevas versiones de QGIS puede que tengan una casilla de verificación Control del orden de renderizado bajo la Lista de capas. Asegúrate de que está marcada.

Ahora que todos los datos están cargados y son adecuadamente visibles, el análisis puede comenzar. Es mejor si las operaciones de recorte se hacen primero. Así no se malgasta potencia procesando áreas que no serían utilizadas de todas formas.

9.4.8. Encuentra los Distritos Correctos

  • Carga la capa vectorial admin_boundaries/Western_Cape_UTM33S.shp en tu mapa.

  • Renómbrala como Districts.

  • Haz clic derecho en la capa Districts en la Lista de capas.

  • En el menú que aparece, selecciona el elemento del menú Filtrar.... El cuadro de diálogo Constructor de Consultas aparecerá.

Ahora construirás una consulta para seleccionar solo la siguiente lista de distritos:

  • Bellville,
  • Cape,
  • Goodwood,
  • Kuils River,
  • Mitchells Plain,
  • Simons Town, y

  • Wynberg.
  • En la lista Campos, haz doble clic en el campo NAME_2. Aparece en el campo de texto inferior Expresión de filtrado específica del proveedor.

  • Haz clic en el botón =; un signo = se añadirá a la consulta SQL.

  • Haz clic en el botón Todos bajo la lista Values (actualmente vacío). Después de una corta espera, se rellenará la lista Values con los valores del campo seleccionado (NAME_2).

  • Haz doble clic en el valor Bellville en la lista Values. Como antes, será añadido a la consulta SQL.

Para seleccionar más de un distrito, necesitarás utilizar el operador booleano O.

  • Haz clic en el botón O y será añadido a la consulta SQL.

  • Utilizando un proceso similar al anterior, añade lo siguiente a la consulta existente SQL:

    "NAME_2" = 'Cape'
    
  • Añade otro operador O, luego trabaja con la lista de distritos anterior de forma similar.

  • La consulta final debería ser

    "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
    "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
    'Simons Town' OR "NAME_2" = 'Wynberg'
  • Haz clic en Aceptar. Los distritos mostrados en tu mapa están limitados a los de la lista anterior.

9.4.9. Recorta los Ráster

Ahora que tienes un área de interés, puedes recortar los ráster a esa área.

  • Asegúrate de que las únicas capas visibles son las de MDE, Rainfall y Districts.

  • Los Districts deben estar en primer lugar para ser visibles.

  • Abre el cuadro de diálogo para recortar seleccionando el elemento del menú Ráster ‣ Extracción ‣ Clipper.

  • En la lista del menú desplegable Archivo de entrada (ráster), selecciona la capa MDE.

  • Especifica una localización de salida en el campo de texto Archivo de salida clicando en el botón Seleccionar....

  • Navega hasta el directorio Rasterprac.

  • Introduce un nombre de archivo.

  • Guarda el archivo. Deja la casilla de verificación Valor de sin datos vacía.

  • Utiliza el modo de corte Extensión asegurándote que el botón radial correcto está seleccionado.

  • Haz clic y arrastra un área en el mapa, de modo que el área que incluye los distritos esté seleccionada.

  • Marca la casilla Cargar en la vista del mapa cuando se termine.

  • Haz clic en Aceptar.

  • Cuando la operación de corte se complete, NO CIERRES el cuadro de diálogo Clipper. (Cerrarlo te haría perder el área a cortar que ya habías definido)

  • Selecciona el ráster Precipitación en el menú desplegable Archivo de entrada (ráster) y elige un nombre de archivo de salida diferente.

  • No cambies ninguna otra opción. No alteres el área a cortar que has dibujado antes. Déjalo todo como estaba y haz clic en Aceptar.

  • Después de que la segunda operación de corte haya terminado, puedes cerrar el cuadro de diálogo Clipper.

  • Guarda el mapa.

9.4.10. Limpia el mapa

  • Borra las capas originales Precipitación y MDE de la Lista de capas.

  • Haz clic derecho en esas capas y selecciona Eliminar.

    • Esto no borrará los datos de tu dispositivo de almacenamiento, solamente lo quitará de tu mapa.

  • Desactiva las etiquetas de la capa Streets.

    • Haz clic en el botón Etiquetado.

    • Quita la marca de la casilla Etiquetar esta capa con.

    • Haz clic en Aceptar.

  • Muestra todas las Streets de nuevo:

    • Haz clic derecho en la capa en la Lista de capas.

    • Selecciona Filtrar.

  • En el cuadro de diálogo que aparece, haz clic en el botón Limpiar, luego haz clic en Aceptar.

  • Espera mientras se cargan los datos. Todas las calles serán visibles ahora.

  • Cambia la simbología del ráster como antes (ver Cambio de simbología de capas ráster).

  • Guarda el mapa.

  • Ahora puedes ocultar las capas vectoriales quitando la marca de la casilla junto a ellas en la Lista de capas. Esto hará que el mapa se dibuje más rápido y te ahorrará tiempo.

Para crear el sombreado de relieve, necesitarás utilizar un complemento que fue escrito para tal propósito.

9.4.11. Activa el plugin Análisis del terreno ráster.

Este complemento está incluido por defecto desde QGIS 1.8. Sin embargo, puede que no sea inmediatamente visible. Para comprobar si es accesible en tu sistema:

  • Click on the menu item Plugins ‣ Manage Plugins....
  • Asegúrate que la casilla junto a Complemento de análisis del terreno ráster está seleccionada.

  • Haz clic en Aceptar.

Ahora tendrás acceso al complementoa través del elemento del menú Ráster ‣ Análisis de terreno.

Recuerda que los plugins puede que dependan a veces de que ciertos módulos Python estén instalados en tu sistema. Un plugin podría rechazar trabajar por falta de dependencias, pregunta a tu tutor para que te asista.

9.4.12. Crear el sombreado del relieve

  • En la Lista de capas, asegúrate que MDE es la capa activa (es decir, es la seleccionada por haber clicado en ella).

  • Haz clic en el elemento del menú Ráster ‣ Análisis de terreno ‣ Mapa de sombras (Hillshade) para abrir el cuadro de diálogo Mapa de sombras (Hillshade).

  • Especifica una localización apropiada para la capa de salida y nómbrala hillshade.

  • Selecciona la casilla Añadir resultados al proyecto.

  • Haz clic en Aceptar.

  • Espera a que termine de procesar.

La nueva capa hillshade a aparecido en tu Lista de capas.

  • Haz clic derecho en la capa hillshade en tu Lista de capas y abre el cuadro de diálogo Propiedades.

  • Haz clic en la pestaña Transparencia y ajusta el control de transparencia a 80%.

  • Haz clic en Aceptar en el cuadro de diálogo.

  • Observa el efecto cuando el sombreado de relieve transparente se sobre impone sobre el MDE recortado.

9.4.13. Pendiente

  • Haz clic en el elemento del menú Ráster ‣ Análisis de terreno.

  • Selecciona el tipo de análisis Pendiente, con el MDE acortado como la capa de entrada.

  • Especifica un nombre de archivo y localización apropiados para propósitos de salida.

  • Selecciona la casilla Añadir resultados al proyecto.

  • Haz clic en Aceptar.

La imagen pendiente ha sido calculada y añadida al mapa. Sin embargo, como siempre, solo es un rectángulo gris. Para ver adecuadamente qué está pasando, cambia la simbología como sigue.

  • Abre el cuadro de diálogo Propiedades de la capa (como siempre, con el menú de clic derecho en la capa).

  • Haz clic en la pestaña Estilo.

  • Donde dice Unibanda gris (en el menú desplegable Tipo de renderizador), cámbialo a Unibanda pseudocolor.

  • Asegúrate de que el botón radial Media +/- desviación estándard está seleccionado.

9.4.14. Orientación

  • Utiliza el mismo enfoque que para calcular la pendiente, pero selecciona Orientación en el cuadro de diálogo inicial.

Recuerda guardar el mapa periódicamente.

9.4.15. Reclasificar rásters

  • Haz clic en el elemento del menú Ráster ‣ Calculadora ráster....

  • Especifica tu directorio Rasterprac como localización para la capa de salida.

  • Asegúrate de que la casilla Añadir resultados al proyecto está seleccionada.

En la lista de la izquierda Bandas ráster, verás todas las capas ráster de tu Lista de capas. Si tu capa de Pendiente se llama slope, se listará como slope@1.

La pendiente necesita estar entre 15 y 60 grados. Cualquier cosa por debajo de 15 o encima de 60 debe estar excluida.

  • Utiliando la lista de elementos y botones en la interfaz, construye la siguiente expresión:

    (([email protected] < 15) OR ([email protected] > 60)) = 0
  • Ajusta el campo Capa de salida a un nombre y localización adecuados.

  • Haz clic en Aceptar.

Ahora encuentra la orientación correcta (orientado al este, entre 45 y 135 grados) utilizando el mismo enfoque.

Habiendo reclasificado todos los ráster, ahora los verás representados como rectángulos grises en tu mapa (asumiendo que se han añadido correctamente al mapa). Para representar los datos ráster correctamente en dos clases (1 y 0, significando verdadero o falso), necesitarás cambiar su simbología.

9.4.16. Ajuste del estilo para capas reclasificadas

  • Abre la pestaña Estilo en el cuadro de diálogo Propiedades de la capa como siempre.

  • Bajo el título Cargar valores min / max, selecciona el botón radial Real (más lento).

  • Haz clic en el botón Cargar.

Los campos valores Min / Max deberían estar ahora rellenos con 0 y 1, respectivamente. (Si no lo están, ha habido un error con la reclasificación de tus datos, y necesitarás volver a esa parte.)

  • En el título Mejora de contraste, ajusta la lista del menú desplegable Sin realce a Estirar a MinMax.

  • Haz clic en Aceptar.

  • Hazlo para los tres ráster reclasificados, ¡y recuerda guardar tu trabajo!

El único criterio que queda es que el área debe estar a 250m de las áreas urbanas. Satisfaremos este requisito asegurándonos que las áreas que computamos están a 250m o más de los bordes de las zonas rurales. Por lo tanto, necesitamos encontrar todas las áreas rurales primero.

9.4.17. Encontrar áreas rurales

  • Oculta todas las capas de la Lista de capas.

  • Haz visible la capa vectorial Zoning.

  • Haz clic derecho en ella y abre el cuadro de diálogo Filtrar.

  • Construye la siguiente consulta:

    "Gen_Zoning" = 'Rural'
    

    Mira antes las instrucciones para construir la consulta ara la capa Streets si te quedas atascado.

  • Cuando hayas terminado, cierra el cuadro de diálogo Constructor de consultas.

Deberías ver una colección de polígonos de la capa Zoning. Necesitarás guardarlos en un nuevo archivo de capa.

  • En el menú de clic derecho en Zoning, selecciona Guardar como....

  • Guarda tu capa en el directorio Zoning.

  • Nombra al archivo de salida rural.shp.

  • Haz clic en Aceptar.

  • Añade la capa a tu mapa.

  • Haz clic en el elemento del menú Vectorial ‣ Herramientas de geoproceso ‣ Disolver.

  • Selecciona la capa rural como tu capa vectorial de entrada, mientras dejas la casilla Usar sólo objetos espaciales seleccionados sin marcar.

  • En Campo para disolver, selecciona — Disolver todo —.

  • Guarda tu capa en el directorio Zoning.

  • Haz clic en Aceptar. Un cuadro de diálogo aparecerá preguntando si quieres añadir la capa nueva al TDC (“Tabla De Contenidos”, refiriéndose a la:guilabel:Lista de capas).

  • Haz clic en .

  • Cierra el cuadro de diálogo Disolver.

  • Borra las capas rural y Zoning.

  • Guarda el mapa.

Ahora necesitas excluir las áreas que estan a 250m del borde de las áreas rurales. Hazlo creando un buffer negativo, como está explicado más abajo.

9.4.18. Crear un buffer negativo

  • Haz clic en el elemento del menú Vectorial ‣ herramientas de geoproceso ‣ Buffer(s).

  • En el cuadro de diálogo que aparece, selecciona la capa rural_dissolve como tu capa vectorial de entrada (Usar sólo objetos espaciales seleccionados no debería estar seleccionado).

  • Selecciona el botón Distancia de buffer e introduce el valor -250 en el campo asociado; el valor negativo significa que el buffer debe ser un buffer interno.

  • Selecciona la casilla Disolver resultados de buffer.

  • Ajusta el archivo de salida al mismo directorio que los otros archivos vectoriales rurales.

  • Nombra al archivo de salida rural_buffer.shp.

  • Haz clic en Guardar.

  • Haz clic en Aceptar y espera a que se complete el proceso.

  • Selecciona en el cuadro de diálogo que aparece.

  • Cierra el cuadro de diálogo Buffer.

  • Borra la capa rural_dissolve.

  • Guarda el mapa.

Para incorporar las zonas rurales al mismo análisis con los tres ráster existentes, será necesario rasterizarlo. Pero para que los ráster sean compatibles para el análisis, necesitarán tener el mismo tamaño. Además, antes de rasterizar, necesitarás recortar el vector a la misma área que los ráster. Un vector solo puede ser recortado por otro vector, así que primero necesitaras crear un polígono de encuadre del mismo tamaño que los ráster.

9.4.19. Crear un encuadre vectorial

  • Click on the menu item Layer ‣ New ‣ New Shapefile Layer....
  • En el título Tipo, selecciona el botón Poligono.

  • Haz clic en Especificar SRC y ajusta el sistema de coordenadas de referencia a WGS 84 / UTM zone 33S : EPSG:32733.

  • Haz clic en Aceptar.

  • Haz clic en Aceptar en el cuadro de diálogo Nueva capa vectorial.

  • Guarda el vector en el directorio Zoning.

  • Nombra al archivo de salida bbox.shp.

  • Oculta todas las capas excepto la nueva capa bbox y uno de los ráster reclasificados.

  • Asegúrate de que la capa bbox está seleccionada en la Lista de capas.

  • Navega hasta el elemento del menú Ver ‣ Barras de herramientas y asegúrate de que Digitalización está seleccionado. Deberías ver en una barra de herramientas el icono de un lápiz o un koki. Es el botón Conmutar edición.

  • Haz clic en el botón Conmutar edición para entrar al modo edición. Esto te permite editar una capa vectorial.

  • Haz clic en el botón Añadir objeto espacial, que debería estar cerca del botón Conmutar edición. Puede que esté oculto tras un botón de flechas dobles; si lo está, haz clic en las flechas dobles para mostrar los botones ocultos de la barra de herramientas Digitalización.

  • Con la herramienta Añadir objeto espacial activada, haz clic izquierdo en las esquinas del ráster. Puede que necesites ampliar el zum con la rueda del ratón para asegurarte que es exacto. Para desplazarte sobre el mapa en este modo, haz clic y arrastra el mapa con el boton central o la rueda del ratón.

  • Para el cuarto y último punto, haz clic derecho para finalizar la forma.

  • Introduce un número arbitrario para la forma ID.

  • Haz clic en Aceptar.

  • Haz clic en el botón Guardar cambios.

  • Haz clic en el botón Conmutar edición para terminar tu sesión de edición.

  • Guarda el mapa.

Ahora que tienes un cuadro delimitador, puedes utilizarlo para recortar la capa rural buffer.

9.4.20. Recortar una capa vectorial

  • Asegúrate de que solo son visibles las capas bbox y rural_buffer, con el último por encima.

  • Haz clic en el elemento del menú Vectorial ‣ Herramientas de geoproceso > Cortar.

  • En el cuadro de diálogo que aparece, ajusta la capa vectorial de entrada a rural_buffer y la capa para cortar a bbox, con ambas casillas usar sólo objetos espaciales seleccionados sin marcar.

  • Pon el archivo de salida en el directorio Zoning.

  • Nombra al archivo de salida rural_clipped.

  • Haz clic en Aceptar.

  • Cuando se requiera añadir la capa al TDC, haz clic en .

  • Cierra el cuadro de diálogo.

  • Compara los tres vectores y ve los resultados por ti mismo.

  • Borra las capas bbox y rural_buffer, luego guarda tu mapa.

Ahora ya está lista para ser rasterizada.

9.4.21. Rasterizar una capa vectorial

Necesitarás especificar un tamaño de píxel para un nuevo ráster que crees, así que primero necesitarás saber el tamaño de uno de los ráster existentes.

  • Abre el cuadro de diálogo Propiedades de cualquiera de los tres ráster existentes.

  • Cambia a la pestaña Metadatos.

  • Anota los valores de X e Y en el título Dimensiones de la tabla de Metadatos.

  • Cierra el cuadro de diálogo Propiedades.

  • Haz clic en el elemento del menú Ráster ‣ Conversión ‣ Rasterizar. Puede que recibas una alerta sobre conjunto de datos no soportado. Haz clic de todos modos he ignoralo.

  • Selecciona rural_clipped como tu capa de entrada.

  • Ajusta la localización de archivo de salida dentro del directorio Zoning.

  • Nombra al archivo de salida rural_raster.tif.

  • Marca la casilla Tamaño del ráster en píxeles y introduce los valores de Anchura y Altura que apuntaste antes.

  • Marca la casilla Cargar en la vista del mapa cuando se termine.

  • Haz clic en el icono del lápiz junto al campo de texto que muestra los comandos que se van a ejecutar. Al final del texto existente, añade un espacio y luego el texto -burn 1. Esto le dice a la función de Rasterizar que “queme” el vector existente al nuevo ráster y dé a las áreas cubiertas por el vector el nuevo valor 1 (opuestamente al resto de la imagen, que cambiará automáticamente a 0).

  • Haz clic en Aceptar.

  • El nuevo ráster se debería mostrar en tu mapa una vez se ha computado.

  • El nuevo ráster se verá como un rectángulo gris - puedes cambiar el estilo de la presentación como hiciste para reclasificar ráster.

  • Guarda tu mapa.

Ahora que tienes los cuatro criterios en ráster separados, necesitas combinarlos para ver qué áreas satisfacen todos los criterios. Para hacerlo, los ráster se multiplicarán entre ellos. Cuando esto ocurra, todos los píxeles superpuestos con un valor de 1 conservarán el valor 1, pero si un pixel tiene el valor 0 en alguno de los cuatro ráster, el resultado será 0. De esta forma, el resultado contendrá solo las áreas superpuestas con valor 1.

9.4.22. Combinación de rásters

  • Haz clic en el elemento del menú Ráster ‣ Calculadora ráster....

  • Construye la siguiente expresión (con los nombres apropiados para tus capas, dependiendo de cómo las llamaste)

    [Rural raster] * [Reclassified aspect] * [Reclassified slope] *
    [Reclassified rainfall]
  • Ajusta la localización de salida al directorio Rasterprac.

  • Llama al ráster de salida cross_product.tif.

  • Asegúrate de que la casilla Añadir resultados al proyecto está marcada.

  • Haz clic en Aceptar.

  • Cambia la simbología del nuevo ráster del mismo modo que ajustaste el estilo para los otros rásters reclasificados. El nuevo ráster ahora representa adecuadamente las áreas donde todos los criterios se satisfacen.

Para obtener el resultado final, necesitas seleccionar las áreas que son mayores de 6000m^2. Sin embargo, computar esas áreas exactamente solo es posible con una capa vectorial, así que necesitarás vectorizar el ráster.

9.4.23. Vectorizar el ráster

  • Haz clic en el elemento del menú Ráster ‣ Conversión ‣ Poligonizar.

  • Selecciona el ráster cross_product.

  • Ajusta la localización de salida a Rasterprac.

  • Llama al archivo candidate_areas.shp.

  • Asegúrate de que Cargar en la vista del mapa cuando se termine está marcado.

  • Haz clic en Aceptar.

  • Cierra el cuadro de diálogo cuando el proceso esté completo.

Todas las áreas del ráster se han vectorizado, así que necesitas seleccionar solo las áreas que tienen el valor 1.

  • Abre el cuadro de diálogo Query para el vector nuevo.

  • Construye esta consulta:

    "DN" = 1
    
  • Haz clic en Aceptar.

  • Crea un archivo vectorial nuevo a partir del resultado guardando el vector candidate_areas después de que se complete la consulta (y solo las áreas con un valor 1 sean visibles). Utiliza la función Guardar como... en el menú de la capa con clic derecho en ella.

  • Guarda el archivo en el directorio Rasterprac.

  • Nombra al archivo candidate_areas_only.shp.

  • Guarda tu mapa.

9.4.24. Cálgulo del área para cada polígono

  • Abre el menú de la nueva capa vectorial con clic derecho.

  • Seleccióna Abrir tabla de atributos.

  • Haz clic en el botón Conmutar el modo edición en la parte inferior de la tabla, o pulsa Ctrl+E.

  • Haz clic en el botón Abrir calculadora de campos en la parte inferior de la tabla, o pulsa Ctrl+M.

  • En el título del cuadro de diálogo que aparece, introduce el nombre de campo area. El tipo de campo de salida debería ser entero, y el ancho del campo debería ser 10.

  • Em tipo Expressão calculadora de campo:

    $area

    Esto significa que la calculadora de campo calculará el área de cada polígono en la capa vectorial y creará una columna nueva (llamada area) con el valor calculado.

  • Haz clic en Aceptar.

  • Faça a mesma coisa para um outro novo campo chamado id. Em tipo Expressão calculadora de campo:

    $id

    Eso asegura que cada polígono tiene una ID única para su identificación.

  • Haz clic de nuevo en Conmutar el modo edición, y guarda tus ediciones si es requerido.

9.4.25. Selección de áreas para un tamaño dado

Ahora que las áreas son conocidas:

  • Construye una consulta (como siempre) para seleccionar solo los polígonos más grandes de 6000m^2. La consulta es:

    "area" > 6000
    
  • Guarda la seleción como una nueva capa vectorial llamada solution.shp.

Ahora tienes tus áreas para tu solución, de las que tendrás que elegir la más proxima a tu casa.

9.4.26. Digitaliza tu casa

  • Crea una nueva capa vectorial como antes, pero esta vez, selecciona el valor Tipo como Punto.

  • ¡Asegúrate de que es el SRC correcto!

  • Nombra a la nueva capa house.shp.

  • Acaba de crear la nueva capa.

  • Entra en el modo de edición (mientras la capa nueva está seleccionada).

  • Haz clic en el punto donde tu casa o otra residencia actual esté, utilizando las calles como guía. Puede que tengas que abrir otras capas para ayudarte a encontrar tu casa. Si no vives cerca, haz clic en algún lugar donde una casa podría ser concebible.

  • Introduce un número arbitrario para la forma ID.

  • Haz clic en Aceptar.

  • Guarda tu edición y sal del modo de edición.

  • Guarda el mapa.

Necesitarás encontrar los centroides (“centros de masa”) para los polígonos solución para decidir cual está más cerca de tu casa.

9.4.27. Calcula los centroides de los polígonos

  • Haz clic en el elemento del menú Vectorial ‣ Herramientas de geometría ‣ Centroides de polígonos.

  • Especifica la capa de entrada como solution.shp.

  • Proporciona la localización de salida como Rasterprac.

  • Llama al archivo de destino solution_centroids.shp.

  • Haz clic en Aceptar y añade el resultado al TDC (Lista de capas), luego cierra el cuadro de diálogo.

  • Arrastra la nueva capa al principio de la lista para poder verla.

9.4.28. Calcula qué centroide está más cerca de tu casa

  • Click on the menu item Vector ‣ Analysis Tools ‣ Distance matrix.
  • La capa de entrada debería ser tu casa, y la capa de destino solution_centroids. Ambas capas deberían utilizar el campo id como su único campo de ID.

  • El tipo de matriz de salida debería ser lineal.

  • Ajusta una localización y nombre adecuadas para la salida.

  • Haz clic en Aceptar.

  • Abre el archivo en un editor de textos (o importalo a nuna hoja de cálculo). Observa qué ID está asociada con la Distance más corta. Puede que haya más de una con la misma distancia.

  • Construye una consulta en QGIS para seleccionar solo las áreas solución más cercanas a tu casa (seleccionala utilizando id field).

Esta es la respuesta final a la pregunta investigada.

Para tu presentación, incluye la capa semi transparente del relieve sombreado encima del ráster de tu elección (como MDE o slope raster, por ejemplo). Incluye también el polígono del área(s) solución más cercano, así como tu casa. Sigue las mejores prácticas de cartografía para crear tu mapa de salida.