Ferramentas Gerais

Atalhos de teclado

QGIS provides default keyboard shortcuts for many features. You find them in Section Barra de Menu. Additionally the menu option Settings ‣ Configure Shortcuts allows to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

A configuração é muito simples. Basta selecionar uma função da lista e clicar em [Mudar], [Desmarcar] ** ou ** [Marcar como padrão]. Depois de ter encontrado sua configuração, você pode salvar como um arquivo XML e carregá-la em outra instalação do QGIS.

Conteúdo da ajuda

Quando precisar de ajuda sobre um tópico específico, você pode acessar a contúdo da ajuda através do: guilabel: Botão ‘Ajuda’ disponível na maioria dos diálogos - observe que complementos de terceiros podem apontar para páginas web dedicadas.

Renderização

Por padrão, o QGIS torna todas as camadas visíveis sempre que a tela do mapa for atualizada. Os eventos que desencadeiam uma atualização da tela do mapa incluem:

  • Adicionar uma camada

  • Pan ou zoom

  • Redimensionar a janela do QGIS

  • Mudanças na visibilidade de uma camada ou camadas

QGIS permite controlar o processo de renderização de várias formas.

Escala dependente da renderização

Renderização dependente da escala permite que você especifique as escalas mínimas e máxima em que uma camada será visível. Para definir dependência de escala de renderização, abra o: guilabel: diálogo Propriedades clicando duas vezes sobre a camada na legenda. Na: guilabel: na guia Geral, defina os valores de escala mínimo e máximo e clique na checkbox: guilabel: caixa de seleção Utilize renderização de escala dependente.

Você pode determinar os valores de escala na primeira ampliação para o nível que você deseja usar e observando o valor de escala na barra de status do QGIS.

Controlando a renderização do mapa

A renderização do mapa pode ser controlada por vários caminhos:

Suspending Rendering

Para suspender a rendirização, clique o checkbox :guilabel: caixa de seleção Renderizar no canto direito inferior da barra de status. Quando a checkbox :guilabel: caixa de seleção Renderizar não estiver marcada, QGIS não redesenhará a tela em resposta a qualquer evento descrito na Seção: ref:redraw_events. Exemplos de quando você pode querer suspender a renderização incluem:

  • Adicionar muitas camadas e simbolizá-las antes de desenhar

  • Adicionar uma ou mais camadas grandes e definir a dependência de escala antes de desenhar

  • Adicionar uma ou mais camadas e ampliar para uma visualização especifica antes de desenhar

  • Qualquer combinação dos anteriores

Caixa de seleção checkbox :guilabel: caixa de seleção Renderizar permite renderização e causa uma atualização imediata na tela do mapa.

Setting Layer Add Option

Você pode definir uma opção para sempre carregar novas camadas sem desenhá-las. Isto significa que a camada será adicionada ao mapa, mas a sua caixa visibilidade na legenda será desmarcada por padrão. Para definir esta opção, escolha a opção do menu :menuselection : Configurações -> Opções -> e clique na: guilabel: Guia Renderização. Desmarque a checkbox: guilabel: caixa de seleção Por padrão novas camadas adicionadas ao mapa podem ser mostradas. Qualquer camada adicionada ao mapa será desligada (invisível) por padrão.

Parar rendirização

To stop the map drawing, press the ESC key. This will halt the refresh of the map canvas and leave the map partially drawn. It may take a bit of time between pressing ESC and the time the map drawing is halted.

Nota

No momento não é possível parar de renderização - ela foi desativada na porta qt4 por causa de problemas e falhas na interface do usuário (UI).

Updating the Map Display During Rendering

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings ‣ Options click on the Rendering tab. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

Influence Rendering Quality

To influence the rendering quality of the map you have 2 options. Choose menu option Settings ‣ Options click on the Rendering tab and select or deselect following checkboxes.

  • checkbox Fazer linhas aparecem com menos definição para não peder performance ao renderizar

  • checkbox Ajustar problemas com polígonos preenchidos incorretamente

Medição

Medindo obras nos sistemas de coordenadas projetadas (por exemplo, UTM) e dados não projetados. Se o mapa carregado é definido com um sistema de coordenadas geográficas (latitude / longitude), os resultados da linha ou a medição da área será incorreta. Para corrigir isso, você precisa definir um sistema de coordenadas adequado ao mapa (ver secção: ref: label_projections). Todos os módulos de medição também usam as configurações de encaixe do módulo de digitalização. Isso é útil se você quiser medir ao longo de linhas ou áreas em camadas vetoriais.

Para selecionar uma ferramenta clique medida em mActionMeasure e selecione a ferramenta que deseja usar.

Medição de linha, áreas ou ângulos

mActionMeasure QGIS is able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings ‣ Options, click on the Map tools tab and choose the appropriate ellipsoid. There you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon). The tools then allows you to click points on the map. Each segment-length as well as the total shows up in the measure-window. To stop measuring click your right mouse button.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Areas can also be measured. In the measure window the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section Definir o valor de tolerância de proximidade para buscar apartir do raio). So if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle Você também pode medir ângulos, selecionando a ferramenta Medida de Ângulo. O cursor se transforma em forma de cruz. Clique para desenhar o primeiro segmento do ângulo que você deseja medir, em seguida, mover o cursor para desenhar o ângulo desejado. A medida é exibido em uma caixa de diálogo pop-up.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

Selecionar e desselecionar feições

A barra de ferramentas do QGIS fornece várias ferramentas para selecionar as feições na tela do mapa. Para selecionar uma ou mais feições basta clicar sobre | mActionSelect| e selecionar a ferramenta:

  • mActionSelect Select single feature
  • mActionSelectRectangle Feições através de retangulo

  • mActionSelectPolygon Feições através de poligono

  • mActionSelectFreehand Feições através de traço livre

  • mActionSelectRadius Feição através de raio

To deselect all selected features click on mActionDeselectAll Deselect features from all layers.

Decorações

As Decorações do QGIS incluem o Rótulo Copyright (direitos autorais), a Seta Norte e a Barra de Escala. Elas são usadas para ‘decorar’ o mapa adicionando os elementos cartográficos.

Nota

Antes da versão 1.8 do QGIS a mesma funcionalidade era fornecida pelo Complemento Decoração.

Seta Norte

north_arrow North Arrow places a simple north arrow on the map canvas. At present there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow you have four options, corresponding to the four corners of the map canvas.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Barra de Escala

scale_bar Scale Bar adds a simple scale bar to the map canvas. You control the style and placement, as well as the labeling of the bar.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS suporta apenas exibir a escala nas mesmas unidades de seu mapa do quadro. Então, se as unidades de suas camadas estão em metros, você não pode criar uma barra de escala em pés. Da mesma forma, se você estiver usando graus decimais, você não pode criar uma barra de escala para mostrar a distância em metros.

Para adicionar uma barra de escala:

  1. Selecione através do menu: menuselection:Exibir –> Decorações –> Barra de Escala abrirá o diálogo (ver figure_decorations_3)

  2. Escolha a posição do: guilabel: Posição lista suspensa ‘Inferior Esquerda’

  3. Escolha o estilo através do: guilabel:estilo de barra de escala lista ‘Marque abaixo’

  4. Selecione a cor para a barra: guilabel:Cor da barra‘preta’ ou use a cor preta padrão

  5. Defina o tamanho da barra e seu rótulo: guilabel: Tamanho da bar‘30 graus’

  6. Verifique se a checkbox: guilabel: caixa de seleção ‘Ativar barra de escala` está marcada

  7. Opcionalmente escolha para ajustar automaticamente a um número redondo quando a tela é redimensionada checkbox: guilabel: se encaixam automaticamente para arredondar o número em redimensionar

  8. Clique [OK]

Dica

Settings of Decorations

Quando você salva um projeto .qgs, todas as alterações que tenham sido feitas para Seta Norte, barra de escala e Rótulo de Copyright serão salvas no projeto e restauradas na próxima vez que você carregar o projeto.

Ferramentas de anotação

The mActionTextAnnotation Text Annotation tools in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Double click on the item opens a dialog with various options. There is the text editor to enter the formatted text and other item settings. E.g. there is the choice of having the item placed on a map position (displayed by a marker symbol) or to have the item on a screen position (not related to the map). The item can be moved by map position (drag the map marker) or by moving only the balloon. The icons are part of GIS theme, and are used by default in the other themes too.

The mActionAnnotation Move Annotation tool allows to move the annotation on the map canvas.

Anotação de formulário

Additionally you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized qt designer form (see figure_custom_annotation). It is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see QGIS blog http://blog.qgis.org/node/143 for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Nota

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

Favoritos Espaciais

Favoritos espaciais permite que você “marque” uma localização geográfica e volte a ela mais tarde.

Novo Favorito

Para criar um novo favorito:

  1. Zoom ou pan na área de interesse.

  2. Select the menu option View ‣ New Bookmark or press Ctrl-B.
  3. Adicione um nome descritivo para o favorito (no máximo 255 caracteres).

  4. Press Enter to add the bookmark or [Delete] to remove the bookmark.

Note que você pode ter vários favoritos com o mesmo nome.

Trabalhando com favoritos

To use or manage bookmarks, select the menu option View ‣ Show Bookmarks. The Geospatial Bookmarks dialog allows you to zoom to or delete a bookmark. You can not edit the bookmark name or coordinates.

Aproximar para um favorito

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

Deletando um favorito

Para excluir um favorito da: guilabel: diálogo Favoritos Geoespaciais, clique sobre ele e depois em [Excluir]. Confirme sua escolha clicando [OK] ou cancelar a exclusão clicando [Cancelar].

Projetos animados

If you want to embed content from other project files into your project you can choose Layer ‣ Embed Layers and Groups.

Incorporando camadas

A seguinte aba permite incorporar camadas de outros projetos:

  1. Pressione browsebutton para olhar para outro projeto do conjunto de dados Alasca.

  2. Selecione o arquivo de projeto grassland. Você pode ver o conteúdo do projeto (ver figure_embed_dialog).

  3. Press Ctrl and klick on the layers grassland and regions. The layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Enquanto as camadas incorporadas estão editáveis ​​que você não pode alterar suas propriedades como estilo e rotulagem.

Removing embedded layers

Right-click on the embedded layer and choose mActionRemoveLayer Remove .